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GETTING STARTED 

CuteFTP is easy enough for a novice FTP user, yet powerful enough for experienced users. CuteFTP 
provides a variety of features to enhance file transfer: 

 The user-friendly interface allows you to easily update and maintain sophisticated Web sites.  

 You can speed the transfer of large architectural, graphic, or engineering files with multi-part 
accelerated downloads.  

 Site caching allows you to minimize bandwidth while you browse.  

 An integrated HTML editor allows you to create, open, and edit HTML documents on your 
computer or a remote server within CuteFTP. 

If you downloaded CuteFTP as a trial and are considering whether to purchase CuteFTP Home or 
CuteFTP Professional, visit our Web site for a comparison of the two products and for information on 
purchasing and upgrading. 

INSTALLING AND REMOVING THE SOFTWARE 

System Requirements 

 Windows 2000, Windows XP, Windows Server 2003, Windows Server 2008, or Windows Vista.  

 An Internet connection  

 Microsoft Internet Explorer 5.5 or higher 

To install CuteFTP on your computer 

1. Do one of the following: 

 Download and save CuteFTP from http://www.globalscape.com/downloads/, then double-
click the executable to run the installer. 

 Place the installation CD in your DVD/CD-ROM drive. Installation should begin 
automatically. If your DVD/CD-ROM drive does not support automatic installation: 

a. Double-click My Computer located on the desktop.  

b. Double-click the DVD/CD-ROM drive icon.  

c. Double-click the Setup.exe icon. 

2. Follow the wizard instructions.  

You are offered the following installation options: 

 Typical - All available options are installed. 

 Compact - If you choose the Compact installation option, the following options are not 
installed: 

o Site Importer 

o Documentation 

 Custom - You can decide which options to install. 

To remove CuteFTP from your computer 

1. Click Start > Settings > Control Panel, then click Add/Remove Programs. 

http://www.globalscape.com/products/compare_clients.aspx
http://www.globalscape.com/downloads/


 

10 ● Upgrading CuteFTP  

2. Click CuteFTP Home. 

3. Click Add/Remove. 

4. Follow the wizard instructions. You are offered the option of retaining your site configuration and 
logs, in case you are reinstalling or moving the application to a different computer. 

For information about installing CuteFTP on Windows Vista, see Knowledge Base article #10278 on the 
GlobalSCAPE support pages. 

UPGRADING CUTEFTP 

The CuteFTP installer makes an upgrade intuitive, so long as it’s the same major version and same 
product type. As long as you are upgrading within the same product type (Home/Pro/Lite) and same 
major version (CuteFTP 8), then the regular installer will automatically upgrade the existing installation 
using all of the existing file locations and settings. 

If you upgrade from one major version to another (CuteFTP 7 to CuteFTP 8) or from one product type to 
another (Lite to Home, Home to Pro, Lite to Pro) then CuteFTP installs as a new application. This means 
that if you do not want your old CuteFTP installation, you will need to uninstall it. The "upgrade" will not 
uninstall it. 

As a precaution, you should backup your old application files and settings files before doing an upgrade, 
just in case you want to go back to your previous version. 

ACTIVATING CUTEFTP 

CuteFTP must be activated within 30 days or it will no longer function. When prompted, provide the serial 
number you received when you purchased the product. You can use either your first and last name or 
your company name. After you have provided the information, you can view your activation information on 
the main menu by clicking Help > About CuteFTP. 

To ensure your software is activated accurately, provide all of the optional details that are requested so 
that we can confirm your eligibility for technical support or any upgrades that may become available in the 
future. 

 

Your serial number can be found on the invoice you received by email or on your product packing if you 
obtained a boxed version. If you have lost your serial number, you can request a copy using GlobalSCAPE's Lost 

Serial Number form. Customer Support can locate your serial number if you provide your name, address, 
order ID, or any other pertinent data that might help us locate your original purchase record. 
 
When you enter your registration information, it will be transmitted to GlobalSCAPE via the Internet. As part of 
the registration, the software assigns a unique number to your computer based on system information and 
reports this number to us. We use this data to help us prevent the program from being copied onto more 
computers than permitted by the license.  

To register successfully, you must be connected to the Internet and have administrator privileges on your 
computer. If a firewall or proxy server is in use, the network administrator should ensure port 80 is open 
during the registration process. 

To activate CuteFTP 

1. On the Welcome screen, click Enter Serial Number or, on the main menu, click Help > Enter a 
serial number. The Registration wizard appears. 

2. In the Serial Number box, provide the serial number, then click Next. 

3. Provide your name, email address, company name, and other details, then click Next. 

http://kb.globalscape.com/article.aspx?id=10278
http://www.globalscape.com/support/lostserial.aspx
http://www.globalscape.com/support/lostserial.aspx
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4. To save a backup of the serial key in text format on a local drive, click Backup and Print 
Registration Data. This information is useful if you change computers and need to install the 
software on the new computer. 

5. In the Backup Registration Location dialog box, browse for the folder in which you want to save 
the backup, then click OK. 

6. Click Finish. 

TROUBLESHOOTING PRODUCT ACTIVATION 

If activation fails, try the following resolutions: 

Invalid Serial Number - The serial number must be entered exactly as it appears on your invoice or 
label. It is not case sensitive. If you received a digital invoice, avoid typing errors by copying the serial 
number to the Windows clipboard and then paste it (CTRL+V) into the serial number box in the 
registration wizard. 

Serial Number Entered for the Wrong Product type - Serial numbers are specific to a particular 
product. Double-check your invoice to see which product and version you purchased. Compare that to the 
product name and version shown in the About dialog box or on the splash screen. If they do not match, 
then download the correct product from the GlobalSCAPE website. If you have accidentally purchased 
the wrong product, then contact the GlobalSCAPE support team. 

Registration Unable to Complete due to a Network Problem - Because activation takes place over the 
Internet, CuteFTP must be able to connect to our registration server to complete the activation process. If 
it cannot connect or complete the process, it will prompt you with various alternatives. You can email us 
certain information and we will reply with an unlock code or you can register via a Web form, which also 
provides you with an unlock code. The final alternative is to continue as an "unverified" registration, which 
means that we will honor the serial number you provided as valid for now and attempt to complete the 
activation process later once a connection to the registration server is secured (checked at application 
startup). 

Unable to Connect due to Proxy Settings - In the Registration Failed dialog box, click HTTP Proxy to 
modify your proxy settings so that CuteFTP can perform HTTP (Web) transactions. If you do not know 
how to edit this information, ask your system administrator what the proxy settings are. Many Internet 
Service Providers have this information on their Web site. 

Lost Serial Number - If you cannot locate your serial number, you can obtain a copy from GlobalSCAPE 
Support. If you still have the original email address used to purchase the software, on the main menu, 
click Help > Locate a lost serial. If you no longer have access to that email account or do not recall 
which email address you used, contact customer service department and provide your name, address, 
order ID or any other pertinent data that might help us locate your original purchase record. 

FREQUENTLY ASKED QUESTIONS 

 How do I set up a connection to my FTP Server?  

 What is my FTP Host Address?  

 What is my user name and password?  

 How do I upload my files with CuteFTP?  

 How do I transfer files from one site to another (CuteFTP Professional only)?  

 How do I navigate the directory tree in CuteFTP?  

 How do I change the permissions of my files (CHMOD)?  

 How do I delete files from my server?  

http://www.globalscape.com/downloads/
http://www.cuteftp.com/support/mail6.asp
http://www.cuteftp.com/support/lostserial.asp
http://www.cuteftp.com/support/mail6.asp
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 Why can I not connect to my FTP site?  

 Does CuteFTP support SSL (FTPS) and SSH2 (SFTP)?  

 How do I connect if I am behind a firewall?  

 Why are my files not transferring?  

 How do I remove files from CuteFTP that have finished transferring?  

 What is the Transfer Engine (TE)?  

 How do the various versions of CuteFTP differ?  

 How can I get a copy of CuteFTP?  

 How long does it take to download?  

 What sort of support do you offer for CuteFTP?  

 How can I best describe my problem if I contact technical support?  

 

Refer to Troubleshooting for answers to problems frequently encountered. 

How do I set up a connection to my FTP Server? 

First time users should use the Connection Wizard, which will ask you for a Label for the site and the rest 
of the login information provided to you by your Web Hosting Provider.  

What is my FTP Host Address?  

A host address will be in the format of ftp.mywebsite.com. This information is assigned by your Web 

Hosting Provider. If you do not know the FTP address, contact your Web Hosting Provider or Internet 
Service Provider. Many ISPs provide FTP configuration information on their Web site. For an example of 
what to look for, go to http://help.yahoo.com/l/us/yahoo/geocities/gftp/gftp-09.html. A similar help page 
should be available from the company that is hosting your web site. 

What is my user name and password?  

Your Web Hosting Provider or Internet Service Provider assigns this information. If you need to find out 
what this information is, you can contact them and they will be able to give that information back to you.  

How do I upload my files with CuteFTP?  

First, you must configure and connect to your site. Once connected, you can upload your files by 
browsing to the directory where your files are located on the left pane, click the files you want to upload, 
then drag them to the corresponding folder in the right pane (the server side). You will see the upload 
progress of your files in the Queue window. 

More on transferring files and folders. 

How do I transfer files from one site to another?  

In CuteFTP Professional, connect to two different servers. In the first server window, click the files you 
want to transfer, then drag and drop these files to the second server window. The files will be transferred 
from the first server to the second server. This feature is not available in CuteFTP Home or CuteFTP Lite. 

http://help.yahoo.com/l/us/yahoo/geocities/gftp/gftp-09.html
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How do I navigate the directory tree in CuteFTP?  

The Local pane, located on the left side of the interface, shows files and folders on your computer. The 
Remote pane, located on the right side of the interface, shows you the directories of the site to which you 
are logged in. You can navigate your drives in the same fashion as in Windows Explorer.  

How do I change the permissions of my files (CHMOD)?  

Connect to your server using CuteFTP. Click to select the file whose permissions you want to change, 
then right-click the selection and click Properties. The options for the permissions are located at the 
bottom of the Properties dialog box. Only servers that support the CHMOD command allow you to 
change permissions. You cannot change permissions on servers that do not support CHMOD.  

Refer to Viewing File and Folder Properties for more information regarding CHMOD. 

How do I delete files from my server? 

To delete files from your server, click the file you want to delete, then press Delete. You can also right-

click the file and click Delete, or you can click the file then click the Delete icon  on the toolbar.  

Why can I not connect to my FTP site? 

If you have tried to log into your FTP site and have been unsuccessful, a message appears telling you 
that CuteFTP could not log in. Click Details to view the exact error message sent to you by the server. 
Contact your Internet Service Provider or your Web Host Provider with this error message and they will be 
able to assist you in getting connected. GlobalSCAPE Technical Support does not have access to your 
Internet Service Provider/Web Host Provider's FTP information. 

See Troubleshooting for more information 

Does CuteFTP support SSL (FTPS) and SSH2 (SFTP)?  

CuteFTP Professional supports SFTP, which is a component of SSH2. Professional and Home editions 
both support SSL. CuteFTP Lite does not support SSL or SSH. Check with your server administrator or 
ISP to verify that the server you are connecting to supports SSL or SFTP (SSH2).  

You cannot connect with SFTP simply by configuring the proxy settings in Global Options. CuteFTP does 
not support using SFTP through a proxy server that is not a SOCKS proxy server. Non-SOCKS servers 
are "protocol dependent," meaning that if it's an FTP server, you must use FTP and if it's an HTTP server, 
you must use HTTP. SOCKS proxy servers are not protocol dependent. A SOCKS proxy server works for 
any TCP/IP socket connection, so the protocol should not matter.  

How do I connect if I am behind a firewall? 

If you are behind a firewall and you cannot connect, you will need to set up CuteFTP to connect through 
that firewall. On the main menu, click Tools > Global Options > Connection node. Click either SOCKS4 
& 5 or Proxy Server and complete the information. If you are unsure if you are behind a proxy firewall or a 
socks firewall, or are not sure of the specific settings for that firewall, consult your system administrator or 
Internet Service Provider for the correct settings. (Since servers can have a variety of configurations, 
GlobalSCAPE Technical Support will not have that information.) 

Why are my files not transferring? 

If a message appears that says your files could not transfer, click Details to view the exact error message 
sent to you by the server. Contact your Internet service provider or your Web hosting provider with this 
error message.  

See Troubleshooting for more help. 
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How do I remove files from CuteFTP that have finished transferring?  

To remove items from the Queue Window that have already transferred or will not transfer, on the main 
menu, click Tools > Queue > Remove all. All of the items are removed from the Queue window. (Or your 
can right-click in the Queue Window, then click Remove Selected, Remove Finished, or Remove All.) 

What is the Transfer Engine (TE)?  

CuteFTP uses a Transfer Engine (TE) to transfer files, which is completely independent of the main 
application interface. You can configure CuteFTP Professional and Home to continue to transfer files 
even after the main CuteFTP interface is exited. In CuteFTP Lite, the TE shuts down and all in-progress 
transfers stop if the application is closed. CuteFTP Professional offers a COM interface to the Transfer 
Engine that allows application developers to develop custom FTP solutions. 

How do the various editions of CuteFTP differ from one another?  

All editions of CuteFTP allow you to connect to FTP sites to transfer files. CuteFTP Professional provides 
extra security, automation, and management tools, such as the Transfer Engine (TE) interface, and 
capabilities for SFTP, HTTPS, site-to-site transfer, multi-part transfers, and more. Visit the comparison 
page at http://www.globalscape.com/cuteftp/compare.asp for more information. 

How can I get a copy of CuteFTP?  

All editions of CuteFTP are available by download from our Web site at 
http://www.globalscape.com/downloads/. 

How long does it take to download?  

Download time depends on your modem speed. On a regular 56K modem, CuteFTP takes about 7 
minutes. The time to download decreases as your connection speed increases.  

What sort of support do you offer for CuteFTP?  

Free online self-help resources are available for all users at the GlobalSCAPE Help Center. Help is also 
available via email and telephone for registered users covered by a Priority Support plan. Visit the 
GlobalSCAPE Help Center for up-to-date information about all of the technical support options available 
to you. 

How can I best describe my problem if I contact technical support?  

If you are having a transfer or connection problem, enable extended log listing, reproduce the problem, 
then copy and paste the log in to our online support request form or your Web Hosting Provider/Internet 
Service Provider. 

CONNECTING TO A SITE USING THE CONNECTION WIZARD 

CuteFTP allows you to connect to a Web site to upload and download files between a server and your 
local computer. To transfer files, you must log on to that server through your FTP client computer. 
CuteFTP Connection Wizard helps you to define a site to which you want to connect and saves the 
information in the Site Manager for future connections. 

 

The Internet Service Provider (ISP) or Web Hosting Provider to which you want to upload files provides you with 
the username, password, and FTP account information required to connect to their server. Many providers 
offer this information on their Web support pages. Refer to the GlobalSCAPE Knowledge Base articles at 
http://kb.globalscape.com/ for information about FTP connections to your AOL or Roadrunner accounts or 

search your provider's support pages for keyword ftp.  

http://www.globalscape.com/cuteftp/compare.asp
http://www.globalscape.com/cuteftp/compare.asp
http://www.globalscape.com/downloads/
http://www.globalscape.com/support/
http://www.globalscape.com/support/
http://www.globalscape.com/support/mail1.asp
http://kb.globalscape.com/
http://kb.globalscape.com/article.aspx?id=10148
http://kb.globalscape.com/article.aspx?id=10325
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To connect to an FTP site 

1. Gather the information that you need to make a connection:  

 Host Address - the IP address or FTP domain address that your ISP gave you to log in 
to the FTP site (e.g., 64.243.64.21 or ftp.example.com).  

 User Name - the user name your ISP gave you to log in to the FTP site. Your username 
is often the part of your email address in front of the @ sign. 

 Password - the password your ISP gave you to log in to the FTP site. This is often the 
same password you use to download your email. 

 Site Name - By default, the Site Name is the same as the Host Address, but you can 
name it anything you want; it is not provided by your ISP or GlobalSCAPE. 

2. Do one of the following: 

 On the main menu, click File > Connect, then click Connection Wizard. 

 On the toolbar, click the Connection Wizard icon .  

 Press CTRL+J. 

The CuteFTP Connection Wizard appears. 
 

 

3. In the Host Address field, type the IP address or FTP domain address that your ISP gave you to 
log in to the FTP site.    

4. The address that you typed in the Host Address field appears in the Site Name field. You can 
leave it as is, or type a descriptive name for this site. The site name will appear on the Site 
Manager tab. 

5. Click Next. The login page appears 

6. In the User Name box, type the user name your ISP gave you to log in to the FTP site.  

7. In the Password box, type the password your ISP gave you to log in to the FTP site. 

8. Specify a login method from the following options. 

 Normal - The user name and password are mandatory to connect to a site. 

 Anonymous - The site does not require any user name and password. 
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 Double - The user name and password are required twice to connect to a site. 

9. Click Next. The Connecting to Site message appears. 

 If you need to change the host address or do not want to log in, click Cancel. 

 If the connection fails, an error message appears. Click Yes to close the message, then 
click Back to verify/correct the host address, username, and password. (If the connection 
fails again, refer to Troubleshooting.) 

10. After you are connected to the FTP site, the default folders page appears. 

11. In the Default Local Folder field, click the folder icon  to browse for the default folder from 
which you want to upload/download files to/from the server. 

12. In the Default Remote Folder field, type the path of the remote folder from/to which you want to 
upload files.  

13. Click Next. The Connection Completed page appears. 

14. Click Finish. Cute FTP connects to the site and saves the site in the Site Manager.  

For subsequent connections to this FTP site, refer to Connecting to a Site. 

Refer to Configuring Connection Options for details of how to configure the number of simultaneous 
connections you will allow from CuteFTP, number of times CuteFTP tries to connect to a site before 
giving up, how long CuteFTP should wait before attempting a new connection after a failed connection, 
and so on.  

TRANSFERRING FILES AND FOLDERS 

Transferring files and folders between sites is quick and easy. Besides just clicking and dragging the item 
that you want to transfer, you can also: 

 Multi-select and drag items as group. (SHIFT + click for contiguous items; CTRL + click for non-
contiguous items.)  

 Drag items to the Queue to upload them later. 

To upload files (transfer from a local to remote computer) 

1. Connect to a remote site. 

2. In the Local pane, locate the files or folders that you want to upload. 

3. Click and hold the mouse button while dragging the item(s) from the Local pane to the Remote 
pane or Queue pane. 

4. Release the mouse button. The items are copied (not moved) to the remote server or to the 
Queue pane for later uploading. 

To download files (transfer from a remote to a local computer) 

1. Connect to a remote site. 

2. In the Remote pane, locate the files or folders that you want to download. 

3. Click and hold the mouse button while dragging the item(s) from  the Remote pane to the Local 
pane or Queue pane. 

4. Release the mouse button. The items are copied (not moved) to your local location or to the 
Queue pane for later downloading. 

For the procedures for file and folder management, see Managing Files and Folders. 



 

Getting Started ● 17 

CONFIGURING INTERNET CONNECTION (DUN/LAN) SETTINGS 

CuteFTP automatically detects which method you use to connect to the Internet. You must have a 
network connection configured on the computer on which you are using CuteFTP in order for it to detect 
the settings.  

 If you connect to the Internet with a phone modem, you are using Dial-Up Networking (DUN). If 
you have a modem connection configured, it will detect it and allow you to use it. If you do not 
have a modem installed, the modem options are not available. 

 If you connect to the Internet with a cable modem, DSL modem, or through a computer network, 
you are using a Local Area Network (LAN). If you have a LAN connection, it will detect it and 
allow you to use it. If you do not have a LAN connection, the LAN options are not available. 

If CuteFTP does not detect your modem, search the Microsoft Window's help file (Start > Help and 
Support) for "Make an Internet Connection." 

To access Dial-up and Network settings 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Connection node, then click DUN/LAN. The DUN/LAN options appear. 

3. Configure options as described below. 

 If you connect to the Internet with a cable modem, DSL modem, or through a computer 
network, click Connect to the Internet using a LAN. 

 If you connect to the Internet using a modem over regular telephone lines, click Connect to 
the Internet using a modem. 

 If you are using a dial-up connection, configure the following options: 

o In the Use the following Dial-Up Networking connection box, click the dial-up 
connection you want CuteFTP to use. The list includes every dial-up connection 
on the local computer that is available in Windows. Many computers list only one. 

o To display the dial-up connection user name and password whenever CuteFTP 
attempts a connection, select the Show authentication window (requires user 
input) check box. Clear this check box to stop the display of the dial-up 
connection user name and password when CuteFTP attempts a connection. 

o To display messages when an error occurs with the dial-up connection, select 
the Show error prompts (requires user interaction) check box. Clear this 
check box to stop the display of error messages from the dial-up connection. 

o To disconnect from the Internet automatically when CuteFTP or the Transfer 
Engine shuts down, select the Disconnect from the Internet upon program 
exit check box. Clear this check box to keep the Internet connection active after 
CuteFTP or the Transfer Engine shuts down. 

o To specify how many times CuteFTP tries to establish a dial-up connection to the 
Internet after a connection fails, in the Number of times to attempt connection 
box, specify from 0 to 1000 attempts. 

o To specify how long in seconds CuteFTP waits between attempts to establish a 
dial-up connection to the Internet, in the Number of seconds to wait between 
attempts box, specify from 0 to 1000 seconds (1000 seconds equals almost 17 
minutes). 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 
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MOVING CUTEFTP TO A DIFFERENT COMPUTER  

In CuteFTP Home and Professional, there are two alternatives for moving the software to a new 
computer.  

OPTION 1 (If the old computer is no longer running or available to you, or if you do not need the existing 
Site Manager data): 

1. Download the software from this page:  http://www.globalscape.com/support/reg.asp 

2. Install CuteFTP on the new computer and activate it using your existing serial number. 

OPTION 2 (If the old computer is still available to you and you need access to the existing Site Manager 
data): 

1. On the old computer:  

a. Launch CuteFTP.  If you do not already have your serial number available, on the main 
menu, click Help > About CuteFTP. Record your serial number so that you can use it on the 
new computer. 

b. On the main menu, click Help > Backup registration & personal data. The Backup 
Registration Location dialog box appears. 

c. Click Browse. Select a drive with portable media (e.g., a USB drive) or network location in 
which to save the data, then click OK. A backup successful message appears when 
completed. 

d. If you are transferring the license to the new computer, remove the software from the old 
computer using Windows Add or Remove Programs. 

2. On the new computer:  

a. Download the software from this page: http://www.globalscape.com/support/reg.asp   

b. Install CuteFTP on the new computer and activate it with the serial number that you recorded 
in step 1 in the previous procedure. 

c. Insert the media on which your backup was saved or make sure you have access to the 
network location in step 2 in the previous procedure. 

d. Launch CuteFTP.  

e. On the main menu, click Tools > Site Manager > Import FTP Sites, and follow the 
instructions.   

 

On some older versions of CuteFTP, open the Site Manager and then click Import. For detailed instructions 
about how to import your Site Manager data, refer to Importing FTP Sites. 

 

http://www.globalscape.com/support/reg.asp
http://www.globalscape.com/support/reg.asp
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USING THE CUTEFTP INTERFACE 

The main window is used to transfer files to and from remote servers and is divided into four panes. The 
two center panes represent files available on local and remote drives, much like Windows Explorer. When 
you first open CuteFTP Home, the upper pane is hidden. You can choose to hide or display the upper 
pane, the center left pane, and the bottom pane. 

 

Upper (Log) pane 

The Log pane displays the commands you send and the server's responses. CuteFTP logs this 
information to inform you of completed transactions or assist in troubleshooting.  

 To display or hide the Log pane, on the main menu, click View, point to Show Panes, then click 
Log Pane. 

Center left (Local) pane 

The Local pane displays files and folders from your hard drive. 

 To display or hide the Local pane, on the main menu, click View, point to Show Panes, then 
click Local Drives Pane. 

Center right (Remote) pane 

The Remote pane displays the files and folders on the remote server. 

Lower (Queue) pane 

The Queue pane shows the files currently being transferred to the server. If you want to transfer files 
later, you can also store them here temporarily. 

 To display or hide the Queue pane, on the main menu, click View, point to Show Panes, then 
click Queue Pane. 
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THE STANDARD TOOLBAR 

The Standard toolbar is displayed by default. To hide or display the Standard toolbar, on the main menu 
click View > Toolbars > Standard Toolbar. The toolbar provides icons for the following functions: 

Name Icon Function 

Site Manager 
 

Opens the Site Manager. 

Connection Wizard 
 

Opens the Connection Wizard. 

New 
 

Opens the Site Properties for dialog box. Click the down arrow to create a new site 

or HTML file.  

Connect 
 

Connects you to your FTP site. 

Quick Connect 
 

Speeds up the connection to FTP sites. 

Disconnect 
 

Disconnects the connection to your site. 

Reconnect 
 

Reconnects the connection to your site. 

Connect to URL 
 

Opens the Connect to URL dialog box in which you can specify the address to 

which you want to connect (e.g., http://www.myremotesite.com). 

Refresh 
 

Refreshes the log pane. 

Stop Transfer 
 

Stops a transfer in progress. 

Download 
 

Downloads selected files from the remote computer to your local computer. Click the 
down arrow and click HIGH to split the file into two parts or MAX to divide the file into 
more parts. 

Upload 
 

Uploads selected files from your local computer to the remote computer. Click the 
down arrow and click HIGH to split the file into two parts or MAX to divide the file into 
more parts. 

Edit 
 

Opens a selected HTML file in your default HTML editor or the built-in HTML editor. 

Rename 
 

Allows you to rename a selected file. 

New Folder 
 

Creates a new folder on the local computer and the remote computer. 

Open 
 

Opens a selected file. 

Delete 
 

Deletes a selected file. 

Properties 
 

Displays the properties of a selected file. 

Global Options 
 

Opens the Global Options dialog box. 

PODCast Manager 
 

Opens the CutePODCast Manager. 

DISPLAYING THE SITE MANAGER 

To display or hide the Site Manager 

 Do one of the following: 

o Press F4 to toggle the Site Manager. 

o On the main menu, click Tools > Site Manager > Display Site Manager.  
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DISPLAYING LOCAL FILES AND FOLDERS 

Local files and folders are displayed in the Local Drives pane on the left-hand side of the CuteFTP 
window. 

To display files and folders on the local computer 

 Do one of the following: 

o Press ALT+0 

o On the main menu, click View > Show Panes > Local Drives Pane (there should be a 
check mark next to it). 

DISPLAYING FOLDER CONTENTS 

To view a listing of local folder contents 

1. Local folders are displayed by default in the left pane. 

2. Double-click a folder to view its contents. 

To view listings in a parent folder 

1. Click in the pane where you want to view the parent folder. 

2. Click the Move up icon . 

To update (refresh) a folder listing 

1. Display the folder. 

2. Click in the pane where the folder is displayed. 

3. Do one of the following: 

 On the main menu, click View > Refresh.  

 Right-click, then click Refresh. 

 Press F5. 

DISPLAYING TRANSFER ITEMS 

The Queue Window displays items ready for transfer, in transit, or just transferred.  

To display or hide queued files and folders 

 On the main menu, click View > Show Panes > Queue Pane (or press ALT+2) .  

DISPLAYING THE CONNECTION LOG 

Messages between the local computer and the server are stored in the Log.  

To display the connection log 

 On the main menu, click View > Show Panes > Log Pane (or press ALT+2). 

 

The log for the active session is displayed above the local and remote panes.  
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DISPLAYING THE STATUS BAR 

The Status Bar appears at the bottom of the CuteFTP interface. When you place the cursor over a tool or 
menu item, the left side of the Status Bar displays a brief description/tool tip of the item. The right side of 
the Status Bar displays information about the folder selected in the Remote pane.  

For example, when you click View > Show Panes > Log Pane, the Status Bar reads, Show or hide 

the log pane, as shown below.  

 

To show/hide the Status Bar 

 On the main menu, click View > Toolbars > Status Bar (or press ALT+3). 

DISPLAYING OR HIDING TOOLBARS 

CuteFTP includes the following toolbars:  

 Standard Bar 

 Quick Connect Bar 

 Custom Commands Bar 

 HTML Editor Bar (available only when a document is open in the Editor) 

 Status Bar 

You can also choose to display large or small toolbar icons.  

To toggle between large and small icons 

 Right-click on the toolbar, then click Show large icons. A check mark indicates that large icons 
are displayed.  
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To hide/show a toolbar 

 On the menu, click View > Toolbars, then click the toolbar you want to hide or display. A check 
mark indicates that the toolbar is visible. 

VIEWING FILE AND FOLDER PROPERTIES 

Just as in Windows Explorer, you can view the properties of any file or folder by right-clicking the file, then 
clicking Properties.   

Local pane information: 

 

 Type: Kind of item (e.g., HTML document, File Folder) 

 Location: Path where the file resides (e.g., C:\Documents and Settings\user1\My Documents; on 
the remote server, displays the directory) 

 Opens with: Indicates in which application the file opens. To open ALL files of that type with a 
different application, click Change. For example, if your computer is configured to open GIF 
(image) files in Internet Explorer, but you want them to open in Paint Shop Pro so that you can 
edit them, click Change, scroll to or browse for psp.exe, then click OK. This change will affect 
ALL files on your computer that have that extension; the same as clicking Tools > Folder 
Options > File Types in Windows Explorer. 

 Size: Size of the file or folder (e.g., 43.1 MB (45,281,728 bytes)) 

 Contains: For folders, displays how many files and subfolders it contains 
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Remote pane information: 
 

 

 Server: The address (URL) of the server on which the file resides 

 Modified: When the item was last modified 

 User: Specifies the user of the item (e.g., owner) 

 Group: Specifies the group to which the item belongs (can be blank) 

 Read/Write Permissions: You can set the CHMOD permissions by changing the number (such 
as 777), or just check off the permissions in the Owner, Group, and Public area of the dialog 
box. 

About CHMOD Permissions 

The CHMOD permission mask is a three-digit number.  

 First digit: Defines the permissions for the owner (you).  

 Second digit: Defines the permissions for the group.  

 Third digit: Defines the permissions for everyone else (referred to as public). 

Each digit works the same for each group of users: the owner, group, and public. What you set for one 
digit has no effect on the other two digits. Each digit is made up of the three Read, Write, and Execute 
permissions. The Read permission value is 4, the Write permission value is 2, and the Execute 
permission value is 1. These three numbers are added together to get the permissions for a file. If you 
want a file only to be readable and not writable or executable, set its permission to 4. This works the 
same for Write and Execute. Executable only files have a permission of 1.  
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For example, if you want a file to have Read and Write permissions, add the Read and Write values 
together (4+2) and you get 6, which is the permissions setting for Read and Write. If you want the file to 
have Read, Write, and Execute permissions, use the value 7 (4+2+1). Do this for each of the three 
permission groups and you get a valid CHMOD mask. If you want your file to have Read, Write, and 
Execute permissions (4+2+1) for yourself; Read and Execute (4+1) for your group; and Execute (1) only 
for everyone else, you would set the file permissions to 751. (Or just select the appropriate check boxes 
under Owner (you), Group, and Public.) 

TRANSFERRING GRAPHIC FILES 

If you are uploading or downloading graphic files, thumbnail view makes it convenient to preview the 
images right in CuteFTP so you can select the ones you want before you transfer them. 

To turn on thumbnail view 

1. Click in the pane (local or remote) that you want to change to thumbnail view. 

2. Do one of the following: 

 On the main menu, click View > View > Thumbnails. 

 At the top of the Local or Remote pane, click the Thumbnail icon . 

 

Thumbnail view supports previews of GIF, JPG, or BMP files, but not PNG files. You can adjust how CuteFTP 
handles thumbnail images in the thumbnail cache settings in Global Options. For more information, refer to 
the procedure in Log File Settings for configuring thumbnail cache options. 

KEYBOARD SHORTCUTS 

If you are more comfortable using the keyboard than the mouse, numerous keyboard shortcuts are 
available in CuteFTP.  

In the table below (and elsewhere in this user guide), "ALT+" indicates that you are to press and hold the 
ALT key on your keyboard while simultaneously pressing one or more other keys. "CTRL+" indicates that 
you are to press and hold the CTRL (Control) key on your keyboard while simultaneously pressing 
another key. For example, "CTRL+SHIFT+D" indicates that you are to press and hold the Control Key 
and the Shift key, while simultaneously pressing the D key (to move items down the list in the queue). 
These key combinations are used instead of using the mouse to click in the interface. For example, press 
ALT+F to activate the File menu; press CTRL+C to copy selected text.  

Key  Function  

Backspace Move to parent folder 

Number Pad + Group select 

Number Pad -  Group deselect 

Number Pad * Invert selection 

Tab Moves focus between tabs (documents) in the active pane group 

Delete Delete selected object 

Esc Cancel transfer 

F1 Help 

F2 Rename 

F3 Find next 
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Key  Function  

F4 Switch between Site Manager and Local Drives tabs  

F5 Refresh active pane 

F8 Display folder information 

F9 Cancel transfer 

F10 Switch between Log pane and Queue pane 

F12 Hide or display individual log window 

Alt+Enter Folder, file, or site properties 

Alt+Up Arrow Move to parent folder 

Alt+Down Arrow Select drop-down arrow for active pane 

Alt+Right Arrow Show bookmark drop-down for remote pane 

Alt+Left Arrow Show bookmark drop-down for local pane 

Alt+F7 Display Global Options dialog box 

Alt+0 Toggle show Site Manager /Local Pane view 

Alt+1 Toggle show Queue /Log Pane 

Alt+2 Hide or display individual log window (same as F12) 

Alt+3 Toggle show status bar 

Alt+Q Exit 

CTRL+A Select All 

CTRL+B Bold Font (when in HTML editor), Browse offline (when a site is selected in Site Manager 
pane) 

CTRL+C Copy 

CTRL+D Change remote folder 

CTRL+E Execute file 

CTRL+F Find 

CTRL+H Launch internal HTML editor 

CTRL+I Italic Font (when in HTML editor mode) 

CTRL+J Launch Connection wizard 

CTRL+L Filter 

CTRL+M Make new folder 

CTRL+N New FTP Connection 

CTRL+O Open (new document) 

CTRL+P Print (when in HTML editor mode) 

CTRL+Q Add current path as new bookmark 

CTRL+R Reconnect 

CTRL+T Connect to selected site 
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Key  Function  

CTRL+S Save open document (HTML editor mode) 

CTRL+U Connect to URL or underline when HTML editor is active. 

CTRL+V Paste 

CTRL+W View file 

CTRL+X Cut 

CTRL+Y Redo (When in HTML editor mode) 

CTRL+Z Undo (When in HTML editor mode) 

CTRL+F4  Close active pane 

CTRL+F8 Quick Connect 

CTRL+~ (tilde) Move focus between left, right and bottom panes 

CTRL+PAGE 
DOWN 

Download 

CTRL+PAGE UP Upload 

CTRL+Tab Move focus right to left among open connections and documents 

CTRL+ENTER Edit selected document (also creates a line-break when in the integrated editor's 
Find/Replace utility) 

CTRL+ALT+T Toggles Thumbnail view 

CTRL+SHIFT+A Add anchor (when in HTML editor mode) 

CTRL+SHIFT+B Change item queue order (place at bottom) 

CTRL+SHIFT+C Add comment (when in HTML editor mode) 

CTRL+SHIFT+D Change item queue order (move down one) 

CTRL+SHIFT+I Font dialog (when in HTML editor mode), Input RAW FTP command when in CuteFTP mode 

CTRL+SHIFT+L Clear entire log 

CTRL+SHIFT+T Change item queue order (move to top) 

CTRL+SHIFT+U Change item queue order (move up one) 

SHIFT+F4 Disconnect 

LOCAL AND REMOTE PANE VIEWS 

To change the pane view 

1. Click within the pane you want to change. 

2. On the main menu, click View > View, then click one of the following: 

 Large Icons 

 Small Icons 

 List 

 Details 

 Thumbnails 
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CHANGING HOW FILES AND FOLDERS ARE DISPLAYED 

You can display files and folders with large or small icons, in a list, or with file size and date-modified 
details. 

Large Icons - Displays files and folders as large icons 

Small Icons - Displays files and folders as small icons 

List - Displays files in a list, but no folders, and no details 

Details - Displays files and folders in a list with the file or folder size, type, and date modified 

To display files and folders as large icons, do one of the following: 

 Right-click in the Local or Remote pane, then click View > Large Icons. 

 On the main menu, click View > View > Large Icons. 

To display files and folders as small icons, do one of the following: 

 Right-click in the Local or Remote pane, then click View > Small Icons. 

 On the main menu, click View > View > Small Icons. 

To display files in a list, but no folders, and no details, do one of the following: 

 Right click in the Local or Remote pane, then click View > List. 

 On the main menu, click View > View > List. 

To display files and folders in a list with the file or folder size, type, and date modified, do one of 
the following: 

 Right-click in the Local or Remote pane, then click View > Details. 

 On the main menu, click View > View > Details. 
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CONFIGURING CUTEFTP (GLOBAL OPTIONS) 

The Global Options dialog box is used to configure logs, connections, security, how files are transferred, 
navigation, prompts, sounds, HTML file editing, and languages. You can configure Global Options to 
apply to all sites, and then configure site-specific options for individual sites, such as port number, time 
zone, caching options. 

CONFIGURING PROMPTS 

You can configure whether CuteFTP displays a confirmation message when you attempt to delete an 
item from local drives, remote sites, or the queue, and displays a prompt for errors, connection progress, 
and other information. The Prompts page is used to configure prompts to appear for various events. 

To configure CuteFTP prompt settings 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Display node, then click Prompts. The Prompts options appear. 

3. Configure options as described below.  

 To display a prompt when deleting from local drive, select the Confirm when deleting 
from local drive check box. Clear this check box if you do want a confirmation prompt. 

 To display a prompt when deleting from a remote folder, select the Confirm when 
deleting from remote drive check box. Clear this check box if you do want a 
confirmation prompt. 

 To display a prompt when deleting from the queue, select the Confirm when deleting 
from queue check box. Clear this check box if you do want a confirmation prompt. 

 To display a prompt when you try to close a window for an active connection, select the 
Confirm when closing a remote pane check box. Clear this check box if you do want a 
confirmation prompt. 

 To display a prompt upon certain server errors (5xx range), select the Show prompt 
upon error check box. 

 To display a prompt when the site password is rejected or missing, select the Show 
login prompt if connection fails or is missing data check box.  

 To display a prompt when a task is scheduled and added to the queue, select the Show 
prompt when new tasks are scheduled check box. 

 To display a prompt when a scheduled task has started to run, select the Show prompt 
when new tasks are started check box. 

 To display a prompt when the archive was expanded successfully, select the Show 
prompt after successful decompression check box. 

 To display a warning when you may be transferring a certain file type in the wrong mode, 
select the Show warning when transferring binary files in ASCII mode check box. 

 To display a connection status message when connecting, select the Show connection 
progress prompts check box. If the log view is unavailable when connecting, this dialog 
will show you if there may be a problem with the connection. This is disabled by default. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 
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CUSTOMIZING TOOLBARS 

You can specify which toolbar icons to display and their order.    

To add, remove, or rearrange icons 

1. On the main menu, click Tools > Global Options. The Global Options dialog box appears. 
 

 

2. Click the Display node. 

3. In the Select the toolbars to display list, click a toolbar, then click Customize Selected 
Toolbar. The Customize Toolbar dialog box appears.  
 

 

4. Do one of the following: 

 To add an icon, click it in the Available toolbar buttons list, then click Add. 

 To remove an icon, click it in the Current toolbar buttons list, then click Remove. 

 To rearrange the toolbar, click an icon in the Current toolbar buttons list, then click 
Move Up to move a button one icon to the left on the toolbar or click Move Down to 
move the button one icon to the right on the toolbar. 

5. Select Reset to cancel any changes made since opening the dialog box.  
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LOG FILE SETTINGS 

In the Global Options dialog box, you can specify where and when log files are saved, and how they are 
displayed. 

To configure the log file settings 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the General node, then click Log Files. The Log Files options appear. 

3. Configure the options as described below. 

 To specify the location at which logs are saved, in the Log path box, click the folder icon 
to browse for the folder or type a different path. 

 To delete log files automatically at time intervals you specify, select the Delete saved 
logs every check box. Specify whether to delete files after a specified number of days, 
hours, or minutes. Clear the check box to keep all log files, or if you plan to delete them in 
other ways.  

 To delete error logs automatically when the Transfer Engine shuts down, select the 
Delete error logs after quitting the Transfer Engine check box. Clear the check box to 
keep error logs after the Transfer Engine shuts down. 

 To delete the associated logs automatically immediately after a successful task is 
finished, select the Delete logs of successful transfers immediately after completion 
check box. Clear the check box to keep the associated logs after a successful task is 
finished.  

 To include the date and time in all log files, select the Record/Display time stamps in 
logs check box. Clear the check box to exclude the date and time from all log files. 

 

This option consumes additional system resources due to insertion of time and date stamp at 
each log event. The Record/Display time stamps in logs check box is selected by default. 
Select the check box if you are copying logs to send to customer support for troubleshooting. 

 To remove all log files from your log folder that are currently not in use, click Delete all 
logs.  

 

Logs for active sessions are not automatically deleted. 

 To remove all remote file and folder listings CuteFTP has saved on your computer for 
offline browsing, click Delete listing cache.  

 To configure thumbnail cache options, in the When the transfer engine exits box, 
specify one of the following actions:  

o Retain images in thumbnail cache - Thumbnails stored in the cache are not 
deleted when you exit CuteFTP or the Transfer Engine. 

o Delete images in thumbnail cache - The thumbnail cache is emptied when the 
Transfer Engine is exited. 

o Delete images older than value specified - Thumbnails are stored for the time 
specified by the thumbnail cache expiration drop down menu. 

 To empty the thumbnail cache immediately, click Delete thumbnail cache. 

 To access the log display and log saving options, click Logs. The Log options appear. 
Configure options as described below. 
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o To choose a new color for all log window status messages, click STATUS  

o To choose a new color for all log window error messages, click ERROR.  

o To choose a new color for all log window command messages, click COMMAND.  

o To choose a new display color for all other messages in log windows, click 
OTHER.  

o To change the style of text in the log windows, click Font. The Font dialog box 
appears in which you can specify a different font face (e.g., Arial, Times), style 
(e.g., Regular, Bold), size (e.g., 8 points, 10 points), and script (e.g., Western, 
Hebrew, Arabic). The Preview box displays how the font will appear in logs. 

o To save each session log as a separate text file and to display the log in the 
individual session log window, select the Enable session (control connection) 
logs check box. Clear this to stop recording a log for each session, and to show 
no logs in the individual session log window. 

o To save the log for each item transferred as a separate text file, select the 
Enable individual transfer item (data connection) logs check box. Clear this 
to stop recording a separate log for each item transferred. 

o To display all logs in the Log Window in the bottom of CuteFTP interface, select 
the Enable consolidated transfer logs (both session and all transfers in log 
pane) check box. This option also saves all activity in one log file. Clear this to 
leave the Log Window blank and to stop recording all activity in a single log file. 

o To include file lists and permissions as part of session logs and consolidated 
logs, select the Record/Display raw directory listing in logs check box. This 
returns a RAW list, which is used commonly for debugging. Clear this to exclude 
file lists and permissions from session logs and consolidated logs. 

o To show a log window in the remote pane for each site to which you connect, 
select the Show individual logs for each connection window check box. Clear 
this to hide any log windows in the remote pane. 

 

Logs can consume a large amount of system resources (memory and hard drive 
space), depending on the amount and size of files being transferred. It is 
recommended that you disable most logging (especially data connection logs) when 
performing a transfer that consists of many thousands of files, especially small files. 
To further reduce resource use, on the main menu, click Tools > Global Options, 
expand the Transfer node, click Events, then click Remove successful transfers from 
the queue automatically. 

4. Click OK to save changes and close the Global Options dialog box. 

General Security Settings 

To display the Security window 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Security node. The Security options appear. 

3. Configure options as described below. 

 To prevent storing any site passwords in the Site Manager file, select the Remove Site 
Manager passwords upon program exit check box. CuteFTP asks for the site 
password for each connection attempt. Clear this check box to allow CuteFTP to store 
site passwords in the Site Manager file (default behavior). When passwords are saved, 
you do not have to enter them again when connecting to a site. 



 

Configuring CuteFTP (Global Options) ● 33 

 

Not saving passwords at all is useful in shared system environments, where CuteFTP is likely 
being used by multiple users on the same physical computer. 

 The default location to store the Site manager is displayed in the Site Manager path box. 
To move your Site Manager to a different location on your computer or network, type or 
browse for a new path.  

 To secure the Site Manager, select the Encrypt contents of Site Manager check box, 
then click Change Password. You must supply a password every time you start 
CuteFTP. Clear this check box, and CuteFTP starts without requiring a password. Site 
Manager and all its sites are available. 

 

When this option is not used (default) CuteFTP uses mild encryption with a system-generated 
password to protect your Site Manager's contents. It is highly recommended that you select 
Encrypt the contents of the Site Manager, as it protects the contents of the Site Manager 
with strong encryption, using a password you supply.  

 To remove passwords from queued items, select the Remove Queue file passwords 
upon program exit check box. Next time you start CuteFTP, you will be prompted for a 
password to complete the transfer. Clear this check box to allow passwords to be sent 
automatically for queued items. 

 To erase any URLs and remove all sites from the Quick Connect drop-down when 
CuteFTP is shut down, select the Remove Quick Connect and Connect to URL 
history upon program exit check box. Clear this check box to keep URLs and to keep a 
list of sites in the Quick Connect drop-down list even when CuteFTP is closed.  

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

SSL SECURITY SETTINGS 

To access the SSL security settings 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Security node, then click SSL Security. The SSL Security options appear. 

3. Configure options as described below: 

 Select the Use SSL certificate when authenticating to send a certificate to SSL servers for 
authentication. Clear this check box to send no certificate to SSL servers for authentication. 

 

Your server may not require client certificates. If they do require client certificates, you may need 
to send your self-signed or 3rd-party signed certificate to the server administrator to be added to 
the server's Trusted List. 

 In the Certificate box, browse to or type the location of an SSL certificate file on your local 
computer. The file should have a .crt extension. 

 In the Private key box, browse to or type the location of an SSL private key file on your local 
computer. The key file should have a .key extension. 

 In the Use passphrase box, provide the passphrase used for the certificate listed in the 
Certificate field. 

 In the Confirm Passphrase, provide the passphrase again for the certificate listed. 



 

34 ● Transfer Settings  

 

The private key password is stored in the registry using strong encryption. For added security, 
leave the passphrase boxes blank so that CuteFTP will prompt you for the private key password 
when necessary. 

 Click Create Certificate to create a new SSL certificate with a signing request and a key for 
the certificate. For more information on creating SSL certificates, see Creating your own SSL 
certificates. 

 Click Trusted Certificates to display a list of certificates that you have accepted as valid. 
For more information on trusted certificates, see Accepting server SSL certificates and 
Importing SSL certificates. 

 Select the Reuse cached session for data connection (required by some servers) check 
box to allow new transfers without encrypting a new data channel. Clear this check box to 
require encryption of every session for every new transfer. 

 Select the Accept certificates in Windows Trusted Root Certificate Authority store 
check box to automatically trust certificates already accepted by your system, even if they 
have not been added to your Trusted list. Clear this check box to require all certificates to be 
added to the CuteFTP Trusted list before allowing connections. 

 Select the Warn when switching from secure to non-secure pages (CuteFTP 
Professional Only) check box to see a pop-up message when, after connecting to a secure 
HTTP site, you click a folder or link that is not secure. Clear this check box to be able to link 
from secure HTTP sites to HTTP sites that are not secure without seeing any pop-up 
messages. 

 Select the Enable SSH operation logging check box to enable SSH logging. Version 8.3.3 
uses a new SSH library which does not make use of the verbosity level setting. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

TRANSFER SETTINGS 

Many of these controls are intended for advanced users only. For example: 

 The REST/APPE sequence is only intended for problem servers that do not support the proper 
resume sequence.  

 Transfer type should only be changed when you need to force files to transfer a certain way.  

 The data port mode should only be changed if you are having problems establishing a data 
connection (on LIST or RETR for example). Limiting the local port range can have adverse affects 
when transferring many small files over a narrow range of ports. 

To access transfer settings 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Transfer node. The Transfer options appear. 

3. Configure options as described below. 

 In the Transfer method box, specify one of the following methods: 

o Choose Auto-detect to have CuteFTP decide the transfer method based on the 
file and server type. 

o Choose ASCII to transfer text files, web pages, or other text type files. 

o Choose Binary to transfer pictures, programs, or executable files. 
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Binary files cannot be transferred in ASCII mode, but ASCII files can be transferred in Binary 
mode. 

 In the Data mode box, specify one of the following modes: 

o Auto - CuteFTP makes connections in PASV mode. If the PASV connection fails, 
CuteFTP attempts to connect in PORT mode automatically.  

o PASV - Helps avoid conflicts with security systems. PASV support is necessary 
for some firewalls and routers, because with PASV, the client opens the 
connection to an IP Address and port that the server supplies. 

o PORT - Connections or transfer attempts fail in PASV mode or when you receive 
data socket errors. When an FTP client connects using PORT, the server opens 
a connection to an IP Address and port that the client supplies.  
 
If you connect in PORT mode, your session becomes vulnerable to "Port theft," 
which means that a third party can interfere with transfers. 

 Select the Allow transfers to occur over the existing (browse) session check box to 
transfer files over new and existing sessions. CuteFTP uses the browse session and if 
available, additional connections. For example, If you define a per site max limit of five 
connections and then transfer five files, CuteFTP checks the browse connection first to 
see if it is busy, and if not busy, transfers the 1st file over the browse connection. The 
subsequent four files are transferred over four additional sessions. CuteFTP 
automatically adjusts for allowed connections (both from the client and server 
perspective) and whether or not it can use the browse session.  

o Clear the check box to transfer files over new sessions only. Use this option if 
your server allows multiple connections, is quick to respond, and you want to 
navigate the site while downloading. All transfers are forced over new 
connections, freeing up the browse session so you can continue to navigate. The 
only time this could cause a problem is when the server either refuses to allow 
multiple connections or is slow to log into. 

o If you select the check box, then press CTRL when transferring files, files transfer 
over the existing session only. To use this, select the files you want to transfer, 
then press and hold the Ctrl key while you drag and drop the files into the 
destination folder. This forces CuteFTP to transfer all the files on the existing 
session. Transferring files using only the currently logged in session can reduce 
overhead in certain situations. For example, a transfer of a large number of small 
HTML files can often be done much faster if limited to the current connection 
rather than performing a full TCP/IP connection and FTP login (and possibly 
FEAT/CWD/LIST) sequence first 

 Select the Turbo mode check box to compress the files when transfer is initiated. 
Compression of files increases the transfer speed and splits a large file into multiple 
parts, depending on the size of the file, to increase the transfer speed when uploading a 
file to a server or downloading a file from a server. 

 In the Reconnect and resume in box, specify the time that CuteFTP waits to try again 
after an interrupted or failed download. Select a time between 0 and 1,000 seconds 
(about 17 minutes).  

 In the Roll back (retry at byte offset) box, specify the number of bytes prior to the 
transfer failure CuteFTP resends when attempting to finish an interrupted transfer. Select 
between 0 and 65536 bytes. 

 Select the Send REST command prior to APPE when resuming a transfer check box 
to send the REST (Restart) command to resume a transfer, before sending the APPE 
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(Append) command. Clear this check box to send the APPE (Append) command to 
resume a transfer without first sending the REST (Restart) command. 

 In the Receive buffer and Send buffer boxes, specify the number of bytes for the send 
and receive buffers. The default setting for both send and receive is 65536 bytes. It is 
unlikely you will ever need to adjust these settings, but if you have problems with dropped 
transfers, you can use them to fine tune transfers over high latency or lossy connections 
like those over satellite links or with legacy CDMA wireless connections. For more, refer 
to Improving Slow Transfers. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

SMART OVERWRITE SETTINGS 

When you try to transfer a file to a destination with a file of the same name, use Smart Overwrite to 
determine the proper action to take. Smart overwrite settings apply to both uploads and downloads. Some 
servers are case sensitive. Such servers will not recognize files names as identical if the letter case of the 
two file names does not match. 

To configure the Smart Overwrite settings 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Transfer node, then click Smart Overwrite. The Smart Overwrite options appear. 

3. Configure options as described below. 

 In the For matching files box, click one of the following actions: 

o Prompt - CuteFTP displays a window asking you to overwrite or skip the file in 
the destination folder that has the same name as the file you are transferring. 

o Overwrite - If a file in the destination folder has the same name as the file you 
are transferring CuteFTP replaces the destination file with the transferred file. 

o Skip - If a file in the destination folder has the same name as the file you are 
transferring CuteFTP does not transfer the file and leave the destination file as it 
is. 

o Rename - If a file in the destination folder has the same name as the file you are 
transferring CuteFTP asks you for a new file name for the transferred file. 

o Resume - If a file in the destination folder has the same name as the file you are 
transferring CuteFTP treats the destination file as an incomplete transfer. If the 
destination file is already a complete file, the transferred file replaces the 
destination file. 

o Numerate - If a file in the destination folder has the same name as the file you 
are transferring CuteFTP renames the transferred file to 'Copy of file.txt'. If the 
same transfer occurs again CuteFTP renames the transferred file to 'Copy (2) of 
file.txt' 

o Use Rules - If a file in the destination folder has the same name as the file you 
are transferring, CuteFTP uses the rules you define in the Overwrite Rules 
dialog box (see below). 

4. Select the Ignore Zero byte files check box to specify that CuteFTP is to ignore any files with a 
size of zero bytes. If you clear this check box, CuteFTP applies all rules and settings to all files 
regardless of size. 



 

Configuring CuteFTP (Global Options) ● 37 

5. In the For matching folders box, click one of the following actions:  

o Prompt - CuteFTP displays a window asking what you want to do to a folder in the 
destination folder that has the same name as the folder you are transferring. 

o Replace All - If a folder in the destination folder has the same name as the folder you are 
transferring CuteFTP replaces every destination file with matching names with files in the 
transferred folder. 

o Use Rules - If a folder in the destination folder has the same name as the folder you are 
transferring, CuteFTP uses the rules you define in the Overwrite Rules window to 
determine how to handle all files with matching names. 

6. Click Configure Rules to open the Overwrite Rules dialog box to define the rules you want 
CuteFTP to use when two files have the same name. You must select Use rules in the For 
matching folders box to enable these options. 
 

 

o In the If destination file date is box, click one of the following options: 

 newer replaces a file if it has a time stamp more recent than the file you are 
transferring.  

 no matter replaces any file regardless of when it was created in relation to the 
file you are transferring. Select this option if you do not want to replace files 
based on when they were created. 

 older replaces a file only if it has a time stamp further in the past than the file you 
are transferring. 

 the same replaces a file if it has the same time stamp as the file you are 
transferring. 

 different replace a file if it has a time stamp that is older or newer than the file 
you are transferring. 

o In the and size is box, click one of the following options: 

 larger replaces a file if it is larger than the file you are transferring. 

 no matter replaces a file regardless of its size. Select this option if you do not 
want to replace files based on their size in relation to the file you are transferring. 

 smaller replaces a file if it is smaller than the file you are transferring. 

 the same replaces a file if it is same size as the file you are transferring. 

 different replaces a file if it is larger or smaller than the file you are transferring. 

o In the during box, click one of the following options: 

 any transfer replaces files whether you are uploading or downloading. 
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 download replace only the files on the local computer with files transferred from 
a remote site.  

 site to site transfer replaces files when with the same name when transferring 
from one remote site to another. 

 upload replace only the files on the remote site with files transferred from the 
local computer. 

o In the then box, click one of the following options: 

 overwrite completes the transfer by replacing the file that is in the destination 
folder.  

 numerate completes the transfer by renaming the transferred file with "Copy (n ) 
of..." added before the name. 

 resume treats the transfer as an attempt to continue an interrupted transfer. 

 show prompt pauses the transfer and display the message that asks the user 
which action to take. 

 skip cancels the transfer and leave the original file in the destination folder. 

o Click Add to places the rule into the list. If you are using rules, CuteFTP checks every 
rule in the list during all transfers. 

o Click Remove to delete a rule you have highlighted in the list and CuteFTP will no longer 
use the rule when it encounters two files of the same name. 

o Click Defaults to delete every rule from the list. 

For more information, see Smart Overwrite Example. 

7. The Prompt timeout action box, defines the action CuteFTP takes if no rules apply, or if you 
enable a timeout value. When you select the Timeout in n seconds check box, a prompt 
appears, but after waiting the defined amount of time, CuteFTP takes one of the following actions 
if a file in the destination folder has the same name as the file you are transferring: 

o Overwrite - Replaces the destination file with the transferred file 

o Skip - Does not transfer the file and leaves the destination file as it is 

o Rename - Asks you for a new file name for the transferred file 

o Resume - Treats the destination file as an incomplete transfer. If the destination file is 
already a complete file, the transferred file replaces the destination file 

o Numerate - Renames the transferred file to Copy of file.txt. If the same transfer 

occurs again CuteFTP renames the transferred file to Copy (2) of file.txt. 

8. Select the Resend LIST command as necessary check box to use the LIST command to 
retrieve file details and determine similarities and differences between a transferring file and 
destination file with the same name. Clear this check box and CuteFTP does NOT use the LIST 
command. 

9. Select the Use SIZE and MDTM commands to gather precise details check box to use the 
SIZE command to retrieve file size and the MDTM command to retrieve file modification time to 
determine similarities and differences between a transferring file and destination file with the 
same name. If you clear this check box, CuteFTP will NOT use the SIZE and MDTM command. 

10. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 
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ASCII TRANSFER SETTINGS 

Select, by file extension, file types that should always be transferred in ASCII mode. 

To configure the ASCII transfer options 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Transfer node, then click ASCII Types. The ASCII Types options appear. 

3. Configure options as described below. 

 In the ASCII extensions box, type the file extension for files you want to transfer in ASCII 
mode, then click Add to add the extension to the list. 

 To remove an extension from the list (to send files of this type in binary mode), click the 
extension in the list, then click Remove. 

 

You can specify a Transfer type from the main menu (see Transferring files in binary or 

ASCII mode). You can also specify a Transfer type for an individual site by highlighting the 
site in the Site Manager, clicking the Type tab, and choosing from the Transfer list. Auto is 
the default transfer type, and sends files in the mode specified for each file's extension. All 
extensions are sent in binary mode unless they are listed in the ASCII Extensions list. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

RENAME RULES  

You can configure CuteFTP to change the name of files automatically they transfer. 

To configure the Rename Rules  

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Transfer node, then click Rename Rules. The Rename Rules options appear. 

3. Configure options as described below.  

 Select the Apply auto-rename rules to transfers check box to change the names of 
transferred files with names that appear in the Rename Rules list. Clear this check box 
and CuteFTP will not rename any files. 

 To create an auto-rename rule, type the original file name in the text box on the upper 
left, type the desired new file name in the text box on the upper right, then click Add. 

 To remove an auto-rename rule, in the Rename Rules list, click the rule you want to 
delete, then click Remove. 

o The rules are case sensitive. 

o These rules will apply to all uploads, downloads, and site-to-site transfers.  

o You can create rules with wildcard masks to change just the extension of several 
files of the same type. For example, if your .jpg files need the extension in upper 
case (.JPG) on the server, create the rule:  

Rename from Rename to 

*.jpg *.JPG 
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o You can create a rule to strip extensions from file names. For instance if you 
want to transfer a file called "index.htm" as simply "index" add this rule to your 
list:  

Rename from Rename to 

index.htm index.* 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

CONFIGURING NAVIGATION OPTIONS 

To configure the navigation options 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Navigation node. The Navigation options appear. 

3. Configure options as described below.  

 In the When adding items to the queue box, click one of the following actions: 

o Transfer immediately to start transfer of the queued item as soon as it is 
dropped in the queue. 

o Suspend to place the item in the queue, but to hold the transfer. 

o Schedule to display the scheduling window when an item is placed in the queue. 

 In the When dragging an item to the local pane box, click one of the following actions: 

o Transfer to current folder to send the dragged item to the folder currently listed 
in the Local Drives pane 

o Transfer to default folder to send the dragged item to the default transfer folder 
listed in General Settings 

o Add to queue & suspend to place the dragged item in the queue, but hold the 
transfer. 

 In the When double-clicking an item box, click one of the following actions: 

o Transfer immediately to send the item to the displayed remote site or the 
default download folder 

o Add to queue & suspend to place the double-clicked item in the queue, but hold 
the transfer 

o Launch in viewer to open the item in the File Viewer program chosen in Helper 
Applications  

o Execute to run the item if it is a program  

o Edit to open the item in the File Editor program chosen in Helper Applications  

 Select the Auto-refresh the remote pane after an upload check box to update the remote 
folder's listing after every upload to that folder. Clear this check box to stop sending LIST 
requests to a remote site after every upload. 

 Select the Use the logical parent (not physical parent) on CDUP command check box to 

return to the folder you just linked from when clicking the Move up directory icon . Clear 
this check box to change to the actual folder the item resides in, and not a folder with a link 
to the item, when clicking the Move up directory icon. 
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4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

TOC FILE SETTINGS 

You may connect with remote folders that have Table of Contents (TOC) files. TOC files contain detailed 
information about the folder. In long and complicated directories, the TOC files can be quite large. If you 
download very large TOC files, they may interfere with CuteFTP's performance or operation. 

To configure the TOC File settings 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Navigation node, then click TOC Files. The TOC Files options appear. 

3. Configure options as described below.  

 Select the Load TOC Files check box to download TOC files automatically whenever 
connecting to a remote folder. If you clear this check box, TOC files are not downloaded. 

 In the If the TOC file size exceeds n Kbytes, then prompt before loading box, specify the 
maximum size (between 1 and 1,000 kilobytes) TOC file CuteFTP downloads without 
prompting for permission. 

 In the TOC include masks box, type file names or extensions that CuteFTP should consider 
as TOC files, then click Add. You can use wildcard masks. To remove a mask, click it in the 
list, then click Remove.  

 In the TOC exclude masks box, type file names or extensions that CuteFTP should NOT 
consider as TOC files, then click Add. You can use wildcard masks. To remove a mask, click 
it in the list, then click Remove. 

 

The TOC include masks and the TOC exclude masks act as a double filter to help CuteFTP 

determine whether a file is a TOC file. For example, if you type Index* in the TOC include 

masks and *.html in the TOC exclude masks, a file named Index.txt would be considered a 
TOC file, but a file named Index.html would not. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

CONFIGURING HOW CUTEFTP HANDLES SYMBOLIC LINKS 

You can determine how CuteFTP handles symbolic links. Symbolic links are similar to shortcuts, in that 
they point to items in other locations on a server. 

To configure the Link options 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Navigation node, then click Links. The Links options appear. 

3. Configure options as described below.  

 Select the Attempt link resolution using LIST-L command check box to send the LIST-L 
command instead of LIST to display folder contents. LIST-L attempts to list the actual file or 
folder rather than the link that points to the file or folder. Clear this check box to send just the 
LIST command to display folder contents and leave links in the list. 

 

Servers are not always able to resolve links using LIST-L. 
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 Select one of the following options: 

o Try to determine the link's target type by its extension - CuteFTP tries to tell 
if the link points to a file or a folder. CuteFTP treats the link as if it were the item it 
references. 

o Always assume the link is a file (don't attempt to resolve) - treats symbolic 
links as files. If you download the link, it displays as a file with size 0 in your local 
folder.   

 

This option is useful when you download large directories or folders with many files 
and subfolders.  

o Always assume the link is a folder (don't attempt to resolve) - treats 
symbolic links as folders that you can double-click to see folder contents. 

 

CuteFTP attempts to show the actual path of a file or folder link in the Remote pane, 
in the Name column. For example, a link to a file called archive.zip might display as 
.3/networks/bbs_info/archive.zip. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

CONFIGURING TOLERANCE OPTIONS  

Some servers treat PASV mode and links differently than others. Configure from the tolerance options to 
help CuteFTP connect to these servers. 

To configure the Tolerance settings 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Navigation node, then click Tolerance. The Tolerance options appear. 

3. Configure options as described below.  

 When using PASV mode, select the Use correct timing of PASV mode command check 
box. This option works with most FTP servers. If you are having difficulty connecting in 
PASV mode, clear this check box. 

 To use the Print Working Directory (PWD) command to determine which remote folder is 
currently open on the server, select the Use PWD to determine current folder check box. 
Clear this check box and CuteFTP attempts to determine the current remote folder based 
upon the relative location from the root login folder. If your server does not support PWD, 
clear this check box. 

 To send the absolute path to the file to complete delete, download, or upload file operations, 
select the Use absolute paths for DELE, RETR, and STOR commands check box (e.g., 
"RETR /pub/cuteftp/cuteftp.exe"). If your server does not support absolute path names for 
these commands, clear this check box, and CuteFTP will send the relative path to the file 
instead (e.g., "RETR cuteftp.exe"). 

 To use the complete absolute path to retrieve the listings for a folder, select the Use 
absolute paths for the LIST command check box. For example: "LIST /pub/cuteftp". If your 
server does not support absolute path names for the LIST command, clear this check box, 
and CuteFTP will use the relative file path to retrieve the listings for a folder (e.g., "LIST"). 

 To retrieve a list of just file names for each folder, select the Use NLST instead of LIST 
(retrieves an abbreviated listing) check box. The list does not include time stamps, file 
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size, or other details. Clear this check box to use the LIST command and retrieve a list with 
details for each file and folder. 

 To continue login attempts if the server returns permanent errors (5xx) inappropriately, such 
as when the server is full or busy, select the Treat 5xx errors as 4xx errors during login 
check box. To accept permanent errors, stop further connection attempts, and avoid being 
banned for hammering, clear this check box. 

 

Selecting this option may result in being banned from a server. CuteFTP will repeatedly try to 
connect to the server (according to retry and retry delay settings). If the retry delay period is set 
too low, these repeated attempts may end up being considered "hammering," and the server 
administrator or service may ban your accounts. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

CONFIGURING DISPLAY SETTINGS 

The display settings determine the way in which toolbars, icons, and fonts appear in dialog boxes. 

To configure CuteFTP display settings 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Display node. The Display options appear. 

3. To specify which toolbars to display, in the Select the toolbars to display list, select their check 
boxes. 

4. To add or remove buttons on the toolbar, with a toolbar in the list selected, click Customize 
selected toolbar. (The Custom Commands and the Quick Connect toolbars cannot be 
customized.) The Customize Toolbar dialog box appears.  

o To add a button, click it in the Available toolbar button s list, then click Add. 

o To remove a button, click it in the Current toolbar buttons list, then click Remove. 

o To move a button on the toolbar, click Move Up to move a button one icon to the left, 
click Move Down to move the button one icon to the right on the toolbar.  

o To accept changes, click Close; to cancel changes, click Reset. (Reset only backs up 
changes made since the dialog box was opened. Changes are applied after you click 
Close.) 

5. To display the large (32x32 pixel) set of main toolbar icons, select the Show large toolbar icons 
check box. Clear this check box to display the small (16x16 pixel) set of main toolbar icons. 

6. To hide the Quick Connect bar upon connection to a site, select the Auto-hide Quick Connect 
bar check box. Clear this to cause the Quick Connect bar to stay in view upon connection to a 
site. 

7. To display small icons in the menus next to commonly used menu items, select the Display 
menu icons check box.  

8. To display a thin blue line at the top of the pane that has the focus, select the Highlight active 
pane check box. 

9. To display borders between rows and columns in the queue window, and in the Local and 
Remote panes when in Detail view, select the Show grid lines on all view panes check box. 
Clear this check box to hide all borders between rows and columns. 
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10. To specify whether to show files in bytes, KB, MB, GB, in the Display File Sizes in box, click one 
of the following options: 

o Adaptive - CuteFTP decides when to show files in bytes, KB, MB, or GB. 

o Kilobytes - CuteFTP always displays values in KB. 

11. To adjust the font type and size display of all text in the Local Drives tab, Queue pane, and 
Remote pane, click Local, Remote, Queue Pane Font. 

12. To sort file lists by the value of each digit or by whole number values, in the Sorting area, select 
one of the following options: 

o To sort file lists by the value of each individual digit, select Use standard lexicographic 
sorting for alphanumeric file names.  

o To sort file lists by whole number value, select Use Smart Sorting for alphanumeric file 
names. 

 

Smart Sorting always lists file names with smaller numbers first. For example, A2 comes 
before A12. David Wincelberg developed Smart Sorting. CuteFTP uses it by default. Standard 
Lexicographic sorting lists file names using one character at a time reading from left to right. 
For example, A12 comes before A2. MS Windows uses Standard Lexicographic sorting by 
default. 

 

Smart Sorting Standard sorting 

FileA1.ext FileA1.ext 

FileA2.ext FileA12.ext 

FileA6.ext FileA2.ext 

FileA9.ext FileA20.ext 

FileA12.ext FileA21.ext 

FileA20.ext FileA6.ext 

FileA21.ext FileA9.ext 

13. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

SOUND OPTIONS 

The Sounds page is used to assign a sound to a specific event. For example, you might want to hear a 
beep when there is a transfer error. You must select the Add sounds check box for the Events list to 
become active (i.e., so you can add sounds to events). 

To configure sound options 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Display node, then click Sounds. The Sounds options appear. 

3. Configure options as described below.  

 To hear audio cues for certain events in CuteFTP and to edit the sounds associated with 
events, click Add sounds. Clear this check box to silence all sounds from CuteFTP and 
disable sound association editing. 

 The Event column lists possible CuteFTP events.  
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 The File column displays the path to the associated sound. If there is nothing in the File 
column, the event does not have a sound associated with it.  

o To add a sound to an event, click the event, then in the File box, browse or type the 
path to a sound that you want.  

o To remove a sound from an event, select it, and then click None. 

 You can preview the sound by clicking the sound, then clicking the speaker icon. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

SPECIFYING THE DEFAULT LANGUAGE  

CuteFTP's user interface resources are independent from the main application executable and are 
contained in a file called Default.lng. You can modify the text and dialogs displayed in the program or 
localize the entire resources in order to use CuteFTP in your own language. The Global Options dialog 
box Language page is used to select the language file. If you have the applicable language pack 
installed for the operating system, CuteFTP will support the language and special characters. 

To specify which language file to use 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Display node, then click Language. The available Language Files appear. The 
Language File Information list displays information about the selected language file, including 
the language and version number. 

3. In the Language File list, click a language file to use, click OK, then restart CuteFTP. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

Creating a Customized Language File 

You can use tools such as Microsoft Visual Studio and Resource Hacker to create your own customized 
language file. 

 

This topic is for advanced users only. Do not attempt if you are unfamiliar with Visual Studio or Resource 
Hacker. The procedure below is provided as a courtesy. GlobalSCAPE Technical Support does not provide 
support for Visual Studio or Resource Hacker.  

CuteFTP's License Agreement contains specific language prohibiting reverse engineering, decompiling, or 
otherwise modifying the application or any one of its components. You are permitted to modify the resource 
file for your own personal use on your own system only. You are not allowed to distribute your modified 
resource file to anyone other than GlobalSCAPE Technical Support. 

To modify the resource file using Microsoft Visual Studio 

1. Locate the default.lng file in the CuteFTP installation folder. 

2. Make a copy of this file in the same folder and rename it with a dll extension. For example: 
custom.dll. 

3. Launch Visual Studio.  

4. On the main menu, click File > Open. The Open dialog box appears. 

5. In the Look in box, locate the CuteFTP installation folder. 

6. In the Files of type field, click Executable Files (.exe; .dll; .ocx). 
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7. In the Open as box, click Resources. 

8. Click the resource dll file you just created, then click Open. 

9. In Visual Studio's main editor, click one of the resource folders, such as String Table. 

10. Modify the resource strings. Take care to not modify dynamic string placeholders (i.e. %d or %s) 
or escape sequences (\n). The "&" sign represents a mnemonic and must remain intact. 

11. After you have completed your modifications, on the main menu, click File, then click Save. 

12. Close Visual Studio. 

13. Locate the resource dll you just modified. 

14. Change its extension back to lng. For example: custom.lng. Be sure to save it in the CuteFTP 
installation folder. 

15. Launch CuteFTP. 

16. On the main menu, click Tools > Global Options (or press ALT+F7). 

17. Expand the Display node, then click Language. The Language options appear. The language 
file you created appears in the Language File column. 

18. Click the new language file, click OK, then restart CuteFTP.  

To modify the resource file using Resource Hacker 

Follow the same steps as above with the following exceptions: 

 When opening the dll file in Resource Hacker, select Win32 PE files as the Files of type. 

 As you edit the resources of each node in the resource tree, make sure to select COMPILE 
SCRIPT after making changes to that node. 

 Remember to save your changes (on the main menu, click File > Save). Resource Hacker 
automatically makes a backup of the original dll file. All other steps are the same as in Visual 
Studio, including the naming of the file back to something.lng and the steps on how to load it in 
CuteFTP. 

VIEWING AND EDITING HTML FILES 

CuteFTP comes with a built-in HTML editor with which you can view and edit HTML files both on your 
local drive and on remote servers. Alternately, you can specify a third-party application to view and edit 
files (such as Notepad, EditPlus, Microsoft Front Page, and so on). 

Note the difference between Opening and Viewing a file: 

 On the main menu, click File > Open (or press CTRL+E). The file opens in your browser (e.g., 
Internet Explorer). 

 On the main menu, click File > View (or press CTRL+W). The file opens in the HTML editor that 
you specify in the Helper Applications node. If you are using the built-in HTML editor, the file 
opens in the right pane, showing the HTML code. (You can change from tabbed view to full 
screen on the HTML Editor Settings page.) 

 On the main menu, click File > Edit (or press CTRL+ENTER). The file opens in the HTML editor 
that you specify below. If you are using the built-in HTML editor, the file opens in the right pane, 
showing the HTML code. (You can change from tabbed view to full screen on the HTML Editor 
Settings page.) 

 

If you open an HTML file in the built-in HTML editor by clicking File, then clicking View, you can still 
edit and save the file. 
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To access Helper Applications 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Helper Applications node. The Helper Applications options appear. 

3. Configure options as described below.  

 To view files in CuteFTP's built-in HTML editor, select the Use the integrated HTML 
editor to view files check box.  

 To specify the application in which to view files, in the File Viewer box, clear the check 
box, then browse for or type the path to the program you want to use. 

 To open files for editing in CuteFTP's built-in HTML editor, select the Use the integrated 
HTML editor to edit files (recommended) check box. The HTML code for the file 
appears in the right pane. (You can change from tabbed view to full screen on the HTML 
Editor Settings page.) On the main menu, click File, then click Save (CTRL+S) or Save 
As to save your changes. 

 To open files for editing in another editor, clear this check box, then in the File editor 
box, browse for or type the path to the program you want to use. 

 

When you edit remote files in a third-party editor, CuteFTP launches the editor and then 
monitors the folder containing the temporary file being modified. After you save your 
changes, CuteFTP uploads the changes to the server.  

If you prefer to use a direct editor, but find the integrated editor too limited in functionality, 
consider trying out our CuteHTML Pro tool. It is powerful editor for working with HTML, 
ASP, PHP, Perl, and many more file types. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

HTML EDITOR SETTINGS 

To view or edit HTML Editor settings 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Helper Applications node, then click HTML Editor. The HTML Editor options 
appear. 

3. Configure options as described below.  

 To display the editor in full screen, select the Display editor using Full Screen view 
check box. To display the editor as a tab in the CuteFTP window, clear the check box. By 
default, CuteFTP displays the HTML editor in tab view mode.  

 To add line breaks at the right end of long lines, so that you can see entire lines of code 
without scrolling to the left or right, select the Enable word wrap check box. Clear this 
check box and the HTML editor will use line breaks where you add them. You might have 
to scroll to the right to see the ends of longer lines of code. 

 To display numbers at the beginning of each line of code, select the Prefix each line 
with line numbers check box. If word wrap is enabled, the numbers will only display 
after line breaks you have entered. The line numbers are not saved as part of the 
document. Clear this check box and no line numbers will be displayed. 

 To allow the cursor to keep moving to the right after the last character in a line, select the 
Allow editing beyond the end of line check box. Clear this check box to force the 
cursor to return to the left end of the following line after the last character in a line. (The 

http://www.cuteftp.com/cutehtmlpro/
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Allow editing beyond the end of line check box is only available if Enable word wrap 
is cleared.) 

 

If you disable Allow editing beyond the end of line, you can still add more characters after 
the right-most character. 

 To specify the number of spaces you want the cursor to move to the right when you hit 
the TAB key, in the Tab size box, type a number from 1 to 32. 

 To change the HTML code and text that is generated automatically when you start a new 
document in the HTML editor, click Edit new document template. The template appears 
for you to edit. When you have finished making changes, click Close. 

 To specify the type, style, and size of the font displayed in the HTML Editor, click Choose 
font for editor. After you make changes, click OK; to abort the changes, click Cancel. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

SPECIFYING DISPLAY COLORS USED IN THE HTML EDITOR 

To specify display colors for HTML tags and Perl scripts 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Helper Applications node, expand the HTML Editor node, then click Colors. The 
HTML Editor Colors options appear. 

3. Configure options as described below.  

 For each HTML tag set and for Perl script components, select a color from the drop-down 
lists. 

 To use the system default colors for the background (white) and text font (black), select 
the Use system settings check box.  

 To choose different colors for the background and text font, clear the Use system 
settings check box, then in the Background and Text font drop-down lists, specify the 
colors.  

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

SPECIFYING THE FOLDER FOR STORING HTML CODE SNIPPETS AND 
JAVA SCRIPTS 

To specify the folder for code snippets and previewing HTML documents from CuteFTP 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Helper Applications node, expand the HTML Editor node, then click Folders. The 
HTML Editor Folders options appear. 

3. Configure options as described below.  

 To specify a browser other than the default, clear the Preview using the default 
browser check box, then in the Browser path box, browse for or type the path to the 
browser executable file. 
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 To specify the folder in which you want to store code snippets, in the Code snippets box, 
browse for or type the path. 

 To specify the folder in which you want to store Java scripts, in the Java scripts box, 
browse for or type the path. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

SPECIFYING HTML TAGS TO USE FOR A SPECIFIC BROWSER 

The HTML Editor can automatically provide suggestions for HTML tags that work for specific browsers. 
The HTML Editor offers HTML tag choices in drop down boxes. These are called tag tips.   

W hen more than one primary browser is selected, the tag tips in the drop down that are common to both 
browsers display in black. This enables you to code for two types of browsers, such as Firefox and 
Internet Explorer, or two versions of the same browser. 

For example, if you want to code for IE 5.0, but maintain backwards compatibility with 4.0, then choose 
5.0 and 4.0 as the two primary browsers. Tags in common to both are available in the tag tips box. Newer 
5.0 tags that did not exist in 4.0 do not appear, which helps you code your HTML without having to worry 
about which tag are supported. 

Choosing a secondary browser lets you see ALL the tags for a certain browser in a different color. In the 
example above, if you wanted to code for IE 4.0 and 5.0 but add certain tags from OPERA, you would 
select OPERA as the secondary browser. When you saw a colored tag in the tag tips box, you would 
know it was an OPERA tag, which may or may not work in IE or Firefox helping you to decide whether to 
insert the particular tag. 

To show tag tips 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Helper Applications node, expand the HTML Editor node, then click Tag tips The 
HTML Editor Tag tips options appear. 

3. Configure options as described below.  

 To show tag tips, select the Show tag tips check box. Clear the Show tag tips check 
box to keep tag tips hidden. 

 To display tag tips that are supported only by the first primary browser, select the browser 
in the First primary browser tags list. 

 To display tag tips that are supported by the first and second primary browser, select the 
browser in the Second primary browser tags list. 

 To display tag tips that are supported by the secondary browser, select the browser in the 
Secondary browser tags list. 

 To specify a color for the tags that are supported by the secondary browser, select the 
color in the Secondary browser color list. 

 To specify how long the tag tips take to appear, in the Tag tips delay in milliseconds 
box, type a time for the HTML editor to wait before showing tag tips. 

 To capitalize all tag tips, select the Capitalize tag tips check box. Clear the Capitalize 
tag tips check box to leave tag tips in lower case. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 
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IMPROVING CUTEFTP PERFORMANCE WHEN TRANSFERRING LARGE 
NUMBERS OF FILES AT ONCE 

A few changes to CuteFTP's default settings can improve CuteFTP performance if you regularly transfer 
a large number of files at the same time. For example, making a few adjustments to the settings in 
CuteFTP's Global Options can prevent the initial connection from being used for transfers and/or improve 
the responsive of CuteFTP.  

To improve CuteFTP performance 

1. Open the Global Options dialog box. On the main menu, click Tools > Global Options (or press 
ALT+F7). 

2. Adjust the following settings as needed: 

o Allow transfers to occur over the existing (browse) session: 

When you transfer more than the (user-configurable) maximum number of files at the 
same time, CuteFTP will use the initial connection to the Server for one of the file transfer 
connections, known as the "browse" session. When this occurs, an hourglass can 
intermittently appear and CuteFTP becomes unresponsive as the files are transferring 
and using the connection. Also, scheduled transactions cannot occur if all of the available 
connections are in use.  

a. Click the Transfer node. 

 

b. In the General area, clear the Allow transfers to occur over the existing (browse) 
session check box. The check box is selected by default, because most users want 
their transfer to occur quickly and are not likely to be browsing while a large number 
of transfers are in progress. 

o Adjust the allowed number of concurrent transfers: 

Allowing a very large number of concurrent transfers can cause CuteFTP to monopolize 
the computer’s CPU. Avoid adjusting these settings, unless you are willing to spend 
some time optimizing CuteFTP to your particular CPU and network capabilities. For 
example, on a broadband connection with a 1 Ghz+ CPU, it might be more appropriate to 
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set Global max concurrent transfers to 120 and Per site concurrent transfers to 40. 
Keep in mind that if the FTP server does not support the requested number of multiple 
connections, connection errors will occur when these settings are increased. One of the 
reasons this setting exists is to prevent CuteFTP from trying to open more connections 
than the server allows. 

a. Click the Connection node. 

 

a. Increase the defaults for Global max concurrent transfers (the default is 12) and 
Per site max concurrent transfers (the default is 4) to allow CuteFTP to open more 
transfer connections simultaneously. 

Regardless of these settings, CuteFTP can become unresponsive if you are sending 
more files than the maximum. 

o Adjust the log storage settings: 

By default, saved logs are deleted every 3 days. You can delete them more frequently if 
you transfer large numbers of files frequently. If you want to keep logs indefinitely, be 
aware that this may adversely affect performance of CuteFTP and/or quickly fill up disk 
space.  

a. Expand the General node, then click Log Files. 
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b. By default, saved logs are deleted every 3 days. In the boxes next to the Delete 
saved logs every check box, you can set the frequency to between 1 to 1000 
minutes, hours, or days. Clear the check box if you do not want to delete the logs 
automatically, but be sure to delete them manually periodically to avoid filling up the 
hard drive. 

c. (Available in Pro and Home only) Select the Delete item logs of successful 
transfers immediately after completion check box. By default, this check box is not 
selected, but selecting it could improve the performance of CuteFTP when 
downloading a large number of files. 

Alternately, you can delete all logs that are not currently associated with an open 
connection or an item listed in the transfer queue, by clicking Delete all logs. (Be sure to 
close connections and clear out the queue before you click Delete all logs to ensure that 
all logs are deleted.) 

o Adjust the Queue cleanup settings: 

A large number of items in the Queue use up memory and resources that can be freed by 
simply keeping the Queue clean. Removing completed transfers from the Queue could 
help improve the performance of CuteFTP when downloading a large number of files. 

a. Expand the Transfer node, then click Events. 
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b. By default, the Remove successful transfer items from the queue automatically 
check box is not selected. Selecting this check box could help improve the 
performance of CuteFTP when downloading a large number of files, by keeping the 
Queue clean. 

Alternately, you can manually empty the queue periodically by clicking Tools > Queue > 
Remove All or by right-clicking in the queue, then clicking Remove All,  but if the browse 
session is being used for transfers, manually removing items from Queue might prove 
difficult. 

o If you have a particularly fast (broadband) connection, you can delete the 
thumbnail cache: 

Enabling Thumbnail cache expiration ensures that the thumbnail cache will periodically 
be cleared; however, it also will cause the FTP session to re-download thumbnails, which 
can take a significant amount of time on a dial-up connection. 

a. Expand the General node, then click Log Files. 
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b. In the Thumbnail settings area, set When the transfer engine exits to Delete 
images older than the value specified. 

c. In Thumbnail cache expiration, set the expiration to an appropriate time. (This 
setting becomes editable after you set When the transfer engine exits to Delete 
images older than the value specified.)  

Alternately, you can click Delete thumbnail cache to delete all thumbnails in the cache 
except those that are currently displayed in the application. (Turn off thumbnail view or 
close all connections before clicking Delete thumbnail cache to ensure all thumbnail 
files are deleted.) 

3. Click OK to close the Global Options and save the changes. 



 

Connecting to Sites ● 55 

CONNECTING TO SITES 

You can connect to any site listed in the CuteFTP Site Manager. You must be connected to the Internet 
before you can connect to any sites. CuteFTP can connect to sites using FTP, FTPS (SSL), TLS (SSL 
v3), and SSCN (SSL Site-to-Site transfer). (To add an FTP site to the Site Manager, refer to Adding a Site 
to the Site Manager.) 

To connect to an existing site within the Site Manager  

1. On the main menu, click Tools > Site Manager > Display Site Manager. 

2. Expand a folder in the list, then click a site. 

3. Do one of the following: 

 On the main menu, click File > Connect > Connect. 

 On the toolbar, click the Connect icon . 

 Double-click the selected site. 

 Press CTRL+T. 

 

You can also connect to a site by clicking File, Connect, then clicking Connect to URL. 

CONNECTING TO A SITE USING THE CONNECTION WIZARD 

CuteFTP allows you to connect to a Web site to upload and download files between a server and your 
local computer. To transfer files, you must log on to that server through your FTP client computer. 
CuteFTP Connection Wizard helps you to define a site to which you want to connect and saves the 
information in the Site Manager for future connections. 

 

The Internet Service Provider (ISP) or Web Hosting Provider to which you want to upload files provides you with 
the username, password, and FTP account information required to connect to their server. Many providers 
offer this information on their Web support pages. Refer to the GlobalSCAPE Knowledge Base articles at 
http://kb.globalscape.com/ for information about FTP connections to your AOL or Roadrunner accounts or 

search your provider's support pages for keyword ftp.  

To connect to an FTP site 

1. Gather the information that you need to make a connection:  

 Host Address - the IP address or FTP domain address that your ISP gave you to log in 
to the FTP site (e.g., 64.243.64.21 or ftp.example.com).  

 User Name - the user name your ISP gave you to log in to the FTP site. Your username 
is often the part of your email address in front of the @ sign. 

 Password - the password your ISP gave you to log in to the FTP site. This is often the 
same password you use to download your email. 

 Site Name - By default, the Site Name is the same as the Host Address, but you can 
name it anything you want; it is not provided by your ISP or GlobalSCAPE. 

2. Do one of the following: 

 On the main menu, click File > Connect, then click Connection Wizard. 

 On the toolbar, click the Connection Wizard icon .  

http://kb.globalscape.com/
http://kb.globalscape.com/article.aspx?id=10148
http://kb.globalscape.com/article.aspx?id=10325
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 Press CTRL+J. 

The CuteFTP Connection Wizard appears. 
 

 

3. In the Host Address field, type the IP address or FTP domain address that your ISP gave you to 
log in to the FTP site.    

4. The address that you typed in the Host Address field appears in the Site Name field. You can 
leave it as is, or type a descriptive name for this site. The site name will appear on the Site 
Manager tab. 

5. Click Next. The login page appears 

6. In the User Name box, type the user name your ISP gave you to log in to the FTP site.  

7. In the Password box, type the password your ISP gave you to log in to the FTP site. 

8. Specify a login method from the following options. 

 Normal - The user name and password are mandatory to connect to a site. 

 Anonymous - The site does not require any user name and password. 

 Double - The user name and password are required twice to connect to a site. 

9. Click Next. The Connecting to Site message appears. 

 If you need to change the host address or do not want to log in, click Cancel. 

 If the connection fails, an error message appears. Click Yes to close the message, then 
click Back to verify/correct the host address, username, and password. (If the connection 
fails again, refer to Troubleshooting.) 

10. After you are connected to the FTP site, the default folders page appears. 

11. In the Default Local Folder field, click the folder icon  to browse for the default folder from 
which you want to upload/download files to/from the server. 

12. In the Default Remote Folder field, type the path of the remote folder from/to which you want to 
upload files.  

13. Click Next. The Connection Completed page appears. 

14. Click Finish. Cute FTP connects to the site and saves the site in the Site Manager.  
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For subsequent connections to this FTP site, refer to Connecting to a Site. 

Refer to Configuring Connection Options for details of how to configure the number of simultaneous 
connections you will allow from CuteFTP, number of times CuteFTP tries to connect to a site before 
giving up, how long CuteFTP should wait before attempting a new connection after a failed connection, 
and so on.  

CONFIGURING CONNECTION OPTIONS 

In the Global Options dialog box, you can configure the number of simultaneous connections you will 
allow from CuteFTP, number of times CuteFTP tries to connect to a site before giving up, how long 
CuteFTP should wait before attempting a new connection after a failed connection, and so on.  

To configure connection options 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Connection node. The Connection options appear. 

3. Configure options as described below. 

 To specify the number of simultaneous connections you will allow from CuteFTP, in the 
Global max concurrent transfers box, specify the number of connections.  

o You can choose up to 200 connections, but CuteFTP will warn you that more 
than 20 connections may compromise system performance.  

o Connections include transfers and browse sessions. 

 To specify the number of simultaneous connections you will allow from CuteFTP per site, 
in the Per site max concurrent transfers box, type or select the number of connections. 
(Same as Global max but on a per site basis.) 

 

If you choose to allow only one connection per site, you must transfer files over the browse 
session only (you can navigate or transfer, but not both at the same time). This may be 
needed in situations where the server does not allow more than one connection from the 
same user. If the server allows more than one connection, then it is recommended that you 
use a value greater than one (e.g., the default of 5). That way you can transfer files and at 
the same time continue to navigate the site.  

 To specify the number of times CuteFTP tries to connect to a site before giving up, in the 
Connection retry attempts box, type or select the number of attempts. You can set 
CuteFTP to try connecting up to 1,000 times. 

 To specify how long CuteFTP waits before attempting a new connection after a failed 
connection, in the Delay between retries in seconds box, choose up to 1,000 seconds 
(about 17 minutes). 

 

CuteFTP does not automatically retry after fatal errors, such as a host unreachable (invalid IP 
address or host name), or upon receiving a socket 1006n error, which usually has to do with 
the client not being able to connect to the host for various reasons (firewall blocking, network 
error, host is down, etc.).  

 To specify how long CuteFTP waits for an unresponsive server before it stops attempting 
a new connection, in the Connection timeout in seconds box, type or select up to 
1,000 seconds (about 17 minutes). 

 To specify the address that you want to send to servers that require an email address for 
anonymous log ins, in the Email address for anonymous logins box, type the email 
address. By default, CuteFTP sends a simulated email address.  
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 To display a pop-up window with information from the server when initial connections are 
successful, select the Display the server's welcome message check box. Clear this 
check box to skip the server's successful connection message. 

 To ask the server for a list of extended features it supports, select the Send the FEAT 
command after login to determine feature support check box. Clear this check box to 
stop sending the FEAT command. 

 

FEAT is used to determine whether extended features are supported, such as MDTM, MLST, 
and others. Not all servers support the FEAT command.  

 To send the QUIT command from CuteFTP no matter how you choose to disconnect, 
select the Send QUIT command before disconnecting check box. Clear this check box 
to disconnect without sending the QUIT command. 

 To use the UPnP NAT interface (available in Windows XP) to provide proper port 
mapping when connecting securely from behind a NAT/firewall using PORT mode (rather 
than PASV, due to the remote host also being behind a NAT/firewall), select the Enable 
port mapping using UPnP check box. Without UPnP, you would need to manually set 
the port range in the client and also enable and forward them in the NAT/firewall device. 

 

You can choose Max connections, Delay between retries, and Retry attempts for individual 
sites. In the Site Manager, click the Options tab. 

 To specify an IP address and define a port range when establishing connections using 
PORT mode, select the Assign PORT mode IP address and port range check box, 
then specify the IP address and port range. Typically, this setting should be turned off, 
but if you are using SSL and are having difficulty negotiating a firewall, it may help to 
specify your public FTP address here to enable CuteFTP to negotiate with the firewall or 
NAT. Optionally, you can specify a range of ports for issuing port commands. 

 

Use local port range when you have a defined limited number of open ports on your firewall. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

USING QUICK CONNECT 

Use the Quick Connect toolbar to make speedy connections to your FTP sites.  

 

The Quick Connect toolbar has the following fields and icons: 

Host - The name or TCP/IP address of the FTP server. The Host box is a drop-down list; by clicking on 
the arrow to the right of the field, you can access a list of the last several sites accessed during the 
current session via Quick Connect.  

User Name - Type your user name or leave it blank for anonymous FTP.  

Password - Type the associated password if not connecting anonymously.  

Port - If you are not connecting to the default FTP port (21), type the appropriate port here.  

 Connect - Activates the connection to the site specified in the fields. You can also connect by 
pressing the Enter key while the cursor is in one of the boxes.  

 Site Properties - Allows you to set connection options for the site.   
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 Add to Site Manager - Automatically creates a Site Manager entry for the site specified in the Quick 
Connect bar, so that you can easily access it in the future.  

The Quick Connect bar can be moved or undocked by clicking and dragging on the vertical bar at the 
left-hand edge of the bar.  

To connect using the Quick Connect toolbar 

1. If the Quick Connect Bar is not displayed, click View > Toolbars > Quick Connect Bar, or 
press CTRL+F8. 

2. In Host box, type or select from the Host drop-down list the Host to which you want to connect. 
The Host drop-down list displays the list of sites to which you have previously connected. 

3. In the Username box, type the user name you use to connect to this site. The user name you 
used previously will appear in the box. 

4. In the Password box, type the password you use to connect to this site. The password you used 
previously will appear in the box as dots. 

5. In the Port box, type the port number if different from the default FTP port (21). The port you 
connected through previously will appear in the box. 

6. Click the Connect icon . The files and folders in the remote server appear in the Remote 
(right) pane.  

CONNECTING TO AN HTTP SITE 

If you have the appropriate permissions, you can connect to an HTTP site, browse its contents, 
download, upload, and delete files.  

To connect to an HTTP site  

1. Do one of the following: 

 On the main menu, click File > New > HTTP Site.  

 On the toolbar, click the arrow next to the New Site icon , then click HTTP Site. 
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The Site Properties for dialog box appears. 
 

 

2. In the Label box, type a descriptive name for the site. 

3. In the Host address box, type the address for the site. The address can be a domain address, 
such as ftp.globalscape.com, or an IP address, such as 192.168.20.52. Ask your hosting provider 
for the address. Prefixing the HTTP site address with http:// is not necessary. 

 

If you do not provide the correct address, then every time you try to connect to that site an error 
message like the one below is displayed. 

 

Click Details to view the details and log entries to determine the specific error. 

4. If the site uses basic HTTP username/password authentication, fill in your user name and 
password in the appropriate fields.  
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5. On the Type tab, the site has been automatically set up as an HTTP site.  
 

 

6. Most HTTP sites connect to port 80. If the Web site operates on a port other than 80, type the 
port number in the Port field. If the last portion of the site's URL ends in a number, that number is 
the port to use. For example, http://www.example.com:99 indicates that the Web server 
www.example.com operates on port 99. The remainder of the tabs and fields are identical to 
those seen when adding an FTP site.  

7. Select Connect to establish the connection or click OK to save the site in the Site Manager.  

CuteFTP takes advantage of the keep-alive header (as defined in RFC 2068 & 2616) which keeps the 
session open during multiple transactions, saving the user considerable time and bandwidth.  

 

The Web server must support basic authentication as described in RFC 1945 
<http://www.faqs.org/rfcs/rfc1945.html>. Because of the way authentication works, the server may challenge 

the client with a www-Authenticate request. The client responds with Authorization: Basic <base64 

encoding of user id-password>. Most Web Servers support basic authentication but require 
intervention on the site operator's behalf to set it up because it is server specific. Various sites employ other 
authentication schemes, such as NTLM or those found in ASP or Java Scripts, and are not supported by CuteFTP.  

CONNECTING TO SECURE SITES 

You can make secure connections and transfers with FTPS (SSL/TLS). 

To connect to a secure site 

1. Do one of the following: 

 On the main menu, click File > New > (FTPS (SSL) Site). 

 On the toolbar, click the down arrow next to the New Site icon , then click the type of 
site (FTPS (SSL) Site). 

The Site Properties appear.  

2. Provide the host address and login information. 

3. Click the Type tab.  

http://www.faqs.org/rfcs/rfc1945.html
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4. In the Protocol Type list, click the down arrow and click one of the following: 

 FTP with TLS/SSL (Implicit encryption) 

 FTP with TLS/SSL (Explicit encryption) 

 FTP with TLS/SSL (AUTH TLS - Explicit) 

The appropriate port appears depending on your selection. Certain servers support only 
one of the above SSL connection mechanisms.  

5. Click Connect to connect to the site now or OK to connect to the site later. 

SAVE LOCAL OR REMOTE PATH AS DEFAULT 

When you connect to a site, your My Documents folder is the default local folder, and the default remote 
folder is the folder that you specified when you configured the site. You can specify that a different local 
folder and/or remote folder to appear in the Local and Remote panes when you log in to a site.  

You can also configure sites to switch  to a local and/or remote filter that you specify in the Site 
Properties dialog box for each site. 

To save the local or remote path as the default 

1. Connect to the Site. 

2. In the Local pane, browse to the folder that you want to make the default. 

3. On the main menu, click Tools > Site Manager > Save Local Path as Default.  
 

 

4. In the Remote pane, browse to the folder that you want to make the default. 

5. On the main menu, click Tools > Site Manager > Save Remote Path as Default. 

The next time you connect to the site, the local folder that you specified as the default will appear 
in the Local pane, and the remote folder that you specified as the default will appear in the 
Remote pane. 

DISPLAYING A SPECIFIC FOLDER WHEN CONNECTING TO A SITE 

When you connect to a site, your My Documents folder is the default local folder, and the default remote 
folder is the folder that you specified when you configured the site. You can specify that a different local 
folder and/or remote folder appear in the Local and Remote panes when you log in to a site.  

You can also configure sites to switch to a local and/or remote filter that you specify in the Site 
Properties dialog box for each site. 

To switch to a remote or local folder when a site connects 

1. Display the Site Manager and view the Site Properties. 
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2. Click the Actions  tab. 
 

 

3. To switch to a specified remote folder when CuteFTP connects, in the When client connects, 
switch to this remote folder box, type the remote folder name, prepended with a forward slash. 

For example, type /mywebsite. 

4. To switch to a specified local folder when CuteFTP connects, in the When client connects, 
switch to this local folder box, click the folder  icon to browse to a select the local folder. 

5. Click Exit. 

STAYING CONNECTED TO SITES 

Smart Keep Alive (SKA) allows you to maintain connections even when you are not transferring files. SKA 
sends commands at random intervals to the FTP server, maintaining an active connection. If the server 
terminates the connection, CuteFTP automatically reconnects to the FTP site.  

To turn on/off Smart Keep Alive 

1. On the main menu, click Tools > Global Options. The Global Options dialog box appears. 

2. Expand the Connection node, then click Smart Keep Alive. 

3. In the right pane, select the Enable Smart Keep Alive (SKA) check box to turn on SKA; clear the 
check box to turn off SKA.  

4. Configure SKA as needed: 

 To set the time SKA waits before starting   

o In the Start SKA n seconds after the last command box, type or select a value 
between 0 and 1000. CuteFTP will begin using SKA after the specified idle time. 
(The default is 30 seconds.) 

 To set how long SKA will run   

o In the Maintain SKA for n minutes box, type or select a value between 1 and 
1000. (The default is 30 minutes.)  

 To set when SKA commands are sent 
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o In the Send command at random intervals between n and n seconds box, 
type or select values between 0 and 1000. (The default is between 15 and 60 
seconds.) SKA sends commands from the Commands list in random order.  

 To add a command 

o Click Add. The Input FTP Command dialog box appears. Type a command to 
add to the list, then click OK. 

 To remove a command 

o Click a command in the list, then click Remove.  

 To set how long CuteFTP waits before reconnecting  

o In the If disconnected, auto-reconnect within n seconds box, type or select a 
value between 1 and 1000 seconds. (The default is 10 seconds.) 

5. Click OK to save the settings and close the dialog box, or click Apply to save the settings without 
closing the dialog box. 

MAKING MULTIPLE CONCURRENT CONNECTIONS 

You can transfer files on one site while browsing another site, or browse a folder on a site while 
transferring files from the same site.  

Multiple Concurrent Sessions are depicted as multiple open windows in the Remote Pane (on the right 
side by default). You can tile, cascade, or minimize these windows. When the panes are maximized, 
select alternate sessions by clicking the tabs at their lower left border.  

To force CuteFTP to open new connections for multiple transfers 

1. On the main menu, click Tools > Global Options.  

2. Click the Transfer node. 

3. Clear the Allow transfers to occur over the existing browse session check box. 

To allow multiple connections from CuteFTP 

1. On the main menu, click Tools > Global Options.  

2. Click the Connection node. 

3. In the Global max concurrent transfers box, type or select a value between 1 and 200. 

To allow multiple connections to the same site 

1. On the main menu, click Tools > Global Options.  

2. Click the Connection node. 

3. In the per site max concurrent transfers box, type or select a value between 1 and 200. 

To enhance performance with limited resources  

 Limit the number of concurrent per site transfers allowed  

 Turn off individual transfer item logging in settings or turn off all logging options.  
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Performance Limitations 

 On a Windows 95/98/ME computer, you can only choose up to 40 concurrent connections. 

 On a Windows NT/2K/XP computer, you can choose up to 200 concurrent connections, but more 
than 40 connections may compromise system performance.  

 Connections include transfers, browser sessions, and every single thread in a multi-part transfer. 

 FTP sites that do not support multiple connections or sites that frequently drop the FTP 
connection will limit concurrent sessions.  

 Computer resources and slow hardware may limit or prohibit multiple connections. 

USING THE ACCT COMMAND 

You can establish a connection and then supply the ACCT command for servers that require it.  

To use ACCT with or without an FTP proxy  

1. In the Site Manager, click the site you want to change. 

2. Click the Options tab.  

3. In the Site-specific configuration options box, click Use site-specific options. 

4. Click Proxy. The Proxy dialog box appears. 

5. In the Proxy type list, click the proxy type (FTP or HTTP). 

6. In the Host name and port boxes, provide the same host and port as specified on the General 
and Type tabs.  

7. Select the Use authentication check box. The Username and Password boxes become 
editable. 

8. In the Password box, type the password (for ACCT).  

9. Click Advanced. The Advanced Proxy Settings dialog box appears. 
 

 

10. Do one of the following: 

 Click Custom, then add the following variables. Press ENTER after each variable: 

 USER %user%  
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 PASS %pass%  

 ACCT %fire_pass%  

 Click USER/PASS/ACCT.  

11. Click OK to save the settings and close the Advanced Proxy Settings dialog box. 

12. Click OK again to close the Proxy dialog box. 

13. Click Connect to connect now or OK to connect later.  

PROTECTING SITE MANAGER CONTENT 

To require a password to open the Site Manager 

1. On the main menu, click Tools > Site Manager > Security > Encrypt Site Manager Data. The 
Site Manager Encryption dialog box appears. 
 

 

2. In the Password and Confirm password boxes, type a password for opening the Site Manager. 
Create a password of at least 5 characters for maximum security. 

3. Click OK. CuteFTP will now display the following prompt every time it starts. 
 

 

To change the Site Manager password  

1. On the main menu, click Tools > Manager > Security > Change Password. The Site Manager 
Encryption dialog box appears. 

2. In the Password and Confirm password boxes, type a new password for opening the Site 
Manager. Create a password of at least 5 characters for maximum security. 

3. Click OK. The password is changed. 

To remove the Site Manager password  

 On the main menu, click Tools > Site Manager > Security > Remove Password. 

CuteFTP will not prompt for a password when it starts. 
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Configuration Notes 

 When the Site Manager Access Password is defined, the Site Manager information is protected with 
64-bit Blowfish encryption. 

 If you forget the password, you will not be able to use the protected Site Manager. You will have the 
option to back up the locked Site Manager and re-enter your site information in a new Site 
Manager. 

 You can import a password-protected Site Manager file, but will need the password to do so. 

PROXY CONNECTION SETTINGS 

To access proxy server settings 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Connection node, then click Proxy Server. The Proxy Server options appear. 

3. Configure options as described below. 

 To use the proxy settings already set in Internet Explorer to connect to FTP sites, select 
the Use network connection proxy settings from Internet Explorer check box. Clear 
this check box to connect to an FTP site without connecting through a proxy server, or to 
connect using proxy settings listed in CuteFTP. 

 

With this option, CuteFTP attempts to detect Internet Explorer's proxy settings, including 
proxy.pac proxy script files. This is only available for Windows XP SP1, W2K Pro SP3, W2K 
Server SP3, and W2K Server 2003 using WinHTTP dll. If that fails, WinInet dll, which is 
supported by XP, 2K PRO, NT4, ME, 98, and 95 is queried.  

 To connect to an FTP site through a proxy server, select the Use the highlighted proxy 
when connecting check box. Clear this check box to connect to an FTP site without 
connecting through a proxy server, or to connect using settings from Internet Explorer. 

 To make FTP connections through a specified server, click it in the Proxies list. 

o To add a server to the Proxies list, click Add, then type the server name in the 
Host name box.   

o To delete a server from the Proxies list, click it, then click Remove.  

 The Host name box displays the name of a server selected in the Proxies list. To edit 
the host name, click a server in the Proxies list, then edit the name in the Host name 
box. 

 The Port box displays the name of a server selected in the Proxies list. To edit the port, 
click a server in the Proxies list, then edit the name in the Port box. 

 In the Username box, type or edit the user name for the selected proxy server. 

 In the Password box, type or edit the password for the selected proxy server. 

 To match the protocol the selected proxy server supports, click FTP or HTTP. 

 To specify advanced authentication methods, click Advanced then click one of the 
following methods: 

o USER user @site if your proxy server requires the USER command followed by 
your user name and the site name to allow connection with a remote site. You 
can change the @ symbol if a different separator is required by your proxy 
server. 
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o SITE site if your proxy server requires the SITE command followed by the 
address of the remote FTP site to allow a connection.  

o USER with logon if your proxy server requires the USER command followed by 
a user name and password to allow connection with a remote site. 

o USER/PASS/ACCT if your proxy server requires all three commands before 
allowing a connection to a remote site. 

o OPEN site if your proxy server requires the OPEN command followed by the site 
name before allowing connection to the site. 

o Custom if your proxy server requires a login sequence different from those 
above. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

To create a custom authentication method for a proxy server 

1. Click Advanced. The Advanced Proxy Settings dialog box appears. 

2. Click Custom, then type a command in the text box. 

3. Follow the command with a space and the appropriate variable. Choose from: 

 %host% - sends the host name you typed in the Proxy server options window. 

 %user% - sends the user name you typed in the Proxy server options window. 

 %pass% - sends the password you typed in the Proxy server options window. 

 %port% - sends the port number you typed in the Proxy server options window. 

 %fire_pass% - sends the password you typed in the Proxy server options window as 
authentication for the firewall. 

 %fire_user% - sends the user name you typed in the Proxy server options window as 
authentication for the firewall. 

4. Enter each variable with percent signs before and after. 

5. Press ENTER to separate commands.  

6. Enter any other commands and variables, separating commands with a line break. 

7. Click OK. 

 

Contact your system administrator for the proper Host name, Port, User name, Password, and proxy type, as 
well as any required advanced authentication methods.  

SOCKS 4 AND 5 CONNECTION SETTINGS 

SOCKS is a network proxy protocol that allows transparent Internet connections across a firewall. 

To access SOCKS 4 and 5 settings 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Connection node, then click SOCKS4 & 5. The SOCKS4 & 5 options appear. 

3. Configure options as described below. 

file:///D:/WorkFolder/Technical%20Writing/CuteFTP/Help/Source/proxycustomauth
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 To connect to an FTP site through a SOCKS server, select the Use the highlighted 
SOCKS server when connecting check box. Clear this check box to connect to an FTP 
site without connecting through a SOCKS server. Then configure the options below: 

o To include a server in the SOCKS list, click Add, then type the server name in 
the Host name box.  

o To make FTP connections through a specified server, click the host name in the 
list  

o To delete a server from the SOCKS list, click it, then click Remove. 

o The Host name box displays the name of a server selected in the SOCKS list. 
To edit a host name, click a server in the SOCKS list, then edit the name in the 
Host name box. 

o The Port box displays the port number for the server selected in the SOCKS list. 
The default port for SOCKS servers is 1080. To edit the server's port number, 
click it in the SOCKS list, then edit the number in the Port box. 

o To have CuteFTP automatically send the proper user name and password for the 
SOCKS server when first connecting, select the Use Authentication check box. 
Clear this check box if you do not have a SOCKS user name and password, or if 
you choose to enter them manually upon connection. 

o In the Username box, provide the user name for the highlighted SOCKS server. 
(The Use Authentication check box must be selected.) 

o In the Password box, provide the password for the highlighted SOCKS server. 
(The Use Authentication check box must be selected.) 

o Click SOCKS4 or SOCKS5 to match the highlighted SOCKS server. 

 

SOCKS4 servers do not require usernames and passwords. If you need a username 
and password to connect to the server, it is a SOCKS5 server. 
 
Contact your system or network administrator or ISP or the proper Host name, Port, 
User name, Password and SOCKS type. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 
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SECURE CONNECTIONS 

LEARNING ABOUT SSL 

When you use CuteFTP to connect securely to a server that supports SSL or TLS (SSL v3), the two 
computers pass a sequence of commands to create a secure connection. The FTP protocol definition 
provides at least two distinct mechanisms by which this sequence is initiated: Explicit (active) and Implicit 
(passive) security.  

Explicit Security - Explicit security requires that the FTP client issue a specific command to the FTP 
server after establishing a connection to establish the SSL link. The default FTP server port is used. This 
formal method is documented in RFC 2228.  

Implicit Security - Implicit security is a mechanism by which security is automatically turned on as soon 
as the FTP client makes a connection to an FTP server. In this case, the FTP server defines a specific 
port for the client (990) to be used for secure connections.  

 

Implicit SSL is discussed in various SSL drafts, but not formally adopted in an RFC. For strict compliance to 
standards, use the explicit method. Implicit SSL adds benefits in the form of a dedicated port strictly used for 
secure connections, requiring fewer overheads in establishing the session. There are various FTP servers that 
support this mode, including GlobalSCAPE's Secure FTP Server. For more on SSL Connection Mechanisms, see 
Troubleshooting SSL Connections. 

SSL Sessions  

The diagram below shows a SSL session using explicit security. In this picture, the two computers 
communicate over an Internet connection. Time is represented vertically; the first communication at the 
top of the time line is from the Client to the Server, and subsequent communications proceed 
chronologically down the time line. The breaks in the time line represent the passage of time.  

EXPLICIT SSL CONNECTION  
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CuteFTP adheres to Internet standards for secure transfer of files over the FTP protocol. Specifically, 
CuteFTP implements the FTP extensions documented in RFC 2228. Any FTP Server that also 
implements these extensions will work with CuteFTP in order to ensure the encryption of your sensitive 
data.  

GlobalSCAPE Secure FTP Servers and Enhanced File Transfer Servers are also capable of Implicit SSL 
sessions over a dedicated port. See the Secure FTP Server User's Guide and Enhanced File Transfer 
Server User's Guide for more information on configuring a secure session to a GlobalSCAPE Secure 
Server. 

CONNECTING TO SECURE SOCKET LAYER (SSL AND TLS) SITES 

To connect to an FTP site over SSL  

1. Do one of the following: 

 On the main menu, click File > New > FTPS (SSL) Site.  

 On the toolbar, click the down arrow next to the New Site icon , then click FTPS 
(SSL) Site. 

2. Type in the Host address, Username, and Password.  

3. Click the Type tab. 

4. In the Protocol list, choose the type of SSL connection mechanism supported by your server or 
use the default type selected. 

5. Click Connect to connect to the site now, or click OK to connect later.  

To connect to an existing site over SSL  

 Click the site in the Site Manager, then click Connect. 

To speed up transfers with an SSL site 

Using a clear data channel speeds up transfers with SSL sites. A clear data channel encrypts the 
connection process, but files are transferred without encryption. 

1. Click the site in the Site Manager. 

2. Click the Type tab. 

3. Select the Clear Data Channel check box. 

4. Click Exit or Connect. 
  

 

Not all servers support or allow the PROT C (Clear Data Channel) command argument sequence. 

To encrypt the data transfer and not the command connection 

Using a Clear Command Channel, you can keep your data transfers encrypted and still avoid firewall 
issues. 

1. Click the site in the Site Manager. 

2. Click the Type tab. 

3. Select the Clear Command Channel check box. 

http://help.globalscape.com/help/secureserver3/
http://help.globalscape.com/help/eft5/
http://help.globalscape.com/help/eft5/
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4. Click Exit or Connect. 
  

 

Not all servers support or allow the CCC (Clear Command Channel) command argument. 

To configure other SSL settings 

1. On the main menu, click Tools, then click Global Options. 

2. Expand the Security node. 

3. Select SSL Security. 

 

CuteFTP Professional supports keyboard interactive authentication. This authentication method involves 
connecting to servers with a challenge/response type of password-based authentication, and requires a one-
time-use password typically generated by hardware-based or, less commonly, software-based password 
generators. 

CREATING SSL CERTIFICATES 

SSL servers use certificates to determine whether they will allow you to connect. With CuteFTP, you can 
create and sign digital certificates.  

To create an SSL certificate 

1. On the main menu, click Tools > Global Options. 

2. Expand the Security node. 

3. Click SSL Security. 

4. Click Create Certificate. The Create Client SSL Certificate Set wizard appears. 

5. In the Certificate Set Name box, type the name of the certificate that will be generated by the 
Certificate Wizard.  

6. In the Output Location box, click the folder icon to select a folder in which to save the certificate.  

7. In the Key length in bits box, click a bit length for the certificate private key. CuteFTP supports 
keys up to 4,096 bits. 

8. In the Expiration box, specify how long the certificate is to remain valid.  

9. Enter and confirm the Passphrase. The passphrase, which is used to encrypt the private key, 
can be any combination of characters or spaces. Do not lose the passphrase, as the certificate is 
useless without it.  

10. Click Next.  

11. In the Certificate Information area, type the following required information:  

 City/Town - the city/town where your organization is located.  

 State/Province - the state/province where your organization is located.   

 Organization - the name of your organization.  

 Common Name - the common name or fully qualified domain name of your site.   

 Email - email address in the format x@x.com.  

 Unit - name of your department, such as Information Systems.  



 

74 ● Having an SSL Certificate Signed  

 Country - the two-letter country code for the country where your organization is located.  

12. Click Next.  

13. Click the Set up CuteFTP to use the generated certificate check box - the wizard automatically 
associates the certificate to CuteFTP.  

 The certificate can be unassociated by clearing the Use SSL Certificate check box in 
Global Options (Tools > Global Options > Security > SSL Security). If the check box 
is cleared, the wizard only saves the certificate files in the folder originally specified. 

14. Click Finish. 

CuteFTP displays the paths to all the files generated for your certificate. If you want a third party to 
sign your certificate, you must send the Certificate Signing Request (.csr) file to the third party.   

Configuration Notes 

 Not all SSL sites require certificates. 

 When you create a certificate CuteFTP generates the following files: 

o Private key file (.key) - The private key should never be distributed to anyone. It is used 
to decrypt sessions encrypted by a public key. 

o Certificate request file (.csr) - This file can be signed by GlobalSCAPE Secure FTP 
Server's Certificate Signing Utility or sent to an intermediate Certificate Authority such as 
Verisign or Thawte for signing. 

o Certificate file (.crt) - This is a signed certificate, whether self-signed or signed by an 
intermediate certificate authority.  

 If the server accepts self-signed certificates, you can connect with the .crt file and .key file you 
created and associated to CuteFTP, provided the server has added your certificate to its trusted 
list. 

 You can export certificates (.crt files) from CuteFTP's Trusted certificate store, located in Global 
Options > Security > SSL Security.  

HAVING AN SSL CERTIFICATE SIGNED 

To have a certificate signed  

1. Create a certificate. CuteFTP generates the necessary files, including a Certificate Signing 
Request (.csr) file. 

2. Send the .csr file to the server or a Certificate Authority (CA) such as Verisign 
(www.verisign.com) or Thawte (www.thawte.com).  

3. The server or CA uses your .csr file to create a signed certificate (.crt) file, which it should then 
send to you. 

4. Replace your existing .crt file with the signed one. 

CHOOSING A CERTIFICATE FOR SSL SESSIONS 

Choose the certificate CuteFTP will send to SSL servers.    

To choose a certificate 

1. On the main menu, click Tools > Global Options. 
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2. Expand the Security node. 

3. Click SSL Security. 

4. Select the Use SSL Certificate when authenticating check box.  

5. Browse to the files to use by clicking the folder icons next to Certificate and Private Key.  

6. Type the passphrase in the Passphrase and Confirm passphrase boxes.  

7. Click Apply, then click OK.  

ACCEPTING SERVER SSL CERTIFICATES 

Accepting a certificate from a server allows you to connect with the server. Once you accept a certificate, 
it is added to your Trusted Certificates list, and you will not be asked to accept or reject the certificate 
again. If you reject a certificate, and try to connect again, you will be asked again to accept the certificate. 

To accept a server's SSL certificate 

1. Connect to a server with SSL. If the server has a certificate, it appears. 

2. Click Accept. The certificate is added to your Trusted Certificates list. 

 

If you click Reject, you will not be able to connect to the server. 

To see your Trusted Certificates 

1. On the main menu, click Tools > Global Options. 

2. Expand the Security node. 

3. Click SSL Security. 

4. Click Trusted Certificate. The Certificate Manager appears. 

5. Click a certificate in the list, then click Properties to see detailed information about the certificate. 

IMPORTING OR REMOVING SSL CERTIFICATES FROM THE TRUSTED 
LIST 

When a certificate is in your trusted list, you are able to connect to any server presenting that certificate. 

To import a certificate to the CuteFTP trusted list 

1. On the main menu, click Tools > Global Options. 

2. Expand the Security node. 

3. Click SSL Security. 

4. Click Trusted Certificate. The Certificate Manager appears. 

5. Click Import. The Open dialog box appears. 

6. In the Files of Type field, select Certificates (*.pem, *pfx, *.crt) or All files (*.*). 

7. Navigate to the folder containing the certificate file.  

8. Click the certificate file, then click Open. The certificate is now listed in your Trusted Certificates 
list. 

9. Close the Certificate Manager.  
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10. Click OK to close the Global Options dialog box. 

To remove an SSL certificate from the trusted list 

1. On the main menu, click Tools > Global Options. 

2. Expand the Security node. 

3. Click SSL Security. 

4. Click Trusted Certificate. The Certificate Manager appears. 

5. Click the certificate you want to remove, then click Remove. 

6. Close the Certificate Manager. 

7. Click OK to close the Global Options dialog box. 

USING A CLEAR DATA CHANNEL WITH SSL 

Using CDC (Clear Data Channel) speeds up transfers with SSL sites. A clear data channel encrypts the 
connection process, but files are transferred without encryption. You can add more speed to your 
transfers by using a clear command channel as well. 

 

The Clear Data channel option is only available with SSL connections. 

To use a clear data channel 

1. Click the site in the Site Manager. 

2. Click the Type tab. 

3. In the Protocol list, click  FTP with TLS/SSL (Port 990 - Implicit), FTP with TLS/SSL (AUTH 
SSL - Explicit), or FTP with TLS/SSL (AUTH TLS - Explicit). 

4. Click the Clear Data channel check box. 

5. Click Connect to connect now or Exit to connect later. 

USING A CLEAR COMMAND CHANNEL WITH SSL 

Using CCC (Clear Command Channel), your connection process and login are encrypted, but when you 
begin transferring data, all FTP commands are sent in clear text. The data transfers remain encrypted, 
unless you choose to use a clear data channel. SSL connections require CCC when connecting in PORT 
mode from behind a NAT firewall. 

 

The Clear Command channel option is only available with SSL connections. 

To use a clear command channel with SSL 

1. Click the site in the Site Manager. 

2. Click the Type tab. 

3. In the Protocol list, click FTP with TLS/SSL (Port 990 - Implicit), FTP with TLS/SSL (AUTH 
SSL - Explicit), or FTP with TLS/SSL (AUTH TLS - Explicit). 

4. Select the Clear Command channel check box. 

5. Click Connect to connect now or Exit to connect later. 
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TROUBLESHOOTING SSL CONNECTIONS 

If you are having difficulty connecting to your FTP server over SSL, refer to the following checklist for 
help. 

SSL Connection Checklist 

1. Verify that the server you are connecting to supports SSL connections. 

2. Verify the port being used. Some servers require that SSL connections use a dedicated port, 
such as 990. 

3. Verify the SSL connection type selected under Site Properties > Type > Protocol Type is the 
correct SSL mechanism supported by your server.  

4. Verify that your Certificate was added to the server’s Trusted List if the server requires client 
certificates upon connect. You may have to notify the server administrator as not all servers will 
auto-accept client certificates upon their first connection attempt. 

5. You must accept the server’s certificate when prompted during a connection attempt, otherwise 
the client will not connect as desired. 

6. Verify that your certificate has not expired. Check your Trusted List. 

7. Copy the connection log to a text file or email to assist in troubleshooting when contacting your 
FTP or Web service provider or the GlobalSCAPE support team. 

SSL Connection Mechanisms 

Not all FTP servers that support SSL connections do so correctly or in strict compliance to proposed or 
approved standards. 

Various FTP-over-SSL implementations have been proposed over the past few years. Most do not 
conform to RFC–2228 or are at odds with the latest IETF (Internet Engineering Task Force) drafts. 
Typical Implementations include: 

Implicit TLS/SSL - This is an SSL connection over a dedicated port (990) registered with the IANA. This 
approach, while quite common, is not favored by the IETF. CuteFTP supports this implementation for 
broader compatibility. 

Explicit "AUTH SSL" - This is an SSL connection over a standard port (21) using "AUTH SSL" or "AUTH 
TLS-P" to negotiate the protection mechanism. AUTH TLS-P implicitly sets the protection mechanism and 
is therefore in direct disagreement with RFC 2228. CuteFTP does support AUTH SSL, and subsequently 
sets the protection mechanism explicitly using the PROT command and its approved arguments. 

Explicit "AUTH TLS" - This is an SSL v3.1 connection over a standard port (21) and explicitly setting the 
protection mechanism. This is the version that best adheres to RFC 2228 and is favored by the IETF in its 
latest FTP over SSL draft (draft-murray-auth-ftp-tls-13.txt). This version is supported by CuteFTP and is 
selected by default when you establish a new SSL connection. 

Apart from those mentioned above, CuteFTP does not connect to servers requiring "AUTH TLS-P" or 
other deprecated SSL connection mechanisms. 

PROTECTING SITE MANAGER CONTENT 

To require a password to open the Site Manager 

1. On the main menu, click Tools > Site Manager > Security > Encrypt Site Manager Data. The 
Site Manager Encryption dialog box appears. 

http://www.iana.org/assignments/port-numbers
http://www.ietf.org/internet-drafts/draft-murray-auth-ftp-ssl-13.txt
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2. In the Password and Confirm password boxes, type a password for opening the Site Manager. 
Create a password of at least 5 characters for maximum security. 

3. Click OK. CuteFTP will now display the following prompt every time it starts. 
 

 

To change the Site Manager password  

1. On the main menu, click Tools > Manager > Security > Change Password. The Site Manager 
Encryption dialog box appears. 

2. In the Password and Confirm password boxes, type a new password for opening the Site 
Manager. Create a password of at least 5 characters for maximum security. 

3. Click OK. The password is changed. 

To remove the Site Manager password  

 On the main menu, click Tools > Site Manager > Security > Remove Password. 

CuteFTP will no longer prompt for a password when it starts. 

Configuration Notes 

 When the Site Manager Access Password is defined, the Site Manager information is protected with 
64-bit Blowfish encryption. 

 If you forget the password, you will not be able to use the protected Site Manager. You will have the 
option to back up the locked Site Manager and re-enter your site information in a new Site 
Manager. 

 You can import a password-protected Site Manager file, but will need the password to do so. 
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STORING AND MODIFYING SITE SETTINGS 

ADDING A SITE TO THE SITE MANAGER WITHOUT THE CONNECTION 
WIZARD 

You can save connection settings for sites that you use often by adding them to the Site Manager. 

To add a site to the Site Manager without the Connection Wizard 

1. On the main menu, click Tools > Site Manager > Display Site Manager. 

2. Click New, then click the type of site to define. 

3. On the Type tab, specify the protocol for the site.  

4. On the General tab, in the Label box, type a descriptive name for the site. 

5. In the Host address box, type the address for the site. The address can be a domain address, 
such as ftp.globalscape.com, or an IP address, such as 192.168.20.52. Ask your hosting 
provider for the address. 

If you do not provide the correct address, then every time you try to connect to that site an error 
message like the one below appears. 

 

Click Details to view the details and log entries to determine the specific error. 

6. In the Username field, type the user name given to you by your hosting provider. 

7. In the Password field, type the password given to you by your hosting provider. 

8. Click Connect to connect now or Exit to connect later. The site information is saved in the Site 
Manager for future use. 

 

Your host address can be in IP format (e.g., 255.255.255.255 ) or in domain name format (e.g., 
ftp.mysite.com).  

 

IMPORTING FTP SITES 

You can add sites to your Site Manager from simple text listings or from site listings in the following FTP 
clients: 

 CuteFTP Pro 1.0-3.3 (sm.dat) 

 CuteFTP Pro exported sites list (*.txt) 

 CuteFTP 4.0-6.0 (sm.dat) 

 CuteFTP 2.6-3.5 sites (smdata.dat) 

 CuteFTP 1.4-2.0 (tree.dat) 

 CuteFTP 1.3 (hosts.dat) 

 Blu Zone v1.0-v2.11 
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 CoffeeCup 4.0-4.5 (FTPServers.ini) 

 Crystal FTP 2000 

 FTP Commander 4.0 (ftplist.txt) 

 FTP explorer 1.00 

 FTP Voyager 6.0-8.0 (ftpvoyager.ftp) 

 Generic Site List from text (*.txt) 

 LapLink 2.0 

 TransSoft 4.4 

 WS_FTP 5.0 (ws_ftp.ini) 

 WS_FTP 6.0-7.0 (ws_ftp.ini) 

To import FTP sites 

1. On the main menu, click Tools > Site Manager > Import/Export FTP Sites. The Choose import 
or export site manager wizard appears. 

2. In the Select the operation area, click Import, then click Next. 

3. Specify the application or file from which you want to import, then click Next. 

4. In the Conversion type area, specify the conversion type, then click Next. 

5. Do one of the following: 

 If you select the Merge the entries into the existing Site Manager option, browse for 
the old database file to be merged and click Next. 

 If you select the Create a new Site Manager with these entries option browse for the 
old database file and the new database file. 

6. Click magnifying glass icon  to open the Find Site Database Tool and view the list of sites. 

7. Click the site you want to import, then click OK. 

8. After the sites are imported, click Finish. 

9. Open the Site Manager to verify the sites were imported. 

EXPORTING FTP SITES 

You can export your Site Manager listings if another user requires the same site configuration, or if you 
just want to back it up. 

To export your Site Manager listings 

1. On the main menu, click Tools > Site Manager > Import/Export FTP Sites. The Choose import 
or export site manager wizard appears. 

2. Click Export, then click Next. 

3. In the Select the file format area, click one of the following: 

 As text - to generate a list of sites in plain text. 

 As URL - to generate a list of sites as Web addresses. 

4. Click Next. 
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5. In the File location and Name box, click the folder icon to define the path for the new file. The 
Save As dialog box opens. 

6. In the File name box, type a name for the file, then click Save. 

7. Click Finish. 

REMOVING A SITE FROM THE SITE MANAGER 

If you have sites defined in the Site Manager to which you no longer connect, you can delete them. 

To remove a site from the Site Manager 

1. Display the Site Manager and view the Site Properties. 

2. Click the site you want to delete, then do one of the following: 

 Right-click the site, then click Delete. 

 On the keyboard, press DELETE. 

 Click Delete.  

A confirmation message appears. 

3. Click Yes.  

BACKING UP SITE CONFIGURATIONS 

CuteFTP can back up your site configuration and save the backup file in any directory you specify. It is a 
good idea to back up this data in case you need to restore your setup. 

To back up the configurations in Site Manager 

1. On the main menu, click Help > Backup Personal & Registration Data. 

2. Specify the location to save your backup data. CuteFTP create backup files (key.reg, serial.txt, 
and sm.dat) in the location you specified. 

3. You are prompted to print out your registration information. If you click Yes, the following 
information prints to your default printer: 

 Instructions for restoring your registration (using key.reg) 

 Instructions for restoring your Site Manager configuration (using sm.dat) 

 Your registration number  

(This same information is saved in the backup file serial.txt.) 

MODIFYING SITE CONNECTION SETTINGS 

Site Properties - General Tab 

On the General tab of the Site Properties, you can modify the name (Label) by which the site is 
displayed in the Site Manager, the host address, username, password, and login method. You can also 
type comments that are saved with the site settings. 
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Label - Type a descriptive name for the site, as it will appear in the Site Manager.  

Host address - Type the address to which you will connect for this site. The address can be a domain 
name, such as ftp.example.com, or an IP address, such as 192.168.125.210. If you do not know the 
address, your hosting provider or system administrator should be able to provide it to you. Many ISPs 
provide FTP configuration information on their Web site. For an example of what to look for, go to 
http://help.yahoo.com/l/us/yahoo/geocities/gftp/gftp-09.html. A similar help page should be available from 
the company that is hosting your web site. 

Username - Type the username given to you by your hosting provider. 

Password - Type the password given to you by your hosting provider. 

Comments - Type any notes about the site that you want to save with the site. 

Login method: 

 Click Normal if the server requires your user name and password for a connection. 

 Click Anonymous if the server does not require a user name and password for a connection. 

 Click Double if you need to supply your user name and password twice for a connection.  

New - Saves all of your changes for the current site, and opens a new blank site. 

Rename - Change the name of the site highlighted in the left pane. 

Delete - Deletes the selected site. The site and all related information are removed from the Site 
Manager. 

Browse Offline - Opens a cached version of the site's folders in the Remote pane. 

Connect - Saves site changes and connects to the site. 

Exit - Saves changes and closes Site Properties. 

Help - Opens the online help. 

Site Properties - Type Tab 

On the Type tab of the Site Properties, you can synchronize the time zone, and define the server type, 
data connection type, and transfer type. 

http://help.yahoo.com/l/us/yahoo/geocities/gftp/gftp-09.html
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Protocol type - Specify the transfer protocol for the site. Options include FTP and various SSL options. In 
CuteFTP Professional, you can also choose HTTP, HTTP with SSL, or SSH2 (SFTP).  

If you choose any of the SSL options, you will also be able to choose a Clear Data Channel or a Clear 
Command Channel.  

Port - The default port number appears (e.g., FTP = 21) You can change the number if the default is not 
correct for your site. Contact your ISP/Web service provider for the correct port number. 

Server type - If you keep the default of Auto-detect, CuteFTP tries to determine what kind of server is at 
the site. If you have connection problems, or you know what kind of server is at the site, you can choose 
from the list that includes UNIX, UNIX compatible, Windows NT, and many others. 

Data connection type - Click Use global settings. CuteFTP uses the connection type set in Global 
Options > Transfer. You can also specify PORT,or  PASV connection mode.  

Transfer type - Specify the transfer type you set in Global Options or one of the following: 

 Auto-detect:  Based on the file type, CuteFTP decides whether to transfer in ASCII or binary. 

 ASCII:  Used primarily for transfer of text-based files such as HTML, text, and other documents. 

 Binary: Used primarily for data type transfers such as pictures and other graphics, or files those 
do not have line feeds (carriage returns).  

Server time zone - Specify No Offset if the server is in the same time zone as yours. If the server is in a 
different time zone, specify it here. These time zones do not account for Daylight Saving Time. To 
account for Daylight Saving Time, choose a time zone one hour ahead of the server's time zone. For 
example, if you are connecting to a server in Central Daylight time, set the time zone to Eastern Standard 
Time.  

Time Zone Synchronization - Select the Automatically detect check box to enable time zone 
synchronization. 

The Time Zone Synchronization feature helps in synchronizing time for all of the time zones. For 
example, if you set the time zone to CST, then during daylight savings the difference in the time occurs. 
In that case, you select the time zone one hour ahead of the server's time zone.  

Time Zone synchronization feature helps in comparing the time of the file when it is uploaded on the 
remote server to the local computer time, rounding to the nearest 30 minutes. The difference in the time is 
the Time Zone offset. 
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The CuteFTP shall automatically detects the remote server time zone and synchronize it with the local 
computer time zone when a file is transferred. 

 

By default the Automatically detect check box is not selected. 

Site Properties - Actions Tab 

On the Actions tab of the Site Properties, you can specify the actions to take when you connect to and 
upload to the site. 

 

When client connects, switch to this remote folder - Type the full path to any folder on the remote site, 
and CuteFTP will automatically open the folder in the Remote Pane when you connect to the site. 

When client connects, switch to this local folder - Type or browse to the full path for any folder on 
your computer, and CuteFTP will automatically open the folder in the Local Pane when you connect to the 
site. 

For navigation use the following caching options - Caching means CuteFTP stores the site list 
information on your computer, so when you navigate to different files and folders, you do not have to 
reconnect. 

 Use cache during session - Store the site's information only until you close the connection. 

 Always use cache - Store the site's information and keep it even after you disconnect. 

 Do not use cache - Never store the site's information. 

When uploading, apply this rule to files and folder names - Use this to change file names to upper 
case, lower case, or to keep the case the same. 

 Preserve case - Keep all uploaded file names in their original case. 

 Force lower case - Change all uploaded file names to small letters. 

 Force upper case - Change all uploaded file names to all capitals. 

Filter - Click this button to define which files will be hidden or displayed on the site. 

For more information, refer Choosing which files and folders to display. 
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Site Properties - Options Tab 

On the Options tab of the Site Properties, you can specify the number of retry attempts, delay between 
retries, and other options. 

 

Site-specific configuration options 

 Use global settings for all options - the site will use the parameters set in Global Options  

 Use site specific option - the site will use the parameters set on this tab.  

Apply auto-rename scheme to transfer - Select this check box if you want the files that you transfer to 
be renamed according to the settings you chose in the Global Options Rename Rules panel. Clear this 
check box if you do not want files to be renamed when you make transfers with this site. 

Use NLST instead of LIST (retrieves an abbreviated listing) - Select this check box to get only a list of 
file names and no other file information from the site. Clear this check box if you want the site to send you 
complete file listings, including file size, file modified date, and folder names. 

Use the logical parent (not physical parent) on CDUP - Select this check box if you want to return to 

the previous directory when you clicked the Up folder icon , even if you clicked a link or shortcut in the 
previous directory. Clear this check box to go back to the parent directory for this folder, which might not 
have been the directory you were in when you jumped to the current directory. 

Site-Specific Firewall settings 

 Click Proxy if you need to connect through a proxy server to get to this site. A Proxy dialog box 
appears in which you can enter the proxy type, server address, username and password. 

 Click Socks if you need to connect through a Socks server to get to this site. A Socks dialog box 
appears in which you can enter the SOCKS type, server address, username and password. 

Retry attempts - Specify the number of times you want CuteFTP to try connecting to this site, if there is a 
problem making a connection. 

Delay between retries - Specify the number of seconds you want CuteFTP to wait before retrying a 
connection after a connection attempt fails. 

Site max concurrent transfers - Specify the number of connections CuteFTP can open to the site for 
transferring many files simultaneously. 
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CHANGING A SITE'S CONNECTION SETTINGS OR LOGIN 
INFORMATION 

On the General tab of the Site Properties dialog box, you can change the connection or login 
information for the selected site. 

To change a site's connection settings or login information 

1. Display the Site Manager and view the Site Properties. 

2. Click the General tab. 
 

 

3. Change the information as needed, then click Connect to accept the changes and connect to the 
site or Exit to accept the changes without logging in.  

CHANGING THE DATA CONNECTION TYPE (PORT OR PASV) 

The sites are all configured by default to use the data connection type set in the Global Options dialog 
box. You can change that setting for each site. For example, if you want to connect in PASV mode to a 
server that prefers PORT for data connections, you might need to change the data connection type. 

To change the data connection type 

1. Display the Site Manager and view the Site Properties. 
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2. Click the Type tab. 
 

 

3. In the Data Connection Type box, click Use PORT or Use PASV. 

4. Click Connect or Exit. 

PROXY SETTINGS FOR INDIVIDUAL SITES 

You can set individual sites to connect through a proxy server in the Site Manager. To set the proxy 
settings the same for all sites in the Global Options dialog box, refer to Proxy Connection Settings. 

To setup a proxy connection for an individual site 

1. In the Site Manager, click the site you want to change. 

2. Click the Options tab. 

3. In the Site specific configuration options list, click Use site specific option. 

4. Click Proxy. The Proxy dialog box appears. 

5. In the Proxy type list, click the protocol your proxy server supports. 

6. In the Host name and port boxes, type the name and port number of the proxy server. The default 
port for proxy servers is 8000. 

7. If the proxy server requires a user name and password or some other authentication, select the 
Use authentication check box. If the proxy server does not require authentication, skip to step 
15. 

8. Type your proxy User name. 

9. Type your proxy Password. 

10. If your proxy server only requires the user name and password, skip to step 15; otherwise, click 
Advanced.  

11. Click one of the following advanced authentication methods. 

o USER user @site if your proxy server requires the USER command followed by your 
user name and the site name to allow connection with a remote site. You can replace 
the @ sign with a different separator to match what your proxy server requires. 
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o SITE site if your proxy server requires the SITE command followed by the address of the 
remote FTP site to allow a connection.  

o USER with logon if your proxy server requires the USER command followed by a user 
name and password to allow connection with a remote site. 

o USER/PASS/ACCT if your proxy server requires all three commands before allowing a 
connection to a remote site. 

o OPEN site if your proxy server requires the OPEN command followed by the site name 
before allowing connection to the site. 

o Custom if your proxy server requires a login sequence different from those above. See 
the procedure below for creating a custom authentication method. 

12. Click OK to close the Advance Proxy Settings dialog box. 

13. Click OK to accept the Proxy settings specific to this site. 

14. Click Connect or Exit to close the Site Manager. 

 

Contact your system administrator for the proper Host name, Port, User name, Password, and proxy type, as 
well as any required advanced authentication methods.  

To create a custom authentication method for a proxy server 

1. Type a command. 

2. Follow the command with a space and an appropriate variable:  

 %host% sends the host name you typed in the Proxy dialog box. 

 %user% sends the user name you typed in the Proxy dialog box. 

 %pass% sends the password you typed in the Proxy dialog box. 

 %port% sends the port number you typed in the Proxy dialog box. 

 %fire_pass% sends the password you typed in the Proxy dialog box as authentication for 
the firewall. 

 %fire_user% sends the user name you typed in the Proxy dialog box as authentication 
for the firewall. 

Type each variable with percent signs before and after. 

3. Press Enter to separate commands.  

4. Click OK. 

CORRECTING TIMES FOR SITES IN DIFFERENT TIME ZONES 

CuteFTP uses time zone offset information for display, transfer, and overwrite logic.  

To compensate for servers in different time zones 

1. Display the Site Manager and view the Site Properties. 
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2. Click the Type tab. 
 

 

3. In the Server time zone list, select the server's time zone. Alternately, select the Automatically 
detect check box, and CuteFTP will determine the time zone from the system clock. 

4. Click Connect or Exit. 

SPECIFYING WHETHER TO SAVE A SITE'S INFORMATION - CACHING 

Caching means CuteFTP stores the site list information on your computer, so when you navigate to 
different files and folders, you don't have to reconnect.  

To specify cache options 

1. Display the Site Manager and view the Site Properties. 

2. Click the Actions  tab. 
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3. In the For navigation use the following caching options box, click one of the following: 

 Use cache during session - Store the site's information only until you close the 
connection (the default setting). 

 Always use cache - Store the site's information and keep it even after you disconnect. 

 Do not use cache - Never store the site's information. 

4. Click Connect or Exit. 

DESIGNATING A SITE'S SERVER TYPE 

You can improve compatibility with individual sites by designating the type of server used for that site. 

To designate server type 

1. Display the Site Manager and view the Site Properties. 

2. Click the Type tab. 
 

 

3. In the Server Type list, select a server type. 

4. Click Connect or Exit. 

FINDING A SITE IN THE SITE MANAGER 

If you have numerous sites defined in the Site Manager, you use the Find function to search for it. 

To find a site in the Site Manager 

1. Display the Site Manager and view the Site Properties. 

2. Right-click in the Site Manager, then click Find Text in Site Manager (or press ALT+F3). 

3. In the Find dialog box, type all or part of the site name, then click OK. 

4. If a site other than the one you wanted is found, right-click and select Find Next, or press F3, 
until the desired site is highlighted. 
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The Find tool is not case sensitive, searches from the top to the bottom of your site listings, and does not 
recognize wildcards. 

CREATING AND USING BOOKMARKS 

You can have special entries called bookmarks associated with sites that open a specific local or remote 
folder, or both the folders. 

To create a bookmark  

1. Connect to a site. 

2. In the Local pane, click or browse to the folder you want to bookmark.  

3. In the Remote pane, click or browse to the remote folder you want to bookmark. 

4. Do one of the following: 

 On the main menu, click Tools > Bookmark current folder. 

 Click the Bookmark icon , then click Bookmark current folder.  

 Press CTRL+Q. 

The Set bookmark dialog box appears. 

 

5. The Local folder and the Remote folder are displayed in the Set Bookmark dialog box and 
cannot be changed. To change the local folder and remote folder you have to repeat the previous 
steps. 

6. In the Bookmark Name box, provide a descriptive name for the bookmark, then click OK. The 
new bookmark appears in the Site Manager as a sub-listing of the remote site's entry. 
Bookmarks created in this manner are assigned the remote folder as their default name, but you 
can rename them.  

 

To connect to a bookmarked directory 

 Do one of the following: 

o Double-click a bookmark displayed as a sub-item under the site name in the Site 
Manager.  
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o Click Bookmark and select the desired bookmark from the shortcut menu. 

o On the toolbar, click the Bookmark  icon, then click the bookmark on the shortcut 
menu. 

A new remote window appears displaying the bookmark's remote folder, if specified; otherwise, the root 
folder appears. The Site Manager switches to Local Drives, displaying the local folder specified in the 
bookmark.  

To edit a bookmark 

1. In the Site Manager, click the bookmark. 

3. To change the remote folder, in the Remote path box, type a new remote path. 

4. To change the local folder, in the Local Path box, type or browse for a new local path. 

5. Click OK. 

To rename a bookmark 

1. Click the bookmark. 

2. Click Rename. 

3. Type a new name, then press ENTER. 

To remove a bookmark 

1. Click the bookmark, then do one of the following: 

 On the main menu, click File > Delete. 

 Right-click the bookmark, then click Delete.  

 On the toolbar, click the Delete icon . 

A confirmation message appears. 

2. Click Yes.  
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TRANSFERRING FILES AND FOLDERS 

SPECIFYING A DEFAULT DOWNLOAD FOLDER 

In the Global Options dialog box, you can specify which folder on your hard drive is the default folder for 
downloads from your remote site. You can specify that whichever folder is displayed in the local pane is 
the download location, or specify another folder. 

To specify a default download folder 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the General node. The General options appear. 

3. Do one of the following: 

 To download remote items that were dragged to the queue to the folder displayed in the 
Local Drives pane, select the Use the current folder in the local pane as the default 
check box.  

 To provide a path to a specific folder, clear the Use the current folder in the local pane 
as the default check box, then in the Use box, browse for or type the path to a download 
location for remote items you place in the queue. All remote items dragged to the queue 
are downloaded to the specified folder. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

TRANSFERRING FILES AND FOLDERS 

Transferring files and folders between sites is quick and easy. Besides just clicking and dragging the item 
that you want to transfer, you can also: 

 Multi-select and drag items as group. (SHIFT + click for contiguous items; CTRL + click for non-
contiguous items.)  

 Drag items to the Queue to upload them later. 

To upload files (transfer from a local to remote computer) 

1. Connect to a remote site. 

2. In the Local pane, locate the files or folders that you want to upload. 

3. Click and hold the mouse button while dragging the item(s) from the Local pane to the Remote 
pane or Queue pane. 

4. Release the mouse button. The items are copied (not moved) to the remote server or to the 
Queue pane for later uploading. 

To download files (transfer from a remote to a local computer) 

1. Connect to a remote site. 

2. In the Remote pane, locate the files or folders that you want to download. 

3. Click and hold the mouse button while dragging the item(s) from  the Remote pane to the Local 
pane or Queue pane. 

4. Release the mouse button. The items are copied (not moved) to your local location or to the 
Queue pane for later downloading. 
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For the procedures for file and folder management, see Managing Files and Folders. 

QUEUING FILES AND FOLDERS FOR TRANSFER 

CuteFTP allows you to drag items to the queue to download them later. From within the queue pane, you 
can also stop, resume, or restart a transfer. For a description of the icons that appear in the Queue pane, 
see Transfer Queue Icons. 

To display or hide the queue 

1. On the main menu, click View > Show Panes. 

2. Click Queue Pane or click ALT+1 to display or hide it. 

To add items to the queue 

1. Connect to a site. (You cannot drag items to the queue unless you are connected to a site.) 

2. Locate the files or folders you want to upload or download in your local or remote pane. 

3. Drag the selected items to the transfer queue window. 

4. Repeat as necessary. You can also connect to other sites and add files and folders to the queue. 

5. Once you have finished adding items to the transfer queue, you can change queue item attributes 
if desired, such as destination path, transfer type, scheduling, and so on by clicking the item, then 
pressing ALT+ENTER. 

6. To change the transfer priority of an item, click it, then drag it up or down in the queue. A blue line 
appears to indicate where the item will be placed. 

7. When you are ready to begin processing the queue, do one of the following: 

 On the main menu, click Tools > Queue > Transfer All.  

 Click to select one or more items in the queue, then click Tools > Queue > Transfer 
Selected. 

 Right-click in the queue, then click Transfer All. 

 Click to select one or more items in the queue, then right-click the selection and click 
Transfer Selected. 

TRANSFER QUEUE ICONS 

The queue icons are displayed next to each item in the Queue pane. 

Icon Description 

 

The item is in the queue but a transfer has not been attempted or scheduled. 

 
The item is in the queue and a transfer has been scheduled, but has not yet occurred. 

 

This item's transfer is starting. 

 

There is an existing file of the same name in the destination folder and you will have to decide whether to 
Overwrite the existing file, Skip the transfer, Resume an interrupted transfer, Rename the file you are 
transferring, or Numerate the file you are transferring. 

 

The item transfer is in progress; this usually appears for large transfers. 

 

The item transferred successfully. 

 

The transfer has been interrupted, but CuteFTP is still trying to complete the transfer. 
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Icon Description 

 

The item has been skipped, usually because you chose to skip it manually or in a Smart Overwrite rule 

that you chose previously. 

 

You have stopped the transfer while it was in progress. You can still Resume this transfer. 

 

The server has refused to transfer the item. The transfer log will show an ERROR:> message with a more 

information. 

TRANSFERRING FILES IN ORDER 

You can see the order in which queued items transfer at the left end of the Queue pane. The numbers in 
the column indicate the order of transfer. By default, files transfer in the same order that they are added to 
the queue. 

To transfer items in the order added 

1. Sort the Local or Remote pane by clicking on the corresponding column header (Name, Time, 
Size, etc.) 

2. In the Local or Remote pane, click the item(s) to transfer, then drag the selected items into the 
queue. Note that the items are ordered in the same way they were sorted prior to adding them to 
the queue. 

3. Right-click in the Queue pane, then click Transfer All. CuteFTP transfers the files in the order 
reflected by the numbers in the left column of the queue. 

To set a specific transfer order 

1. Move transfer items to the Queue pane as described above. 

2. Click the pound sign (#) column header to sort the items by their transfer order. 

3. Click an item in the queue. 

4. On the main menu, click Tools > Queue > Change Order. 

 To transfer the selected item first, click Move to Top (or press CTRL+SHIFT+T). 

 To transfer the selected item last, click Move to Bottom (or press CTRL+SHIFT+B). 

 To transfer the selected item before the previous item in the queue, click Move Up One 
(or press CTRL+SHIFT+U). 

 To transfer the selected item after the following item in the queue, click Move Down One 
(or press CTRL+SHIFT+D). 

 

You can also change an item's place in the transfer order by clicking and dragging the item up or down in the 
queue. A blue line indicates where the item's new position in the queue will be after you release the mouse. 
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STOPPING TRANSFERS 

You can stop in-progress transfers, remove items from the queue, and reset failed transfers. To resume 
or restart a transfer, refer to Resuming Transfers. 

To stop a transfer 

1. Click the item(s) in the queue to be stopped. 

2. On the main menu, click View > Stop (or press ESC). 

To remove items queued for transfer 

1. Click an item in the Queue pane.  

2. Do one of the following: 

 On the main menu, click Tools > Queue > Remove Selected.  

 Select one or more items in the queue, then right-click the selection and click Remove 
Selected. 

 Press DELETE. 

A confirmation message appears. 

3. Click Yes.  

 

Remove All deletes every file from the queue. Remove Finished deletes all of the items from the queue that 
have completed their transfer.  

The shortcut keys ESC or F9 stop active transfers. Press ESC once to stop the last command (be it a transfer or 
connection request). Press ESC repeatedly to cycle through active transfers and/or connections and stop them 
one by one. You can also select multiple items in the queue and press ESC to stop them. Press DELETE to stop 
and remove selected queue items. 

RESUMING TRANSFERS 

CuteFTP automatically attempts to resume interrupted transfers caused by lossy connection, server-
kicked users, a slow server, and so on. CuteFTP does not auto-resume interrupted transfers when the 
remote server is unreachable (i.e., there is no connection available, the server is down, or for any other 
reason). In those situations, you must manually resume the transfer. 

 

In you have not shut down and restarted CuteFTP since the interruption took place, CuteFTP assumes that the 
transfer is within its original context and attempts to resume it from the point it left off. If the transfer is no 
longer in the original context, CuteFTP prompts you to overwrite the destination file, that is, to start over again. 
You can set up overwrite rules to tailor such situations to your specific needs. 

To resume a stopped transfer 

 Click the stopped item in the queue, then do one of the following: 

o On the main menu, click Tools > Queue > Transfer Selected. 

o Right-click the item, then click Transfer Selected. 

To reset a failed transfer 

 Click the stopped item in the queue, then do one of the following: 

o On the main menu, click Tools > Queue > Reset Selected. 
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o Right-click the item, then click Reset Selected.  

o To restart the transfer, click Tools > Queue > Transfer Selected. 

o Right-click the item, then click Transfer Selected. 

VIEWING TRANSFER STATUS 

While items are transferring and after the transfer is complete, you can view the details of the transfer in 
the Log pane. Refer to CuteFTP Home's Main Screen to view an illustration showing where the Log pane 
appears. 

The Log pane is hidden by default. 

Ensure the log settings in the Global Options dialog box are configured to display the logs. 

To view the log pane 

 On the main menu, click View > Show Panes > Log pane (or press ALT+2). 

USING THE CLIPBOARD TO TRANSFER 

You can use the Windows clipboard to copy and paste a URL directly into CuteFTP with the Connect to 
URL feature. This allows you to connect to a site, or if specified, download a file.  

1. In a browser or Windows application, copy the URL to the clipboard (e.g., press CTRL+C). The 
URL may be general (ftp://www.globalscape.com) or specific 
(ftp://www.globalscape.com/pub/cuteftp/cute2632.exe).  

2. In CuteFTP, on the main menu, click File > Connect > Connect to URL (or press CTRL+U). The 
Connect to URL dialog box appears. 

3. Paste the URL into the Connect to URL dialog box (e.g., press CTRL+V).  

4. Click OK. CuteFTP parses the URL and connects to the site or, if specified, starts downloading 
the file. 

 

The URLs that you paste into the Connect to URL dialog box are saved for future sessions. Then you can just 
press CTRL+U, then click the down arrow to select the URL. 

The following formats are supported:  

 ftp://user:pass@host.host.com:port  

 ftp://user:pass@host.host.com  

 ftp://user@host.host.com  

 ftp://host.host.com:port  

 ftp://host.host.com  

 ftp://ftp.sitename.com/pub l: user  p: pass  

 ftp://ftp.sitename.com/pub:44 l: user  p: pass  

 ftp://ftp.sitename.com/pub port:44 l: user  p: pass  

 ftp://ftp.sitename.com/pub l/p:  user/pass  

 ftp://ftp.sitename.com/pub:44 l/p:  user/pass  

 ftp://ftp.sitename.com/pub p:44 l/p:  user/pass  

 ftp://ftp.sitename.com/pub port:44 l/p:  user/pass  
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 ftp://ftp.sitename.com/pub l: user p: pass  

 ftp://ftp.sitename.com/pub:44 l:  user p: pass  

 ftp://ftp.sitename.com/pub p:44 l: user p: pass  

 ftp://ftp.sitename.com/pub port:44 l: user p: pass  

 ftp://[any of the above formats]/pathnametofile/[optional filename] 

Depending on the URL you paste, CuteFTP tries to connect and navigate to the specified folder or 
attempts to download the item. Following is a sample of path endings and how CuteFTP handles them.  

Path endings Interpretation  Action Attempted 

ftp://host/dir.ext/ A folder Connection 

host/.ext/ A folder Connection 

host/dir/ A folder Connection 

host/dir A folder Connection 

host/dir.ext A file Download 

host/.ext A file Download 

SCHEDULING TRANSFERS 

CuteFTP allows you to schedule transfers from the queue window. Additionally, you can schedule 
uploading files from your local computer to a server and downloading files from a server to your local 
computer.  

To schedule transfers from the queue window  

1. In the Queue pane, click the file to be transferred, then do one of the following:  

 On the main menu, click Tools > Queue > Schedule Selected.  

 Right-click the item, then click Schedule Selected.  

The Scheduling Properties dialog box appears. 

2. Select the Schedule the current item check box. 

3. In the Start on boxes, specify a date and time to transfer the item. 

4. If you want the transfer to repeat automatically, select the Enable Recurrence check box, then, 
in the Repeat every boxes, specify how often you want the transfer to repeat.  

5. Click OK. 

 

 You can schedule multiple transfers. 

 CuteFTP continues to run and complete any scheduled or pending transfers even if you exit the program 
before a transfer is scheduled to start, unless the "Don't close the transfer engine if tasks are pending" is 
disabled in Tools > Global Options > General.   

 If you close the Transfer Engine or shut down the computer before a scheduled transfer can start, CuteFTP 
prompts if you still want to complete the scheduled transfer the next time you open CuteFTP.  

 If you leave CuteFTP or the Transfer Engine open to accomplish a number of tasks, it is a good idea to 
configure CuteFTP to delete successfully finished items from the queue. 
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FILTERING TRANSFERS 

CuteFTP allows you to set filters that automatically include or exclude files from transfers. You define the 
filters in the Filter dialog box, then apply them to individual transfers, or use them on all transfers. You 
can also use filters during folder synchronizations.  

To transfer filtered items 

1. Click in the pane displaying the files or directory to which you want to apply a filter.  

2. On the main menu, click View, then click Filter (or press CTRL+L). The Filter dialog appears. 

3. On the Filter Properties tab, click Enable filtering. 

4. If you want to filter at the folder level, select Apply filtering to folder names. If a filter you add 
matches a folder name, the entire contents of that folder are included or excluded along with the 
folder. 

5. If you want the filters to work during transfers, select Apply to file transfers. 

6. On the Filter Mask tab, type a mask, then click Add to add files you want to include. 

7. On the Filter NOT Mask tab, type a mask, then click Add to add items you want to exclude. 

8. Click OK. 

9. Click the files that remain visible, then click File, Upload Advanced, then click Upload filtered 
(or Download filtered if you are downloading.). 

 

 You can configure two filter sets: one for the local pane, and one for the remote pane. Note that CuteFTP 
applies the filter parameters to all of the contents, directories, and subdirectories displayed in that pane. 

 Filtering works with folder synchronizing.  

 You can filter by file extensions, for example, .htm, .php, .asp, etc. 

TRANSFERRING FILES IN BINARY OR ASCII MODE 

You can specify binary or ASCII mode for a session, globally (per file type), and per site. All extensions 
are sent in binary mode unless they are listed in the ASCII extensions list, as described below. 

To choose the transfer mode for a session 

You can change the transfer type for a single CuteFTP session. Once CuteFTP is restarted, it reverts to 
the transfer type set in Global Options. 

 On the main menu, click File > Transfer Type, then click one of the following:  

o Auto (or press CTRL+F1) - Auto is the default transfer type, and sends files in the mode 
specified for each file's extension. All extensions are sent in binary mode unless they are 
listed in Global Options, as described below. 

o ASCII (or press CTRL+F2) - files will be transferred in ASCII mode. 

o Binary (or press CTRL+F3) - files will be transferred in Binary mode. 

To transfer specific file types in ASCII mode 

1. On the main menu, click Tools > Global Options (or press ALT+F7). The Global Options dialog 
box appears. 

2. Expand the Transfer node, then click ASCII Types. A list of the file types that are transferred in 
ASCII mode are displayed.  



 

100 ● Transferring Files in Binary or ASCII Mode  

3. Do the following: 

 To specify file types that are to be transferred in ASCII mode, in the ASCII extensions 
list, type the file extension for the file type you want to transfer in ASCII mode, then click 
Add. The extension appears in the list. 

 To specify file types that are to be transferred in binary mode, in the ASCII extensions 
list, click the extension of the file type that you want to transfer in binary mode, then click 
Remove. Removing the file type from the ASCII extensions list will cause that type of 
file to be transferred in binary mode. 

4. Click OK. 

To change a site's transfer types 

1. Display the Site Manager and view the Site Properties. 

2. Click the Type  tab. 
 

 

3. In the Transfer type box, Auto-detect is selected by default. Based on the file type, CuteFTP 
decides whether to transfer in ASCII or binary. To change this setting for this site, click one of the 
following: 

 ASCII - Used primarily for transfer of text-based files such as HTML, text, and other 
documents. 

 Binary - Used primarily for data type transfers such as pictures and other graphics or 
files that do not have line feeds. 

4. Click Connect or Exit. 

 

SSH2 servers do not support ASCII transfers (see http://www.ssh.com/tech/archive/secsh.cfm). CuteFTP 
Professional adjusts for this by automatically stripping line feeds prior to uploads and restores them during 
downloads (prior to the file being written to disk). 

http://www.ssh.com/tech/archive/secsh.cfm
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SAVING AND REUSING A LIST OF TRANSFER TASKS 

When you create a Folder Monitor job, the job is saved in the Queue pane. 

 

CAUTION: If you use Remove All to remove everything from the Queue pane, you will also remove your 
Folder Monitor rules!! 

Unfortunately it is not possible to retrieve any jobs that were deleted. However, you can backup (export) 
all jobs and reload (import) them if they are deleted. 

To save a list of transfer jobs/Folder Monitor Rules 

1. Do one of the following: 
o On the main menu, click Tools > Queue > Load & Save Queue > Save Queue. 
o Right-click in the Queue, then click Load & Save Queue > Save Queue. 

2. In the Save As dialog box, specify a name and location, then click Save. The file is saved as 
quesave.cpx by default. 

To reuse a list of jobs (load a previously saved queue) 

1. Do one of the following: 
o On the main menu, click Tools > Queue > Load & Save Queue > Load Queue. 
o Right-click in the Queue, then click Load & Save Queue > Load Queue. 

2. In the Open dialog box, click a saved Queue file (Queue files are saved with a .cpx extension), 
then click Open. The saved jobs appear in the Queue. (NOTE: If a job in the .cpx file is already in 
the Queue, it is not overwritten; instead, you will have duplicate jobs in the Queue. Sort the 
Queue by the Local or Remote column to find the duplicates.) 

IMPROVING SLOW TRANSFERS 

If you are experiencing slow transfer speeds, try fine tuning CuteFTP as described below. 

 Tweak the receive and send buffers 

 Turn off the time stamp in logs 

 Try using multi-part transfers  

 Check the global bandwidth limit 

Tweak the receive and send buffers 

Setting these buffers allow you to fine tune transfers over high latency or lossy connections like those 
over satellite links or with legacy CDMA wireless connections. It is unlikely you will ever need to adjust 
this setting, but if you have problems with successful transfers and suspect the latency or quality of the 
connection is at fault, try tweaking these buffers. The receive buffer holds data until CuteFTP is ready to 
read it; the send buffer holds data until it can be sent to the server. Typically, both send and receive 
buffers should be set to the same size. The default is set at 65536 bytes, the normal maximum window 
size of TCP.  
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You can measure the latency and estimate the available bandwidth with network monitoring tools. There 
is some guesswork involved, as most tools are not entirely accurate, but they can guide you to finding a 
sweet spot where transmissions are successful. If you have a lossy connection, try lowering the buffer 
size. If you have high latency, a higher buffer size might help. 

Normally, the optimal buffer size is your bandwidth times the latency of the link. So, 

bandwidth (in bits) * latency (round trip time in seconds) = socket buffer size (in 

bits) 

Convert bits to bytes (bits divided by 8 equals bytes) for the buffer size. 

So, if your bandwidth is 1,536,000 bps and you have a latency of 200ms (.2 seconds), your socket buffers 
should be set to 38400: 

1536000*.2=307200 bits 

307200/8=38,400 bytes 

You can also try halving or doubling the buffer size. For example, if the buffer is set to 65536 (64kb), try 
32768 (32kb). 

1. On the main menu, click Tools > Global Options.  

2. Click the Transfer node.  

3. In Receive buffer and Send buffer boxes, change the values as needed. (See guidelines 
above.) 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

Turn off the time stamp in logs 

 When this feature is on, CuteFTP adds a time stamp next to each log event. This option 
consumes system resources, so you can turn this off if performance is critical. For more 
information, see Record/Display time stamps in Log file settings 

Try using multi-part transfers  

 If you are transferring large files, try using a multi-part transfer. You can only use this option if the 
server you are connecting to supports it. 

Check the global bandwidth limit 

 Determine whether the global bandwidth limit is limiting your throughput. This setting in Global 
Options throttles the bandwidth of all sessions on CuteFTP. See Global bandwidth limits. 

TRANSFERRING MANUALLY 

Use this function to transfer a specific file if you know its exact location and you are unable to navigate to 
that location or do not have LIST permissions for that folder. 

To download a file manually 

1. In the Local pane, open the destination folder. 

2. Connect to the site where the file exists. 

3. In the Remote pane, click any file or folder. 

4. On the main menu, click File > Download Advanced > Download Manually. The File to 
Download dialog box appears. 
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5. In Download path, type the path to the file you want to download.  

6. Click OK.  

To upload a file manually 

1. Connect to the site to which you want to upload the file. 

2. Open the destination folder in the Remote pane. 

3. In the Local pane, select the file you want to upload. 

4. On the main menu, click File > Upload Advanced > Upload Manually. The File to Upload 
dialog box appears. 

5. In Upload path, type the complete path to the file you want to upload.  

6. Click OK. 

CONFIGURING OPTIONS FOR COMPLETED TRANSFERS 

You can configure CuteFTP to disconnect, shut down, and/or log off after transfers have completed. 

To access transfer event settings 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Transfer node, then click Events. The Events options appear. 

3. Configure options as described below. 

 In the After all transfers have finished box, specify one of the following actions: 

o Do Nothing - Keep the connection and CuteFTP open after all transfers are 
complete. 

o Disconnect from site - Close the connection, but keep CuteFTP open after all 
transfers are complete. 

o Disconnect and close program - Close all connections and close CuteFTP 
after all transfers are complete.  

o Disconnect from Internet - Close the dial-up connection automatically after all 
transfers are complete. 

o Shut Down Computer - Close all connections, close CuteFTP, close the dial-up 
connection, and shut down the computer after all transfers are complete. 

o Log Off - Log the current user off the computer automatically after all transfers 
are complete. 

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

SPECIFYING TIME CUTEFTP WAITS AFTER A TRANSFER COMPLETES 

You can configure CuteFTP to keep a thread open for a specific number of seconds after a transfer is 
complete. Leaving data connections open allows more transfers to use the same connection, avoiding the 
need to open new connections. 

To specify the wait time that CuteFTP 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 
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2. Expand the Transfer node, then click Events. The Events options appear. 

3. In the Close the file transfer thread n seconds after the transfer is finished box, specify the 
time that CuteFTP will wait to close the data connection after a transfer is complete.  Specify a 
time between 0 and 1,000 seconds.  

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

EXECUTING COMMANDS ON DOWNLOADED FILES 

As old items build up in the queue, it can consume large amounts of memory. Use the settings on the 
Events node to remove old items from the queue and to preserve the local and/or remote time stamp. 

To execute commands on downloaded files 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Transfer node, then click Events. The Events options appear. 

3. Select the Execute the following command on the downloaded file check box to execute the 
command value on the specified executable file displayed in the edit box below the check box. 
Browse for the file to define the path of an executable, batch file, and so on. You can enter your 
own command line parameters by typing them in the edit box; the system appends the full path of 
the downloaded file to that string.  
 
For example, if the Execute the following command value is "c:\windows\system32\csript.exe" 
"c:\documents and settings\ghoffer\mydocuments\check.vbs", then with this value turned on, if 
you download a file "foo.dat" to "d:\temp\", the command is executed in the following way: 
 

"c:\windows\system32\cscript.exe" "c:\documents and 

settings\ghoffer\mydocuments\check.vbs" "d:\temp\foo.dat"  

4. Click Apply if you are going to make changes to other pages; click OK to save changes and 
close the Global Options dialog box. 

MANUALLY ENTERING FTP COMMANDS 

You can communicate with an FTP site on the lowest possible level. 

To manually enter an FTP command 

1. Connect to a site. 

2. On the main menu, click Tools > Enter FTP Command. 

3. In the Input FTP command box, type a command such as LIST or CWD or PWD. 

4. Click OK. 

 

You can also input multiple commands to the FTP server by using the Custom Commands feature.  
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MANAGING FILES AND FOLDERS 

OPENING, EDITING, RENAMING, AND DELETING FILES 

You can manage your files on both local and remote drives from within CuteFTP.  

Because of the way in which various type of servers handle files and to make file maintenance easier, 
keep the following in mind when naming your files and folders: 

 Keep names short. Some servers only allow a certain number of characters.  

 Create meaningful names using whole words to avoid ambiguity and so that you do not have to 
open a file to know what it is. For example, a year after you create a Web page for your friend's 

cat, Greta, you are more likely to know what pictures-of-greta.htm contains versus 

pog.htm. 

 Use lowercase for names. Some servers are case sensitive. 

 Names should never contain spaces or special characters (? * / \ : ; < > , and so on ). If you want 
to make filenames easier read, use hyphens or underscores; however, underscores are hidden if 
the filename is turned into a hyperlink. 

 For most Web sites, the main page must be called index.htm or index.html. If you rename it 

main.htm, it might not work. 

To open a file 

1. Click a file in Local Drives or the Remote pane. 

2. On the main menu, click File > Open, or click the Open icon . The applicable program opens 
or runs the file. 

To edit a file (HTML) 

1. Click a file in Local Drives or the Remote pane. 

2. On the main menu, click File > Edit or View. The file opens in CuteFTP's built-in HTML editor or 
the HTML editor that you have specified in Global Options. 

3. Make any desired changes.  

4. On the main menu, click File > Save. 

 

You can configure the built-in editor to open in full-screen mode or in tab view. When you exit the editor, 
CuteFTP restores the screen to its original state. Cycle through the open panes, including any editor tabs, by 
pressing CTRL+TAB. 

To rename a file 

1. Click a file in Local Drives or the Remote pane. 

2. On the main menu, click File > Rename or right-click the file and click Rename.   

3. Type a new name for the file, then press ENTER. 

4. The renamed file is highlighted and the sequence of the file is changed alphabetically. For 
example, if the file name was S.txt, and the name of the file is changed to A.txt, then the 
sequence of the file changes. The file A.txt appears where all files starting with alphabet A 
appear. 
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If you change the extension when you rename the file, you may not be able to open the file in the proper 
program. 

To delete a file 

1. Click a file in Local Drives > Remote pane. 

2. On the main menu, click File > Delete. A confirmation message appears. 

3. Click Yes. 

UPDATING OR REFRESHING FOLDER LISTINGS 

To update or refresh a folder listing 

1. Click in the pane where the folder is displayed. 

2. On the main menu, click View > Refresh. 

To update remote folder listings automatically 

1. On the main menu, click Tools > Global Options (or press ALT+F7). The Global Options dialog 
box appears. 

2. Expand the Navigation node, then select the Auto-refresh the remote pane after uploading a 
file or folder check box. 

3. Click OK. 

LISTING FILES AND FOLDERS IN ORDER 

You can sort the display of the files and folders in the Remote, Local, and Queue panes. Sorting is for 
ease of finding a file or folder; it does not affect the transfer order of the files/folders in the Queue. 

To sort files and folders in order by name 

1. Click in the Remote or Local Drives pane. 

2. On the main menu, click View > View > Details. 

3. Click the Name column header in the Remote or Local drives pane. 

4. Each time you select the column header the items are sorted in the opposite order. 

 

You can sort by any column when in Details view. 

To sort files and folders in order in the Queue 

1. Click in the Queue pane. 

2. Click a column header in the Queue pane. The transfer items are listed in alphabetic order of the 
selected column's contents. 

3. Each time you select the column header the items are sorted in the opposite order. 
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The order items are listed in the Queue is not necessarily the order in which they transfer. The numbers in the 
left-most column of the Queue indicate the order of transfer. For example, when the Queue is sorted 
alphabetically by Item Name, the transfer order stays the same. 
 

 

CHANGING HOW FILES AND FOLDERS ARE DISPLAYED 

You can display files and folders with large or small icons, in a list, or with file size and date-modified 
details. 

Large Icons - Displays files and folders as large icons 

Small Icons - Displays files and folders as small icons 

List - Displays files in a list, but no folders, and no details 

Details - Displays files and folders in a list with the file or folder size, type, and date modified 

To display files and folders as large icons, do one of the following: 

 Right-click in the Local or Remote pane, then click View > Large Icons. 

 On the main menu, click View > View > Large Icons. 

To display files and folders as small icons, do one of the following: 

 Right-click in the Local or Remote pane, then click View > Small Icons. 

 On the main menu, click View > View > Small Icons. 

To display files in a list, but no folders, and no details, do one of the following: 

 Right click in the Local or Remote pane, then click View > List. 

 On the main menu, click View > View > List. 

To display files and folders in a list with the file or folder size, type, and date modified, do one of 
the following: 

 Right-click in the Local or Remote pane, then click View > Details. 

 On the main menu, click View > View > Details. 

FINDING FILES AND FOLDERS 

CuteFTP Site Search function allows you to search local and remote drives and folders for files based on 
all or part of the filename with wildcard support, modification date or date range, and file size or size 
range.  
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To find a file or folder 

1. On the main menu, click Edit > Find. The Search Results dialog box opens. 

2. Next to Search in, specify whether to search on the local or remove pane. 

 Local drives - If you want to search for a file in your local drive. 

 Remote pane - If you want to search for a file in the remote pane. 

3. In the Search for the files or folder named box, type the name of a file or folder, or the 
extension of a file for which you want to search. The name or the extension of the file is added to 
the drop-down list. You can also use wildcards. 

4. In the Look in box, specify the folder to search or type the path. 

5. To include the subfolders in the target folder, select the Search subfolders check box. 

6. To define the file size, select the File size between check box, then type the number of kilobytes 
in the text boxes. 

7. To specify a date range, select the Date modified between check box, then type or select the 
date range in which to search. 

8. To start the search, click Search Now. 

9. To stop the search, click Stop search. 

10. All of the files with the same extension or with same name with other details, such as size, type, 
modified on, and attributes are listed in the Results pane of the Search Results dialog box. 

 

Find and Find Next are not case sensitive and only search from the top to the bottom of your listings. 

SELECTING A GROUP OF ITEMS 

You can select (highlight) items in the remote, local, or queue pane by name or type using Group Select 
and wildcard masks. 

To select all files of a certain type 

1. Click in the pane displaying the files you want to select. 

2. Do one of the following: 

 On the main menu, click Edit > Group Select. 

 Press the PLUS SIGN (+) on the number pag. (Be sure NUM LOCK is on).  

The Select group dialog box appears. 
 

 

3. In the Select mask box, do one of the following: 

 Type *. and the extension of the file type you want to group select. For example, to group 

select all gif files, type *.gif. 
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 Type a string to match. For example, if you type doc, all items containing the string doc, 

regardless of file type, are selected. 

4. To group select only files (not folders), clear the Mask directories check box. 

5. To include previously selected files in the new group you are defining, select the Remove 
Selection check box. Clear the check box to exclude previously selected items that are not in the 
new group.   

6. Click OK. Files of the specified type are selected (highlighted) in the pane. You can now manage 
them (transfer, copy, delete, move, etc.) as a group. 

To switch the selection between the highlighted group and all non-highlighted items 

 With a group selected, on the main menu, click Edit > Invert Selection or press * (asterisk). 

To remove items from a group selection 

If you have selected a large group of items then decide you want to remove certain items or file types 
from the group, use the procedure below. 

1. With a group selected, on the main menu, click Edit > Group Deselect. 

2. In Deselect group, type the name of the file or file type you want to remove or use wildcard 
masks to remove a group of items. 

3. Select the Mask directories check box to include folders in the action. 

4. Click OK. 

MOVING ITEMS FROM ONE FOLDER TO ANOTHER ON A REMOTE 
SERVER 

You can move selected items from one remote folder to another remote folder on the same server. 

To move items from one remote folder to another 

1. Connect to the site, then open a folder on the remote site. 

2. Select items in the folder. 

3. Do one of the following: 

 On the main menu, click Edit > Move to Folder. 

 Right-click the file, then click Move to. 

4. In the Move items to box, specify the path at which to save the selected items. 

5. Click OK. 

 

CuteFTP does not create the folder. If the folder does not exist, an error message appears. 
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CHANGING FILE AND FOLDER PERMISSIONS ON REMOTE SITES 

You can set who can open, change, or delete files and folders on remote sites. 

To change permissions for a remote file(s) or folder(s) 

1. Connect to a site. 

2. Select the file(s) or folder(s) for which you want to change permissions. 

3. On the main menu, click File > Properties. 

4. Select the check boxes next to the permissions you want for yourself (Owner), a Group of users, 
and the Public. 

 When multiple items are selected, a gray check mark signifies the permission is granted 
for some files in the group, but not in others. You can still change the permission for the 
whole group. 

 If you cannot change permissions for a file or folder, the FTP server administrator must 
modify your account or the file permissions. 

5. Click OK. 

CHOOSING THE FILES AND FOLDERS TO DISPLAY (FILTERING) 

When you apply filters, you do not add or remove files, you simply set which files will be visible or invisible 
in CuteFTP. 

To choose which files/folders to display 

1. On the main menu, click View > Filter. 

2. Select the Enable Filtering check box. 

3. Select the following check boxes as needed: 

 To apply the filter to folders, select the Apply filtering to folder name(s) check box. 

 To use filters with transfers, select the Apply to file transfers check box. 

 To make filters case sensitive, select the Case sensitive filtering check box. 

 To use server filters, select the Enable server side filtering check box, and type a filter 
from the Unix ls program. 

4. Click the Filter Mask tab. 

5. Type the names of files/folders you want to display, or use wildcard masks to include a group of 
files, then click Add. 

6. Select the Filter NOT Mask tab. 

7. Type the names of files/folders you want to hide, or use wildcard masks to exclude a group of 
files, then Add.  

8. Click OK. 
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Below are a few of the LIST wildcards (parameters) and combinations that can be passed to the ls program 
running on a UNIX server: 

Parameter Definition 

-l Display a list of files in the current directory, and information about each file (long format) 

-a Display hidden files 

-la Display a list of files in long format and include hidden files 

-l *.ext Display a list of files with a specific extension (*.html, *.txt, etc.) 

ls r* Displays a list of files with names beginning with r (or any other letter) 

-t Sort display by time stamp 

-R Sort recursively 

-lt Display files in long format, sorted by time 

-t *.ext Displays a list of files with a specific extension (*.html, *.txt, etc.), sorted by time 
 

DISPLAYING HIDDEN FILES OR FOLDERS 

By default, some servers will hide files with names starting with a period such as ".htaccess" or ".profile".   

To display hidden files on a remote site 

1. In the Site Manager, click the site with the hidden files. 

2. On the Actions tab, click Filter.  

3. Select the Enable filtering check box.  

4. Select the Enable server side filtering check box.  

5. In the Remote filter field, type -a, then click OK. 

6. Connect to the site. You should now be able to see hidden files and folders. 

BACKING UP LOCAL FILES TO REMOTE HOST  

You can back up files and folders from your local computer to a remote host. The Local Backup Wizard 
guides you through the process of selecting the files and folders to be backed up and specifying other 
settings. 

To backup local files to remote host 

1. On the main menu, click Tools > Folder Tools > Backup Local to Remote. The Choose 
Backup or Restore dialog box appears. 
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2. Click Create Backup, then click Next. The Local Backup Wizard appears. The Local Backup 
Wizard contains the list of all local files and directories on your local computer. 

 

3. Select one or more check boxes adjacent to the files and folders to backup, then click Next.  
 
When you select the check box for a folder, each of the subfolders and files in that folder are 
selected automatically. To clear the check boxes for the subfolders and files the folder, clear the 
check box next to the parent directory. 

 

4. In the Select site to backup to page, click the site. The parent directory for the site appears in 
the Select remote folder box. If necessary, specify the subfolder of the remote folder to which 
you want to save the backup, then click Next. 
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5. Select the compression settings from the following options, then click Next. 

 No compression 

 Compress all files to a single ZIP file - ZIP is an industry standard archival method. ZIP 
supports most of the files, but provides medium compression. 

 Compress all files to a single CAB file - CAB is a Microsoft format. It provides stronger 
compression than ZIP.  

 Compress all files to single GZIP file - GZIP/tar is a UNIX format. Files are stored in a 
“Tarball”, and then compressed.  

The Schedule page appears.  

 

6. Select the Immediately run backup job option to take the backup immediately. 

- or - 

Select the Schedule local backup check box to set the date and time. 

7. Set the date and time for the local backup from the Start on calendar if you select the Schedule 
option. 

8. Select the Enable backup recurrence check box to repeat the synchronization after a specified 
period. 

9. In the Repeat every list, specify a time and unit (minute, hours, days, weeks, months, years). 

10. In the Name box, specify a name for the backup folder. 

11. Click Finish. The backup folder appears in the remote folder of the server. 
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INTEGRATED HTML EDITOR 

For the procedures for customizing the built-in HTML Editor, refer to Helper Applications. 

CREATING A NEW HTML DOCUMENT 

You can create new HTML documents within the CuteFTP interface. 

To create a new HTML document 

1. Do one of the following: 

 On the main menu, click File > New > HTML Document. 

 On the HTML Editor toolbar, click the New HTML document   icon. 

 Press CTRL+H. 

A new HTML document appears in which you can use HTML tags to create the document. 

2. Type the content of your HTML document, that is, the part you want your viewers to see, between 
the two BODY tags.  

 

Every HTML document must contain, at minimum, the tags in the default HTML template. The 
template as is will display a blank page. 

3. To change HTML editor settings, including editing the default template, and opening in full view 
instead of tab view, refer to HTML Editor Settings. 

EDITING THE DEFAULT HTML TEMPLATE 

All HTML documents should contain the following tags:  

 Document Type <HTML></HTML> (beginning and end of file)  

 Header <HEAD></HEAD> (after the HTML tag, but before the BODY tags, includes descriptive 
info, such as title)  

 Title <TITLE></TITLE> (must be in header)  

 Body <BODY></BODY> (after the HEAD tags, bulk of the page)  

When you create a new HTML document with CuteFTP's HTML Editor, it uses the default HTML template 
shown in the New document template dialog box.  

To open the default HTML template 

1. On the main menu, click Tools > Global Options. The Global Options dialog box appears. 

2. Expand the Helper Applications node, then click HTML Editor. 



 

116 ● HTML Editor Toolbar  

3. Click Edit new document template. The New document template dialog box appears. 
 

 

Each of the tags shown in the template are required, except for the META tags. The attributes in 
the Body tag, BGCOLOR="#FFFFFF" TEXT="#000000" LINK="#0000FF" VLINK="#800080", 
define the background color (BGCOLOR is white), text color (black), and the colors of hyperlinks 
(blue) and visited hyperlinks (dark magenta) in the document.  

4. Add/remove tags or edit attributes that you want to appear in each of your new HTML documents, 
then click Close. The changes are saved when you close the dialog box. 

A link to your style sheet is one tag you might want to add to your default template.  

HTML EDITOR TOOLBAR 

When a document is open in CuteFTP's built-in HTML Editor (click Tools > HTML Editor, or press 
CTRL+H), the following HTML Editor toolbar icons are available.  

 

To close the HTML Editor, right-click within the editor, click File, then click Close. 

 

Name Icon Function 

New HTML 
document 

 

Opens a new HTML document in the editor 

Save 
 

Save the document as web page (htm or html) 

Undo 
 

Click this to undo an action 

Redo 
 

Click this redo an action 

Find/Replace 
 

Finds and replaces the words in an HTML document 

View in Browser 
 

Opens the document in your default Web browser 

Bold 
 

Formats text as bold 

Italics 
 

Formats text as italicized 

Underline 
 

Formats text as underlined 

Insert Anchor 
 

Opens the Anchor Tag dialog box in which you can assign hyperlinks to a specific location 
in a topic. (Similar to a bookmark.) 
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Name Icon Function 

Insert Image 
 

Opens the Image tag dialog box in which you can browse to a folder and specify an image 
to insert in an HTML document 

Set Font 
 

Opens the Font tag dialog box in which you can specify the font face, color, and size for 
text 

Insert Comment 
 

Inserts the opening and closing comment tags. Type the desired comment between the 
tags. The comment does not appear when the page is viewed in a browser. 

Insert Table 
 

Inserts the HTML table tags for the specified number of rows and columns, into which you 
can type your text 

To show/hide the toolbar, refer to Displaying and Hiding the Toolbar. 

FINDING AND REPLACING TEXT IN HTML DOCUMENTS 

Using the integrated editor's powerful search and replace tool, you can search and replace characters, 
words, sentences, or entire paragraphs  

To open search and replace 

1. Click within the HTML Editor pane, then on the main menu, click Edit, then click Find/Replace 
(or press CTRL+F). The Find/Replace dialog box appears. 

2. In the Search for box, type the words to search for or change. 

3. In the Replace with box, type the replacement words or phrase. 

 

When entering text into the Search for or Replace with fields, use Ctrl+Enter to insert a line break. 

4. In the Where to search area, specify whether to search only the selected document or all open 
documents. 

5. If you want to match upper or lower case (depending on which you have typed in the boxes 
above, select the Match case check box. 

6. Click Find. 

7. If a match is found, it is replaced. To continue to search and replace throughout the document, 
select Find Next for each instance (or press F3). 

 

Because it replaces all occurrences, be very careful when choosing the replace option. For example, if you want 
to change all occurrences of 'one' to '1', it will also change words like 'everyone' to 'every1'. 
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VIEWING DOCUMENT INFORMATION  

The Document Data dialog box provides information about the document currently being edited. 

 

 The Text Size area displays the total size of text contained in the document, in kilobytes. 

 The Image Size area displays the total size of images contained in the document, in kilobytes. 

 The Total Size area displays the total size of text and images combined, in kilobytes. 

 The Weight area displays the approximate number of seconds your page will take to load based 
on the size of the file and the modem speed of your viewers. Click the down arrow on the modem 
speed box to see how soon the page displays at various speeds.  

 The Images box displays a list of all images in the document. 

 The Anchors box displays a list of all anchors in the document. 

 If the number of seconds in the Weight area seems excessive, you can shorten the time it takes 
to display your page by doing some or all of the following: 

o Remove excess code or text, or use smaller graphics files.  

o If you are using graphics to display bullets in lists, remove the images used for the 
bullets, and instead use list tags to create lists. You will also have fewer files to transfer 
and maintain if you eliminate the graphic bullets.  

o Use a style sheet (CSS file) and link each of your pages to the style sheet. You will need 
fewer tags within each document, creating smaller files with a faster upload speed. Style 
sheets also create a "consistent look and feel" for your site. For more information about 
using style sheets, refer to http://www.w3schools.com/css/default.asp. 

o Review your code for extra tags that you do nothing to enhance your page. For example, 

this <P>&nbsp;</p> makes a blank line. If you do not need the extra line, you can 

remove it; however, adding "white space" such as this to HTML pages often enhances 
readability. 

o Use tables to design the layout, rather than using multiple &nbsp; (non-breaking space) 

tags to indent text.  

http://www.w3schools.com/html/html_lists.asp
http://www.w3schools.com/css/default.asp
http://en.wikipedia.org/wiki/White_space_(visual_arts)
http://www.w3schools.com/html/html_layout.asp
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BASIC HTML TAGS 

All HTML documents should contain the following tags:  

 Document Type <HTML></HTML> (beginning and end of file)  

 Header <HEAD></HEAD> (after the HTML tag, but before the BODY tags, includes descriptive 
info, such as title)  

 Title <TITLE></TITLE> (must be in header)  

 Body <BODY></BODY> (after the HEAD tags, bulk of the page)  

When you create a new HTML document with CuteFTP's HTML Editor, it uses the default HTML 
template. You can change the attributes as you see fit. 

The HTML Editor toolbar allows you to insert basic HTML tags into your page, without any prior 
knowledge of HTML code. 

To format text 

 Select the text you want to format, then do one of the following: 

o To bold the text, click the Bold icon . 

o To italicize the text, click the Italic icon . 

o To underline the text, click the Underline icon . 

o To format the font face, size, and color, click the Font icon . In the Font tag dialog 
box, click the down arrow to specify the Font (e.g., Arial), Color (e.g., Red), and Size 
(e.g., 1). As a base font size for a document, 1em (or 100%) is equivalent to setting the 
font size to the user's preference. Avoid sizes in em smaller than 1em for text body, 
except for copyright statements or other kinds of "fine print." Do not specify the font size 
in pt, or other absolute length units. They do not appear the same on all computers and 
cannot be resized by the browser.   

To insert a table 

 Click the Table icon  then on the graphic that appears, use your cursor to highlight the number 
of rows and columns you want. When you click the selection, the table tags appear in your 

document. Type the content for each cell between the tags. (Tip: Click the Browser icon  to 
preview how the table will look.) You can even insert images into the table.  

To insert an image 

1. Click the Image icon . The Image tag dialog box appears. 

2. Specify the location of the image, then click OK.  

 

The steps above are sufficient to insert an image; however, you can experiment with the advanced settings 
when you are comfortable in HTML. Regarding the Width and Height boxes, it is better for page loading if you 
size the graphic itself properly in your graphics editor, rather than adjusting the size with Width and Height 
attributes. Inserting a huge graphic and then downsizing it with the Width and Height attributes will cause your 
page to load very slowly (and your viewers to leave your Web site!). 
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To insert an anchor 

An anchor is used to link to a specific spot within Web page. For information about the HREF (Anchor) 
tag, refer to http://www.w3schools.com/tags/tag_a.asp. 

1. Click the Anchor icon . The Anchor tag dialog box appears.  

2. In the HREF box, type the URL (e.g., http://www.globalscape.com ). 

3. In the Target box, click an attribute: 

 _blank - the target URL opens in a new window  

 _self - the target URL opens in the same window 

 _parent - the target URL opens in the parent frame  

 _top - the target URL opens in the full body of the window  

To insert a comment 

Comments are used to notate your code to remind yourself why you inserted a particular element, or for 
team members editing the same documents. 

 Click the Comment icon . The Comment tags are inserted into the document. Type your 

comment between <!--  and -->.  

CASCADING STYLE SHEETS (CSS) 

Cascading Style Sheets (CSS) are used to define the attributes of the tags in your HTML documents. 
Although not required, they make designing and, more importantly, updating HTML documents much 
more efficient. For example, if you have defined the BODY tag in a linked style sheet to display the page 
with a white background and black text, you can change the background to yellow in one file--the style 
sheet--and that change appears in every one of your HTML documents that are linked to that style sheet. 
You can also have more than one style sheet if you want different sections of your site to have a different 
look. 

When you use a style sheet, you do not need to add the attributes for the BODY tag to every single HTML 
document. The BODY tag is defined in the style sheet, and each of your Web pages contain a link to the 
style sheet. The link to your style sheet is one tag you might want to add to your default template. For 
example, if your style sheet is named default.css, you would add the following tag between the 
<HEAD></HEAD> tags of your default template, after the META tags: 

<link rel="StyleSheet" href="default.css"> 

 

http://www.w3schools.com/tags/tag_a.asp
http://www.w3.org/Style/
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In the example above, the style sheet is placed in the same directory as the HTML documents to which it 
is linked; otherwise, you need to add a path to the style sheet in the link. For example, if your HTML 
documents are in a folder called htms and your style sheet is in a folder called css, and both of those 
folders are in a folder called myweb, you would type the link as follows: 

<link rel="StyleSheet" href="../css/ default.css"> 

The ../css/ part of the tag (red text shown for emphasis only) tells CuteFTP to search up one directory and 
look in the css directory for the file. 

Your style sheet can contain tags for just one or several tags, such as default paragraph font face, size, 
color, and margins, table format, heading styles, headers, footers, and so on.  

USING COLORS  

In HTML documents, when you want to change the font color, you have to type a hexadecimal value for 
the color. The code is in hexadecimal with a pound sign and 6 characters from 0 (zero) to F (fifteen in 
hexadecimal). Some of the most common colors are shown below; however, the Color utility in CuteFTP 
eliminates the need to memorize the HTML codes for colors. 

Color Name Hex Code RGB (Red, Green, Blue) Values 

black #000000 0,0,0 

white #FFFFFF 255,255,255 

red #FF0000 255,0,0 

blue #0000FF 0,0,255 

green #00FF00 0,255,0 

yellow #FFFF00 255,255,0 

To open the color options 

1. Click within the HTML Editor pane at the location where you want to paste the hexadecimal color 
code.  

2. On the main menu, click Tools > Color to HEX. (This option is not available if you do not click 
within the HTML Editor pane first.) The Color dialog box appears. 

3. Click the color to use. 

4. If you want to use browser-safe colors only, select the Paste browser safe color check box . 

5. Choose OK to insert the HEX code for the selected color into your document. 



 

122 ● Saving HTML Documents  

For more information about using colors in HTML documents, as well as a chart of many different color 
codes, refer to http://www.w3schools.com/html/html_colors.asp. 

 

You can view or choose a color number using the Color Picker in most graphic editors.  

 

SAVING HTML DOCUMENTS 

To save an HTML document 

1. Make sure the file you want to save is visible in the right pane.  

2. Do one of the following: 

 To save the file is saved in its current location with its current name, do one of the 
following: 

o On the main menu, click File > Save. 

o On the HTML editor toolbar, click the Save icon . 

o Press CTRL+S. 

o Right-click within the HTML document, click File > Save. 
  

 

If the file has never been saved before, CuteFTP opens the Save As dialog box. 

 To save the file with a new name and/or location, do one of the following: 

o On the main menu, click File > Save As.  

o Right-click within the HTML document, click File > Save As. 

o In the Save As dialog box, specify the file name and location, then click Save. 

 

Each open HTML document has a tab with its name on it. 

http://www.w3schools.com/html/html_colors.asp
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OPENING AN HTML DOCUMENT FOR EDITING 

You can open HTML documents for editing within CuteFTP. 

To open an HTML document for editing 

1. Do one of the following: 

 On the main menu, click File > Open file (or press CTRL+O). In the Open dialog box, 
browse to and select the document, then click Open. 

 In the Local or Remote pane, right-click the document, then click Edit. 

2. The document opens in the editor that you have specified in Helper Applications. 

When you edit the document in the HTML Editor, the file name text in the tab turns red and is underlined 
to indicate that the file has been modified. 

PREVIEWING AN HTML DOCUMENT IN A BROWSER 

From within CuteFTP, you can open an HTML document in your default browser. 

To preview an HTML document in a browser 

1. Open an HTML document in CuteFTP.  

2. Click anywhere in the document, then do one of the following: 

 On the main menu, click Tools > View in Browser. 

 On the HTML editor toolbar, click View in Browser .    

To close the preview 

 Do one of the following: 

o In the upper-right corner of the browser window, click Close . 

o On the main menu of the browser, click File > Close. 

EDITING AN HTML DOCUMENT ON A REMOTE SITE 

To edit HTML documents on a remote site 

1. Connect to a remote server. 

2. In the Remote pane, click an HTML document. 

3. Do one of the following: 

 On the main menu, click File > Edit. 

 Right-click the file, then click Edit. 

 Press CTRL+ENTER. 

4. The document will be downloaded and opened in the built-in HTML editor or the editor you have 
defined in Global Options. 

5. Make your changes to the document, then save the changes. The saved document will be 
uploaded to the remote server. 
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When you edit the document in the HTML Editor, the file name text in the tab turns red and is underlined 
to indicate that the file has been modified. 

PRINTING AN HTML DOCUMENT 

To print a document 

1. Open a document in the HTML editor. 

2. Do one of the following: 

 On the main menu, click File > Print.  

 Press CTRL+P. 

 

The document prints as it appears in the HTML editor, NOT as it appears in a browser. 

To see a print preview 

1. Open a document in the HTML editor. 

2. On the main menu, click File > Print Preview. The Preview dialog box appears. 

3. Do one or more of the following:  

 To increase/decrease magnification, click Zoom In/Zoom Out. 

 To display two pages at a time, click Two Page. 

 To scroll through multiple pages, click Next page and Prev Page. 

 To send the document to the printer, in the preview dialog box, click Print. 

 Click Close to close the dialog box. 

To change the printer setup (such as the printer, paper size or orientation) 

1. Open a document in the HTML editor. 

2. On the main menu, click File >  Print Setup. The Print Setup dialog box appears. 

3. Specify the printer, printer properties, paper size, paper source, and orientation, then click OK to 
accept, or Cancel to abort changes. 

 

While a document is printing, a printer icon appears next to the clock on the task bar. When this icon 
disappears, your entire document has been sent to the printer. 

CLOSING AN HTML DOCUMENT 

To close an HTML document 

1. Make sure the document you want to close is visible in the right pane. 

2. Do one of the following: 

 On the main menu, click File > Close.  

 In the upper-right corner of CuteFTP, click Close . 

 Right-click within the HTML document click File > Close. 
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3. If your document has unsaved changes, you are prompted to save the changes. Click one of the 
following:  

 Yes to save the document.  

 No to exit without saving the document.  

 Cancel to return to the document without saving the document.  

OPENING THE HTML EDITOR IN A FULL WINDOW 

The HTML editor opens either in the Remote pane or a full window, depending on the selection in Global 
Options.  

To open an HTML document in the Remote pane or a full window 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Helper Applications > HTML Editor. The HTML Editor options appear. 

3. Select or clear the Display editor using Full-Screen view check box.  

 

In Full-Screen view, the editor in opens in the full CuteFTP window. To close Full-Screen view, click the 
 in the upper-right corner or on the main menu, click File, then click Close. The CuteFTP interface will 

reappear. 

ADDING COUNTERS AND OTHER UTILITIES 

GlobalSCAPE does not offer support for creating or coding advanced HTML. If you want to add counters, 
animations, or other special effects to a Web page, you will need to seek other sources. Many Web 
hosting services (e.g., Yahoo) provide extras, such as counters, that you can add to Web pages hosted 
on their servers. Usually, the code that they provide you to paste into your Web page links to code stored 
on their server, so the same code might not work if you move your Web page to a different server.   

Search your Web hosting provider's Web pages to see if they offer code for counters or other add-ons. 
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LEARNING HTML 

HTML code uses tags to define how text, pictures, and other objects are to appear in a Web browser, 
such as Internet Explorer. Numerous Web sites explain HTML tags and how to use to use them. Like 
software applications, HTML code comes in versions, some of which are not supported by common 
browsers. For the most current version of HTML code that is supported by most common browsers, 
search the Web for free guides and tutorials. The World Wide Web Consortium, a cooperative of Web 
developers and designers, provides standards for HTML and CSS code, as well as tutorials for beginners 
and advanced users. 

While you search for tutorials about how to code your Web pages, keep in mind that, although most 
browsers still support HTML v4, many Web developers have moved on to XHTML, which is a more strict 
version of HTML. Also, most Web sites now use cascading style sheets (CSS) to help maintain a 
consistent design across all Web pages on the site, and allow you to update an entire Web site design 
simply by changing one file--the style sheet. 

Here are a few references to get you started: 

 NCSA Beginner's guide to HTML. 

 Getting started with HTML 

 W3 Schools (Web building tutorials for beginners to developers) 

 Introduction to HTML, including listings of common tags 

http://www.w3.org/
http://www.w3.org/MarkUp/Guide/
http://www.w3.org/MarkUp/Guide/Advanced.html
http://archive.ncsa.uiuc.edu/General/Internet/WWW/HTMLPrimer.html
http://www.w3.org/MarkUp/Guide/
http://www.w3schools.com/
http://www.w3schools.com/html/html_intro.asp
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CUTEPODCAST MANAGER 

ABOUT CUTEPODCAST MANAGER 

CutePODCast Manager provides you a user-friendly Windows interface to subscribe to media files from 
an RSS feed using its Subscriptions option and to publish media files in the form of an RSS feed using its 
Publications option.  

Subscribing to CutePODCast Manager allows users to collect programs from a variety of sources for 
listening or viewing even when the user is offline. 

The publish and subscribe model of PodCasting is a version of push technology. The information provider 
chooses which files to offer in a feed, and the subscriber chooses among available feed channels.  

Benefits and Features 

CutePODCast Manager offers the following benefits and features: 

 Subscribe to multiple feeds 

 Schedule downloads 

 Manage episodes 

 Play selected episodes  

 Download selected episodes 

 Upload feeds 

 Set skip hours for uploads 

To open CutePODCast Manager, see Getting Started. 

For a list of available Podcasts, visit http://www.podcast.net/. 

GETTING STARTED  

CutePODCast Manager's Interface 

CutePODCast Manager's Interface is used to configure and schedule subscriptions for RSS feeds and to 
configure channels and publications.  

The CutePODCast Manager window consists of three panes: 

http://www.podcast.net/
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Navigation Pane 

The Navigation pane contains the Subscriptions tab and the Publications tab. The Navigation pane 
allows you to navigate through your subscribed and published feeds. You can add, delete, update, and 
rename feeds, and add episodes on the Navigation pane. 

The tree view allows the creation of folders and subfolders that you can use to organize PODCast 
subscriptions and publications. You can drag and drop feeds into parent or child folders in the tree. 

The Subscriptions tab is used to add and manage subscriptions to RSS feeds. The right-click menu in 
the tree provides the following functions: 
 

 Adding New Channels to Subscriptions 

 Create a new folder 

 Delete an item 

 Renaming Channels in Publications 

 Renaming a folder 

 Downloading Episodes from Feeds in Subscriptions 

 Updating Channels in Subscriptions 

 



 

CutePODCast Manager ● 129 

 

By default, the Subscriptions tab is in front of the Publications tab; however, if the Publications tab is selected 
when you close the Cute PODCast Manager, then the Publications tab retains the focus the next time you open 
the CutePODCast Manager. 

The Publications tab is used to add and manage newsgroups. The right-click menu in the tree provides 
the following functions: 
 

 Adding New Channels to Publications 

 Adding Episodes to Feeds in Publications 

 Creating a New Folder 

 Deleting Channels from Publications 

 Renaming Channels in Publications 

 Renaming a folder 

 Uploading Episodes for Publication 

To create new folder 

 Right-click a selected feed or folder, then click New Folder. 
  

 

If you right-click the mouse and select New Folder without selecting any channel, then the new folder 
is created under the parent node.  

To delete an item 

 Right-click the item, then click Delete. 

To rename a folder 

 Right-click the folder, then click Rename.  

Details Pane 

The Details pane contains the Configuration tab and the Episode Details tab.  

The Configuration tab displays the following information for an item selected in the Navigation pane: 

 Configuration and subscription details for a subscription.  

 Channel settings and the publish configuration for a publication selected in the Navigation pane.  

 Subscriptions Details for a feed selected in the Navigation pane.  

The Episode Details tab displays information about an item selected in the Navigation pane, including 
details of the episodes in subscriptions and publications, such as the title, description, and so on. You can 
also perform various operations on the episodes, such as play an episode, delete an episode, and so on. 

Episodes Pane 

The Episodes pane displays the title, publication date, size, and other details of an episode or feed 
selected in the Navigation pane.  
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CutePODCast Manager Toolbar 

The CutePODCast Manager toolbar provides the following functions: 

Name Icon Function 

New Feed 
 

Adds a new channel to your subscriptions. For publications, 
this invokes the Publication Wizard. 

Delete Feed 
 

Deletes a selected channel from your subscriptions or 
publications. 

Download 
 

Downloads all the episodes of the selected channel from your 
Subscriptions. You can view the download details in the 
CuteFTP Queue pane. 

Upload 
 

Uploads the selected channel from your publications. You 
can view the upload details in the CuteFTP Queue pane. 

Update 
 

Updates the details and episodes of a subscribed channel. 

Filter 
 

Filters the list of episodes in a subscribed channel based on 
the specified criteria. 

CutePODcast Manager Episode Details Toolbar 

The Episode Details toolbar provides the following functions: 

Name Icon Function 

Play 
 

Downloads and plays the selected episode from a subscribed channel. 

Delete 
 

Deletes the selected episode from a subscribed or published channel. 

Upload 
 

Uploads the selected episode for publication. 

Download 
 

Downloads the selected episode from a subscribed channel. 

Add 
 

Adds an episode to a published channel. 

 

 

These icons are only available when an episode is selected in the Episodes pane. 

Publication Wizard 

The Publication Wizard is used to easily add new channels and episodes. 

To add a new channel and episode 

1. On the Publications tab, click the Publications node. 

2. On the toolbar, click the New icon . The Publication Wizard appears. 

3. Provide the channel settings, then click Next. (For information on the Channel settings, refer to 
Configuring channel settings for publications .) 

4. Provide the publish configuration information, then click Next. (For details of publish 
configuration, refer to Configuring Channels for Publications.) 

5. Provide the publication information for new episodes or leave the fields empty to do it later, then 
click Next. 

6. The last page of the wizard displays the channel summary. Click Finish. The new channel is 
added. 
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MANAGING SUBSCRIPTIONS 

Configuring Subscription Settings 

You can specify the configuration settings for all subscriptions. Configuration settings are inheritable. The 
values set for the Subscriptions folder are applied to the new child nodes by default. However, you can 
modify the settings for each channel or subfolder. 

To configure general subscriptions settings 

1. In the Navigation pane, click the Subscriptions tab, then do one of the following: 

 To configure the setting for all subscriptions, click the Subscriptions folder. 

 To configure the settings for a specific feed or subfolder, click the feed or subfolder. 

2. In the Details pane, click the Configuration tab. In the Channel Details area, the name, URL, 
and description of the selected feed appear. 

 To download new episodes, select the Download new episodes check box, then click an 
option in the drop-down list (Every time CuteFTP starts, or Every Week, Day, or Hour). 

 To keep only recent episodes, select the Keep only the check box, then type or select 
the number of most recent episodes to keep. 

 In the Download path box, specify the location in which to save the episodes. 

3. Click Apply. 

Adding New Channels to Subscriptions 

You can subscribe to numerous channels that are available on a variety of servers. 

To add a new channel to subscriptions 

1. In the Navigation pane, click the Subscriptions tab, then do one of the following: 

 On the toolbar, click the New icon . 

 Right-click Subscriptions, then click Add New Channel.  

The Add New Channel dialog box appears. 

2. In the Channel URL box, type or paste the URL for the RSS feed, then click OK. The application 
validates whether the specified channel is a valid RSS feed. 

3. Do one of the following: 

 If the RSS feed is found, CutePODCast Manager parses the feed and downloads the 
media episodes. The channel is added to the subscriptions in the Navigation pane and 
the episodes found are listed in the Episodes pane. 

 If the load fails, a message such as Failed to download the channel or Channel 
contains no episodes is displayed. Click OK to close the message, then try again after 
verifying the URL. 

4. Click Apply to save the subscribed channel. 

Deleting Channels from Subscriptions 

Deleting a channel clears the channel from the Navigation pane, but does not affect the server. You 
cannot delete channels or feeds off of the server from within the CutePODCast Manager. 
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To delete a channel from subscriptions 

1. On the Navigation pane, select the channel under Subscriptions, then do one of the following: 

 On the toolbar, click the Delete Feed icon . 

 Right-click the channel, then click Delete.  

A confirmation message appears. 

2. Click Yes to delete the channel. 

Updating Channels in Subscriptions 

The CutePODCast Manager allows you to update channels in subscriptions by downloading the latest 
RSS XML file, then parsing, and updating the episode list. When you update a channel, all episodes 
added to the channel are displayed in the Episodes pane. 

To update a feed in subscriptions 

1. In the Navigation pane, select the channel under Subscriptions, then do one of the following: 

 On the toolbar, click the Update icon . 

 Right-click the channel, then click Update.  

2. The selected channel is updated and all the episodes added to the channel are displayed in the 
episodes pane. 

Episodes in Subscriptions 

A channel can contain one or more episodes. An episode is an individual news article or announcement 
present in an RSS feed or channel. The owner of a channel adds new episodes as content becomes 
available.  

In the CutePODCast Manager, the Episodes pane displays the title, publication date, status of 
download, and size of the file. The Keep column of the Episode pane contains a check box for each 
episode. To retain the episodes, select the Keep check box, or clear the Keep check box to remove it 
from the Episode pane. If you delete an episode, it remains on the server from which you downloaded it, 
but is no longer viewable in the CutePODCast Manager. 

Viewing Episodes in Subscriptions 

When you subscribe to a channel, all the episodes present in the channel are listed in the Episodes 
pane. You can view the episode details after you select the channel in the tree view. 

To view episodes 

1. On the Subscriptions tab, click a channel. The latest episodes are downloaded and appear in 
the Episodes pane. The first episode is selected. 

2. Click the Episode Details tab. The title, URL, and description of the selected channel appear on 
the tab. In the Episodes pane (at the bottom), the list of each of the current episodes in the RSS 
feed appear.  

3. In the Episodes pane, click an episode to view its description in the Description box of the 
Episode Details tab. 

In the example below, on the Subscriptions tab ESPN Radio Daily Podcast is selected, and in 
the Episodes pane, the podcast for 11/27 is selected. The Episode Details pane displays a 
summary of the selected podcast. 
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 If you are looking for a specific podcast, but do not recall the date, you can click each episode 
and read the descriptions until you find the one you are looking for. Alternately, you can filter the 
episodes. 

 

By default the first episode is selected. Every time the Episode tab is activated for a channel and the episode list 
is updated with the list of episodes for that channel, the first episode in the episode list is selected by default.  

Downloading Episodes in Subscriptions 

CutePODCast Manager allows you to download the episodes to your computer. The Download column in 
the episodes pane displays the status of the download. For each episode, the column displays Yes when 
the download is complete, displays No if the download fails, and In progress whenever the episode has 
been added to the queue to be downloaded. The local filename for the episode that is downloaded is the 
same as the title of the episode. 

To download an episode from channels in subscriptions 

1. In the Navigation pane, click the Subscriptions tab, then click a channel.  

2. In the Episodes pane, click the episode you want to download, then click the Download icon . 
  

 

The episode also appears in the Queue Pane of the CuteFTP window. 
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To download all episodes from channels in subscriptions 

1. In the Navigation pane, click the Subscriptions tab, click a channel, then do one of the 
following: 

 On the toolbar, click the Download icon . 

 Right-click the feed, then click Download. 

2. Click OK. 

To download new episodes 

1. In the Navigation pane, click the Subscriptions tab, then click a channel. 

2. Right-click the feed, then click Download New Episodes. All the episodes that are new and are 
not already available on your computer are downloaded. 

Deleting Episodes in Subscriptions 

The CutePODCast Manager allows users to delete an episode from a channel in a subscription. This 
deletes the episode from the computer. Deleting an episode removes it from the Episode pane, but does 
not affect the server. You cannot delete episodes off of the server from within the CutePODCast 
Manager. 

To delete an episode from a channel in subscriptions 

1. In the Navigation pane, click the channel. 

2. In the Episodes pane, click the episode you want to delete, then click Delete  . A confirmation 
message appears.  

 

The Delete icon is available only when an episode has been downloaded.  

3. Click Yes to delete the episode. The local file is deleted and the downloaded status of the 
episode changes to No. 

Playing Episodes in Subscriptions 

The CutePODCast Manager allows you to play the episodes directly from your computer.  

To play an episode from channels in subscriptions 

1. In the Navigation pane, click the channel. 

2. In the Episode pane, click the episode you want to play, then do one of the following: 

 On the Episode Details tab, click the Play icon . 

 Right-click the episode, then click Play.  

 Double-click the episode.  

If the selected episode was not previously downloaded (a No appears in the Downloaded 
column), it is first downloaded and then plays in the appropriate application (e.g., Windows Media 
Player).  

Filtering Episodes in Subscriptions 

For your convenience, you can filter the Episode pane to display only those episodes that contain 
information in the Title or Description boxes that you specify. For example, if you configure the filter to 

display only episodes that contain the text 11/27 in the title, only the episodes with 11/27 in the title 

appear. 
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To filter episodes in a channel 

1. In the Navigation pane, click the channel you want to filter. 

2. On the toolbar, click the Filter icon . The Filter Episodes dialog box appears. 
 

 

3. In the drop-down boxes and text box, specify the filter criteria.  

 In the first box, select one of the following:  

o Title or Description 

o Title 

o Description 

 In the second box, select one of the following: 

o Contains 

o Does not contain 

o In the text box, specify any value that might appear in the Title or Description. 

4. Click OK. The Episode pane updates based on the criteria you specified. 

5. To clear the filter, click the Filter icon  again. 

MANAGING PUBLICATIONS 

Configuring Channels for Publications 

If you are uploading episodes to a server, you must specify the channel settings. Except for the channel 
name, the values set for the Publications node are inherited by the child nodes. You cannot rename the 
Publications node; however, you can add subfolders and name them whatever you want. You cannot 
specify different channel settings for different folders; channel settings for all the folders are same. If you 
change the channel settings for one folder, then the channel settings for all the subfolders and the main 
Publications folder change automatically. You can drag and drop the channels in subfolders and specify 
different channel settings for the channels. 

To configure general channel settings 

1. In the Navigation pane, click the Publications tab. 

2. Click the Configuration tab and specify the following information: 

 Title - Provide a title for the channel. The Title box is automatically populated based on 
what you typed in the tree, but you can type a different title. 

 Email - Type the webmaster's email address. A valid email address is in the format 
<username>@<domain_name or host_name>, such as abc@example.com. 

 Summary - Provide a relevant summary and description for the channel. 
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3. Click Advanced to add additional information about the owner of the channel. The Optional 
Channel Fields dialog box appears in which you can provide information such as Language, 
Copyright, Editor email, Category, and Skip Hours. 

4. In the Publish Configuration area, specify the following details: 

 Upload Type - Click the drop-down menu to specify FTP or HTTP. 

 Server and Port - Type the name and port of the server on which you want to publish the 
RSS feed, or click Site Manager to open the Select site dialog box, which lists each of 
the sites defined in CuteFTP. In the Select site dialog box, click a site, then click OK. 
The site's configuration data is imported into the CutePODCast Manager. 

 User Name - Type the user name given to you by your hosting provider. 

 Password - Type the password given to you by your hosting provider. 

 Remote Path - Type the path on which you will upload the channel. 

 RSS Filename - Click the drop-down list and select an XML file.  

 Base URL - Type the address at which the episode will be available for download. 
Provide the complete http path. e.g., http:\\www.globalscape.com\podcast\.  

5. Click Apply to save the channel settings. 

 

The Publications node is the default folder.  

Adding Channels to Publications 

You can add feeds on the server for publication. These channels are then available for download by the 
users who subscribe to your publications. 

To add a new channels to publications 

1. On the Publications tab, right-click Publications > Add New Channel. A new channel appears 
in the tree with the default values. The tree node is editable. The new channel is assigned a 

name in the format Channel x, which you can change.  

2. If you have specified general settings for all publications, the Configuration tab displays the 
general settings. You can modify these settings for each channel. 

3. To upload the episodes for the channel to the server, on the toolbar, click the Upload icon . 
Every channel must have at east one episode before you click Upload. 

4. Click Advanced in the Details pane to add additional information about the owner of the channel, 
such as Language, Copyright, Editor email, Category, and Skip Hours. 

5. Click Apply to save the settings. 

 

You can also use the Publication Wizard to add a channel. 
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Deleting Channels from Publications 

You can delete channels from the CutePODCast Manager. Deleting a channel clears the Publications 
tab, but it remains on the server. You cannot delete the feeds from the server from within the 
CutePODCast Manager. 

To delete a channel from publications 

1. On the Publications tab, click the channel you want to delete, then do one of the following: 

 On the toolbar, click the Delete icon . 

 Right-click the channel, then click Delete. A confirmation message is appears. 

2. Click Yes to delete the channel; otherwise, click No. 

Uploading Channels for Publications 

You can upload an RSS XML file and episodes for publication after specifying the publish configuration. 
Remember to add episodes before you upload. This generates a new XML file during upload and uploads 
items marked as Publish. 

To upload an RSS XML file for publications 

 On the Publications tab, click the channel, then do one of the following:  

o On the toolbar, click the Upload icon . 

o Right-click the channel, then click Upload.  

The selected channel is uploaded to the specified server. 

Renaming Channels in Publications  

By default, a published feed is assigned a name in the format Channel x, but you can rename it. 

To rename a channel in publications 

1. On the Publications tab, right-click the channel you want to rename, then click Rename. 

2. Type a new name for the channel, then click Apply. 

Episodes in Publications 

Episodes are the items present in an RSS feed or channel. A channel can contain one or more episodes. 
Each episode is a separate news article or announcement. The owner of a feed adds new content, when 
available, to periodically update items. You can add new episodes in the feeds and publish them using 
CutePODCast Manager. 

The Episode pane displays the title, publication date, duration, and size of an episode. The Publish 
column contains a check box for each episode. Select the Publish check box for each episode that you 
want to upload. If you clear the Publish check box, then the episode information is not placed into the 
RSS XML file, and the episode is not uploaded. 

 

By default, the Publish check box is selected. 
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Viewing Episodes in Publications 

When you select a channel, all the episodes present in the channel are listed in the Episodes pane. 

To view episodes 

1. On the Publications tab, click the channel.  

2. In the Episodes pane, each of the episodes present in the RSS feed are displayed. 

3. Click the Episode Details tab, then click the folder icon to browse for the file you want to upload. 

4. In the Description pane, provide a summary for your subscribers. 

5. Click Apply to save the settings. 

 

By default, the first episode is selected. Each time the Episode Details tab is activated for a channel 
and the Episode pane is updated with the list of episodes for that channel, the first episode in the 
Episode pane is selected. 

Adding Episodes in Publications  

CutePODCast Manager allows you to add new episodes to a feed and publish them. These episodes are 
then available for download by subscribers. 

To add an episode to a feed in publications 

1. On the Publications tab, click the feed to which you want to add and episode.  

2. On the Episode Details tab, click the Add icon . The Publish episode dialog box appears.  

3. On the Required Fields tab, provide the details of the episode: 

 Title - Type the title of the episode. 

 File - Browse for the folder to enter the name of the file. 

 Duration - Enter the duration of the episode. 

 Description - Provide a brief summary of the episode. 

4. On the Optional Fields tab, provide optional information:  

 Author (Email) - Type the email address of the owner of the feed or episode. 

 Subtitle - Type the subtitle, if any.  

 Category - Type the category (e.g., News). 

 Keywords - Type any keywords that will help subscribers find the episode. 

5. If the episode contains any explicit material, select the Explicit Content check box. 

6. To prevent the episode from appearing in the episode list, select the Block Episode check box. 
The episode is not available for download if you select this check box. 

7. Click OK. 
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Playing Episodes in Subscriptions 

The CutePODCast Manager allows you to play the episodes directly from your computer.  

To play an episode from channels in subscriptions 

1. In the Navigation pane, click the channel. 

2. In the Episode pane, click the episode you want to play, then do one of the following: 

 On the Episode Details tab, click the Play icon . 

 Right-click the episode, then click Play.  

 Double-click the episode.  

If the selected episode was not previously downloaded (a No appears in the Downloaded 
column), it is first downloaded and then plays in the appropriate application (e.g., Windows Media 
Player).  

Uploading Episodes for Publication 

You can upload selected episodes in a channel for publication. 

To upload selected episodes for publication 

1. On the Publications tab, click the channel that contains the episode you want to upload. 

2. In the Episodes list, click the episode, then do one of the following: 

 On the Episode Details pane, click Upload icon . 

 Right-click the episode, then click Upload. 

Deleting Episodes from Channels in Publications 

CutePODCast Manager allows you to delete an episode from a channel in a publication. The episode is 
deleted from your computer, but remains on the server.  

To delete an episode from a channel in publications 

1. On the Publications tab, click the channel that contains the episode you want to delete. 

2. In the Episodes list, click the episode you want to delete, then do one of the following: 

 On the toolbar, click the Delete icon . 

 Right-click the episode, then click Delete.  

The Delete Episode dialog box appears. 

3. Do one or more of the following: 

 To delete the file from your computer, but not from the remote file or the RSS XML file, 
select the Delete local file check box.  

 To delete the episode from the publication list or an RSS XML file, select the Remove 
this episode from the list check box. 

 To delete the remote file corresponding to this episode, select the Delete remote file 
check box. The Delete remote file check box is only available if the Remove this 
episode from list check box is selected. 

4. Click OK to delete an episode or click Cancel if you decide not to delete the file. 



 

140 ● Managing Publications  

Filtering Episodes in Subscriptions 

For your convenience, you can filter the Episode pane to display only those episodes that contain 
information in the Title or Description boxes that you specify. For example, if you configure the filter to 

display only episodes that contain the text 11/27 in the title, only the episodes with 11/27 in the title 

appear. 

To filter episodes in a channel 

1. In the Navigation pane, click the channel you want to filter. 

2. On the toolbar, click the Filter icon . The Filter Episodes dialog box appears. 
 

 

3. In the drop-down boxes and text box, specify the filter criteria.  

 In the first box, select one of the following:  

o Title or Description 

o Title 

o Description 

 In the second box, select one of the following: 

o Contains 

o Does not contain 

o In the text box, specify any value that might appear in the Title or Description. 

4. Click OK. The Episode pane updates based on the criteria you specified. 

5. To clear the filter, click the Filter icon  again. 

Opening Containing Folder 

You can open the local folder that contains a copy of the episode. 

To open the local folder 

 In the Episode list, right-click the episode, then click Open Containing Folder. Windows 
Explorer opens to the folder on your computer that contains the episode. 
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Adding Media Files to Channel from Local Pane 

You can add audio and video files to a channel in the CuteFTP Local pane without opening the 
CutePODCast Manager. 

To add media files to a channel from Local pane 

1. In the Local pane, open the folder in which your media files are stored. 

2. Right-click the media file that you want to add to a channel, then click Add to Channel. The 
Publish Episode dialog box appears. 

3. Type the information as described in Configuring Channels for Publications, then click OK. The 
file is added to the specified feed or channel. 

 



 

142 ● Managing Publications  



 

Troubleshooting ● 143 

TROUBLESHOOTING 

TROUBLESHOOTING TIPS 

A common file transfer error is the inability to connect to the server. To test your connection, you can use 
the ping and tracert utilities. 

Ping and tracert are DOS command-line utilities that you can use to troubleshoot connection problems. 
Third-party applications are also available that do basically the same thing, but provide a graphical 
interface for those who are not comfortable entering commands at a command prompt. 

 Ping - When you ping a remote host, your computer sends "echo request" packets to the target 
host and listens for "echo response" replies. Ping also estimates the round-trip time, generally in 
milliseconds, records any packet loss, and prints the ping statistics when finished. 

 Tracert - Tracert is used to determine the route taken by packets across an IP network. This is 
useful to determine where the connection problem exists, whether with your CuteFTP 
configuration, at the server, or somewhere in between, such as blocking by a firewall. 

 

TCPView is a Windows utility, available for free on Microsoft TechNet at 
http://www.microsoft.com/technet/sysinternals/Utilities/TcpView.mspx. 

To use ping or traceroute 

1. On the Windows task bar, click Start > Run. The Run dialog box appears. 

2. In the Run box, type cmd, then click OK. The Windows Command Prompt appears.  

3. At the prompt, type the command and then the IP address or domain name of the server to which 
you are trying to connect.  
 
For example, to test that you are using ping correctly, try pinging the GlobalSCAPE web site and 
do a tracert to the Gmail server, as shown in the illustrations below: 

ping www.globalscape.com 

-or- 

tracert www.gmail.com 

 

 

http://www.microsoft.com/technet/sysinternals/Utilities/TcpView.mspx
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Windows XP SP1 will not respond to an echo request on the public Internet, but you should have updated to 
SP2 to get the latest security fixes. 
 
The ping command function has several switches available, as described in the Windows XP documentation 
available at http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-

us/ping.mspx?mfr=true. At that same address, click in the table of contents for more Windows XP 
troubleshooting tips.  

USING ERROR MESSAGES AND LOGS TO TROUBLESHOOT 

You can help resolve errors by recording information from error messages and log files.  

 The Log pane appears at the top of the interface. 

 A standard error dialog box includes a short error message and two buttons, Cancel and Details. 
Click Cancel to dismiss the error dialog box. Click Details to expand the error dialog to show 
more information.  

Review the information in the logs and error messages. The problem could be as simple as a typo in the 
connection information, or the remote server might be refusing connection for some reason. 

To use an error messages and logs to troubleshoot   

1. Do one or both of the following: 

 In the error message, click the Details button, right-click in the log text area, then click 
Copy All Text. The entire contents of the window is copied to the clipboard, then paste it 
into an email or text file.  

 In the Log pane, right-click, then click Copy Entire Log to Clipboard (or press 
CTRL+SHIFT+C), then paste it into an email or text file.  

2. If you suspect CuteFTP configuration is at fault, paste it directly into the Description field at the 
GlobalSCAPE Technical Support Contact page to ask for help from GlobalSCAPE Technical 
Support. 

3. Send the information to your technical support department, ISP, or Web hosting provider for 
troubleshooting assistance.  

 

http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/ping.mspx?mfr=true
http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/ping.mspx?mfr=true
http://www.globalscape.com/support/techsupport.aspx


 

Troubleshooting ● 145 

FTP STATUS AND ERROR CODES 

CuteFTP displays FTP status codes in the log window. The codes are numbered according to their 
category. Some codes represent errors, while most codes simply communicate the status of the 
connection. Below are brief explanations for the most common status and error codes They are provided 
here to point you in the right direction for solving your FTP errors. For example, if you receive a 331 error, 
you can look at the table below and see that a 331 error indicates that your username is authorized and 
now you need to provide a password. If you received a 530 error, your password was rejected (because 
you typed it wrong, your account is expired, you provided the wrong username/password pair, etc.). Often 
you can type the description from the table below into your ISP/Web Hosting Provider's help pages to find 
an explanation for the error. 

 100  

 200  

 300  

 400  

 500  

 10000  

Code Description 

100 Series  The requested action is being initiated, expect another reply before proceeding with a new 
command. 

110 Restart marker reply. 

120 Service ready in nn minutes. 

125  Data Connection already open, transfer starting. 

150 File status okay, about to open data connection. 

200 Series  The requested action has been successfully completed. 

200 Command okay. 

202  Command not implemented, superfluous at this site. 

211  System status, or system help reply. 

212 Directory status. 

213 File status. 

214 Help message. 

215 NAME system type. (Where NAME is an official system name from the list in the Assigned 
Numbers document.) 

220  Service ready for new user. 

221  Service closing control connection. Logged out if appropriate. 

225 Data connection open; no transfer in progress. 

226 Closing data connection. Requested file action successful (for example; file transfer or file abort). 

227  Entering Passive Mode. 

230 User logged in, proceed. 

250  Requested file action okay, completed. 
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Code Description 

257 "PATHNAME" created. 

300 Series  The command has been accepted, but the requested action is on hold, pending receipt of further 
information. 

331  User name okay, need password. 

332  Need account for login. 

350  Requested file action pending further information. 

400 Series  The command was not accepted and the requested action did not take place, but the error 
condition is temporary and the action may be requested again. 

421 Error 421 Service not available, closing control connection.  

Error 421 User limit reached 

Error 421 You are not authorized to make the connection 

Error 421 Max connections reached 

Error 421 Max connections exceeded 

Possible Solutions 

You can receive that 421 error if the FTP server you are connected to limits the total number of 
connections available or limits the connections available to one user. There are three things you 
can do: 

1. Limit the number of connections to any one FTP site:  Click Tools, click Global Options, 
then click the Connection node. Set Per site max connections /transfers to 1. (By 

default it is set to 2.) 

2. Remove items from the queue. The Queue pane displays items ready for transfer, in 
transit, or just transferred. Sometimes the Queue pane can become cluttered with 
unfinished transfers. To clear the queue, right-click within it, then click Remove All. 

3. Make sure only one instance of CuteFTP is running on your system. Open the Windows 
Task Manager and see if CuteFTP is listed more than once. 

425  Cannot open data connection. Try changing from PASV to PORT mode. Check your firewall 
settings. Try making an HTTP connection. 

426 Connection closed; transfer aborted. 

450  Requested file action not taken. File unavailable (e.g., file busy). 

451 Requested action aborted: local error in processing. 

452 Requested action not taken. Insufficient storage space in system. 

500 Series  The command was not accepted and the requested action did not take place. 

501  Syntax error in parameters or arguments. 

502  Command not implemented. The server does not support this command. 

503 Bad sequence of commands. 

504  Command not implemented for that parameter. 

530 Not logged in. Your password is being rejected, contact the server administrator. 

532  Need account for storing files. 

550  Requested action not taken. File unavailable (e.g., file not found, no access) or permission denied. 
This error is not caused by CuteFTP. If you believe that your FTP account privileges or 
permissions are configured incorrectly, contact the technical support department at the remote FTP 
site or your Web hosting company for help. 
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Code Description 

552 Requested file action aborted. Exceeded storage allocation (for current directory or data set). This 
error is not caused by CuteFTP. There is not enough disk space available to you on the remote 
FTP server. The most common cause for this error is that the limited disk space allocated for your 
individual FTP account is already in use. This error may also appear when disk space appears to 
be available but the file being uploaded is large enough so that if it were uploaded, it would cause 
your disk space quota to be exceeded. To resolve this error, you can increase the space available 
by deleting unnecessary files from the remote server or by making arrangements with your Web 
hosting provider or FTP account administrator for additional disk space.  

553  Requested action not taken. File name not allowed. Try changing the file name, or getting rid of 
spaces in the file name. This error is not caused by CuteFTP.  The file name is not allowed by your 
server. Many FTP servers have restrictions on file names. If your file name contains special 
characters, symbols, or spaces in the file name, it might be rejected by the remote FTP server. The 
remote FTP site may also be rejecting a particular file based on the file type or extension. To 
resolve this error, if the file name contains special characters, symbols, or spaces, you will need to 
rename the file before you can upload it. Rename the file using only alpha-numeric characters and 

no spaces. For more information, refer to Opening, Editing, Renaming, and Deleting Files. 
Note: If you change the file name, you will also need to change links in Web pages that point to 

that file name. 

10,000 series Winsock error codes 

10054 Connection reset by peer. The connection was forcibly closed by the remote host.  

10060 Cannot connect to remote server (Generally a time-out error). Try switching from PASV to PORT 

mode, or try increasing the time-out value (See Reconnect and resume in Transfer settings) 

10061 Cannot connect to remote server. The connection is actively refused by the server. Try switching 
the connection port. 

10066 Directory not empty. The server will not delete this directory while there are files/folders in it. 

10068 Too many users, server is full. Try connecting later. If the problem persists, contact the server 
administrator. 

HTTP STATUS AND ERROR CODES 

During your HTTP sessions, you will receive various numbered codes from Web servers. When 
connected via HTTP, CuteFTP displays these codes in the Log window. Some codes represent errors; 
most others simply communicate the status of the connection. Below are descriptions of the most 
common status and error codes. 

Code Description 

100 
Series 

Informational - These status codes indicate a provisional response. The client should be prepared to 
receive one or more 1xx responses before receiving a regular response. 

100 Continue. 

101 Switching protocols. 

200 Okay - The client request has succeeded  This status code indicates that the Web server has successfully 
processed the request 

201 Created. 

202 Accepted. 

203 Non-authoritative information. 

204 No content. 
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Code Description 

205 Reset content. 

206 Partial content. 

302 Object moved. 

304 Not modified. The client requests a document that is already in its cache and the document has not been 
modified since it was cached. The client uses the cached copy of the document, instead of downloading it 
from the server 

307 Temporary redirect. 

400 Bad request. 

401 Access denied. 

401.1 Logon failed. The logon attempt is unsuccessful, probably because of a user name or password that is not 
valid. 

401.2 Logon failed due to server configuration. 

401.3 Unauthorized due to ACL on resource. This indicates a problem with NTFS permissions. This error may 
occur even if the permissions are correct for the file that you are trying to access. For example, you see 
this error if the IUSR account does not have access to the C:\Winnt\System32\Inetsrv directory. 

401.4 Authorization failed by filter. 

401.5 Authorization failed by ISAPI/CGI application. 

401.7 Access denied by URL authorization policy on the Web server. This error code is specific to IIS 6.0. 

403 Forbidden. 

403.1 

Execute access forbidden. The most two common causes of this error message are: 

 You do not have enough Execute permissions. For example, you may receive this error message 
if you try to access an ASP page in a directory where permissions are set to None, or you try to 
execute a CGI script in a directory with Scripts Only permissions.  

 The script mapping for the file type that you are trying to execute is not set up to recognize the 
verb that you are using (for example, GET or POST). 

403.2 
Read access forbidden. Verify that you have Read access to the directory. Also, if you are using a default 
document, verify that the document exists. 

403.3 Write access forbidden. Verify that you have Write access to the directory 

403.4 SSL required. Use HTTPS instead of HTTP to access the page. 

403.5 SSL 128 required. 

403.6 IP address rejected. 

403.7 Client certificate required. You do not have a valid client certificate installed 

403.8 Site access denied. 

403.9 Too many users. The number of users who are connected to the server exceeds the connection limit. 

403.10 Invalid configuration. 

403.11 Password change. 

403.12 
Mapper denied access. The page that you want to access requires a client certificate, but the user ID that 
is mapped to your client certificate has been denied access to the file. 

403.13 Client certificate revoked. 
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Code Description 

403.14 Directory listing denied. 

403.15 Client Access Licenses exceeded. 

403.16 Client certificate is untrusted or invalid. 

403.17 Client certificate has expired or is not yet valid. 

403.18 Cannot execute requested URL in the current application pool. This error code is specific to IIS 6.0. 

403.19 Cannot execute CGIs for the client in this application pool. This error code is specific to IIS 6.0. 

403.20 Passport logon failed. This error code is specific to IIS 6.0. 

404 Not found. This error may occur if the file that you are trying to access has been moved or deleted. 

404.0 File or directory not found. 

404.1 Web site not accessible on the requested port. 

404.2 Web service extension lockdown policy prevents this request. 

404.3 MIME map policy prevents this request. 

405 HTTP verb used to access this page is not allowed (method not allowed). 

406 Client browser does not accept the MIME type of the requested page. 

407 Proxy authentication required. 

412 Precondition failed. 

413 Request entity too large. 

414 Request-URL too long. 

415 Unsupported media type. 

416 Requested range not satisfiable. 

417 Execution failed. 

423 Locked error. 

500 Internal server error.  You see this error message for a wide variety of server-side errors. 

500.12 Application is busy restarting on the Web server. Indicates that you tried to load an ASP page while IIS 
was in the process of restarting the application. This message should disappear when you refresh the 
page. If you refresh the page and the message appears again, it may be caused by antivirus software that 
is scanning your configuration file. 

500.13 Web server is too busy. 

500.15 Direct requests for configuration are not allowed. 

500.16 UNC authorization credentials incorrect. This error code is specific to IIS 6.0. 

500.18 URL authorization store cannot be opened. This error code is specific to IIS 6.0. 

500.100 Internal ASP error. You receive this error message when you try to load an ASP page that has errors in 
the code. 

501 Header values specify a configuration that is not implemented. 

502 Bad Gateway. Web server received an invalid response while acting as a gateway or proxy. You receive 
this error message when you try to run a CGI script that does not return a valid set of HTTP headers. 

502.1 CGI application timeout. 
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Code Description 

502.2 Error in CGI application. 

503 Service unavailable. This error code is specific to IIS 6.0. 

504 Gateway timeout. 

505 HTTP version not supported. 

CANNOT CLOSE DATA TRANSFER GRACEFULLY 

If the error message "Cannot close data transfer gracefully" is generated after a download is complete, it 
indicates that CuteFTP has received all the data it needs, but the server is still sending information. Since 
that data is still transmitting, CuteFTP forces the connection to close.  

CANNOT INITIATE DATA TRANSFER 

If you receive this error from a server, it could indicate one of the following problems: 

 The site you are trying to log into requires a special user name and or password in order to 
transfer files.  

o Contact the administrator of the site, and find out if you need to use a special user name 
or password, and whether or not you can access that site.  

 The permissions on the site are incorrect, so even though your user name and password are 
correct, you are unable to upload or download.  

o Contact the administrator of the site, and make sure that your user name and password 
have read and write permissions set correctly.  

 You cannot upload because the server you are sending to is full and will not allow more files to be 
uploaded.  

o Delete files that are no longer used or ask the administrator for more space on the 
system.  

 The file name you are using has a space or a character that the server will not allow.  

o Double-check with the administrator of your site about which characters are accepted on 
your server, and rename the files to an acceptable name. For example, some Web 
hosting providers only allow lower-case characters, no spaces, and the files must be 
named htm instead of html. Many hosting providers list this information on their Web 
sites. 

 A communication error is occurring between the FTP host and your computer, making data 
transfer impossible.  

o If CuteFTP has worked in the past, change nothing and wait a little while to see if the 
problem is caused by Internet traffic. If this is the first time you are trying to connect, try 
using the other hosts types rather than Auto-detect.  
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CANNOT RESOLVE HOST NAME  

The Cannot Resolve Host Name message is displayed when CuteFTP cannot make a connection to the 
FTP host address that you specified when you set up the connection. It could be compared to browsing to 
a Web site that either is not up at the moment or does not exist. There are several ways to approach this 
situation: 

 Make sure you are connected to the Internet. If you are not connected to the Internet, you will 
need to connect before you can connect to any FTP sites.  

 Make sure you typed in the FTP Host Address correctly. This would be just the host address of 
the server. For example, if you were given an FTP Host Address in the format: 

ftp://ftp.yourhost.com, you would only type ftp.yourhost.com. Also be sure there is 

nothing after the host address, especially slashes ("/") indicating subdirectories. If the server does 
not automatically put you in your default directory when you log in to it, then you can add the 
directory into the "Default Remote Directory" box when configuring this site.  

 If you are using CuteFTP Home or Lite, make sure you are not trying to connect to a HTTP server 
such as http://www.cuteftp.com. You cannot connect to a HTTP (web) server with CuteFTP Home 
or Lite. If you do not know the FTP Host Address for your site, you will need to contact your 
server administrator for more information. GlobalSCAPE support staff does not know or keep 
track of FTP host addresses of every ISP/Web server.  

 If you have a firewall or proxy server, make sure CuteFTP is properly configured to work with the 
proxy server. You can edit the firewall or proxy settings by clicking Tools > Global Options and 
expanding Connection and selecting Proxy Server. If you are not sure what the settings for the 
proxy should be, you will need to contact your network or system administrator for that 
information.  

If all of these options fail with the same results, contact the server administrator of the site to which you 
are attempting to connect to in order to resolve the problem. 

CHILD TRANSFER FAILED 

If you attempt to transfer a folder or directory and see this error, it simply means that an item or items 
within the folder failed to transfer. You can check your connection log to find a more detailed error 
describing why the item failed to transfer.  

NOT ENOUGH CREDITS TO DOWNLOAD 

You may not be able to download from some FTP sites until you have uploaded something to them. In 
other words, you have to give them a file before they give you one -- a type of file trading. Most of these 
"ratio sites" have a text file that explains how to upload files to them to get credits. If you have any 
problems, contact the administrator of the site. (GlobalSCAPE does not have this information.) 

PERMISSION DENIED 

Every time an FTP account (for uploading your Web pages) is opened, your server determines all the 
things that you are allowed to do, like upload, download, write to a file, delete a file, make new directories, 
etc. If permissions have not been set up correctly, you will not be able to upload your files to the server. If 
you receive this message, your server administrator has not established your permissions correctly. 
Contact the server administrator to reset the permissions.  

If none of the transactions you try with CuteFTP seem to be completed, refer to the log pane for any 
entries that are colored red or any messages indicating a potential problem. You can copy the contents of 
the log into an email or text file to send to your administrator or Web hosting provider. 

Refer to FTP Error Codes and HTTP Status and Error Codes for information about error codes. 
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PORT ALREADY IN USE ERROR WITH DIAL-UP VPN 

If you are connecting to a Virtual Private Network through a modem and receive the Port already in use 
error when trying to connect, you might need to correct your connection settings. 

To review/correct connections settings 

1. On the main menu, click Tools > Global Options. 

2. In the left pane, expand Connection, then click DUN/LAN. 

3. In the right pane, click Connect to the Internet using a LAN. CuteFTP uses an existing 
connection defined on your computer.  

4. Click OK. 

If Connect to the Internet using a LAN is already selected, verify your computer's VPN settings. 

To verify your computer's connection settings 

1. Do one of the following: 

 In the Windows Control Panel, click Internet Options. 

 In Internet Explorer, click Tools > Internet Options. 

2. Click the Connections tab. The connection settings for one or more internet connections appear 
on this tab. 

3. The Dial-up and Virtual Private Network settings box displays dial-up and VPN connections 
that are defined on your computer. 

4. Click LAN Settings to view the local area network and proxy server settings. 

 

Changing any of these settings can cause your computer to lose its connection to your network and/or the 
Internet. Do not change them unless you know what they should be. Your network administrator, Web hosting 
provider, or Internet Service Provider (ISP) can provide you with this information. GlobalSCAPE does not have 
this information; however, many ISPs provide this information on their Web sites. 

FAILED TO ESTABLISH DATA SOCKET 

This error usually occurs when trying to connect in PASV mode to a site that only accepts PORT mode 
connections. Change the connection type from PASV mode to PORT mode to connect to the site.  

To switch from PASV to PORT mode  

1. In the Site Manager, click the problem site. 

2. On the main menu, click File > Properties.  

3. Click the Type tab.  

4. In the Data connection type list, select the Use PORT check box. 

5. Click OK. 
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SOCKET ERRORS 10060, 10061, 10064, 10065 

A socket error in the 10060 range is a Winsock error. It is generally caused by either outgoing connection 
problems or connection problems on the host end. 

Outgoing connections can be affected by the presence of firewall or anti-virus software on the local 
computer or network connection. Either can block the ports needed to make a successful FTP connection 
to the remote server. For a regular FTP session, either disable the firewall or anti-virus software or 
configure them to allow CuteFTP to establish an FTP session over ports 20 and 21.  Consult the 
documentation or help file for your specific firewall or antivirus software product for instructions. Usually 
the manufacturer of the device or software will also have specific instructions available on their Web site. 
If you continue to receive the same error after insuring ports 20 and 21 are open, contact the 
administrator of the site you are trying to connect to. 

 

For more error code information, refer to Knowledge Base article 10140 at http://kb.globalscape.com. 

WSAETIMEDOUT (10060) 

10060 is a connection-timeout error that usually appears when the client does not receive a response 
from the server for a specific command. This error often occurs when you try to connect in PASV mode to 
a server that prefers PORT for data connections. If you see an error log similar to the one below, in the 
Site Properties of the problem site, click the Type tab, then change the Data Connection Type to Use 
PORT.  

COMMAND:> PASV 

227 Entering Passive Mode (xxx,xx,xxx,xx,x,xxx). 

COMMAND:> LIST 

STATUS:> Connecting ftp data socket xxx.xx.xxx.xx:xxxx... 

ERROR:> Can't connect to remote server. Socket error = #10060. 

ERROR:> Failed to establish data socket. 

If you still receive a 10060 error, the server may be trying to send a listing for a very large directory (with 
many thousands of files) causing the client to time-out while waiting. Try increasing the time-out value in 
the Global Options dialog box (Tools > Global Options > Transfer > Reconnect and resume in [ n ] 
seconds if nothing received ) to a higher value, such as 45 or 60 seconds. 

1. The connection fails due to an error or timeout. 

2. Verify that the destination IP address is correct. 

3. Increase the connection timeout threshold under Global Settings > Connection. 

4. Switch to the opposite data connection type (PASV or PORT) under Site Settings > Type tab. 

5. Verify that the problem is not local by trying to connect to an alternate server. 

6. If a server name was used, verify it resolves to the correct address. 

7. If using a local server table for server name resolution, check to see that it doesn't resolve to an 
obsolete address. 

8. Try pinging the address. (See Troubleshooting Tips for details.) 

9. If you are using a router, verify the router is up and running (check by pinging it and then ping an 
address outside of the router). 

10. Do a traceroute to the destination to verify all routers along the connection path are operational. 
(See Troubleshooting Tips for details.) 

11. Verify that your subnet mask is setup properly. 

http://kb.globalscape.com/article.aspx?id=10140
http://kb.globalscape.com/
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WSAECONNREFUSED (10061) 

10061 is a Connection Refused error sent to you by the server. You could not make a connection 
because the target computer actively refused it. The most common cause is an incorrectly configured 
server, full server, or incorrect Port specified by the client.  

To change your connection Port for an FTP site 

1. Open the Site Manager, then click the site. 

2. On the main menu, click File > Properties. 

3. Click the Type tab. 

4. In the Port box, type the correct port number.  

Sometimes a 10061 error is caused by either a firewall or anti-virus software presence on the local 
computer or network connection.  Either one may be blocking the ports needed to make a successful FTP 
connection to the server.  

For a regular FTP session, please either disable the firewall or anti-virus software or configure it to allow 
CuteFTP to establish an FTP session over ports 20 and 21. Please consult the documentation or help file 
for your specific firewall or antivirus software product for further instructions. Usually, the manufacturer of 
the device or software has specific instructions available on their Web site. 

If you continue to receive the same error after insuring ports 20 and 21 are open, please contact the 
administrator of the site where you are trying to connect. 

1. The remote host actively refused the attempt to connect to it. 

2. Verify that the destination server name or IP address is correct 

3. Verify that the connection port number is correct (under Site Settings > Type tab). 

4. The remote server may be temporarily or permanently inaccessible (try again later). 

5. Verify that you have chosen the right protocol (SSH2, SSL, FTP, etc.) and have setup all required 
options for that protocol. 

6. Verify that the destination IP address and port numbers are correct. 

7. The remote server may be refusing multiple connections from the same client. Try using only one 
connection thread when connecting to this particular server (Site Settings > Options). 

8. Try pinging the address. 

9. If you are using a router, verify the router is up and running (check by pinging it and then ping an 
address outside of the router). 

10. Do a traceroute to the destination to verify all routers along the connection path are operational. 

11. Verify that your subnet mask is setup properly. 

WSAESERVERDOWN (10064) 

 The server is temporarily or permanently unreachable. Verify that the destination host name or IP 
address is correct and try again later. 

WSAESERVERUNREACH (10065) 

 The server is unreachable. Verify that the destination host name or IP address is correct and try 
again later. 
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SOCKET ERROR 2000 

This error generally occurs when port 21 is blocked on your computer. The port could be blocked by a 
firewall or a proxy server that has not been configured properly. Generally you'll see a log like this: 

STATUS:> Connecting to server xxx.xxx.x.xx (ip= xxx.xxx.x.xx)... 

ERROR:> Can't connect to remote server. Socket error = #2000. 

ERROR:> Timeout (60000ms). 

STATUS:> Waiting 30 seconds...... 

To avoid this error, open port 21 to inbound and outbound traffic. Most often a firewall (such as those 
from MacAfee, Norton or the built-in Windows XP firewall) is blocking inbound or outbound TCP traffic on 
port 21. 

 

For more error code information, refer to Knowledge Base article 10140 at http://kb.globalscape.com. 

SFTP ERROR #4 

This is a general SFTP connection error. The SFTP server is using an encryption algorithm or cipher that 
is not supported by CuteFTP Pro. The most common cipher causing this error is AES which is not 
currently supported in CuteFTP Pro. Ask the administrator of the remote FTP server to allow use of a 
different cipher. The default configuration of CuteFTP Pro provides support for TripleDES, ARCFOUR, 
CAST128, Twofish, and Blowfish automatically.  

See Trouble Shooting SFTP connections for details. 

SFTP ERROR #0 

This error is by a timeout of an SFTP operation. This problem may be caused by a misconfigured firewall. 
or attempting an SFTP connection to a server computer running Titan FTP Server (the issue was fixed in 
CuteFTP 8.1). 

Verify the firewall settings and ensure that port 22 is open and enabled for SFTP transfers. 

If you are connecting with a server computer running Titan FTP Server, update to CuteFTP 8.1 or greater. 

ERROR 421 MESSAGES 

Common 421 errors include: 

 Error 421 Service not available, closing control connection. 

 Error 421 User limit reached 

 Error 421 You are not authorized to make the connection 

 Error 421 Max connections reached 

 Error 421 Max connections exceeded 

You can receive a 421 error if the FTP server you are connected to limits the total number of connections 
available or limits the connections available to one user. To clear the error, change the number of per site 
max concurrent transfers, remove items from the Queue Pane, and make sure only one instance of 
CuteFTP is running.  

To change per site max concurrent transfers 

1. On the main menu, click Tools > Global Options.  

2. Click the Connection node. 

http://kb.globalscape.com/article.aspx?id=10140
http://kb.globalscape.com/


 

156 ● Installshield Error 1628: Failed to Complete Script-Based Installation  

3. Set Per site max concurrent transfers to 1. (By default it is set to 2. This setting limits the 
number of connections to any one FTP site.  

To remove items from the Queue Pane 

 Sometimes the Queue Pane can become cluttered with unfinished transfers. To clear the queue, 
right-click inside the Queue Pane, then click Remove All. 

To verify only one instance of CuteFTP is running on your system.  

1. Right-click on the Windows Task bar, then click Task Manager.  

2. On the Applications tab, view the list of running tasks to determine if CuteFTP is listed more 
than once.  

3. If more than one instance is listed, click one of them, then click End Task. 

INSTALLSHIELD ERROR 1628: FAILED TO COMPLETE SCRIPT-BASED 
INSTALLATION 

The following error message can occur at run time when you are trying to uninstall, repair, or update an 
installation.  

Error 1628: Failed to complete script based install. 

This error message is caused by the Windows Installer Service and is often caused by the installation 
itself. 

Possible Cause 1 

This error message is often caused when the uninstallation log file becomes corrupt. This can happen if 
the installation is somehow corrupt. 

Fix:  In the Windows Task Manager, end the process that is running IDriver.exe: 

1. Right-click the Windows Task bar, then click Task Manager. 

2. On the Processes tab, click the Image Name column to sort it alphabetically. 

3. Review the running processes to see if idriver.exe is running. 

4. If idriver.exe is running, click it or right-click it, then click End Process. 

Run the installation again to see if the error still occurs. 

Possible Cause 2 

This error can also occur if the Windows Installer Service is not properly configured on your computer or if 
the installation is created with a newer version of the Windows Installer Service than the one on your 
computer. 

Fix:  To fix this issue, install the latest Windows Installer Service on your computer. Instructions and 
download links for the Windows Installer are listed below, sorted by operating system. 

 Windows 95/ 98/ Me: 
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=CEBBACD8-C094-
4255-B702-DE3BB768148F 

 Windows NT 4.0 or 2000: 
http://www.microsoft.com/downloads/details.aspx?FamilyID=4b6140f9-2d36-4977-8fa1-
6f8a0f5dca8f&DisplayLang=en 

http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=CEBBACD8-C094-4255-B702-DE3BB768148F
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=CEBBACD8-C094-4255-B702-DE3BB768148F
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=CEBBACD8-C094-4255-B702-DE3BB768148F
http://www.microsoft.com/downloads/details.aspx?FamilyID=4b6140f9-2d36-4977-8fa1-6f8a0f5dca8f&DisplayLang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=4b6140f9-2d36-4977-8fa1-6f8a0f5dca8f&DisplayLang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=4b6140f9-2d36-4977-8fa1-6f8a0f5dca8f&DisplayLang=en
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 Windows XP: 
Windows XP contains Windows Installer version 2.0. You should not have to install the Windows 
Installer Service (MSI engine) on Windows XP. 

Restart your computer and run the installation again to see if the error continues to occur. 

Possible Cause 3 

This error message may also occur if a file in the Temp directory is conflicting with the files used by the 
installation while it is running. 

Fix:  Delete the entire contents of the Temp directory: 

1. Double-click the My Computer icon on your desktop, or right-click Start, then click Explore. 

2. Navigate to the Temp directory, for example, C:\Windows\Temp. 

3. Click in the directory, then right-click and click Select All (or CTRL+A). 

4. On the toolbar, click Delete or right-click the selection, then click Delete (or CTRL+X). A 
confirmation message appears. 

5. Click Yes. 

Run the installation again to see if the issue is resolved. 

CANNOT CONNECT TO SERVER 

Making one or more minor configuration changes usually solves connection problems quite easily. 

In the Log pane, a complete list of all communications and commands between CuteFTP and the FTP 
server to which you are trying to connect appear. If you cannot connect, at least one ERROR message 
appears in the Log pane in red text, which you probably need to scroll up to see. That error message 
should tell you the specific reason why you cannot connect. 

The most common connection problem is that the Host Address, the User Name or the Password 
has been entered incorrectly. Make sure all three pieces of information exactly match what the 
administrator of the Server you are connecting with provided.  

GlobalSCAPE does not provide you with an FTP server, username, or password for uploading 
files. The Internet Service Provider/Web Hosting Provider to which you want to upload files 
provides you with the username, password, and FTP account information required to connect to 
their server. Most Internet Service Providers/Web Hosting Providers have this information 
available on their Web pages. 

If you cannot connect to your server: 

1. Verify that the destination server name and IP address is correct 

2. Verify that the connection port number is correct (on the Type tab of Site Properties). For 
example, for FTP connections, it is usually port 21. 

3. The remote server may be temporarily or permanently inaccessible (try again later). 

4. Verify that you have chosen the right protocol (SSH2, SSL, FTP, etc.) and have setup all required 
options for that protocol. 

5. The remote server may be refusing multiple connections from the same client. Try using only one 
connection thread when connecting to this particular server  (on the Options tab of Site 
Properties). 

6. Try pinging the address (see Troubleshooting Tips for details). 
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7. If you are using a router, verify the router is up and running (check by pinging it and then ping an 
address outside of the router). 

8. Do a traceroute to the destination to verify all routers along the connection path are operational 
(see Troubleshooting Tips for details). 

9. Verify that your Windows network connection is setup properly. (Can you connect to the 
Internet?) 

10. Verify that your local software or hardware firewall is not blocking outbound connections 
originating from CuteFTP. 

11. Verify that your anti-virus software is not at fault (try disabling it). 

CANNOT SEE REMOTE FILES OR FOLDERS 

If you cannot see your directory listing or files, you can try these solutions then attempt to connect again.  

Your connection log shows a LIST-L command instead of the normal LIST 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Navigation node, then click Links. The Links options appear.  

3. Clear the Attempt link resolution using LIST -L command check box, then click OK.  

Use the -L filter on the server  

1. Display the Site Manager and view the Site properties. 

2. Click the Actions tab, then click Filter. The Filter Properties dialog box appears. 

3. Select the Enable filtering check box.  

4. Select the Enable server side filtering check box, then type -L in the Remote filter box.  

5. Click OK to close the Filter Properties dialog box and accept the changes. 

6. Click Connect or Exit. 

Change connection type  

1. Display the Site Manager and view the Site Properties. 

2. Click the Type tab.  

3. In the Data connection type box, click Use PASV.  

4. Click Connect or Exit. 

If you still cannot connect, follow the same steps, but click Use PORT.  

Turn off all filters  

1. Display the Site Manager and view the Site Properties. 

2. Click the Actions tab, then click Filter. The Filter Properties dialog box appears. 

3. Clear the Enable filtering check box, then click OK.  

4. Click Connect or Exit. 
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Change server Host type 

1. Display the Site Manager and view the Site Properties. 

2. Click the Type tab.  

3. In the Server type box, click the first server type in the list (Unix).  

4. Click Connect or Exit. 

If that does not work, try the next server type on the list.  

Send an extended log to Technical Support 

If none of the solutions above resolve the problem, obtain a raw directory listing and submit it, along with 
details of the problem, to GlobalSCAPE Technical Support. 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the General node, then click Logs. The Log options appear. 

3. Select the Record/display raw directory listing in logs check box. 

4. Reconnect to the problem site. 

5. Once connected, right-click in the Log pane, then click Copy Entire Log to Clipboard. 

6. Paste the selection (CTRL+V) into an email message. 

7. Describe the problem, what you have already tried and include information about the computer 
you are using (operating system, Internet connection, etc.). 

8. Submit your support request using our support submission form. 

COPY AND PASTE FUNCTIONS REMOVE FILE FROM THE REMOTE 
FOLDER 

FTP Servers do not support the Copy command. If you copy a file from a folder in the Remote pane and 
then try to paste it in any folder in the Remote pane itself, you are moving the file from the original folder 
to that folder or to a new location on the server. FTP protocol does not allow you to retain the original file 
and create a copy in other folder in the remote location. You can use the Cut and Paste commands to 
restore the original file. This is a limitation of the FTP protocol, not CuteFTP.  

 

The copy command is available, because you can copy files from the Remote to the Local pane, to the queue, 
etc. 

To copy a file or folder from one remote folder to another remote folder 

1. Download the file. 

2. Upload the file to the new location. 

CANNOT DOWNLOAD FILES FROM A VMS SERVER 

If your downloads from a VMS server repeatedly restart and try to complete but never do, try turning off 
the SIZE and MDTM commands. 

To turn off the SIZE and MDTM commands 

1. On the main menu, click Tools, then click Global Options (or press ALT+F7). 

2. Expand the Transfer node, then click Smart Overwrite. The Smart Overwrite options appear. 

http://www.globalscape.com/support/techsupport.aspx
http://www.globalscape.com/support/techsupport.aspx
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3. In the Advanced Options area, clear the Use SIZE and MDTM commands to gather precise 
details check box. 

4. Click OK. 

HIGH MEMORY USAGE 

If the Transfer Engine (SDK) of the CuteFTP works for extended periods of time, it begins to consume 
large amount of system resources, such as memory and hard drive space, due to log and queue 
requirements.  

You can set CuteFTP to remove successful items from the queue to help alleviate this problem.    

 

Successful items are removed even if tasks were run without the user interface open. 

Each finished queue item takes up about 500 bytes of memory until the Transfer Engine is closed. 

Disable the logging function to improve resource management. 

To remove successful items from the queue  

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Transfer node, then click Events. The Events options appear. 

3. Select the Remove successful transfers from the queue automatically check box, then click 
OK.  

To disable logging 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the General node, then click Logs. The Log options appear. 

3. Clear the check boxes for logs you do not need. 

TRANSFERRING TO CASE-SENSITIVE SERVERS 

Some case-sensitive servers treat two files with same name but different case as two different files. 
CuteFTP is not case-sensitive and, when uploading or downloading files, it treats two files with same 
name and different case as the same file. For example, if you want to upload TEXT.txt file and a text.txt 
file already exists on the server, then it will see the files as the same and prompt you to overwrite the 
text.txt file. 

To set a site as case sensitive 

1. Display the Site Manager and view the Site Properties. 

2. Click the Type tab. 

3. In the Server type list, click Unix-compatible. 

4. Click Connect or Exit. 
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OVERWRITE REPEATEDLY PROMPTS ME 

If you are getting numerous overwrite prompts and want to avoid receiving them in the future, configure a 
default rule for the overwrite configuration panel. 

To add a rule  

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Transfer node, then click Smart Overwrite. The Smart Overwrite options appear. 

3. In the For matching files list, click Use Rules. 

4. Select the Ignore zero byte files check box. 

5. In the For matching folders list, click Use Rules. 

6. Click Configure Rules. The Overwrite Rules dialog box appears. 

7. In the If the destination file date is list, click older. 

8. In the and size is list, click smaller. 

9. In the during list, click any transfer. 

10. In the then list, click overwrite. 

11. Click Add. The new rule appears in the list. Add more rules as needed. Below are some 
recommendations: 

 If destination file date is the same and size is the same during any transfer then skip. 

 If destination file date is older and size is different during any transfer then overwrite. 

 If destination file date is no matter and size is smaller during any transfer then resume. 

 If destination file date is newer and size is larger during any transfer then skip. 

12. Click OK to save the rule and close t he Overwrite Rules dialog box. 

13. In the Prompt timeout action list, click Skip. 

14. Select the Timeout in check box, and leave the time at 30 seconds. 

15. Select the Resend LIST command as necessary check box. 

16. Select the Use SIZE and MDTM commands to gather precise details check box. 

17. Click OK. 

USING THE ACCT COMMAND 

You can establish a connection and then supply the ACCT command for servers that require it.  

To use ACCT with or without an FTP proxy  

1. In the Site Manager, click the site you want to change. 

2. Click the Options tab.  

3. In the Site-specific configuration options box, click Use site-specific options. 

4. Click Proxy. The Proxy dialog box appears. 

5. In the Proxy type list, click the proxy type (FTP or HTTP). 

6. In the Host name and port boxes, provide the same host and port as specified on the General 
and Type tabs.  
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7. Select the Use authentication check box. The Username and Password boxes become 
editable. 

8. In the Password box, type the password (for ACCT).  

9. Click Advanced. The Advanced Proxy Settings dialog box appears. 
 

 

10. Do one of the following: 

 Click Custom, then add the following variables. Press ENTER after each variable: 

 USER %user%  

 PASS %pass%  

 ACCT %fire_pass%  

 Click USER/PASS/ACCT.  

11. Click OK to save the settings and close the Advanced Proxy Settings dialog box. 

12. Click OK again to close the Proxy dialog box. 

13. Click Connect to connect now or OK to connect later.  

USING CUTEFTP BEHIND A ROUTER 

In most cases, CuteFTP does not have any problems working behind a router. If you are having 
problems, try transferring in PASV mode. 

 

To transfer in PORT mode or for secure transfers, refer to your router's documentation for information on how 
to configure the router for such transfers. 
 
If you are behind a NAT firewall and the FTP server is on a different network, you can only make data transfers 
in PORT mode using a Clear Command Channel SSL connection. 

If connections or transfers fail, try one or more of the following possible solutions: 

1. Ask the FTP server's administrator if the server and its network are configured to allow FTP in 
PASV mode.  

2. Review the router documentation for information on how to set it up for FTP or how to open the 
appropriate ports. FTP generally uses port 21. 
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3. Define a port range for CuteFTP. 

4. Use UPnP (if your NAT or router supports it) to establish a connection properly.  

5. Turn on port mapping. 

USING CUTEFTP WITH NORTON INTERNET SECURITY 2004 

If you have Norton Internet Security 2004 installed on the same computer as CuteFTP, you will need to 
adjust a setting in the Norton program to allow CuteFTP to make connections and transfers. 

Allowing CuteFTP to make connections will not compromise the other security settings in Norton Internet 
Security 2004. 

 

Also see the Knowledge Base article regarding Norton Internet Security 2005. 

To use CuteFTP with Norton Internet Security 2004 

1. Open Norton Internet Security 2004. You can open it by clicking the Norton Internet Security icon 
on your task bar.  

2. In the Norton Internet Security window, select Personal Firewall. 

3. In the lower right, select Configure. A dialog box with tabs appears. 

4. Click Programs tab. 

5. In the Manual Program Control section, scroll down to find the ftpte.exe row. 

6. Right-click in the Internet Access column of the ftpte.exe row, then click Permit All. 

7. Click OK. Norton Internet Security 2004 should now allow CuteFTP to make connections and 
transfers. 

CANNOT DOWNLOAD EXECUTABLE FILES 

If you use remote filters while connecting with some Unix or Linux servers, CuteFTP cannot download 
some of the files. You must turn off the filters to download the files. 

To turn off remote filters 

1. In the Site Manager, click the site you want to change. 

2. Click the Actions tab. 

3. Click Filter. The Filter dialog box appears. 

4. Delete any filters listed in Remote filter, except for the -L filter. 

5. Click OK to close the Filter dialog box. 

6. Click Connect and download your files. 

CANNOT CONNECT FROM WINDOWS 

Windows comes with a built-in Internet Firewall that is active by default and blocks all FTP traffic. You can 
turn off this firewall (not recommended by Microsoft) or configure it to allow connections via CuteFTP. 
Follow the steps below to add CuteFTP to the Windows Firewall exceptions list. 

http://kb.globalscape.com/Article.aspx?id=10132
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To add CuteFTP to the Windows Firewall exceptions list 

1. In the Windows Control Panel, double-click Security Center, then click Windows Firewall.  

2. On the General tab, ensure Windows Firewall is On and then clear the Don't allow exceptions 
check box.  

3. On the Exceptions tab, review the Programs and Services list to determine if CuteFTP is listed. 
Look for: 

 CuteFTP (the interface) 

 ftpte.exe (the Transfer Engine) 

Both programs must be shown in the list of exceptions. If they are not, then follow the steps below 
to add either one or both programs to the list. 

4. Click Add Program. The Add a Program dialog box appears. 

5. In the Programs list, click CuteFTP, then click OK. The Add a Program dialog box closes. 

6. Click Add Program. The Add a Program dialog box appears. 

7. Click Browse to navigate to the CuteFTP installation folder (by default in C:\Program 
Files\GlobalSCAPE ), click ftpte.exe, then click Open.  

8. Click OK to close the Add a Program dialog box and save your changes. 

9. Verify both programs appear in the Programs and Services list, then click OK to exit Windows 
Firewall. The firewall will now ignore the transfer engine and the interface. 

 

For more information about the Windows Firewall, see the article on Microsoft's web site at 
http://www.microsoft.com/windowsxp/using/security/internet/sp2_wfintro.mspx, or search the Internet for 
"Windows Firewall." 

TRUNCATED LISTINGS 

If you connect to a server and the log displays the message 266-Options: -1 or 226 Output truncated to 
2000 matches, the server cannot display more than 2000 items in file listings. This is a limitation of the 
server to which you are connecting, not CuteFTP. 

UNABLE TO CONNECT TO TITAN FTP SERVER WHEN USING SSL 

You must use encryption for every session for every new transfer by disabling the reuse of cached 
sessions for data connection. 

To require encryption of every session for every new transfer 

1. On the main menu, click Tools > Global Options (or press ALT+F7). 

2. Expand the Security node, then click SSL Security. The SSL Security options appear. 

3. Clear the Reuse cached session for data connection (required by some servers) check box 
to require encryption of every session for every new transfer, then click OK. 

http://www.microsoft.com/windowsxp/using/security/internet/sp2_wfintro.mspx
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FIREWALL PROBLEMS 

Outgoing connections can be affected by the presence of firewall or anti-virus software on the local 
computer or network connection. Either one can block the ports needed to make a successful FTP 
connection to a remote server.   

If you are using a personal firewall software package, configure it so that ports 20 and 21 are open (not 
blocked). It may also be necessary to grant specific permission for CuteFTP to access those ports. If you 
need help configuring your personal firewall software, consult the documentation or the support section of 
their Web site. 

Symantec (Norton) support site:  

http://www.symantec.com/techsupp/support_options.html 

McAfee support site:  

http://www.mcafeehelp.com 

Microsoft Windows Firewall 

Refer to Cannot Connect from Windows XP. 

CONSERVE LOCAL FILE TIME FEATURE DOES NOT WORK PROPERLY 
WHEN CONNECTED TO SERV-U FTP SERVER 

The MDTM command is designed to be used for retrieving a file's time from the server. However, 
CuteFTP and various other FTP clients use the MDTM command to change (set) an uploaded file's 
timestamp. The standard documenting the MDTM command (http://www.ietf.org/rfc/rfc3659.txt) makes no 
provisions for using the MDTM command to set the file time stamp, so various clients and servers have 
implemented the command differently. 

Turn off this feature when connecting to Serv-U or other FTP servers that modify the time sent as 
part of the MDTM set sequence. 

The typical command syntax is MDTM YYYYMMDDHHMMSS FILENAME, where the HHMMSS is either the 

client's actual local time zone or, in the case of some FTP clients, GMT (Greenwich Mean Time), which 
mimics the retrieve behavior of MDTM as documented in section 2.3 of the standard. 

Certain servers, such as Serv-u, have extended the MDTM command even further, adding a time zone 
parameter to the end of the MDTM command, as follows:  

MDTM YYYYMMDDHHMMSS[+-TZ] FILENAME 

CuteFTP does not support this proprietary [+-TZ] parameter. Also, CuteFTP sends the local time for 

the HHMMSS portion of the MDTM command sequence, not the GMT time. Unfortunately, Serv-u (and 
potentially other FTP servers) expect the time to be sent in GMT and automatically adjust the time for the 
file, causing it to be different than what the client expected. 

Example 

CuteFTP retrieves a listing. File time shows 8:55 AM: 

-rw-rw-rw-   1 user     group       20249 May 14 08:55 Reports.cfc 

CuteFTP does an MDTM retrieve time to determine what the remote file's time is. Notice the server sends 
12:55 PM, adding 4 hours due to the server's time difference and GMT: 

COMMAND:>       MDTM Reports.cfc 

                213 20040514125501 

http://www.symantec.com/techsupp/support_options.html
http://www.mcafeehelp.com/
http://www.ietf.org/rfc/rfc3659.txt
http://tools.ietf.org/html/rfc3659#section-2.3
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CuteFTP uploads the replacement file: 

STOR Reports.cfc 

CuteFTP issues an MDTM command to set the time according the actual date and LOCAL time of the file, 
12:55 PM: 

COMMAND:>       MDTM 20040514125501 Reports.cfc 

Subsequently, CuteFTP retrieves the list from the server, with the time of 8:55 AM. 

-rw-rw-rw-   1 user     group       20249 May 14 08:55 Reports.cfc 

Notice that the server did not write the timestamp as 12:55, as requested. Instead, it assumed the 
timestamp was in GMT and subtracted 4 hours. 

PUBLIC KEY AUTHENTICATION FAILS 

After you set up an account for public key authentication, you still have to enter a password the first time 
you log in. When you set up public key authentication for an account and set the authentication type to 
Pwd OR Key, WinSSHD still must cache the password so that you can log in with just the public key. 
Therefore, on your first login attempt after you set up public key authentication, WinSSHD asks you for a 
password to store in the cache, even if your client already authenticated successfully using a public key. 
When this happens, just supply a valid password. When you log in after that, the password will be cached 
and you will not have to provide it again. 
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GETTING HELP 

GLOBALSCAPE SUPPORT CENTER 

For fast answers to most questions, please visit the GlobalSCAPE Help Center. Our Customer Service 
team can answer your questions about software activation and registration or help with order problems. If 
you need technical assistance with your software, please submit your question to the Technical Support 
team. 

 The GlobalSCAPE User Forum is a great place to find information or seek help from the global 
community of GlobalSCAPE customers and product experts.  

 The GlobalSCAPE Knowledge Base (KB) is a database of information on our products.  

 Subscribe to the RSS feed to keep abreast of the latest KB articles. Copy and paste this URL 
http://kb.globalscape.com/rssfeed.aspx into your RSS feed reader. (See below for examples.) 

 Subscribe to GlobalSCAPE Email Announcements Sign up for the GlobalSCAPE Newsletter, 
press releases, product announcements, and other GlobalSCAPE news.  

 Recover a Lost Serial Number - If you know the email address you used when you activated the 
software, we can send it to you at your new address.  

 Contact Customer Service by phone or email.  

 Contact Sales by calling 1-800-290-5054 or 1-210-308-8267, or use the online submission form. 
Sales representatives are available 8:00 a.m. to 6:00 p.m. (US Central Time) Monday through 
Friday, excluding major US holidays.  

 Order Status - Complete the online email form to request information about your order. 

 CuteFTP support pages provide downloads, documentation, activation instructions, and the latest 
news regarding CuteFTP. 

To add the GlobalSCAPE Knowledge Base RSS feed to your Google home page 

 

The procedures below are provided as an example; see your feed reader's online help for specific instructions. 

1. Sign in to your Google home page, then, in the upper right area of the page, click Add Stuff. 

2. At the top center of the page, to the right of Search Homepage Content, click Add by URL. The 
Add by URL form appears. 

3. In the text box, provide the URL of the RSS feed, http://kb.globalscape.com/rssfeed.aspx, then 
click Add. 

4. In the upper left corner, click Back to Homepage. The GlobalSCAPE RSS feed appears on your 
home page. 
 

 

http://www.globalscape.com/support/
http://www.globalscape.com/support/techsupport.aspx
http://forums.globalscape.com/
http://kb.globalscape.com/rssfeed.aspx
http://www.globalscape.com/e/s.aspx
http://www.globalscape.com/support/lostserial.aspx
http://www.globalscape.com/support/customerservice.aspx
http://www.globalscape.com/support/sales.aspx
http://kb.globalscape.com/article.aspx?id=10296
http://www.globalscape.com/support/customerservice.aspx
http://www.globalscape.com/support/pro.aspx
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To add the RSS feed to Microsoft Outlook 2007 

1. On the main menu, click Tools > Account Settings.  

2. On the RSS Feeds tab, click New.  

3. In the New RSS Feed dialog box, type or paste the URL of the RSS Feed. For example, 
http://kb.globalscape.com/rssfeed.aspx.  

4. Click Add.  

5. Click OK.  
  

 

Microsoft Office Online provides a tutorial on RSS feeds. 

FINDING INFORMATION IN THE HELP 

You can find information in the online or application help in several ways: 

 Hyperlinks - Clickable text that opens another topic or a Web page. 

 Related Topics - Listed at the bottom of many topics, lists other topics relevant to the current 
topic.   

 Using the Contents, Search, or Favorites, tabs, do the following: 

Tab Description 

Contents Contains the table of contents. Click a main heading (represented by a book icon) to display 
pages that link to topics, and click each subheading (represented by a page icon) to display 
the corresponding topic in the right pane. 

Search  Use the search pane or the Search box in the toolbar to locate words or phrases within the 

content of the topics. Type the word or phrase in the text box, press ENTER, then click in the 
list of topics, click the topic you want to view. 

Favorites (This option is not available in the Web help.) You can add a frequently viewed topic to the 
Favorites tab in the application's help. Click Add to add the topic you are viewing to the 
Favorites tab. To remove a topic, click the topic then click Remove. To display a topic, 
double-click it or click the topic, then click Display.  

Searching the User Guide or globalscape.com 

When searching, try several different searches using different words for the same concept. For example, 
if you want help with creating a script, search for script, vb, batch, and so on. Also, we have attempted to 
provide intuitive names for the topic titles, and the Index and Table of Contents contains the topic titles of 
every topic in the help file. So, in this example, if you are looking for a procedure on how to create a 
script, click the Index tab or Contents tab and scroll to the topic Creating Scripts. 

When you search globalscape.com, you are searching across all of GlobalSCAPE products, not just 
CuteFTP. For targeted searches, try the application's help file first, then the online help file, then the 
Knowledge Base, then the user forum. (You can also search this PDF.) If you still cannot find the answer 
to your question, contact GlobalSCAPE Technical Support. Be sure to let us know that you had problems 
finding your answer in any of our self-help resources so that we can provide better information in the 
future. 

http://office.microsoft.com/training/training.aspx?AssetID=RC102254891033&pid=CR100654581033
http://kb.globalscape.com/
http://forums.globalscape.com/
http://www.globalscape.com/support/techsupport.aspx
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Printing a Help Topic 

To print a Help topic: 

1. Do one of the following: 

 Click the Print icon in the toolbar. 

 Right-click in the topic (in the right pane), then click Print. The Print dialog box for your 
operating system appears. 

2. Click Print. The topic is printed to the specified printer. 

Sharing Topic Links from the Online Help 

In the online (HTML) help, the address bar displays the IP address (URL) of the help file, not the URL of 
the specific topic. If you right-click in the topic, then click Properties, you can copy the URL of the topic; 
however, the URL displays only the topic, without the Table of Contents.. The procedure below describes 
how to send a topic URL that also displays the Table of Contents.  

To copy a topic URL that includes the table of contents 

1. Open the topic in your Web browser.  

2. Right-click within the topic (the right frame), then click Properties. 

3. Highlight the URL for the topic, right-click the selection, click Copy, and then close the 
Properties dialog box.  
 

 

4. Right-click in the address bar of your browser, click Paste, and then press ENTER. The topic 
displays, but not the table of contents (TOC). 

5. If you want to see the topic AND the TOC, click Show. The URL will update in the address bar 
and the TOC will appear to the left of the topic. 

6. Copy the URL in the address bar (e.g., 
http://help.globalscape.com/help/cuteftp8/index.htm#toc_getting_help.htm) and paste it into an e-
mail.  
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USING THE KNOWLEDGE BASE 

GlobalSCAPE's Knowledge Base, http://kb.globalscape.com, provides information in HOW TOs, FAQs, 
and other types of articles. Many of the articles are created as a result of assisting customers with 
configuration and troubleshooting.  

 

Search Tips: 

 For the most comprehensive search for articles specific to CuteFTP type cuteFTP, then click Go.  

 To narrow your search, in the Within drop-down menu, click CuteFTP. 

 To only find certain types of articles (FAQ, HOWTO, INFO, etc.), in the Type drop-down menu, 
click an article type. 

 In the Search area, the options apply to where it searches, not the display of results. That is, if 

you search for cuteftp and then click Article ID, no results are returned, since Article IDs are 

numbers. For example, if you wanted to search for an article ID 10070, in the For solutions 

containing box type 10070, click Article ID, then click Go.  

 To search for your keyword only in article titles, click Article Title Only.  

 To search only for articles going back a certain length of time (e.g., 3 days ago, last year), click 
the Maximum Age drop-down menu, then click the interval.  

 After your search results display, at the bottom left of the page, you can click a drop-down menu 
to choose to display from 10 to 100 results per page, then click Update. 

LICENSE INFORMATION 

When you contact GlobalSCAPE Customer Support for assistance, you might be asked to provide your 
serial number, which is available in the About dialog box: 

 On the main menu, click Help > About. The About dialog box appears. 

http://kb.globalscape.com/
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LICENSE AGREEMENTS 

GLOBALSCAPE, INC. CUTEFTP® HOME VERSION 8 LICENSE   

THIS SOFTWARE IS LICENSED, NOT SOLD. YOU MAY USE THIS SOFTWARE ONLY AS 
DESCRIBED IN THIS AGREEMENT.  

IF YOU DO NOT AGREE TO THE TERMS OF THIS AGREEMENT, DO NOT INSTALL THE 
SOFTWARE OR USE ANY REGISTRATION NUMBER THAT WAS PROVIDED WITH THE SOFTWARE. 
YOU MAY CONTACT THE WEB SITE OR STORE WHERE YOU PURCHASED THE LICENSE FOR A 
REFUND IF APPLICABLE. 

1. SOFTWARE. The capitalized term "Software" refers to the object code for the computer program 
known as CuteFTP Home, any updates, supplemental code or programs provided to you by 
GlobalSCAPE with or in connection with CuteFTP Home, the user's manual and Help file, any 
components, any related media and printed materials, and any related "online" or electronic 
documentation. 

2. GRANT OF LICENSE. Evaluation License. If you acquired the license for the Software on an 
evaluation or trial basis, you may use the Software without charge for the evaluation period. Your 
evaluation period begins on the day you install the Software. You must pay the license fee and register 
your copy to continue to use the Software after the evaluation period. To pay the license fee and register 
your copy, you should visit www.globalscape.com or an authorized sales agent. For so long as the 
Software is the most current version of CuteFTP Home distributed by GlobalSCAPE, you may give exact 
copies of the evaluation Software to anyone. You may not charge any fee for the copy or use of the 
evaluation Software itself, but you may charge a distribution fee that is reasonably related to any cost you 
incur distributing the evaluation Software (e.g. packaging). You must not represent in any way that you 
are selling the Software itself. Your distribution of the evaluation Software will not entitle you to any 
compensation from GlobalSCAPE. You must distribute a copy of this license with any copy of the 
Software and anyone to whom you distribute the Software is subject to this license. You may not remove 
any copyright, trademark, or reservation of rights language displayed on, in, or with the Software. 

Registered License. When you purchase a license, you will be provided with a registration number. You 
must enable the registered license for the Software by entering the registration number as prompted by 
the Software. The term of the license is perpetual unless you purchased a limited term license. You may 
install and use one copy of the registered Software on the number of computers for which you have 
purchased a separate license as indicated on the invoice or sales receipt. If the Software is installed on a 
network server or other storage device, you must purchase a license for each separate computer on 
which the Software is used or accessed. A license for the Software may not be shared by alternating use 
of the Software between different computers. If you acquired the Software for a reduced price as an 
upgrade from a previous version of the Software, you may no longer use the previous version. The 
primary user of a computer for which a license has been purchased may access the Software via a 
remote technology, and may make and use one copy of the Software on his or her portable computer. 
You may also make one copy of the Software for back-up or archival purposes. Otherwise, you may not 
copy the Software in whole or in part. You may permanently transfer all of your rights under this license if 
the recipient agrees to the terms of this license, you destroy any copy of the Software not transferred to 
the recipient, and, if the Software was licensed to you at a reduced price as an upgrade from a previous 
version, you destroy any copy of any previous version that is not transferred to the recipient. If you 
purchased the Software on a multi-user basis, you may permanently transfer your rights to one person 
only, but that person may use the Software on that number of computers for which you purchased a 
license. 

3. RESTRICTIONS. You may not reduce the Software to human readable form, reverse engineer, de-
compile, disassemble, merge, adapt, or modify the Software, except and only to the extent that such 
activity is expressly permitted by applicable law notwithstanding this limitation. You may not rent, lease, or 
lend the Software. You may not use the Software to perform any unauthorized transfer of information, 
such as copying or transferring a file in violation of a copyright, or for any illegal purpose. 
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4. SUPPORT SERVICES. GlobalSCAPE may provide you with support services related to the Software. 
Use of support services is governed by the user manual, online documentation, and other GlobalSCAPE 
materials, as they may be modified from time to time. GlobalSCAPE may use any information you provide 
as part of obtaining support services for its business purposes, including product support and 
development. 

5.  INFORMATION COLLECTION. The Software includes a feature that assigns a unique number to your 
computer based on system information. The Software reports this number to us when you install the 
Software, enter your registration number, or both. The Software may also identify and report to us your 
Windows language-identifier setting, IP address, and the date and time of installation and/or registration. 
We use this information to count the number of installations, detect piracy of the Software, and develop 
rough statistical data regarding the geographic location of our users. If you register our Software, we tie 
this information to the personally identifiable information that we have about you. 

6. TERMINATION.  This license terminates if you fail to comply with its terms and conditions.  If your 
license terminates, you must destroy all copies of the Software. The termination of this license does not 
limit GlobalSCAPE's other rights it may have by law. 

7. INTELLECTUAL PROPERTY. You acknowledge that you have only the limited, non-exclusive right to 
use and copy the Software as expressly stated in this license and that GlobalSCAPE retains title to the 
Software and all other rights not expressly granted. You agree not to remove or modify any copyright, 
trademark, patent, or other proprietary notices that appear, on, in, or with the Software. The Software is 
protected by United States copyright, patent and trademark laws, and international treaty provisions. 

8. EXPORT RESTRICTIONS. You may not export or re-export the Software in violation of the export laws 
of the United States, or the applicable laws of any other jurisdiction. Among other things, U.S. laws 
provide that the Software may not be exported or re-exported to certain countries that are embargoed or 
restricted or to certain restricted persons. Embargoed and restricted countries currently include Cuba, 
Iran, Iraq, Libya, and Sudan. 

9. NO WARRANTIES: TO THE EXTENT PERMITTED BY APPLICABLE LAW, THE SOFTWARE AND 
ANY SUPPORT SERVICES ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER 
EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NONINFRINGEMENT. IF 
APPLICABLE LAW REQUIRES A WARRANTY, THE REQUIRED WARRANTY IS LIMITED TO NINETY 
(90) DAYS FROM YOUR RECEIPT OF A COPY OF THE SOFTWARE. COMPUTER PROGRAMS ARE 
INHERENTLY COMPLEX, AND THE SOFTWARE MAY NOT BE FREE OF ERRORS. THE SOFTWARE 
IS PROVIDED WITH ALL FAULTS AND THE ENTIRE RISK AS TO SATISFACTORY QUALITY, 
PERFORMANCE, ACCURACY AND EFFORT IS WITH YOU. 

10. LIMITATION OF LIABILITY. GLOBALSCAPE IS NOT LIABLE TO YOU FOR ANY 
CONSEQUENTIAL, SPECIAL, INCIDENTAL, OR INDIRECT DAMAGES OF ANY KIND ARISING OUT 
OF THE DELIVERY, PERFORMANCE, OR USE OF THE SOFTWARE, EVEN IF GLOBALSCAPE HAS 
BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  UNLESS APPLICABLE LAW 
PROVIDES OTHERWISE, GLOBALSCAPE'S LIABILITY FOR ANY CLAIM RELATED TO YOUR 
PURCHASE OF A LICENSE FOR OR USE OF THE SOFTWARE, WHETHER IN CONTRACT, TORT, 
OR ANY OTHER THEORY OF LIABILITY WILL NOT EXCEED THE GREATER OF U.S. $5.00 OR THE 
LICENSE FEE PAID BY YOU. 

11. U.S. GOVERNMENT. The Software is commercial computer software developed solely at private 
expense. The rights of civilian and non-civilian agencies of the U.S. Government to use, disclose and 
reproduce the Software are governed by the terms of this License. Publisher is GlobalSCAPE, Inc., 4500 
Lockhill-Selma Road, Suite 150, San Antonio, Texas, 78249, USA. 

12. SECURITY. You agree that GlobalSCAPE is not liable to you for security breaches resulting from your 
use of the Software. The security of the Software depends primarily on you selecting a secure password 
and keeping it confidential. You should not select a password that may be easily discovered by others. 
 For example, you should not use a word or sequential series of numbers. We recommend a random 
choice of at least 6 mixed alpha and numeric characters, with variations between upper and lower case. 
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13. AUDIT. You agree that on GlobalSCAPE's request you will certify in writing your compliance with the 
terms of this license, including your use of the Software only on the number of computers/servers 
licensed. 

14. ASK.COM TOOLBAR END USER LICENSE TERMS. If you have chosen to install the ask.com 
search toolbar with CuteFTP, review the ask.com toolbar End-User License Terms and Privacy Policy at 
http://about.ask.com/en/docs/about/ask_eula.shtml. 

15.MISCELLANEOUS. This license is governed by the laws of the State of Texas, U.S.A. This license is 
not governed by the United Nations Convention of Contracts for the International Sale of Goods. You 
agree to submit to the jurisdiction of courts sitting in the State of Texas for all purposes. Sole and 
exclusive venue for any dispute arising under or relating to this agreement shall be in a court sitting in 
Bexar County, San Antonio, Texas. This license constitutes the complete and exclusive agreement 
between us, notwithstanding any provision in any purchase order or other written document, except for 
our except for the definition of any evaluation period or limited term license appearing on the Web or 
other documentation accompanying the license and the statement of the number of separate user license 
fees for which you have paid as described in Section 2, above. This license may only be modified by a 
written document signed by GlobalSCAPE.  No GlobalSCAPE dealer or distributor is authorized to 
change the terms of this license. If any provision of this license is held to be unenforceable, the remainder 
of the license shall not be affected, and the unenforceable provision shall be reformed to the extent 
necessary to make the provision enforceable. If you are located outside the United States, then the 
following provision applies: Les parties aux présentés conferment leur volonté que cette convention de 
même que tous les documents y compris tout avis qui SHY rattaché, soient redigés en langue anglaise. 
(Translation: "The parties confirm that this Agreement and all related documentation is and will be in the 
English language.") 

Should you have any questions concerning this license, or if you desire to contact GlobalSCAPE for any 
reason, please contact GlobalSCAPE by mail at: GlobalSCAPE, Inc., 4500 Lockhill-Selma Road, Suite 
150, San Antonio, Texas, 78249, USA, by telephone at: (210) 308-8267, or by electronic mail from: 
http://support.globalscape.com. 

REGISTRATION AND TRADEMARKS 

© 1996 GlobalSCAPE, Inc. All rights reserved. CuteFTP and GlobalSCAPE are registered trademarks of 
GlobalSCAPE, Inc. The CuteFTP Home, CuteFTP Professional, CuteFTP Lite, and GlobalSCAPE logos 
are trademarks of GlobalSCAPE, Inc.  

This program includes software developed by Info-Zip, zlib, David Wincelberg, and the OpenSSL 
Projects. See the Info-Zip License Agreement, OpenSSL License Agreement, and zlib license agreement. 
A portion of this program is derived from the RSA Data Security, Inc. MD5 Message-Digest Algorithm. 

OPENSSL LICENSE AGREEMENT 

This program includes software developed by the OpenSSL Project which was used by GlobalSCAPE 
pursuant to the following license.  

Copyright (c) 1998-2003 The OpenSSL Project.  All rights reserved. 

Redistribution and use in source and binary forms, with or without modification, are permitted provided 
that the following conditions are met: 

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the 
following disclaimer. 

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the 
following disclaimer in the documentation and/or other materials provided with the distribution. 

3. All advertising materials mentioning features or use of this software must display the following 
acknowledgment: "This product includes software developed by the OpenSSL Project for use in the 
OpenSSL Toolkit. (http://www.openssl.org/)" 

http://about.ask.com/en/docs/about/ask_eula.shtml
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4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse or promote 
products derived from this software without prior written permission. For written permission, please 
contact openssl-core@openssl.org. 

5. Products derived from this software may not be called "OpenSSL" nor may "OpenSSL" appear in their 
names without prior written  permission of the OpenSSL Project. 

6. Redistributions of any form whatsoever must retain the following acknowledgment: "This product 
includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit 
(http://www.openssl.org/)" 

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY EXPRESSED OR 
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO 
EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, 
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, 
BUT  NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, 
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY 
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE 
OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED 
OF THE POSSIBILITY OF SUCH DAMAGE. 

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com).  This product 
includes software written by Tim Hudson (tjh@cryptsoft.com). 

ZLIB LICENSE AGREEMENT 

This program includes Info-Zip Software which was used by GlobalSCAPE pursuant to the following 
license. 

  zlib.h -- interface of the 'zlib' general purpose compression library version 1.2.1, November 17th, 2003 

  Copyright (C) 1995-2003 Jean-loup Gailly and Mark Adler 

This software is provided 'as-is', without any express or implied warranty.  In no event will the authors be 
held liable for any damages arising from the use of this software. Permission is granted to anyone to use 
this software for any purpose, including commercial applications, and to alter it and redistribute it freely, 
subject to the following restrictions: 

1. The origin of this software must not be misrepresented; you must not claim that you wrote the original 
software. If you use this software in a product, an acknowledgment in the product documentation would 
be appreciated but is not required. 

2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the 
original software. 

3. This notice may not be removed or altered from any source distribution. 

  Jean-loup Gailly jloup@gzip.org 

  Mark Adler madler@alumni.caltech.edu 
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