# Table of Contents

## Chapter 1. Getting Started

- What's New in this Version? ................................................................. 16
- System Requirements ........................................................................ 17
- Installing the CutFTP® Application .................................................. 17
- Activating CuteFTP ............................................................................ 18
- Troubleshooting Product Activation ................................................ 19
- Backing Up Registration Information ............................................... 19
- Upgrading CuteFTP ........................................................................... 20
- Moving CuteFTP to a Different Computer ....................................... 20
- Quick Reference Guide ..................................................................... 21

## Chapter 2. The CuteFTP Interface

- Main Menu .......................................................................................... 27
- Displaying or Hiding Toolbars ........................................................ 30
- The Standard Toolbar ......................................................................... 30
- HTML Editor Toolbar .......................................................................... 31
- Status Bar ............................................................................................ 32
- Keyboard Shortcuts ........................................................................... 32
- The Site Manager ................................................................................ 35
- Local Files and Folders ...................................................................... 36
- Transfer Queue .................................................................................. 36
- Connection Log .................................................................................. 37
- Individual Session Log ....................................................................... 37
- Global Options Dialog Box ............................................................... 38
- Site Properties .................................................................................... 43
  - Site Properties - General Tab ......................................................... 43
  - Site Properties - Actions Tab ......................................................... 44
  - Site Properties - Type Tab ............................................................ 45
  - Site Properties - Options Tab ....................................................... 46
- File and Folder Properties .................................................................. 47
  - About CHMOD Permissions ......................................................... 48
- Filtering the List of Files and Folders ............................................... 49
- Viewing Thumbnails .......................................................................... 50
- Changing How Files and Folders are Displayed ............................ 50
- Lockstep Folder Navigation .............................................................. 51
- Default Language ............................................................................... 51
- Display Settings ................................................................................ 51
Prompts ................................................................................................................................................ 53
Windows Explorer Right-Click Menu ................................................................................................. 53
Sound Options ...................................................................................................................................... 54
Log File Settings ................................................................................................................................... 54
Security Settings ................................................................................................................................... 57

Chapter 3. Defining Sites .............................................................................................................. 59
Using the Connection Wizard ............................................................................................................... 60
The Site Manager .................................................................................................................................. 62
Internet Connection (DUN/LAN) Settings ............................................................................................. 62
Connection Options .............................................................................................................................. 63
Changing the FTP Port .......................................................................................................................... 65
Connecting to an HTTP Site .................................................................................................................. 66
Connecting to Secure Sites .................................................................................................................. 68
Connecting to Secure Socket Layer (SSL and TLS) Sites ...................................................................... 69
Connecting to Secure Shell (SSH2) Sites .............................................................................................. 71
Automatically Displaying a Specific Folder when Connecting to a Site .............................................. 71
Multiple Concurrent Connections ......................................................................................................... 72
Performance Limitations ...................................................................................................................... 73
Using the ACCT Command .................................................................................................................. 73
Password Protect Site Manager Content ............................................................................................. 74
Staying Connected with Smart Keep Alive .......................................................................................... 75
SOCKS 4 and 5 Connection Settings .................................................................................................... 76
Proxy Connection Settings .................................................................................................................. 77
Encrypt Passwords Using OTP ............................................................................................................. 78
TappIn™ Site Creation ........................................................................................................................... 79
Web Distributed Authoring and Versioning (WebDAV) ........................................................................ 83

Chapter 4. Site Administration ..................................................................................................... 85
Importing and Exporting Site Configuration ....................................................................................... 85
Removing a Site from the Site Manager ............................................................................................... 86
Changing a Site's Connection Settings or Login Information ............................................................. 86
Changing the Data Connection Type (Port or PASV) ........................................................................... 87
Proxy Settings for Individual Sites ........................................................................................................ 87
Correcting Times for Sites in Different Time Zones ............................................................................ 89
Specifying Whether to Save a Site's Information - Caching ............................................................... 89
Designating a Site's Server Type ........................................................................................................... 90
Finding a Site in the Site Manager ....................................................................................................... 91
Creating and Using Bookmarks .......................................................................................................... 91

Chapter 5. OpenPGP Security Settings .......................................................................................... 95
OpenPGP keys ...................................................................................................................................... 95
Table of Contents

Uploading and Downloading Files Using OpenPGP Keys............................................................. 96

Chapter 6. SSL/TLS Connections (FTPS/HTTPS).................................................................99

Learning about SSL.............................................................................................................................. 99
SSL Security Settings ........................................................................................................................... 99
Creating SSL Certificates ................................................................................................................... 100
Signed SSL Certificates .................................................................................................................... 103
Choosing a Certificate for SSL Sessions ........................................................................................... 103
Accepting Server SSL Certificates .................................................................................................. 103
Importing or Removing SSL Certificates from the Trusted List ....................................................... 104
Using a Clear Data Channel with SSL .............................................................................................. 104
Using a Clear Command Channel with SSL .................................................................................... 105
Secure Site-to-Site Transfers Using SSCN...................................................................................... 105
Troubleshooting SSL Connections ................................................................................................... 105
Unable to Connect to Titan FTP Server when Using SSL ............................................................... 106

Chapter 7. SSH2 Connections (SFTP)........................................................................................107

SFTP in CuteFTP ............................................................................................................................... 107
Transport Layer Settings................................................................................................................... 108
Authentication Layer Settings......................................................................................................... 108
Authenticating in SSH2....................................................................................................................... 109
SSH2 Security Settings ...................................................................................................................... 110
Creating SSH2 Key Pairs ................................................................................................................... 111
Using SSH2 Key Pairs ......................................................................................................................... 113
Troubleshooting SFTP Connections.................................................................................................. 114
Cannot Connect to SSH2 (SFTP) Sites ........................................................................................... 114
SFTP Errors......................................................................................................................................... 115
Public Key Authentication Fails......................................................................................................... 115

Chapter 8. Transferring Files and Folders...............................................................................117

Transferring Files and Folders........................................................................................................... 117
Transfer Settings............................................................................................................................... 117
Startup and Exit Options................................................................................................................... 119
Smart Overwrite Settings.................................................................................................................. 120
Default Download Folder ................................................................................................................ 123
Rename Rules..................................................................................................................................... 123
Symbolic Links................................................................................................................................... 124
Queuing Files and Folders for Transfer............................................................................................ 125
Removing Items from the Queue....................................................................................................... 125
Uploading Files from Anywhere in Windows .................................................................................. 126
Transferring Files in Order............................................................................................................... 127
Navigation Options........................................................................................................................... 127
<table>
<thead>
<tr>
<th>Table of Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wildcard Masks</td>
<td>155</td>
</tr>
<tr>
<td>Displaying Hidden Files or Folders</td>
<td>156</td>
</tr>
<tr>
<td>Comparing Folders by Case, Size, and Date</td>
<td>156</td>
</tr>
<tr>
<td>Synchronizing Folders</td>
<td>157</td>
</tr>
<tr>
<td>Backing Up Local Files to Remote Host</td>
<td>159</td>
</tr>
<tr>
<td>Restoring Local Files Backed Up to Remote Host</td>
<td>163</td>
</tr>
<tr>
<td>Backing Up Remote Folders</td>
<td>165</td>
</tr>
<tr>
<td>Monitoring a Local Folder for Changes</td>
<td>166</td>
</tr>
<tr>
<td>Listing Files on HTTP Sites</td>
<td>168</td>
</tr>
<tr>
<td>Chapter 10. Integrated HTML Editor</td>
<td>169</td>
</tr>
<tr>
<td>HTML Editor Overview</td>
<td>169</td>
</tr>
<tr>
<td>HTML Editor Settings</td>
<td>169</td>
</tr>
<tr>
<td>Default HTML Template</td>
<td>171</td>
</tr>
<tr>
<td>HTML Tags for a Specific Browser</td>
<td>172</td>
</tr>
<tr>
<td>HTML Code Snippets and Java Scripts</td>
<td>173</td>
</tr>
<tr>
<td>Creating a New HTML Document</td>
<td>174</td>
</tr>
<tr>
<td>Finding and Replacing Text in HTML Documents</td>
<td>174</td>
</tr>
<tr>
<td>Page Loading Speed and File Size</td>
<td>175</td>
</tr>
<tr>
<td>Basic HTML Tags</td>
<td>176</td>
</tr>
<tr>
<td>Cascading Style Sheets (CSS)</td>
<td>178</td>
</tr>
<tr>
<td>Using Colors</td>
<td>179</td>
</tr>
<tr>
<td>Saving HTML Documents</td>
<td>180</td>
</tr>
<tr>
<td>Opening an HTML Document for Editing</td>
<td>180</td>
</tr>
<tr>
<td>Previewing an HTML Document in a Browser</td>
<td>181</td>
</tr>
<tr>
<td>Editing an HTML Document on a Remote Site</td>
<td>181</td>
</tr>
<tr>
<td>Printing an HTML Document</td>
<td>181</td>
</tr>
<tr>
<td>Closing an HTML Document</td>
<td>182</td>
</tr>
<tr>
<td>Opening the HTML Editor in a Full Window</td>
<td>183</td>
</tr>
<tr>
<td>Adding Counters and Other Utilities</td>
<td>183</td>
</tr>
<tr>
<td>Learning HTML</td>
<td>183</td>
</tr>
<tr>
<td>Chapter 11. Transfer Engine (Scripting)</td>
<td>185</td>
</tr>
<tr>
<td>About the Transfer Engine</td>
<td>185</td>
</tr>
<tr>
<td>Transfer Engine (TE) Initial Setup</td>
<td>187</td>
</tr>
<tr>
<td>Distributing and Licensing the Transfer Engine</td>
<td>187</td>
</tr>
<tr>
<td>Installing the TE (for Distribution)</td>
<td>188</td>
</tr>
<tr>
<td>Registering the TE (for distribution)</td>
<td>188</td>
</tr>
<tr>
<td>COM Registration of the TE (for Distribution)</td>
<td>189</td>
</tr>
<tr>
<td>Finalizing TE Distribution</td>
<td>190</td>
</tr>
<tr>
<td>Troubleshooting TE Distribution</td>
<td>190</td>
</tr>
</tbody>
</table>
Using the TE to Connect via FTPS (When Running a Script and not Logged In) .............................................. 191
Transferring Files or Sites with the Transfer Engine .......................................................................................... 193
Running Scripts .................................................................................................................................................. 193
Creating Scripts ............................................................................................................................................... 194
Methods, Properties, and Wildcards Overview ............................................................................................... 195
  Available Methods and Properties .................................................................................................................. 196
  Timeout Strategies for the Wait Method ............................................................................................................ 237
Using a Script to Connect to a Remote Site ........................................................................................................ 238
Using a Script to Download a File ...................................................................................................................... 238
Scheduling Scripts with the Windows Task Scheduler ...................................................................................... 239
Scheduling Scripts with the Windows NT 4 AT Scheduler .................................................................................. 240
Running the Transfer Engine without a User Present .......................................................................................... 240
Running the Transfer Engine from a SQL Job ..................................................................................................... 241
Help with Scripts ............................................................................................................................................... 242
Disabling Prompts ............................................................................................................................................. 242
Troubleshooting TE Problems ........................................................................................................................... 243

Chapter 12. Troubleshooting Connection and Transfer Errors ................................................................................. 245
Antivirus Problems ............................................................................................................................................. 245
Cannot Close Data Transfer Gracefully ........................................................................................................... 245
Cannot Connect to Server ................................................................................................................................ 245
Cannot Create Multiple Connections to the Same Server .................................................................................. 246
Cannot Download Executable Files .................................................................................................................. 247
Cannot Download Files from a VMS Server ....................................................................................................... 247
Cannot Initiate Data Transfer ................................................................................................................................ 247
Cannot Resolve Host Name .................................................................................................................................. 248
Cannot See Remote Files or Folders .................................................................................................................. 248
Child Transfer Failed ......................................................................................................................................... 250
Connecting after a 425 Error ............................................................................................................................. 250
Copy and Paste Functions Remove File from the Remote Folder ...................................................................... 250
Error 421 Messages ........................................................................................................................................... 250
Failed to Establish Data Socket ....................................................................................................................... 251
FTP Status and Error Codes ................................................................................................................................ 251
High Memory Usage .......................................................................................................................................... 251
HTTP Status and Error Codes .......................................................................................................................... 252
Installshield Error 1628: Failed to Complete Script-Based Installation .............................................................. 252
Not Enough Credits to Download .................................................................................................................... 253
Shell cannot get Data from TE .......................................................................................................................... 253
Site-to-Site Transfer Limitations ........................................................................................................................ 254
Socket Errors ...................................................................................................................................................... 254
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overwrite Repeatedly Prompts Me</td>
<td>254</td>
</tr>
<tr>
<td>Permission Denied</td>
<td>255</td>
</tr>
<tr>
<td>Port Already in Use Error with Dial-up VPN</td>
<td>255</td>
</tr>
<tr>
<td>Transferring to Case-Sensitive Servers</td>
<td>256</td>
</tr>
<tr>
<td>Troubleshooting Connections</td>
<td>256</td>
</tr>
<tr>
<td>Truncated Listings</td>
<td>257</td>
</tr>
<tr>
<td>Using CuteFTP behind a Router</td>
<td>257</td>
</tr>
<tr>
<td>Using CuteFTP with Norton Internet Security</td>
<td>258</td>
</tr>
<tr>
<td>Using Error Messages and Logs to Troubleshoot</td>
<td>258</td>
</tr>
<tr>
<td>Windows Firewall is Blocking Connections</td>
<td>259</td>
</tr>
</tbody>
</table>

**Chapter 13. Getting Help**                         261  
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Globalscape Support Center</td>
<td>261</td>
</tr>
<tr>
<td>Finding Information in the Help</td>
<td>262</td>
</tr>
<tr>
<td>Searching the User Guide or globalscape.com</td>
<td>262</td>
</tr>
<tr>
<td>Printing a Help Topic</td>
<td>263</td>
</tr>
<tr>
<td>Sharing Topic Links from the Online Help</td>
<td>263</td>
</tr>
<tr>
<td>Using the Knowledge Base</td>
<td>264</td>
</tr>
<tr>
<td>Serial Number</td>
<td>264</td>
</tr>
</tbody>
</table>

**Chapter 14. License Agreements**                     265  
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>CuteFTP® Version 9 End-User License Agreement</td>
<td>265</td>
</tr>
<tr>
<td>Registration and Trademarks</td>
<td>267</td>
</tr>
<tr>
<td>3rd-Party License Agreements</td>
<td>268</td>
</tr>
</tbody>
</table>

**Index**                                               269
This page left blank for 2-sided "book" printing.
Chapter 1. Getting Started

At home or at the office, industry-leading CuteFTP software lets you intelligently and securely move your important files across multiple locations over WAN or LAN. With CuteFTP you can publish web pages; download the latest music, images, and software; or transfer files between servers at home, your Internet Service Provider, the office—any server that you can access over the network.

CuteFTP is simple enough for a novice FTP user, yet powerful enough for experienced users.

- The user-friendly interface allows you to easily update and maintain sophisticated websites
- You can safeguard transfers of mission-critical files with CuteFTP's security features
- You can even schedule and script transfers with minimal overhead using the Transfer Engine. You can use the Transfer Engine from within CuteFTP or with any COM-enabled scripting or programming language
- An integrated, color-coded HTML editor allows you to create, open, and edit HTML documents on your computer or a remote server within CuteFTP
- Unicode support—CuteFTP supports Unicode file names
- Integration with Tappln™ by Globalscape

File Transfer Security

- Secure SSL Sessions—CuteFTP secures sessions with 128-bit SSL, the same secure technology used by Internet browsers and servers for authentication, message integrity, and data confidentiality. SSL Session Choices—When setting up your SSL connection, CuteFTP lets you choose between three common SSL implementations, including TLS (AUTH TLS)*, SSL Implicit** (direct connect over port 990) and SSL Explicit** (AUTH SSL) mode. Most FTP servers support at least one, while some (such as Globalscape EFT Server) support all three.
- SSL Certificates—CuteFTP includes a full certificate management system, giving you the ability to accept or reject a server's certificate, store accepted certificates in a local database, import and export certificates in the local store, use Windows trusted certificate store for certificate approval, and the ability to create your own "strong" (4096-bit) self-signed certificate set, including a certificate request file (for signing by a Certificate Authority (CA) such as Verisign or Thawte).
- HTTPS Sessions—Connect, browse directories, and transfer to/from HTTPS Sites using the same strong security (SSL) that web browsers use for secure e-commerce transactions. HTTPS Sites also rely on certificates to verify that the client is communicating with the desired HTTPS server.
- Secure Shell (SSH2) Sessions—CuteFTP also supports the SSH2 protocol, specifically, SFTP.
- SFTP Configuration Options—CuteFTP gives you vast control over you SFTP session, including choice of encryption ciphers, MAC (Message Authentication Code) types, compression, and authentication* mechanisms to use.
- SFTP Identity Files—Use an identity file supplied by your host or create your own key-pair for authentication. When creating your own identity file, you can choose between RSA and DSS public key formats, key length (up to 4096 bits), and key storage location. Store trusted server identity files (certificates) in a local database. You can also import or export identity files from your local trusted store.
• **OpenPGP Encryption and Decryption**—CuteFTP uses an open-source encryption (OpenPGP) technology to encrypt data before it is sent to a server or to decrypt data retrieved from a server. OpenPGP uses public keys and private keys. This allows you to give others your public key, which they can use to encrypt a file. Only you can decrypt the file with your private key. The OpenPGP functionality in CuteFTP lets you encrypt files before uploading or decrypt files after downloading; create OpenPGP keys, key sizes, and select RSA or DSS cryptosystems; and import and export OpenPGP keys.

• **Secure Login Using OTP**—Some situations call for a secure login sequence, but not the securing of subsequent data and control channel transactions. For this case, CuteFTP offers One Time Password (OTP) authentication, a protocol based on Bell Lab's S/Key technology. OTP authentication is accepted by many UNIX and some Windows' FTP hosts, including Globalscape EFT Server.

• **Password Manager**—Encrypt your Site Manager contents using the powerful Blowfish cipher or completely disallow password saving, including URL and Quick Connect history, between application sessions. You can also change the default Site Manager and session-log storage locations. These policies and features help mitigate risks when running on a shared or physically unrestricted machine.

### Connection Options

• **Connection Wizard**—CuteFTP's Connection Wizard can guide you through setting up a new FTP connection. Once completed, CuteFTP will automatically connect to the new Site and store it in your Site Manager for subsequent connections.

• **Site Manager**—Store commonly accessed Sites in the built-in address book, the Site Manager. The Site Manager allows you to set specific options per-Site, and you can export or import Site data, including address books from 3rd-party FTP clients or previous versions of CuteFTP. You can optionally password protect your Site Manager with strong encryption to protect your Site information (especially Site passwords).

• **Quick Connect**—CuteFTP offers various other connection choices. Use the Quick Connect bar to enter Site connection information; use the Paste URL dialog to paste entire URLs from the clipboard, create a new Site, or launch an existing one directly from the main menu, or have CuteFTP automatically reconnect to the last visited Site on program startup.

• **Proxy / Socks / Firewall**—CuteFTP allows you to connect via proxy, socks, or firewall, including socks 4 & 5, HTTP, or FTP proxy connection options. Manually configure proxy or firewall connection settings or have CuteFTP automatically detect Internet Explorer's proxy settings, including "proxy.pac" proxy script files.

• **NAT UPnP**—CuteFTP will attempt to use the UPnP (Universal Plug and Play) NAT interface to provide proper port-mapping when connecting securely from behind a NAT/firewall using PORT mode (rather than PASV, due to the remote host also being behind a NAT/firewall). Without UPnP, you would need to manually set the port range in the client and also enable and forward them in the NAT/firewall device.

• **Smart Keep Alive**—Stay connected to Sites that automatically disconnect you when no activity is detected over a certain period. Configure various commands to be sent at random intervals to simulate user activity. CuteFTP's keep alive feature differs from its competitors in that it offers completely customizable keep alive options, including time to start sending commands, random time intervals between commands, a customizable commands list, and auto-reconnect and redial options.

• **Multiple Connections**—Connect, browse and navigate multiple Sites at the same time. Most FTP clients force you to disconnect from a Site when connecting to an alternate one. Each connection takes place in its own window. Connection windows can be tiled, cascaded or accessed by clicking on the corresponding tab.
Getting Started

- **Session Logs**—Connection and transfer logs can be displayed, captured to the Windows clipboard, and recorded to file. Determine where logs are saved, how often they’re updated or deleted, and more. Smart Keep Alive commands are not recorded and time stamps are included by default, greatly improving usability.

- **Work Offline**—Site caching allows you to minimize bandwidth while you browse. Browse previously visited Sites while offline, speeding up navigation while saving bandwidth and network resources. This benefits users in cases where they are charged for time connected and in cases where the host Site restricts access time.

- **Connection Options**—Set timeout, retry and delay values, connection limits, data connection port range, on connect events, and other connection related settings globally or per-Site.

**Transfer Options**

- **Standard Transfers**—CuteFTP supports multiple methods for transferring files and folders, including keyboard, mouse, menu, and toolbar. This simplest way to transfer is to "drag-and-drop" files into the Transfer queue.

- **Scheduled transfers**—Schedule a file, folder, or queue entry to be transferred later. Specify whether the scheduled event should recur at specific intervals and even choose from certain events to take place once the transfer is completed.

- **Site-to-Site transfers** (FXP)—Allows you to transfer files from one remote server to another, bypassing your computer altogether, thus decreasing the time necessary to complete the transfer. Site-to-Site transfers are made easy with a simple "drag n' drop" between remote Site panes. (While CuteFTP supports this feature, many servers block it due to "port theft" considerations.)

- **Transfer resume**—Transfer with confidence, even with slow connections or if you're using a lower performance FTP server. CuteFTP can detect a broken transfer and automatically resume it where it left off, rather than transfer the whole file over again.

- **Queue Transfers**—Select files and folders spanning multiple remote Sites and queue them for future transfer. CuteFTP’s robust queue management system allows you to manage the order (priority) of queue items, track the transfer status of queue items, schedule queue items, and modify a queue item’s properties. You can also save a snapshot of the queue and then load and run it in the future.

- **Multi-part transfers**—You can speed the transfer of large architectural, graphic, or engineering files with multi-part accelerated downloads. CuteFTP can split a single download file into multiple parts and later recombine them upon receipt. Combined with Globalsec EFT Server, CuteFTP is the only client that can perform multi-part uploads.

- **Simultaneous Transfers; Concurrent transfers**—Connect, browse, and navigate multiple Sites at the same time. Each connection takes place in its own window. Connection windows can be tiled, cascaded, or accessed by clicking on the corresponding tab.

- **Compressed Transfers**—Compress file and folders to .ZIP, .CAB, and Gzip/Tarball archives prior to uploading them, as well as, decompress downloaded archives of the same type.

- **Bandwidth throttling**—Specify the number of kilobytes per second to throttle the bandwidth of all sessions on CuteFTP.

- **Transfer integrity**—Verify the file integrity after a transfer has been completed. This feature relies on a proprietary command supported by Globalsec EFT Server.

- **Overwrite Rules**—Configure CuteFTP to determine whether an existing file that matches one being transferred needs to be overwritten, renamed, or skipped based on date, size, and other criteria, or choose to be prompted each time a matching file is found.
• **Auto-Rename Transfers**—Create rules to change a file’s name, extension, or case during transfer. Specify the source and destination name, including wildcards, and whether to change the case of a transferred file.

• **Right-click shell integration**—Transfer files from the Windows Desktop or Explorer.

• **Advanced Transfers**—Other transfer options in CuteFTP include transfer mode (ASCII/Binary/Auto), data connection mode (PASV/PORT/Auto), after transfer events, time stamp handling, byte offset from which to restart broken transfers, and more.

**Automation**

• **Transfer Engine**—Create sophisticated scripts or record sessions for automating FTP tasks using CuteFTP’s Transfer Engine. The modular Transfer Engine uses an industry standard Component Object Model (COM) interface to expose most of CuteFTP’s functions and properties. Choose between manually creating scripts using your favorite programming or scripting language or automatically creating scripts using the session record and playback tool.

• **Macro recording and playback**—CuteFTP can record and playback entire sessions using the powerful macro record/playback tool. Sessions are recorded in Visual Basic Script and take advantage of CuteFTP’s COM-exposed transfer engine (TE) interface.

• **Integrated HTML editor**—This powerful text editor includes color-coded HTML and PERL tags, Site-wide find and replace, HTML code-completion, and integration with CuteFTP that lets you edit files on your FTP server without downloading them.

• **Synchronize folders**—Mirror your local drive, remote Site, or both with just a couple of mouse clicks using CuteFTP’s Folder Synchronization tool. Schedule recurring synchronization events for continuous mirroring of local and remote folder trees. You can monitor more than one folder or synchronize multiple Sites with the Folder Synchronization Wizard, which guides you through setup.

• **Folder Comparison**—Compare folders before synchronizing them. Local and remote folder contents can be compared based on case, name, date, or size. Files that are different from each other are highlighted and can be selected and transferred for directory-wide changes.

• **Site Backup**—Schedule a single or recurring backup of your entire Site in three easy steps with our Site Backup Wizard. CuteFTP will download the entire Site into a backup folder, compress it (.ZIP, .CAB, or GZIP compression), and then label the resulting archive with a time and date stamp.

• **Local Backup**—Schedule a single or recurring backup of your local computer and safely store your data on a remote server. CuteFTP will upload the selected files and folders to an archive on a remote FTP server and will restore your data from the archive if your computer ever goes down.

• **Remote Backup**—CuteFTP allows you to create copies of remote files and folders on your local computer regularly or at a scheduled time. CuteFTP also compresses the backup automatically.

• **"On exit" events**—CuteFTP can be set to automatically exit, shutdown your computer, run a virus scan, or any number of other tasks after completing a transfer.

• **Folder monitoring**—(AKA "Hot Drop"): Detect changed items in a specific local folder tree automatically. If changes are detected, the modified files or folders are uploaded to a predefined server. Works great for publishing Web site changes from a staging server to a live server.

• **Custom Commands**—Create sets of commonly used command sequences and assign them a shortcut key for quick access. If needed, send FTP commands directly to the FTP server using the RAW FTP command feature for more granular control of the FTP session.

• **File Properties**—View or change permissions (CHMOD) for multiple files without having to know their numerical values by simply selecting whether Read, Write, or Execute is allowed for each group. View file and folder size, date, owner values, and more.
- **Time Stamp Control**—Preserve a server's time stamp for downloaded files. Choose to keep the locally defined time for uploaded files. Define the time offset for the server for greater efficiency in transfer and synchronization overwrite rules.

- **View and Open**—View the contents of remote text-based files quickly using Notepad or the built-in editor. You can also open files, which will download an item (if necessary) and run it using the associated program.

- **Event Triggers**—Specify automatic events to occur upon program startup, upon connecting to a Site, and upon transfer success. Choose to play sounds for various events as they occur and execute commands (such as virus scans) on files after they are downloaded.

**Navigation**

- **Advanced search**—Find files and folders easily, by name, size, or creation/modification date, whether they are on your local computer or a remote server.

- **Lockstep Folder Navigation**—Navigate simultaneously through local and remote folder directories that share the same structure. This makes it easier to compare the two when synchronizing content.

- **Folder Navigation**—Navigate remote and local folders using the mouse, keyboard, and toolbar buttons as you would when navigating through folders on your Windows Desktop or Explorer.

- **Folder Management**—Create new folders, rename existing ones, or delete unused folders. View a folder's properties and perform standard operations, such as cut, copy, and paste.

- **Default Download Folder**—Specify a default folder for placing your downloads. You can also specify a default local and remote folder for each Site, so when you connect, CuteFTP will automatically switch to the chosen folders.

- **Folder Bookmarks**—This feature is similar to the favorites or bookmark feature in your browser. You can bookmark one or more folder paths per Site, and later return to those paths by selecting the bookmark.

- **File and Folder Links**—Navigate folder links with ease with the help of CuteFTP's various link configuration options. These options tell CuteFTP how to interpret links, how to navigate to and from links, and what to do with the resulting target.

- **Folder Listings**—View folder listings for a variety of hosts, including UNIX, NT, VMS, MVS, AS/400, OS/2, Sterling CONNECT: Enterprise, Van Dyke SSH, and many more. Simple folder listing support (NLST), and raw folder listing options help display uncommon or proprietary folder listings not supported by CuteFTP.

- **Filtered listings**—Configure include and exclude masks for displaying specific items within a folder. Use filtering to only display or download specific items or as a way of sending specific parameters to a server's LIST command program.

- **File and Folder Select**—Use the various Group Select features along with wildcard masks to mark specific groups of items within a folder for transfer or deletion.

- **File and Folder Search**—Search for files or folders contained within a folder. Search for exact or partial names, including wildcards.

- **Navigation Settings**—CuteFTP has an enormous set of navigation features and options. Apart from those above, CuteFTP can lock a local folder to the active remote pane, configure folder index (table of contents) options, configure folder caching, auto-refresh folders after transfer and navigation events, set tolerance settings for problem servers, recursively delete across folders, delete to recycle bin, and much more.
Display Options

- **View thumbnails**—Find local or remote pictures quickly using Thumbnail View.
- **Toolbar**—Customize the toolbar in variety of ways.
- **Fonts and Colors**—Set log, editor, and main window fonts and colors.
- **File and Folder size**—Select whether to display file and folder sizes in kilobytes or let CuteFTP determine the best way to display them.
- **Sort**—Sort local and remote listings just like you would in Windows. Also choose between a natural language sorting alternative to the traditional lexicographic sorting of alphanumeric sequences.
- **Panes**—Choose which panes to show, whether to display Site and transfer logs, and whether gridlines should be displayed in each pane.
- **Prompts**—Choose whether to display error and event prompts. CuteFTP will also display detailed error messages for a better understanding of connection related errors.
- **Sounds**—Specify sounds for certain events, such as when a successful connection or transfer is made.
- **Focus**—CuteFTP optionally highlights the active pane, helping you visually identify which pane has the focus. Use the tabs on each pane to toggle between active sessions, between the **Site Manager** and **Local Drives** tabs, and between the **Queue Window** and **Log Windows**.

What's New in this Version?

CuteFTP version 9 includes the following improvements:

- **Unicode support** throughout CuteFTP (except for the integrated HTML Editor)
- Ability to specify the **filename encoding** for each Site in the Site manager as UTF-8, ASCII, or Auto-detect (default). You can also specify filename encoding separately for SFTP and FTPS Sites in **Global Options > Transfer** settings.
- Ability to save a text-based file as UTF-8 encoding format when you open it for editing
- Site Manager password reminder prompt
- **Site Manager import/export wizard** supports only text files.
- Updated or replaced 3rd-party libraries used in CuteFTP, including 7zip (as part of UNICODE changes), Zlib, log4cpp, pugixml, Veridis (Refer to **License Agreements** for more information)
- Updated SSL.DLL
- Updated SFTP.DLL and SFTP key manager (See note in **Upgrading CuteFTP** regarding SFTP keys.)
- **TappIn™ integration**:
  - TappIn Sites configured in the Site Manager are indicated by the TappIn logo
  - TappIn "test drive" Site installed by default
  - Ability to create a TappIn account from CuteFTP
- **Support for Web Distributed Authoring and Versioning (WebDAV)**, including TappIn and TappIn Lite users. Servers with WebDAV support are expected to return a "DAV" header in response to an HTTP(S) OPTIONS request from the client. CuteFTP automatically treats servers exhibiting this behavior as WebDAV servers.
- CuteFTP Pro, Home, and Lite have all been merged into one CuteFTP product.
- CutePODCast manager was removed

System Requirements

- An Internet connection, for accessing remote servers
- Web browser (for online registration, accessing the Knowledgebase, and accessing Support information)

The CuteFTP test effort spanned multiple releases of each of the four most popular browsers throughout our testing. CuteFTP was tested on the versions of the following browsers that were current at the time of testing:
- Chrome v21 and later
- Firefox v14 and later
- Safari v5.1 and later
- Internet Explorer v8, 9, and 10

At the time of release of CuteFTP, no compatibility issues were noted with any of the current versions of the browsers listed above. If any issues are discovered with future releases of these browsers, such issues will be noted in the Globalscape Knowledgebase at http://kb.globalscape.com/KnowledgebaseCategory7.aspx.

It is a good idea to keep your browser updated, as new versions are often released to fix security issues.

Installing the CutFTP® Application

Installing CuteFTP is fast and easy. The installation wizard steps you through the process with no confusing options to set in a typical installation.

To install CuteFTP

1. Do one of the following:
   - Download and save CuteFTP on your desktop, then double-click the executable to run the installer.
   - Place the installation CD in your DVD/CD-ROM drive. Installation should begin automatically. If your DVD/CD-ROM drive does not support automatic installation:
     a. Double-click My Computer located on the desktop.
     b. Double-click the DVD/CD-ROM drive icon.
     c. Double-click the installation program.
2. The Welcome page of the installer appears. Click Next.
3. The License Agreement appears. Click Yes to accept the agreement.
4. The Choose Destination Location page appears. The Destination Folder box displays the default location. To specify a different location, click Browse.
5. Click Next. The Setup Status appears and CuteFTP installation progress is displayed.
6. The InstallShield Wizard Complete page appears. If you want to place a shortcut on the desktop, select the Install a shortcut to CuteFTP on my desktop check box. Click Finish.
7. Double-click the desktop shortcut or the Start menu shortcut (Start > All Programs > Globalscape > CuteFTP 9) to open CuteFTP. The Welcome to CuteFTP 9 dialog box appears.
8. Do one of the following:
   - If you have a serial number, click Enter Serial Number and follow the procedure in Activating CuteFTP to register your copy of CuteFTP 9.
   - If you do not have a serial number, click Continue to begin the trial.

9. Go to the procedure for Using the Connection Wizard. (Before you begin transferring files, you will need to create a "Site" with which you will connect to a server to transfer files.)

Activating CuteFTP

CuteFTP must be activated within 30 days or it will no longer function. When prompted, provide the serial number you received when you purchased the product. You can use either your first and last name or your company name. After you have provided the information, you can view your activation information on the main menu by clicking Help > About CuteFTP.

To ensure your software is activated accurately, provide all of the optional details that are requested so that we can confirm your eligibility for technical support or any upgrades that may become available in the future.

Your serial number can be found on the invoice you received by email or on your product packing if you obtained a boxed version. If you have lost your serial number, you can request a copy using Globalscape’s Lost Serial Number form. Customer Support can locate your serial number if you provide your name, address, order ID, or any other pertinent data that might help us locate your original purchase record.

When you enter your registration information, it will be transmitted to Globalscape via the Internet. As part of the registration, the software assigns a unique number to your computer based on system information and reports this number to us. We use this data to help us prevent the program from being copied onto more computers than permitted by the license.

To register successfully, you must be connected to the Internet and have administrator privileges on your computer. If a firewall or proxy server is in use, the network administrator should ensure port 80 is open during the registration process.

If you do not have Internet access on the computer on which CuteFTP is installed, refer to the Troubleshooting section below.

To activate CuteFTP

1. On the Welcome screen, click Enter Serial Number or, on the main menu, click Help > Enter a serial number. The Registration wizard appears.
2. In the Serial Number box, provide the serial number, then click Next.
3. Provide your name, email address, company name, and other details, then click Next.
4. If online registration fails, you can try again, go to the Globalscape website to register, or email a request to Globalscape support. Instructions are provided in the message. If the problem is your Internet connection, you might need to configure an HTTP Proxy. Refer to Unable to Connect due to Proxy Settings below.
5. To save a backup of the serial key in text format on a local drive, click Backup and Print Registration Data. This information is useful if you change computers and need to install the software on the new computer.
6. In the Backup Registration Location dialog box, browse for the folder in which you want to save the backup, then click OK.
7. Click Finish.
Troubleshooting Product Activation

If activation fails, try the following resolutions:

Invalid Serial Number - The serial number must be entered exactly as it appears on your invoice or label. It is not case sensitive. If you received a digital invoice, avoid typing errors by copying the serial number to the Windows clipboard and then paste it (CTRL+V) into the serial number box in the registration wizard.

Serial Number Entered for the Wrong Product type - Serial numbers are specific to a particular product. Double-check your invoice to see which product and version you purchased. Compare that to the product name and version shown in the About dialog box or on the splash screen. If they do not match, then download the correct product from the Globalscape website. If you have accidentally purchased the wrong product, then contact the Globalscape support team.

Registration Unable to Complete due to a temporary Network Problem - Because activation takes place over the Internet, CuteFTP must be able to connect to our registration server to complete the activation process. Try again after the network problem is resolved or refer to the paragraph below regarding activating CuteFTP on a computer that does not have Internet access.

If you do not have Internet access on the computer on which CuteFTP is installed, follow the activation instructions above, but when connection to the registration server fails, click Email, then click Next. This will copy the necessary information to the Windows Clipboard. You can then paste the information into a text document and, on a computer that has Internet access, go to http://www.globalscape.com/register/, paste the contents of the text file, then click Register Me. You will receive a .REG file. On the computer on which CuteFTP is installed, close CuteFTP, double-click the .REG file to merge the registration information to the Windows registry, then restart CuteFTP.

Unable to Connect due to Proxy Settings - In the Registration Failed dialog box, click HTTP Proxy to modify your proxy settings (IP address and port) so that CuteFTP can perform HTTP (Web) transactions. If you do not have the proxy information, ask your system administrator or Internet Service Provider for assistance. (Globalscape does not have this information.)

Lost Serial Number - If you cannot locate your serial number, you can obtain a copy from Globalscape Support. If you still have the original email address used to purchase the software, on the main menu, click Help > Locate a lost serial. If you no longer have access to that email account or do not recall which email address you used, contact customer service department and provide your name, address, order ID or any other pertinent data that might help us locate your original purchase record.

Backing Up Registration Information

CuteFTP can back up your CuteFTP data and save the backup file in any directory you specify. It is a good idea to back up this data in case you need to restore your setup. This is not the same thing as exporting your Site Manager data. Exporting your Sites only exports the information necessary to recreate them in Site Manager. When you back up your CuteFTP data, the following information is saved:

- Instructions for restoring your registration (using key.reg)
- Instructions for restoring your Site Manager configuration (using sm.dat)
- Your registration number (This same information is saved in the backup file serial.txt.)

To back up your CuteFTP data

1. On the main menu, click Help > Backup Personal & Registration Data.
2. Specify the location to save your backup data. CuteFTP creates backup files in the location you specify.
3. You are prompted to print out your registration information. If you click Yes, the text file appears and attempts to print on your default printer.
The location in which CuteFTP’s data files are stored depends on your version of Windows:

- Windows XP: `C:\Documents and Settings\USERNAME\Application Data\Globalscape\CuteFTP\<VERSION>\SM.DAT`
- Windows Vista: `C:\ProgramData\Globalscape\CuteFTP\<VERSION>\SM.DAT`
- Windows 7: `C:\Users\USERNAME\Application Data\Roaming\Globalscape\CuteFTP\<VERSION>\SM.DAT`
- Windows 2008: `C:\Users\Administrator\AppData\Roaming\Globalscape\CuteFTP\<VERSION>\SM.DAT`

If you can’t see the `SM.DAT` file, you may need to show hidden files and folders:

1. Open Windows Explorer.
2. In Windows 7, click **Organize > Folder and search options**; in Windows XP, click **Tools > Folder Options**.
3. Click the **View** tab, then select **Show hidden files and folders**.

**Upgrading CuteFTP**

You can upgrade to version 9 from CuteFTP Pro, Home, or Lite v8.3.4. The Sites defined in the **Site Manager** and the settings in **Global Options** are migrated to the new version when you upgrade. To be safe, you should **Back Up Site Configurations** before doing any upgrade.

**Upgrade considerations:**

- If a password for an existing SFTP key contains any Extended ASCII characters, after upgrading to CuteFTP 9, the password will no longer work. You will have to reenter the password. (This is because of changes to CuteFTP version 9 to support UTF-8.)
- Refer to globalscape.com **support** pages for licensing considerations and costs, and any last-minute upgrade considerations.

**Moving CuteFTP to a Different Computer**

You have two options for moving CuteFTP to a new computer:

**OPTION 1** (If the old computer is no longer running or available to you, or if you do not need the existing **Site Manager** data):

1. Download the software from this page: [http://www.globalscape.com/support/reg.asp](http://www.globalscape.com/support/reg.asp)
2. Install CuteFTP on the new computer and activate it using your existing serial number.

**OPTION 2** (If the old computer is still available to you and you need access to the existing **Site Manager** data):

1. On the old computer:
   a. Launch CuteFTP. If you do not already have your serial number available, on the main menu, click **Help > About CuteFTP**. Record your serial number so that you can use it on the new computer.
   b. On the main menu, click **Help > Backup registration & personal data**. The **Backup Registration Location** dialog box appears.
   c. Click **Browse**. Select a drive with portable media (e.g., a USB drive) or network location in which to save the data, then click **OK**. A backup successful message appears when completed.
   d. If you are transferring the license to the new computer, remove the software from the old computer using **Windows Add or Remove Programs**.
2. **On the new computer:**
   a. Download the software from this page: http://www.globalscape.com/support/reg.asp
   b. Install CuteFTP on the new computer and activate it with the serial number that you recorded in step 1 in the previous procedure.
   c. Insert the media on which your backup was saved or make sure you have access to the network location in step 2 in the previous procedure.
   d. Launch CuteFTP.
   e. On the main menu, click Tools > Site Manager > Import FTP Sites, and follow the instructions. For detailed instructions about how to import your Site Manager data, refer to Importing FTP Sites.

The Sites in the Site Manager are stored in a file called **sm.dat**. The location in which sm.dat is stored depends on your version of Windows.

- **Windows XP:** `C:\Documents and Settings\USERNAME\Application Data\Globalscape\CuteFTP\VERSION\SM.DAT`
- **Windows Vista:** `C:\ProgramData\Globalscape\CuteFTP\VERSION\`
- **Windows 7:** `C:\Users\USERNAME\Application Data\Roaming\Globalscape\CuteFTP\VERSION\SM.DAT`

If you can't see the **SM.DAT** file, you may need to show hidden files and folders:

1. Open Windows Explorer.
2. In Windows 7, click **Organize > Folder and search options**; in Windows XP, click **Tools > Folder Options**.
3. Click the **View** tab, then select **Show hidden files and folders**.

**Quick Reference Guide**

The topics in this user guide are organized in the Contents pane by function (installing, configuring, connecting, transferring, managing, troubleshooting). Once you have become familiar with CuteFTP's interface and features, use the table below as a "cheat sheet" to find information by the task that you need to perform. (Note that the topic titles are often named for the task that you want to perform.)

<table>
<thead>
<tr>
<th>If you want to ...</th>
<th>Refer to ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Install CuteFTP</td>
<td>Installing CuteFTP</td>
</tr>
<tr>
<td>Activate/Register my copy of CuteFTP</td>
<td>Activating CuteFTP</td>
</tr>
<tr>
<td>Backup CuteFTP data and registration information</td>
<td>Backing Up CuteFTP Data</td>
</tr>
<tr>
<td>Upgrade CuteFTP</td>
<td>Upgrading CuteFTP</td>
</tr>
<tr>
<td>Move CuteFTP to a different computer</td>
<td>Moving CuteFTP to a Different Computer</td>
</tr>
<tr>
<td>Specify TE startup and exit options</td>
<td>Starting the Transfer Engine on Windows Startup</td>
</tr>
<tr>
<td>Connect to a file server</td>
<td>Adding a Site to the Site Manager</td>
</tr>
<tr>
<td>Find my server's host address</td>
<td>Site Properties - General Tab</td>
</tr>
<tr>
<td>Determine my username and password to log in to my server</td>
<td>Site Properties - General Tab</td>
</tr>
<tr>
<td>Upload files to my server</td>
<td>Transferring Files and Folders</td>
</tr>
<tr>
<td>Transfer files from my old server to my new server</td>
<td>Site-to-Site Transfers (FXP)</td>
</tr>
<tr>
<td>Change permissions on my files</td>
<td>Viewing File and Folder Properties</td>
</tr>
<tr>
<td>If you want to ...</td>
<td>Refer to ...</td>
</tr>
<tr>
<td>------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Delete my files</td>
<td>Opening, Editing, Renaming, and Deleting Files</td>
</tr>
<tr>
<td>Specify Site Manager options on start up</td>
<td>Displaying the Site Manager</td>
</tr>
<tr>
<td>Delete completed transfers from the Queue Window</td>
<td>Removing Items from the Queue</td>
</tr>
<tr>
<td>Display or hide the Site Manager</td>
<td>Displaying the Site Manager</td>
</tr>
<tr>
<td>Specify a download folder</td>
<td>Specifying a Default Download Folder</td>
</tr>
<tr>
<td>Upload files to a different server</td>
<td>Adding a Site to the Site Manager</td>
</tr>
<tr>
<td>Add CuteFTP to the Windows Explorer right-click menu</td>
<td>Adding CuteFTP to the Windows Explorer Right-Click Menu</td>
</tr>
<tr>
<td>Change log fonts and colors</td>
<td>Log File Settings</td>
</tr>
<tr>
<td>Change log location, time, and saving/removing options</td>
<td>Log File Settings</td>
</tr>
<tr>
<td>Turn off individual transfer item logging</td>
<td>Log File Settings</td>
</tr>
<tr>
<td>Allow multiple connections to the same Site</td>
<td>Multiple Concurrent Connections</td>
</tr>
<tr>
<td>Allow multiple connections from CuteFTP</td>
<td>Multiple Concurrent Connections</td>
</tr>
<tr>
<td>Stay connected to Sites when inactive</td>
<td>Staying Connected to Sites</td>
</tr>
<tr>
<td>Access SOCKS 4 and 5 settings</td>
<td>Socks 4 and 5 Connection Settings</td>
</tr>
<tr>
<td>Access proxy server settings</td>
<td>Proxy Connection Settings</td>
</tr>
<tr>
<td>Specify Site Manager, Queue Window, and Quick Connect security</td>
<td>Security Settings</td>
</tr>
<tr>
<td>Specify SSH2 (SFTP) security options</td>
<td>SSH2 (SFTP2) Security Settings</td>
</tr>
<tr>
<td>Specify SSL (FTPS, HTTPS) security options</td>
<td>SSL Security Settings</td>
</tr>
<tr>
<td>Manage, import, export, and upload OpenPGP keys</td>
<td>OpenPGP Security Settings</td>
</tr>
<tr>
<td>Specify the transfer method (ASCII/Binary) for all transfers</td>
<td>Transfer Settings</td>
</tr>
<tr>
<td>Specify the data mode (PASV, Port, EPRT, EPSV)</td>
<td>Transfer Settings</td>
</tr>
<tr>
<td>Specify Filename encoding</td>
<td>Transfer Settings</td>
</tr>
<tr>
<td>Specify multi-part transfer (COMB) setting s</td>
<td>Transfer Settings</td>
</tr>
<tr>
<td>Specify Bandwidth limit</td>
<td>Transfer Settings</td>
</tr>
<tr>
<td>Specify retry wait time</td>
<td>Transfer Settings</td>
</tr>
<tr>
<td>Specify retry at byte offset for interrupted transfers</td>
<td>Transfer Settings</td>
</tr>
<tr>
<td>Specify whether to send REST command</td>
<td>Transfer Settings</td>
</tr>
<tr>
<td>Specify receive/send buffer size</td>
<td>Transfer Settings</td>
</tr>
<tr>
<td>Improve CuteFTP performance</td>
<td>Improving CuteFTP Performance When Transferring Large Numbers of Files at Once</td>
</tr>
<tr>
<td>Open new connections for multiple transfers</td>
<td>Multiple Concurrent Connections</td>
</tr>
<tr>
<td>Disconnect, shut down, and/or log off after transfers have completed</td>
<td>Configuring Options for Completed Transfers</td>
</tr>
<tr>
<td>Specify the wait time before closing the transfer thread after transfer completes</td>
<td>Specifying Time CuteFTP Waits after a Transfer Completes</td>
</tr>
<tr>
<td>If you want to ...</td>
<td>Refer to ...</td>
</tr>
<tr>
<td>----------------------------------------------------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Execute commands on downloaded files</td>
<td>Executing Commands on Downloaded Files</td>
</tr>
<tr>
<td>Specify time stamp settings</td>
<td>Preserving the Local Time Stamp</td>
</tr>
<tr>
<td>Specify settings for overwriting files</td>
<td>Smart Overwrite Settings</td>
</tr>
<tr>
<td>Change file names during transfer</td>
<td>Rename Rules</td>
</tr>
<tr>
<td>Specify settings for file types that should always be transferred in ASCII mode</td>
<td>ASCII Transfer Settings</td>
</tr>
<tr>
<td>Specify compression settings</td>
<td>Mode Z Settings</td>
</tr>
<tr>
<td>Actions when dragging items to Queue or local pane, double-clicking items</td>
<td>Configuring Navigation Options</td>
</tr>
<tr>
<td>Display Site Manager or Local Pane when connecting/disconnecting</td>
<td>Configuring Navigation Options</td>
</tr>
<tr>
<td>Auto-refresh the remote pane after upload</td>
<td>Configuring Navigation Options</td>
</tr>
<tr>
<td>Specify CDUP setting</td>
<td>Configuring Navigation Options</td>
</tr>
<tr>
<td>Specify Remote servers' Table of Contents file settings</td>
<td>TOC File Settings</td>
</tr>
<tr>
<td>Specify settings for Symbolic Links (shortcuts)</td>
<td>Symbolic Links</td>
</tr>
<tr>
<td>Specify settings for PASV mode</td>
<td>Tolerance Settings</td>
</tr>
<tr>
<td>Specify which language to use in the interface</td>
<td>Specifying the Default Language</td>
</tr>
<tr>
<td>Specify which messages to display/hide</td>
<td>Configuring Prompts</td>
</tr>
<tr>
<td>Specify event sounds</td>
<td>Sound Options</td>
</tr>
<tr>
<td>Specify HTML editor</td>
<td>HTML Editor Settings</td>
</tr>
<tr>
<td>Specify built-in Editor settings</td>
<td>HTML Editor Settings</td>
</tr>
<tr>
<td>Specify Default template</td>
<td>Editing the Default HTML Template</td>
</tr>
<tr>
<td>Specify HTML Editor folders</td>
<td>Specifying the Folder for Storing HTML Code Snippets and Java Scripts</td>
</tr>
<tr>
<td>Specify HTML Editor tag tips</td>
<td>Specifying HTML Tags to Use for a Specific Browser</td>
</tr>
</tbody>
</table>
This page left blank for 2-sided “book” printing.
Chapter 2. The CuteFTP Interface

The topics in this section describe the CuteFTP interface.

CuteFTP’s main window is divided into four panes: **Local** pane, **Remote** pane, **Individual Session Logs** pane, and the bottom pane, which has the **Queue Window** tab and the **Log Window** tab.

- The **Local** pane has two tabs: **Local Drives** and **Site Manager**. The **Local Drives** tab displays the files available for upload on local computer and the **Site Manager** tab displays the list of your FTP Sites. The **Local** pane displays files and folders on your computer in the same manner as Windows Explorer.
  - To show and hide the **Local Drives** and **Site Manager** tabs, on the main menu, click **View > Show Panes > Local Drives and SM Pane**.

- The **Remote** pane displays the list of files available for download to your local computer, the files and folders on FTP Sites to which you are connected. The pane is blank if you are not connected to any remote Sites. You cannot hide the **Remote** pane.

- The **Individual Session Logs** pane displays the time and date of uploads, downloads, and other events that occur. The **Individual Session Logs** pane displays the FTP connection information for one remote connection.
  - To show and hide the **Individual Session Logs** pane, on the main menu, click **View > Show Panes > Individual Session Logs**. (You must be connected to a Site to show the Individual Session Logs.)

- The bottom pane has a **Queue Window** that displays the status of the uploads and downloads (file and folder transfers) and the **Log Window** that displays the FTP connection information for all remote Sites, number of Sites you are connected to, and other details of the session, such as the time, date, and so on.
  - To show and hide the **Queue & Log** pane, on the main menu, click **View > Show Panes > Queue & Log Pane**.
Classic View

The Classic view is also a four-pane view with a Log Pane displayed above the Local Drives and Remote panes and the Queue Pane at the bottom. This is the view found in earlier versions of CuteFTP.

To use the classic view

- On the main menu, click View > Switch to Classic Interface or press F6.
# Main Menu

The table below describes the options available on CuteFTP’s main menu and includes links to relevant procedures. For a list of keyboard shortcuts, refer to [Keyboard Shortcuts](#). For a description of the toolbar icons, refer to [The Standard Toolbar and HTML Editor Toolbar](#).

<table>
<thead>
<tr>
<th>Menu</th>
<th>Sub Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td></td>
<td>Opens the Site Properties dialog box in which you can <a href="#">define a new Site</a>.</td>
</tr>
<tr>
<td>Open File</td>
<td></td>
<td>Opens a file on your computer.</td>
</tr>
<tr>
<td>Connect</td>
<td></td>
<td>Connects to Site selected in the Site Manager</td>
</tr>
<tr>
<td>Disconnect</td>
<td></td>
<td>Disconnect from a connected Site</td>
</tr>
<tr>
<td>Upload</td>
<td></td>
<td>Available only when connected to a Site and a file or folder is selected in the Local Drives pane.</td>
</tr>
<tr>
<td>Upload Manually</td>
<td></td>
<td>Available only when connected to a Site and the Local Drives pane is selected; opens the File to upload dialog box.</td>
</tr>
<tr>
<td>Download</td>
<td></td>
<td>Available only when connected to a Site and a file or folder is selected in the remote pane.</td>
</tr>
<tr>
<td>Download Advanced</td>
<td></td>
<td>Available only when connected to a Site and the remote pane is selected; opens the File to download dialog box. Refer to <a href="#">Multi-Part (Accelerated) Transfers, Site-to-Site Transfers (FXP), Transferring Manually, Uploading and Downloading Files Using OpenPGP Keys</a>.</td>
</tr>
<tr>
<td>Transfer Type</td>
<td></td>
<td>Toggle to specify default transfer type (Auto, ASCII, Binary)</td>
</tr>
<tr>
<td>Edit</td>
<td></td>
<td>Edit selected file (also creates a line break when using the HTML editor’s Find/Replace utility)</td>
</tr>
<tr>
<td>View</td>
<td></td>
<td>Opens selected file for editing</td>
</tr>
<tr>
<td>Open</td>
<td></td>
<td>Executes selected file</td>
</tr>
<tr>
<td>Rename</td>
<td></td>
<td>Allows selected file or folder name to be edited</td>
</tr>
<tr>
<td>Delete</td>
<td></td>
<td>Deletes selected file or folder (if you have the proper permission)</td>
</tr>
<tr>
<td>Properties</td>
<td></td>
<td>Open selected folder properties, file properties, or Site Properties</td>
</tr>
<tr>
<td>Site list</td>
<td></td>
<td>Lists Sites defined in the Site Manager; click a Site to connect to it</td>
</tr>
<tr>
<td>Exit</td>
<td></td>
<td>Closes CuteFTP interface</td>
</tr>
<tr>
<td>Undo</td>
<td></td>
<td>Undoes the last editing change when in the HTML editor</td>
</tr>
<tr>
<td>Cut</td>
<td></td>
<td>Removes the selected object/text and places it on the Clipboard</td>
</tr>
<tr>
<td>Copy</td>
<td></td>
<td>Copies the object/text to the Clipboard</td>
</tr>
<tr>
<td>Paste</td>
<td></td>
<td>Pastes an object/text from the Clipboard to the insertion point/folder</td>
</tr>
<tr>
<td>Copy to Folder</td>
<td></td>
<td>Opens the Copy to folder dialog box in which you type or paste a folder path into which you want to copy the selected item. The original remains in its current location.</td>
</tr>
<tr>
<td>Move to Folder</td>
<td></td>
<td>Opens the Move to folder dialog box in which you type or paste a folder path into which you want to move the selected item. The original is moved from its current location.</td>
</tr>
<tr>
<td>Group Select</td>
<td></td>
<td>Opens the Select group dialog box in which you define a &quot;mask&quot; to select files-folders to move/copy/transfer. For example, type *.log to select all LOG files in a folder.</td>
</tr>
<tr>
<td>Group Deselect</td>
<td></td>
<td>When multiple files are selected, opens the Deselect group dialog box in which you define a &quot;mask&quot; to unselect files-folders.</td>
</tr>
</tbody>
</table>
## Menu Sub Menu Description

### Invert Selection
When multiple files are selected, clears the selection of files and selects all other files in the folder. For example, if all LOG files are selected, when you click **Invert Selection**, everything EXCEPT the LOG files will be selected.

### Select All
Selects all files/folders in a folder

### Find
Opens the **Search Results** dialog box in which you can search for files or folders in the Local drives or the Remote pane based on name, file extension, file size, and a date modified range.

### Toolbars
Displays or hides the **Standard toolbar**, **Quick Connect toolbar**, **Custom Commands toolbar**, **HTML Editor toolbar**, and **Status bar**

### Show panes
Displays or hides the **Local Drives** and **Site Manager (SM)** pane, **Queue** and **Log pane**, and **Individual Session Logs**

### Switch to Classic/Modern Interface
Toggle between **default (Modern) interface** and "Classic" interface used in earlier version of CuteFTP.

### View
Specifies whether to display **Large** or **Small** icons and how to display file lists (**List, Details, Thumbnails**). Refer to **Changing How Files and Folders are Displayed**.

### Arrange Icons
Specifies whether to sort the file list by Name, Size, Type, Modified date, Attributes, Description, Owner, Ascending, or Descending. You can also sort and choose which columns to display by right-clicking in the column header. (Attributes, Description, and Owner columns are available only in the remote pane.)

### Choose Columns
Specifies whether to display the Name, Size, Type, Modified date, Attributes, Description, Owner, Ascending, and/or Descending columns. You can also sort and choose which columns to display by right-clicking the column header. (Attributes, Description, and Owner columns are available only in the remote pane.)

### Filter
Opens the **Filter** dialog box in which you can filter the display of files.

### Go to
Allows you to move within the file list Up One Level, to Personal Folder (Local Drives pane only), Desktop (Local Drives pane only), or Change to a different folder (Remote pane only). The Personal Folder is your Documents folder, e.g., C:\Users\<username>\Documents.

### Stop
Stops an in-progress transfer

### Refresh
Reloads the file list

### Queue
Provides **transfer queue options** to add/remove files from the queue, transfer all file or only selected files, schedule selected files for transfer, change the order to transfer files in the queue, save a queue for later transfer, load a saved queue, specify multi-part values, and show log details.

### Site Manager
Display or hide the **Site Manager**, add/remove/change Site Manager, password, import/export Site Manager details, find a Site in the Site Manager, add a current connection to the Site Manager, and save a local or remote path as the default path.

### Bookmarks
**Bookmark** the current folder or select a bookmark

### Folder Tools
Available only when connected to a Site; compare folder contents, synchronize folders, backup local to remote, backup remote folders, monitor local folders for changes.

### HTML Editor
Opens a blank HTML file in the default HTML editor in which you can create a new HTML file.
<table>
<thead>
<tr>
<th>Menu</th>
<th>Sub Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compression</td>
<td></td>
<td>Compress and upload a selected file as ZIP, CAB, or GZIP/TAR, or decompress a selected file.</td>
</tr>
<tr>
<td>OpenPGP Mode</td>
<td></td>
<td>Enables or disables OpenPGP mode. If no key is defined, you are asked to create one.</td>
</tr>
<tr>
<td>Lockstep Navigation</td>
<td></td>
<td>Enables or disables lockstep folder navigation.</td>
</tr>
<tr>
<td>Macros &amp; Scripting</td>
<td>Custom Commands</td>
<td>Options to create, run, and manage macros and scripts for transferring files.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Option to create, edit, or run custom commands. As you create commands, they are displayed in the Tools &gt; Custom Commands list.</td>
</tr>
<tr>
<td>View in Browser</td>
<td>Document Data</td>
<td>(Available when HTML file is selected) Opens the file in a the default browser.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Opens the Document Data dialog box, which displays the size of the file and how long a transfer would take at various baud rates.</td>
</tr>
<tr>
<td></td>
<td>Color to HEX</td>
<td>Opens the color dialog box to convert a selected color to the browser safe color HEX code, and insert the code into the HTML document.</td>
</tr>
<tr>
<td>Java scripts</td>
<td>Code snippets</td>
<td>All Java Scripts opens the Java scripts dialog box in which you can edit, delete, rename, or insert a Java script. Save clipboard to Java script opens the Save java script dialog box in which you provide a name for and save Java script code selected in an HTML document.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>All Code Snippets opens the Code snippets dialog box in which you can edit, delete, rename, or insert a code snippet. Save clipboard as snippet opens the Save code snippet dialog box in which you provide a name for and save code selected in an HTML document.</td>
</tr>
<tr>
<td></td>
<td>Insert tag</td>
<td>Insert HTML tag. Select text to apply the tag to that text. Bold, Italic, Underline, Anchor, Image, Font, Comment.</td>
</tr>
<tr>
<td></td>
<td>Enter FTP Command</td>
<td>Opens the Input FTP Command dialog box in which you can type or select and execute an FTP command. Previously entered commands appear in a selectable drop-down list</td>
</tr>
<tr>
<td></td>
<td>Global Options</td>
<td>Opens the Global Options dialog box.</td>
</tr>
<tr>
<td></td>
<td>Cascade, Tile</td>
<td>Formats the display of windows in the remote pane when you have multiple connections.</td>
</tr>
<tr>
<td></td>
<td>Close, Close All</td>
<td>Closes the selected window or all windows.</td>
</tr>
<tr>
<td></td>
<td>Log</td>
<td>Copy or clear the session log; while connected to Site and with the cursor in the session log, choose whether to show or hide raw listings. (Disconnect and then reconnect to the Site to see the changes.)</td>
</tr>
<tr>
<td></td>
<td>Connected Site list</td>
<td>Navigate between multiple connected Sites by clicking a Site in the list.</td>
</tr>
<tr>
<td></td>
<td>Help Contents</td>
<td>Opens the help file</td>
</tr>
<tr>
<td></td>
<td>Tip of the Day</td>
<td>Opens the Tip of the Day to a random tip</td>
</tr>
<tr>
<td></td>
<td>Request Technical Assistance</td>
<td>Opens http://www_globalscape.com/support/</td>
</tr>
<tr>
<td></td>
<td>Visit the Online Knowledge Base</td>
<td>Opens <a href="http://kbglobalscape.com/Default.aspx">http://kbglobalscape.com/Default.aspx</a></td>
</tr>
<tr>
<td></td>
<td>Visit Online Support</td>
<td>Opens http://www_globalscape.com/support/</td>
</tr>
<tr>
<td>Menu</td>
<td>Sub Menu</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Purchase Now</td>
<td></td>
<td>Opens <a href="http://www.globalscape.com/store/">http://www.globalscape.com/store/</a></td>
</tr>
<tr>
<td>Locate a Lost Serial Number</td>
<td></td>
<td>Opens <a href="http://www.globalscape.com/support/lostserial.aspx">http://www.globalscape.com/support/lostserial.aspx</a></td>
</tr>
<tr>
<td>Enter a Serial Number</td>
<td></td>
<td>Opens the CuteFTP Registration Wizard</td>
</tr>
<tr>
<td>Backup Personal &amp; Registration Data</td>
<td>After you have purchased and registered CuteFTP, you can back up the registration information in case you need to reinstall/reregister.</td>
<td></td>
</tr>
<tr>
<td>About CuteFTP</td>
<td></td>
<td>Displays the CuteFTP version number and copyright information</td>
</tr>
</tbody>
</table>

### Displaying or Hiding Toolbars

CuteFTP includes the following toolbars:

- **Standard Toolbar**
- **Quick Connect Toolbar**
- **Custom Commands Toolbar** (Available only when Custom Commands are defined.)
- **HTML Editor Toolbar**
- **Status Toolbar**

You can also choose to display large or small toolbar icons.

#### To toggle between large and small icons

- Right-click on the toolbar, then click **Show large icons**. A check mark indicates that large icons are displayed.

#### To hide/show a toolbar

- On the menu, click **View > Toolbars**, then click the toolbar you want to hide or display. A check mark indicates that the toolbar is visible.

### The Standard Toolbar

The Standard toolbar is displayed by default. To hide or display the Standard toolbar, on the main menu click **View > Toolbars > Standard Toolbar**. The toolbar provides icons for the following functions:

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site Manager</td>
<td><img src="image" alt="Site Manager" /></td>
<td>Opens the Site Manager.</td>
</tr>
<tr>
<td>Connection Wizard</td>
<td><img src="image" alt="Connection Wizard" /></td>
<td>Opens the Connection Wizard.</td>
</tr>
<tr>
<td>New</td>
<td><img src="image" alt="New" /></td>
<td>Opens the Site Properties for dialog box. Click the down arrow to create a new Site, new macro/script, or HTML file.</td>
</tr>
<tr>
<td>Connect</td>
<td><img src="image" alt="Connect" /></td>
<td>Connects you to the FTP Site.</td>
</tr>
<tr>
<td>Quick Connect</td>
<td><img src="image" alt="Quick Connect" /></td>
<td>Displays or hides the Quick Connect toolbar.</td>
</tr>
<tr>
<td>Disconnect</td>
<td><img src="image" alt="Disconnect" /></td>
<td>Disconnects from the Site.</td>
</tr>
<tr>
<td>Reconnect</td>
<td><img src="image" alt="Reconnect" /></td>
<td>Reconnects to the Site.</td>
</tr>
</tbody>
</table>
The CuteFTP Interface

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connect to URL</td>
<td></td>
<td>Opens the <strong>Connect to URL</strong> dialog box in which you can specify the address to which you want to connect (e.g., <a href="http://www.myremotesite.com">http://www.myremotesite.com</a>).</td>
</tr>
<tr>
<td>Refresh</td>
<td></td>
<td>Refreshes the log pane or folder list.</td>
</tr>
<tr>
<td>Stop Transfer</td>
<td></td>
<td>Stops a transfer in progress.</td>
</tr>
<tr>
<td>Download</td>
<td></td>
<td>Downloads selected files from the remote computer to your local computer. Click the down arrow and click <strong>HIGH</strong> to split the file into two parts or <strong>MAX</strong> to divide the file into more parts.</td>
</tr>
<tr>
<td>Upload</td>
<td></td>
<td>Uploads selected files from your local computer to the remote computer. Click the down arrow and click <strong>HIGH</strong> to split the file into two parts or <strong>MAX</strong> to divide the file into more parts.</td>
</tr>
<tr>
<td>Edit</td>
<td></td>
<td>Opens a selected HTML file in the default HTML editor or the built-in HTML editor.</td>
</tr>
<tr>
<td>Rename</td>
<td></td>
<td>Allows you to rename a selected file.</td>
</tr>
<tr>
<td>New Folder</td>
<td></td>
<td>Creates a new folder on the local computer and the remote computer.</td>
</tr>
<tr>
<td>Open</td>
<td></td>
<td>Opens a selected file.</td>
</tr>
<tr>
<td>Delete</td>
<td></td>
<td>Deletes a selected file.</td>
</tr>
<tr>
<td>Properties</td>
<td></td>
<td>Displays the properties of a selected file.</td>
</tr>
<tr>
<td>Global Options</td>
<td></td>
<td>Opens the <strong>Global Options</strong> dialog box.</td>
</tr>
<tr>
<td>OpenPGP Mode</td>
<td></td>
<td>Opens the <strong>OpenPGP Mode Settings</strong> dialog box to select a key or allows you to create a key.</td>
</tr>
</tbody>
</table>

**HTML Editor Toolbar**

When a document is open in CuteFTP's built-in HTML Editor (click **Tools > HTML Editor** or press **CTRL+H**), the following HTML Editor toolbar icons are available.

ℹ️ To close the HTML Editor, right-click within the editor, click **File**, then click **Close**.

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>New HTML document</td>
<td></td>
<td>Opens a new HTML document in the editor</td>
</tr>
<tr>
<td>Save</td>
<td></td>
<td>Save the document as web page (htm or html)</td>
</tr>
<tr>
<td>Undo</td>
<td></td>
<td>Click this to undo an action</td>
</tr>
<tr>
<td>Redo</td>
<td></td>
<td>Click this redo an action</td>
</tr>
<tr>
<td>Find/Replace</td>
<td></td>
<td>Finds and replaces the words in an HTML document</td>
</tr>
<tr>
<td>View in Browser</td>
<td></td>
<td>Opens the document in your default Web browser</td>
</tr>
<tr>
<td>Bold</td>
<td></td>
<td>Formats text as bold</td>
</tr>
<tr>
<td>Italics</td>
<td></td>
<td>Formats text as italicized</td>
</tr>
<tr>
<td>Name</td>
<td>Icon</td>
<td>Function</td>
</tr>
<tr>
<td>-----------------</td>
<td>------</td>
<td>---------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Underline</td>
<td>🟡</td>
<td>Formats text as underlined</td>
</tr>
<tr>
<td>Insert Anchor</td>
<td>🌋</td>
<td>Opens the Anchor Tag dialog box in which you can assign hyperlinks to a specific location in a topic. (Similar to a bookmark.)</td>
</tr>
<tr>
<td>Insert Image</td>
<td>📸</td>
<td>Opens the Image tag dialog box in which you can browse to a folder and specify an image to insert in an HTML document</td>
</tr>
<tr>
<td>Set Font</td>
<td>🍃</td>
<td>Opens the Font tag dialog box in which you can specify the font face, color, and size for text</td>
</tr>
<tr>
<td>Insert Comment</td>
<td>🔒</td>
<td>Inserts the opening and closing comment tags. Type the desired comment between the tags. The comment does not appear when the page is viewed in a browser.</td>
</tr>
<tr>
<td>Insert Table</td>
<td>📋</td>
<td>Inserts the HTML table tags for the specified number of rows and columns, into which you can type your text</td>
</tr>
</tbody>
</table>

To show/hide the toolbar, refer to Displaying and Hiding the Toolbar.

### Status Bar

The **Status Bar** appears at the bottom of the CuteFTP interface. When you place the cursor over a tool or menu item, the left side of the **Status Bar** displays a brief description/tool tip of the item. The right side of the **Status Bar** displays information about the folder selected in the Remote pane.

#### To show/hide the Status Bar

- On the main menu, click **View > Toolbars > Status Bar** (or press ALT+3).

### Keyboard Shortcuts

If you are more comfortable using the keyboard than the mouse, numerous keyboard shortcuts are available in CuteFTP.

In the table below (and elsewhere in this user guide), “ALT+” indicates that you are to press and hold the ALT key on your keyboard while simultaneously pressing one or more other keys. “CTRL+” indicates that you are to press and hold the CTRL (Control) key on your keyboard while simultaneously pressing another key. For example, “CTRL+SHIFT+D” indicates that you are to press and hold the Control Key and the Shift key, while simultaneously pressing the D key (to move items down the list in the queue). These key combinations are used instead of using the mouse to click in the interface. For example, press **ALT+F** to activate the **File** menu; press **CTRL+C** to copy selected text.

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Backspace</td>
<td>Move to parent folder</td>
</tr>
<tr>
<td>Number Pad +</td>
<td>Group select</td>
</tr>
<tr>
<td>Number Pad -</td>
<td>Group deselect</td>
</tr>
<tr>
<td>Number Pad *</td>
<td>Invert selection</td>
</tr>
<tr>
<td>Tab</td>
<td>Moves focus between tabs (documents) in the active pane group</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete selected object</td>
</tr>
<tr>
<td>Esc</td>
<td>Cancel transfer</td>
</tr>
<tr>
<td>F1</td>
<td>Help</td>
</tr>
<tr>
<td>F2</td>
<td>Rename</td>
</tr>
<tr>
<td>F3</td>
<td>Find next</td>
</tr>
<tr>
<td>Key</td>
<td>Function</td>
</tr>
<tr>
<td>-----------</td>
<td>---------------------------------------------------------------------------</td>
</tr>
<tr>
<td>F4</td>
<td>Switch between Site Manager and Local Drives tabs</td>
</tr>
<tr>
<td>F5</td>
<td>Refresh active pane</td>
</tr>
<tr>
<td>F8</td>
<td>Display folder information</td>
</tr>
<tr>
<td>F9</td>
<td>Cancel transfer</td>
</tr>
<tr>
<td>F10</td>
<td>Switch between <strong>Log</strong> pane and <strong>Queue</strong> pane</td>
</tr>
<tr>
<td>F11</td>
<td>Folder comparison options</td>
</tr>
<tr>
<td>F12</td>
<td>Hide or display individual log window</td>
</tr>
<tr>
<td>Alt+Enter</td>
<td>Folder, file, or Site properties</td>
</tr>
<tr>
<td>Alt+Up Arrow</td>
<td>Move to parent folder</td>
</tr>
<tr>
<td>Alt+Down Arrow</td>
<td>Select drop-down arrow for active pane</td>
</tr>
<tr>
<td>Alt+Right Arrow</td>
<td>Show bookmark drop-down for remote pane</td>
</tr>
<tr>
<td>Alt+Left Arrow</td>
<td>Show bookmark drop-down for local pane</td>
</tr>
<tr>
<td>Alt+F7</td>
<td>Display <strong>Global Options</strong> dialog box</td>
</tr>
<tr>
<td>Alt+0</td>
<td>Toggle show <strong>Site Manager</strong> /<strong>Local Pane</strong> view</td>
</tr>
<tr>
<td>Alt+1</td>
<td>Toggle show <strong>Queue</strong> /<strong>Log</strong> Pane</td>
</tr>
<tr>
<td>Alt+2</td>
<td>Hide or display individual log window (same as F12)</td>
</tr>
<tr>
<td>Alt+3</td>
<td>Toggle show status bar</td>
</tr>
<tr>
<td>Alt+Q</td>
<td>Exit</td>
</tr>
<tr>
<td>CTRL+A</td>
<td>Select All</td>
</tr>
<tr>
<td>CTRL+B</td>
<td>Bold Font (when in HTML editor), Browse offline (when a Site is selected in Site Manager pane)</td>
</tr>
<tr>
<td>CTRL+C</td>
<td>Copy</td>
</tr>
<tr>
<td>CTRL+D</td>
<td>Change remote folder</td>
</tr>
<tr>
<td>CTRL+E</td>
<td>Execute selected file</td>
</tr>
<tr>
<td>CTRL+F</td>
<td>Find</td>
</tr>
<tr>
<td>CTRL+H</td>
<td>Launch internal HTML editor</td>
</tr>
<tr>
<td>CTRL+I</td>
<td>Italic Font (when in HTML editor mode)</td>
</tr>
<tr>
<td>CTRL+J</td>
<td>Launch Connection wizard</td>
</tr>
<tr>
<td>CTRL+L</td>
<td>Filter</td>
</tr>
<tr>
<td>CTRL+M</td>
<td>Make new folder</td>
</tr>
<tr>
<td>CTRL+N</td>
<td>Opens the <strong>Site Properties</strong> dialog box in which you can define a new Site.</td>
</tr>
<tr>
<td>CTRL+O</td>
<td>Opens file on your computer.</td>
</tr>
<tr>
<td>CTRL+P</td>
<td>Print (when in HTML editor mode)</td>
</tr>
<tr>
<td>CTRL+Q</td>
<td>Add current path as new bookmark</td>
</tr>
<tr>
<td><strong>Key</strong></td>
<td><strong>Function</strong></td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>CTRL+R</td>
<td>Reconnect to last connected Site</td>
</tr>
<tr>
<td>CTRL+T</td>
<td>Connects to Site selected in the Site Manager</td>
</tr>
<tr>
<td>CTRL+S</td>
<td>Save open document (HTML editor mode)</td>
</tr>
<tr>
<td>CTRL+U</td>
<td>Connect to URL or underline when HTML editor is active.</td>
</tr>
<tr>
<td>CTRL+V</td>
<td>Paste</td>
</tr>
<tr>
<td>CTRL+W</td>
<td>Opens selected file for editing</td>
</tr>
<tr>
<td>CTRL+X</td>
<td>Cut</td>
</tr>
<tr>
<td>CTRL+Y</td>
<td>Redo (When in HTML editor mode)</td>
</tr>
<tr>
<td>CTRL+Z</td>
<td>Undo (When in HTML editor mode)</td>
</tr>
<tr>
<td>CTRL+F4</td>
<td>Close active pane</td>
</tr>
<tr>
<td>CTRL+F8</td>
<td>Open/close the Quick Connect toolbar</td>
</tr>
<tr>
<td>CTRL+F9</td>
<td>Folder Monitor Tool</td>
</tr>
<tr>
<td>CTRL+F10</td>
<td>Folder Backup Tool</td>
</tr>
<tr>
<td>CTRL+F11</td>
<td>Folder Synchronize Tool</td>
</tr>
<tr>
<td>CTRL+~ (tilde)</td>
<td>Move focus between left, right and bottom panes</td>
</tr>
<tr>
<td>CTRL+PAGE DOWN</td>
<td>Download</td>
</tr>
<tr>
<td>CTRL+PAGE UP</td>
<td>Upload</td>
</tr>
<tr>
<td>CTRL+Tab</td>
<td>Move focus right to left among open connections and documents</td>
</tr>
<tr>
<td>CTRL+ENTER</td>
<td>Edit selected file (also creates a line-break when in the integrated editor's Find/Replace utility)</td>
</tr>
<tr>
<td>CTRL+ALT+T</td>
<td>Toggles Thumbnail view</td>
</tr>
<tr>
<td>CTRL+SHIFT+A</td>
<td>Add anchor (when in HTML editor mode)</td>
</tr>
<tr>
<td>CTRL+SHIFT+B</td>
<td>Change item queue order (place at bottom)</td>
</tr>
<tr>
<td>CTRL+SHIFT+C</td>
<td>Add comment (when in HTML editor mode)</td>
</tr>
<tr>
<td>CTRL+SHIFT+D</td>
<td>Change item queue order (move down one)</td>
</tr>
<tr>
<td>CTRL+SHIFT+I</td>
<td>Font dialog (when in HTML editor mode), Input RAW FTP command when in CuteFTP mode</td>
</tr>
<tr>
<td>CTRL+SHIFT+L</td>
<td>Clear entire log</td>
</tr>
<tr>
<td>CTRL+SHIFT+T</td>
<td>Change item queue order (move to top)</td>
</tr>
<tr>
<td>CTRL+SHIFT+U</td>
<td>Change item queue order (move up one)</td>
</tr>
<tr>
<td>SHIFT+F4</td>
<td>Disconnect</td>
</tr>
</tbody>
</table>
The Site Manager

The Site Manager stores connection information for servers that you visit often, such as the server that hosts your website or the server of a partner with whom you share files. Each server connection is called a "Site." Once a Site is defined, you only need to double-click the Site to connect to the server. Refer to Using the Connection Wizard or Adding a Site to the Site Manager for details of defining a Site. If you are connected to a Site when you choose to display the Site Manager, a confirmation prompt warns you that you will be disconnected from the Site.

To display or hide the Site Manager

- Do one of the following:
  - Press F4 to display or hide the Site Manager.
  - On the main menu, click Tools > Site Manager > Display Site Manager. A check mark indicates the Site Manager is visible. No check mark indicates that the Site Manager is hidden.

### Hiding the Site Manager also hides the Local Drives Pane.

To specify Site Manager options on start up

1. On the main menu, click Tools > Global Options (or press ALT+F7).
3. In the On startup box, specify one of the following actions:
   - Display Site Manager - Displays the Site Manager on program start
   - Do Nothing - Prevents the Site Manager from displaying on program start
   - Connect to the last connected to Site Manager Site - Connects to the Site you were connected to the last time you closed the program, so long as the Site is saved in the Site Manager.
4. Click Apply if you are going to make changes to other pages; click OK to save changes and close the Global Options dialog box.

To change Site properties or settings

1. Display the Site Manager.
2. Right-click a Site, then click Properties. The Site Properties dialog box appears.
3. Click the General, Type, Actions, or Options tab.
4. Modify the Site properties, then do one of the following:
   - Click Connect to connect to the Site.
   - Click OK to save the changes without connecting.
   - Click Cancel to abort the changes.
Local Files and Folders

Local files and folders are displayed in the Local Drives pane on the left-hand side of the CuteFTP window.

To display files and folders on the local computer
- Do one of the following:
  - Press ALT+0
  - On the main menu, click View > Show Panes > Local Drives & SM Pane (there should be a check mark next to it).

To toggle between the Local Drives and the Site Manager
- Click the Local Drives tab in the left pane to toggle between Local Drives and the Site Manager.

Folder Listing

To view a listing of local folder contents
1. Click the Local Drives tab.
2. Double-click a folder to view its contents.

To view listings in a parent folder
1. Click in the pane where you want to view the parent folder.
2. Click the Move up icon.

To update (refresh) a folder listing
1. Display the folder.
2. Click in the pane where the folder is displayed.
3. Do one of the following:
   - On the main menu, click View > Refresh.
   - Right-click, then click Refresh.
   - Press F5.
   - In the selected pane, click the Refresh icon.

Transfer Queue

The Queue Window displays items ready for transfer, in transit, or just transferred.

To display or hide queued files and folders
- On the main menu, click View > Show Panes > Queue Window (or press ALT+2).

To toggle between the Queue Window and the Log Window
- Click the Queue Window or Log Window tab.
Hiding the Queue Window also hides the Log Window.

The Queue icons are displayed next to each item in the Queue pane.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🔄</td>
<td>The item is in the queue but a transfer has not been attempted or scheduled.</td>
</tr>
<tr>
<td>🔄</td>
<td>The item is in the queue and a transfer has been scheduled, but has not yet occurred.</td>
</tr>
<tr>
<td>▶</td>
<td>This item's transfer is starting.</td>
</tr>
<tr>
<td>🗿</td>
<td>There is an existing file of the same name in the destination folder and you will have to decide whether to Overwrite the existing file, Skip the transfer, Resume an interrupted transfer, Rename the file you are transferring, or Numerate the file you are transferring.</td>
</tr>
<tr>
<td>✔</td>
<td>The item transfer is in progress; this usually appears for large transfers.</td>
</tr>
<tr>
<td>✗</td>
<td>The transfer has been interrupted, but CuteFTP is still trying to complete the transfer.</td>
</tr>
<tr>
<td>🚫</td>
<td>The item has been skipped, usually because you chose to skip it manually or in a Smart Overwrite rule that you chose previously.</td>
</tr>
<tr>
<td>✗</td>
<td>You have stopped the transfer while it was in progress. You can still Resume this transfer.</td>
</tr>
<tr>
<td>⚠️</td>
<td>The server has refused to transfer the item. The transfer log will show an ERROR: message with a more information.</td>
</tr>
</tbody>
</table>

See also Removing Items from the Queue.

Connection Log

Messages between the local computer and the server are stored in the Log.

To display the connection log

1. On the main menu, click View > Show Panes > Queue & Log Pane (or press ALT+1).

   Hiding the Queue Window also hides the Log Window.

2. Select the Log Window tab.
3. On the left side of the Log Window, click the plus sign next to the FTP address.
4. Click a session. The log for that session appears on the right side of the Log Window.

   The active session log displays as a small log underneath the Remote pane, with additional transfer session logs shown in the Log Window.

Individual Session Log

Messages between the local computer and the server appear in the Log. You can also see a log for each individual session in the Individual Session Log, just below the Remote Pane.

To display a session log for a connection

- Click View > Show Panes > Individual Session Logs.
Global Options Dialog Box

The Global Options dialog box is used to configure settings that apply to every Site and every transfer. (You can override these settings in a Site’s Properties dialog box.) Procedures for using Global Options are numerous and organized in this user guide by function. Refer to the Contents, Index, or Quick Reference Guide to jump to the procedure you are looking for.

To open the Global Options dialog box

- On the main menu, click Tools > Global Options or press ALT+F7. The Global Options dialog box opens to the page that was displayed when the dialog box was closed.

The General node is used to configure various startup and exit events, download defaults, shell integration, and log settings.

For details of the options on the General node, refer to the following topics:

- Starting the Transfer Engine on Windows Startup
- Displaying the Site Manager
- Specifying a Default Download Folder
- Uploading Files from Anywhere in Windows
- Log File Settings

The Connection node is used to configure connection-related settings such as proxy/socks, retry attempts, and PORT mode configuration.
The CuteFTP Interface

For details of the options on the Connection node, refer to the following topics:

- Improving CuteFTP Performance When Transferring Large Numbers of Files at Once
- Connection Options
- Staying Connected
- Internet Connection Settings
- Socks 4 and 5 Connection Settings
- Proxy Connection Settings

The Security node is used to configure security settings such whether to use a Site Manager password, and SSH2, SSL, and OpenPGP options.
For details of the options on the Security node, refer to the following topics:

- Security Settings
- SSL/TLS Connections (FTPS/HTTPS)
- SSH2 Connections (SFTP)
- OpenPGP Security Settings
- Unable to Connect to Titan FTP Server when Using SSL

The Transfer node is used to configure transfer options such as whether to use ASCII or Binary, data mode settings, filename encoding, rename rules, and other transfer events.
For details of the options on the Transfer node, refer to the topics in:

- Transferring Files and Folders
- Preserving the Local Time Stamp
- Specifying Time CuteFTP Waits after a Transfer Completes
- Smart Overwrite Settings
- Rename Rules
- Specifying Binary or ASCII Mode
- Accelerating Transfers with Mode Z

The Navigation node is used to configure navigation options such as event handling and how certain commands are used.

For details of the options on the Navigation node, refer to the following topics:

- Configuring Navigation Options
- Cannot See Files or Folders
- Symbolic Links
- TOC File Settings
- Tolerance Settings
- Updating or Refreshing Folder Listings

The Display node is used to configure the way windows and toolbars are displayed, which prompts to display, assign sounds to events, and specify a default language.
For details of the options on the Display node, refer to the following topics:

- Configuring Display Settings
- Configuring Prompts
- Sound Options
- Specifying the Default Language

The Helper Applications node is used to specify the applications you will use to view and edit HTML files.
For details of the options on the Helper Applications node, refer to the following topics:

- Integrated HTML Editor
- HTML Editor Settings
- Editing the Default HTML Template
- Using Colors
- Specifying the Folder for Storing HTML Code Snippets and Java Scripts
- Previewing an HTML Document in a Browser
- Specifying HTML Tags to Use for a Specific Browser

Site Properties

You can change a number of connection settings for individual Sites in the Site Manager. The changes made to Sites in the Site Manager only affect the individual Site.

Site Properties - General Tab

On the General tab of the Site Properties, you can modify the name (Label) by which the Site is displayed in the Site Manager, the host address, username, password, and login method. You can also type comments that are saved with the Site settings.

Label - Provide a descriptive name for the Site, as it will appear in the Site Manager.

Host address - Provide the address to which you will connect for this Site. The address can be a domain name, such as ftp.example.com, or an IP address, such as 192.168.125.210. If you do not know the address, your hosting provider or system administrator should be able to provide it to you. Many ISPs provide FTP configuration information on their website. For an example of what to look for, go to http://help.rr.com/hmsflags/e25_rr_ftp_setup.aspx. A similar help page should be available from the company that is hosting your website.

Username - Provide the username given to you by your hosting provider. Globalscape does not provide or maintain this information.

Password - Provide the password given to you by your hosting provider. Globalscape does not provide or maintain this information.

Comments - Provide any notes about the Site that you want to save with the Site.
Login method:

- Click **Normal** if the server requires your user name and password for a connection.
- Click **Anonymous** if the server does not require a user name and password for a connection.
- Click **Double** if you need to supply your user name and password twice for a connection.

**Connect** - Saves Site changes and connects to the Site.

**OK** - Saves changes and closes **Site Properties**.

**Cancel** - Cancels changes and closes **Site Properties**.

**Help** - Opens the online help.

**Site Properties - Actions Tab**

On the **Actions** tab of the **Site Properties**, you can specify the actions to take when you connect to and upload to the Site.

- **When client connects, switch to this remote folder** - Type the full path to any folder on the remote Site, and CuteFTP will automatically open the folder in the Remote Pane when you connect to the Site.

- **When client connects, switch to this local folder** - Type or browse to the full path for any folder on your computer, and CuteFTP will automatically open the folder in the Local Pane when you connect to the Site.

- **For navigation use the following caching options** - Caching means CuteFTP stores the Site list information on your computer, so when you navigate to different files and folders, you do not have to reconnect.
  - **Use cache during session** - Store the Site's information only until you close the connection.
  - **Always use cache** - Store the Site's information and keep it even after you disconnect.
  - **Do not use cache** - Never store the Site's information.

- **When uploading, apply this rule to files and folder names** - Use this to change file names to upper case, lower case, or to keep the case the same.
  - **Preserve case** - Keep all uploaded file names in their original case.
  - **Force lower case** - Change all uploaded file names to small letters.
• **Force upper case** - Change all uploaded file names to all capitals.

**Filter** - Click Filter to define which files will be hidden or displayed. For more information, refer to Filtering the List of Files and Folders.

### Site Properties - Type Tab

On the **Type** tab of the Site Properties, you can synchronize the **time zone**, and define the **server type**, **data connection type**, and **transfer type**. (Not available for Tapln Sites; Tapln Sites connect via HTTPS on port 443 only.)

![Site Properties for GlobalSCAPE Download Site](image)

- **Protocol type** - Specify the transfer protocol for the Site: FTP, FTP with TLS/SSL Implicit, FTP with TLS/SSL Explicit, FTP with SSL Explicit, SFTP using SSH2, HTTP, and HTTPS.

If you choose any of the SSL options, you will also be able to specify whether to use Clear Data Channel or Clear Command Channel.

- **Port** - The default port number appears when you specify the protocol type (e.g., FTP = 21). You can change the number if the server uses a different port. Contact your ISP/Web service provider for the correct port number.

- **Server type** - If you keep the default of Auto-detect, CuteFTP tries to determine the kind of server when it attempts to connect. If you have connection problems or you know the kind of server, you can click it in the list (UNIX, UNIX compatible, Windows NT, and many others).

- **Data connection type** - By default, CuteFTP uses the connection type set in Global Options > Transfer, or you can specify PORT, PASV, EPRT, or EPSV connection mode.

- **Transfer type** - Specify the transfer type set in Global Options or one of the following:
  
  - **Auto-detect**: Based on the file type, CuteFTP decides whether to transfer in ASCII or binary.
  
  - **ASCII**: Used primarily for transfer of text-based files such as HTML, text, and other documents.
  
  - **Binary**: Used primarily for data type transfers such as pictures and other graphics, or files those do not have line feeds (carriage returns).

- **Server time zone** - Specify No Offset if the server is in the same time zone as yours. If the server is in a different time zone, specify it here. These time zones do not account for Daylight Saving Time. To account for Daylight Saving Time, choose a time zone one hour ahead of the server’s time zone. For example, if you are connecting to a server in Central Daylight time, set the time zone to Eastern Standard Time.
• Select the **Automatically detect** check box to enable time zone synchronization. Time Zone synchronization helps in comparing the time of the file when it is uploaded on the remote server to the local computer time, rounding to the nearest 30 minutes. The difference in the time is the Time Zone offset. CuteFTP automatically detects the remote server time zone and synchronizes it with the local computer time zone when a file is transferred. The **Automatically detect** check box is not selected by default.

**Password Protection** - If simple FTP is selected as the protocol type, **password encryption** options appear.

**Clear Data channel** - If FTP with TLS/SSL is selected, you can select the check box for unencrypted data transfers.

**Clear Command channel** - If FTP with TLS/SSL is selected, you can select the check box to send unencrypted commands.

**Site Properties - Options Tab**

On the **Options** tab of the **Site Properties**, you can specify the number of retry attempts, delay between retries, and other options.

![Site Properties for GlobalSCAPE Download Site](image)

**Site-specific configuration options**—

• **Use global settings for all options** - the Site will use the parameters set in **Global Options**

• **Use Site-specific option** - the Site will use the parameters set on this tab.

**Apply auto-rename scheme to transfer**—Select this check box if you want the files that you transfer to be renamed according to the settings you chose in the **Global Options Rename Rules** panel. Clear this check box if you do not want files to be renamed when you make transfers with this Site.

**Use NLST instead of LIST (retrieves an abbreviated listing)**—Select this check box to get only a list of file names and no other file information from the Site. Clear this check box if you want the Site to display complete file listings, including file size, file modified date, and folder names. (Applies to FTP protocols only.)

**Use the logical parent (not physical parent) on CDUP**—Select this check box if you want to return to the previous directory when you clicked the **Up folder** icon, even if you clicked a link or shortcut in the previous directory. Clear this check box to go back to the parent directory for this folder, which might not have been the directory you were in when you jumped to the current directory.
Site-Specific Firewall settings:

- Click **Proxy** if you need to connect through a proxy server to get to this Site. A **Proxy** dialog box appears in which you can enter the proxy type, server address, username, and password.
- Click **Socks** if you need to connect through a Socks server to get to this Site. A **Socks** dialog box appears in which you can enter the SOCKS type, server address, username, and password.

**Retry attempts**—Specify the number of times you want CuteFTP to try connecting to this Site, if there is a problem making a connection.

**Delay between retries**—Specify the number of seconds you want CuteFTP to wait before retrying a connection after a connection attempt fails.

**Site max concurrent transfers**—Specify the number of connections CuteFTP can open to the Site for transferring many files simultaneously.

**Filename encoding**—Specify the filename encoding as **UTF-8** (default) or **ASCII**, or leave the default of **Auto**.

**File and Folder Properties**

Just as in Windows Explorer, you can view the properties of any file or folder by right-clicking the file, then clicking **Properties**.

**Local pane information:**

- **Type**: Kind of item (e.g., HTML document, File Folder)
- **Location**: Path where the file resides (e.g., C:\Documents and Settings\user1\My Documents; on the remote server, displays the directory)
- **Opens with**: Indicates in which application the file opens. To open ALL files of that type with a different application, click **Change**. For example, if your computer is configured to open GIF (image) files in Internet Explorer, but you want them to open in Paint Shop Pro so that you can edit them, click **Change**, scroll to or browse for `psp.exe`, then click **OK**. This change will affect ALL files on your computer that have that extension.
- **Size**: Size of the file or folder (e.g., 43.1 MB (45,281,728 bytes))
- **Contains**: For folders, displays how many files and subfolders it contains
Remote pane information:

- **Server**: The address (URL) of the server on which the file resides
- **Modified**: When the item was last modified
- **User**: Specifies the user of the item (e.g., owner)
- **Group**: Specifies the group to which the item belongs (can be blank)
- **Read/Write Permissions**: You can set the CHMOD permissions by changing the number (such as 777), or just check off the permissions in the **Owner**, **Group**, and **Public** area of the dialog box.

### About CHMOD Permissions

The CHMOD permission mask is a three-digit number.

- **First digit**: Defines the permissions for the owner (you).
- **Second digit**: Defines the permissions for the group.
- **Third digit**: Defines the permissions for everyone else (referred to as public).

Each digit works the same for each group of users: the owner, group, and public. What you set for one digit has no effect on the other two digits. Each digit is made up of the three **Read**, **Write**, and **Execute** permissions. The Read permission value is 4, the Write permission value is 2, and the Execute permission value is 1. These three numbers are added together to get the permissions for a file. If you want a file only to be readable and not writable or executable, set its permission to 4. This works the same for Write and Execute. Executable only files have a permission of 1.
For example, if you want a file to have Read and Write permissions, add the Read and Write values together (4+2) and you get 6, which is the permissions setting for Read and Write. If you want the file to have Read, Write, and Execute permissions, use the value 7 (4+2+1). Do this for each of the three permission groups and you get a valid CHMOD mask. If you want your file to have Read, Write, and Execute permissions (4+2+1) for yourself; Read and Execute (4+1) for your group; and Execute (1) only for everyone else, you would set the file permissions to 751. (Or just select the appropriate check boxes under Owner (you), Group, and Public.)

Filtering the List of Files and Folders

CuteFTP allows you to set filters that automatically include or exclude files from transfers. You define the filters in the Filter dialog box, then apply them to individual transfers, or use them on all transfers. You can also use filters during folder synchronizations. When you apply filters, you do not add or remove files, you simply set which files will be visible or invisible in CuteFTP.

To choose which files/folders to display

1. On the main menu, click View > Filter.
2. Select the Enable Filtering check box.
3. Select the following check boxes as needed:
   a. To apply the filter to folders, select the Apply filtering to folder name(s) check box.
   b. To use filters with transfers, select the Apply to file transfers check box.
   c. To make filters case sensitive, select the Case sensitive filtering check box.
   d. To use server filters, select the Enable server-side filtering check box, and type a filter from the Unix ls program.
4. Click the Filter Mask tab.
5. Type the names of files/folders you want to display, or use wildcard masks to include a group of files, then click Add.
6. Select the Filter NOT Mask tab.
7. Type the names of files/folders you want to hide, or use wildcard masks to exclude a group of files, then Add.
8. Click OK.

Below are a few of the LIST wildcards (parameters) and combinations that can be passed to the Is program running on a UNIX server:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>-l</td>
<td>Display a list of files in the current directory, and information about each file (long format)</td>
</tr>
<tr>
<td>-a</td>
<td>Display hidden files</td>
</tr>
<tr>
<td>-la</td>
<td>Display a list of files in long format and include hidden files</td>
</tr>
<tr>
<td>-l *.ext</td>
<td>Display a list of files with a specific extension (*.html, *.txt, etc.)</td>
</tr>
<tr>
<td>ls r*</td>
<td>Displays a list of files with names beginning with r (or any other letter)</td>
</tr>
<tr>
<td>-t</td>
<td>Sort display by time stamp</td>
</tr>
<tr>
<td>-R</td>
<td>Sort recursively</td>
</tr>
<tr>
<td>-lt</td>
<td>Display files in long format, sorted by time</td>
</tr>
<tr>
<td>-t *.ext</td>
<td>Displays a list of files with a specific extension (*.html, *.txt, etc.), sorted by time</td>
</tr>
</tbody>
</table>
To transfer filtered items

- After defining a filter as described above, in the Local Drives or Remote pane, click the files that remain visible, then click File > Upload Advanced, then click Upload filtered (or Download filtered if you are downloading.).

- You can configure two filter sets: one for the Local pane, and one for the Remote pane. Note that CuteFTP applies the filter parameters to all of the contents, directories, and subdirectories displayed in that pane.
- Filtering works with folder synchronizing.
- You can filter by file extensions, for example, .htm, .php, .asp, etc.

Viewing Thumbnails

If you are uploading or downloading graphic files, thumbnail view makes it convenient to preview the images right in CuteFTP so you can select the ones you want before you transfer them.

To turn on thumbnail view

1. Click in the pane (local or remote) that you want to change to thumbnail view.
2. Do one of the following:
   - On the main menu, click View > View > Thumbnails.
   - At the top of the Local or Remote pane, click the Thumbnail icon .

- You can adjust how CuteFTP handles thumbnail images in the thumbnail cache settings in Global Options. For more information, refer to the procedure in Log File Settings for configuring thumbnail cache options.

Changing How Files and Folders are Displayed

You can display files and folders with large or small icons, in a list, or with file size and date-modified details.

   Large Icons - Displays files and folders as large icons
   Small Icons - Displays files and folders as small icons
   List - Displays files in a list, but no folders, and no details
   Details - Displays files and folders in a list with the file or folder size, type, and date modified

To display files and folders as large icons

- Do one of the following:
  - Right-click in the Local or Remote pane, then click View > Large Icons.
  - On the main menu, click View > View > Large Icons.

To display files and folders as small icons

- Do one of the following:
  - Right-click in the Local or Remote pane, then click View > Small Icons.
  - On the main menu, click View > View > Small Icons.
To display files in a list, but no folders, and no details
- Do one of the following:
  - Right click in the Local or Remote pane, then click View > List.
  - On the main menu, click View > View > List.

To display files and folders in a list with the file or folder size, type, and date modified
- Do one of the following:
  - Right-click in the Local or Remote pane, then click View > Details.
  - On the main menu, click View > View > Details.

Lockstep Folder Navigation
Lockstep folder navigation allows you to navigate simultaneously through local and remote folders that have the same structure.

To turn on Lockstep Navigation
- On the main menu, click Tools > Lockstep Navigation.

The lockstep navigation function does not apply if you jump up or down several directory levels at once.

Default Language
CuteFTP’s user interface resources are independent from the main application executable and are contained in a file called Default.lng. You can modify the text and dialogs displayed in the program or localize the entire resources in order to use CuteFTP in your own language. The Global Options dialog box Language page is used to select the language file. If you have the applicable language pack installed for the operating system, CuteFTP will support the language and special characters.

To specify which language file to use
1. On the main menu, click Tools > Global Options (or press ALT+F7).
2. Expand the Display node, then click Language. The available Language Files appear. The Language File Information list displays information about the selected language file, including the language and version number.
3. In the Language File list, click a language file to use, click OK, then restart CuteFTP.
4. Click Apply if you are going to make changes to other pages; click OK to save changes and close the Global Options dialog box.

Display Settings
The display settings determine the way in which toolbars, icons, and fonts appear in dialog boxes.

To configure CuteFTP display settings
1. On the main menu, click Tools > Global Options (or press ALT+F7).
2. Expand and click the Display node. The Display options appear.
3. To specify which toolbars to display, in the Select the toolbars to display list, select the applicable check box.
4. To add or remove buttons on the toolbar, with a toolbar in the list selected, click Customize selected toolbar. (The Custom Commands and the Quick Connect toolbars cannot be customized.) The Customize Toolbar dialog box appears.
To add a button, click it in the **Available toolbar button** list, then click **Add**.

- To remove a button, click it in the **Current toolbar buttons** list, then click **Remove**.
- To move a button on the toolbar, click **Move Up** to move a button one icon to the left, click **Move Down** to move the button one icon to the right on the toolbar.
- To accept changes, click **Close**; to cancel changes, click **Reset**. (Reset only backs up changes made since the dialog box was opened. Changes are applied after you click **Close**.)

5. To display the large (32x32 pixel) set of main toolbar icons, select the **Show large toolbar icons** check box. Clear this check box to display the small (16x16 pixel) set of main toolbar icons.

6. To hide the **Quick Connect** toolbar upon connection to a Site, select the **Auto-hide Quick Connect bar** check box. Clear this to cause the **Quick Connect** toolbar to stay in view upon connection to a Site.

7. To display small icons in the menus next to commonly used menu items, select the **Display menu icons** check box.

8. To display a thin blue line at the top of the pane that has the focus, select the **Highlight active pane** check box.

9. To display borders between rows and columns in the **Queue Window**, and in the **Local** and **Remote** panes when in **Detail** view, select the **Show grid lines on all view panes** check box. Clear this check box to hide all borders between rows and columns.

10. To specify whether to show files in bytes, KB, MB, GB, in the **Display File Sizes in** box, click one of the following options:
    - **Adaptive** - CuteFTP decides when to show files in bytes, KB, MB, or GB.
    - **Kilobytes** - CuteFTP always displays values in KB.

11. To adjust the font type and size display of all text in the **Local Drives** tab, **Queue Window**, and **Remote** pane, click **Local, Remote, Queue Window Font**.

12. To sort file lists by the value of each digit or by whole number values, in the **Sorting** area, select one of the following options:
    - To sort file lists by the value of each individual digit, select **Use standard lexicographic sorting for alphanumeric file names**.
    - To sort file lists by whole number value, select **Use Smart Sorting for alphanumeric file names**.

**Smart Sorting always lists file names with smaller numbers first. For example, A2 comes before A12. David Wincelberg developed Smart Sorting. CuteFTP uses it by default. Standard Lexicographic sorting lists file names using one character at a time reading from left to right. For example, A12 comes before A2. MS Windows uses Standard Lexicographic sorting by default.**

<table>
<thead>
<tr>
<th>Smart Sorting</th>
<th>Standard sorting</th>
</tr>
</thead>
<tbody>
<tr>
<td>FileA1.ext</td>
<td>FileA1.ext</td>
</tr>
<tr>
<td>FileA2.ext</td>
<td>FileA12.ext</td>
</tr>
<tr>
<td>FileA6.ext</td>
<td>FileA2.ext</td>
</tr>
<tr>
<td>FileA9.ext</td>
<td>FileA20.ext</td>
</tr>
<tr>
<td>FileA12.ext</td>
<td>FileA21.ext</td>
</tr>
<tr>
<td>FileA20.ext</td>
<td>FileA6.ext</td>
</tr>
<tr>
<td>FileA21.ext</td>
<td>FileA9.ext</td>
</tr>
</tbody>
</table>

13. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.
Prompts
You can configure whether CuteFTP displays a confirmation message when you attempt to delete an item from local drives, remote Sites, or the queue, and displays a prompt for errors, connection progress, and other information. The Prompts page is used to configure prompts to appear for various events. All prompts on this page of Global Options are enabled by default.

To configure CuteFTP prompt settings
1. On the main menu, click Tools > Global Options (or press ALT+F7).
2. Expand the Display node, then click Prompts. The Prompts options appear.
3. To display a prompt when deleting from local drive, select the Confirm when deleting from local drive check box. Clear this check box if you do not want a confirmation prompt to appear.
4. To display a prompt when deleting from a remote folder, select the Confirm when deleting from remote drive check box. Clear this check box if you do not want a confirmation prompt to appear.
5. To display a prompt when deleting from the queue, select the Confirm when deleting from queue check box. Clear this check box if you do not want a confirmation prompt to appear.
6. To display a prompt when you try to close a window for an active connection, select the Confirm when closing a remote pane check box. Clear this check box if you do not want a confirmation prompt to appear.
7. To display a prompt upon certain server errors (5xx range), select the Show prompt upon error check box.
8. To display a prompt when the Site password is rejected or missing, select the Show login prompt if connection fails or is missing data check box.
9. To display a prompt when a task is scheduled and added to the queue, select the Show prompt when new tasks are scheduled check box.
10. To display a prompt when a scheduled task has started to run, select the Show prompt when new tasks are started check box.
11. To display a prompt when the archive was expanded successfully, select the Show prompt after successful decompression check box.
12. To display a warning when you may be transferring a certain file type in the wrong mode, select the Show warning when transferring binary files in ASCII mode check box.
13. To display a connection status message when connecting, select the Show connection progress prompts check box. If the log view is unavailable when connecting, this dialog will show you if there may be a problem with the connection.
14. To display a reminder to create a Site Manager password, select the Show Site Manager password reminder prompt check box.
15. Click Apply if you are going to make changes to other pages; click OK to save changes and close the Global Options dialog box.

Windows Explorer Right-Click Menu
You can create a submenu option in Windows Explorer that will allow you to right-click a file to upload it with CuteFTP. The submenu provides options to connect to a Site using the Connection Wizard or Sites that you have defined in Site Manager.

To add CuteFTP to the Windows Explorer right-click menu
1. On the main menu, click Tools > Global Options (or press ALT+F7).
2. Expand and click the General node. The General options appear.
3. Select the **Integrate into Windows Explorer context menu** check box. Clear the check box to remove the option from the submenu.

4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**Sound Options**

The **Sounds** page is used to assign a sound to a specific event. For example, you might want to hear a beep when there is a transfer error. You must select the **Add sounds** check box for the **Events** list to become active (i.e., so you can add sounds to events).

**To configure sound options**

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
   
   Expand the **Display** node, then click **Sounds**. The **Sounds** options appear.
   
   - The **Event** column lists possible CuteFTP events.
   - The **File** column displays the path to the associated sound.

2. To hear audio cues for certain events in CuteFTP and to edit the sounds associated with events, click **Add sounds**. Clear this check box to silence all sounds from CuteFTP and disable sound association editing.

3. If there is nothing in the **File** column, the event does not have a sound associated with it.
   
   - To add a sound to an event, click the event, then in the **File** box, browse or type the path to a sound that you want.
   
   - To remove a sound from an event, select it, and then click **None**.

   You can preview the sound by clicking the sound, then clicking the speaker icon.

4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**Log File Settings**

In the **Global Options** dialog box, you can specify where and when log files are saved, and how they are displayed.

The connection and transfer information that appear in the **Log** pane is color coded. By default, the following colors are assigned, but you can specify a different color for each log type in the **Global Options** dialog box.

- **STATUS** logs are in blue text
- **COMMAND** logs are in green text
- **ERROR** logs are in maroon text
- other information is in black text.

<table>
<thead>
<tr>
<th>STATUS</th>
<th>2/15/2008 10:56:48 AM</th>
<th>Log file is opened...</th>
</tr>
</thead>
<tbody>
<tr>
<td>STATUS</td>
<td>2/15/2008 10:56:48 AM</td>
<td>Resolving host name...</td>
</tr>
<tr>
<td>STATUS</td>
<td>2/15/2008 10:56:48 AM</td>
<td>Host name resolved...</td>
</tr>
<tr>
<td>STATUS</td>
<td>2/15/2008 10:56:48 AM</td>
<td>Connecting to FTP server...</td>
</tr>
<tr>
<td>STATUS</td>
<td>2/15/2008 10:56:48 AM</td>
<td>Socket connected, waiting for welcome message...</td>
</tr>
<tr>
<td></td>
<td>2/15/2008 10:56:48 AM</td>
<td>220 Microsoft FTP Service...</td>
</tr>
<tr>
<td></td>
<td>2/15/2008 10:56:48 AM</td>
<td>Connected, Authenticating...</td>
</tr>
<tr>
<td>COMMAND</td>
<td>2/15/2008 10:56:48 AM</td>
<td>USER...</td>
</tr>
<tr>
<td></td>
<td>2/15/2008 10:56:48 AM</td>
<td>331 Password required...</td>
</tr>
<tr>
<td>COMMAND</td>
<td>2/15/2008 10:56:48 AM</td>
<td>PASS ***...</td>
</tr>
<tr>
<td>ERROR</td>
<td>2/15/2008 10:56:48 AM</td>
<td>530 Login failed...</td>
</tr>
<tr>
<td>STATUS</td>
<td>2/15/2008 10:56:48 AM</td>
<td>Connection closed...</td>
</tr>
</tbody>
</table>
You can also change the display font type (e.g., Arial), font style (e.g., Bold), size (e.g., 10pt), and script (e.g., Western).

To edit the log display options
1. On the main menu, click **Tools > Global Options**.
2. Expand the **General** node, then click **Logs**.
   - To specify a new color for all log window status messages
     a. Click the applicable color icon. The color picker appears.
     b. Click a color, then click **OK**.
   - To change the style of text in the log windows
     a. Click **Select Font**. The **Font** dialog box appears.
     b. Specify the font type, font style, size, and script then click **OK**. A sample of the selected font appears in the **Preview** box.
3. Click **OK** to save changes and close the **Global Options** dialog box.

To configure the log file settings
1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **General** node, then click **Log Files**. The **Log Files** options appear.
3. To specify the location at which logs are saved, in the **Log path** box, click the folder icon to browse for the folder or type a different path.
4. To delete log files automatically at time intervals you specify, select the **Delete saved logs every** check box. Specify whether to delete files after a specified number of days, hours, or minutes. Clear the check box to keep all log files, or if you plan to delete them in other ways.
5. To delete error logs automatically when the Transfer Engine shuts down, select the **Delete error logs after quitting the Transfer Engine** check box. Clear the check box to keep error logs after the Transfer Engine shuts down.
6. To delete the associated logs automatically immediately after a successful task is finished, select the **Delete logs of successful transfers immediately after completion** check box. Clear the check box to keep the associated logs after a successful task is finished.
7. To include the date and time in all log files, select the **Record/Display time stamps in logs** check box. Clear the check box to exclude the date and time from all log files.

   This option consumes additional system resources due to insertion of time and date stamp at each log event. The **Record/Display time stamps in logs** check box is selected by default. Select the check box if you are copying logs to send to customer support for troubleshooting.

8. To remove all log files from your log folder that are currently not in use, click **Delete all logs**.

   Logs for active sessions are not automatically deleted.

9. To remove all remote file and folder listings CuteFTP has saved on your computer for offline browsing, click **Delete listing cache**.
10. To configure thumbnail cache options, in the **When the transfer engine exits** box, specify one of the following actions:
    - Retain images in thumbnail cache - Thumbnails stored in the cache are not deleted when you exit CuteFTP or the Transfer Engine.
Delete images in thumbnail cache - The thumbnail cache is emptied when the Transfer Engine is exited.

Delete images older than value specified - Thumbnails are stored for the time specified by the thumbnail cache expiration drop down menu.

11. To empty the thumbnail cache immediately, click **Delete thumbnail cache**.

12. To access the log display and log saving options, click **Logs**. The Log options appear. Configure options as described below.

   - To choose a new color for all log window status messages, click **STATUS**
   - To choose a new color for all log window error messages, click **ERROR**.
   - To choose a new color for all log window command messages, click **COMMAND**.
   - To choose a new display color for all other messages in log windows, click **OTHER**.
   - To change the style of text in the log windows, click **Font**. The Font dialog box appears in which you can specify a different font face (e.g., Arial, Times), style (e.g., Regular, Bold), size (e.g., 8 points, 10 points), and script (e.g., Western, Hebrew, Arabic). The Preview box displays how the font will appear in logs.
   - To save each session log as a separate text file and to display the log in the individual session log window, select the **Enable session (control connection) logs** check box. Clear this to stop recording a log for each session, and to show no logs in the individual session log window.
   - To save the log for each item transferred as a separate text file, select the **Enable individual transfer item (data connection) logs** check box. Clear this to stop recording a separate log for each item transferred.
   - To display all logs in the **Log Window** in the bottom of CuteFTP interface, select the **Enable consolidated transfer logs (both session and all transfers in Log Window)** check box. Clear this to leave the Log Window blank and to stop recording all activity in a single log file.
   - To include file lists and permissions as part of session logs and consolidated logs, select the **Record/Display raw directory listing in logs** check box. This returns a RAW list, which is used commonly for debugging. Clear this to exclude file lists and permissions from session logs and consolidated logs.
   - To show a log window in the remote pane for each Site to which you connect, select the **Show individual logs for each connection window** check box. Clear this to hide any log windows in the remote pane.

Logs can consume a large amount of system resources (memory and hard drive space), depending on the amount and size of files being transferred. It is recommended that you disable most logging (especially data connection logs) when performing a transfer that consists of many thousands of files, especially small files. To further reduce resource use, on the main menu, click **Tools > Global Options**, expand the **Transfer** node, click **Events**, then click **Remove successful transfers from the queue automatically**.

13. Click **OK** to save changes and close the **Global Options** dialog box.
Security Settings

The Security settings in the Global Options dialog box define security as it relates to the Site Manager and CuteFTP. These security settings do not affect the way in which files are transferred. For those security settings, refer to OpenPGP Security Settings, SSL/TLS Connections (FTPS/HTTPS), and SSH2 Connections (SFTP).

To edit the security settings

1. On the main menu, click Tools > Global Options (or press ALT+F7).
3. To prevent storing any Site passwords in the Site Manager file, select the Remove Site Manager passwords upon program exit check box. CuteFTP asks for the Site password for each connection attempt. Clear this check box to allow CuteFTP to store Site passwords in the Site Manager file (default behavior). When passwords are saved, you do not have to enter them again when connecting to a Site.

   Not saving passwords at all is useful in shared system environments, where CuteFTP is likely being used by multiple users on the same physical computer.

4. The default location to store the Site Manager is displayed in the Site Manager path box. To move your Site Manager to a different location on your computer or network, type or browse for a new path. The default location is:
   C:\Users\<username>\AppData\Roaming\Globalscape\CuteFTP\9.0\sm.dat

5. To secure the Site Manager, select the Encrypt contents of Site Manager check box, then click Change Password. You must supply a password every time you start CuteFTP. Clear this check box, and CuteFTP starts without requiring a password. Site Manager and all its Sites are available.

   When this option is not used (default) CuteFTP uses mild encryption with a system-generated password to protect your Site Manager's contents. It is highly recommended that you select Encrypt the contents of the Site Manager, as it protects the contents of the Site Manager with strong encryption, using a password you supply.

6. To remove passwords from queued items, select the Remove Queue file passwords upon program exit check box. Next time you start CuteFTP, you will be prompted for a password to complete the transfer. Clear this check box to allow passwords to be sent automatically for queued items.

7. To erase any URLs and remove all Sites from the Quick Connect drop-down when CuteFTP is shut down, select the Remove Quick Connect and Connect to URL history upon program exit check box. Clear this check box to keep URLs and to keep a list of Sites in the Quick Connect drop-down list even when CuteFTP is closed.

8. Click Apply if you are going to make changes to other pages; click OK to save changes and close the Global Options dialog box.
This page left blank for 2-sided “book” printing.
Chapter 3. Defining Sites

The topics below describe the various methods for connecting to sites to transfer files.

You can connect to any server defined in the CuteFTP Site Manager. If the server that you want to connect to is not yet defined, refer to Adding a Site to the Site Manager or Using the Connection Wizard. You must be connected to the Internet before you can connect to any remote server.

To connect to an existing server within the Site Manager

1. On the main menu, click Tools > Site Manager > Display Site Manager or click the Site Manager tab.
2. Click the Site to which you want to connect.
3. Do one of the following:
   - On the main menu, click File > Connect > Connect.
   - On the toolbar, click the Connect icon  
   - Double-click the selected Site.
   - Press CTRL+T.
4. If this is a server that requires an SSH2 host key, a message appears asking if you want to add the key to your trusted list. Click Yes. You will not see this message on subsequent connections unless the key has changed.
5. Transfer files as described in Transferring Files and Folders.

To disconnect from a server

- Do one of the following:
  - On the main menu, click File > Disconnect.
  - On the toolbar, click the Disconnect icon  
  - Click the X in the upper right corner.
  - Press SHIFT+F4.

To connect to a URL with the Transfer Engine

The Connect to URL feature is also supported by the Transfer Engine. Whether the URL specifies a path to a folder or file, the TE will try to download it.

1. In the Windows System Tray, right-click the Transfer Engine icon  then click Download URL.
2. Type or paste the URL in the Download URL box. See below for supported URL formats and the behavior depending on the URL pasted.

Supported URL formats

- ftp://user:pass@host.host.com:port
- ftp://user:pass@host.host.com
- ftp://user@host.host.com
- ftp://host.host.com:port
- ftp://host.host.com
Tip:
Using Paste URL, CuteFTP either connects to the folder or downloads the file specified in the path. Here are some sample path endings and how the main program interprets them.

- "ftp://host/dir.ext/" This URL is considered a folder. CuteFTP can connect to it.
- "host/.ext/" This is considered a folder. CuteFTP can connect to it.
- "host/dir/" This is considered a folder. CuteFTP can connect to it.
- "host/dir.ext" This is considered a file. CuteFTP can download it.
- "host/.ext" This is considered a file. CuteFTP can download it.

Using the Connection Wizard

To transfer files, you must log on to that server through your client computer. The Connection Wizard helps you to define a "Site" through which you can connect to an FTP server and saves the information in the Site Manager for future connections. (Refer to Adding a Site to the Site Manager for other protocol connections.)

To connect to an FTP site

1. Gather the information that you need to make a connection to an FTP site.
   - **Host Address** - the IP address or FTP domain address that your ISP gave you to log in to the FTP site (e.g., 64.243.64.21 or ftp.example.com).
   - **User Name** - the user name your ISP gave you to log in to the FTP site. Your username is often the part of your email address in front of the @ sign.
Defining Sites

- **Password** - the password your ISP gave you to log in to the FTP site. This is often the same password you use to download your email.
- **Site Name** - By default, the Site Name is the same as the Host Address, but you can name it anything you want; it is not provided by your ISP or Globalscape.

2. The **Connection Wizard** appears the first time you open CuteFTP. Otherwise, do one of the following:
   - On the main menu, click **File > Connect > Connection Wizard**.
   - On the toolbar, click the **Connection Wizard** icon.
   - Press CTRL+J.

   The **Connection Wizard** appears.

3. Do one of the following:
   - To password protect your Site Manager information, click **Password Protect My Site Manager Now**.
     - Provide your password for the Site Manager, then click **OK**.
   - Select the **Do not show this warning again** check box, then click **Next** if you choose not to password protect your Site Manager and do not want to see this warning again.

4. In the **Host Address** field, type the IP address or FTP domain address that your ISP gave you to log in to the FTP site.

5. The address that you typed in the **Host Address** field appears in the **Site Name** field. You can leave it as is, or type a descriptive name for this site. The site name will appear on the **Site Manager** tab. You can name it anything you want.

6. Click **Next**. The login page appears.

7. In the **User Name** box, type the user name your ISP gave you to log in to the FTP site.

8. In the **Password** box, type the password your ISP gave you to log in to the FTP site.

9. Specify a login method from the following options.
   - **Normal** - The user name and password are mandatory to connect to a site.
   - **Anonymous** - The site does not require any user name and password.
   - **Double** - The user name and password are required twice to connect to a site.

10. Click **Next**. The **Connecting to Site** message appears.
    - If you need to change the host address or do not want to log in, click **Cancel**.
    - If the connection fails, an error message appears. Click **Yes** to close the message, then click **Back** to verify/correct the host address, username, and password. (If the connection fails again, refer to **Troubleshooting**.)
    - If an **Accept Certificate** dialog box appears, click **Accept**.
    - If a message asking if you want to add the certificate to your trusted list, click **Yes**. (Adding the certificate to your trusted list prevents the message from appearing each time you try to connect.)

11. After you are connected to the FTP site, the default folders page appears.

12. In the **Default Local Folder** field, click the folder icon to browse for the default folder on your computer from which you want to transfer files to/from the remote server.
13. (Optional) In the Default Remote Folder field, type the path of the remote folder from/to which you want to transfer files.

14. Click Next, then click Finish. Cute FTP connects to the site and saves the site in the Site Manager.

For subsequent connections to this FTP site, refer to Connecting to a Site. Refer to Configuring Connection Options for details of how to configure the number of simultaneous connections you will allow from CuteFTP, number of times CuteFTP tries to connect to a site before giving up, how long CuteFTP should wait before attempting a new connection after a failed connection, and so on.

The Site Manager

The Site Manager stores each Site’s connection information so that you don’t have to enter it every time you want to connect to a server. You can also export and import your Site data, in case you need to install CuteFTP on a new computer or to share with other CuteFTP users. When you create a Site using the Connection Wizard, the Site is automatically added to the Site Manager. You can also save connection settings for Sites that you use often by manually adding them to the Site Manager.

To add a Site to the Site Manager

1. Do one of the following:
   - On the main menu, click File > New, then click the type of Site: TappIn Site, FTP, FTSP (SSL), SFTP, HTTP, HTTP (SSL) or a Folder with which you will organize your Sites.
   - Press CTRL+N (for an FTP Site).
   - On the toolbar, click down arrow on the New Site icon , then click the type of Site.

   The Site Properties for dialog box appears.

2. On the General tab, specify the connection information. Refer to Site Properties - General Tab for details.

3. On the Actions tab, specify the actions to occur when CuteFTP connects to the server. Refer to Site Properties - Actions Tab for details.

4. On the Type tab, specify the protocol and other connection options. Refer to Site Properties - Type Tab for details.

5. On the Options tab, specify transfer options or use global settings defined in Tools > Global Options > Transfer. Refer to Site Properties - Options Tab for details.

6. Click Connect to connect now or OK to save the Site settings and connect later. The Site information is saved in the Site Manager for future use.

Internet Connection (DUN/LAN) Settings

CuteFTP automatically detects which method you use to connect to the Internet. You must have a network connection configured on the computer on which you are using CuteFTP before it can detect the settings.

- If you connect to the Internet with a phone modem, you are using Dial-Up Networking (DUN). If you have a modem connection configured, it will detect it and allow you to use it. If you do not have a modem installed, the modem options are not available.

- If you connect to the Internet with a cable modem, DSL modem, or through a computer network, you are using a Local Area Network (LAN). If you have a LAN connection, it will detect it and allow you to use it. If you do not have a LAN connection, the LAN options are not available.
If CuteFTP does not detect your modem, search the Microsoft Window's help file (Start > Help and Support) for "Make an Internet Connection."

**To access Dial-up and Network settings**

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Connection** node, then click **DUN/LAN**. The **DUN/LAN** options appear.
3. Configure options as described below.
   - If you connect to the Internet with a cable modem, DSL modem, or through a computer network, click **Connect to the Internet using a LAN**.
   - If you connect to the Internet using a modem over regular telephone lines, click **Connect to the Internet using a modem**.
   - If you are using a dial-up connection, configure the following options:
     - In the **Use the following Dial-Up Networking connection** box, click the dial-up connection you want CuteFTP to use. The list includes every dial-up connection on the local computer that is available in Windows. Many computers list only one.
     - To display the dial-up connection user name and password whenever CuteFTP attempts a connection, select the **Show authentication window (requires user input)** check box. Clear this check box to stop the display of the dial-up connection user name and password when CuteFTP attempts a connection.
     - To display messages when an error occurs with the dial-up connection, select the **Show error prompts (requires user interaction)** check box. Clear this check box to stop the display of error messages from the dial-up connection.
     - To disconnect from the Internet automatically when CuteFTP or the Transfer Engine shuts down, select the **Disconnect from the Internet upon program exit** check box. Clear this check box to keep the Internet connection active after CuteFTP or the Transfer Engine shuts down.
     - To specify how many times CuteFTP tries to establish a dial-up connection to the Internet after a connection fails, in the **Number of times to attempt connection** box, specify from 0 to 1000 attempts.
     - To specify how long in seconds CuteFTP waits between attempts to establish a dial-up connection to the Internet, in the **Number of seconds to wait between attempts** box, specify from 0 to 1000 seconds (1000 seconds equals almost 17 minutes).
4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**Connection Options**

In the **Global Options** dialog box, you can configure the number of simultaneous connections you will allow from CuteFTP, number of times CuteFTP tries to connect to a Site before giving up, how long CuteFTP should wait before attempting a new connection after a failed connection, and so on. In most situations, the default settings will allow you to connect to your remote Sites.

**To configure connection options**

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Click the **Connection** node. The **Connection** options appear.
3. Configure options as described below.
To specify the number of simultaneous connections you will allow from CuteFTP, in the **Global max concurrent transfers** box, specify the number of connections.

- You can choose up to 200 connections, but CuteFTP will warn you that more than 20 connections may compromise system performance.
- Connections include transfers and browse sessions, and every thread in a Multi-Part transfer.

To specify the number of simultaneous connections you will allow from CuteFTP per Site, in the **Per Site max concurrent transfers** box, type or select the number of connections. (Same as **Global max** but on a per Site basis.)

If you choose to allow only one connection per Site, you must transfer files over the browse session only (you can navigate or transfer, but not both at the same time). This may be needed in situations where the server does not allow more than one connection from the same user. If the server allows more than one connection, then it is recommended that you use a value greater than one (e.g., the default of 5). That way you can transfer files and at the same time continue to navigate the Site.

To specify the number of times CuteFTP tries to connect to a Site before giving up, in the **Connection retry attempts** box, type or select the number of attempts. You can set CuteFTP to try connecting up to 1,000 times.

To specify how long CuteFTP waits before attempting a new connection after a failed connection, in the **Delay between retries in seconds** box, choose up to 1,000 seconds (about 17 minutes).

CuteFTP does not automatically retry after fatal errors, such as a host unreachable (invalid IP address or host name), or upon receiving a socket 1006n error, which usually has to do with the client not being able to connect to the host for various reasons (firewall blocking, network error, host is down, etc.).

To specify how long CuteFTP waits for an unresponsive server before it stops attempting a new connection, in the **Connection timeout in seconds** box, type or select up to 1,000 seconds (about 17 minutes).

To specify the address that you want to send to servers that require an email address for anonymous log ins, in the **Email address for anonymous logins** box, type the email address. By default, CuteFTP sends a simulated email address.

To display a pop-up window with information from the server when initial connections are successful, select the **Display the server's welcome message** check box. Clear this check box to skip the server's successful connection message.

To ask the server for a list of extended features it supports, select the **Send the FEAT command after login to determine feature support** check box. Clear this check box to stop sending the FEAT command.

**FEAT is used to determine whether extended features are supported, such as MDTM, MLST, and others. Not all servers support the FEAT command.**

To send the QUIT command from CuteFTP no matter how you choose to disconnect, select the **Send QUIT command before disconnecting** check box. Clear this check box to disconnect without sending the QUIT command.
• To use the UPnP NAT interface (available in Windows XP) to provide proper port mapping when connecting securely from behind a NAT/firewall using PORT mode (rather than PASV, due to the remote host also being behind a NAT/firewall), select the **Enable port mapping using UPnP** check box. Without UPnP, you would need to manually set the port range in CuteFTP (see the next bullet below) and also enable and forward them in the NAT/firewall device.

> You can choose **Max connections, Delay between retries, and Retry attempts** for individual Sites. In the **Site Manager**, click the **Options** tab.

• To specify an IP address and define a port range when establishing connections using PORT mode, select the **Assign PORT mode IP address and port range** check box, then specify the IP address and port range. Typically, this setting should be turned off, but if you are using SSL and are having difficulty negotiating a firewall, it may help to specify your public FTP address here to enable CuteFTP to negotiate with the firewall or NAT.

• Optionally, you can specify a range of ports for issuing port commands. CuteFTP selects ports randomly within the range defined in Global Options -> Connection -> Port range. Instead of incrementing the FTP data port, a random number within the range is chosen; if the number is already at the max number of concurrent transfers, the function recurses until it finds a valid port or runs out of options.

> Use local port range when you have a defined limited number of open ports on your firewall.

4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

### Changing the FTP Port

On the **General** tab of the **Site Properties**, you can change the connection or login information for the selected Site.

**To change a Site's connection settings or login information**

1. **Display the Site Manager**, right-click the Site, then click **Properties**.
2. Click the **Type** tab.

3. In the **Port** box, type a new port number, then click **Connect** to accept the changes and connect to the Site or **OK** to accept the changes without logging in.

### Connecting to an HTTP Site

If you have the appropriate permissions, you can connect to an HTTP Site, browse its contents, download, upload, and delete files. (For TappIn share connections, refer to [TappIn™ Site Creation](#). For WebDAV connections, refer to [Web Distributed Authoring and Versioning (WebDAV)](#).

**To connect to an HTTP Site**

1. Do one of the following:
   - On the main menu, click **File > New > HTTP Site**.
   - On the toolbar, click the arrow next to the **New Site** icon ➔, then click HTTP Site.
The **Site Properties for** dialog box appears.

2. In the **Label** box, type a descriptive name for the Site.

3. In the **Host address** box, type the address for the Site. The address can be a domain address, such as ftp.globalscape.com, or an IP address, such as 192.168.20.52. Ask your hosting provider for the address. Prefixing the HTTP Site address with http:// is not necessary.

   **If you do not provide the correct address, then every time you try to connect to that Site an error message like the one below is displayed.**

   Click **Details** to view information and log entries to determine the specific error.

4. If the Site uses basic HTTP username/password authentication, fill in your user name and password in the appropriate fields.
5. On the **Type** tab, the Site has been automatically set up as an HTTP Site.

![](image)

6. Most HTTP Sites connect to port 80. If the website operates on a port other than 80, type the port number in the **Port** field. If the last portion of the Site’s URL ends in a number, that number is the port to use. For example, http://www.example.com:99 indicates that the Web server www.example.com operates on port 99. The remainder of the tabs and fields are identical to those seen when adding an FTP Site.

7. Select **Connect** to establish the connection or click **OK** to save the Site in the Site Manager.

CuteFTP takes advantage of the *keep-alive header* (as defined in RFC 2068 & 2616) which keeps the session open during multiple transactions, saving the user considerable time and bandwidth.

The Web server must support basic authentication as described in RFC 1945 (<http://www.faqs.org/rfcs/rfc1945.html>). Because of the way authentication works, the server may challenge the client with a www-Authenticate request. The client responds with **Authorization: Basic** `<base64 encoding of user id-password>`. Most Web Servers support basic authentication but require intervention on the Site operator’s behalf to set it up because it is server specific. Various Sites employ other authentication schemes, such as NTLM or those found in ASP or Java Scripts, and are not supported by CuteFTP.

### Connecting to Secure Sites

You can make secure connections and transfers with FTPS (SSL/TLS), SFTP (SSH2), HTTPS (SSL), and standard FTP with **One Time Password** authentication.

#### To connect to a secure Site

1. Do one of the following:
   - On the main menu, click File > New > (FTPS (SSL) Site, SFTP (SSH2) Site, HTTPS (SSL) Site).
   - On the toolbar, click the down arrow next to the **New Site** icon, then click the type of Site (FTPS (SSL) Site, SFTP (SSH2) Site, HTTPS (SSL) Site).

   The **Site Properties** dialog box appears.

2. Provide the host address and login information.
3. If you are defining an FTPS (SSL/TLS) Site, click the **Type** tab.
4. In the **Protocol Type** list, click the down arrow and click one of the following:
   - FTP with TLS/SSL (Implicit encryption)
   - FTP with TLS/SSL (Explicit encryption)
   - FTP with TLS/SSL (AUTH TLS - Explicit)
   The appropriate port appears, depending on your selection. Certain servers support only one of
   the above **SSL connection mechanisms**.
5. Click **Connect** to connect to the Site now or **OK** to connect to the Site later.

### Connecting to Secure Socket Layer (SSL and TLS) Sites
You can use CuteFTP to connect to FTPS and HTTPS Sites. (Refer to **SSL/TLS Connections (FTPS/HTTPS)** for more information about SSL.)

#### To connect to an FTP Site over SSL (FTPS)
1. Do one of the following:
   - On the main menu, click **File > New > FTPS (SSL) Site**.
   - On the toolbar, click the down arrow next to the **New Site** icon, then click **FTPS (SSL) Site**.
   - In the **Site Manager**, right-click, then click **New > FTPS (SSL) Site**.

   The **Site Properties** dialog box appears.
2. Type a name for the Site in the **Label** field.
3. Type in the **Host address**, **Username**, and **Password**.
4. Click the **Type** tab.
5. In the **Protocol** list, choose the type of **SSL connection mechanism** supported by your server or use the default type selected.
6. Click **Connect** to connect to the Site now, or click **OK** to connect later.

#### To connect to an existing Site over SSL
- Click the Site in the **Site Manager**, then click **Connect**.

#### To connect to an HTTPS Site
1. HTTPS Sites use SSL to secure HTTP connections. Do one of the following:
   - On the main menu, click **File, New**, then click **HTTPS (SSL) Site**.
   - On the toolbar, click the arrow next to the **New Site** icon, then click **HTTPS (SSL) Site**.

   The **Site Properties for** dialog box appears.
2. Type a name for the Site in the **Label** field.
3. Type the Site’s address in the **Host address** field. You do not need to prefix the Site address with **https://**.
4. Type your user name in the **Username** field provided by your administrator.
5. Type your password in the **Password** field.
6. Click **Connect**.
7. When you connect for the first time, the **Accept Certificate** dialog box appears.
8. Click **Accept** if you trust the certificate. Rejecting a certificate will abort the connection.

**Configuration Notes**

- HTTPS Sites rely on the use of certificates to verify that you are in fact communicating with the desired HTTPS server and to establish the secure connection.
- Accepting a certificate stores the certificate on your computer so you do not have to verify it again the next time you connect to the Site.
- If a Site’s certificate appears unusual, has not been signed by a third party (such as VeriSign, or Thawte), or does not match the operator’s name, you should reject the request.
- Once the connection is established, a small lock icon displays on the **Status Bar**. Double-clicking the icon in the **Status Bar** displays the server’s certificate.
- The lock icon represents the type of connection established, but does not guarantee a secured connection. Even though you are connected to an https Site, you could be linked to an unsecured directory, at which time the session is no longer https, but http instead. Check the log if you are unsure of the security of your connection.

**To speed up transfers with an SSL Site**

Using a clear data channel speeds up transfers with SSL Sites. A clear data channel encrypts the connection process, but files are transferred without encryption.

1. Click the Site in the **Site Manager**.
2. On the main menu, click **File**, then click **Properties**. The **Site Properties** dialog box appears.
3. Click the **Type** tab.
4. Select the **Clear Data Channel** check box.
5. Click **OK** or **Connect**.

---

Not all servers support or allow the PROT C (Clear Data Channel) command argument sequence.

**To encrypt the data transfer and not the command connection**

Using a Clear Command Channel, you can keep your data transfers encrypted and still avoid firewall issues.

1. Click the Site in the **Site Manager**.
2. On the main menu, click **File**, then click **Properties**. The **Site Properties** dialog box appears.
3. Click the **Type** tab.
4. Select the **Clear Command Channel** check box.
5. Click **OK** or **Connect**.

---

Not all servers support or allow the CCC (Clear Command Channel) command argument.

**To configure other SSL settings**

1. On the main menu, click **Tools**, then click **Global Options**.
2. Expand the **Security** node.
3. Select **SSL Security**.
CuteFTP supports keyboard interactive authentication. This authentication method involves connecting to servers with a challenge/response type of password-based authentication, and requires a one-time-use password typically generated by hardware-based or, less commonly, software-based password generators.

Connecting to Secure Shell (SSH2) Sites

To connect to an SSH2 Site

1. Do one of the following:
   - On the main menu, click File > New > SFTP (SSH2) Site.
   - On the toolbar, click the down arrow next to the New Site icon, then click SFTP (SSH2) Site.
   - On the Site Manager tab, right-click, click New > SFTP (SSH2) Site.
   
   The Site Properties appear.

2. Type the Site's address in the Host address field. You do not need to prefix the Site address with "ftp://" or "sftp://".

3. Type your user name in the Username field provided by your administrator.

4. Type your password in the Password field.

5. Click Connect.

To choose SSH2 ciphers and authentication methods

1. On the main menu, click Tools > Global Options, or press ALT+F7.

2. Expand the Security node, then click SSH2 security.

3. Configure the SSH2 cipher, MAC, and other options, then click OK.

CuteFTP supports keyboard interactive authentication (KIA). This authentication method involves connecting to servers with a challenge/response type of password-based authentication, and requires a one-time-use password typically generated by hardware or, less commonly, software based password generators.

Refer to SSH2 Connections (SFTP) for details of SSH2/SFTP.

Automatically Displaying a Specific Folder when Connecting to a Site

When you connect to a Site, your Documents folder is the default local folder, and the default remote folder is the folder that you specified when you configured the Site. You can specify that a different local folder and/or remote folder appear in the Local and Remote panes when you log in to a Site.

You can also configure Sites to switch to a local and/or remote filter that you specify in the Site Properties dialog box for each Site.

To switch to a remote or local folder when a Site connects

- Do one of the following:
  - When you're not logged in to the Site:
    a. Display the Site Manager and view the Site Properties.
    b. Click the Actions tab.
c. To switch to a specified remote folder when CuteFTP connects, in the **When client connects, switch to this remote folder** box, type the remote folder name, prepended with a forward slash. For example, type /mywebsite.

d. To switch to a specified local folder when CuteFTP connects, in the **When client connects, switch to this local folder** box, click the folder icon to browse to a select the local folder.

e. Click **OK**.

   o **After you are connected to the Site:**

   a. In the **Local** pane, browse to the folder that you want to make the default.

   b. On the main menu, click **Tools > Site Manager > Save Local Path as Default**.

   c. In the **Remote** pane, browse to the folder that you want to make the default.

   d. On the main menu, click **Tools > Site Manager > Save Remote Path as Default**.

The next time you connect to the Site, the local folder that you specified as the default will appear in the **Local pane**, and the remote folder that you specified as the default will appear in the **Remote pane**.

**Multiple Concurrent Connections**

You can transfer files on one Site while browsing another Site, or browse a folder on a Site while transferring files from the same Site.

Multiple Concurrent Sessions are depicted as multiple open windows in the **Remote Pane** (on the right side by default). You can tile, cascade, or minimize these windows. When the panes are maximized, you can select alternate sessions by clicking the tabs at their lower left border.

**To open multiple concurrent connections**

1. Click the **Site Manager** tab, click a Site, then do one of the following:

   - Right-click the Site, then click **Connect**.
   - On the main menu, click **File > Connect > Connect**.
   - Press CTRL+T.

2. Repeat to connect to more Sites. You can connect to the same or different Sites.

**To force CuteFTP to open new connections for multiple transfers**

1. On the main menu, click **Tools > Global Options**.

2. Click the **Transfer** node.

3. Clear the **Allow transfers to occur over the existing browse session** check box.

**To allow multiple connections from CuteFTP**

1. On the main menu, click **Tools > Global Options**.

2. Click the **Connection** node.

3. In the **Global max concurrent transfers** box, type or select a value between 1 and 200.

**To allow multiple connections to the same Site**

1. On the main menu, click **Tools > Global Options**.

2. Click the **Connection** node.

3. In the **per Site max concurrent transfers** box, type or select a value between 1 and 200.
To enhance performance with limited resources

- Limit the number of concurrent per Site transfers allowed
- Turn off individual transfer item logging in settings or turn off all logging options.
- Do not transfer files in Multi-Part mode
- Do not perform on-the-fly File Integrity Checking
- Close the main program interface and use the Transfer Engine.

Performance Limitations

- You can choose up to 200 concurrent connections, but more than 40 connections may compromise system performance.
- Connections include transfers, browser sessions, and every single thread in a multi-part transfer.
- FTP Sites that do not support multiple connections or Sites that frequently drop the FTP connection will limit concurrent sessions.
- Computer resources and slow hardware may limit or prohibit multiple connections.

Using the ACCT Command

You can establish a connection and then supply the ACCT command for servers that require it.

To use ACCT with or without an FTP proxy

1. In the Site Manager, click the site you want to change.
2. Do one of the following:
   - Right-click the site, then click Properties.
   - On the main menu, click File > Properties.
3. Click the Options tab.
4. In the Site-specific configuration options box, click Use site-specific options.
5. Click Proxy. The Proxy dialog box appears.
6. In the Proxy type list, click the proxy type (FTP or HTTP).
7. In the Host name and port boxes, provide the same host and port as specified on the General and Type tabs.
8. Select the Use authentication check box. The Username and Password boxes become editable.
9. In the Password box, type the password (for ACCT).
10. Click **Advanced**. The **Advanced Proxy Settings** dialog box appears.

![Advanced Proxy Settings dialog box](image)

11. Do one of the following:
   - Click **Custom**, then add the following variables. Press ENTER after each variable:
     - USER %user%
     - PASS %pass%
     - ACCT %fire_pass%
   - Click **USER/PASS/ACCT**.

12. Click **OK** to save the settings and close the **Advanced Proxy Settings** dialog box.

13. Click **OK** again to close the **Proxy** dialog box.

14. Click **Connect** to connect now or **OK** to connect later.

### Password Protect Site Manager Content

**To require a password to open the Site Manager**

1. On the main menu, click **Tools > Site Manager > Security > Encrypt Site Manager Data**. The **Site Manager Encryption** dialog box appears.

![Site Manager Encryption dialog box](image)

2. In the **Password** and **Confirm password** boxes, type a password for opening the Site Manager. For maximum security, create a password of at least 8 characters, with a mix of numbers, letters, upper and lower case, and punctuation.
3. Click **OK**. CuteFTP will now display the following prompt every time it starts.

![Site Manager Access Password dialog box](image)

**To change the Site Manager password**

1. On the main menu, click **Tools > Manager > Security > Change Password**. The **Site Manager Encryption** dialog box appears.
2. In the **Password** and **Confirm password** boxes, type a new password for opening the Site Manager.
3. Click **OK**. The password is changed.

**To remove the Site Manager password**

- On the main menu, click **Tools > Site Manager > Security > Remove Password**. CuteFTP will not prompt for a password when it starts.

**Configuration Notes**

- When the Site Manager access password is defined, the Site Manager information is protected with 64-bit Blowfish encryption.
- If you forget the password, you will not be able to use the protected **Site Manager**. You will have the option to back up the locked **Site Manager** and re-enter your Site information in a new **Site Manager**.
- You can import a password-protected **Site Manager** file, but will need the password to do so.

**Staying Connected with Smart Keep Alive**

**Smart Keep Alive (SKA)** allows you to maintain connections even when you are not transferring files. SKA sends commands at random intervals to the FTP server, maintaining an active connection. If the server terminates the connection, CuteFTP automatically reconnects to the FTP site.

**To turn on/off Smart Keep Alive**

1. On the main menu, click **Tools > Global Options**. The **Global Options** dialog box appears.
2. Expand the **Connection** node, then click **Smart Keep Alive**.
3. In the right pane, select the **Enable Smart Keep Alive (SKA)** check box to turn on SKA; clear the check box to turn off SKA.
4. Configure SKA as needed:
   - **To set the time SKA waits before starting**
     - In the **Start SKA n seconds after the last command** box, type or select a value between 0 and 1000. CuteFTP will begin using SKA after the specified idle time. (The default is 30 seconds.)
   - **To set how long SKA will run**
     - In the **Maintain SKA for n minutes** box, type or select a value between 1 and 1000. (The default is 30 minutes.)
   - **To set when SKA commands are sent**
In the Send command at random intervals between $n$ and $n$ seconds box, type or select values between 0 and 1000. (The default is between 15 and 60 seconds.) SKA sends commands from the Commands list in random order.

- **To add a command**
  - Click Add. The Input FTP Command dialog box appears. Type a command to add to the list, then click OK.

- **To remove a command**
  - Click a command in the list, then click Remove.

- **To set how long CuteFTP waits before reconnecting**
  - In the If disconnected, auto-reconnect within $n$ seconds box, type or select a value between 1 and 1000 seconds. (The default is 10 seconds.)

5. Click **OK** to save the settings and close the dialog box, or click **Apply** to save the settings without closing the dialog box.

### SOCKS 4 and 5 Connection Settings

SOCKS is a network proxy protocol that allows transparent Internet connections across a firewall.

**To access SOCKS 4 and 5 settings**

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the Connection node, then click **SOCKS4 & 5**. The **SOCKS4 & 5** options appear.
3. To connect to an FTP site through a SOCKS server, select the Use the highlighted SOCKS server when connecting check box. Clear this check box to connect to an FTP site without connecting through a SOCKS server.
4. Configure options as described below.

- **To include a server in the SOCKS list**, click Add, then type the server name in the Host name box.
- **To make FTP connections through a specified server**, click the host name in the list
- **To delete a server from the SOCKS list**, click it, then click Remove.
- The Host name box displays the name of a server selected in the SOCKS list. To edit a host name, click a server in the SOCKS list, then edit the name in the Host name box.
- The Port box displays the port number for the server selected in the SOCKS list. The default port for SOCKS servers is 1080. To edit the server's port number, click it in the SOCKS list, then edit the number in the Port box.
- **To send the proper user name and password for the SOCKS server automatically when first connecting**, select the Use Authentication check box. Clear this check box if you do not have a SOCKS user name and password, or if you choose to enter them manually upon connection.
- In the Username box, provide the user name for the highlighted SOCKS server. (The Use Authentication check box must be selected.)
- In the Password box, provide the password for the highlighted SOCKS server. (The Use Authentication check box must be selected.)
- Click **SOCKS4** or **SOCKS5** to match the highlighted SOCKS server.
SOCKS4 servers do not require usernames and passwords. If you need a username and password to connect to the server, it is a SOCKS5 server.

Contact your system or network administrator or ISP or the proper Host name, Port, User name, Password and SOCKS type.

5. Click Apply if you are going to make changes to other pages; click OK to save changes and close the Global Options dialog box.

Proxy Connection Settings

To access proxy server settings

1. On the main menu, click Tools > Global Options (or press ALT+F7).
2. Expand the Connection node, then click Proxy Server. The Proxy Server options appear.
3. Configure options as described below.

- To use the proxy settings already set in Internet Explorer to connect to FTP Sites, select the Use network connection proxy settings from Internet Explorer check box. Clear this check box to connect to an FTP Site without connecting through a proxy server, or to connect using proxy settings listed in CuteFTP.
  
  With this option, CuteFTP attempts to detect Internet Explorer’s proxy settings, including proxy.pac proxy script files. This is only available for Windows XP SP1, W2K Pro SP3, W2K Server SP3, and W2K Server 2003 using WinHTTP.dll. If that fails, WinInet.dll, which is supported by XP, 2K PRO, NT4, ME, 98, and 95 is queried.

- To connect to an FTP Site through a proxy server, select the Use the highlighted proxy when connecting check box. Clear this check box to connect to an FTP Site without connecting through a proxy server, or to connect using settings from Internet Explorer.

- To make FTP connections through a specified server, click it in the Proxies list.
  
  - To add a server to the Proxies list, click Add, then type the server name in the Host name box.
  
  - To delete a server from the Proxies list, click it, then click Remove.

- The Host name box displays the name of a server selected in the Proxies list. To edit the host name, click a server in the Proxies list, then edit the name in the Host name box.

- The Port box displays the name of a server selected in the Proxies list. To edit the port, click a server in the Proxies list, then edit the name in the Port box.

- In the Username box, type or edit the user name for the selected proxy server.

- In the Password box, type or edit the password for the selected proxy server.

- To match the protocol the selected proxy server supports, click FTP or HTTP.

- To specify advanced authentication methods, click Advanced then click one of the following methods:
  
  - USER user @site if your proxy server requires the USER command followed by your user name and the Site name to allow connection with a remote Site. You can change the @ symbol if a different separator is required by your proxy server.
To create a custom authentication method for a proxy server

1. Click Advanced. The Advanced Proxy Settings dialog box appears.
2. Click Custom, then type a command in the text box.
3. Follow the command with a space and the appropriate variable. Choose from:
   - %host% - sends the host name you typed in the Proxy server options window.
   - %user% - sends the user name you typed in the Proxy server options window.
   - %pass% - sends the password you typed in the Proxy server options window.
   - %port% - sends the port number you typed in the Proxy server options window.
   - %fire_pass% - sends the password you typed in the Proxy server options window as authentication for the firewall.
   - %fire_user% - sends the user name you typed in the Proxy server options window as authentication for the firewall.
4. Enter each variable with percent signs before and after.
5. Press ENTER to separate commands.
6. Enter any other commands and variables, separating commands with a line break.
7. Click OK.

Contact your system administrator for the proper Host name, Port, User name, Password, and proxy type, as well as any required advanced authentication methods.

Encrypt Passwords Using OTP

When you connect to a Site, you can encrypt your password to protect it from interception using the One-Time Password (OTP) scheme. OTP is supported by Globalscape EFT Server, various *nix servers, and a few Windows-based servers.

To enable OTP for a standard FTP Site

1. In the Site Manager, click a Site.
2. On the main menu, click File > Properties.
3. Click the Type tab.
4. In the Protocol type box, make sure FTP (standard File Transfer Protocol) is selected.
5. In the **Password Protection** group, specify an encryption method.
   - **Not Encrypted** - the password is sent unprotected to the server.
   - **MD4** - A system that encrypts your password a different way every time it is sent.
   - **MD5** - A system like MD4, with more complex encryption scheme.
   - **Auto detect OTP** - CuteFTP tries to detect the encryption method the server uses.

6. Click **Connect** or **OK**.

**To enable OTP for an FTP over SSL Site**

1. On the **Site Manager** tab, click a Site.
2. On the main menu, click **File > Properties**.
3. Click the **Type** tab.
4. In the **Protocol type** box, make sure **FTP (standard File Transfer Protocol)** is selected.
5. In the **Password Protection** group, specify an encryption method.
6. In **Protocol type**, select the desired **SSL connection mechanism**.
7. Click **Connect** or **OK**.

---

**Using OTP with SSL adds a redundant layer of protection as SSL authentication already protects the password using a robust encryption mechanism.**

**OTP is defined in RFC 1938 (replaced by 2289) and was evolved from S/KEY™, a One-Time Password System originally developed by Bellcore.**

**CuteFTP supports keyboard-interactive authentication. This authentication method involves connecting to servers with a challenge/response type of password-based authentication, and requires a one-time use password typically generated by hardware or, less commonly, software-based password generators.**

---

**TapIn™ Site Creation**

TapIn™ is a Globalscape product that allows you to connect to your music, movies, and documents at home or in the office from anywhere, including mobile devices. For information about TapIn, refer to the **TapIn articles** in the Globalscape Knowledgebase.

CuteFTP is installed with a **TapIn Test Drive** Site with which you can experience TapIn. The **TapIn Test Drive** Site provides read-only access to a sample TapIn share. The **TapIn Test Drive** Site connects to webdav.tappin.com via HTTPS, port 443. If this port or HTTPS is blocked by a firewall, you will not be able to connect to the **TapIn Test Drive** Site.
You can create your own TappIn Sites to access your TappIn shares and your friends' TappIn shares. One Site can access only one share, so you must create a Site for each share that you want to access.

- To create your own TappIn connection (on which you can have create, read, update, and delete permissions, depending on the settings for the TappIn share), refer to the procedure below.

- If you don't have a TappIn account, or if you want to learn more about TappIn, click Sign up to go to http://www.tappin.com/sign-up and create one.

- If you have forgotten your TappIn password, go to https://app.tappin.com/forgot to reset it.

**To create a TappIn connection in CuteFTP**

1. On the computer on which the shared folder exists, create a TappIn share. (Refer to http://kb.globalscape.com/KnowledgebaseArticle11079.aspx for details of creating a TappIn share.)

2. In CuteFTP, do one of the following:
   - On the main menu, click File > New > TappIn Site.
   - Right-click in the Site Manager, then click New > TappIn Site.
   - Click TappIn Test Drive.

The Site Properties dialog box for a TappIn Site appears.
3. Provide the following information:

- In the **Label** box, give the Site a name.
- In the **Username** box, provide your TappIn username. If you do not have an account, click **Sign up** and follow the prompts to create an account.
- In the **Password** box, provide your TappIn password. If you have an account but have forgotten your password, click **Forgot your password** or go to [https://app.tappin.com/forgot](https://app.tappin.com/forgot) to reset it. (The **Forgot your password** link is not functional for the TappIn Test Drive Site; you cannot change its password.)
- In the **Connect to** box, click the drop-down list to specify which shares you want to access: **All of my TappIn shares**, **One of my TappIn shares**, or **A friend's TappIn share**.
- In the **Share name** box, if you specified **one of my TappIn shares** or **A friend's TappIn share**, type the name of the TappIn share exactly as it is in TappIn. (Refer to [http://kb_globalscape.com/KnowledgebaseArticle11079.aspx](http://kb_globalscape.com/KnowledgebaseArticle11079.aspx) for details of creating a TappIn share.)
- In the **Friend's TappIn username** box, if you specify **A friend's TappIn share**, type the username of the owner of the shared location. (Friend shares cannot be accessed from your own directory.)

4. Click the **Actions** tab and provide the following information:

- **When client connects, switch to this remote folder**—Specify the remote folder that you want to access. Typically, you would specify the top folder that you have permission to access.
When client connects, switch to this local folder—Specify the folder on your computer that you want to use with this connection. For example, you might want to download files from the TappIn location to your hard drive.

For navigation, use the following caching options—"Caching" means that CuteFTP temporarily stores the Site's list information on your computer, so when you navigate to different files and folders, you don't have to reconnect. Specify to Always use cache, Do not use cache, or Use cache during session (the default).

When uploading, apply this rule to files and folder names—Some operating systems, such as the Unix, are "case sensitive." If you type your username in mixed case (e.g., ImaUser rather than imauser) Unix will not recognize it. Depending on the server to which your are connecting, specify whether to Force upper case, Force lower case, or Preserve case (the default).

Filter—Click Filter, then specify whether to filter the remote server's list of folders and files. For details of using filters, refer to Filtering the List of Files and Folders.

Add this Site to right-click upload menu—Select the check box add the TappIn Site to the right-click menu in Windows Explorer.

5. Click the Options tab and specify whether to Use global settings for all options (the Site will use the parameters set in Global Options) or Use Site-specific option (the Site will use the parameters set on this tab). If you specify to Use Site-specific options, specify the following options:

- Apply auto-rename scheme to transfers—Select this check box if you want the files that you transfer to be renamed according to the settings you chose in the Rename Rules. Clear this check box if you do not want files to be renamed when you make transfers with this Site.

- Use the logical parent (not physical parent) on CDUP—Select this check box if you want to return to the previous directory when you clicked the Up folder icon, even if you clicked a link or shortcut in the previous directory. Clear this check box to go back to the parent directory for this folder, which might not have been the directory you were in when you jumped to the current directory.

- Site-specific firewall settings—Click Proxy if you need to connect through a proxy server to get to this Site. A Proxy dialog box appears in which you can enter the proxy type, server address, username and password. Click Socks if you need to connect through a Socks server to get to this Site. A Socks dialog box appears in which you can enter the SOCKS type, server address, username and password. Refer to Proxy Connection Settings and Socks 4 and 5 Connection Settings for details.

- Retry attempts—Specify the number of times you want CuteFTP to try connecting to this Site, if there is a problem making a connection.

- Delay between retries—Specify the number of seconds you want CuteFTP to wait before retrying a connection after a connection attempt fails.

- Site max concurrent transfers—Specify the number of connections CuteFTP can open to the Site for transferring many files simultaneously.

6. Click OK to save the Site or click Connect to connect.
Web Distributed Authoring and Versioning (WebDAV)

WebDAV is an extension to the HTTP/1.1 protocol that allows clients to perform remote Web content authoring operations. HTTP defines many headers that can be used in WebDAV requests and responses. WebDAV provides functionality to create, change, and move documents on a remote server (typically a web server or "web share"). This is useful, among other things, for authoring the documents that a web server serves, but can also be used for general web-based file storage that can be accessed from anywhere. Important features in WebDAV protocol include locking (overwrite prevention), properties (creation, removal, and querying of information about author, modified date, etc.), name space management (ability to copy and move Web pages within a server's namespace), and collections (creation, removal, and listing of resources).

CuteFTP doesn't support all WebDAV verbs. In particular, CuteFTP can't take advantage of the additional services offered by "Class 2" WebDAV-compliant servers (http://www.webdav.org/specs/rfc4918.html#dav.compliance.classes). Verbs that CuteFTP doesn't support are PROPPATCH, LOCK, and UNLOCK.

In CuteFTP, WebDav is most often used with TappIn shares. For non-TappIn Sites, refer to Connecting to an HTTP Site.
This page left blank for 2-sided "book" printing.
Chapter 4. Site Administration

The topics below provide procedures for administering your Sites. (For creating a site, see Connecting to Sites using the Connection Wizard.)

Importing and Exporting Site Configuration

You can add Sites to your Site Manager from text listings; you can export your Site Manager listings if another user requires the same Site configuration, or if you just want to back up the Site Manager.

To import Sites

1. On the main menu, click Tools > Site Manager > Import/Export FTP Sites. The Choose import or export Site Manager wizard appears.
2. In the Select the operation area, click Import, then click Next.
3. Specify the source from which you want to import, then click Next.
4. In the Conversion type area, do one of the following:
   - Merge the entries into the existing Site Manager
   - Create a new Site Manager with these entries
5. Click Next. The file location page appears.
6. Click magnifying glass icon to open the Find Site Database Tool and view the list of Sites.
7. Click the Site you want to import, then click OK. (You may need to click Stop to stop the search and enable the OK button.)
8. After the Sites are imported, click Finish.
9. Open the Site Manager to verify the Sites were imported.

To export your Site Manager listings

Do one of the following:
   - Right-click in the Site Manager, then click one of the following formats, then specify the location and file name for the file.
     - Export Sites as Text (contains all Site properties)
     - Export Sites as URL (contains only the URLs of the Sites).
   - On the main menu, click Tools > Site Manager > Import/Export FTP Sites. The Choose import or export Site manager wizard appears.
     a. Click Export, then click Next.
     b. In the Select the file format area, click one of the following:
        - As text - to generate a list of Sites in plain text.
        - As URL - to generate a list of Sites as Web addresses.
     c. Click Next.
     d. In the File location and Name box, click the folder icon to define the path for the new file. The Save As dialog box opens.
     e. In the File name box, type a name for the file, then click Save.
     f. Click Finish
Removing a Site from the Site Manager

If you have Sites defined in the Site Manager to which you no longer connect, you can delete them. There is no way to recover them after you delete them. It is a good idea to export a backup file of the Sites before you delete any Sites.

To remove a Site from the Site Manager

1. Display the Site Manager.
2. Click the Site you want to delete, then do one of the following:
   - Click the Site that you want to delete, then on the main menu, click File > Delete.
   - Right-click the Site, then click Delete.
   - On the keyboard, press DELETE.
   - On the toolbar, click the Delete icon.
3. A confirmation message appears. Click Yes.

Changing a Site's Connection Settings or Login Information

On the General tab of the Site Properties dialog box, you can change the connection or login information for the selected Site.

To change a Site's connection settings or login information

1. Display the Site Manager and view the Site Properties.
2. Click the General tab.
3. Change the information as needed, then click Connect to accept the changes and connect to the Site, or OK to accept the changes without logging in.
Changing the Data Connection Type (Port or PASV)

The Sites use the data connection type (or mode) set in the Global Options dialog box. You can override that setting for each Site. For example, if you want to connect in PASV mode to a server that prefers PORT for data connections, you might need to change the data connection type.

**To change the data connection type**

1. Display the Site Manager and view the Site Properties.
2. Click the Type tab.

   ![Site Properties dialog box](image)

3. In the Data Connection Type box, click Use PORT or Use PASV.
4. Click Connect or OK.

Proxy Settings for Individual Sites

The Sites use the proxy settings in the Global Options dialog box. You can override that setting in the Site's properties.

**To setup a proxy connection for an individual Site**

1. In the Site Manager, click the Site you want to change.
2. Do one of the following:
   - Right-click the Site, then click Properties.
   - On the main menu, click File > Properties.
3. Click the Options tab.
4. In the Site-specific configuration options list, click Use Site-specific option.
5. Click Proxy. The Proxy dialog box appears.
6. In the Proxy type list, click the protocol your proxy server supports.
7. In the Host name and port boxes, type the name and port number of the proxy server. The default port for proxy servers is 8000.
8. If the proxy server requires a user name and password or some other authentication, select the **Use authentication** check box. If the proxy server does not require authentication, skip to step **15**.

9. Type your proxy **User name**.

10. Type your proxy **Password**.

11. If your proxy server only requires the user name and password, skip to step **15**; otherwise, click **Advanced**.

12. Click one of the following advanced authentication methods.
   - **USER user @site** if your proxy server requires the USER command followed by your user name and the Site name to allow connection with a remote Site. You can replace the @ sign with a different separator to match what your proxy server requires.
   - **SITE Site** if your proxy server requires the SITE command followed by the address of the remote FTP Site to allow a connection.
   - **USER with logon** if your proxy server requires the USER command followed by a user name and password to allow connection with a remote Site.
   - **USER/PASS/ACCT** if your proxy server requires all three commands before allowing a connection to a remote Site.
   - **OPEN Site** if your proxy server requires the OPEN command followed by the Site name before allowing connection to the Site.
   - **Custom** if your proxy server requires a login sequence different from those above. See the procedure below for creating a custom authentication method.

14. Click **OK** to close the **Advance Proxy Settings** dialog box.

15. Click **OK** to accept the Proxy settings specific to this Site.

16. Click **Connect** or **OK** to close the Site Manager.

---

**Contact your system administrator for the proper Host name, Port, User name, Password, and proxy type, as well as any required advanced authentication methods.**

---

**To create a custom authentication method for a proxy server**

1. Type a command.

2. Follow the command with a space and an appropriate variable:
   - `%host%` sends the host name you typed in the **Proxy** dialog box.
   - `%user%` sends the user name you typed in the **Proxy** dialog box.
   - `%pass%` sends the password you typed in the **Proxy** dialog box.
   - `%port%` sends the port number you typed in the **Proxy** dialog box.
   - `%fire_pass%` sends the password you typed in the **Proxy** dialog box as authentication for the firewall.
   - `%fire_user%` sends the user name you typed in the **Proxy** dialog box as authentication for the firewall.

   Type each variable with percent signs before and after.

3. Press **Enter** to separate commands.

4. Click **OK**.
Correcting Times for Sites in Different Time Zones

CuteFTP uses time zone offset information for display, transfer, and overwrite logic.

To compensate for servers in different time zones

1. Display the Site Manager, right-click the Site, then click Properties.

2. Click the Type tab.

3. In the Server time zone list, select the server's time zone. Alternatively, select the Automatically detect check box, and CuteFTP will determine the time zone from the system clock.

4. Click Connect or OK.

Specifying Whether to Save a Site's Information - Caching

"Caching" means CuteFTP stores the Site list information on your computer, so when you navigate to different files and folders, you don't have to reconnect.

To specify cache options

1. Display the Site Manager, right-click the Site, then click Properties.
2. Click the **Actions** tab.

3. In the **For navigation use the following caching options** box, click one of the following:
   - **Use cache during session** - Store the site's information only until you close the connection (the default setting).
   - **Always use cache** - Store the site's information and keep it even after you disconnect.
   - **Do not use cache** - Never store the site's information.

4. Click **Connect** or **OK**.

**Designating a Site's Server Type**

You can improve compatibility with individual Sites by designating the type of server used for that Site.

**To designate server type**

1. **Display the Site Manager**, right-click the Site, then click **Properties**.
2. Click the **Type** tab.

3. In the **Server Type** list, select a server type.

4. Click **Connect** or **OK**.

### Finding a Site in the Site Manager

If you have numerous Sites defined in the Site Manager, you use the **Find** function to search for it.

**To find a Site in the Site Manager**

1. **Display the Site Manager**.
2. Right-click in the **Site Manager**, then click **Find Text in Site Manager** (or press ALT+F3). The **Find** dialog box appears.

3. Type all or part of the Site name, then click **OK**.
4. If a Site other than the one you wanted is found, right-click and select **Find Next**, or press F3, until the desired Site is highlighted.

> The **Find** tool is not case sensitive, searches from the top to the bottom of your Site listings, and does not recognize wildcards.

### Creating and Using Bookmarks

You can have special entries called **bookmarks** associated with Sites that open a specific local or remote folder, or both local and remote folders.

**To create a bookmark**

1. **Display the Site Manager**, then double-click the Site to connect to it.
2. In the **Local** tab, click or browse to the folder you want to bookmark.

3. In the **Remote** tab, click or browse to the remote folder you want to bookmark.

4. Do one of the following:
   - On the main menu, click **Tools > Bookmark current folder**.
   - Click the **Bookmark** icon  
   - Press CTRL+Q.

The **Set bookmark** dialog box appears.

![Set Bookmark](image)

5. The **Local folder** and the **Remote folder** are displayed in the **Set Bookmark** dialog box and cannot be changed. To change the local folder and remote folder you have to repeat the previous steps.

6. Bookmarks created in this manner are assigned the remote folder as their default name, but you can name it anything you want. In the **Bookmark Name** box, provide a descriptive name for the bookmark, then click **OK**.

The new bookmark appears in the **Site Manager** as a sub-listing of the remote Site's entry.

![Site Manager](image)

**To connect to a bookmarked directory**

- Do one of the following:
  - Double-click a bookmark displayed as a sub-item under the Site name in the **Site Manager**.
  - Click **Bookmark** and select the desired bookmark from the shortcut menu.
  - On the toolbar, click the **Bookmark** icon, then click the bookmark on the shortcut menu.
  - A new remote window appears displaying the bookmark's remote folder, if specified; otherwise, the root folder appears. The **Site Manager** switches to **Local Drives**, displaying the local folder specified in the bookmark.
To edit a bookmark
1. In the **Site Manager**, click the bookmark.
2. Do one of the following:
   - On the main menu, click **File > Properties**.
   - Right-click the bookmark, then click **Properties**.
   
   ![Bookmark Properties dialog box](image)

   The **Bookmark Properties** dialog box appears.

   3. To change the remote folder, in the **Remote path** box, type a new remote path.

   4. To change the local folder, in the **Local Path** box, type or browse for a new local path.

   5. Click **OK**.

To rename a bookmark
1. Click the bookmark.
2. On the main menu, click **File > Rename** (or press F2).
3. Type a new name, then press ENTER.

To remove a bookmark
1. Click the bookmark, then do one of the following:
   - On the main menu, click **File > Delete**.
   - Right-click the bookmark, then click **Delete**.
   - On the toolbar, click the **Delete** icon .

2. A confirmation message appears. Click **Yes**.


This page left blank for 2-sided “book” printing.
Chapter 5. OpenPGP Security Settings

The topics below provide the procedures for managing, importing, exporting, and uploading OpenPGP keys.

CuteFTP uses OpenPGP, based on the open source implementation of Pretty Good Privacy (PGP), to safeguard transferred data. PGP provides cryptographic privacy and authentication by encrypting the content of any data, such as any computer file or message text.

OpenPGP uses asymmetric key encryption algorithms, with which the recipient must have previously generated a linked key pair, a Public key, and a Private key. This key pair is associated with a particular site. The public key encrypts the data and the private key helps in decrypting data.

CuteFTP allows you to create keys and ensures security of the transferred data. A file is encrypted before it is uploaded to a server.

For example, if you want to upload result.txt as OpenPGP encrypted file, the system encrypts result.txt into result.txt.pgp and then uploads result.txt.pgp to a server.

OpenPGP keys

CuteFTP allows you to create, import, export, and delete OpenPGP keys. To create an OpenPGP Key on the fly to transfer files, refer to Uploading and Downloading Files Using OpenPGP Keys.

To specify an OpenPGP key to use (if you have created a key)

1. On the toolbar, click the OpenPGP Mode icon . The OpenPGP Mode Settings dialog box appears.
2. In the Select key list, click a key.

To view, create, import, export, or delete keys

1. On the main menu, click Tools > Global Options (or press ALT+F7).
2. Expand the Security node, then click OpenPGP Security. The OpenPGP Security options appear.
   - To create OpenPGP keys
     a. Click Create. The OpenPGP Key Generation dialog box appears.
     b. In the Key ID box, type your email address. The key identifies the key pair.
     c. In the Key Passphrase and the Confirm Passphrase boxes, type your private key passphrase.
d. In the **Key size to use** list, click a key size. A key is a value that works with a cryptographic algorithm to produce a specific ciphertext (encrypted message) from a specific plaintext (original document). Key size is measured in bits. In cryptography, a bigger the key ensures more secure ciphertext.

e. In the **Key type to use** list, click a key type. Key types are the cryptosystems named after their inventors.

f. To generate the keys, click **Generate**.

g. The generated key is added to the **OpenPGP Key** list. The **OpenPGP Key** list displays the user id, key id, and key type.

- **To delete an OpenPGP key**
  - Click a key in the list, then click **Delete**.

- **To import an OpenPGP key**
  1. In the **OpenPGP** list, click a key, then click **Import**. The **Open** dialog box appears.
  2. Navigate to the OpenPGP key file, then click **Open**.
  3. Click **OK**.

- **To export an OpenPGP key**
  1. In the **OpenPGP** list, click a key, then click **Export**. A confirmation message appears.
  2. Click **Yes** to export the private key along with the public key, otherwise click **No**. The **Save As** dialog box appears.
  3. In the **File name** box, type a name for the key, then click **Save**.
  4. Click **OK**.

### Uploading and Downloading Files Using OpenPGP Keys

You can upload and download files using OpenPGP keys. The Public key encrypts the data before the upload starts and Private key decrypts the data prior to the download.

#### To upload or download a file using OpenPGP keys

1. Connect to your site.
2. In the **Local** pane (upload) or **Remote** pane (download), click the file you want to transfer.
3. Do one of the following:
   - On the main menu, click **Tools > OpenPGP mode**.
   - On the toolbar, click **OpenPGP Mode**.
   - Right-click the file you want to upload, click **Upload Advanced**, then click **Upload OpenPGPed**.
   - Right-click the file you want to download, click **Download Advanced**, then click **Download OpenPGPed**.

If no key is defined, a message appears asking if you want to create one.
a. Click Yes. The OpenPGP Key Generation dialog box appears.

b. In the Key ID box, type your email address. The key identifies the key pair.

c. In the Key Passphrase and the Confirm Passphrase boxes, type your private key passphrase.

d. In the Key size to use list, click a key size. A key is a value that works with a cryptographic algorithm to produce a specific ciphertext (encrypted message) from a specific plaintext (original document). Key size is measured in bits. In cryptography, a bigger the key ensures more secure ciphertext.

e. In the Key type to use list, click a key type. Key types are the cryptosystems named after their inventors.

f. To generate the keys, click Generate.

g. The generated key is added to the OpenPGP Key list. The OpenPGP Key list displays the user id, key id, and key type.

4. In the OpenPGP Mode Settings dialog box, click a key, then click OK.
This page left blank for 2-sided “book” printing.
Learning about SSL

When you use CuteFTP to connect securely to a server that supports SSL or TLS (SSL v3), the two computers pass a sequence of commands to create a secure connection. The FTP protocol definition provides at least two distinct mechanisms by which this sequence is initiated: Explicit (active) and Implicit (passive) security.

**Explicit Security** - Explicit security requires that the FTP client issue a specific command to the FTP server after establishing a connection to establish the SSL link. The default FTP server port is used. This formal method is documented in RFC 2228.

**Implicit Security** - Implicit security is a mechanism by which security is automatically turned on as soon as the FTP client makes a connection to an FTP server. In this case, the FTP server defines a specific port for the client (990) to be used for secure connections.

*Implicit SSL is discussed in various SSL drafts, but not formally adopted in an RFC. For strict compliance to standards, use the explicit method. Implicit SSL adds benefits in the form of a dedicated port strictly used for secure connections, requiring fewer overheads in establishing the session. There are various FTP servers that support this mode, including Globalscape's EFT Server. For more on SSL Connection Mechanisms, see Troubleshooting SSL Connections.*

---

**SSL Sessions**

The diagram shows an SSL session using explicit security.

In this picture, the two computers communicate over an Internet connection.

Time is represented vertically; the first communication at the top of the time line is from the Client to the Server, and subsequent communications proceed chronologically down the time line.

The breaks in the time line represent the passage of time.

CuteFTP adheres to Internet standards for secure transfer of files over the FTP protocol.

Specifically, CuteFTP implements the FTP extensions documented in RFC 2228. Any FTP Server that also implements these extensions will work with CuteFTP in order to ensure the encryption of your sensitive data.

---

**SSL Security Settings**

To access the SSL security settings

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Security** node, then click **SSL Security**. The **SSL Security** options appear.

3. Configure options as described below:

   - Select the **Use SSL certificate when authenticating** to send a certificate to SSL servers for authentication. Clear this check box to send no certificate to SSL servers for authentication.

     *Your server may not require client certificates. If they do require client certificates, you may need to send your self-signed or 3rd-party signed certificate to the server administrator to be added to the server's Trusted List.*

   - In the **Certificate** box, browse to or type the location of an SSL certificate file on your local computer. The file should have a .crt extension.
   - In the **Private key** box, browse to or type the location of an SSL private key file on your local computer. The key file should have a .key extension.
   - In the **Use passphrase** box, provide the passphrase used for the certificate listed in the **Certificate** field.
   - In the **Confirm Passphrase**, provide the passphrase again for the certificate listed.

     *The private key password is stored in the registry using strong encryption. For added security, leave the passphrase boxes blank so that CuteFTP will prompt you for the private key password when necessary.*

   - Click **Create Certificate** to create a new SSL certificate with a signing request and a key for the certificate. For more information on creating SSL certificates, see [Creating your own SSL certificates](#).
   - Click **Trusted Certificates** to display a list of certificates that you have accepted as valid. For more information on trusted certificates, see [Accepting server SSL certificates](#) and [Importing SSL certificates](#).
   - Select the **Reuse cached session for data connection (required by some servers)** check box to allow new transfers without encrypting a new data channel. Clear this check box to require encryption of every session for every new transfer.
   - Select the **Accept certificates in Windows Trusted Root Certificate Authority store** check box to automatically trust certificates already accepted by your system, even if they have not been added to your Trusted list. Clear this check box to require all certificates to be added to the CuteFTP Trusted list before allowing connections.
   - Select the **Warn when switching from secure to non-secure pages** check box to see a pop-up message when, after connecting to a secure HTTP site, you click a folder or link that is not secure. Clear this check box to be able to link from secure HTTP sites to HTTP sites that are not secure without seeing any pop-up messages.

4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

### Creating SSL Certificates

SSL servers use certificates to determine whether they will allow you to connect. With CuteFTP, you can create and sign digital certificates.

**To create an SSL certificate**

1. On the main menu, click **Tools > Global Options**.
2. Expand the **Security** node.
3. Click **SSL Security**.
4. Click **Create Certificate**. The **Create Client SSL Certificate Set** wizard appears.

5. In the **Certificate set name** box, type the name of the certificate that will be generated by the **Certificate Wizard**.

6. In the **Output Location** box, click the folder icon to select a folder in which to save the certificate.

7. In the **Key length in bits** box, click a bit length for the certificate private key. CuteFTP supports keys up to 4,096 bits.

8. In the **Expiration** box, specify how long the certificate is to remain valid.

9. Create and confirm the **Passphrase**. The passphrase, which is used to encrypt the private key, can be any combination of characters or spaces. Do not lose the passphrase, as the certificate is useless without it.

10. Click **Next**. The **Certificate Information** page appears.

11. Provide the following required information:

    - **City/Town** - the city/town where your organization is located.
    - **State/Province** - the state/province where your organization is located.
• **Organization** - the name of your organization.
• **Common Name** - the common name or fully qualified domain name of your Site (e.g., www.globalscape.com)
• **Email** - email address in the format x@x.com.
• **Unit** - name of your department, such as Information Systems.
• **Country** - the two-letter country code for the country where your organization is located.

12. Click Next. The final page appears.

13. Click the **Set up CuteFTP to use the generated certificate** check box - the wizard automatically associates the certificate to CuteFTP.

   - The certificate can be unassociated by clearing the **Use SSL Certificate** check box in **Global Options (Tools > Global Options > Security > SSL Security)**. If the check box is cleared, the wizard only saves the certificate files in the folder originally specified.

14. Click Finish.
CuteFTP displays the paths to all the files generated for your certificate. If you want a third party to sign your certificate, you must send the Certificate Signing Request (.csr) file to the third party. The CSR is saved in the location you specified on the first page of the wizard, e.g., C:\Users\Administrator\AppData\Roaming\Globalscape\CuteFTP\9.0\Security.

**Configuration Notes**

- Not all SSL Sites require certificates.
- When you create a certificate, CuteFTP generates the following files:
  - **Private key file (.key)** - The private key should never be distributed to anyone. It is used to decrypt sessions encrypted by a public key.
  - **Certificate request file (.csr)** - This file can be signed by Globalscape EFT Server's Certificate Signing Utility or sent to an intermediate Certificate Authority such as Verisign or Thawte for signing.
  - **Certificate file (.crt)** - This is a signed certificate, whether self-signed or signed by an intermediate certificate authority.
- If the server accepts self-signed certificates, you can connect with the .crt file and .key file you created and associated to CuteFTP, provided the server has added your certificate to its trusted list.
SSL/TLS Connections (FTPS/HTTPS)

- You can export certificates (.crt files) from CuteFTP's Trusted certificate store, located in Global Options > Security > SSL Security.

Signed SSL Certificates

To have a certificate signed
1. Create a certificate. CuteFTP generates the necessary files, including a Certificate Signing Request (.csr) file.
2. Send the CSR file to EFT Server or a Certificate Authority (CA) such as Verisign (www.verisign.com) or Thawte (www.thawte.com).
3. EFT Server or the CA creates a signed certificate (CRT) file.
4. Replace your existing CRT file with the signed one.

Choosing a Certificate for SSL Sessions

Choose the certificate CuteFTP will send to SSL servers.

To choose a certificate
1. On the main menu, click Tools > Global Options.
2. Expand the Security node.
3. Click SSL Security.
4. Select the Use SSL Certificate when authenticating check box.
5. Browse to the files to use by clicking the folder icons next to Certificate and Private Key.
6. Type the passphrase in the Passphrase and Confirm passphrase boxes.
7. Click Apply, then click OK.

CuteFTP can use digital certificates in the following formats: PEM, Base64 Encoded X509, PKCS#7, and PKCS#12. The private key associated with the digital certificate must be in one of the following formats: PEM, PKCS#8, PKCS#12. DER Encoded keys or certificates are not supported by CuteFTP.

Accepting Server SSL Certificates

Accepting a certificate from a server allows you to connect with the server. Once you accept a certificate, it is added to your Trusted Certificates list, and you will not be asked to accept or reject the certificate again. If you reject a certificate, and try to connect again, you will be asked again to accept the certificate.

To accept a server's SSL certificate
1. Connect to a server with SSL. If the server has a certificate, it appears.
2. Click Accept. The certificate is added to your Trusted Certificates list.
   If you click Reject, you will not be able to connect to the server.

To see your Trusted Certificates
1. On the main menu, click Tools > Global Options.
2. Expand the Security node.
3. Click SSL Security.
5. Click a certificate in the list, then click Properties to see detailed information about the certificate.
Importing or Removing SSL Certificates from the Trusted List

When a certificate is in your trusted list, you are able to connect to any server presenting that certificate.

**To import a certificate to the CuteFTP trusted list**

1. On the main menu, click **Tools > Global Options**.
2. Expand the **Security** node.
3. Click **SSL Security**.
4. Click **Trusted Certificate**. The **Certificate Manager** appears.
5. Click **Import**. The **Open** dialog box appears.
6. In the **Files of Type** field, select **Certificates (*.pem, *pfx, *.crt)** or **All files (*.*)**.
7. Navigate to the folder containing the certificate file.
8. Click the certificate file, then click **Open**. The certificate is now listed in your **Trusted Certificates** list.
9. Close the **Certificate Manager**.
10. Click **OK** to close the **Global Options** dialog box.

**To remove an SSL certificate from the trusted list**

1. On the main menu, click **Tools > Global Options**.
2. Expand the **Security** node.
3. Click **SSL Security**.
4. Click **Trusted Certificate**. The **Certificate Manager** appears.
5. Click the certificate you want to remove, then click **Remove**.
6. Close the **Certificate Manager**.
7. Click **OK** to close the **Global Options** dialog box.

Using a Clear Data Channel with SSL

Using CDC (Clear Data Channel) speeds up transfers with SSL sites. A clear data channel encrypts the connection process, but files are transferred without encryption. You can add more speed to your transfers by using a clear command channel as well.

*The Clear Data channel option is only available with SSL connections.*

**To use a clear data channel**

1. Open the Site Properties and click the **Type** tab.
2. In the **Protocol** list, click **FTP with TLS/SSL (Port 990 - Implicit)**, **FTP with TLS/SSL (AUTH SSL - Explicit)**, or **FTP with TLS/SSL (AUTH TLS - Explicit)**.
3. Click the **Clear Data channel** check box.
4. Click **Connect** to connect now or **OK** to connect later.
Using a Clear Command Channel with SSL

Using CCC (Clear Command Channel), your connection and login are encrypted, but when you begin transferring data, all FTP commands are sent in clear text. The data transfers remain encrypted, unless you choose to use a clear data channel. SSL connections require CCC when connecting in PORT mode from behind a NAT firewall.

The Clear Command channel option is only available with SSL connections.

To use a clear command channel with SSL

1. Click the site in the Site Manager, then do one of the following:
   - On the main menu, click File > Properties.
   - Right-click the site, then click Properties.
   - Press ALT+ENTER.
2. Click the Type tab.
3. In the Protocol list, click FTP with TLS/SSL (Port 990 - Implicit), FTP with TLS/SSL (AUTH SSL - Explicit), or FTP with TLS/SSL (AUTH TLS - Explicit).
4. Select the Clear Command channel check box.
5. Click Connect to connect now or OK to connect later.

Secure Site-to-Site Transfers Using SSCN

CuteFTP supports secure (SSL) Site-to-Site transfers using a proprietary command developed by Raiden FTP Server and supported by Globalscape EFT Server and a few others.

To transfer files from one server to another securely

1. Connect to each Site (source and destination).
2. On the main menu, click Window > Tile.
3. Drag the file from one Remote Pane to another. The Queue pane displays a double arrow (<->) to indicate a Site-to-Site transfer.

Both Sites must support and enable SSCN (Set Secured Client Negotiation). As of March 2004, the following servers are the only ones to support this command: Globalscape EFT Server, SurgeFTP Server, Raiden FTPD, Blackmoon FTP Server, Titan FTP Server, and Orenosv HTTP/FTP Server.

Troubleshooting SSL Connections

If you are having difficulty connecting to your FTP server or HTTPS over SSL, refer to the following checklist for help.

SSL Connection Checklist

1. Verify that the server you are connecting to supports SSL connections.
2. Verify the port being used. Some servers require that SSL connections use a dedicated port, such as 990.
3. Verify the SSL connection type on the Site Properties Type tab is the correct SSL mechanism supported by your server.
4. Verify that your Certificate was added to the server’s Trusted List if the server requires client certificates upon connect. You may have to notify the server administrator as not all servers will auto-accept client certificates upon their first connection attempt.
5. You must accept the server’s certificate when prompted during a connection attempt, otherwise the client will not connect as desired.
6. Verify that your certificate has not expired. Check your Trusted List.
7. Copy the connection log to a text file or email to assist in troubleshooting when contacting your FTP or Web service provider or the Globalscape support team.

**SSL Connection Mechanisms**

Not all FTP servers that support SSL connections do so correctly or in strict compliance to proposed or approved standards.

Various FTP-over-SSL implementations have been proposed over the past few years. Most do not conform to RFC–2228 or are at odds with the latest IETF (Internet Engineering Task Force) drafts. Typical Implementations include:

**Implicit TLS/SSL** - This is an SSL connection over a dedicated port (990) registered with the IANA. This approach, while quite common, is not favored by the IETF. CuteFTP supports this implementation for broader compatibility.

**Explicit "AUTH SSL"** - This is an SSL connection over a standard port (21) using "AUTH SSL" or "AUTH TLS-P" to negotiate the protection mechanism. AUTH TLS-P implicitly sets the protection mechanism and is therefore in direct disagreement with RFC 2228. CuteFTP does support AUTH SSL, and subsequently sets the protection mechanism explicitly using the PROT command and its approved arguments.

**Explicit "AUTH TLS"** - This is an SSL v3.1 connection over a standard port (21) and explicitly setting the protection mechanism. This is the version that best adheres to RFC 2228, "FTP Security Extensions." This version is supported by CuteFTP and is selected by default when you establish a new SSL connection.

Apart from those mentioned above, CuteFTP does not connect to servers requiring "AUTH TLS-P" or other deprecated SSL connection mechanisms.

**Unable to Connect to Titan FTP Server when Using SSL**

You must use encryption for every session for every new transfer by disabling the reuse of cached sessions for data connection.

**To require encryption of every session for every new transfer**

1. On the main menu, click Tools > Global Options (or press ALT+F7).
3. Clear the Reuse cached session for data connection (required by some servers) check box to require encryption of every session for every new transfer, then click OK.
Chapter 7. SSH2 Connections (SFTP)

The topics below provide the procedures for defining SSH2 (SFTP) connections with CuteFTP. See also: Connecting to Secure Shell (SSH2) Sites

**SFTP in CuteFTP**

When you connect with SSH2 there are two components or layers involved: the Transport and Authentication layers.

**Transport Layer**

When you first attempt to connect to an SSH2 Site, CuteFTP and the server determine whether the transmission should be:

- Encrypted or clear
- Compressed or uncompressed
- Which Method Authentication Code (MAC) to use
- Which kind of encryption (cipher) to use

Once the encryption method is chosen, the following occurs:

1. The server sends a public key to CuteFTP.
2. CuteFTP generates a session key, and encrypts it with the server's public key.
3. CuteFTP then sends the encrypted session key back to server.
4. The server then decrypts the session key with its private key and, from that time on, all transmitted data is encrypted with the session key.

**Authentication Layer**

After the Transport Layer is established, the server attempts to authenticate the client.

Common methods for establishing user authentication include:

- **Public Key Authentication Method: public key**
  
  To use this method, you will need your private key and your public key, which is passed to the server. The server encrypts a random number with your public key and sends it to you.
  
  1. If you have not already entered your passphrase in SSH2 security settings, CuteFTP asks you for your passphrase to activate the private key.
  2. The private key decrypts the number and sends it back to the server.
  3. The server recognizes the number as correct and allows the connection.

- **Password Authentication Method: password**
  
    o Using this method, the client sends its password to server. The client does not need to encrypt the password explicitly, because the SSH2 Transport layer automatically encrypts it. This is the default in CuteFTP. With this type of authentication, the connection fails if the Transport Layer cannot encrypt the data.

After the encryption method is established and authentication is complete, the two systems are ready to exchange secure data. CuteFTP sends a secured FTP connection along the encrypted data tunnel, the remote system and responds and you can begin transferring files securely.
Transport Layer Settings

To select Message Authentication Codes (MAC)
Message Authentication Codes are algorithms used to confirm data has not been altered between the client and server.

1. On the main menu, click **Tools > Global Options**, or press ALT+F7.
2. Expand the **Security** node, then click **SSH2 security**.
3. In the **MAC** list, specify at least one Message Authentication Code.
4. Click **OK**. CuteFTP tries each selected MAC with the server starting with the top method in the **MAC** list.

To select encryption methods (ciphers)

1. On the main menu, click **Tools > Global Options**, or press ALT+F7.
2. Expand the **Security** node, then click **SSH2 security**.
3. In the **Cipher** list, specify at least one encryption method.
4. Click **OK**. CuteFTP tries each selected encryption method with the server starting with the top method in the **Cipher** list.

Authentication Layer Settings

To use public key authentication
If you want to use public key authentication, you will need to send your public key to the server administrator before you will be able to make an SSH2 connection.

1. On the main menu, click **Tools > Global Options**, or press ALT+F7.
2. Expand the **Security** node, then click **SSH2 security**.
3. Select the **Use public key authentication** check box. You are using public key authentication whenever the check box is selected, even if the box and check are dimmed.
4. Click **OK**.

To use password authentication

1. On the main menu, click **Tools > Global Options**, or press ALT+F7.
2. Expand the **Security** node, then click **SSH2 security**.
3. Select the **Use password authentication** check box. You are using password authentication whenever the check box is selected, even if the box and check are dimmed. If you have upgraded to CuteFTP v9 and are using key pairs created with CuteFTP v8, if the password for an existing key contains any Extended ASCII characters, the password will not work. You will have to reenter the password after upgrading to v9.
4. Click **OK**.

---

You have to use at least one authentication method for an SSH2 connection. You can use both methods for the same SSH2 connection.
Authenticating in SSH2

You can use Password, Public Key, or both authentication methods for SSH2 connections. Password authentication is the default.

To use password authentication

1. On the main menu, click Tools > Global Options, or press ALT+F7.
2. Expand the Security node, then click SSH2 security.
3. Make sure the Use password authentication check box is selected. You are using password authentication whenever the check box is selected, even if the box and check are dimmed. If you have upgraded to CuteFTP v9 and are using key pairs created with CuteFTP v8, if the password for an existing key contains any Extended ASCII characters, the password will not work. You will have to reenter the password after upgrading to v9.
4. Click OK.

**Password authentication uses the FTP Site login password for authentication, not the passphrase used to decrypt the identity file’s private key shown in the field beneath the Use password authentication check box.**

To use public key authentication

1. On the main menu, click Tools > Global Options, or press ALT+F7.
2. Expand the Security node, then click SSH2 security.
3. Select the Use public key authentication check box. You are using public key authentication whenever the check box is selected, even if the box and check are dimmed.
4. Click OK.

**To use public key authentication, you will need to send your public key to the server administrator before making an SSH2 connection. If the server is running OpenSSH, you will need to convert the public key as described below.**

5. Create an identity file in the client.
6. Send the public key (Identity.pub) to the server administrator (via FTP, e-mail, etc.)
7. The server administrator must convert the public key to OpenSSH, check it with wordcount, and add it to authorized_keys.
   
   Command sequence:
   ```
   ssh-keygen -i -f Identity.pub > sshpub
   wc sshpub
   cat sshpub > ~\.ssh\authorized_keys
   ```

**Word count should return a "1" as the first number. OpenSSH asks for the identity files password the first time you log in. If CuteFTP fails to connect, contact our support team and provide the kernel version, OpenSSH build, and the CuteFTP build number. (To view the build number, on the main menu, click Help > About.)**
SSH2 Security Settings

To edit the SSH2 security settings

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Security** node, then click **SSH2 Security**. The **SSH2 Security** options appear.
3. In the **Cipher** list, select the check box for every cipher (encryption algorithm) you want available for SSH2 connections. See **Learning about SSH2** for an explanation of the algorithms. Clear the check box for any cipher you do not want available for SSH2 connections.
4. In the **MAC** list, select the check box for every MAC (Message Authentication Code) you want available for SSH2 connections. See **Learning about SSH2** for an explanation of MACs. Clear the check box for any MAC you do not want available for SSH2 connections.
5. **Priority** - Use the Priority arrows to determine the level of precedence for the selected schemes. Move your preferred cipher or MAC to the top of the list by highlighting it and clicking the up arrow outside the list. Move your least preferred Cipher or MAC to the bottom of the list by highlighting it and clicking the down arrow outside the list.
6. Select the **Use data compression** check box to compress transfers if the server will allow it. Clear the check box to refuse transfer compression.
7. Select the **Use password authentication** check box to sign on to SSH2 servers with a password (entered in your Site Manager). Clear this check box to use public/private key authentication only. You can clear this box only if you have already selected the **Use public key authentication** check box. If you have upgraded to CuteFTP v9 and are using key pairs created with CuteFTP v8, if the password for an existing key contains any Extended ASCII characters, the password will not work. You will have to reenter the password after upgrading to v9.
8. Select the **Use public key authentication** check box to sign on to SSH2 servers with a certificate (identity file). Clear this check box to only sign on to SSH2 servers with a password.
   - In the **Public Key Path** box, browse or type the location of the Public Key file on your local computer.
   - In the **Private Key Path** box, browse or type the location of the Private Key file on your local computer.
   - In the **Use Passphrase** box, type the appropriate passphrase for decrypting the key listed in **Private Key Path**.
   - In the **Confirm Passphrase** box, type the same passphrase again for the key listed in **Private Key Path**.

   *The private key password is stored in the registry using strong encryption. For added security, leave the passphrase fields blank. CuteFTP prompts you for the private key password when necessary.*

   - Click **Create identity file** to create a new Public/Private key pair. For instructions on key pair creation see **Creating SSH2 key pairs**.
   - Click **Trusted identity list** to open the **Certificate Manager** to see a list of public keys that you have accepted as valid. In the Certificate manager:
     - Select **Import** to add a public key to the trusted list.
     - Select **Export** to send a highlighted public key to a location or program.
     - Select **Remove** to delete a highlighted public key from the trusted list.
SSH2 Connections (SFTP)

SSH2 connections require at least one authentication method, but may require more than one. Check with your server administrator when in doubt. To use public key authentication, you must send your public key to the server administrator before making an SSH2 connection.

9. Select the **Enable SSH operation logging with verbosity level** check box, then specify one of the following levels:
   - 0, 1, 2) Software malfunctions (0-2 should also be logged using log event)
   - 3) External non-fatal high level errors (incorrect format received from an outside source; failed negotiation)
   - 4) Positive high level info (succeeded negotiation)
   - 5) Start of a high or middle level operation (start of a negotiation; opening of a device)
   - 6) Uncommon situations which might be caused by a bug
   - 7) Nice-to-know info (entering or exiting a function; result of a low level operation,
   - 8) Data block dumps (hash, keys, certificates, other non-massive data blocks)
   - 9) Protocol packet dumps (TCP, UDP, ESP, AH)

10. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**Creating SSH2 Key Pairs**

To create your own Private and Public key for SSH2 connections

1. On the main menu, click **Tools > Global Options**, or press ALT+F7.
2. Expand the **Security** node, then click **SSH2 security**.
3. Click **Create identity file**. The **Create public/private key pair** wizard appears.

4. In the Key type box, click **RSA** or **DSA**. CuteFTP only supports two algorithms for SSH2 keys: ssh-dss (DSA) and ssh-rsa (RSA). A DSA key is required for SSH2, an RSA key is recommended.
5. Click **Next**. The password page appears.

6. In the **Passphrase** and **Confirm Passphrase** boxes, type any combination of characters and spaces, then click **Next**. The output locations page appears.

7. In the **Private key filename** box, type or click the folder icon to specify the location at which to store the private key, then type a name for the key at the end of the path.

8. In the **Public key filename** box, type or click the folder icon to specify the location at which to store the public key. Make sure the filename extension is .pub and the file name matches.

9. In the **Key length** box, specify a key length between 1024 and 4096 bits. Shorter keys are faster but less secure; longer keys are more secure but slow connections.

10. Click **Finish**. CuteFTP generates the keys. Longer keys take more time to generate.

11. A confirmation message appears with the path and name of the keys. If you want CuteFTP to use the keys just generated, select **Yes**.
12. Click **OK** to close the **Global Options** dialog box.

---

**For added security, before closing the Global Options dialog box, clear the Passphrase and Confirm passphrase fields in the SSH2 Security page. CuteFTP then prompts for the identity file’s secret key passphrase when required for connection to a SFTP Site.**

---

**Using SSH2 Key Pairs**

You can authenticate SSH2 connections with a certificate (public key). To use “public key authentication,” you must send your public key to the server administrator before making an SSH2 connection. If the server is running OpenSSH, you must convert the public key as described below.

*If you have upgraded to CuteFTP v9 and are using key pairs created with CuteFTP v8, if the password for an existing key contains any Extended ASCII characters, the password will not work. You will have to reenter the password in Tools > Global Options > Security > SSH2 Security.*

---

**To use public key authentication in SSH2**

1. Create an SSH2 key pair.
2. Send the Public key to the SSH2 server administrator.
3. On the main menu, click **Tools > Global Options**, or press **ALT+F7**.
4. Expand the **Security** node, then click **SSH2 security**.
5. Select the **Use public key authentication** check box.
6. In the **Public key path** and **Private key path** boxes, specify the path to your public and private keys.
7. In the **Use Passphrase** and **Confirm passphrase** boxes, type the passphrase for the key.
8. Click **OK**.

*The private key and passphrase are never transmitted over a connection. When the server attempts to authenticate:*

1. The server encrypts a random number with your public key and sends it to you.
2. If you have not entered your passphrase in **SSH2 security settings**, CuteFTP asks you for your passphrase to activate the private key.
3. The private key decrypts the number and sends it back to the server.
4. The server recognizes the number as correct and allows the connection.

---

**To convert the public key**

1. Create an identity file in the client.
2. Send the public key (Identity.pub) to the server administrator (via FTP, e-mail, etc.)
3. The server administrator must convert the public key to OpenSSH, check it with **wordcount**, and add it to **authorized_keys**.

   Command sequence:
   ```
   ssh-keygen -i -f Identity.pub > sshpub
   wc sshpub
   cat sshpub > ~/.ssh/authorized_keys
   ```

*Word count should return a “1” as the first number. OpenSSH asks for the identity files password the first time you log in. If CuteFTP fails to connect, contact our support team and provide the kernel version, OpenSSH build, and the CuteFTP build number (located under Help > About).*
Troubleshooting SFTP Connections

You cannot connect with SFTP simply by configuring the proxy settings in Global Options. CuteFTP does not support using SFTP through a proxy server that is **not** a SOCKS proxy server. Non-SOCKS servers are "protocol dependent," meaning that if it is an FTP server, you must use FTP and if it’s an HTTP server, you must use HTTP. SOCKS proxy servers are not protocol dependent. A SOCKS proxy server works for any TCP/IP socket connection, so the protocol should not matter.

**If you are having difficulty connecting to your SFTP server, do the following:**

1. Verify that the server you are connecting to supports **SFTP connections**.

2. **CuteFTP supports SFTP, a secure service provided by the SSH2 host in which the server both encrypts the data and handles the file transfer. This should not be confused with FTP over SSH2, in which SSH2 uses port forwarding capabilities to forward standard FTP transactions through an encrypted tunnel but the actual file is transferred by a separate, non-secure FTP server. If you are unsure if the host is supporting SFTP, check the connection port. SFTP usually occurs over port 22.**

3. Try toggling the **compression options** in the **SSH2 Security** page.
4. Verify the authentication mechanism supported and required by the server. It may require **password, public key** (identity file), or **both** (see note below).
5. If public key authentication is required, be sure to provide a copy of the public key you created to the server’s administrator, as it must be in the server’s **trusted list** in order for you to connect.
6. If the server administrator created a public key for you, be sure to replace your existing one with it and select the provided key from within the **SSH2 Security** page.
7. **Copy the connection log to a text file or email** to assist in troubleshooting when contacting your FTP or Web service provider or the Globalscape support team.

**To use public key authentication, you must send your public key to the server administrator before making an SSH2 connection. If the server is running OpenSSH, convert the public key.**

Cannot Connect to SSH2 (SFTP) Sites

CuteFTP supports SFTP, which is a secure service provided by the SSH2 host, in which the server both encrypts the data and handles the file transfer. This should not be confused with FTP over SSH2, in which the SSH2 uses port forwarding to forward standard FTP transactions over an encrypted tunnel, with the actual file transfer being handled by a separate (and non-secure) FTP server.

**SSH2 connections** will fail if the client or server is not properly configured. If you are having difficulty connecting to your SFTP server, try the following:

**SSH2 Connection Checklist**

1. Verify that the server you are connecting to supports **SFTP connections**.
2. **Verify the connection port.** SFTP usually occurs over port 22.
3. Try toggling the **compression options** in the **SSH2 Security** page.
4. Verify the authentication mechanism supported and required by the server. It may require **password, public key** (identity file), or both (see note below).
5. If public key authentication is required, be sure to provide a copy of the public key you created to the server’s administrator, as it must be in the server's trusted list in order for you to connect.
6. If the server administrator created a public key for you, be sure to replace your existing one with it and **select the provided key** from within the **SSH2 Security** page.
7. Copy the connection log to a text file or email message to assist in troubleshooting when contacting your FTP or Web service provider or the Globalscape support team.

Public key authentication

To use public key authentication, you must send your public key to the server administrator before making an SSH2 connection. If the server is running OpenSSH, convert the public key as described below.

To convert the public key

1. Create an identity file in the client.
2. Send the public key (Identity.pub) to the server administrator (via FTP, e-mail, etc.)
3. The server administrator must convert the public key to OpenSSH, check it with wordcount, and add it to authorized_keys.

```
Command sequence:
ssh-keygen -i -f Identity.pub > sshpub
wc sshpub
cat sshpub > ~\ssh\authorized_keys
```

Wordcount should return a “1” as the first number. OpenSSH is going to ask for the identity files password the first time you log in. If CuteFTP fails to connect, contact our support team and provide the kernel version, OpenSSH build, and the CuteFTP build number. The CuteFTP build number appears in the About dialog box. (On the main menu, click Help, then click About.)

SFTP Errors

Refer to the Globalscape Knowledgebase for details of the following SFTP errors:

- "SFTP21 error = #0 The file being transferred in ASCII mode appears to be a Binary file. Proceed anyway?": [http://kb.globalscape.com/KnowledgebaseArticle10356.aspx](http://kb.globalscape.com/KnowledgebaseArticle10356.aspx)
- "SFTP21 error = #0. 0 Can't connect to sftp.xxxxx.com:22": [http://kb.globalscape.com/KnowledgebaseArticle10606.aspx](http://kb.globalscape.com/KnowledgebaseArticle10606.aspx)
- "SFTP21 error = #4 Algorithm negotiation failed": [http://kb.globalscape.com/KnowledgebaseArticle10351.aspx](http://kb.globalscape.com/KnowledgebaseArticle10351.aspx)
- "SFTP21 error = #4 No further authentication methods available": [http://kb.globalscape.com/KnowledgebaseArticle10352.aspx](http://kb.globalscape.com/KnowledgebaseArticle10352.aspx)
- "SFTP21 error = #7 Connection to the server was lost": [http://kb.globalscape.com/KnowledgebaseArticle10353.aspx](http://kb.globalscape.com/KnowledgebaseArticle10353.aspx)

Public Key Authentication Fails

After you set up an account for public key authentication, you still have to enter a password the first time you log in. When you set up public key authentication for an account and set the authentication type to **Pwd OR Key**, WinSSHD still must cache the password so that you can log in with just the public key. Therefore, on your first login attempt after you set up public key authentication, WinSSHD asks you for a password to store in the cache, even if your client already authenticated successfully using a public key. When this happens, just supply a valid password. When you log in after that, the password will be cached and you will not have to provide it again.
This page left blank for 2-sided "book" printing.
Chapter 8. Transferring Files and Folders

The topics below provide procedures for transferring files and folders between your local hard drive and a remote server. (For the procedures for file and folder management, see Managing Files and Folders.)

Transferring Files and Folders

Besides just clicking and dragging the item that you want to transfer from one pane to the other, you can also:

- Multi-select and drag items as group. (SHIFT + click for contiguous items; CTRL + click for non-contiguous items.)
- Drag items to the Queue to upload them later.
- Select an item or group of items in Windows Explorer, then right-click and click Upload.

To upload files (transfer from a local to remote computer)

1. Connect to a remote site.
2. In the Local pane, locate the files or folders that you want to upload.
3. Click and hold the mouse button while dragging the item(s) from the Local pane to the Remote pane or Queue pane.
4. Release the mouse button. The items are copied (not moved) to the remote server or to the Queue pane for later uploading.

To download files (transfer from a remote to a local computer)

1. Connect to a remote site.
2. In the Remote pane, locate the files or folders that you want to download.
3. Click and hold the mouse button while dragging the item(s) from the Remote pane to the Local pane or Queue pane.
4. Release the mouse button. The items are copied (not moved) to your local location or to the Queue pane for later downloading.

Transfer Settings

Many of these controls are intended for advanced users only. For example:

- The REST/APPE sequence is only intended for problem servers that do not support the proper resume sequence.
- Transfer type should only be changed when you need to force files to transfer a certain way.
- The data port mode should only be changed if you are having problems establishing a data connection (on LIST or RETR for example). Limiting the local port range can have adverse affects when transferring many small files over a narrow range of ports.

To access transfer settings

1. On the main menu, click Tools > Global Options (or press ALT+F7).
2. Expand the Transfer node. The Transfer options appear.
3. In the Transfer method box, specify one of the following methods:
   - Choose Auto-detect to have CuteFTP decide the transfer method based on the file and server type.
- Choose **ASCII** to transfer text files, web pages, or other text type files.
- Choose **Binary** to transfer pictures, programs, or executable files.

**Binary files cannot be transferred in ASCII mode, but ASCII files can be transferred in Binary mode.**

4. In the **Data mode** box, specify one of the following modes:

- **Auto** - CuteFTP makes connections in PASV mode. If the PASV connection fails, CuteFTP attempts to connect in PORT mode automatically.
- **PASV** - Helps avoid conflicts with security systems. PASV support is necessary for some firewalls and routers, because with PASV, the client opens the connection to an IP Address and port that the server supplies.
- **PORT** - Connections or transfer attempts fail in PASV mode or when you receive data socket errors. When an FTP client connects using PORT, the server opens a connection to an IP Address and port that the client supplies.
  - If you connect in PORT mode, your session becomes vulnerable to "Port theft," which means that a third party can interfere with transfers.
- **EPRT** - An extension of PORT command designed for communicating the client’s data connection IPv6 address and port, but used presently used in CuteFTP for communicating its IPv4 address and port. It is useful for negotiation through NAT firewalls.
- **EPSV** - An extension of PASV command designed for requesting the server’s data connection port; present CuteFTP assumes IPv4 network protocol and is useful for negotiation through NAT firewalls.

**EPRT and EPSV were designed for communicating IP and data port information for IPv6 addresses. This feature is primarily used for improving firewall traversal of NAT firewalls for secure (FTPS) connections. Read RFC 2428 for more details. Note that each site in the Site Manager is currently able to either inherit global settings for Data Mode or define its own. Therefore the EPRT and EPSV choices are also available at the Site level (Site Properties > Type tab).**

5. Select the **Allow transfers to occur over the existing (browse) session** check box to transfer files over new and existing sessions. CuteFTP uses the browse session and if available, additional connections. For example, if you define a per site max limit of five connections and then transfer five files, CuteFTP checks the browse connection first to see if it is busy, and if not busy, transfers the 1st file over the browse connection. The subsequent four files are transferred over four additional sessions. CuteFTP automatically adjusts for allowed connections (both from the client and server perspective) and whether or not it can use the browse session.

- Clear the check box to transfer files over new sessions only. Use this option if your server allows multiple connections, is quick to respond, and you want to navigate the site while downloading. All transfers are forced over new connections, freeing up the browse session so you can continue to navigate. The only time this could cause a problem is when the server either refuses to allow multiple connections or is slow to log into.
• If you select the check box, then press CTRL when transferring files, files transfer over the existing session only. To use this, select the files you want to transfer, then press and hold the Ctrl key while you drag and drop the files into the destination folder. This forces CuteFTP to transfer all the files on the existing session. Transferring files using only the currently logged in session can reduce overhead in certain situations. For example, a transfer of a large number of small HTML files can often be done much faster if limited to the current connection rather than performing a full TCP/IP connection and FTP login (and possibly FEAT/CWD/LIST) sequence first.

6. In the **Filename encoding** areas, click **UTF-8**, **ASCII**, or **Auto-detect**.

7. In the **When selecting MAX in a multi-part transfer use** box, specify the number of parts to split a file into when a max **multi-part transfer** is requested.

8. In the **Global bandwidth limit** box, specify the number of kilobytes per second to throttle the bandwidth of all sessions on CuteFTP. If this is set to 0 (the default), there is no throttling.

9. In the **Reconnect and resume in** box, specify the time that CuteFTP waits to try again after an interrupted or failed download. Select a time between 0 and 1,000 seconds (about 17 minutes).

10. In the **Roll back (retry at byte offset)** box, specify the number of bytes prior to the transfer failure CuteFTP resends when attempting to finish an interrupted transfer. Select between 0 and 65536 bytes.

11. Select the **Send REST command prior to APPE when resuming a transfer** check box to send the **REST** (Restart) command to resume a transfer, before sending the **APPE** (Append) command. Clear this check box to send the **APPE** (Append) command to resume a transfer without first sending the **REST** ( Restart) command.

12. In the **Receive buffer** and **Send buffer** boxes, specify the number of bytes for the send and receive buffers. The default setting for both send and receive is 65536 bytes. It is unlikely you will ever need to adjust these settings, but if you have problems with dropped transfers, you can use them to fine tune transfers over high latency or lossy connections like those over satellite links or with legacy CDMA wireless connections. For more, refer to [Improving Slow Transfers](#).

13. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

### Startup and Exit Options

By default, the Transfer Engine (TE) starts when Windows starts up. You can change this setting in the **Global Options** dialog box. You can also configure whether the Transfer Engine remains running or closes when Windows closes.

**To specify TE startup and exit options**

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).

2. Expand the **General** node. The **General** options appear.

3. To start the Transfer Engine automatically when your computer boots up, select the **Start the Transfer Engine on Windows startup** check box. When not selected, the Transfer Engine does not start until you start CuteFTP or call it from a script.

4. In the **On exit** box, specify one of the following actions:

   • **Don't close the Transfer Engine if tasks are pending** - Completes unfinished or scheduled transfers after CuteFTP is closed. The Transfer Engine automatically shuts down after the last scheduled transfer.
• **Don't close the Transfer Engine** - Leaves the Transfer Engine running even when CuteFTP is closed and there are no transfers to complete. The Transfer Engine stays open until the computer is shut down or you close the Transfer Engine from the System Tray.

• **Close the Transfer Engine** - Shuts down the Transfer Engine whenever you close CuteFTP.

5. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

### Smart Overwrite Settings

When you try to transfer a file to a destination with a file of the same name, use Smart Overwrite to determine the proper action to take. Smart overwrite settings apply to both uploads and downloads. Some servers are **case sensitive**. Such servers will not recognize files names as identical if the letter case of the two file names does not match.

**To configure the Smart Overwrite settings**

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Transfer** node, then click **Smart Overwrite**. The **Smart Overwrite** options appear.
3. In the **For matching files** box, click one of the following actions:
   - **Prompt** - CuteFTP displays a window asking you to overwrite or skip the file in the destination folder that has the same name as the file you are transferring.
   - **Overwrite** - If a file in the destination folder has the same name as the file you are transferring, CuteFTP replaces the destination file with the transferred file.
   - **Skip** - If a file in the destination folder has the same name as the file you are transferring, CuteFTP does not transfer the file and leave the destination file as it is.
   - **Rename** - If a file in the destination folder has the same name as the file you are transferring, CuteFTP asks you for a new file name for the transferred file.
   - **Resume** - If a file in the destination folder has the same name as the file you are transferring, CuteFTP treats the destination file as an incomplete transfer. If the destination file is already a complete file, the transferred file replaces the destination file.
   - **Numerate** - If a file in the destination folder has the same name as the file you are transferring, CuteFTP renames the transferred file to 'Copy of file.txt'. If the same transfer occurs again, CuteFTP renames the transferred file to 'Copy (2) of file.txt'.

   - **Use Rules** - If a file in the destination folder has the same name as the file you are transferring, CuteFTP uses the rules you define in the **Overwrite Rules** dialog box (see below).

4. The **Ignore Zero Byte File** check box applies only when attempting to transfer a file > 0 bytes to a destination where the same filename exists AND the destination filesize equals 0. If the destination file = 0 bytes and the source file also = 0 bytes, then the file transfer will be skipped and Smart Overwrite rules and the **Ignore zero byte file** check box will be ignored. No Smart Overwrite rules are applied because it doesn't make sense to transfer a 0 byte file that will replace another 0 byte file. Do one of the following:
   - Select the **Ignore Zero byte files** check box - CuteFTP will overwrite the destination file.
   - Clear the **Ignore Zero byte files** check box - CuteFTP will invoke the configured Smart Overwrite file/folder settings.
5. In the **For matching folders** box, click one of the following actions:
   - **Prompt** - CuteFTP displays a window asking what you want to do to a folder in the destination folder that has the same name as the folder you are transferring.
   - **Replace All** - If a folder in the destination folder has the same name as the folder you are transferring, CuteFTP replaces every destination file with matching names with files in the transferred folder.
   - **Use Rules** - If a folder in the destination folder has the same name as the folder you are transferring, CuteFTP uses the rules you define in the **Overwrite Rules** dialog box to determine how to handle all files with matching names.

6. Click **Configure Rules** to open the **Overwrite Rules** dialog box to define the rules you want CuteFTP to use when two files have the same name. You must select **Use rules** in the **For matching folders** box to enable these options.

7. In the **If destination file date is** box, click one of the following options:
   - **newer** replaces a file if it has a time stamp more recent than the file you are transferring.
   - **no matter** replaces any file regardless of when it was created in relation to the file you are transferring. Select this option if you do not want to replace files based on when they were created.
   - **older** replaces a file only if it has a time stamp further in the past than the file you are transferring.
   - **the same** replaces a file if it has the same time stamp as the file you are transferring.
   - **different** replace a file if it has a time stamp that is older or newer than the file you are transferring.

8. In the **and size is** box, click one of the following options:
   - **larger** replaces a file if it is larger than the file you are transferring.
   - **no matter** replaces a file regardless of its size. Select this option if you do not want to replace files based on their size in relation to the file you are transferring.
   - **smaller** replaces a file if it is smaller than the file you are transferring.
   - **the same** replaces a file if it is same size as the file you are transferring.
   - **different** replaces a file if it is larger or smaller than the file you are transferring.
9. In the during box, click one of the following options:
   - **any transfer** replaces files whether you are uploading or downloading.
   - **download** replace only the files on the local computer with files transferred from a remote Site.
   - **Site to Site transfer** replaces files when with the same name when transferring from one remote Site to another.
   - **upload** replace only the files on the remote Site with files transferred from the local computer.

10. In the then box, click one of the following options:
    - **overwrite** completes the transfer by replacing the file that is in the destination folder.
    - **numerate** completes the transfer by renaming the transferred file with "Copy (n) of..." added before the name.
    - **resume** treats the transfer as an attempt to continue an interrupted transfer.
    - **show prompt** pauses the transfer and display the message that asks the user which action to take.
    - **skip** cancels the transfer and leave the original file in the destination folder.

11. Click **Add** to places the rule into the list. If you are using rules, CuteFTP checks every rule in the list during all transfers.

12. Click **Remove** to delete a rule you have highlighted in the list and CuteFTP will no longer use the rule when it encounters two files of the same name.

13. Click **Defaults** to delete every rule from the list.

For more information, see Smart Overwrite Example.

14. The **Prompt timeout action** box, defines the action CuteFTP takes if no rules apply, or if you enable a timeout value. When you select the **Timeout in n seconds** check box, a prompt appears, but after waiting the defined amount of time, CuteFTP takes one of the following actions if a file in the destination folder has the same name as the file you are transferring:
   - **Overwrite** - Replaces the destination file with the transferred file
   - **Skip** - Does not transfer the file and leaves the destination file as it is
   - **Rename** - Asks you for a new file name for the transferred file
   - **Resume** - Treats the destination file as an incomplete transfer. If the destination file is already a complete file, the transferred file replaces the destination file
   - **Numerate** - Renames the transferred file to Copy of file.txt. If the same transfer occurs again, CuteFTP renames the transferred file to Copy (2) of file.txt.

15. Select the **Resend LIST command as necessary** check box to use the LIST command to retrieve file details and determine similarities and differences between a transferring file and destination file with the same name. Clear this check box and CuteFTP does NOT use the LIST command.

16. Select the **Use SIZE and MDTM commands to gather precise details** check box to use the SIZE command to retrieve file size and the MDTM command to retrieve file modification time to determine similarities and differences between a transferring file and destination file with the same name. If you clear this check box, CuteFTP will NOT use the SIZE and MDTM command.
17. Select the **Compare using XCRC and overwrite, skip, or resume accordingly** check box to use file integrity checking (cyclical redundancy checksums) to determine overwrite, skip or resume status based on similarities and differences between a source and destination file with the same name.

   *This feature only works with Globalscape Secure Server and EFT Server. **Compare using XCRC** takes precedence over standard overwrite action settings.*

18. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

### Default Download Folder

In the **Global Options** dialog box, you can specify which folder on your hard drive is the default folder for downloads from your remote site. You can specify that whichever folder is displayed in the local pane is the download location, or specify another folder.

**To specify a default download folder**

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **General** node. The **General** options appear.
3. In the **Download folder defaults** area, do one of the following:
   - To download remote items that were dragged to the queue to the folder displayed in the **Local Drives** pane, select the **Use the current folder in the local pane as the default** check box.
   - To provide a path to a specific folder, clear the **Use the current folder in the local pane as the default** check box, then in the **Use** box, browse for or type the path to a download location for remote items that you place in the queue. All remote items dragged to the queue are downloaded to the specified folder.
4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

### Rename Rules

You can configure CuteFTP to change the name of files automatically as they transfer.

**To configure the Rename Rules**

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Transfer** node, then click **Rename Rules**. The **Rename Rules** options appear.
3. Configure options as described below.
   - Select the **Apply auto-rename rules to transfers** check box to change the names of transferred files with names that appear in the **Rename Rules** list. Clear this check box and CuteFTP will not rename any files.
   - To create an auto-rename rule, type the original file name in the text box on the upper left, type the desired new file name in the text box on the upper right, then click **Add**.
   - To remove an auto-rename rule, in the **Rename Rules** list, click the rule you want to delete, then click **Remove**.
     - The rules are case sensitive.
     - These rules will apply to all uploads, downloads, and Site-to-Site transfers.
You can create rules with wildcard masks to change just the extension of several files of the same type. For example, if your .jpg files need the extension in upper case (.JPG) on the server, create the rule:

<table>
<thead>
<tr>
<th>Rename from</th>
<th>Rename to</th>
</tr>
</thead>
<tbody>
<tr>
<td>*.jpg</td>
<td>*.JPG</td>
</tr>
</tbody>
</table>

You can create a rule to strip extensions from file names. For instance if you want to transfer a file called "index.htm" as simply "index" add this rule to your list:

<table>
<thead>
<tr>
<th>Rename from</th>
<th>Rename to</th>
</tr>
</thead>
<tbody>
<tr>
<td>index.htm</td>
<td>index.*</td>
</tr>
</tbody>
</table>

4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**Symbolic Links**

In CuteFTP's **Global Options** dialog box, "link" refers to Unix symbol links, not Windows shortcuts. Symbolic links are similar to shortcuts, in that they point to items in other locations on a server. You can determine how CuteFTP handles symbolic links.

**To configure the Link options**

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Navigation** node, then click **Links**. The **Links** options appear.
3. Configure options as described below.

   - Select the **Attempt link resolution using LIST-L command** check box to send the LIST-L command instead of LIST to display folder contents. LIST-L attempts to list the actual file or folder rather than the link that points to the file or folder. Clear this check box to send just the LIST command to display folder contents and leave links in the list.

     **Servers are not always able to resolve links using LIST-L.**

   - Select one of the following options:
     - **Try to determine the link's target type by its extension** - CuteFTP tries to tell if the link points to a file or a folder. CuteFTP treats the link as if it were the item it references.
     - **Always assume the link is a file (don't attempt to resolve)** - treats symbolic links as files. CuteFTP removes the empty downloaded file from the local folder if the RETR command returns error.

       **This option is useful when you download large directories or folders with many files and subfolders.**

     - **Always assume the link is a folder (don't attempt to resolve)** - treats symbolic links as folders that you can double-click to see folder contents.

       **CuteFTP attempts to show the actual path of a file or folder link in the Remote pane, in the Name column. For example, a link to a file called archive.zip might display as .3/networks/bbs_info/archive.zip.**
4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**Queuing Files and Folders for Transfer**

CuteFTP allows you to drag items to the queue to download them later. From within the **Queue Window**, you can also **stop**, **resume**, or **restart** a transfer. For a description of the icons that appear in the **Queue Window**, see **Transfer Queue Icons**.

**To display or hide the queue**

1. On the main menu, click **View > Show Panes**.
2. Click **Queue & Log Pane** or click ALT+1 to display or hide it.

**To add items to the queue**

1. **Connect** to a Site. (You cannot drag items to the queue unless you are connected to a Site.)
2. **Locate** the files or folders you want to upload or download in your local or remote pane.
3. **Drag** the selected items to the transfer queue window.
4. **Repeat** as necessary. You can also connect to other Sites and add files and folders to the queue.
5. Once you have finished adding items to the transfer queue, you can change queue item attributes if desired, such as destination path, transfer type, scheduling, and so on by clicking the item, then pressing ALT+ENTER.
6. To **change the transfer priority** of an item, click it, then drag it up or down in the queue. A blue line appears to indicate where the item will be placed.
7. When you are ready to begin processing the queue, do one of the following:
   - On the main menu, click **Tools > Queue > Transfer All**.
   - Click to select one or more items in the queue, then click **Tools > Queue > Transfer Selected**.
   - Right-click in the queue, then click **Transfer All**.
   - Click to select one or more items in the queue, then right-click the selection and click **Transfer Selected**.

**Removing Items from the Queue**

You can remove items from the **Queue Window** that are ready for transfer, that have completed transfer, or that have failed transfer. As old items build up in the queue, it can consume large amounts of memory. You can either remove them manually or configure CuteFTP to remove successfully transferred items automatically.

**To remove selected items from the queue**

1. Click to select one or more items in the queue, then do one of the following:
   - On the main menu, click **Tools > Queue > Remove Selected**.
   - Right-click the selection and click **Remove Selected**.
   - Press DELETE.
   
   A confirmation message appears.
2. Click **Yes**.
To remove completed transactions from the queue

1. Do one of the following:
   - On the main menu, click **Tools > Queue > Remove Finished**.
   - Right-click in the Queue Window, then click **Remove Finished**.

   A confirmation message appears.

2. Click **Yes**.

To clear everything from the queue

⚠️ *If you remove everything from the Queue Window, you will also remove your Folder Monitor Rules!*

1. Do one of the following:
   - On the main menu, click **Tools > Queue > Remove All**.
   - Right-click in the Queue Window, then click **Remove All**.

   A confirmation message appears.

2. Click **Yes**.

To remove successful transfers from the queue automatically

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).

2. Expand the **Transfer** node, then click **Events**. The **Events** options appear.

3. Select the **Remove successful transfer items from the queue automatically** check box to erase items from the queue after they have transferred. Clear the check box to keep items in the queue even after they have transferred.

4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

Uploading Files from Anywhere in Windows

You can upload files from anywhere in Windows by selecting CuteFTP's Upload options from Window's context menu (usually a right-click). You must first add CuteFTP to the Windows Explorer right-click menu by selecting the **Shell integration** check box in **Global Options**.

To upload files in Windows

1. In Windows, right-click the file you want to upload to a server, click **Upload using CuteFTP**, then click **Connection wizard**. The **CuteFTP Connection Wizard** appears.

2. File the instructions in **Connecting to Sites Using the Connection Wizard** to define the Site connection options, then click **Finish**. Cute FTP connects to the Site, uploads the file, then saves the site in the **Site Manager** for future connections.
Transferring Files in Order

You can see the order in which queued items transfer at the left end of the Queue Window. The numbers in the column indicate the order of transfer. By default, files transfer in the same order that they are added to the queue.

To transfer items in the order added

1. Sort the Local or Remote pane by clicking on the corresponding column header (Name, Time, Size, etc.)
2. In the Local or Remote pane, click the item(s) to transfer, then drag the selected items into the queue. Note that the items are ordered in the same way they were sorted prior to adding them to the queue.
3. Right-click in the Queue Window, then click Transfer All. CuteFTP transfers the files in the order reflected by the numbers in the left column of the queue.

To set a specific transfer order

1. Move transfer items to the Queue Window as described above.
2. Click the pound sign (#) column header to sort the items by their transfer order.
3. Click an item in the Queue.
4. On the main menu, click Tools > Queue > Change Order.
   • To transfer the selected item first, click Move to Top (or press CTRL+SHIFT+T).
   • To transfer the selected item last, click Move to Bottom (or press CTRL+SHIFT+B).
   • To transfer the selected item before the previous item in the queue, click Move Up One (or press CTRL+SHIFT+U).
   • To transfer the selected item after the following item in the queue, click Move Down One (or press CTRL+SHIFT+D).

You can also change an item's place in the transfer order by clicking and dragging the item up or down in the queue. A blue line indicates where the item's new position in the queue will be after you release the mouse.

Navigation Options

To configure the navigation options

1. On the main menu, click Tools > Global Options (or press ALT+F7).
3. Configure options as described below.
   • In the When adding items to the queue box, click one of the following actions:
     o Transfer immediately to start transfer of the queued item as soon as it is dropped in the queue.
- **Suspend** to place the item in the queue, but to hold the transfer.
- **Schedule** to display the scheduling window when an item is placed in the queue.

- In the **When dragging an item to the local pane** box, click one of the following actions:
  - **Transfer to current folder** to send the dragged item to the folder currently listed in the Local Drives pane
  - **Transfer to default folder** to send the dragged item to the default transfer folder listed in General Settings
  - **Add to queue & suspend** to place the dragged item in the queue, but hold the transfer.

- In the **When double-clicking an item** box, click one of the following actions:
  - **Transfer immediately** to send the item to the displayed remote Site or the default download folder
  - **Add to queue & suspend** to place the double-clicked item in the queue, but hold the transfer
  - **Launch in viewer** to open the item in the File Viewer program chosen in **Helper Applications**
  - **Execute Open** to run the item if it is a program
  - **Edit** to open the item in the File Editor program chosen in **Helper Applications**

- Select the **Auto-refresh the remote pane after an upload** check box to update the remote folder's listing after every upload to that folder. Clear this check box to stop sending LIST requests to a remote Site after every upload.

- Select the **Use the logical parent (not physical parent) on CDUP command** check box to return to the folder you just linked from when clicking the **Move up directory** icon. Clear this check box to change to the actual folder the item resides in, and not a folder with a link to the item, when clicking the **Move up directory** icon.

- Select the **Link the remote and its associated local pane when working with multiple Sites** to tie the local and remote panes to each other. If you have more than one remote pane open and you switch between the remote panes, the last path in the local pane used for that remote pane is recalled. Clear this check box to retain the same path in the local pane regardless of the remote pane selected.

- Select the **Switch from the Site Manager to the Local Drives Pane upon connection** check box to display the Local Drives pane automatically when a connection is made. Clear this check box to leave the Site Manager displayed when a connection is made.

- Select the **Switch from the Local Pane to the Site Manager upon closing all connections** check box to display the Site Manager automatically when all connections are closed. Clear this check box to leave the Site Manager hidden when all connections are closed.

4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**Tolerance Settings**

Some servers treat PASV mode and links differently than others. Configure from the tolerance options to help CuteFTP connect to these servers.
To configure the Tolerance settings

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Navigation** node, then click **Tolerance**. The **Tolerance** options appear.
3. Configure options as described below.
   - When using PASV mode, select the **Use correct timing of PASV mode command** check box. This option works with most FTP servers. If you are having difficulty connecting in PASV mode, clear this check box.
   - To use the Print Working Directory (PWD) command to determine which remote folder is currently open on the server, select the **Use PWD to determine current folder** check box. Clear this check box and CuteFTP attempts to determine the current remote folder based upon the relative location from the root login folder. If your server does not support PWD, clear this check box.
   - To send the absolute path to the file to complete delete, download, or upload file operations, select the **Use absolute paths for DELE, RETR, and STOR commands** check box (e.g., "RETR /pub/cuteftp/cuteftp.exe"). If your server does not support absolute path names for these commands, clear this check box, and CuteFTP will send the relative path to the file instead (e.g., "RETR cuteftp.exe").
   - To use the complete absolute path to retrieve the listings for a folder, select the **Use absolute paths for the LIST command** check box. For example: "LIST /pub/cuteftp". If your server does not support absolute path names for the LIST command, clear this check box, and CuteFTP will use the relative file path to retrieve the listings for a folder (e.g., "LIST").
   - To retrieve a list of just file names for each folder, select the **Use NLST instead of LIST (retrieves an abbreviated listing)** check box. The list does not include time stamps, file size, or other details. Clear this check box to use the LIST command and retrieve a list with details for each file and folder. (Applies to FTP protocols only.)
   - To continue login attempts if the server returns permanent errors (5xx) inappropriately, such as when the server is full or busy, select the **Treat 5xx errors as 4xx errors during login** check box. To accept permanent errors, stop further connection attempts, and avoid being banned for hammering, clear this check box.

4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**Stopping Transfers**

You can stop in-progress transfers, remove items from the **Queue Window**, and reset failed transfers. To resume or restart a transfer, refer to **Resuming Transfers**.

**To stop a transfer**

1. Click the item(s) in the **Queue Window** to be stopped.
2. On the main menu, click **View > Stop** (or press ESC).

**To remove items queued for transfer**

1. Click an item in the **Queue Window**.
2. Do one of the following:
   - On the main menu, click **Tools > Queue > Remove Selected**.
   - Select one or more items in the queue, then right-click the selection and click **Remove Selected**.
   - Press DELETE.

3. A confirmation message appears. Click **Yes**.

   - **Remove All** deletes every file from the queue. **Remove Finished** deletes all of the items from the Queue Window that have completed their transfer.
   - The shortcut keys **ESC** or **F9** stop active transfers. Press **ESC** once to stop the last command (be it a transfer or connection request). Press **ESC** repeatedly to cycle through active transfers and/or connections and stop them one by one. You can also select multiple items in the queue and press **ESC** to stop them. Press DELETE to stop and remove selected queue items.

**TOC File Settings**

You may connect with remote folders that have Table of Contents (TOC) files. TOC files contain detailed information about the folder. In long and complicated directories, the TOC files can be quite large. If you download very large TOC files, they may interfere with CuteFTP’s performance or operation.

To configure the TOC File settings

1. On the main menu, click **Tools > Global Options** (or press **ALT+F7**).
2. Expand the **Navigation** node, then click **TOC Files**. The **TOC Files** options appear.
3. Configure options as described below.
   - Select the **Load TOC Files** check box to download TOC files automatically whenever connecting to a remote folder. If you clear this check box, TOC files are not downloaded.
   - In the **If the TOC file size exceeds n Kbytes, then prompt before loading** box, specify the maximum size (between 1 and 1,000 kilobytes) TOC file CuteFTP downloads without prompting for permission.
   - In the **TOC include masks** box, type file names or extensions that CuteFTP should consider as TOC files, then click **Add**. You can use wildcard masks. To remove a mask, click it in the list, then click **Remove**.
   - In the **TOC exclude masks** box, type file names or extensions that CuteFTP should NOT consider as TOC files, then click **Add**. You can use wildcard masks. To remove a mask, click it in the list, then click **Remove**.

   - The **TOC include masks** and the **TOC exclude masks** act as a double filter to help CuteFTP determine whether a file is a TOC file. For example, if you type `Index* in the TOC include masks and *.html in the TOC exclude masks`, a file named `Index.txt` would be considered a TOC file, but a file named `Index.html` would not.

4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.
Configuring Options for Completed Transfers
You can configure CuteFTP to disconnect, shut down, and/or log off after transfers have completed.

To access transfer event settings
1. On the main menu, click Tools > Global Options (or press ALT+F7).
2. Expand the Transfer node, then click Events. The Events options appear.
3. In the After all transfers have finished box, specify one of the following actions:
   - Do Nothing - Keep the connection and CuteFTP open after all transfers are complete.
   - Disconnect from Site - Close the connection, but keep CuteFTP open after all transfers are complete.
   - Disconnect and close program - Close all connections and close CuteFTP after all transfers are complete.
   - Disconnect from Internet - Close the dial-up connection automatically after all transfers are complete.
   - Shut Down Computer - Close all connections, close CuteFTP, close the dial-up connection, and shut down the computer after all transfers are complete.
   - Log Off - Log the current user off the computer automatically after all transfers are complete.
4. Click Apply if you are going to make changes to other pages; click OK to save changes and close the Global Options dialog box.

Preserving the Local Time Stamp
You can configure CuteFTP to keep a downloaded file's time stamp the same on the local computer as it is on the server and keep an uploaded file's time stamp the same on the server as it is on the local computer.

To specify time stamp settings
1. On the main menu, click Tools > Global Options (or press ALT+F7).
2. Expand the Transfer node, then click Events. The Events options appear.
3. Select the Preserve remote time stamp for downloaded files check box to keep a downloaded file's time stamp the same on the local computer as it is on the server. Clear the check box to allow the local computer to give downloaded files a new time stamp.
4. Select the Preserve the local time stamp for uploaded files if the server allows MFMT check box to keep an uploaded file's time stamp the same on the server as it is on the local computer. Clear the check box to allow the server to give uploaded files a new time stamp.
5. Click Apply if you are going to make changes to other pages; click OK to save changes and close the Global Options dialog box.
**Resuming Transfers**

CuteFTP automatically attempts to resume interrupted transfers caused by lossy connection, server-kicked users, a slow server, and so on. CuteFTP does not auto-resume interrupted transfers when the remote server is unreachable (i.e., there is no connection available, the server is down, or for any other reason). In those situations, you must manually resume the transfer.

> **In you have not shut down and restarted CuteFTP since the interruption took place, CuteFTP assumes that the transfer is within its original context and attempts to resume it from the point it left off. If the transfer is no longer in the original context, CuteFTP prompts you to overwrite the destination file; that is, to start over. You can set up overwrite rules to tailor such situations to your specific needs.**

To resume a stopped transfer

- In the **Queue Window**, click the stopped item, then do one of the following:
  - On the main menu, click **Tools > Queue > Transfer Selected**.
  - Right-click the item, then click **Transfer Selected**.

To reset a failed transfer

- In the **Queue Window**, click the stopped item, then do one of the following:
  - On the main menu, click **Tools > Queue > Reset Selected**.
  - Right-click the item, then click **Reset Selected**.
  - To restart the transfer, click **Tools > Queue > Transfer Selected**.
  - Right-click the item, then click **Transfer Selected**.

**Specifying Time CuteFTP Waits after a Transfer Completes**

You can configure CuteFTP to keep a thread open for a specific number of seconds after a transfer is complete. Leaving data connections open allows more transfers to use the same connection, avoiding the need to open new connections.

A “file transfer thread” is a connection (session) to the server. After a file is successfully transferred, CuteFTP does not close the corresponding connection (session) to the server during the next 30 seconds in case there are more pending file transfers in the queue. If transfers are waiting, CuteFTP will reuse this connection for them. If there are no transfers waiting, then the connection (session) will be closed in 30 seconds. The **Log Window** (View > Show Panes > Queue & Log Pane) displays a list of open sessions to the Site. These sessions are the “file transfer threads” mentioned in **Global Options > Transfer > Events**. For 30 seconds after files are transferred, the **Log Window** will still show the session in this window. After 30 seconds, the session is closed except for one browse window. You can change this timeout to 0 - 1000 seconds.
Transferring Files and Folders

To specify the wait time after transfer completes

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Transfer** node, then click **Events**. The **Events** options appear.

3. In the **Close the file transfer thread n seconds after the transfer is finished** box, specify the time that CuteFTP will wait to close the data connection after a transfer is complete. Specify a time between 0 and 1,000 seconds.
4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**Executing Commands on Downloaded Files**

As old items build up in the queue, it can consume large amounts of memory. Use the settings on the **Tools > Global Options > Transfer > Events** node to remove old items from the queue and to preserve the local and/or remote time stamp.
To execute commands on downloaded files

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Transfer** node, then click **Events**. The **Events** options appear.
3. Select the **Execute the following command on the downloaded file** check box to execute the command value on the specified executable file displayed in the edit box below the check box. Browse for the file to define the path of an executable, batch file, and so on. You can enter your own command line parameters by typing them in the edit box; the system appends the full path of the downloaded file to that string.

   For example, if the **Execute the following command** value is "c:\windows\system32\cscript.exe" "c:\documents and settings\ghoffer\mydocuments\check.vbs", then with this value turned on, if you download a file "foo.dat" to "d:\temp", the command is executed in the following way:

   "c:\windows\system32\cscript.exe" "c:\documents and settings\ghoffer\mydocuments\check.vbs" "d:\temp\foo.dat"

4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**Viewing Transfer Status Logs**

While items are transferring and after the transfer is complete, you can view the details of the transfer in the **Individual Session Logs** pane. The **Individual Session Logs** pane appears under the **Remote** pane when you are connected to a site. The **Log Window** tab (behind the **Queue Window** tab) shows detailed session status.

Ensure the log settings in the **Global Options** dialog box are configured to display the logs.

**To view the log pane**

- On the main menu, click **View > Show Panes > Individual Session Logs** (or press ALT+2).

**To view the Log Window**

1. On the main menu, click **View > Show Panes > Queue & Log Pane** (or press ALT+1).
2. In the bottom pane, click the **Log Window** tab.

**Using Quick Connect**

Use the **Quick Connect toolbar** to make connections to servers that aren’t defined in the Site Manager or that you connect to frequently. Sites that you connect to are added to the **Host** list. You can keep the servers in the list or configure CuteFTP’s Global Options to **remove Quick Connect history** when you close CuteFTP.

The **Quick Connect** toolbar has the following fields and icons:

- **Host** - The name or TCP/IP address of the FTP server. The **Host** box is a drop-down list; by clicking on the arrow to the right of the field, you can access a list of the last several sites accessed during the current session via Quick Connect.
- **User Name** - Type your user name or leave it blank for anonymous FTP.
- **Password** - Type the associated password if not connecting anonymously.
- **Port** - If you are not connecting to the default FTP port (21), type the appropriate port here.
- **️ Connect** - Activates the connection to the site specified in the fields. You can also connect by pressing the **Enter** key while the cursor is in one of the boxes.
• **Site Properties** - Allows you to set connection options for the site.

• **Add to Site Manager** - Automatically creates a Site Manager entry for the site specified in the Quick Connect bar, so that you can easily access it in the future.

The Quick Connect bar can be moved or undocked by clicking and dragging on the vertical bar at the left-hand edge of the toolbar.

**To connect using the Quick Connect toolbar**

1. If the Quick Connect Bar is not displayed, click View > Toolbars > Quick Connect Bar, or press CTRL+F8.

2. In Host box, type or select from the Host drop-down list the Host to which you want to connect. The Host drop-down list displays the list of sites to which you have previously connected.

3. In the Username box, type the user name you use to connect to this site. The user name you used previously will appear in the box.

4. In the Password box, type the password you use to connect to this site. The password you used previously will appear in the box as dots.

5. In the Port box, type the port number if different from the default FTP port (21). The port you connected through previously will appear in the box.

6. Click the Connect icon 🔄. The files and folders in the remote server appear in the Remote (right) pane. If you connect to more than one site, each site has its own tab.

**Using the Clipboard to Transfer**

You can use the Windows clipboard to copy and paste a URL directly into CuteFTP with the Connect to URL feature. This allows you to connect to a Site, or if specified, download a file.

1. In a browser or Windows application, copy the URL to the clipboard (i.e., press CTRL+C). The URL may be general (ftp://www.globalscape.com) or specific (ftp://www.globalscape.com/pub/cuteftp/cute2632.exe).

2. In CuteFTP, on the main menu, click File > Connect > Connect to URL (or press CTRL+U). The Connect to URL dialog box appears.

3. Paste the URL into the Connect to URL dialog box (i.e., press CTRL+V).

4. Click OK. CuteFTP parses the URL and connects to the Site or, if specified, starts downloading the file.

*The URLs that you paste into the Connect to URL dialog box are saved for future sessions. Then you can just press CTRL+U, then click the down arrow to select the URL.*

**The following formats are supported:**

- ftp://user:pass@host.host.com:port
- ftp://user:pass@host.host.com
- ftp://user@host.host.com
- ftp://host.host.com:port
- ftp://host.host.com
• ftp://ftp.sitename.com/pub port:44 l/p: user/pass
• ftp://[any of the above formats]/pathnametofile/[optional filename]

CuteFTP also accepts http, https, sftp, and ftps URLs.

Pasting an URL Directly into the Transfer Engine

The Paste URL feature is also accessible from the Transfer Engine icon 🎨 in the Windows system tray.

1. Right-click the TE icon, then click Download URL. The Download URL dialog box appears.
2. Paste the URL into the Download URL dialog box, then click OK. The TE attempts to download the URL regardless of whether the URL specifies a path to a folder or a file.

Depending on the URL you paste, CuteFTP tries to connect and navigate to the specified folder or attempts to download the item. In the table is a sample of path endings and how CuteFTP handles them.

<table>
<thead>
<tr>
<th>Path endings</th>
<th>Interpretation</th>
<th>Action Attempted</th>
</tr>
</thead>
<tbody>
<tr>
<td>ftp://host/dir.ext/</td>
<td>A folder</td>
<td>Connection</td>
</tr>
<tr>
<td>host/.ext/</td>
<td>A folder</td>
<td>Connection</td>
</tr>
<tr>
<td>host/dir/</td>
<td>A folder</td>
<td>Connection</td>
</tr>
<tr>
<td>host/dir.ext</td>
<td>A file</td>
<td>Download</td>
</tr>
<tr>
<td>host/.ext</td>
<td>A file</td>
<td>Download</td>
</tr>
</tbody>
</table>

Scheduling Transfers

CuteFTP allows you to schedule transfers from the Queue Window. Additionally, you can schedule uploading files from your local computer to a server and downloading files from a server to your local computer.

To schedule transfers from the Queue Window

1. In the Queue Window, click the file to be transferred, then do one of the following:
   • On the main menu, click Tools > Queue > Schedule Selected.
   • Right-click the item, then click Schedule Selected.

   The Scheduling Properties dialog box appears.
2. Select the Schedule the current item check box.
3. In the Start on boxes, specify a date and time to transfer the item.
4. If you want the transfer to repeat automatically, select the Enable Recurrence check box, then, in the Repeat every boxes, specify how often you want the transfer to repeat.
5. Click OK.

- You can schedule multiple transfers.
- CuteFTP continues to run and complete any scheduled or pending transfers even if you exit.
the program before a transfer is scheduled to start, unless the "Don't close the transfer engine if tasks are pending" is disabled in Tools > Global Options > General.

- If you close the Transfer Engine or shut down the computer before a scheduled transfer can start, CuteFTP prompts if you still want to complete the scheduled transfer the next time you open CuteFTP.
- If you leave CuteFTP or the Transfer Engine open to accomplish a number of tasks, it is a good idea to configure CuteFTP to delete successfully finished items from the queue.

Site-to-Site Transfers (FXP)

Separate CONTROL and DATA connections allows transmitting data not only between client and server, but also between two FTP servers at once and transfer data between them by issuing a PASV command on one server and then a matching PORT command on the other. Thus, one server connects to the other instead of to a client. This behavior is not a hack; it is part of the official FTP specs. Today, it is widely known as FXP. Because Site-to-Site transfers are considered a security risk, many servers do not support them. If you are transferring between Sites with SSH2 or SSL connections, transfers between them are not secure unless both servers support SSCN.

To perform a Site-to-Site transfer

1. Connect to each Site (source and destination).
2. On the main menu, click Window > Tile.
3. Drag the file from one Remote Pane to another. The Queue Window displays a double arrow (<<), to indicate a Site-to-Site transfer.

To display more than one remote Site at a time

1. Connect to two or more Sites.
2. On the main menu, click Window > Cascade or Tile.
3. To return to the default, tabbed view, click Maximize in the upper right of any remote pane.

Multi-Part (Accelerated) Transfers

You can greatly speed up the transfer of large files using multi-part transfers. A multi-part transfer divides large files and sends the parts over multiple FTP sessions.

You can only use multi-part uploads with servers that support the COMB command, such as Globalscape EFT Server.

To perform a multi-part download

1. Connect to a remote Site.
2. In the Remote pane, click the file you want to transfer.
3. In the Local Drives pane, open the destination folder.
4. On the main menu, click File > Download Advanced > Multi-part Download, then click one of the following:
   - HIGH, to split the file into two parts
   - MAX, to divide the file into more parts
To perform a multi-part upload
1. Connect to a remote Site.
2. In the Local Drives pane, click the file you want to transfer.
3. On the main menu, click File > Upload Advanced > Multi-part Upload, then click one of the following:
   - HIGH, to split the file into two parts
   - MAX, to divide the file into more parts

- Very large files can take time to combine, so you might have to refresh (F5) the screen after a large multi-part transfer to see the resulting single, combined file on the remote server.
- You can quickly gauge the effectiveness of the transfer by highlighting that item in the Queue Window, and clicking on the small plus sign + next to the item name. The item will expand to show you all parts of the transfer with the average speed of each part.
- Multi-part transfers are not very effective for smaller files.
- Multi-part downloads do not occur for Sites that do not support resume downloading.
- Multi-part transfers are not very effective within your own network.
- Multi-part transfers are not very effective for modems slower than 56kb, because most FTP servers can at least transfer at that speed.
- Multi-part transfers do not work if the FTP Site does not allow multiple simultaneous connections from the same user or IP address.
- Due to added overhead on the processor of a server when generating encrypted transfers, multi-part downloads over SSH and SSL can be ineffective and are not recommended.

Accelerating Transfers with Mode Z
Mode Z compression compresses files on-the-fly for file transfers from the local computer to the remote computer and remote to local computer, saving bandwidth and improving transfer time. You must configure MODE Z to take advantage of this feature. This feature is turned on by default, and is used whenever you connect to a server that supports Mode Z. If MODE Z is enabled, then all the file types in the Mode Z list (ASP, BMP, CSS, DAT, DOC, EXE, HTM, JS, LOG, PDF, PHP, PL, PPT, PY, SWF, TXT VBS, XLS, XML, XSL) are compressed when transfer of files between the computers take place.

To configure Mode Z settings
1. On the main menu, click Tools > Global Options (or press ALT+F7).
2. Expand the Transfer node, then click MODE Z. The MODE Z options appear.
3. Configure options as described below.
   - Select the Apply MODE Z compression check box to enable the compression of files. Mode Z compression is applied to all file types in the list.
   - To add file type to Mode Z list, in the box, type the file extension, then click Add.
   - To remove file type from Mode Z list, click the extension of the file in the list, then click Remove.

Only those files in the Mode Z list are compressed.

4. Click Apply if you are going to make changes to other pages; click OK to save changes and close the Global Options dialog box.
Improving CuteFTP Performance When Transferring Large Numbers of Files at Once

A few changes to CuteFTP's default settings can improve CuteFTP performance if you regularly transfer a large number of files at the same time. For example, making a few adjustments to the settings in CuteFTP's Global Options can prevent the initial connection from being used for transfers and/or improve the responsive of CuteFTP.

To improve CuteFTP performance

1. Open the **Global Options** dialog box. On the main menu, click **Tools > Global Options** (or press **ALT+F7**).
2. Adjust the following settings as needed:

   - **Allow transfers to occur over the existing (browse) session:**
     - When you transfer more than the (user-configurable) maximum number of files at the same time, CuteFTP will use the initial connection to the Server for one of the file transfer connections, known as the "browse" session. When this occurs, an hourglass can intermittently appear and CuteFTP becomes unresponsive as the files are transferring and using the connection. Also, scheduled transactions cannot occur if all of the available connections are in use.
       a. Click the **Transfer** node.
       b. In the **General** area, clear the **Allow transfers to occur over the existing (browse) session** check box. The check box is selected by default, because most users want their transfer to occur quickly and are not likely to be browsing while a large number of transfers are in progress.

   - **Adjust the allowed number of concurrent transfers:**
     - Allowing a very large number of concurrent transfers can cause CuteFTP to monopolize the computer's CPU. Avoid adjusting these settings, unless you are willing to spend some time optimizing CuteFTP to your particular CPU and network capabilities. For example, on a broadband connection with a 1 Ghz+ CPU, it might be more appropriate to set **Global max concurrent transfers** to 120 and **Per Site concurrent transfers** to 40. Keep in mind that if the FTP server does not support the requested number of multiple connections, connection errors will occur when these settings are increased. One of the reasons this setting exists is to prevent CuteFTP from trying to open more connections than the server allows.
       a. Click the **Connection** node.
       b. Increase the defaults for **Global max concurrent transfers** (the default is 12) and **Per Site max concurrent transfers** (the default is 4) to allow CuteFTP to open more transfer connections simultaneously.

     Regardless of these settings, CuteFTP can become unresponsive if you are sending more files than the maximum.

   - **Adjust the log storage settings:**
     - By default, saved logs are deleted every 3 days. You can delete them more frequently if you transfer large numbers of files frequently. If you want to keep logs indefinitely, be aware that this may adversely affect performance of CuteFTP and/or quickly fill up disk space.
       1. Expand the **General** node, then click **Log Files**.
2. By default, saved logs are deleted every 3 days. In the boxes next to the **Delete saved logs every** check box, you can set the frequency to between 1 to 1000 minutes, hours, or days. Clear the check box if you do not want to delete the logs automatically, but be sure to delete them manually periodically to avoid filling up the hard drive.

3. Select the **Delete item logs of successful transfers immediately after completion** check box. By default, this check box is not selected, but selecting it could improve the performance of CuteFTP when downloading a large number of files.

Alternatively, you can delete all logs that are not currently associated with an open connection or an item listed in the transfer queue, by clicking **Delete all logs**. (Be sure to close connections and clear out the queue before you click **Delete all logs** to ensure that all logs are deleted.)

- **Adjust the Queue cleanup settings:**
  - A large number of items in the Queue use up memory and resources that can be freed by simply keeping the Queue clean. Removing completed transfers from the Queue could help improve the performance of CuteFTP when downloading a large number of files.
    1. Expand the **Transfer** node, then click **Events**.
    2. By default, the **Remove successful transfer items from the queue automatically** check box is not selected. Selecting this check box could help improve the performance of CuteFTP when downloading a large number of files, by keeping the Queue clean.

Alternatively, you can manually empty the queue periodically by clicking **Tools > Queue > Remove All** or by right-clicking in the queue, then clicking **Remove All**, but if the browse session is being used for transfers, manually removing items from Queue might prove difficult.

- **If you have a particularly fast (broadband) connection, you can delete the thumbnail cache:**
  - Enabling **Thumbnail cache expiration** ensures that the thumbnail cache will periodically be cleared; however, it also will cause the FTP session to re-download thumbnails, which can take a significant amount of time on a dial-up connection.
    1. Expand the **General** node, then click **Log Files**.
    2. In the **Thumbnail settings** area, set **When the transfer engine exits** to **Delete images older than the value specified**.
    3. In **Thumbnail cache expiration**, set the expiration to an appropriate time. (This setting becomes editable after you set **When the transfer engine exits** to **Delete images older than the value specified**.)

Alternatively, you can click **Delete thumbnail cache** to delete all thumbnails in the cache except those that are currently displayed in the application. (Turn off thumbnail view or close all connections before clicking **Delete thumbnail cache** to ensure all thumbnail files are deleted.)

2. Click **OK** to close the Global Options and save the changes.
ASCII Transfer Settings

Select, by file extension, file types that should always be transferred in ASCII mode.

To configure the ASCII transfer options

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Transfer** node, then click **ASCII Types**. The **ASCII Types** options appear.
3. Configure options as described below.
   - In the **ASCII extensions** box, type the file extension for files you want to transfer in ASCII mode, then click **Add** to add the extension to the list.
   - To remove an extension from the list (to send files of this type in binary mode), click the extension in the list, then click **Remove**.

   You can specify a Transfer type from the main menu (see Transferring files in binary or ASCII mode). You can also specify a Transfer type for an individual Site by highlighting the Site in the Site Manager, clicking the Type tab, and choosing from the Transfer list. Auto is the default transfer type, and sends files in the mode specified for each file's extension. All extensions are sent in binary mode unless they are listed in the **ASCII Extensions** list.

4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

Specifying Binary or ASCII Mode

You can specify binary or ASCII mode for a session, globally (per file type), and per site. All extensions are sent in binary mode unless they are listed in the ASCII extensions list, as described below.

To choose the transfer mode for a session

You can change the transfer type for a single CuteFTP session. Once CuteFTP is restarted, it reverts to the transfer type set in **Global Options**.

- On the main menu, click **File > Transfer Type**, then click one of the following:
  - **Auto** (or press CTRL+F1) - Auto is the default transfer type, and sends files in the mode specified for each file's extension. All extensions are sent in binary mode unless they are listed in Global Options, as described below.
  - **ASCII** (or press CTRL+F2) - files will be transferred in ASCII mode.
  - **Binary** (or press CTRL+F3) - files will be transferred in Binary mode.

To transfer specific file types in ASCII mode

1. On the main menu, click **Tools > Global Options** (or press ALT+F7). The **Global Options** dialog box appears.
2. Expand the **Transfer** node, then click **ASCII Types**. A list of the file types that are transferred in ASCII mode are displayed.
3. Do the following:
   - To specify file types that are to be transferred in ASCII mode, in the **ASCII extensions** list, type the file extension for the file type you want to transfer in ASCII mode, then click **Add**. The extension appears in the list.
To specify file types that are to be transferred in binary mode, in the **ASCII extensions** list, click the extension of the file type that you want to transfer in binary mode, then click **Remove**. Removing the file type from the **ASCII extensions** list will cause that type of file to be transferred in binary mode.

4. Click **OK**.

**To change a Site's transfer type**

1. Display the **Site Manager**, right-click the Site, then click **Properties**.
2. Click the **Type** tab.
3. In the **Transfer type** box, **Auto-detect** is selected by default. Based on the file type, CuteFTP decides whether to transfer in ASCII or binary. To change this setting for this site, click one of the following:
   - **ASCII** - Used primarily for transfer of text-based files such as HTML, text, and other documents.
   - **Binary** - Used primarily for data type transfers such as pictures and other graphics or files that do not have line feeds.
4. Click **Connect** or **OK**.

**SSH2 servers do not support ASCII transfers** (see [http://www.ssh.com/tech/archive/secsh.cfm](http://www.ssh.com/tech/archive/secsh.cfm)). CuteFTP adjusts for this by automatically stripping line feeds prior to uploads and restores them during downloads (prior to the file being written to disk).

**Verifying Integrity of Transferred Files**

Although TCP/IP ensures that all packets are received properly, mishandling by the application can occur, leading the client to believe that a transfer was successful when it was not.

The Server's file integrity command is defined as **XCRC**. Once an XCRC-enabled client (such as CuteFTP) performs a transfer, it can request the Server to do a checksum calculation on the file. If it matches the checksum on the client, then the transfer is deemed successful. Performing XCRC checksum calculations is processor intensive; enable or disable the feature accordingly.

**XCRC applies to FTP only, not SFTP. Refer to File Integrity Checking in FTP and SFTP below for details of file integrity checking in SFTP.**

XCRC is a proprietary command and is not defined nor endorsed by any FTP-related RFC. Competing servers who want to implement this command may do so using the syntax described below.

```
XCRC <File Name>
XCRC <File Name>, <EP>
XCRC <File Name>, <SP>, <EP>
```

- **SP** = Starting Point in bytes (from where to start CRC calculating)
- **EP** = Ending Point in bytes (where to stop CRC calculating)
Transferring Files and Folders

FTP Client Log Example

```
COMMAND:> XRC "\Program Files/MSN Gaming Zone/Windows/chkrzm.exe" 0 42575
```

- SP and EP are optional parameters. If not specified then it calculates the CRC for the whole file. If only EP is specified, then the CRC calculation starts from the beginning of the file to the EP.
- This command can be used for a single file at a time. It does not allow file lists as parameters.
- The standard CRC32 algorithm is used (for speed and efficiency).
- A client can invoke this command for uploads, downloads, and single and Multi-Part Transfers.

<table>
<thead>
<tr>
<th>Server Reply</th>
<th>Indicates</th>
</tr>
</thead>
<tbody>
<tr>
<td>250 &lt;XRC&gt;</td>
<td>calculated CRC value</td>
</tr>
<tr>
<td>450 Requested file action not taken</td>
<td>file is busy</td>
</tr>
<tr>
<td>550 Requested action not taken</td>
<td>file is not found or has no read permission; or the SP or EP are not correct</td>
</tr>
</tbody>
</table>

File Integrity Checking in FTP and SFTP

FTP provides a very raw mechanism to transfer files – the data for a file is uploaded/downloaded as a stream of bits over a TCP/IP connection. There is no additional overhead on that operation, so it is fast; however, this also means that there are no intrinsic mechanisms for ensuring that the file got to the other end intact. That is why many servers, including EFT Server, support the XRC command, an extension to the FTP protocol. The XRC command performs a CRC32 checksum over the file (either the whole file, or a portion of the file if a byte range is specified on the command line). This gives a 32-bit value that the Server computes on the file, which can be compared to the 32-bit value computed on the client side. If both files are the same size and the CRC32 matches, then there is a very high probability that the files are identical and files were transferred correctly.

In contrast, SFTP does add overhead to the transfer of files. As a file is transferred between client and server, it is broken up into smaller chunks called "packets." For example, suppose each packet is 32KB. The SFTP protocol does a checksum on each 32KB packet as it is sent, and includes that checksum along with that packet. The receiver gets that packet and decrypts the data, and then verifies the checksum. The checksum itself is "stronger" than the CRC32 checksum (because SFTP uses a 128-bit or higher checksum, such as MD5 or SHA, and because this is done on each and every packet, there is a very granular integrity checking that is accomplished as part of the transfer. Thus, the protocol itself is slower (because of the additional overhead), but the successful completion of a transfer means, de facto, that it has been transferred integrally and there is no need for an additional check.

If you want to verify integrity, then use SFTP protocol and it is built-in; or, use FTP and after a transfer issue the raw command "XCRC /path/to/file" and read the results, comparing to a locally calculated CRC32 on the client side. EFT Server also supports querying the CRC32 value over the HTTP/S protocol by issuing a "HEAD" request to the file. The result of a HEAD method invocation on the HTTP/S engine will result in a response that includes the "X-CRC" header, which contains the CRC32 value of the file in question. This can be compared to the CRC32 computed over the local file, just like in the FTP case.

To verify files have successfully transferred

1. On the main menu, click Tools > Global Options (or press ALT+F7). The Global Options dialog box appears.
2. Expand the Transfer node, then click Events.
3. In the Operations after transfer area, select the Verify file integrity when transferring to/from Globalscape's FTP Server check box.
4. Click OK.
The File Integrity CRC Checksum is used ONLY if all of the following are true:

- The file integrity feature is turned on in CuteFTP.
- The FEAT command is enabled in CuteFTP (Tools > Global Options > Navigation Settings).
- The remote server supports both FEAT and XCRC, and has enabled it for the specific user account.
- The files are binary files transferring in binary mode.
- The destination file size is smaller than the source and the server supports resume OR the destination is equal to the source size (regardless of resume capability).

Compressing and Decompressing

To compress files for uploads

1. Connect to a Site and click the destination folder in the Remote pane.
2. In the Local Drives pane, click the item(s) you want to upload.
3. On the main menu, click File > Upload Advanced > Upload Compressed. A sub menu displays the selected file name with three different extensions. Each extension identifies a compression scheme.
4. Click the file name with the extension for the compression scheme you want.

To decompress a local archive

1. In the Local Drives pane, click the archive to be expanded.
2. On the main menu, click Tools > Compression > Decompress. The contents of the archive expand into a directory with the same name as the archive.

You cannot decompress a file on a remote FTP server from within CuteFTP's interface. To decompress an archive remotely, use a compression tool and Globalscape EFT Server to create an Event Rule or Custom Command (on the Server) that will decompress archives uploaded to the server (either automatically or as a result of a custom command sent by the client). See this custom command example for more information.

To create encrypted archives for upload, you need a compression tool and a call script to encrypt, compress, and then upload an archive.

- .zip is the industry standard archival method (wide support, medium compression).
- .cab is a Microsoft format (not very wide support, stronger compression than ZIP).
- .gzip/tar is a UNIX format (files are stored in a "r;Tarball" then compressed).
- Windows XP has a built-in compression/decompression tool. Refer to the Microsoft Support article #306351, at http://support.microsoft.com/kb/306531.
Using Scripts to Transfer Files

You can write scripts to transfer files using CuteFTP's Transfer Engine (TE). With scripts, you can interact directly with the TE using common programming languages such as Visual Basic (VB) or other scripting languages supported by the Windows Scripting Host (WSH).

Sample scripts and examples are available in the Transfer Engine section.

You can also use CuteFTP’s macro recorder to capture entire sessions to a script for future playback.

To conserve resources, if you leave CuteFTP or the Transfer Engine open to accomplish a number of tasks, you should set CuteFTP to delete successfully finished items from the queue.

Recording a Macro

CuteFTP can record and playback entire sessions using the powerful macro record/playback tool. Sessions are recorded in Visual Basic Script and take advantage of CuteFTP's COM-exposed transfer engine (TE) interface. To play a recorded macro, refer to Playing a Recorded Macro.

To start recording a macro

1. Before recording your macro, perform the steps you will be recording to test the process.
2. When you are ready to record, on the main menu, click Tools > Macros and Scripting > Start Recording.
3. Connect to your Site and perform the tasks you want to record.
4. When you finish recording the macro, click Tools > Macros and Scripting > Stop Recording. The Save As dialog box opens.
5. In the File name box, type a name for the macro, then click Save (or click Cancel to cancel the recording). If you click Cancel, a confirmation message appears.
6. Click Yes to cancel the recording session or click No to specify a location to save. If you click Yes, the recorded script is lost.

Configuration Notes

The macro recorder can record most events supported by the CuteFTP’s TE COM interface:

- Connect (FTP, FTPS, SFTP, HTTPS) including all parameters (OTP, CCC, AUTH_TLS, etc.)
- Disconnect
- Upload
- Download
- Site to Site Transfer
- Synchronize
- URL Transfer
- Create Local Folder
- Create Remote Folder
- Rename Local Folder
- Rename Remote Folder
- Remove Local Folder
- Raw FTP Command
The macro recorder uses all defined parameters set in the CuteFTP interface for Socks and Proxy information; therefore, there is no need to add "UseProxy" to the resulting script (macro) that is created.

Playing a Recorded Macro

To play a macro from within CuteFTP

1. On the main menu, click Tools > Macros and Scripting > Run > Browse. The Open dialog appears.
2. Click the macro you want to run, then click Open. The Open dialog closes and the macro runs.

To playback a macro script from outside of CuteFTP

- In Windows Explorer, locate the macro file, then double-click it. CuteFTP's Transfer Engine performs the recorded events without launching the interface.

You must have the Windows Scripting Host (WSH) installed to play recorded macros or scripts.

To create a macro, refer to Recording a Macro (Automating Sessions).

Custom Commands

Custom commands allow you to specify a raw FTP command sequence and assign shortcuts or toolbar links to these sequences.

To add a custom command

1. On the main menu, click Tools > Custom Commands > Edit Custom Commands. The Custom Commands dialog box appears.
2. Click the New Folder icon. A new folder is created.
3. Type a name for the folder.
4. Click the New Command icon. A new command appears beneath the folder.
5. Type a name for the command.
6. With the command selected, click the Properties icon. The Custom Command Properties dialog box appears.
7. In the Command box, type an FTP command or command sequence.
   - To add a command sequence, add a line break between command sequences when entering them into the Command box. For example:

```
USER %u 
PASS %p
```
8. (Optional) Click in the Shortcut Key box, then press the keys on your keyboard for the shortcut.
9. (Optional) Click Change Icon to select a toolbar icon for the command. The Choose an Icon dialog box appears.
10. Click the icon you want, then click OK.
11. To include the new command on the Custom Commands toolbar, select the Place on the custom commands toolbar check box.
12. Click OK twice to accept the changes and close the Custom Commands dialog box.
To use a custom command

1. **Connect to a Site.**
2. On the main menu, click **Tools > Custom Commands**, then click your custom command.

To display the Custom Commands Bar

- On the main menu, click **View > Toolbars > Custom Commands Bar.**

ℹ️ *The remote Site must be in the active pane for a command to be sent. Once sent, you can view the server's response in the Log window.*

### Saving and Reusing a List of Transfer Tasks

When you **create a Folder Monitor task**, the task is saved in the Queue Window.

#### CAUTION:
If you use **Remove All** to remove everything from the Queue Window, you will also remove your Folder Monitor rules!!

Unfortunately, it is not possible to retrieve any tasks that were deleted. However, you can backup (export) all tasks and reload (import) them.

**To save a list of transfer task/Folder Monitor Rules**

1. Do one of the following:
   - On the main menu, click **Tools > Queue > Load & Save Queue > Save Queue.**
   - Right-click in the **Queue Window**, then click **Load & Save Queue > Save Queue.**
2. In the **Save As** dialog box, specify a name and location, then click **Save.** The file is saved as **quesave.cpx** by default.

**To reuse a list of tasks (load a previously saved queue)**

1. Do one of the following:
   - On the main menu, click **Tools > Queue > Load & Save Queue > Load Queue.**
   - Right-click in the **Queue Window**, then click **Load & Save Queue > Load Queue.**
2. In the **Open** dialog box, click a saved Queue file (Queue files are saved with a .cpx extension), then click **Open.** The saved tasks appear in the Queue. **(NOTE: If a task in the .cpx file is already in the Queue, it is not overwritten; instead, you will have duplicate tasks in the Queue. Sort the Queue by the Local or Remote column to find the duplicates.)**

### Improving Slow Transfers

If you are experiencing slow transfer speeds, try fine tuning CuteFTP as described below.
**Make sure that Mode Z is turned on**

Mode Z compression compresses files as they are transferred. Reducing the file size reduces the necessary bandwidth and improves transfer times. If this option is turned on, CuteFTP will take advantage of any server that supports Mode Z.

**Tweak the receive and send buffers**

Setting these buffers allow you to fine tune transfers over high latency or lossy connections like those over satellite links or with legacy CDMA wireless connections. It is unlikely you will ever need to adjust this setting, but if you have problems with successful transfers and suspect the latency or quality of the connection is at fault, try tweaking these buffers. The receive buffer holds data until CuteFTP is ready to read it; the send buffer holds data until it can be sent to the server. Typically, both send and receive buffers should be set to the same size. The default is set at 65536 bytes, the normal maximum window size of TCP. You can measure the latency and estimate the available bandwidth with network monitoring tools. There is some guesswork involved, as most tools are not entirely accurate, but they can guide you to finding a sweet spot where transmissions are successful. If you have a lossy connection, try lowering the buffer size. If you have high latency, a higher buffer size might help.

Normally, the optimal buffer size is your bandwidth times the latency of the link. So,

\[
\text{bandwidth (in bits) } \times \text{ latency (round trip time in seconds)} = \text{ socket buffer size (in bits)}
\]

Convert bits to bytes (bits divided by 8 equals bytes) for the buffer size.

So, if your bandwidth is 1,536,000 bps and you have a latency of 200ms (.2 seconds), your socket buffers should be set to 38400:

\[
1536000 \times .2 = 307200 \text{ bits} \\
307200 / 8 = 38,400 \text{ bytes}
\]

You can also try halving or doubling the buffer size. For example, if the buffer is set to 65536 (64kb), try 32768 (32kb).

1. On the main menu, click **Tools > Global Options**.
2. Click the **Transfer** node.
3. In **Receive buffer** and **Send buffer** boxes, change the values as needed. (See guidelines above.)
4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**Turn off the time stamp in logs**

- When this feature is on, CuteFTP adds a time stamp next to each log event. This option consumes system resources, so you can turn this off if performance is critical. For more information, see Record/Display time stamps in Log file settings

**Try using multi-part transfers**

- If you are transferring large files, try using a [multi-part transfer](#). You can only use this option if the server you are connecting to supports it.

**Check the global bandwidth limit**

- Determine whether the global bandwidth limit is limiting your throughput. This setting in **Global Options** throttles the bandwidth of all sessions on CuteFTP. See [Global bandwidth limits](#).
Transferring Manually

Use this function to transfer a specific file if you know its exact location and you are unable to navigate to that location or do not have LIST permissions for that folder.

To download a file manually

1. In the Local Drives pane, open the destination folder.
2. Connect to the Site where the file exists.
3. In the Remote pane, click any file or folder.
4. On the main menu, click File > Download Advanced > Download Manually. The File to Download dialog box appears.
5. In Download path, type the path to the file you want to download.
6. Click OK.

To upload a file manually

1. Connect to the Site to which you want to upload the file.
2. Open the destination folder in the Remote pane.
3. In the Local Drives pane, select the file you want to upload.
5. In Upload path, type the complete path to the file you want to upload.
6. Click OK.

Upload/Download Filtered Files

CuteFTP allows you to set filters that automatically include or exclude files from transfers. You define the filters in the Filter dialog box, then apply them to transfers. When you apply filters, you do not add or remove files, you simply set which files will be visible or invisible in CuteFTP.

Refer to Filtering the List of Files and Folders for more information.

To transfer filtered items

- After defining a filter as described above, in the Local Drives or Remote pane, click the files that remain visible, then click File > Upload Advanced, then click Upload filtered (or Download Advanced > Download filtered if you are downloading).

For the Upload Advanced option to be available, you must connect to a Site and select a folder in the Local Drives pane.

For the Download Advanced option to be available, you must connect to a Site and select a folder in the remote pane.
FTP Commands

You can communicate with an FTP Site on the lowest possible level.

To manually enter an FTP command

1. Connect to a Site.
2. On the main menu, click Tools > Enter FTP Command.
3. In the Input FTP command box, type a command such as LIST or CWD or PWD.
4. Click OK.

You can also send multiple commands to the FTP server by using Custom Commands.

- RFC959 describes FTP commands and reply codes.

Unicode Support in CuteFTP

CuteFTP supports Unicode file names.

- To conserve Unicode file names, the remote server must support UTF-8 and advertise UTF-8 in its FEAT command.
- To conserve Unicode file content you must transfer the file using binary transfer mode. (Refer to Specifying Binary or ASCII Mode.)
- Note that text (ASCII) files transferred in binary mode will retain their carriage return (CR) and line feed (LN) hidden characters, which are not supported by Unix systems by default.

The following areas and features of CuteFTP do not currently support Unicode:

- Compression: GZIP/TAR files
- PGP: Key paths and key passwords can include Unicode symbols, but old passwords with Extended ASCII symbols will not work
- SSL: In the Create Certificate wizard, the following fields cannot include Unicode symbols: Passphrase, Common name, Country, Private key password.
- SFTP: If you have upgraded to CuteFTP v9 and are using key pairs created with CuteFTP v8, if the password for an existing key contains any Extended ASCII characters, the password will not work. You will have to reenter the password (Tools > Global Options > Security > SSH2 Security) after upgrading to v9.
Chapter 9. Managing Files and Folders

The topics below provide procedures for managing files and folders. (See also Transferring Files and Folders.)

Opening, Editing, Renaming, and Deleting Files

You can manage your files on both local and remote drives from within CuteFTP.

Because of the way in which various type of servers handle files and to make file maintenance easier, keep the following in mind when naming your files and folders:

- Keep names short. Some servers only allow a certain number of characters.
- Create meaningful names using whole words to avoid ambiguity and so that you do not have to open a file to know what it is. For example, a year after you create a Web page for your friend's cat, Greta, you are more likely to know what pictures-of-greta.htm contains versus pog.htm.
- Use lowercase for names. Some servers are case sensitive.
- Names should never contain spaces or special characters (\* / : ; < > , and so on ). If you want to make filenames easier read, use hyphens or underscores; however, underscores are hidden if the filename is turned into a hyperlink.
- For most websites, the main page must be called index.htm or index.html. If you rename it main.htm, it might not work.

To open a file

1. Click a file in Local Drives or the Remote pane.
2. On the main menu, click File > Open, or click the Open icon . The applicable program opens or runs the file.

To edit a file

1. Click a file in Local Drives or the Remote pane.
2. On the main menu, click File > Edit or View. The file opens in CuteFTP’s built-in editor or the HTML editor that you have specified in Global Options.
3. Make any desired changes.
4. On the main menu, click File > Save. If you want to save a text file as UTF-8 format, click File > Save As, and then click UTF-8 in the Encoding list.

You can configure the built-in editor to open in full-screen mode or in tab view. When you exit the editor, CuteFTP restores the screen to its original state. Cycle through the open panes, including any editor tabs, by pressing CTRL+TAB.

To rename a file

1. Click a file in Local Drives or the Remote pane.
2. On the main menu, click File > Rename or right-click the file and click Rename.
3. Type a new name for the file, then press ENTER.
4. The renamed file is highlighted and the sequence of the file is changed alphabetically. For example, if the file name was S.txt, and the name of the file is changed to A.txt, then the sequence of the file changes. The file A.txt appears where all files starting with alphabet A appear.
**If you change the extension when you rename the file, you may not be able to open the file in the proper program.**

**To delete a file**
1. Click a file in **Local Drives > Remote** pane.
2. On the main menu, click **File > Delete**. A confirmation message appears.
3. Click **Yes**.

**Updating or Refreshing Folder Listings**

**To update or refresh a folder listing**
1. Click in the pane where the folder is displayed.
2. On the main menu, click **View > Refresh**.

**To update remote folder listings automatically**
1. On the main menu, click **Tools > Global Options** (or press ALT+F7). The **Global Options** dialog box appears.
2. Expand the **Navigation** node, then select the **Auto-refresh the remote pane after uploading a file or folder** check box.
3. Click **OK**.

**Listing Files and Folders in Order**

You can sort the display of the files and folders in the Remote pane, **Local Drives** pane, and **Queue Window**. Sorting is for ease of finding a file or folder; it does not affect the transfer order of the files/folders in the Queue.

**To sort files and folders in order by name**
1. Click in the **Remote** or **Local Drives** pane.
2. On the main menu, click **View > View > Details**.
3. Click the **Name** column header in the Remote or **Local Drives** pane.
4. Each time you select the column header the items are sorted in the opposite order.

*You can sort by any column when in Details view.*

**To sort files and folders in order in the Queue Window**
1. Click in the **Queue Window**.
2. Click a column header in the **Queue Window**. The transfer items are listed in alphabetic order of the selected column’s contents.
3. Each time you select the column header the items are sorted in the opposite order.
The order items are listed in the Queue Window is not necessarily the order in which they transfer. The numbers in the left-most column of the Queue Window indicate the order of transfer. For example, when the Queue Window is sorted alphabetically by Item Name, the transfer order stays the same.

### Finding Files and Folders

CuteFTP Site Search function allows you to search local and remote drives and folders for files based on all or part of the filename with wildcard support, modification date or date range, and file size or size range.

**To find a file or folder**

1. On the main menu, click **Edit > Find**. The **Search Results** dialog box opens.
2. Next to **Search in**, specify whether to search on the local or remote pane.
   - **Local Drives** - If you want to search for a file in your local drive.
   - **Remote pane** - If you want to search for a file in the remote pane.
3. In the **Search for the files or folder named** box, type the name of a file or folder, or the extension of a file for which you want to search. The name or the extension of the file is added to the drop-down list. You can also use wildcards.
4. In the **Look in** box, specify the folder to search or type the path.
5. To include the subfolders in the target folder, select the **Search subfolders** check box.
6. To define the file size, select the **File size between** check box, then type the number of kilobytes in the text boxes.
7. To specify a date range, select the **Date modified between** check box, then type or select the date range in which to search.
8. To start the search, click **Search Now**.
9. To stop the search, click **Stop search**.
10. All of the files with the same extension or with same name with other details, such as size, type, modified on, and attributes are listed in the **Results** pane of the **Search Results** dialog box.

*Find and Find Next are not case sensitive and only search from the top to the bottom of your listings.*
Selecting a Group of Items

You can select (highlight) items in the Remote pane, Local Drives pane, or Queue Window by name or type using Group Select and wildcard masks.

To select all files of a certain type

1. Click in the pane displaying the files you want to select.
2. Do one of the following:
   - On the main menu, click Edit > Group Select.
   - Press the PLUS SIGN (+) on the number pag. (Be sure NUM LOCK is on).

   The Select group dialog box appears.

3. In the Select mask box, do one of the following:
   - Type *.
   - Type a string to match. For example, if you type doc, all items containing the string doc, regardless of file type, are selected.
4. To group select only files (not folders), clear the Mask directories check box.
5. To include previously selected files in the new group you are defining, select the Remove Selection check box. Clear the check box to exclude previously selected items that are not in the new group.
6. Click OK. Files of the specified type are selected (highlighted) in the pane. You can now manage them (transfer, copy, delete, move, etc.) as a group.

To switch the selection between the highlighted group and all non-highlighted items

- With a group selected, on the main menu, click Edit > Invert Selection or press * (asterisk).

To remove items from a group selection

If you have selected a large group of items then decide you want to remove certain items or file types from the group, use the procedure below.

1. With a group selected, on the main menu, click Edit > Group Deselect.
2. In Deselect group, type the name of the file or file type you want to remove or use wildcard masks to remove a group of items.
3. Select the Mask directories check box to include folders in the action.
4. Click OK.
Moving Items from One Folder to Another on a Remote Server

You can move selected items from one remote folder to another remote folder on the same server.

To move items from one remote folder to another
1. Connect to the Site, then open a folder on the remote Site.
2. Select items in the folder.
3. Do one of the following:
   • On the main menu, click **Edit > Move to Folder**.
   • Right-click the file, then click **Move to**.
4. In the **Move items to** box, specify the path at which to save the selected items.
5. Click **OK**.

*CuteFTP does not create the folder. If the folder does not exist, an error message appears.*

Changing File and Folder Permissions on Remote Sites

You can set who can open, change, or delete files and folders on remote Sites. See also About CHMOD Permissions.

To change permissions for a remote file(s) or folder(s)
1. Connect to a Site.
2. Select the file(s) or folder(s) for which you want to change permissions.
3. On the main menu, click **File > Properties**.
4. Select the check boxes next to the permissions you want for yourself (Owner), a Group of users, and the Public.
   • When multiple items are selected, a gray check mark signifies the permission is granted for some files in the group, but not in others. You can still change the permission for the whole group.
   • If you cannot change permissions for a file or folder, the FTP server administrator must modify your account or the file permissions.
5. Click **OK**.

Wildcard Masks

Wildcard masks are patterns of special characters used to filter files/folder names or transfers. When a wildcard mask is matched against a filename, the two patterns are compared, letter-by-letter, from left to right until a mismatch occurs. If all the characters in both patterns compare positively, the filename matches the Wildcard Mask.

Wildcard mask characters
• ? Will match any single character
• * Will match any sequence of characters (including no characters at all), terminated by the next character in the mask.
• [ ] Will match any character in the character set enclosed in the brackets. This can also be a range of characters
• If the opening bracket is followed by "!", will match any character NOT in the set.
Wildcard Mask Examples

<table>
<thead>
<tr>
<th>Mask</th>
<th>Will Match</th>
<th>Will NOT Match</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>all files</td>
<td>--</td>
</tr>
<tr>
<td>*.bmp</td>
<td>sample.bmp, xyz.bmp</td>
<td>sample.gif</td>
</tr>
<tr>
<td>x?z</td>
<td>xyz, xaz</td>
<td>xyy, zyz</td>
</tr>
<tr>
<td>a[xyz]c</td>
<td>axc, ayc, azc</td>
<td>abc, awc</td>
</tr>
<tr>
<td>a[!xyz]c</td>
<td>abc, adc, awc</td>
<td>ayc, azc</td>
</tr>
<tr>
<td>a[a-c]d</td>
<td>aad, abd, acd</td>
<td>add, axd</td>
</tr>
</tbody>
</table>

Displaying Hidden Files or Folders

By default, some servers will hide files with names starting with a period such as ".htaccess" or ".profile."

To display hidden files on a remote Site

1. In the Site Manager, click the Site with the hidden files.
2. On the main menu, click File > Properties.
3. On the Actions tab, click Filter.
4. Select the Enable filtering check box.
5. Select the Enable server side filtering check box.
6. In the Remote filter field, type –a, then click OK.
7. Connect to the Site. You should now be able to see hidden files and folders.

Comparing Folders by Case, Size, and Date

CuteFTP allows you to compare folders in a local folder with a remote folder. You can compare file size and/or dates. The files that are different are highlighted in red. If the file does not exist, it is highlighted in blue.

To compare folders

1. Click the Local Drives tab and navigate to the folder you want to compare.
2. Navigate to the same folder on the remote computer pane.
3. On main menu, click Tools > Folder Tools > Compare Folders (or press F11).

The Directory Comparison Options dialog box appears.
Managing Files and Folders

• To ignore case while comparing the folders, select the **Ignore case** check box. This compares all files with the same name, regardless of case. That is, *AddFile.gif* is compared to *addfile.gif*.

• To compare files by size, select the **Compare sizes** check box.

• To compare files by date, select the **Compare dates** check box.

4. Click **OK** to start comparing. CuteFTP compares the files with the same name, and highlights any files or folders that are different (either in size and/or by date).

• If the file is **highlighted in blue**, the file does not exist in the remote folder.

| If a file in your local folder is called *add feed.gif*, and a file in the remote folder is called *add_feed.gif* (the local file has a space and the remote file has an underscore), the comparison tool thinks the file does not exist on the remote system. It is recommended that you use underscores instead of spaces when naming files so that the format is compatible across operating systems. For example, Windows allows spaces in file names, but UNIX does not. |

• If the file is **highlighted in red**, the file size or date is different.

| If you have NOT selected the **Preserve the local time stamp for uploaded files if the server allows MDTM** check box in **Tools > Global Options > Transfer > Events**, then the date/time will likely be different between local and remote files. |

• If the file is not highlighted, the file on your local system has the same properties as the file on the remote system.

5. If you want to update the files in the remote location, hold down CTRL to multi-select the files that are different, then do one of the following:

• Right-click the selection and click **Upload**.

• Drag the selection to the remote location.

• On the main menu, click **File**, then click **Upload**.

• Press CTRL+PAGE UP

| If you are not sure why a file is different and want to compare the HTML contents manually before uploading, you can right-click the file, then click **View**. |

---

Synchronizing Folders

CuteFTP provides a wizard to allow you to synchronize the contents of a local folder with a remote folder and vice versa. The contents are matched accurately so that there is no difference in the contents between the folders. You can monitor more than one folder or synchronize multiple sites. You have to schedule and queue the required synchronizations. **Folder Synchronization Wizard** guides you through the steps required for synchronizing folders.

**To synchronize folders**

1. On the main menu, click **Tools > Folder Tools > Synchronize Folders** (or press CTRL+F11). The **Folder Synchronization Wizard** appears.

2. In the **Enter the local path to synchronize** box, click the folder icon to browse for the folder.

3. In the **Enter the remote path to synchronize** box, type the remote path of the folder.

4. To include the subfolders within the folder you want to synchronize, select the **Include subfolders** check box.

5. Click **Next**.
6. In the **Select the direction of synchronization** box, click one of the following options:
   - **Mirror Local** keeps the local folder the same and changes the remote folder to match the local folder. This is the default selection.
   - **Mirror Remote** keeps the remote folder the same and changes the local folder to match the remote folder.
   - **Mirror Both** adds files to both the folders and puts the latest version of all files in both folders.

7. Click **Next**.

8. In the **For matching filenames always** box, click one of the following:
   - **Use global overwrite settings**. This is the default selection. This option uses overwrite settings configured for all sites in **Tools > Global Options > Transfer > Smart Overwrite**.
   - **Overwrite**. The transferring file replaces the destination file. When mirroring both folders, the most recent version of the file is kept.
   - **Numerate**. Both files are kept, and one is renamed with a number to distinguish between the two.
   - **Skip**. Ignores matching files and transfers only those files that are not present on the other system.

9. In the **Remote file names that differ only in case** box, if the file names are identically spelled but differently cased, you can select one of the following:
   - Transfer first file only and skip others. >The first file transfers and the rest are skipped.
   - Numerate files. Both files are kept. One is renamed with a number to distinguish between the two.
   - Show rename prompt. CuteFTP prompts you to rename one of the identical files.

10. To make the mirrored folder a strict duplicate of the source folder, select the **When one way mirroring, delete the destination file if it does not exist in the source folder** check box. This updates old files and deletes unused files. If you clear this check box, the extra files present in the mirrored folder are left in place.

11. To prompt you before deleting the file, select the **Always prompt before deleting** check box.

12. Click **Next**.

13. To prevent CuteFTP from following symbolic links when mirroring subfolders, select the **Ignore symbolic link** check box. Select this option unless symbolic links are absolutely needed. If you clear this check box and a symbolic link points to a spot further up in the folder tree from where the mirroring began, you are stuck in an infinite loop.

14. To compensate for a problem that occurs when trying to synchronize ASCII files residing on Unix file systems, select the **Transfer all files in binary to compensate for ASCII file differences** check box.

   Windows and UNIX differ slightly on how they store ASCII files, especially with regard to the End of Line (EOL) or line breaks in ASCII documents. This difference causes an otherwise identical file to be seen as "different" when performing a synchronization tasks because of size difference.

   All files are transferred in binary mode, which means that an ASCII file residing on a local system is transferred to the remote server with its EOLs intact.

15. Click **Next**.
16. Click one of the following:
   • To start synchronization of the folders immediately, click Run.
   • To start synchronization of folders at a specified time, click Schedule.

17. Click Next.

18. Do one of the following:
   • If you clicked Run, click Finish to start the synchronization.
   • If you clicked Schedule:
     a. In the Start on area, specify the date and time for the synchronization.
     b. To repeat the synchronization after a specified period, select the Enable recurrence check box, then in the Repeat every box, specify the frequency.
     c. Click Next. The synchronization settings appear.
     d. Verify the synchronization settings, then click Finish to save the settings or click back to edit the settings.

The synchronization task appears in the Queue Window.

**To stop a synchronization task**
1. Select the task in the Queue Window.
2. On the main menu, click Tools > Queue > Remove Selected.

**To use filters with synchronizations**
- When you set up the Folder synchronization wizard, right-click in the pane you want to filter (local or remote), click Filter, and make sure that Enable filtering and Apply to file transfers are selected. Additionally, ensure that the filter definitions are in place when you set up the synchronization wizard. For more information, refer to Filtering transfers.

**Backing Up Local Files to Remote Host**

You can back up files and folders from your local computer to a remote host. (For details of restoring files backed up to a remote host, refer to Restoring Local Files Backed Up to Remote Host.) If you've already created a backup job, skip to Run the Backup Job Again.

**To backup local files to remote host**
1. Log in to the remote host.
2. On the main menu, click Tools > Folder Tools > Backup Local to Remote. The Choose Backup or Restore dialog box appears.
3. Click **Create Backup**, then click **Next**. The **Local Backup Wizard** appears. The Local Backup Wizard contains the list of all local files and directories on your local computer.

4. Select one or more check boxes adjacent to the files and folders to backup. When you select the check box for a folder, each of the subfolders and files in that folder are selected automatically. To clear the check boxes for the subfolders and files the folder, clear the check box next to the parent directory.

5. Click **Next**. The **Select Site and Remote Folder** page appears.
6. Click the Site on which you want to save the backup. The parent directory for the Site appears in the **Select remote folder** box. If necessary, specify the folder on the remote Site to which you want to save the backup, then click **Next**.

7. Select the compression settings from the following options.
   - No compression
   - Compress all files to a single ZIP file - ZIP is an industry standard archival method. ZIP supports most of the files, but provides medium compression.
   - Compress all files to a single CAB file - CAB is a Microsoft format. It provides stronger compression than ZIP.
   - Compress all files to single GZIP file - GZIP/tar is a UNIX format. Files are stored in a "Tarball," and then compressed.

8. Click **Next**. The **Schedule** page appears.
9. Select one of the following options:
   - **Immediately run backup job** option to make a backup immediately.
     - or -
   - **Schedule local backup** check box to set a future date and time, then specify the following options:
     - Set the date and time for the local backup from the **Start on** calendar.
     - Select the **Enable backup recurrence** check box to enable recurring backups.
     - In the **Repeat every** list, specify a frequency.

10. In the **Name** box, specify a name for the backup folder.

11. Click **Finish**. The backup folder appears in the remote folder of the server.

### Run the Backup Job Again

Once the backup has been created, you can reactivate it (run it again) at any time from the same wizard. That is, if you had created a backup job and chose to run it immediately, after it is removed from the queue (either after completion or manually removed), "Activate backup" appears in the wizard.

#### To run a backup job again

1. Log in to the remote host.
2. On the main menu, click **Tools > Folder Tools > Backup Local to Remote**. The **Choose Backup or Restore** dialog box appears.
3. Click Activate backup.
4. In the Inactive backup list, click the backup that you want to run, then click Next.
5. Specify a schedule to run the backup (immediately or in the future), then click Finish.

Restoring Local Files Backed Up to Remote Host

If you have backed up your local files to a remote host, you can restore them using the same wizard. (For details of backing up local files to a remote host, refer to Backing Up Local Files to Remote Host.)

To restore your backed up local files from a remote host

1. On the main menu, click Tools > Folder Tools > Backup Local to Remote. The Choose Backup or Restore dialog box appears.

2. Click Restore. The names of your scheduled backup jobs appear.
3. Click the name of the Job that you want to restore, then click **Next**.

4. Specify the location in which to restore the backup, then click **Next**.
5. Specify one of the following overwrite rules.
   - Use global overwrite settings—Use the setting defined in Global Options.
   - Overwrite—Overwrite files with the same name.
   - Numerate—Make a copy of same-named files and add a number to the copy.
   - Skip—Do not overwrite existing file and skip the restore of that file.

6. Click Next. You are asked to log in to the Site, and then the files are restored.

7. Click OK to close the prompt, and then click Finish to close the wizard.

**Backing Up Remote Folders**

CuteFTP allows you to create copies of remote files and folders on your local computer regularly or at a scheduled time. CuteFTP also compresses the backup automatically.

**To back up a remote folder**

1. On the main menu, click **Tools > Folder Tools > Backup Remote Folders**. The Site Backup Wizard appears.
2. In the **Local path for storing backup file** box, click the folder icon to specify the local folder for the backup.

3. In the **Remote path to backup** box, type the path of the remote folder to be backed up.

4. To include subfolders of the target folder, select the **Include subfolders** check box.

5. Click **Next**.

6. In the **Choose compression type** list, click a compression type:
   - No compression
   - ZIP
   - Cab
   - GZip

7. Click **Next**.

8. Select from the following options.
   - **Run now** - To start the backup immediately.
   - **Schedule** - To schedule the backup at a specified time.

9. Click **Next**.

10. Do one of the following:
    - If you clicked **Run**, click **Finish** to start the backup.
    - If you clicked **Schedule**:
      a. In the **Start on** area, specify the date and time for the synchronization.
      b. To repeat the backup after a specified period, select the **Enable recurrence** check box, then in the **Repeat every** box, specify a time and unit (minute, hours, days, weeks, months, years).
      c. Click **Next**.
      d. Click **Finish**.

   The backup task appears in the **Queue Window**.

**To discontinue a scheduled backup task**

- Right-click the task in the **Queue Window**, then click **Remove Selected**.

**Monitoring a Local Folder for Changes**

CuteFTP allows you to upload any new or modified files or folders added to a specific local folder automatically. The **Folder Monitor** wizard guides you through the steps required for activating the folder monitoring function.

**To upload changes to a local folder automatically**

1. **Connect to the Site** that contains the folder to which you want to upload the changed or new files.

2. On the main menu, click **Tools > Folder Tools > Monitor Local Folders**. The **Folder Monitor Wizard** appears.

3. Specify the local path to the folder you want to monitor.

4. In the **Upload to the following remote path** box, provide the remote path to where you want to upload the files in the monitored folder.
5. To monitor all subdirectories within the target folder, select the **Include subfolders** check box.

6. Click **Next**.

7. Specify the date and the time after which all the files created or modified in the folder are uploaded to the server.

8. To overwrite any file with the same name on the server, select the **Always overwrite** check box.

   *If you select this check box, Smart Overwrite rules are ignored and there is no warning before files are overwritten.*

10. To monitor certain files or file types in a folder, select the **Apply monitor filters** check box.

12. To apply filtering to the particular folders, select the **Apply filtering to folder names** check box.

   *(The filters should be predefined. Refer to Filtering Transfers for details.)*

14. If you want two files with the same name but different case to be treated as two separate files, select the **Use case sensitive filtering** check box.

15. Click **Next**.

16. If you selected filtering, specify which files to include or exclude in the transfer (otherwise, skip this step):

   - Type the file name or file type in the **Include files that match the mask listed below** box, then click **Add**. The file or file type is added to the list of files that are monitored. For example, type `.txt` in the **Include files that match the mask listed below** box, then click **Add**. All the `.txt` files in the folder are monitored.

   - For the files you do not want to monitor, add them to the **Do not include files that match the mask** list.

   - To remove a file from the list, click the file, then click **Remove**.

17. Click **Next**.

18. To use system functions to determine the changes when a file is modified, select the **Attempt to auto-detect changes in monitored folder** check box. If the check box is cleared, CuteFTP cycles through the folder at the rate defined by **Monitor folder every n seconds** and looks for changes to the modified time-stamp.

19. Click **Next**.

20. Click **Finish**.

To later stop monitoring the folder, start the wizard again. The list of monitored folders appears on the first page of the wizard. (You may have to disconnect and then reconnect for the monitored folders to appear.) You can also right-click the job in the Queue, then click **Properties**.

*If you right-click in the Queue, then click **Remove All**, you will remove your Folder Monitor Rules!*  

*Items deleted from the local folder are not deleted from the remote folder. To discontinue a scheduled backup task, select the task in the Queue window, then on the main menu, click **Tools > Queue > Remove Selected**.*
Listing Files on HTTP Sites

To list files on HTTP Sites

1. Connect to an HTTP Site within CuteFTP.
2. Files on the Site will be listed in the remote pane.

When you connect to HTTP Sites in CuteFTP, the Sites do not list file sizes, attributes, or dates like FTP Sites do. This is because HTTP listings are not actual lists of files on the server.

CuteFTP downloads the server's index.html file and parses it, looking for links. Each link is then listed as an available file in the HTTP Site's window. Because this is not an actual file listing, there may be files on the HTTP Site not accessible to CuteFTP. Also, some of the files may just be links that lead to another HTTP Site.

If you connect to an HTTP Site that does not support the listing of folder contents, CuteFTP attempts to guess the contents of the HTTP server by scanning its Web pages.
Chapter 10. Integrated HTML Editor

The topics below provide instructions for using CuteFTP's built-in HTML editor.

**HTML Editor Overview**

CuteFTP has a built-in HTML editor with which you can edit HTML and other ASCII (text)-based documents. The built-in editor was added primarily for remote file editing to enable you to select a document on the remote Site, open it in the editor, make edits, and then save the document in the remote location. You can also use it to edit documents locally.

> You do not have to use the HTML Editor. You can configure a different editor, such as Notepad or EditPlus, to open HTML documents.

**To open the HTML Editor**

- Do one of the following:
  - On the main menu, click **File > New > HTML Document**.
  - In either the **Local** or **Remote** pane, right-click an HTML document, then click **Edit**.

The HTML Editor opens in a new tab. Tags are in different colors from text to make it easier to read. Refer to **HTML Editor Settings** for details of configuring the Editor.

**HTML Editor Settings**

CuteFTP comes with a built-in HTML editor with which you can view and edit HTML files both on your local drive and on remote servers. Alternatively, you can specify a third-party application to view and edit files (such as Notepad, EditPlus, Microsoft Front Page, and so on).

Note the difference between **Opening** and **Viewing** a file:

- On the main menu, click **File > Open** (or press CTRL+E). The file opens in your browser (e.g., Internet Explorer).

- On the main menu, click **File > View** (or press CTRL+W). The file opens in the HTML editor that you specify in the **Helper Applications** node. If you are using the built-in HTML editor, the file opens in the right pane, showing the HTML code. (You can change from tabbed view to full screen on the HTML Editor settings page.)
On the main menu, click **File > Edit** (or press CTRL+ENTER). The file opens in the HTML editor that you specify below. If you are using the built-in HTML editor, the file opens in the right pane, showing the HTML code. (You can change from tabbed view to full screen on the HTML Editor settings page.)

*If you open an HTML file in the built-in HTML editor by clicking **File**, then clicking **View**, you can still edit and save the file.*

**To access Helper Applications**

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Helper Applications** node. The **Helper Applications** options appear.
3. Configure options as described below.
   - To view files in CuteFTP's built-in HTML editor, select the **Use the integrated HTML editor to view files** check box.
   - To specify the application in which to view files, in the **File Viewer** box, clear the check box, then browse for or type the path to the program you want to use.
   - To open files for editing in CuteFTP’s built-in HTML editor, select the **Use the integrated HTML editor to edit files (recommended)** check box. The HTML code for the file appears in the right pane. (You can change from tabbed view to full screen on the HTML Editor settings page.) On the main menu, click **File**, then click **Save** (CTRL+S) or **Save As** to save your changes.
   - To open files for editing in another editor, clear this check box, then in the **File editor** box, browse for or type the path to the program you want to use.

*When you edit remote files in a third-party editor, CuteFTP launches the editor and then monitors the folder containing the temporary file being modified. After you save your changes, CuteFTP uploads the changes to the server.*

4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**To view or edit HTML Editor settings**

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Helper Applications** node, then click **HTML Editor**. The **HTML Editor** options appear.
3. Configure options as described below.
   - To display the editor in full screen, select the **Display editor using Full Screen view** check box. To display the editor as a tab in the CuteFTP window, clear the check box. By default, CuteFTP displays the HTML editor in tab view mode.
   - To add line breaks at the right end of long lines, so that you can see entire lines of code without scrolling to the left or right, select the **Enable word wrap** check box. Clear this check box and the HTML editor will use line breaks where you add them. You might have to scroll to the right to see the ends of longer lines of code.
   - To display numbers at the beginning of each line of code, select the **Prefix each line with line numbers** check box. If word wrap is enabled, the numbers will only display after line breaks you have entered. The line numbers are not saved as part of the document. Clear this check box and no line numbers will be displayed.
To allow the cursor to keep moving to the right after the last character in a line, select the **Allow editing beyond the end of line** check box. Clear this check box to force the cursor to return to the left end of the following line after the last character in a line. (The **Allow editing beyond the end of line** check box is only available if **Enable word wrap** is cleared.)

> If you disable **Allow editing beyond the end of line**, you can still add more characters after the right-most character.

To specify the number of spaces you want the cursor to move to the right when you hit the TAB key, in the **Tab size** box, type a number from 1 to 32.

To change the HTML code and text that is generated automatically when you start a new document in the HTML editor, click **Edit new document template**. The template appears for you to edit. When you have finished making changes, click **Close**.

To specify the type, style, and size of the font displayed in the HTML Editor, click **Choose font for editor**. After you make changes, click **OK**; to abort the changes, click **Cancel**.

4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**To specify display colors for HTML tags and Perl scripts**

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Helper Applications** node, expand the **HTML Editor** node, then click **Colors**. The **HTML Editor Colors** options appear.
3. Configure options as described below.
   - For each HTML tag set and for Perl script components, select a color from the drop-down lists.
   - To use the system default colors for the background (white) and text font (black), select the **Use system settings** check box.
   - To choose different colors for the background and text font, clear the **Use system settings** check box, then in the **Background** and **Text font** drop-down lists, specify the colors.
4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**Default HTML Template**

All HTML documents should contain the following tags:

- **Document Type** `<HTML></HTML>` (beginning and end of file)
- **Header** `<HEAD></HEAD>` (after the HTML tag, but before the BODY tags, includes descriptive info, such as title)
- **Title** `<TITLE></TITLE>` (must be in header)
- **Body** `<BODY></BODY>` (after the HEAD tags, bulk of the page)

When you create a new HTML document with CuteFTP's HTML Editor, it uses the default HTML template shown in the **New document template** dialog box.

**To open the default HTML template**

1. On the main menu, click **Tools > Global Options**. The **Global Options** dialog box appears.
2. Expand the Helper Applications node, then click HTML Editor.


Each of the tags shown in the template are required, except for the META tags. The attributes in the Body tag, BGCOLOR="#FFFFFF" TEXT="#000000" LINK="#0000FF" VLINK="#800080", define the background color (BGCOLOR is white), text color (black), and the colors of hyperlinks (blue) and visited hyperlinks (dark magenta) in the document.

4. Add/remove tags or edit attributes that you want to appear in each of your new HTML documents, then click Close. The changes are saved when you close the dialog box.

A link to your style sheet is one tag you might want to add to your default template.

**HTML Tags for a Specific Browser**

The HTML Editor can automatically provide suggestions for HTML tags that work for specific browsers. The HTML Editor offers HTML tag choices in drop down boxes. These are called tag tips.

**To show tag tips**

1. On the main menu, click Tools > Global Options (or press ALT+F7).

1. Expand the Helper Applications node, expand the HTML Editor node, then click Tag tips. The HTML Editor Tag tips options appear.
2. To show tag tips, select the **Show tag tips** check box. Clear the **Show tag tips** check box to keep tag tips hidden.
   - To specify how long the tag tips take to appear, in the **Tag tips delay in milliseconds** box, type a time for the HTML editor to wait before showing tag tips.
   - To capitalize all tag tips, select the **Capitalize tag tips** check box. Clear the **Capitalize tag tips** check box to leave tag tips in lower case.

3. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.

**HTML Code Snippets and Java Scripts**

To specify the folder for code snippets and previewing HTML documents from CuteFTP

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Helper Applications** node, expand the **HTML Editor** node, then click **Folders**. The **HTML Editor Folders** options appear.
3. Configure options as described below.
   - To specify a browser other than the default, clear the **Preview using the default browser** check box, then in the **Browser path** box, browse for or type the path to the browser executable file.
   - To specify the folder in which you want to store code snippets, in the **Code snippets** box, browse for or type the path.
   - To specify the folder in which you want to store Java scripts, in the **Java scripts** box, browse for or type the path.

4. Click **Apply** if you are going to make changes to other pages; click **OK** to save changes and close the **Global Options** dialog box.
Creating a New HTML Document

You can create new HTML documents within the CuteFTP interface.

To create a new HTML document

1. Do one of the following:
   - On the main menu, click **File > New > HTML Document**.
   - On the HTML Editor toolbar, click the **New HTML document** icon.
   - Press **CTRL+H**.

   A new HTML document appears in which you can use HTML tags to create the document.

2. Type the content of your HTML document, that is, the part you want your viewers to see, between the two **BODY** tags.

   Every HTML document must contain, at minimum, the **tags in the default HTML template**. The template as is will display a blank page.

3. To change HTML editor settings, including editing the default template, and opening in full view instead of tab view, refer to **HTML Editor Settings** and **Editing the Default HTML Template**.

Finding and Replacing Text in HTML Documents

Using the integrated editor’s powerful search and replace tool, you can search and replace characters, words, sentences, or entire paragraphs.

To open search and replace

1. Click within the HTML Editor pane, then on the main menu, click **Edit**, then click **Find/Replace** (or press **CTRL+F**). The **Find/Replace** dialog box appears.

2. In the **Search for** box, type the words to search for or change.

3. In the **Replace with** box, type the replacement words or phrase.

   When entering text into the **Search for** or **Replace with** fields, use **Ctrl+Enter** to insert a line break.

4. In the **Where to search** area, specify whether to search only the selected document or all open documents.

5. If you want to match upper or lower case (depending on which you have typed in the boxes above, select the **Match case** check box.

6. Click **Find**.

7. If a match is found, it is replaced. To continue to search and replace throughout the document, select **Find Next** for each instance (or press F3).

Because it replaces all occurrences, be very careful when choosing the replace option. For example, if you want to change all occurrences of ‘one’ to ‘1’, it will also change words like ‘everyone’ to ‘every1’.
Page Loading Speed and File Size

The Document Data dialog box provides information about the document currently being edited, including file size and how fast the page will load at various speeds.

To open the Document Data dialog box

1. Click within the HTML Editor pane to ensure that it is the active pane.
2. On the main menu, click **Tools**, then click **Document Data**. The Document Data dialog box appears.

3. Click the **Weight** drop-down menu to view the document information at different bit rates: 14.4, 28.8, 56.6 bps.
   - The **Text Size** area displays the total size of text contained in the document, in kilobytes.
   - The **Image Size** area displays the total size of images contained in the document, in kilobytes.
   - The **Total Size** area displays the total size of text and images combined, in kilobytes.
   - The **Weight** area displays the approximate number of seconds your page will take to load based on the size of the file and the modem speed of your viewers. Click the down arrow on the modem speed box to see how soon the page displays at various speeds.
   - The **Images** box displays a list of all images in the document.
   - The **Anchors** box displays a list of all anchors in the document.

2. If the number of seconds in the **Weight** area seems excessive, you can shorten the time it takes to display your page by doing some or all of the following:
   - Remove excess code or text, or use smaller graphics files.
   - If you are using graphics to display bullets in lists, remove the images used for the bullets, and instead use **list tags** to create lists. You will also have fewer files to transfer and maintain if you eliminate the graphic bullets.
   - Use a style sheet (CSS file) and link each of your pages to the style sheet. You will need fewer tags within each document, creating smaller files with a faster upload speed. Style sheets also create a "consistent look and feel" for your website. For more information about using style sheets, refer to [http://www.w3schools.com/css/default.asp](http://www.w3schools.com/css/default.asp).
Review your code for extra tags that you do nothing to enhance your page. For example, this `<P>&nbsp;</P>` or this `<P>&#160;</P>` makes a paragraph space between paragraphs. If you do not need the extra space, you can remove it; however, adding "white space" such as this often enhances readability.

Use tables or `<blockquote>` `<</blockquote>` to indent paragraphs, rather than using multiple `&nbsp;` (non-breaking space) tags to indent text.

### Basic HTML Tags

All HTML documents should contain the following tags:

- **Document Type** `<HTML></HTML>` (beginning and end of file)
- **Header** `<HEAD></HEAD>` (after the HTML tag, but before the BODY tags, includes descriptive info, such as title)
- **Title** `<TITLE></TITLE>` (must be in header)
- **Body** `<BODY></BODY>` (after the HEAD tags, bulk of the page)

When you create a new HTML document with CuteFTP's HTML Editor, it uses the default HTML template. You can change the attributes as you see fit.

Tag text is color coded to make the HTML easier to read. You can change the default colors in the HTML editor in Global Options. For example, the HTML code for that last sentence looks like this:

You can `<a href='Helper_Applications.htm'>change the default colors</a>` in the HTML editor in `<span style='font-weight: bold;'>Global Options</span>`.

### To insert a paragraph

1. Click in the document where you want to insert a paragraph, then type `<p></p>`
2. Type text between the paragraph tags. For example, type:
   `<p>Welcome to my wonderful website!</p>`

   It doesn't matter if you type the tag with lowercase or capital letters.

The HTML Editor toolbar allows you to insert basic HTML tags into your page, without any prior knowledge of HTML code.

### To format text

- Select the text you want to format, then do one of the following:
  - To bold the text, click the **Bold** icon `B`.
  - To italicize the text, click the **Italic** icon `I`.
  - To underline the text, click the **Underline** icon `U`.
  - To format the font face, size, and color, click the **Font** icon `A`. In the **Font tag** dialog box, click the down arrow to specify the Font (e.g., Arial), Color (e.g., Red), and Size (e.g., 1). As a base font size for a document, 1em (or 100%) is equivalent to setting the font size to the user's preference. Avoid sizes in em smaller than 1em for text body, except for copyright statements or other kinds of "fine print." Do not specify the font size in pt, or other absolute length units. They do not appear the same on all computers and cannot be resized by the browser.
To insert a table

- Click the **Table** icon then on the graphic that appears, use your cursor to highlight the number of rows and columns you want. When you click the selection, the table tags appear in your document. Type the content for each cell between the tags. *(Tip: Click the **Browser** icon to preview how the table will look.)* You can even insert images into the table.

To insert an image

1. Click the **Image** icon. The **Image tag** dialog box appears.
2. Specify the location of the image, then click **OK**.

*The steps above are sufficient to insert an image; however, you can experiment with the advanced settings when you are comfortable in HTML. Regarding the **Width** and **Height** boxes, it is better for page loading if you size the graphic itself properly in your graphics editor, rather than adjusting the size with **Width** and **Height** attributes. Inserting a huge graphic and then downsizing it with the **Width** and **Height** attributes will cause your page to load very slowly (and your viewers to leave your website!)*

To insert a hyperlink

1. Select the text that you want to make a link.
2. Click the **Hyperlink** icon. The **Hyperlink tag** dialog box appears.

   ![Hyperlink tag dialog box](image)

   - In the **HREF** box, type the URL to which you want to link the highlighted text.
   - In the **Target** box, click an attribute:
     - `_blank` - the target URL opens in a new window
     - `_self` - the target URL opens in the same window
     - `_parent` - the target URL opens in the parent frame
     - `_top` - the target URL opens in the full body of the window
   - In the **Name** box, type a name for the tag (optional).
   - Click **OK** to insert the tag.

To insert a comment

Comments are used to notate your code to remind yourself why you inserted a particular element, or for team members editing the same documents.

- Click the **Comment** icon. The Comment tags are inserted into the document. Type your comment between `<! --` and `-- >`. 
Cascading Style Sheets (CSS)

Cascading Style Sheets (CSS) are used to define the attributes of the tags in your HTML documents. Although not required, they make designing and, more importantly, updating HTML documents much more efficient. For example, if you have defined the BODY tag in a linked style sheet to display the page with a white background and black text, you can change the background to yellow in one file—the style sheet—and that change appears in every one of your HTML documents that are linked to that style sheet. You can also have more than one style sheet if you want different sections of your site to have a different look.

When you use a style sheet, you do not need to add the attributes for the BODY tag to every single HTML document. The BODY tag is defined in the style sheet and each of your Web pages contain a link to the style sheet. The link to your style sheet is one tag you might want to add to your default template. For example, if your style sheet is named `default.css`, you would add the following tag between the `<HEAD></HEAD>` tags of your default template, after the META tags:

```html
<link rel="StyleSheet" href="default.css">
```

In the example above, the style sheet is placed in the same directory as the HTML documents to which it is linked; otherwise, you need to add a path to the style sheet in the link. For example, if your HTML documents are in a folder called `htms` and your style sheet is in a folder called `css`, and both of those folders are in a folder called `myweb`, you would type the link as follows:

```html
<link rel="StyleSheet" href="../css/default.css">
```

The `../css/` part of the tag (red text shown for emphasis only) tells CuteFTP to search up one directory and look in the `css` directory for the file.

Your style sheet can contain tags for just one or several tags, such as default paragraph font face, size, color, and margins, table format, heading styles, headers, footers, and so on.
Using Colors

In HTML documents, when you want to change the font color, you have to type a hexadecimal value for the color. The code is in hexadecimal with a pound sign and 6 characters from 0 (zero) to F (fifteen in hexadecimal). Some of the most common colors are shown below; however, the Color utility in CuteFTP eliminates the need to memorize the HTML codes for colors.

<table>
<thead>
<tr>
<th>Color Name</th>
<th>Hex Code</th>
<th>RGB (Red, Green, Blue) Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>black</td>
<td>#000000</td>
<td>0,0,0</td>
</tr>
<tr>
<td>white</td>
<td>#FFFFFF</td>
<td>255,255,255</td>
</tr>
<tr>
<td>red</td>
<td>#FF0000</td>
<td>255,0,0</td>
</tr>
<tr>
<td>blue</td>
<td>#0000FF</td>
<td>0,0,255</td>
</tr>
<tr>
<td>green</td>
<td>#00FF00</td>
<td>0,255,0</td>
</tr>
<tr>
<td>yellow</td>
<td>#FFFF00</td>
<td>255,255,0</td>
</tr>
</tbody>
</table>

To open the color options

1. Click within the HTML Editor pane at the location where you want to paste the hexadecimal color code.
2. On the main menu, click Tools > Color to HEX. (This option is not available if you do not click within the HTML Editor pane first.) The Color dialog box appears.
3. Click the color to use.
4. If you want to use browser-safe colors only, select the Paste browser safe color check box.
5. Choose OK to insert the HEX code for the selected color into your document. For example:

   `<p><font color="FF0000">text</font>`

For more information about using colors in HTML documents, as well as a chart of many different color codes, refer to http://www.w3schools.com/html/html_colors.asp.
Saving HTML Documents

Before attempting to save a document, make sure the file you want to save is visible in the right pane.

To save the file in its current location with its current name

- Do one of the following:
  - On the main menu, click **File > Save**.
  - On the HTML editor toolbar, click the **Save** icon.
  - Press CTRL+S.
  - Right-click within the HTML document, click **File > Save**.

> **If the file has never been saved before, CuteFTP opens the **Save As** dialog box.**

To save the file with a new name and/or location

- Do one of the following:
  - On the main menu, click **File > Save As**.
  - Right-click within the HTML document, click **File > Save As**.
  - In the **Save As** dialog box, specify the file name and location, then click **Save**.

To save all open HTML documents at the same time

a. On the main menu, click **File > Save All**. All open documents are saved. If you have not saved all of them previously, the **Save As** dialog box appears for each new file.

b. Specify a name and location for each new file, then click **Save**.

> **Each open HTML document has a tab with its name on it.**

Opening an HTML Document for Editing

You can open HTML documents for editing within CuteFTP.

To open an HTML document for editing

1. Do one of the following:
   - On the main menu, click **File > Open file** (or press CTRL+O). In the **Open** dialog box, browse to and select the document, then click **Open**.
   - In the **Local Drives** or **Remote** pane, right-click the document, then click **Edit**.

2. The document opens in the editor that you have specified in **HTML Editor Settings**.

When you edit the document in the HTML editor, the file name text in the tab turns red and is underlined to indicate that the file has been modified.
Previewing an HTML Document in a Browser

From within CuteFTP, you can open an HTML document in your default browser. To change your default browser, open the browser that you want to be your default, then specify in the browser that it is the default. (When you open Internet Explorer or Firefox and it is not the default browser, it will ask you to make it the default, usually by clicking Yes or selecting a check box.)

To preview an HTML document in a browser

1. Open an HTML document in CuteFTP.
2. Click anywhere in the document, then do one of the following:
   - On the main menu, click **Tools > View in Browser**.
   - On the HTML editor toolbar, click **View in Browser**.

To close the preview

- Do one of the following:
  - In the upper-right corner of the browser window, click **Close**.
  - On the main menu of the browser, click **File > Close**.

To use a browser other than the default browser

1. In the **Global Options** dialog box, expand the **Helper Applications** node, then expand the **HTML Editor** node.
2. Click the **Folders** node.
3. In the **Preview in browser** area, clear the **Preview using the default browser** check box.
4. In the **Browser path** box, specify the path to the browser you want to use.
5. Click **OK** to save the changes.

Editing an HTML Document on a Remote Site

To edit HTML documents on a remote Site

1. Connect to a remote server.
2. In the **Remote** pane, click an HTML document.
3. Do one of the following:
   - On the main menu, click **File > Edit**.
   - Right-click the file, then click **Edit**.
   - Press **CTRL+ENTER**.
4. The document will be downloaded and opened in the built-in HTML editor or the editor you have defined in **Global Options**.
5. Make your changes to the document, then save the changes. The saved document will be uploaded to the remote server.

When you edit the document in the HTML Editor, the file name text in the tab turns red and is underlined to indicate that the file has been modified.
Printing an HTML Document

To print a document
1. Open a document in the HTML editor.
2. Do one of the following:
   - On the main menu, click File > Print.
   - Press CTRL+P.

⚠️ The document prints as it appears in the HTML editor, NOT as it appears in a browser.

To see a print preview
1. Open a document in the HTML editor.
2. On the main menu, click File > Print Preview. The Preview dialog box appears.
3. Do one or more of the following:
   - To increase/decrease magnification, click Zoom In/Zoom Out.
   - To display two pages at a time, click Two Page.
   - To scroll through multiple pages, click Next page and Prev Page.
   - To send the document to the printer, in the preview dialog box, click Print.
   - Click Close to close the dialog box.

To change the printer setup (such as the printer, paper size or orientation)
1. Open a document in the HTML editor.
2. On the main menu, click File > Print Setup. The Print Setup dialog box appears.
3. Specify the printer, printer properties, paper size, paper source, and orientation, then click OK to accept, or Cancel to abort changes.

⚠️ While a document is printing, a printer icon appears next to the clock on the task bar. When this icon disappears, your entire document has been sent to the printer.

Closing an HTML Document

To close an HTML document
1. Make sure the document you want to close is visible in the right pane.
2. Do one of the following:
   - On the main menu, click File > Close.
   - In the upper-right corner of CuteFTP, click Close.
   - Right-click within the HTML document click File > Close.
   - At the top of the HTML document, right-click the tab, then click Close.
3. If your document has unsaved changes, you are prompted to save the changes. Click one of the following:
   - Yes to save the document.
   - No to exit without saving the document.
   - Cancel to return to the document without saving the document.

**Opening the HTML Editor in a Full Window**

The HTML editor opens in the Remote pane or a full window, depending on the selection in Global Options.

**To open an HTML document in the Remote pane or a full window**

1. On the main menu, click Tools > Global Options (or press ALT+F7).
2. Expand the Helper Applications > HTML Editor. The HTML Editor options appear.
3. Select or clear the Display editor using Full-Screen view check box.

*In Full-Screen view, the editor opens in the full CuteFTP window. To close Full-Screen view, click the ☒ in the upper-right corner or on the main menu, click File, then click Close. The CuteFTP interface will reappear.*

**Adding Counters and Other Utilities**

Globalscape does not offer support for creating or coding advanced HTML. If you want to add counters, animations, or other special effects to a Web page, you will need to seek other sources. Many Web hosting services provide extras, such as counters, that you can add to Web pages hosted on their servers. Usually, the code that they provide you to paste into your Web page links to code stored on their server, so the same code might not work if you move your Web page to a different server.

Search your Web hosting provider's Web pages to see if they offer code for counters or other add-ons.

**Learning HTML**

HTML code uses tags to define how text, pictures, and other objects are to appear in a Web browser, such as Internet Explorer. Numerous websites explain HTML tags and how to use them. Like software applications, HTML code comes in versions, some of which are not supported by common browsers. For the most current version of HTML code that is supported by most common browsers, search the Web for free guides and tutorials. The World Wide Web Consortium, a cooperative of Web developers and designers, provides standards for HTML and CSS code, as well as tutorials for beginners and advanced users.

While you search for tutorials about how to code your Web pages, keep in mind that, although most browsers support HTML v4, many Web developers have moved on to XHTML, which is a more strict version of HTML. Also, most websites now use cascading style sheets (CSS) to help maintain a consistent design across all Web pages on the Site, and allow you to update an entire website design simply by changing one file, the style sheet.

**Here are a few references to get you started:**

- [Getting started with HTML](#)
- [W3 Schools (Web building tutorials for beginners to developers)](#)
- [Introduction to HTML, including listings of common tags](#)
This page left blank for 2-sided "book" printing.
Chapter 11. Transfer Engine (Scripting)

The topics below provide the procedures for using the Transfer Engine.

About the Transfer Engine

CuteFTP's FTP Transfer Engine (TE) is completely independent of the main application's interface. The Transfer Engine (TE) runs invisibly in the background and does most of the real work that CuteFTP does. The TE program allows features such as scheduled transfers to operate in the background while the CuteFTP interface is closed. In CuteFTP, you can interact with the Transfer Engine through an industry-standard COM (Component Object Model) interface using your favorite programming or scripting language, such as Visual Basic, Perl, ASP or JavaScript.

The Transfer Engine:
- Is COM enabled
- Takes up minimal resources
- Handles background transfers
- Handles transfers outside the main interface
- Handles continuous folder synchronization events
- Can be used with a custom application or script to perform FTP related tasks.

CuteFTP relies on two executables for file transfers:
- Cuteftppro.exe is the CuteFTP interface
- ftpte.exe is the Transfer Engine (TE)

The Transfer Engine requires an NT login and will not run as an NT service; however, it is configured by default to start on Windows startup. You can change this setting in the CuteFTP interface Global Options dialog box.

Some of the actions you can accomplish using the TE include:
- Log in to an FTP server over a defined port
- Log in using an encrypted authentication mechanism, such as OTP
- Log in and transfer files using industry standard SSL/TLS (explicit & implicit modes supported)
- Log in and transfer files using SSH2
- Log in to Sites through Firewalls or Socks or Proxy servers
- Transfer files one at a time or simultaneously
- Transfer files using multi-part transfers to increase throughput
- Transfer files from one remote Site to another
- Transfer files using a wildcard mask
- Transfer files obtained from server-side links
- Perform folder synchronization tasks
- Check on an item's transfer status
To access Transfer Engine features

The Transfer Engine starts when the CuteFTP interface opens or on Windows startup when selected in the CuteFTP interface. When the Transfer Engine is started, its icon appears in the Windows system tray.

- Right-click the TE icon in the Windows system tray. The Transfer Engine menu appears. (Certain features are only available when the CuteFTP interface is closed.)

  - To view information about the Transfer Engine, including your serial number, click About.
  - To open the CuteFTP interface, click Launch CuteFTP interface.
  - To access the current download queue (only visible if the CuteFTP interface is closed), click Show current Transfers. The Transfer Queue appears. (You can also open the Transfer Queue by double-clicking the TE icon.)
  - To download from a Site by typing the URL, click Download URL.

The Transfer Queue displays each item queued for transfer. For example, if you are monitoring a folder for changes and scheduled them for uploading to a remote location, the queue displays each item and its properties. You can specify which properties to hide or display by right-clicking on the header of the queue. All properties are selected by default. Clear the check box to hide a property. Arrange the columns by clicking and dragging the column header.

- To download from a specific URL, click Download URL.
- To activate a new serial number, click Enter Serial Number. (Not available when the CuteFTP interface is open. To activate a serial number when the interface is open, click Help, then click Enter a Serial Number.)
- To request your serial number from Globalscape Support, click Find Lost Serial Number. The Globalscape Support Lost Serial Number request web page appears. (Not available when the CuteFTP interface is open. To request your serial number when the interface is open, click Help, then click Locate a Lost Serial Number.)
- If you are using a trial serial number and want to purchase a license, click How to Purchase. The Purchase CuteFTP web page appears. (Not available when the CuteFTP interface is open. To purchase CuteFTP when the interface is open, click Help, then click Purchase Now.)
- To close the TE, click Exit Transfer Engine.

Transfer Engine Licensing Requirements

The TE is licensed with CuteFTP. The TE is a component of CuteFTP, therefore any computer with a licensed copy of CuteFTP can access the TE through the CuteFTP interface or through its COM interface.
Transfer Engine (TE) Initial Setup

The Transfer Engine object must be registered as a COM component on the target system. The TE automatically performs COM registration if it has been manually executed (run once) prior to a script or application instantiating (calling) the TE object.

In order to run script files, you must have the Windows Scripting Host (WSH) installed. WSH relies on the Visual Basic Script and JavaScript engines provided with Internet Explorer 3.0 or later. WSH is also installed as a part of Windows 98, Windows 2000, and Internet Information Server (IIS) 4.0.

To register the TE COM component

- Do one of the following:
  - Launch CuteFTP, then close CuteFTP.
  - In the CuteFTP installation folder, double-click `ftpte.exe`, right-click the TE icon in the system tray, then click Exit Transfer Engine.

   It should now be registered.

Once the TE is registered, you can create script files to interface with it. You can create your own scripts or use the scripts included in this user guide, modifying the script to suit your needs.

Distributing and Licensing the Transfer Engine

If you have created a script or application that calls the TE, you may wish to distribute your script or application to a group of end-users.

CuteFTP's Transfer Engine (TE) is subject to End User License Agreement and can only be distributed in its current form (evaluation software). However you can purchase a license for and register the trial version of the TE on each computer you install it on.

Then, you must configure the TE so that it can run properly without the CuteFTP GUI (interface) installed, especially if you plan to run automated or scheduled tasks while not logged in, or if you plan to connect to SSL enabled FTP servers.

Contact Globalscape and request special licensing arrangements when distributing to large amounts of users.

Licensing - Steps to License the TE

1. Determine how many copies (seats) you will need.
3. Click the Purchase link.
4. Purchase one license for each seat you need. If you need to purchase a license to cover a large number of seats, please contact Globalscape support.
5. Once registered, check your email for the serial number.

Licensing Considerations

- The TE inherits its registration process from CuteFTP. If running on a system that has a registered copy of CuteFTP installed, you do not need to register the TE. If CuteFTP is not installed (or registered), you must register the TE.
• The TE runs through a 30-day trial just like CuteFTP. Therefore, the TE may be distributed royalty-free with unlimited runtimes for 30 days from the time it is installed on an end-user's computer.

• After residing 30 days on the target computer, it disables itself if not properly registered. The TE must be registered either prior to first launch, during the trial, or after the trial has expired.

• When you purchase a license for CuteFTP you may NOT distribute CuteFTP or any of its sub-components (such as the Transfer Engine) in an unlimited royalty free fashion.

• Each copy of the distributed Transfer Engine must be licensed for each computer where it is installed. This means you must purchase a full license of CuteFTP for each distributed copy of the TE.

• You can purchase the necessary amount of licenses up front or after the TE has expired on the end-user computer. The benefit of licensing up front is that you can distribute the TE and register it on the end-user's computer. They will not see any prompts or registration related dialogs.

• Once you have licensed the TE, you must install it (if not already installed) and then register it on each target computer.

• You are not permitted to distribute the TE as a component of an FTP client or other product that competes with CuteFTP or Globalscape's EFT Server.

Installing the TE (for Distribution)

You do NOT need to install the full copy of CuteFTP on the end-user's computer. If you were distributing a custom-made application, this would not be the case.

Installation - Steps to Install the TE

1. Locate the TE component (ftpte.exe), the End User License Agreement (license.txt), and the TE's subordinate dynamic link libraries (sftp21.dll, ssl.dll, etc.) and the resource file (default.lng) on your developer (source) computer.

2. Package the TE along with the other items mentioned in step 1, along with your installation program, script, or executable.

For setting specific options only available through the GUI (that is, no property or method available), you can copy specific registry settings from the source computer to the destination. Most all settings are stored in the registry under the following hive:

HKEY_CURRENT_USER\Software\Globalscape\CuteFTP

Registering the TE (for distribution)

You can register the TE automatically or manually using the procedures below.

Registration - Automated Registration

The first method of registering the TE is the most efficient when dealing with a large amount of target systems, or when you do not have direct access to the target system. Your application installer or script can perform the steps below to transparently register the TE.

1. Purchase a license for the amount of TE seats that you want to distribute.

2. Install a copy of the Transfer Engine and related components onto the target computer.

3. Create a new registry key on the target computer at the following location:

HKEY_USERS\.DEFAULT\Software\Globalscape\CuteFTP\Index

4. Create a new string value in the key above and insert the serial number as the data value.
String Value = "1"
Data = "[Your Serial Number]"

5. When the transfer engine is called for the first time, it retrieves this value (the serial number) and uses it to complete the registration with Globalscape.

The target computer must have access to the Internet. If no Internet access is available, the registration process may fail and disable the TE. The TE is automatically registered if it is installed onto a computer with a registered copy of CuteFTP. Keep in mind that the TE must be the same version as CuteFTP.

Registration - Manual Registration

If you have physical access to the target computer or want to register the copy installed on your developer computer, do the following:

1. Right-click the **TE icon** in the system tray to display the context menu (while running, the TE is represented by a yellow folder icon with up and down arrows), then click **Enter Serial Number**.

2. Paste or type the serial number, then click **Register**.

A message should appear declaring that the registration was successful. The TE can now be used on that computer without interruptions.

If you receive an error message, verify that the serial number was typed correctly and that the number of licensed computers does not exceed the licenses purchased. If all this is correct and you are still unable to register, contact the Globalscape support department and provide them with the exact details of the error received.

COM Registration of the TE (for Distribution)

As a typical COM component, the TE must be registered as such on the target system. The TE automatically performs COM registration if it has been manually executed prior to a script or application instantiating the TE object.

The preferred method (for distributed versions of the TE on end-user's systems) is to set the appropriate registry entries before trying to call the TE.

COM Registration via the Registry

From your installation program, script, or custom application, write the registry entries below to the target computer. The entries are shown in the standard .reg file notation.

Include the correct the path to the Transfer Engine (/installpath/ftpte.exe) where **%MODULE%** is shown below.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\CuteFTPPro.TEConnection]
@="TEConnection Class"

[HKEY_CURRENT_USER\Software\Classes\CuteFTPPro.TEConnection\CLSID]
@="{112EA537-7AB9-4e22-8BFB-7FD5FCB19849}"

[HKEY_CURRENT_USER\Software\Classes\CuteFTPPro.TEConnection\CurVer]
@="CuteFTPPro.TEConnection.8"

[HKEY_CURRENT_USER\Software\Classes\CuteFTPPro.TEConnection.8]
@="TEConnection Class"

[HKEY_CURRENT_USER\Software\Classes\CuteFTPPro.TEConnection.8\CLSID]
@="{112EA537-7AB9-4e22-8BFB-7FD5FCB19849}"
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{112EA537-7AB9-4e22-8BFB-7FD5FCB19849\}]
@="TEConnection Class"
"AppID"="{DA15006A-FADA-495b-9A0C-EC2107E2FB9F}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{112EA537-7AB9-4e22-8BFB-7FD5FCB19849\}\LocalServer32]
@=""C:\Program Files\Globalscape\CuteFTP 8 Professional\ftpte.exe""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{112EA537-7AB9-4e22-8BFB-7FD5FCB19849\}\ProgID]
@="CuteFTPPro.TEConnection.8"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{112EA537-7AB9-4e22-8BFB-7FD5FCB19849\}\Programmable]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{112EA537-7AB9-4e22-8BFB-7FD5FCB19849\}\TypeLib]
@="{1804F22B-5012-432d-8EA0-B57DD75EBF9D}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{112EA537-7AB9-4e22-8BFB-7FD5FCB19849\}\VersionIndependentProgID]
@="CuteFTPPro.TEConnection"

Finalizing TE Distribution

Once the TE has been licensed, installed, registered, and COM registered on the target system, your
script or custom application should be able to instantiate the TE object, and invoke any one of the
supported methods or properties.

For a complete description of the TE, including its supported methods and properties, sample scripts and
extended trouble shooting guide, please refer to the related topics in this user guide and our online
knowledgebase.

Troubleshooting TE Distribution

Described below are some common issues encountered when distributing the TE.

Problems with running scripts while not logged in (suppressing message prompts or dialogs)

Your script should not contain Message Box functions or any other function that requires user input or
shows a dialog box. These prompts do not display when the system is not logged in.

You can physically suppress prompts from ever appearing. Use the –noprompts flag and execute the
TE from the shell on the target computer before calling it from the script. For example, run c:\program
files\mycustomapp\ftpte.exe – noprompts.

⚠️ Suppressing prompts may cause lockups if no default action is available for the event in question,
or if the prompt was produced by an error.

The best way to avoid prompts is to properly configure the TE ahead of time to cover all possible prompt
scenarios, such as overwrite conditions, or SSL server certificate acceptance dialogs. For example, set
your overwrite actions under CuteFTP’s global settings to Always Overwrite to avoid any overwrite
prompts, or pre-define various rules to cover various overwrite scenarios. You can then export those rules
as registry entries and import them onto the target computer.

You can also tell the TE to auto-accept SSL or SSH certificates using the AutoCloseMethod parameter
of the Option property. Also refer to the following trouble shooting topic regarding running the TE while
not logged in.
Locked TE

If your script or application runs the TE and does not return control to the script, it is possible that the TE has locked. Before trying to troubleshoot the problem, make sure you exit the locked TE process using the Windows Task Manager (kill the ftpte.exe process).

If your script is connecting to an SSL enabled server, double check the steps listed under Handling SSL Certificates. The primary cause for a locked TE during an SSL connection is the fact that the TE could not locate the client or server certificate, or the client certificate does not reside in the server's trusted list.

An incorrect FTP host address or other common connection problem (host not available, connection refused, etc.) can lock up the TE. Verify that the host, proxy, socks, user, and password property value are correct.

The TE may also lock up if an improperly registered TE is launched and unsuccessfully tries to display the registration reminder (Web nag dialog).

Lastly, not properly configuring DCOM configuration for the TE to access the target user's settings may cause the TE to lock up.

If the system is currently logged in when the TE is run, it runs as the user specified under DCOMCNFG. The TE icon does not display in the system tray when the CuteFTP's main interface runs. Also, the hard coded user's settings are employed when the TE is run, not those of the currently logged in user. This is not an issue if you are running the TE when the system is not logged in.

Using the TE to Connect via FTPS (When Running a Script and not Logged In)

Setting up the TE to connect to an FTP server over SSL (via scripting) involves several steps. Follow the instructions below carefully.

You must know whether the TE will require the use of server certificates only or both server and client certificates.

Server Certificates

Most FTP SSL servers will provide a certificate to the client during authentication. The certificate proves the server's legitimacy to the client. The server's certificate must be added the client's Trusted Certificate store prior to any connection, otherwise the TE will lock up when trying to authenticate.

To add the SSL certificate to the client's Trusted Certificate store

1. Export or obtain a copy of the server's certificate from the FTP server administrator. Otherwise connect to the server with the CuteFTP GUI (interface) from the developer computer and manually accept the server's certificate. You can then export it from the Trusted List under Global Options > Security > SSL Security to a staging directory of your choice.

2. Place/Install the certificate into the target computer's Default User directory. For example:

C:\Documents and Settings\Default User\Application Data\Globalscape\CuteFTP\Security

3. If you will also be running the TE while logged in, place a copy of the server certificate under the USER folder on the target computer, as follows:

C:\Documents and Settings\[USERNAME]\Application Data\Globalscape\CuteFTP\Security

- where [USERNAME] is the login name for the user.

4. Configure the TE to auto-accept SSL or SSH certificates using the AutoCloseMethod parameter of the Option parameter. Also refer to the following trouble shooting topic regarding running the TE while not logged in.
Now when you connect, the TE sees the server’s certificate and proceed with the connection.

**Client Certificates**

Some FTP SSL servers require that the client provide a certificate. The certificate proves the veracity of the client and is an important factor in weeding out spurious FTP clients masquerading as legitimate ones.

**To setup the target system to use client certificates**

1. On the developer computer, create the client certificate and private key pair using the CuteFTP GUI (interface). The certificate creation utility is located under the **Tools > Global Settings > Security > SSL** dialog.

2. Add the client certificate to the server’s trusted list. Do this by connecting to the server with the CuteFTP GUI (interface) from the developer computer. On the server, move the certificate from the Pending to the Trusted list. If your server only has a Trusted list, manually import the client certificate into the Trusted list.

3. Place the client certificate and private key into the target computer’s USER folder:

   ```
   C:\Documents and Settings\[USERNAME]\Application
   Data\Globalscape\CuteFTP\Security
   ```

   - where [USERNAME] is the login name for the user.

4. If you created the certificate set on the developer computer, export the following registry key:

   ```
   HKEY_CURRENT_USER\Software\Globalscape\CuteFTP\Settings\SecuritySSL
   ```

5. Import the registry key from step 4 onto the target computer, or manually create the necessary entries. The entries are shown in standard .reg file notation.

   ```
   REGEDIT4
   [HKEY_CURRENT_USER\Software\Globalscape\CuteFTP\Settings\SecuritySSL]
   "SSLCertificate"="C:\Documents and Settings\[USERNAME]\Application
   Data\Globalscape\CuteFTP\Security\client.crt"
   "SSLPrivateKey"="C:\Documents and Settings\[USERNAME]\Application
   Data\Globalscape\CuteFTP\Security\client.key"
   "UseSSLCertificate"=dword:00000001
   "UseSSLCertPassphrase"=dword:00000001
   "ReuseSSLData"=dword:00000000
   "WarnWhenToNonSecure"=dword:00000001
   "DataTransportMethod"=dword:00000001
   "SSLCertPassphrase"=[PASSWORD]"
   ```

   - where [USERNAME] is the login name for the target system and where [PASSWORD] is the encrypted password exported from the source computer. *Do not modify the password exported from the source computer!*

At the next connection, the TE finds the client certificate and uses it to authenticate with the server.

**Example**

Below is a sample script that connects to a fictitious Site running SSL Implicit over port 990. It also writes to the event log for debugging purposes. if you use this script to test your setup, make sure you modify the MySite.Host line to include your actual FTP SSL server host and login information.

```vbs
#file test.vbs
Const EVENT_SUCCESS = 0
Set objShell = Wscript.CreateObject("Wscript.Shell")
objShell.LogEvent EVENT_SUCCESS,"AT Loaded me"
Set MySite= CreateObject("CuteFTPPro.TEConnection")
MySite.Option ("ThrowError") = True
MySite.Host = "ftp://myuser:mypass@ftp.mysslserver.com:990"
```
Transferring Files or Sites with the Transfer Engine

When the Transfer Engine (TE) is running, the TE icon \( \text{\textendash} \) appears in the Windows system tray. You can download files or even an entire site by right-clicking the TE icon, then clicking **Download URL**.

To download files from a URL with the Transfer Engine

1. Right-click the TE icon, then click **Download URL**. The **Download URL** dialog box appears.

2. Type the full URL, e.g., ftp://mysite.com, then click **OK**.

   If CuteFTP is closed, the download happens in the background. If CuteFTP is open, the progress of the download appears in the Queue Window.

To view current transfers

- Right-click the TE icon, then click **Show current transfers**. (Only available if the CuteFTP interface is closed.) The **Transfer Queue** appears. (You can also open the **Transfer Queue** by double-clicking the TE icon.)

To stop a transfer

- Right-click the in-progress transfer in the **Transfer Queue**, then click **Stop transfer**.

To start a transfer in the Transfer Queue

- Right-click the item(s) to be transferred, then click **Start transfer**.

To remove items from the Transfer Queue

- To remove one or more items, right-click the item(s) to be removed, then click **Remove**.
- To remove all items from the queue, right-click anywhere in the queue, then click **Remove All**.

Running Scripts

You can execute a script you create in Windows, from the command line, from within CuteFTP's interface, or as a scheduled task to be run with no user logged in.

To execute a script directly in windows

1. Launch CuteFTP.
2. On the main menu, click **Tools > Macros & Scripting > Run**.
3. **Browse** for the script file you created. For example, **sample.vbs**.
4. Click **Open** to launch the script.

   The log and queue view in CuteFTP populates with session and transfer information.

---

**When creating your VB scripts, remember that in VB, you aren’t checking to see if the returned value is the string “True” or “False”; you’re checking for the *value* True (i.e., -1) or False (i.e., 0). So, the values should *not* be quoted. The rule is, with quotes, it’s a string.**

---

**To execute a script from the command line**

1. On the Windows task bar, click **Start > Run.**
2. In the **Run** dialog box, type **CMD**, then press ENTER.
3. Navigate to the location of the script file.
4. Type the name of the file, then press ENTER.

   TE launches (the TE icon display in the system tray) and executes your script.

**To execute a script directly in Windows**

1. In Windows Explorer, navigate to the location of the script file.
2. Double click the script file

   TE launches (the TE icon displays in the system tray) and executes your script.

---

**Creating Scripts**

You can interact with the TE directly from your own custom applications using common programming languages such as Visual Basic (VB) or in a scripting language supported by the Windows Scripting Host (WSH).

You can create a script from the development IDE of your choice, or you can create scripts from within CuteFTP by clicking **Tools > Macros & Scripting > New.** CuteFTP will open a template script file in a document window.

To create a new script file, you need to have some familiarity with programming concepts and, ideally, some experience with VB or Java.

---

**If you do not have any programming experience, you can still create scripts using the session Record and Playback functionality in CuteFTP.**

---

- Due to the wide range of scripts that CuteFTP is able to accommodate, we are unable to offer technical support on individual scripts other than what is available in the help files and online Knowledge Base.
- If you are having trouble with your script, try to perform the desired action manually, using the CuteFTP interface. If you cannot, then troubleshoot that problem first, and then retry your script.
- If you are able to perform the desired actions, and in the desired sequence when using the interface, then the problem is not with CuteFTP or the FTP Server. The next thing to do is to troubleshoot your script line by line.
- You have to register the TE COM component on the computer before you can create script files to interact with it.
Methods, Properties, and Wildcards Overview

Use methods and properties to operate the Transfer Engine. Methods and properties are defined below.

Methods

A method can be described as a command or function that may accept arguments (parameters) and may return a certain type of value. For example:

```csharp
Boolean Object.LocalExists(BSTR bstrName);
```

For this method, the type of the return value is Boolean. The command accepts an argument as a string value, here shown as `BSTR` (the type) and `bstrName` (a placeholder for the argument).

In a program, you can execute a method and assign the return value to a variable all in one command. For example:

```csharp
Exists = MySite.LocalExists "c:\temp\file.txt"
```

The argument "c:\temp\file.txt exists" is passed to the method `LocalExists` as a string (reason for the quotes). The variable `Exists` is then populated with a 1 or a 0 which is, in essence, true or false. You can then perform actions in your script based on those results.

Properties

A property is simply an attribute of a function (another word for method) or object internal to the TE framework. All properties have default values. Methods that rely on these properties will use default values unless you specify otherwise.

Most of the time, you can assign a value to a property or retrieve its value into a variable. You can set a property much like a local variable to your script. For example

```csharp
String Object.Protocol
```

The above property can accept a predefined set of string values or can be assigned to a variable to retrieve the currently selected value. The default in this case is "FTP."

You can assign a value to a property as follows:

```csharp
MySite.Protocol = "FTPS"
```

Upon subsequent connections, the TE will attempt to login using FTP over SSL, rather than via FTP, the default attribute for this property.

Wildcard Masks

Wildcard masks are patterns of special characters used to filter file names. When a wildcard mask is matched against a file name, the two patterns are compared, letter-by-letter, from left to right until a mismatch occurs. If all the characters in both patterns compare positively, the file name matches the Wildcard Mask.

Wildcard mask characters

- `?` Will match any single character
- `*` Will match any sequence of characters (including no characters at all), terminated by the next character in the mask.
- `[]` Will match any character in the character set enclosed in the brackets. This can also be a range of characters
- If the opening bracket is followed by "!", will match any character NOT in the set.
Available Methods and Properties

The table below describes the methods and properties available to use with the Transfer Engine.

AbortAsync

Use the AbortAsync method to stop an asynchronous task created previously by UploadAsync, DownloadAsync, or TransferURLAsync. Refer to those methods for more information.

```
HRESULT AbortAsync([in, defaultvalue(-1)] long taskIdx);
```

**Syntax**

```
Object.AbortAsync(long taskIdx)
```

**Parameters**

TaskIdx—This is a task index in the array of tasks created by the various asynchronous methods. The default value of taskIdx is -1 which specifies all the asynchronous tasks in array. TaskIdx should be between 0 and AsyncTaskNumber minus one.

**Example**

```
Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Option("CleanupAsync") = False
'Initialize all necessary fields for MySite: host name, user, password, etc.
MySite.Connect
MySite.DownloadAsync "*.", "c:\temp"
MsgBox "Number of tasks created: " & MySite.AsyncTaskNumber
If MySite.AsyncTaskNumber > 10 then
    MsgBox "Aborting 11th task"
    MySite.AbortAsync (10) 'abort task # 11 (one less then total, since starts from 0)
End if
```

---

You must set MySite.Option("CleanupAsync") = False so that all asynchronous tasks are counted. Otherwise, only the last asynchronous task launched will be referenced when calling the AbortAsync method.

AsyncTaskNumber

Use the AsyncTaskNumber property to return the number of tasks created by the UploadAsync, DownloadAsync and TransferURLAsync methods.

```
HRESULT AsyncTaskNumber([out, retval] long *pVal);
```

**Syntax**

```
Long Object.AsyncTaskNumber
```

**Example**

```
Set MySite = CreateObject("CuteFTPPro.TEConnection")
'Initialize all necessary fields for MySite: host name, user, password, etc.
MySite.Option("CleanupAsync") = False
MySite.DownloadAsync "/path/\*.*, */path/\*.*"
MsgBox "task number created" & MySite.AsyncTaskNumber
```

---

You must set MySite.Option("CleanupAsync") = False so that all asynchronous tasks are counted. Otherwise, only the last asynchronous task launched will be referenced when calling the AsyncTaskNumber property.
AutoRename

Use the **AutoRename** property to set or retrieve the renaming values prior to the transfer of a file or folder.

To configure the auto-rename rules, refer to the procedure in [Rename Rules Settings](#).

```csharp
HRESULT AutoRename([out, retval] BSTR *pVal);
HRESULT AutoRename([in] BSTR newVal);
```

**Syntax**

```csharp
String MySite.AutoRename
```

**Parameters**

"ON"—AutoRename feature turned on

"OFF"—AutoRename feature turned off

**Example**

```csharp
MySite.AutoRename = "ON"
```

CaseHandling

Use the **CaseHandling** property to specify that the command channel should not be encrypted over SSL.

```csharp
HRESULT CaseHandling([out, retval] long *pVal);
HRESULT CaseHandling([in] long newVal);
```

**Syntax**

```csharp
long Object.ClearCommandChannel
```

**Parameters**

True—Your login is encrypted but as data transfers start, commands are not encrypted.

False—Your login and subsequent commands are encrypted. This is the default

**Example**

```csharp
MySite.Host = "host"
MySite.Protocol = "FTPS"
MySite.ClearCommandChannel = true '<-- CCC will be sent prior to the first data connection operation.
MySite.Connect
```

**Configuration Notes**

The default is false (encrypted), so only set this property if you wish to log in securely but send subsequent commands in the clear.

This property will only work if the remote server supports SSL and clear command channel connections (according to RFC 2228) and you have specified FTPS as the protocol type.
ClearDataConnection

Use the ClearDataConnection property to specify whether the data channel should be encrypted or not when using FTP over SSL.

```csharp
HRESULT ClearDataConnection([out, retval] BOOL *pVal);
HRESULT ClearDataConnection([in] BOOL newVal);
```

### Syntax

```csharp
long Object.ClearDataConnection
```

### Parameters

- **True**—Your login is encrypted but data transfers are not. This is the default.
- **False**—Your login and data transfers are encrypted.

### Example

```csharp
Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Protocol = "FTPS"
MySite.ClearDataConnection = false 'encrypt FTP data channel
```

### Configuration Notes

The default is true (encrypted), so only set this property if you wish to log in securely but transfer data in the clear.

This property will only work if the remote server supports SSL and clear data channel connections (PROT C command according to RFC 2228) and you have specified FTPS as the protocol type.

Close

Use the Close method to exit the Transfer Engine. You can include parameters to exit only on certain conditions.

```csharp
HRESULT Close([in, defaultvalue("BSTR bstrCondition);]
```

### Syntax

```csharp
Object.Close (BSTR bstrParameter)
```

### Parameters

- **""** (default empty), "CLOSE", "EXIT"—Closes TE (all tasks will be stopped)
- "EXITNOPENDING"—Closes TE if no pending tasks available

ℹ️ You can use any number of spaces or underscores inside these parameters. For example, "exit no pending" and "_EXIT_NO_PENDING_" are the same.

### Example

```csharp
Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.LocalFolder = "c:\temp"
MySite.Close "EXITNOPENDING"
```
CombSupport

Use the CombSupport property to check if the server supports the COMB (multi-part upload) command.

```csharp
HRESULT CombSupport([out, retval] BOOL *pVal);
```

**Syntax**

```csharp
Boolean Object.CombSupport
```

**Return values**

-1—Server supports COMB

0—Server does not support COMB

**Example**

```csharp
Set MySite = CreateObject("CuteFTPPro.TEConnection")
'Initialize all necessary fields for MySite : host name, user, password, etc.
If (not MySite.CombSupport) Then
MsgBox "This server doesn't support the COMB command!"
End if
```

Connect

Use the Connect method to log in to a remote server. Before calling it, set the protocol, host address (with the Host property), user name (with the Login property) and password (with the Password property) to establish a successful connection.

```csharp
HRESULT Connect([out, retval] BOOL *pVal);
```

**Syntax**

```csharp
Object.Connect
```

**Example**

```csharp
Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Protocol = "FTP"
MySite.Host = "ftp.cuteftp.net"
MySite.Login = "username"
MySite.Password = "password"
MySite.Connect
```

**Important Note**

Any time you call a transfer function, the Connect method is called indirectly. It is recommended you explicitly invoke the Connect method, though it is not necessary. You can always use the IsConnected property to determine whether you are connected at any given time.

CreateLocalFolder

Use the CreateLocalFolder method to create a new folder (directory) on your local hard drive.

```csharp
HRESULT CreateLocalFolder([in, defaultvalue("BSTR strName, [out, retval] BOOL *pVal);
```

**Syntax**

```csharp
Object.CreateLocalFolder(BSTR strName)
```
Parameters

BstrName—This contains the folder's relative or absolute path.

Example

```vbscript
 Set MySite = CreateObject("CuteFTPPro.TEConnection")
 MySite.CreateLocalFolder "c:\temp\New Folder"

Now check to see if it was created

 MySite.LocalFolder = "c:\temp\New Folder"
 currentdir = MySite.LocalFolder
 MsgBox currentdir
```

CreateRemoteFolder

Use the CreateRemoteFolder method to create a new folder (directory) on a remote server.

```vbscript
 HRESULT CreateRemoteFolder([in, defaultvalue("BSTR strName, [out, retval] BOOL *pVal)]
```

Syntax

```vbscript
 Object.CreateRemoteFolder(BSTR strName)
```

Parameters

BstrName—This contains the folder's relative or absolute path.

Example

```vbscript
 Set MySite = CreateObject("CuteFTPPro.TEConnection")
 Initialize all necessary fields for MySite : host name, user, password, etc.
 MySite.Connect
 MySite.CreateRemoteFolder("/dir") 'creates /dir (because absolute path was used)
 MySite.RemoteFolder = "/dir" 'now change to the newly create 'dir' folder
 MySite.CreateRemoteFolder("dir2") 'creates /dir/dir2 (because relative path was used)
```

CreateSSHKeyPair

Used to create an SSH Key pair.

```vbscript
 HRESULT CreateSSHKeyPair([in] long KeyAlgorithm, [in] long KeyBits, [in] BSTR bstrPassphrase, [in] BSTR bstrPrivateKeyFile, [out, retval] BOOL *pVal);
```

DataChannel

Use the DataChannel property to set or retrieve values for the method in which the data port is established for the data channel (PASV or PORT). The default is PORT.

```vbscript
 HRESULT DataChannel([out, retval] BSTR *pVal);
 HRESULT DataChannel([in] BSTR newVal);
```

Syntax

```vbscript
 String Object.DataChannel
```
Parameters

"PORT"—The client specifies what port to use for the data connection

"PASV"—Lets the server specify the port used for the data connection port

"DEFAULT"—Uses the method defined in Global Options

Example

```
Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.useProxy = "off"
MySite.DataChannel = "PASV"
MySite.RemoteCommand("LIST")
MySite.DataChannel = "PORT"
MySite.RemoteCommand("LIST")
MsgBox MySite.Log
```

Delay

Use the Delay property to set the delay between connection retry attempts (in seconds).

```
HRESULT Delay([out, retval] long *pVal);
HRESULT Delay([in] long newVal);
```

Syntax

```
int Object.Delay
```

Example

```
MySite.Delay = 90
```

> You cannot use the Delay property with transfers; you can only use Delay with connections.

DeleteDestination

```
HRESULT DeleteDestination([out, retval] BOOL *pVal);
HRESULT DeleteDestination([in] BOOL newVal);
```

Parameters

0 = Don't remove destination

1 = Remove destination if source does not exist (default)

Disconnect

Use the Disconnect method to end an event in progress. It is normally used to stop a file transfer.

```
HRESULT Disconnect();
```

Syntax

```
Object.Disconnect()
```

Example

```
Set MySite = CreateObject("CuteFTPPro.TEConnection")
```
Configuration Notes

Disconnect is not the same as the standard FTP command QUIT. Instead it is simply a command to stop the current transfer task. You can issue a QUIT command prior to invoking Disconnect by using the RemoteCommand method.

A socket disconnect (more brutal than QUIT) to an FTP server occurs automatically after all transfers and other commands have finished. This is similar to the Connect command, which is implicitly called when a transfer method is invoked.

The example above uses the TransferURLAsync command to pass the TE an FTP file location to download. Since the TransferURLAsync command is asynchronous, you could called TransferURLAsync multiple times consecutively.

If you issue a Disconnect command after issuing multiple TransferURLAsync commands, the last called TransferURLAsync request is the one that is cancelled.

Download

Use the Download method to transfer a file or folder from a remote location to your local hard drive.

```vbnet
HRESULT Download([in, defaultvalue("BSTR bstrRemoteName, [in,
defaultValue("BSTR bstrLocalName, [in, defaultValue(1)] long nParts, [out,
retval] BOOL *pVal);
```

Parameters

- **strLocalName**—This is optional. Use this only if you want to change the destination name or path for the downloaded files or folder. You can use absolute or relative paths.
- **strRemoteName**—This is the path to the remote item you are downloading. You can use absolute or relative paths with or without wildcards.
- **nMultiPartNumber**—Use this to split the download into multiple parts. The default value = 1. The value specifies the number of parts used for the download.

Example

```vbnet
Set MySite = CreateObject("CuteFTPPro.TEConnection")
'MSpecify user, pass, host, and connect as normal
MySite.Connect 'Recommended: call connect first

'next line changes to a predetermined folder so you can use a relative path in the download method
MySite.RemoteFolder = "/c:/Inetpub/ftproot/Temp/Temp/
MsgBox (MySite.RemoteFolder) 'display current remote folder
MySite.Download "agent.ini", "c:\temp\agent1.ini"

'now verify downloaded ok
If CBool(MySite.LocalExists ("c:\temp\agent1.ini")) Then
MsgBox "File downloaded OK."
End If
```
Transfer Engine (Scripting)

Configuration Notes:

Setting the Multi-part download attribute can greatly increase the transfer speed for larger files under certain conditions. For example, the Site must support multiple concurrent connections from the same user and you must have significant bandwidth.

The Download method is a synchronous command, meaning it must finish executing before subsequent commands in your script can be called. Use the method DownloadAsync (which also supports Multi-part transfers) to asynchronously download files, which allows you to execute the rest of the script while the download(s) take place.

You cannot download and rename multiple files by specifying a wildcard in the strLocalName parameter. For example, MySite.Download "*.exe", "*.txt" will download all of the files in the current remote folder that end with *.exe to a local folder named "_.txt". That is, if you specify a wildcard, the wildcard character is replaced by an underscore (_) character.

DownloadAsync

Use the DownloadAsync method to download a file or folder to the local hard drive asynchronously. An asynchronous download starts and then returns control to the script before the transfer finishes. This allows you to perform many simultaneous transfers because the method does not wait for the download to end. Immediately after you call this method subsequent methods in your script will be called, so be careful when timing certain events.

If DownloadAsync encounters a problem when trying to complete its task, it will not throw a COM, ATL, or VB error. DownloadAsync will also adhere to your max global and per Site settings.

```c
HRESULT DownloadAsync([in, defaultvalue("BSTR strRemoteName, [in, defaultvalue("BSTR strLocalName, [in, defaultvalue(1)] long nParts, [out, retval] BOOL *pVal);
```

Syntax

Object.DownloadAsync(BSTR strRemoteName, BSTR strLocalName, long nMultiPartNumber)

Parameters

strLocalName—This is optional, use it only if you want to change the destination name or path for the downloaded files or folder. You can use absolute or relative paths with or without wildcards.

strRemoteName—This is the path to the remote item you are downloading. You can use absolute or relative paths with or without wildcards.

nMultiPartNumber—Use this to split the download into multiple parts. The default value = 1. The value specifies the number of parts used for the download.

Example

```vbnet
Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Host = "ftp.cuteftp.com"
MySite.Connect
MySite.DownloadAsync "/pub/cuteftp/english/**", "c:\temp" 'downloads all files in the pub/cuteftp folder
```

You can call the DownloadAsync method many times sequentially in a script. Each call, in turn, opens a new data connection to the specified server, enabling you to transfer multiple files simultaneously. This, combined with the ability to transfer the file in multiple parts, greatly increases the overall transfer speed and execution of your task.
ErrorDescription

Use the **ErrorDescription** property to get the string describing the last error condition. It may consist of some messages taken from the transfer log.

```
HRESULT ErrorDescription([in, defaultvalue(-1)] long taskIdx, [out, retval] BSTR *pVal);
```

**Syntax**

```
String Object.ErrorDescription (long taskIdx)
```

**Parameter**

**TaskIdx**—This is a task index in the array of tasks created by the various asynchronous methods. The default value of taskIdx is -1 which specifies all the asynchronous tasks in array. TaskIdx should be between 0 and AsyncTaskNumber minus one.

**Example**

```
Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Option("ThrowError") = false 'disable ATL exceptions
if cbool(MySite.Connect) then
    MsgBox "Connected OK"
else
    MsgBox "Error! " & MySite.ErrorDescription
```

FileOverWriteMethod

Use the **FileOverWriteMethod** to specify the action to take when transferring a file when a file with the same name exists. Refer to **Smart Overwrite Settings** for more information.

```
HRESULT FileOverWriteMethod([out, retval] BSTR* pVal);
HRESULT FileOverWriteMethod([in] BSTR newVal);
```

**Parameters**

"OVERWRITE"—Overwrite the file

"SKIP"—Do not transfer the file and leave the destination file as it is.

"RESUME"—Treat the file as an incomplete transfer. If the destination file is already a complete file, the transferred file replaces the destination file.

"RENAME"—Rename the file

"PROMPT"—Prompt before overwriting

"NUMERATE"—Create a copy of the file and add a number to the name

"USE_RULES"—Use the rules you define in the **Overwrite Rules** dialog box in Global Options to determine how to handle all files with matching names.

**Examples**

'Display the current folder overwrite setting

```
MsgBox( MySite.FolderOverwriteMethod )
```

'Set folder overwrite to replace all

```
MySite.FolderOverwriteMethod = "FOLDER_REPLACE_ALL"
```
FileSize

FileTimeModified

FileType

Use the FileType, FileSize, and FileTimeModified properties to retrieve information about a particular item.

```csharp
HRESULT FileSize([out, retval] BSTR *pVal);
HRESULT FileTimeModified([out, retval] BSTR *pVal);
HRESULT FileType([out, retval] long *pVal);
```

Syntax

```csharp
long Object.FileType
long Object.FileSize
string Object.FileTimeModified
```

Return Values

For FileType:
1—Directory
2—File
3—Link

For FileSize: the size in bytes of the file

For FileTimeModified: mm/dd/yyyy hh:mm:ss

Example

```csharp
Set fserv = CreateObject("CuteFTPPro.TEConnection")
strRemote = "somefilename.ext"
if cbool(fserv.RemoteExists(strRemote)) then
else
    MsgBox "Error! " & fserv>ErrorDescription
End If
```

FolderOverwriteMethod

Use the FolderOverwriteMethod to specify the action to take when transferring a file when a file with the same name exists. Refer to Smart Overwrite Settings for more information.

```csharp
HRESULT FolderOverwriteMethod([out, retval] BSTR* pVal);
HRESULT FolderOverwriteMethod([in] BSTR newVal);
```

Parameters

"FOLDER_PROMPT"—Prompt before overwriting

"FOLDER_REPLACE_ALL"—Replace (overwrite) all

"FOLDER_USE_RULES"—Use the rules you define in the Overwrite Rules dialog box in Global Options to determine how to handle all folders with matching names.
Examples

‘Display the current overwrite setting

MsgBox( MySite.FileOverWriteMethod )

‘Set file overwrite method to numerate

MySite.FileOverWriteMethod = "NUMERATE"

GetList

Use the GetList method to download folder listings.

Syntax

Object.GetList(BSTR bstrPath, BSTR bstrLocalFile, BSTR bstrFormat, BOOL *pVal)

Parameters

bstrPath—The remote path to be listed. Leave it empty if its the current path.
bstrLocalFile—Specifies a local file name where the listing can be saved.
bstrFormat—Can be used to format the listing. If left empty, a raw listing will be returned. You can specify %NAME, %DATE, and %SIZE as return values in a string.

Example

Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Host = "ftp.cuteftp.com/pub"
MySite.Connect
MySite.GetList "", "c:\temp_list.txt" 'saves a raw listing for the default path
to the file temp_list.txt
MsgBox MySite.GetResult 'retrieves and displays the listing

Example 2

Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Host = "ftp.cuteftp.com"
MySite.Connect
MySite.GetList "/pub", "", "FILE NAME: %NAME" 'goes to pub folder, doesn't
save the listing to file, and formats it as shown
MsgBox MySite.GetResult 'retrieves and displays the listing

Example 3

Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Host = "ftp.cuteftp.com"
MySite.Connect
MySite.GetList "/pub", "", "NAME= %NAME SIZE= %SIZE DATE= %DATE" 'goes to pub
folder, doesn't save the listing to file, and formats it as shown
MsgBox MySite.GetResult 'retrieves and displays the listing

GetResult is an optional method used only with GetList. It simply retrieves the data. Without GetResult the
data is written to the buffer, or if defined in the parameters, the data is written to the log.
GetResult

HRESULT GetResult([in, defaultvalue("BSTR bstrReserved, [out, retval] BSTR * bstrResult")]);

HomeDir

Use the HomeDir property to return a string value containing the name of the server's home directory.

HRESULT HomeDir([out, retval] BSTR * pVal);

Syntax

String Object.HomeDir

Example

Set MySite = CreateObject("CuteFTPPro.TEConnection")
'Initialize all necessary fields for MySite : host name, user, password, etc.
MsgBox "Home dir for server " + MySite.Host + " is: " + MySite.HomeDir

Host

Use the Host property to set or retrieve the value for the host name of a Site when you are connecting.

HRESULT Host([out, retval] BSTR * pVal);
HRESULT Host([in] BSTR newVal);

Syntax

int Object.Host

Example

Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Protocol = "FTP"
MySite.Host = "ftp.ftp.net"
MySite.Port = 21
MySite.Login = "username"
MySite.Password = "password"

IgnoreLinks

Use the IgnoreLinks property when working with Unix servers. Use IgnoreLinks to set or retrieve the value that determines whether or not you want to bypass links.

HRESULT IgnoreLinks([out, retval] BOOL * pVal);
HRESULT IgnoreLinks([in] BOOL newVal);

Syntax

bool Object.IgnoreLinks

Parameters

True—Skip symlinks during synchronization
False—Handle symlinks during synchronization as files or folders
Example

Mysite.IgnoreLinks = False

IsConnected

Use the *IsConnected* property to indicate whether or not you are presently connected to the remote Site.

HRESULT IsConnected([out, retval] BOOL *pVal);

Syntax

Boolean Object.IsConnected

Parameters

True—The Transfer Engine is currently connected to the server.
False—The Transfer Engine is not currently connected to the server.

Example

Set MySite = CreateObject("CuteFTPPro.TEConnection")
If Cbool(MySite.IsConnected) Then
    MsgBox "Connected to server:" + MySite.Host
End if

You can specify how long the Transfer Engine will leave the data connection open after a completed transfer.

IsPending

Use the *IsPending* property to determine whether a transfer is active or if it is already finished with success or error. This can be useful in combination with async commands or during an interactive script. The *IsPending* property will return a value of either true or false.

HRESULT IsPending([in, defaultvalue(-1)] long taskIdx, [out, retval] BOOL *pVal);

Syntax

Boolean Object.IsPending(long taskIdx)

Parameter

TaskIdx—This is a task index in the array of tasks created by the various asynchronous methods. [0..AsyncTaskNumber minus one, or - 1 (last asynchronous task started)]

This has a default value (if nothing is specified) of ALL tasks. Therefore, IsPending will return true if any task is still pending. It will return false if none are pending.

Example 1

Set MySite = CreateObject("CuteFTPPro.TEConnection")

'Regular connection code here:

MySite.Download inbound/*.*", "c:\temp"
If Cbool(MySite.IsPending) Then
    MsgBox "task is in working state" + MySite.Host
End if
Example 2

Here is another example that checks an asynchronous transfer and will return various transfer progress properties of each transfer while IsPending is true.

If you copy and paste this code, be aware that line breaks may be inserted into the code.

```vba
Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Protocol = "FTP"
MySite.Port = "21"
MySite.Host = "ftp.url"
MySite.login = "loginname"
MySite.Password = "your pass"
MySite.Connect
MySite.Option("CleanupAsync") = False

strNL = (Chr(13) & Chr(10))
MySite.MaxConnections = 3
MySite.Option("ThrowError") = false
MySite.DownloadAsync "inbound/*/.*", "c:\temp"
bContinue = true

while CBool(MySite.IsPending) and bContinue
    str = "LOOP, Total: " & MySite.AsyncTaskNumber & strNL
    for i = 0 to MySite.AsyncTaskNumber - 1 step 1
        str = str & i & ": size: " & MySite.TransferredSize(i) & ", speed: " & MySite.Speed(i) & ", time left: " & MySite.TimeLeft(i) & ", status: " & MySite.Status(i) & strNL
    next

    str = str & "YES - continue loop, NO - stop tasks, CANCEL - exit loop"
    nUserChoice = MsgBox(str, vbYesNocancel) 'press YES many time to see transfer progresses
    if nUserChoice = vbCancel then
        bContinue = false
    elseif nUserChoice = vbNO then
        MySite.AbortAsync 'abort all tasks
        bContinue = false
    end if
wend

str = "DONE, Total: " & MySite.AsyncTaskNumber & strNL
for i = 0 to MySite.AsyncTaskNumber - 1 step 1
    str = str & i & ": size: " & MySite.TransferredSize(i) & ", speed: " & MySite.Speed(i) & ", time left: " & MySite.TimeLeft(i) & ", status: " & MySite.Status(i) & strNL
next
MsgBox str
```

Links

Use the Links property to both set and retrieve values for working with links on a remote server.

```vba
HRESULT Links([out, retval] BSTR *pVal);
HRESULT Links([in] BSTR newVal);
```

Syntax

```vba
String Object.Links
```

Parameters

"Resolve"—The TE will attempt to resolve the link prior to transfer.
"GetAsFile"—The TE will assume it's a file and transfer as is (This is used to avoid endless loops in a large multi-directory transfer).

**Example**

```vbscript
MySite.Links = "Resolve"
```

**LocalExists**

Use the **LocalExists** method to verify that a local file or folder exists.

```vbscript
HRESULT LocalExists([in, defaultvalue("BSTR bstrName, [out, retval] BOOL * bExists);]
```

**Syntax**

```vbscript
Boolean Object.LocalExists(BSTR bstrName);
BstrName should be the full path.
```

**Return Values**

- True—File or folder does exist
- False—File or folder does not exist

**Example**

```vbscript
Set MySite = CreateObject("CuteFPTPro.TEConnection")
'Initialize all necessary fields for MySite : host name, user, password, etc.
L = MySite.LocalExists("c:\temp\file.txt")
If (L) Then
    MsgBox "File exists on local side"
Else
    MsgBox "File doesn't exist on local side"
End if
```

**LocalFilterExclude**

Use the **LocalFilterExclude** property to set and retrieve the values for excluding local files or folders from transfers and listings. The string values may contain wildcards and you can add multiple filters by separating them with a semicolon.

```vbscript
HRESULT LocalFilterExclude([out, retval] BSTR *pVal);
HRESULT LocalFilterExclude([in] BSTR newVal);
```

**Syntax**

```vbscript
String Object.LocalFilterExclude
```

**Example**

```vbscript
MySite.LocalFilterExclude = "*.mp3;*.jpg"
```

If filter causes no file to be transferred, then no folders will be created.

**LocalFilterInclude**

Use the **LocalFilterInclude** property to set or retrieve the values for including local files or folders in transfers and listings. The string values may contain wildcards and you can add multiple filters by separating them with a semicolon ( : ).

```vbscript
HRESULT LocalFilterInclude([out, retval] BSTR *pVal);```
HRESULT LocalFilterInclude([in] BSTR newVal);

Syntax

String Object.LocalFilterInclude

Example

MySite.LocalFilterInclude = "*.jpg;*.gif"

If a filter causes no file to be transferred then no folders will be created.

LocalFolder

Use the LocalFolder property to retrieve or set the current folder on your local hard disk. You can use relative or absolute paths.

HRESULT LocalFolder([out, retval] BSTR *pVal);
HRESULT LocalFolder([in] BSTR newVal);

Syntax

String Object.LocalFolder

Example

Object.LocalFolder = "c:\temp"

LocalRemove

Use the LocalRemove method to delete a local file or folder. Use the absolute path name for the item you want to delete.

HRESULT LocalRemove([in, defaultvalue("BSTR bstrName, [out, retval] BOOL *pVal"));

Syntax

Object.LocalRemove(BSTR bstrName)

Parameters

BstrName—This contains the items full absolute path.

Example 1

Set MySite = CreateObject("CuteFTPPro.TEConnection")
'Initialize all necessary fields for MySite : host name, user, password, etc.
MySite.LocalRemove "c:\temp\file.txt"

You can also use wild cards to replace the string value of bstrName. These wild card masks include "*", ",", and 
"\n" (new line symbol, also known as Chr(10) in VB).

Example 2

Set MySite = CreateObject("CuteFTPPro.TEConnection")
'Initialize all necessary fields for MySite : host name, user, password, etc.

MySite.LocalFolder = "c:\temp"
MySite.LocalRemove("file.ext") 'removes if exact match
MySite.LocalRemove("*.obj") 'wild card match with a specific extension
MySite.LocalRemove("*.aaa" & Chr(10) & ".bbb" & Chr(10) & "t*") 'various wildcard filters

LocalRename

Use the **LocalRename** method to rename a file or folder on your local hard disk.

```
HRESULT LocalRename([in] BSTR bstrFrom, [in] BSTR bstrTo, [out, retval] BOOL *pVal);
```

**Syntax**

```
Object.LocalRename(BSTR bstrFrom, BSTR bstrTo)
```

**Parameters**

- **BstrTo**—This contains the folder's new name in its full absolute path.
- **BstrFrom**—This contains the folder's old name in its full absolute path.

**Example**

```vba
Set MySite = CreateObject("CuteFTPPro.TEConnection")
'Initialize all necessary fields for MySite : host name, user, password, etc.
MySite.LocalRename "c:\file.txt", "e:\temp\users\file.exe"
```

*Make sure you specify the full source and destination path. If you had written the command as MySite.LocalRename "c:\file.txt", "file.exe", thinking it would rename it using relative paths, you might be surprised to find that your file has been moved to your profiles folder (system dependent). The LocalRename property is similar to a MOVE command issued through drag and drop with the added name change sequence.*

Log

Use the **Log** property to return the entire log as a string which can be handled separately in your VB application or VB script.

```
HRESULT Log([in, defaultvalue(-1)] long taskIdx, [out, retval] BSTR *pVal);
```

**Syntax**

```
String Object.Log (long taskIdx)
```

**Parameters**

- **TaskIdx**—This is the task index in the array of tasks created by asynchronous methods [0..AsyncTaskNumber minus one, or - 1 (last asynchronous task started)]. It has a default value of -1 = current task.

**Example**

```vba
Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Connect
MsgBox MySite.Log
```
Login
Use the `Login` property to set or retrieve the value for the user name (login) you use to connect.

```csharp
HRESULT Login([out, retval] BSTR *pVal);
HRESULT Login([in] BSTR newVal);
```

Syntax
```
String Object.Login
```

Example
```
Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Protocol = "FTP"
MySite.Host = "ftp.cuteftp.com"
MySite.Login = "username"
MySite.Password = "password"
MySite.Connect
```

MaxConnections
Use the `MaxConnections` property to set or retrieve the most connections the script is allowed to open.

```csharp
HRESULT MaxConnections([out, retval] long *pVal);
HRESULT MaxConnections([in] long newVal);
```

Syntax
```
long Object.MaxConnections
```

Example
```
Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.MaxConnections = 1 'restrict connections to 1
```

Option
Use the `Option` property to set or retrieve various settings, such as Auto-rename, include folder names when filtering, cache invalidation, error handling, cleaning up of asynchronous tasks, and to auto-close prompts.

```csharp
HRESULT Option([in] BSTR bstrOptName, [out, retval] BOOL *pVal);
HRESULT Option([in] BSTR bstrOptName, [in] BOOL newVal);
```

Syntax
```
String Object.Option("[option name"]") = true | false
```

Parameters

"ThrowError"—(defaults to True) - TE COM will call AtlReportError (showing a VB runtime error message box) on connection/transfer/IO/other error which will terminate script execution. If set to False, then if some transfer method fails the script will continue to the next command.

"AutoRename"—(defaults to False) - The same as the AutoRename property.

"CleanupAsync"—(defaults to True) - All task IDs accumulated by previous Async methods will be lost. If set to False, all task IDs will be added to the ones created by previous Async methods.
"InvalidateCache"—(defaults to True) - Remove cached file (containing listings) before uploading, downloading, renaming or deleting files. If false, then don't remove cached listing. You can obtain the specific file information when needed by using one of the file property methods. InvalidateCache optimizes LIST traffic.

"FilterDirs"—(defaults to True) - Apply filters to folder names. If set to False, then don't apply.

"AutoCloseMethod"—(default to 0) 1 - auto accept, 2 - auto reject, 0 - Don't accept (default). This handles hidden prompts (such as SSL Accept Cert Prompt when running a script while not logged in).

"AutoCloseDelay"—(default value is 60 seconds). Time delay before CuteFTP should perform the action specified by the AutoCloseMethod option.

"ConnectionTimeout"—Display connection timeout value

Examples

MsgBox( MySite.Option("ConnectionTimeout") )

' Set connection timeout to 45 seconds
MySite.Option("ConnectionTimeout") = 45
ValidateFileIntegrity

'Display current value of ValidateFileIntegrity
MsgBox( MySite.Option("ValidateFileIntegrity") )

'Turn on ValidateFileIntegrity
MySite.Option("ValidateFileIntegrity") = 1

0=FALSE and 1=TRUE

Example 1

Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Option("FilterDirs")=False          'don't filter folder names
MySite.LocalFilterExclude= "TDImon; *.txt; *.vbs"

'now set the item names to exclude MySite.Upload "c:\test"
'uploads all of test including sub dirs.
'Even sub dirs that match the filter, such as TDImon.
'If I had left FilterDirs=True, then the folter
'TDImond would not have been uploaded.

Example 2

Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Option("ThrowError") = false
if not CBool(MySite.Connect) then
  MsgBox "Error : " & MySite.ErrorDescription
end if

Example 3

Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Host = "ftps://ftp.asecuredomain.com"
MySite.Option("AutoCloseMethod") = 1

'will auto accept cert and continue
MySite.Option("AutoCloseDelay") = 5

'wait 5 seconds before accepting
MySite.Connect

'now connect to the secure Site. The TE will accept the server's SSL cert after 5 seconds and continue executing the rest of the script.

**Password**

Use the **Password** property to set or retrieve the value for the password you use to connect.

```vbnet
HRESULT Password([out, retval] BSTR *pVal);
HRESULT Password([in] BSTR newVal);
```

**Syntax**

```vbnet
String Object.Password
```

**Example**

```vbnet
Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Protocol = "FTP"
MySite.Host = "ftp.ftp.net"
Object.Login = "username"
MySite.Password = "password"
MySite.Connect
```

**Port**

Use the **Port** property to set or retrieve the value for the Port on the server when you connect.

```vbnet
HRESULT Port([out, retval] long *pVal);
HRESULT Port([in] long newVal);
```

**Syntax**

```vbnet
int Object.Port
```

**Example**

```vbnet
Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Protocol = "FTP"
MySite.Host = "ftp.cuteftp.com"
MySite.Port = 21
MySite.Login = "username"
MySite.Password = "password"
MySite.Connect
```

**PromptDelete**

```vbnet
HRESULT PromptDelete([out, retval] BOOL *pVal);
HRESULT PromptDelete([in] BOOL newVal);
```

**Parameters**

- 0 = Don't prompt before removing
- 1 = Prompt before removing (default)

**Protocol**

Use the **Protocol** property to set or retrieve the value for the protocol type.
HRESULT Protocol([out, retval] BSTR *pVal);
HRESULT Protocol([in] BSTR newVal);

Syntax

String Object.Protocol

Parameters

"FTP"—File Transfer Protocol
"FTPS"—FTP using SSL in explicit mode (standard port 21)
"FTPS_IMPLICIT"—Extension of FTP using SSL -- FTP using SSL in implicit mode (specific port)
"FTPS_AUTH_TLS"—AUTH TLS - Explicit
"SFTP"—Secure protocol based on SSH2
"FTP_SKEY_MD4"—Secure one time password login using MD4
"FTP_SKEY_MD5"—Secure one time password login using MD5
"HTTP"—Hypertext Transfer Protocol
"HTTPS"—HTTP with SSL

Example

Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Protocol = "FTPS_IMPLICIT"
MySite.Host = "ftp.ftp.net" >
MySite.Port = 990
MySite.Login = "username"
MySite.Password = "password"
MySite.Connect

You can find more options for using SSL in ClearDataConnection.

ProxyInfo

Use the ProxyInfo property to set or retrieve FTP and HTTP proxy server configurations. Do not use this function if you do not connect through a proxy server.

HRESULT ProxyInfo([out, retval] BSTR *pVal);
HRESULT ProxyInfo([in] BSTR newVal);

Syntax

String Object.ProxyInfo

Authentication Parameters

"ftp://proxyusername:proxypassword@proxyhostname:proxyport"—For FTP proxies that require authentication.
"http://proxyusername:proxypassword@proxyhostname:proxyport"—For HTTP proxies that require authentication.
"ftp://proxyhostname:proxyport"—For FTP proxies that don't require Authentication.
"http://proxyhostname:proxyport"—For HTTP proxies that don't require Authentication.
Additional parameters

"proxyusername"—The user name for login to the proxy server
"proxypassword"—The password for login to the proxy server
"proxyhostname"—The proxy server address
"proxyport"—The proxy server connection port

Example 1

MySite.ProxyInfo = http://_globalscape.com:8000 'use http proxy without authorization

Example 2

MySite.ProxyInfo = ftp://joeuser:mypassword@Globalscape.com:21 'use ftp proxy with authorization for user "joesuser" & password "mypass"

Example 3

'retrieve the current value of SocksInfo (empty if none)

str = MySite.SocksInfo

'now display it

MsgBox str

Recursive

Use the Recursive property to set or retrieve the value that determines whether or not subfolders will be included in a transfer task. This property is used often in synchronization scripts.

HRMRESULT Recursive([out, retval] BOOL *pVal);
HRMRESULT Recursive([in] BOOL newVal);

Syntax

Bool Object.Recursive

Parameters

True—Include subfolders
False—Do not include subfolders

Example

Mysite.Recursive = True

RemoteCommand

Use the RemoteCommand method to send the server any supported command. This function acts like the raw input command found in CuteFTP.

There is no resume method; however, you can use the RemoteCommand method to send the APPE (Append) command to a server. APPE is the FTP command to resume a transfer.

The RemoteCommand method exists to allow you to pass any command to the server manually, even if that command is not natively supported through the TE API.

HRMRESULT RemoteCommand([in] BSTR bstrCmd, [out, retval] BOOL *pVal);
Syntax

```vbnet
Object.RemoteCommand(BSTR bstrCmd)
```

Examples

```vbnet
MySite.RemoteCommand "APPE html/test.txt"
```

```vbnet
Set MySite = CreateObject("CuteFTPPro.TEConnection")
'Initialize all necessary fields for MySite: host name, user, password, etc.
MySite.RemoteCommand "PWD" 'sends a print working directory command
```

If you include the word "LIST", or "RETR", or "STOR" in `bstrCmd` then the Transfer Engine will open the data connection, perform the operation (to the buffer) and then discard it. You should use the GetList, Download or Upload methods to accomplish these tasks.

You can combine strings to perform custom commands. For example, if you wanted to do use CHMOD on a file, you could do as shown in the example below:

'Initialize all necessary fields for MySite: host name, user, password, etc.
```vbnet
Set MySite = CreateObject("CuteFTPPro.TEConnection")
'full permissions
strMODE = "777"
'an input dialog with some default content
strFile = InputBox("Type in the file name below ", "CHMOD Dialog", "cftppro10.log")
'concatenate the values
strvar = "SITE CHMOD " & strMODE & " " & strFile
'send the command
MySite.RemoteCommand strvar
```

RemoteExists

Use the **RemoteExists** method to verify that a remote file or folder exists.

```vbnet
HRESULT RemoteExists([in, defaultvalue("BSTR bstrName, [out, retval] BOOL bExist] BOOL * bExists);
```

Syntax

```vbnet
Boolean Object.RemoteExists(BSTR bstrName)
```

BstrName should be the full path.

Return Values

true—File or folder does exist
false—File or folder does not exist

Example

```vbnet
Set MySite = CreateObject("CuteFTPPro.TEConnection")
```
'Initialize all necessary fields for MySite: host name, user, password, etc.

```vbnet
R = MySite.RemoteExists( "/pub/user/file.txt")
If (R) Then
    MsgBox "File exists on remote side"
Else
    MsgBox "File doesn't exist on remote side"
End if
```

*If using an "if not" conditional, use CBool instead of boolean as the return type.*

**Correct:**

```vbnet
if not CBool(MySite.RemoteExists(strRemote)) then
    MsgBox "Error! " & MySite.ErrorDescription
```

**Incorrect:**

```vbnet
if not MySite.RemoteExists(strRemote) then
    MsgBox "Error! " & MySiteErrorDescription
```

### RemoteFilterExclude

Use the `RemoteFilterExclude` property to set and retrieve the values for excluding remote files or folders from transfers and listings. The string values may contain wildcards and you can add multiple filters by separating them with a semicolon.

```vbnet
HRESULT RemoteFilterExclude([out, retval] BSTR *pVal);
HRESULT RemoteFilterExclude([in] BSTR newVal);
```

**Syntax**

```vbnet
String Object.RemoteFilterExclude
```

**Example**

```vbnet
MySite.RemoteFilterExclude = "*.txt;*.swp"
MySite.Download "*.*"

' will download all files except those with extensions of *.txt and *.swp
```

*If filter causes no file to be transferred then no folders will be created.*

### RemoteFilterInclude

Use the `RemoteFilterInclude` property to set or retrieve the values used to include remote files or folders in transfers and listings. The string values may contain wildcards and you can add multiple filters by separating them with a semicolon `";"`.

```vbnet
HRESULT RemoteFilterInclude([out, retval] BSTR *pVal);
HRESULT RemoteFilterInclude([in] BSTR newVal);
```

**Syntax**

```vbnet
String Object.RemoteFilterInclude
```

**Example**

```vbnet
MySite.RemoteFilterInclude = "*.jpg;*.gif"
```
If filter causes no file to be transferred then no folders will be created.

RemoteFolder

Use the RemoteFolder property to retrieve or set the current remote folder. You can use absolute or relative paths.

```csharp
HRESULT RemoteFolder([out, retval] BSTR *pVal);
HRESULT RemoteFolder([in] BSTR newVal);
```

Syntax

```csharp
String Object.RemoteFolder
```

Example

'Connect to site following previous samples

```csharp
MySite.RemoteFolder = "/pub/cuteftp" 'Changes the remote folder to /pub/cuteftp (absolute paths used)
```

'subsequently

```csharp
MySite.RemoteFolder = "test" 'Changes to the folder called "test" located in "/pub/cuteftp", using relative paths.
```

RemoteRemove

Use the RemoteRemove method to delete a remote file or folder. You can specify the file or folder with absolute or relative paths. If the command fails, make sure you have specified the correct path and that you have the appropriate permissions required to delete the item.

```csharp
HRESULT RemoteRemove([in, defaultvalue("BSTR bstrName, [out, retval] BOOL */pVal);]
```

Syntax

```csharp
Object.RemoteRemove(BSTR bstrName)
```

Parameters

BstrName—This contains the folder's relative or absolute path.

Example

```csharp
Set MySite = CreateObject("CuteFTPPro.TEConnection")
'Initialize all necessary fields for MySite: host name, user, password, etc.
MySite.RemoteRemove "/pub/user1/file.txt"
MySite.RemoteRemove("file.ext") 'removes if exact match
MySite.RemoteRemove("*.obj") 'wild card match with a specific extension
MySite.RemoteRemove("*.aaa" & Chr(10) & ".bbb" & Chr(10) & "t") 'various wildcard filters
```

You can also use wild cards to replace the string value of bstrName. These wild card masks include ",", ",", and "\n" (new line symbol, also known as Chr(10) in VB).

RemoteRename

Use the RemoteRename method to rename a file or folder on the remote server.
HRESULT RemoteRename([in] BSTR bstrFrom, [in] BSTR bstrTo, [out, retval] BOOL *pVal);

**Syntax**

Object.RemoteRename(BSTR bstrFrom, BSTR bstrTo)

**Parameters**

BstrFrom—This contains the folder's old name in a relative or absolute path. The path must be the same in both parameters.

BstrTo—This contains the folder's new name in a relative or absolute path. The path must be the same in both parameters.

**Example**

Set MySite = CreateObject("CuteFTPPro.TEConnection")

'Initialize all necessary fields for MySite : host name, user, password, etc.

MySite.RemoteRename "/pub/user1/file.txt", "/pub/user1/file3.txt"

RemoteSiteFilter

Use the **RemoteSiteFilter** property to specify a string which will be used as a filter parameter by the LIST command.

HRESULT RemoteSiteFilter([out, retval] BSTR *pVal);
HRESULT RemoteSiteFilter([in] BSTR newVal);

**Syntax**

string Object. RemoteSiteFilter

**Example**

Set MySite = CreateObject("CuteFTPPro.TEConnection")

MySite. RemoteSiteFilter = "-l"

'This will send a "List -l" command to the server.

**Configuration Notes**

Refer to Filtering Transfers for a table of LIST wildcards (parameters) and combinations that can be passed to the ls program running on a UNIX server.

RestSupport

Use the **RestSupport** property to check if the server supports the REST (resume download) command.

HRESULT RestSupport([out, retval] BOOL *pVal);

**Syntax**

Boolean Object.RestSupport

**Return values**

-1—Server supports REST.
0—Server does not support REST.

**Example**

```vbscript
Set MySite = CreateObject("CuteFTPPro.TEConnection")

'Initialize all necessary fields for MySite: host name, user, password, etc.
If (not cbool(MySite.RestSupport)) Then
    MsgBox "This server doesn't support the REST command"
End if
```

**Retries**

Use the **Retries** property to retrieve or set the value for the maximum number of attempts the Transfer Engine should make to connect to a remote host.

```vbscript
HRESULT Retries([out, retval] long *pVal);
```

**Syntax**

```vbscript
int Object.Retries
```

**Example**

```vbscript
MySite.Retries = 10
```

**I** You cannot use the **Retries** property with transfers; you can only use **Retries** with connections.

**S2Sxfer**

Use the **S2Sxfer** method to transfer a file from one remote Site to another. You must use absolute path names for the source and target folders.

```vbscript
```

**Syntax**

```vbscript
Boolean Object.S2Sxfer(BSTR bstrSourceName, BSTR bstrDestName, BSTR bstrPeerHost, BSTR bstrPeerLogin, BSTR bstrPeerPassword, long Port, BSTR bstrPeerProtocol);
```

**Parameters**

- `bstrSourceName`—source file and folder name
- `bstrDestName`—target file and folder name
- `bstrPeerHost`—target host name
- `bstrPeerLogin`—target login
- `bstrPeerPassword`—target password
- `Port`—target port
- `BstrPeerProtocol`—target protocol (FXP can be applied for hosts with different protocols FTP, FTP-S)

**Return values**

- `true`—Transfer was successful
false—Transfer failed

**Example**

```vbscript
Set MySite = CreateObject("CuteFTPPro.TEConnection")
'MySite host name, user, password, etc.
MySite.Connect
```

**SocksInfo**

Use the SocksInfo property to set or retrieve values for SOCKS4 or SOCKS5 servers. (SOCKS is a protocol for a TCP proxy across firewalls.)

```vbscript
HRESULT SocksInfo([out, retval] BSTR *pVal);
HRESULT SocksInfo([in] BSTR newVal);
```

**Syntax**

```vbscript
String Object.SocksInfo
```

**Authentication Parameters**

"socks4://socksusername:sockspassword@sockshostname:socksport"—For SOCKS4 servers that require authentication.

"socks5://socksusername:sockspassword@sockshostname:socksport"—For SOCKS5 servers that require authentication.

"socks4://sockshostname:socksport"—For SOCKS4 servers that do not require authentication.

"socks5://sockshostname:socksport"—For SOCKS5 servers that do not require authentication.

**Additional parameters**

"socksusername"—The user name or log in name to the SOCKS server.

"sockspassword"—The password for the SOCKS server.

"sockshostname"—The address and port for the SOCKS server.

**Example 1**

```vbscript
MySite.SocksInfo = "socks4://globalscape.com:1080" 'use socks4 without authorization
```

**Example 2**

```vbscript
MySite.SocksInfo = "socks5://joeuser:mypass@globalscape.com:1080" 'use socks5 with authorization for user "joeuser" with password "mypass"
```

**Example 3**

'retrieve the current value of SocksInfo (empty if none)

```vbscript
str = MySite.SocksInfo
```

'now display it

```vbscript
MsgBox str
```
Speed
Use the **Speed** property to determine a transfer's progress and various other aspects of the transfer.

See also the **TimeLeft**, **TimeElapsed**, **TotalSize**, and **TransferredSize** properties below.

```csharp
HRESULT Speed([in, defaultvalue(-1)] long taskIdx, [out, retval] long *pVal);
```

**Syntax**

```
long Object.Speed (long taskIdx) = bytes/second
```

**Parameters**

TaskIdx—This is the task index in the array of tasks created by asynchronous methods [0..AsyncTaskNumber minus one, or - 1 (last asynchronous task started)] It has a default value of - 1 = current task.

**Example**

```vbscript
Set MySite = CreateObject("CuteFTPPro.TEConnection")
'st all relavant host, login, pass, etc. properties
MySite.Host = host
MySite.Download "aaa", "c:\temp"
```

Status
Use the **Status** property to determine whether a transfer is active or it is already finished with success or error. This can be useful in combination with asynchronous commands or during an interactive script. The Status property will return a string.

```csharp
HRESULT Status([in, defaultvalue(-1)] long taskIdx, [out, retval] BSTR *pVal);
```

**Syntax**

```
String Object.Status (long taskIdx)
```

**Parameters**

TaskIdx—This is the task index in the array of tasks created by asynchronous methods [0..AsyncTaskNumber or - 1 (last started)]

**Return Values**

"WAIT"—Transfer action invoked but not initiated yet (followed by connecting)

"CANCELLED"—Active transfer canceled by user

"FINISHED"—Transfer completed

"ERROR"—Error in transfer (any possible client or server error)

"SUSPENDED"—Added to queue but no transfer initiated yet

"SCHEDULED"—Item is scheduled for future transfer

"BLOCKED"—An internal status used for navigation and does not pertain to active or pending transfers. You can cancel any transfer requests in BLOCKED status without any ill effects.
"CHILDWAIT"—Condition when transfer item is waiting for a dependant item to finish transferring (*)
"SKIPPED"—Transfer skipped by user or automatically per overwrite rules
"CONNECTING"—Connecting to server (status right after WAIT)
"CANCELLING"—Cancel initiated but not completely stopped yet
"WORKING"—After connecting but before transferring. Could be opening data connection, or setting
REST params, etc.
"TRANSFERRING"—File transfer in progress
"UNKNOWN"—Another string was returned other than one of the above. The string was
unrecognized.

Example

```vbscript
Set MySite = CreateObject("CuteFTPPro.TEConnection")
If not CBool(MySite.IsPending) Then
    MsgBox "Task done, final status is " + MySite.Status
End if
```

Synchronize

Use the **Synchronize** method to perform one or two way mirrors of a remote and local folder's
contents.

```vbscript
HRESULT Synchronize([in, defaultvalue("BSTR bstrRemoteName, [in,
defaultvalue("BSTR bstrLocalName, [in, defaultvalue(0)] long nDirection, [in,
defaultvalue(0)] long nAction, [in, defaultvalue(0)] long nCasehandling, [in,
defaultvalue(TRUE)] BOOL bRecursive, [in, defaultvalue(TRUE)] BOOL
bIgnoreLinks, [in, defaultvalue(FALSE)] BOOL bDelDestination, [in,
defaultvalue(TRUE)] BOOL bPromptDel, [out, retval] BOOL *pVal);```

Syntax

```vbscript
Object.Synchronize(BSTR bstrRemoteName, BSTR bstrLocalName, long nDirection,
long nAction, long nCasehandling, BOOL bRecursive, BOOL bIgnoreLinks, BOOL
bDelDestination, BOOL bPromptDel);```

Parameters

Be sure to use absolute path names for both local and remote folder paths.

<table>
<thead>
<tr>
<th>#</th>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>BstrRemoteName</td>
<td>String value that specifies the absolute path name of the remote folder</td>
</tr>
<tr>
<td>2</td>
<td>BstrLocalName</td>
<td>String value that specifies the absolute path name of the local folder</td>
</tr>
<tr>
<td>3</td>
<td>nDirection</td>
<td>0 = Mirror Local (make the remote look just like the local) 1 = Mirror Remote (make the local look just like the remote) 2 = Mirror Both</td>
</tr>
<tr>
<td>4</td>
<td>nAction</td>
<td>When nDirection = 2 (Mirror Both) 0 = Mirror the more recent file 1 = Mirror the larger file 2 = Prompt for matching file names 3 = Skip mirroring files with the same names</td>
</tr>
<tr>
<td></td>
<td></td>
<td>When nDirection = 0 or 1 (Mirror Local or Remote) 0 = Use Global Overwrite settings in the CuteFTP shell for matching filenames 1 = Always overwrite the file with a matching name 2 = Numerate the file (filename[1]) 3 = Skip</td>
</tr>
<tr>
<td>5</td>
<td>nCaseHandling</td>
<td>0 = Transfer first and skip the rest (default) 1 = Show rename prompt 2 = Numerate</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note: This action applies when matching filenames are found and the only difference is the filename case.</td>
</tr>
<tr>
<td>6</td>
<td>bRecursive</td>
<td>0 = Don't sync subfolders 1 = Apply sync to subfolders (default)</td>
</tr>
<tr>
<td>7</td>
<td>bIgnoreLinks</td>
<td>0 = Don't ignore symbolic links 1 = Ignore symbolic links (default)</td>
</tr>
<tr>
<td>8</td>
<td>bDelDestination</td>
<td>0 = Don't remove destination 1 = Remove destination if source does not exist (default)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note: This action only applies to one-way mirroring. If a file exists in the destination that isn't in the source being mirrored, then delete the destination file.</td>
</tr>
<tr>
<td>9</td>
<td>bPromptDel</td>
<td>0 = Don't prompt before removing destination 1 = Prompt before removing destination (default)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note: Only applies to one-way mirroring when DelDestination is True.</td>
</tr>
</tbody>
</table>

Examples

'Simple synchronize using minimal parameters

    Set MySite = CreateObject("CuteFTPPro.TEConnection")
    MySite.Connect
    MySite.Synchronize "\pub\myfolder", "C:\mysitesfiles", 0, 1

'Don't forget to initialize all necessary fields for MySite : host name, user, password, etc.

    MySite.Connect
    MySite.Synchronize "\pub\myfolder", "C:\mysitesfiles", 0, 1

'This will perform a local mirror, overwriting any matching filename.
'Simple synchronize using minimal parameters

    Set MySite = CreateObject("CuteFTPPro.TEConnection")

'Don't forget to initialize all necessary fields for MySite : host name, user, password, etc.

    MySite.Connect
    MySite.Synchronize "/pub/myfolder", "C:\mysitesfiles", 2, 0

'This will perform full mirror (both), overwriting older files when a matching filename is found.
&Slightly more complex synchronize routine used to synchronize bookmarks. Uses variables for the path names

    strRemotePath = "\Favorites"
    strLocalPath = "C:\Documents and Settings\username\Favorites"

'Don't forget to initialize all necessary fields for MySite : host name, user, password, etc.

    MySite.Connect
    If (Not (MySite.IsConnected)) Then
        MsgBox "Unable to connect to server:" + MySite.Host
    End if
    MySite.Synchronize strRemotePath, strLocalPath, 2, 3, 0, 1, 1, 0, 1

'Performs a full mirror, skips matching filenames, transfers only the first file if multiple files are found with the same name but different case, applies to subfolders, ignores symbolic links, does not remove destination files if the source doesn't exist (N/A when dealing with dual mirror), and prompt prior to deleting anything (N/A when dealing with dual mirror).

'Alert me to the completed task

    MsgBox "DONE!"

'Disconnects from the site when done

    MySite.Disconnect

'Close the Transfer Engine process

    MySite.Close

'A full synchronizeaiton VB subroutine:

Sub Sync()

    Dim MySite
    Set MySite = CreateObject("CuteFTPPro.TEConnection")
    strHost = "ftp.yourhost.com"
    strPath = "/pub"
    strLocalPath = "c:\temp\sync_test"
    strHost = InputBox("Enter host", "CuteFTP", strHost)
    strPath = InputBox("Enter remote path", "CuteFTP", strPath)
    strLocalPath = InputBox("Enter local path", "CuteFTP", strLocalPath)
    MySite.Host = strHost
    MySite.CaseHandling = 1
    MySite.Recursive = False
    MySite.IgnoreLinks = True
    MySite.DeleteDestination = False
    MySite.PromptDelete = True
    nUserChoise = MsgBox ("Mirror remote: " & strHost & strPath & " to local " & strLocalPath & " ?", vbYesNoCancel)
    If nUserChoise = vbYes Then
        MySite.Synchronize strPath, strLocalPath, 1, 0

    End If
End Sub
else
nUserChoise = MsgBox("Mirror local: " & strHost & strLocalPath & " to remote " & strPath & " ?", vbYesNoCancel)
    If nUserChoise = vbYes Then
        MySite.Synchronize strPath,
        strLocalPath, 0, 0
    else
        nUserChoise = MsgBox("Mirror both: " & strHost & strPath & " <- > " & strLocalPath & " ?", vbYesNoCancel)
        If nUserChoise = vbYes Then
            MySite.Synchronize strPath,
            strLocalPath, 2, 1
        else
            End if
        End if
    End if
End Sub

TECommand

Use the TECommand method to pass various commands to the Transfer Engine component. If you leave the Transfer Engine running for a long time, it is recommended you include the DELETEFINISHED or DELETEALL in your scripts to occasionally empty the queue. The Transfer Engine does not empty the queue automatically.

HRESULT TECommand([in] BSTR bstrCommand);

Syntax

Object.TECommand(BSTR bstrParameter)

Parameters

"CLOSE" or "EXIT"—Closes the TE (all tasks will be stopped)
"EXITNOPENDING"—Closes the TE if no pending tasks are available
"UPDATESETTINGS"—Reloads settings from the registry (Note you can modify the registry from VBS)
"DELETEFINISHED"—Removes finished items from queue
"DELETEALL"—Removes all items from queue

You can use any number of spaces or underscores inside these parameters. For example, "update setting" and "_UPDATE_SETTINGS_" are the same.

If the Transfer Engine has several tasks, or must run for a long time, you should include the DELETEFINISHED command in your scripts to occasionally clear items from the queue.

Example

Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.TECommand("DELETEFINISHED")

TimeElapsed

Use the TimeElapsed property to determine a transfer's progress.

HRESULT TimeElapsed([in, defaultValue(-1)] long taskId, [out, retval] long *pVal);
Transfer Engine (Scripting)

Syntax

```
long Object.TimeElapsed (long taskIdx) = seconds
```

Parameters

TaskIdx—This is the task index in the array of tasks created by asynchronous methods [0..AsyncTaskNumber minus one, or -1 (last asynchronous task started)]. It has a default value of -1 = current task.

Example

```
Set MySite = CreateObject("CuteFTPPro.TEConnection")
'Mset all relevant host, login, pass, etc. properties
MySite.Host = host
MySite.Download "aaa", "c:\temp"
```

TimeLeft

Use the `TimeLeft` property to determine how many seconds are left before a transfer is complete.

```
HRESULT TimeLeft([in, defaultvalue(-1)] long taskIdx, [out, retval] long *pVal);
```

Syntax

```
long Object.TimeLeft (long taskIdx) = seconds
```

Parameters

TaskIdx—This is the task index in the array of tasks created by asynchronous methods [0..AsyncTaskNumber minus one, or -1 (last asynchronous task started)]. It has a default value of -1 = current task.

Example

```
Set MySite = CreateObject("CuteFTPPro.TEConnection")
'Mset all relevant host, login, pass, etc. properties
MySite.Host = host
MySite.Download "aaa", "c:\temp"
```

TotalSize

Use the `TotalSize` property to determine the total file size of a transfer.

See also `TransferredSize` below.

```
HRESULT TotalSize([in, defaultvalue(-1)] long taskIdx, [out, retval] BSTR *pVal);
```

Syntax

```
long Object.TotalSize (long taskIdx) = size in bytes
```
### Parameters

**TaskIdx**—This is the task index in the array of tasks created by asynchronous methods [0..AsyncTaskNumber minus one, or -1 (last asynchronous task started)]. It has a default value of -1 = current task.

**Example**

```vbs
Set MySite = CreateObject("CuteFTPPro.TEConnection")
' set all relevant host, login, pass, etc. properties
MySite.Host = host
MySite.Download "aaa", "c:\temp"
MsgBox "Size: " & MySite.TotalSize & ", speed: " & MySite.Speed & ", time: 
& MySite.TimeElapsed
```

### TransferredSize

Use the **TransferredSize** property to determine the size after a file has been transferred and possibly compressed.

```vbs
HRESULT TransferredSize([in, defaultvalue(-1)] long taskIdx, [out, retval] BSTR *pVal);
```

**Syntax**

```vbs
long Object.TransferredSize (long taskIdx) = size in bytes
```

**Parameters**

**TaskIdx**—This is the task index in the array of tasks created by asynchronous methods [0..AsyncTaskNumber minus one, or -1 (last asynchronous task started)]. It has a default value of -1 = current task.

**Example**

```vbs
Set MySite = CreateObject("CuteFTPPro.TEConnection")
' set all relevant host, login, pass, etc. properties
MySite.Host = host ' set all relevant host, login, pass, etc. properties
MySite.Download "aaa", "c:\temp"
MsgBox "Size: " & MySite.TotalSize & ", speed: " & MySite.Speed & ", time: 
& MySite.TimeElapsed
```

### TransferType

Use the **TransferType** property to retrieve or set the value for the way the Transfer Engine should transfer files (ASCII, binary or auto).

```vbs
HRESULT TransferType([out, retval] BSTR *pVal);
```

**Syntax**

```vbs
String Object.TransferType
```

**Parameters**

"ASCII"—All files should be transferred in ASCII mode

"BINARY"—All files should be transferred in BINARY mode
"AUTO" (default)—The TE will reference an internal list editable from CuteFTP's Global Options to determine the proper transfer type for that particular file. For example, if the ASCII list contains a filter mask of "txt" then all files with extension ".txt" will be transferred in ASCII. If a file doesn't correspond to any mask in this list then it will be transferred in binary mode.

**Example**

```vba```
Object.TransferType = "AUTO"
```
'the Transfer Engine will use the shell's default settings to establish whether the transfer should occur in binary or ASCII.
'twrite file transfer code next
```

**TransferURL**

Use the **TransferURL** method to download files directly from a Web address.

```vba```
HRESULT TransferURL([in] BSTR bstrRemoteName, [in, defaultValue(1)] long nParts, [out, retval] BOOL *pVal);
```

**Syntax**

```vba```
Object.TransferURL(BSTR bstrRemoteName, long nMultipartNumber)
```

**Parameters**

- **bstrRemoteName**—This is a string value for the URL for the file transfer such as: (ftp://ftp.globalscape.com/pub/cuteftp/cuteftp.exe).
- **nMultipartNumber**—This is optional and will split a file into parts for transfer. The default = 1.

**Example**

```vba```
Set MySite = CreateObject("CuteFTPPro.TEConnection")
```

**The TE recognizes these URL formats:**

ftp://user:pass@ ftp.sitename.com:port
ftp://user:pass@ ftp.sitename.com
ftp://user@ ftp.sitename.com
ftp:// ftp.sitename.com
ftp://ftp.sitename.com/pub l: user p: pass & l: user is a lowercase "L", not "one"
```
TransferURLAsync

Use the TransferURLAsync method to start a download from a web address, and return control to the script immediately. This method does not wait for the transfer to end. You can use it to perform many simultaneous transfers.

The difference between this method and DownloadAsync is simply the ability to specify all of the necessary parameters in one command, rather than having to set the user name, port, host, etc. and then transfer a file.

Immediately after you call this method subsequent methods in your script will be called, so be careful when timing certain events.

If TransferURLAsync encounters a problem when trying to complete its task, it will not throw a COM, ATL, or VB error. TransferURLAsync will also adhere to your max global and per site settings. You can't use wildcards in this method.

```
HRESULT TransferURLAsync([in] BSTR bstrRemoteName, [in, defaultValue(1)] long nParts, [out, retval] BOOL *pVal);
```

Syntax

```
Object.TransferURLAsync(BSTR bstrURL [, long nMultipartNumber])
```

Parameters

- **bstrURL**—A string value for the URL for the file transfer (ftp://ftp.cuteftp.com/pub/cuteftp)
- **nMultipartNumber**—An optional multipart parameter with default = 1

Example

```
Set MySite = CreateObject("CuteFTPPro.TEConnection")
```

'this will transfer the entire English CuteFTP directory from the CuteFTP.com ftp site.

Normal Formats Supported

- ftp://user:pass@ ftp.sitename.com:port
- ftp://user:pass@ ftp.sitename.com
- ftp://user@ ftp.sitename.com

232

Extended URL Formats
Aside from the standard URL formats shown above, additional specifiers may be used to denote the direction of transfer and download path. Use the extended format to perform site to site transfers, uploads, targeted downloads, and more.
The standard url ftp://user:pass@ftp.host.com will be used in the following examples:
Format: Normal URL transfer
```
MySite.TransferURLAsync "ftp://user:pass@ftp.host.com"
```
'download site to the default download folder
Format: URL [space] "--->" [space] LPATH
```
MySite.TransferURLAsync "ftp://user:pass@ftp.host.com --> c:\temp"
```
'download site to the c:\temp folder
Format: URL [space] "<--" [space] LPATH
```
MySite.TransferURLAsync "ftp://user:pass@ftp.host.com <-- c:\web"
```
'upload files from c:\web to the site
Format: URL1 [space] "<--" [space] URL2
```
MySite.TransferURLAsync "ftp://user:pass@ftp.host.com <-- ftp://user2:pass2@ftp.host2.com"' perform a site to site transfer
Format: URL [space] "<==" [space] LPATH
```
MySite.TransferURLAsync "ftp://user:pass@ftp.host.com <== c:\web"
```
'synchronize (mirror local) the c:\web folder to the site
Format: URL [space] "==>" [space] LPATH
```
MySite.TransferURLAsync "ftp://user:pass@ftp.host.com ==> c:\web"
```
'synchronize (mirror remote) the site to c:\web
Format: URL [space] "<=" [space] LPATH
```
MySite.TransferURLAsync "ftp://user:pass@ftp.host.com <== c:\web"
```
'synchronize both local and remote (mirror both)

Upload
Use the Upload method to transfer a file or folder from a local hard drive to a remote server.
```
HRESULT Upload([in, defaultvalue("BSTR bstrLocalName, [in, defaultvalue("BSTR bstrRemoteName, [in, defaultvalue(1)] long nParts, [out, retval] BOOL *pVal);
```

Syntax
```
Object.Upload(BSTR strLocalName ,BSTR strRemoteName , long nMultiPartNumber)
```
Parameters

strRemoteName—This is optional; use it only if you want to change the destination name or path for the uploaded files or folders. You can use absolute or relative paths.

strLocalName—This is the path to the local item you are uploading. You can use absolute or relative paths with or without wildcards.

nMultiPartNumber—Use this to split the upload into multiple parts. The default value = 1. The value specifies the number of parts used for the download.

Example

    Set MySite = CreateObject("CuteFTPPro.TEConnection")
    MySite.Connect 'r;Recommended: call connect first
    MySite.RemoteFolder = "Temp"
    MySite.LocalFolder = "C:\123"

    MySite.Upload "*.*"

Configuration Notes

You can only use multi-part uploads with servers that support the COMB command. Currently, only Globalscape EFT Server supports the COMB command.

Setting the Multi-part upload attribute can greatly increase the transfer speed for larger files under certain conditions. For example, the site must support multiple concurrent connections from the same user and you must have significant bandwidth.

The Upload method is a synchronous command, meaning it must finish executing before subsequent commands in your script can be called. Use the method UploadAsync (which also supports Multi-part transfers) to synchronously upload files, which allows you to execute the rest of the script while the upload(s) take place.

You cannot upload and rename multiple files by specifying a wildcard in the strRemoteName parameter. For example, MySite.Upload "*.exe", "*.txt" will upload all of the files in the current local folder that end with *.exe to a remote folder named "_.txt". That is, if you specify a wildcard, the wildcard character is replaced by an underscore ( _ ) character.

UploadAsync

Use the UploadAsync method to upload a file or folder to a remote server asynchronously. An asynchronous upload starts and then returns control to the script before the transfer finishes. This allows you to perform many simultaneous transfers because the method does not wait for the upload to end.

Immediately after you call this method subsequent methods in your script will be called, so be careful when timing certain events.

If UploadAsync encounters a problem when trying to complete its task, it will not throw a COM, ATL, or VB error. UploadAsync will also adhere to your max global and per site settings.

    HRESULT UploadAsync([in, defaultvalue("BSTR strLocalName, [in, defaultvalue("BSTR strRemoteName, [in, defaultvalue(1)] long nParts, [out, retval] BOOL *pVal);
Transfer Engine (Scripting)

Syntax

```vbscript
Object.UploadAsync(BSTR strLocalName [,BSTR strRemoteName [, long nMultiPartNumber]])
```

Parameters

- **strRemoteName**—This is optional, use it only if you want to change the destination name or path for the uploaded files or folders. You can use absolute or relative paths with or without wildcards.
- **strLocalName**—This is the path to the local item you are uploading. You can use absolute or relative paths with or without wildcards.
- **nMultiPartNumber**—Use this to split the upload into multiple parts. The default value = 1. The value specifies the number of parts used for the download.

Example

```vbscript
Set MySite = CreateObject("CuteFTPPro.TEConnection")
'MySite.Connect
'MySite.UploadAsync "c:\temp\*.vob", "/DVDFiles" 'uploads as many .vob files as concurrent connection settings allow
```

Info: The multi-part parameter for the **UploadAsync** method is currently limited to servers that support this operation, due to the need to recombine the files after the upload of each part has completed. Globalscape EFT Server supports this function.

UseProxy

Use the **UseProxy** property to retrieve or set the value for the type of SOCKS or proxy server that is being (or should be) used. Since OFF is the default, you don't need UseProxy for regular connections which do not pass through proxy or SOCKS servers.

```vbscript
HRESULT UseProxy([out, retval] BSTR *pVal);
HRESULT UseProxy([in] BSTR newVal);
```

Syntax

```vbscript
String Object.UseProxy
```

Parameters

- **"OFF"**—Direct connection without any socks and proxy
- **"SOCKS"**—SOCKS server only - the user must specify the SOCKS parameters by setting the **SocksInfo** property
- **"PROXY"**—Proxy server only - the user must specify the proxy server parameters by setting the **ProxyInfo** property
- **"BOTH"**—Use both SOCKS and proxy - the user should specify the appropriate information for both the proxy and the socks server with **ProxyInfo** and **SocksInfo**.

Example

```vbscript
' specify that socks will be used, then configure SocksInfo
Object.UseProxy = "SOCKS"
Object.SocksInfo = "socks5://globalscape.com:1080"
```

'Rest of connection code follows
Wait

Use the **Wait** method to tell the Transfer Engine to hold all other tasks until a specific asynchronous task is completed. Then continue with the rest of the script.

```cpp
HRESULT Wait([in, defaultvalue(-1)] long taskIdx, [in, defaultvalue(0)] long timeout, [out, retval] BSTR * pStatus);
```

**Syntax**

```
String Object.Wait (long taskIndex, long timeout)
```

**Parameters**

- **taskIndex**—This is the task index in the asynchronous tasks array. The default = -1 (which is current task). It can range from 0 to the total number of tasks minus one.
- **timeout**—Determines how long (in milliseconds) to wait for a finished, cancelled, or error status before continuing with the script.

**Return Value**

- "CANCELLED"—Transfer was stopped by the user
- "FINISHED"—Transfer was successfully finished
- "ERROR"—There were errors during the transfer
- "SKIPPED"—The transfer was skipped (file overwrite rules)

**Example**

```vbs
'Initialize all necessary fields for MySite : host name, user, password, etc.
Set MySite = CreateObject("CuteFTPPro.TEConnection")
strResult = MySite.Wait
If (strResult = "ERROR") then
    MsgBox "warning! An error has occurred!"
End if
```

**Configuration Notes**

The default timeout value for the Wait method is 21,805,184 milliseconds, or approximately 6 hours.
The maximum possible value for timeout is 2,147,483,647 milliseconds, or just under 25 days.
You can set the Wait method to never timeout by using a timeout value of 0 (zero).
For hints on Wait method timeouts, see [Timeout strategies](#), below.

WriteToLOG

Use the **WriteToLOG** method to write a message directly to the connection log saved in the path set in CuteFTP's global options. It is useful for documenting events to aid in script debugging.

```cpp
HRESULT WriteToLOG([in] BSTR bstr, [in, defaultvalue("statusBSTR bstrType));
```

**Syntax**

```
Object.WriteToLOG(BSTR bstr , BSTR bstrType)
```

**Parameters**

- **bstr**—The log message.
bstrType—A log message, type: "STATUS", "ERROR", "NOTE", "COMMAND", "RAW". The default is "STATUS".

Example

'Initialize all necessary fields for MySite : host name, user, password, etc.

    Set MySite = CreateObject("CuteFTPPro.TEConnection")
    strResult = MySite.Wait
    If (strResult = "FINISHED") then
        MySite.WriteToLOG "Transfer successful!!"
        MySite.WriteToLOG "Transfer successful!!", "error"
        MySite.WriteToLOG "Transfer successful!!", "note"
    End if

As result, the log will contain the following strings:

    STATUS: > Transfer successful!!
    ERROR: > Transfer successful!!
    Note > Transfer successful!!

Timeout Strategies for the Wait Method

The default timeout value for the Wait method is 21,805,184 milliseconds, which is approximately 6 hours. The timeout value is a SIGNED LONG data type, meaning its maximum possible value is 2,147,483,647 milliseconds, which is roughly 596.5 hours or just under 25 days. This is likely enough time for even the slowest transfer.

The Wait method supports a "0" timeout value which means "keep waiting forever or until the transfer reaches a state of CANCELED, FINISHED, ERROR, SUSPENDED, SKIPPED, or BLOCKED."

You can also write scripts so that they check the condition of a transfer and if it is still in the "TRANSFERRING" state, to wait on it again.

Three timeout strategies for long transfer tasks

1. **Specify a large timeout value in the script call** - Because the first parameter to the Wait method is a task index, this example uses a "-1" which means "current task." For this example, the timeout is set for 10 hours or, 10 * 60 * 60 * 1000 = 36000000 milliseconds.

   Example

   `strResult = strataFTP.Wait( -1, 36000000 )`

2. **After a Wait() function has timed out, check the STATUS of the transfer** - In this scenario, use the program (or script) logic to keep trying after a Wait times out when the transfer is still in the TRANSFERRING state. In other words, your polling for the termination status has timed out, but not necessarily the transfer itself, so you keep going. In the following example, you wait up to 10 hours for the transfer, and if that times out, you check the status of the transfer. If it is still TRANSFERRING, you do it again (please note the last two conditional statements):

   Example

   Do
   `strResult = strataFTP.Wait( -1, 36000000 )`
   Loop While ( strResult <> "CANCELED") and ( strResult <> "FINISHED" ) and
(strResult <> "ERROR") and (strResult <> "SKIPPED") and
(strResult <> "SUSPENDED") and (strResult <> "BLOCKED")

Alternatively, you can take the more positive outlook of continuing on while the transfer task is
either WORKING, CONNECTING, or TRANSFERRING:

**Example**

Do

strResult = strataFTP.Wait(-1, 36000000)

Loop While (strResult = "TRANSFERRING") or (strResult = "WORKING") or

(strResult = "CONNECTING")

3. **Wait forever, or until the transfer reaches some termination point.** Most transfers eventually
either FINISH or receive an error from the server; but there is a minor chance that the transfer in
the queue is perpetually stuck in a "TRANSFERRING" state. This strategy might be considered a
little riskier than the first two:

**Example**

strResult = strataFTP.Wait(-1, 0)

### Using a Script to Connect to a Remote Site

The script below connects the TE to the public Globalscape FTP server and displays the words
**Connected OK** in a message box after a successful connection.

```vbs
Set MySite= CreateObject("CuteFTPPro.TEConnection")
MySite.Option ("ThrowError") = False
MySite.Protocol = "FTP"
MySite.Host = "ftp.cuteftp.com"
if cbool(MySite.Connect) then
    MsgBox "Connected OK"
else
    MsgBox MySite.ErrorDescription
end if
MySite.Disconnect
MySite.Close
```

*Save this script in a text editor with a .vbs extension, then double-click the .vbs file to execute the script.*

### Using a Script to Download a File

The script below connects to the Globalscape FTP Site and downloads a file called **index.txt** to a local
folder, c:/temp.

'This sample script performs an anonymous login to ftp://ftp.globalscape.net

'Get a reference to the TE COM object.

```vbs
Dim MySite
Set MySite = CreateObject("CuteFTPPro.TEConnection")
MySite.Protocol = "FTP"
MySite.Host = "ftp.globalscape.com"
MySite.Login = "anonymous"
MySite.Password = "user\user.com"
MySite.UseProxy = "BOTH"
```
MySite.FileOverWriteMethod = "NUMERATE"
MySite.Connect

'Verify the connection was made successfully
If (Not CBool(MySite.IsConnected)) Then
    MsgBox "Could not connect to: " & MySite.Host & "!"
    Quit(1)
End If

'The script will now check to see if the local folder c:\temp exists and will create it if necessary
If (Not (MySite.LocalExists("c:\temp"))) Then
    MySite.CreateLocalFolder "c:\temp"
End If

'Change TE's local working folder to to c:\temp
MySite.LocalFolder = "c:\temp"

'Check for existence of remote folder "/pub/cuteftp"
b = MySite.RemoteExists("/pub/cuteftp")
If (Not CBool(b)) Then
    'Verify existence of remote folder
    MsgBox "Remote folder not found!. Please make sure that the Pub folder exists on
    the remote Site"
    Quit(1)
End If

'Now download the index file to the local destination folder
MySite.Download "/pub/cuteftp/index.txt"

'Complete.  Show the status of this transfer.
MsgBox "File downloaded attempted. Status:  '" + MySite.Status + "'"'
MySite.Disconnect
MySite.Close

Scheduling Scripts with the Windows Task Scheduler

The Windows Task Scheduler is the recommended tool for setting your TE scripts to run at specific times, but you can also use the NT 4 AT Scheduler.

To schedule a task

1. Click Start > Control Panel > Administrative Tools > Task Scheduler.
3. Click Next, then click Browse. The Select Program to Schedule dialog appears.
4. Navigate to the script that you created, click it, then Open. You are returned to the Scheduled Task Wizard.
5. Provide a name for the task, or keep the default, which is the filename, specify how often to run the script, then click Next.
6. Specify the starting time and date (if you specified Daily, Weekly, or Monthly, or One time only) and recurrence (if you specified Daily, Weekly, or Monthly), then click Next.
7. Type the user name and password for the account that will run the script (e.g., the EFT Server account in Windows), then click Next.
8. If you want to configure advanced properties, select the check box, then click Finish.

If you want to disable the task without deleting it, open the task in the Scheduled Tasks dialog.
box (see step 1 above), then on the Task tab, clear the Enable check box.

• To delete the task, in the Scheduled Tasks dialog box (see step 1 above), click the task, then click Delete.
• If you do not have the Scheduled Tasks folder, you can use the NT 4 AT scheduler.
• In Windows 2000 or Windows XP, you can configure the Transfer Engine so that it can run when no one is logged in.
• In Windows NT 4, you must have Internet Explorer 4 or higher and the Offline Browsing Pack installed to see the Scheduled Tasks folder.

Scheduling Scripts with the Windows NT 4 AT Scheduler

The Windows Task Scheduler is the recommended tool for running TE scripts at specific times, but you can also use the NT 4 AT scheduler.

If you want to use the Windows NT 4 AT Scheduler to run TE scripts at specific times, follow these guidelines:

• A user must be logged in at the time the task is scheduled to run, though the computer can be locked.
• Include the /interactive switch in each task.
• Include the full path to the script with the file name and extension.

The following example runs a script at 2:12 pm, every day of the week. The script is on the computer's C drive, in the example folder, and is named te-test.vbs. For example:

```
at 14:12 /interactive /every:M,T,W,Th,F,S,Su c:\example\te-test.vbs
```

• For more details and switches for the AT Scheduler type AT/? at the command prompt.
• You can install a GUI task scheduler as part of Internet Explorer if you have version 4 or higher, see http://support.microsoft.com/default.aspx?scid=kb;EN-US;171229. The task scheduler is part of the Offline Browsing Pack.

Running the Transfer Engine without a User Present

The Transfer Engine is a process, not a service. However, you can execute scripts while the system is not logged in if you properly configure Windows DCOM configuration for the Transfer Engine. Carefully read and follow the steps below. A sample script is provided.

To configure the TE under the DCOM configuration applet

1. Click Start > Run.
2. In the Run dialog box, type:
   `DCOMCNFG`
3. Click OK. The Windows Component Services dialog box appears.
4. In the left pane, expand Component Services, expand Computers, expand My Computer, expand DCOM Config, then click TECConnection Class.
5. Right-click TECConnection Class, then click Properties. The TECConnection Class Properties dialog box appears.
6. Click the Identity tab.
7. Under Which user account do you want to use to run this application, click This user, then provide a valid user name and password. It must be the same user as established under your task scheduler's run as property (if applicable), so that the scheduler service can call the COM object as a user. This will enable the Transfer Engine to run with the user settings, and if necessary, access pre-established SSL certificates (for secure connections).

8. Click OK to save the changes, and close the Properties dialog box.

9. Close the Component Services dialog box.

Configuration Notes

- If the system is currently logged in when the TE runs, it runs as the user that you specified in the TEConnection Class Properties dialog box. You will not see the TE icon in the system tray when running CuteFTP’s main interface. Also, the hard coded user's settings are employed when the TE is run, not those of the currently logged in user. This is not an issue if you are running the TE while the system is not logged in.

- You should test your script from the command line while logged in. You can also write to the Event Viewer or a local text file to debug a script when run on system startup if necessary. Below is a sample script that includes event viewer logging of transactions.

- Your script should not contain Message Box functions or any other function that requires user input or shows a dialog box. Dialog boxes cannot display these prompts while the system is not logged in. Set your overwrite actions under CuteFTP's Global Options\Transfer\Smart Overwrite to Always Overwrite to avoid any overwrite prompts, or pre-define various rules to cover various overwrite scenarios. (See also Disabling Prompts.)

```vbnet
Const EVENT_SUCCESS = 0
Set objShell = Wscript.CreateObject("Wscript.Shell")
objShell.LogEvent EVENT_SUCCESS,"AT Loaded me"
Set MySite= CreateObject("CuteFTPPro.TEConnection")
MySite.Option ("ThrowError") = False
MySite.Host = "ftp://anonymous:user@user.com@ftp.globalscape.com/pub/cuteftp"
objShell.LogEvent EVENT_SUCCESS,"vars set"
MySite.Connect
objShell.LogEvent EVENT_SUCCESS, "connected"
MySite.Download "index.txt", "c:\temp"
objShell.LogEvent EVENT_SUCCESS, "downloaded"
MySite.Disconnect
MySite.Close
```

Running the Transfer Engine from a SQL Job

You can use SGL function sp_OACreate to create a TEConnection object. SQL runs ftpte and hides all windows. SQL uses a special instance of ftpte exe, which cannot prompt for user name and password.

Specify a local download path or filename. While optional, it's a good idea to make sure that it is going where you intend. Also, make sure that the local path has the appropriate NTFS permissions to allow the TE to have full control.

For scripted or scheduled tasks use an otherwise unused account for scheduled TE tasks. Once the CuteFTP TE (transfer engine) is started, another instance cannot be created. Windows treats the logged-in user differently than the logged-out-user and DCOM errors may occur. For instance, if a recurring background process has already run before the user logs in, once the user logs in and the background process starts again, a DCOM error will occur.

Example Transfer Script

```sql
DECLARE @property varchar(255)
DECLARE @object int
```
DECLARE @hr int
DECLARE @src varchar(255), @desc varchar(255)
PRINT '---start'
EXEC @hr = sp_OACreate 'CuteFTPPro.TEConnection', @object OUT
EXEC @hr = sp_OASetProperty @object, 'Host', 'ftp.mysite.com'
EXEC @hr = sp_OAGetProperty @object, 'Host', @property OUT
PRINT @property
EXEC @hr = sp_OAGetProperty @object, 'Login', @property OUT
PRINT @property
EXEC @hr = sp_OAGetProperty @object, 'Protocol', @property OUT
PRINT @property
EXEC @hr = sp_OAMethod @object, 'Connect'
EXEC @hr = sp_OAMethod @object, 'download', NULL, '/pub', "e:/eee"
EXEC @hr = sp_OAGetProperty @object, 'Log', @property OUT
PRINT @property
EXEC @hr = sp_OADestroy @object
PRINT '---finish'

Configuration Notes

- SQL cannot use an already running instance of ftpte.exe. The CuteFTP interface cannot communicate with an ftpte instance created by SQL.
- When a scheduled task runs as user X while user X is logged in, the profile path will be set to that user's directory (C:\Documents and Settings\X\). However, when a scheduled task runs as user X while user X is "not" logged in, the profile path will be set to the default user directory (C:\Documents and Settings\Default User\). Therefore, the desired SSL certificates from C:\Documents and Settings\X\Application Data\Globalscape\CuteFTP\certs.crt should be copied to C:\Documents and Settings\Default User\Application Data\Globalscape\CuteFTP\certs.crt
- If you use UseProxy, be sure to specify any proxy information. Please refer to Properties for more information.
  - Add a couple of log lines so that it can write to the log whenever something happens successfully. Add it after the connect line, so that you can see how far it gets.
  - To make sure you are connecting long enough to get data, use the GetList method to write a list to a local file.

Help with Scripts

CuteFTP is able to accommodate a wide range of scripts. Therefore, we are unable to offer technical support on individual scripts, other than what is available in the help files and online Knowledge Base.

If you are having trouble with your script, try to perform the desired action manually, using the CuteFTP interface. If you cannot, then troubleshoot that problem first and then retry your script.

If you are able to perform the desired actions in the desired sequence when using the interface, then the problem is not with CuteFTP or the server. The next thing to do is to troubleshoot your script line by line.

Disabling Prompts

To run the Transfer Engine with prompts disabled

Launch the TE manually and supply the -noprompts parameter.

Example

1. On the Windows Start menu, click Run.
2. In the Run dialog box, type:
   "C:\Program Files\Globalscape\CuteFTP\TE\ftpte.exe" -noprompts.
3. Click **OK**.

**Warning:** Suppressing prompts may cause lockups if no default action is available for the event in question, or if the prompt was produced by an error. When running the TE in this mode using Windows scheduler from a different user account, the TE will not be accessible from its COM or GUI interface and can only be unloaded via the Task Manager.

The best way to avoid prompts is to properly configure the TE ahead of time to cover all possible prompt scenarios, such as overwrite conditions, or SSL server certificate acceptance dialogs. For example, set your overwrite actions under CuteFTP’s global settings to Always Overwrite to avoid any overwrite prompts, or pre-define various rules to cover various overwrite scenarios. You can then export those rules as registry entries and import them onto the target computer.

You can also tell the TE to auto-accept SSL or SSH certificates using the **AutoCloseMethod** parameter of the **Option** property. Also refer to the following trouble shooting topic regarding running the TE while not logged in.

---

**Troubleshooting TE Problems**

- **High Memory Usage with the Transfer Engine**
  If you leave the Transfer Engine running for extended lengths of time, it may begin to consume large amounts of memory. Set the CuteFTP Transfer Engine to remove successful items from the queue to avoid this problem.

To remove successful items from the queue in a script

- Use the **TECommand** method with the **DELETEFINISHED** or **DELETEALL** parameter.

- **No Timeout when Connecting to an Unavailable Host**
  If the Transfer Engine’s **Connection method** refuses to timeout when connecting to a non-existing or temporarily unavailable host, try setting the throw error to true. The Connection method does not have a built-in timeout value. It will keep trying to connect indefinitely. Because the event is synchronous, subsequent lines in the script, including conditional statements for determining the connection status of the TE, never get called.

**Examples:**

A few possible workarounds, and help for accepting and rejecting certificates:

```plaintext
MySite.Option("AutoCloseMethod") = 2 '1 - auto accept, 2 - auto reject, 0 - default no auto
MySite.Option("AutoCloseDelay") = 12 ' default value is 60 sec
Set Option("AutoCloseMethod") property to 1 or 2 in order for script can continue its processing:
MySite.Option("AutoCloseMethod") = 1 will auto accept cert and continue
MySite.Option("AutoCloseMethod") = 2 will auto reject cert and finish with error
MySite.Option("AutoCloseMethod") = 0 default: will not close prompt on timeout
```

- **My Scheduled Scripts No Longer Run while not Logged In**
  If you have installed the Security Update for Microsoft Data Access Components (MDAC) Security Patch MS03-033 you may have problems using scripts to connect to secure sites.
You can get your scripts to work again by moving your certificate file. The CuteFTP certificate files generally reside in a specific user's folder, like: C:\Documents and Settings\jsmith\Application Data\Globalscape\CuteFTP\Security\certs.crt.

Move the certs.crt file to the Default User Folder. For example; C:\Documents and Settings\Default User\Application Data\Globalscape\CuteFTP\Security\certs.crt, and your scripts should now work.

- **Scripting Technical Support**

  Due to the wide range of scripts that CuteFTP is able to accommodate, we are unable to offer technical support on individual scripts other than what is available in the help files and online Knowledge Base.

  If you are having trouble with your script, try to perform the desired action manually, using the CuteFTP interface. If you cannot, then troubleshoot that problem first, then retry your script.

  If you are able to perform the desired actions in the desired sequence from within CuteFTP, then the problem is not with CuteFTP or the FTP Server. The next thing to do is to troubleshoot your script line by line.

The file name for Security Patch MS03-033 is Q823718_MDAC_SecurityPatch.exe.
Chapter 12. Troubleshooting Connection and Transfer Errors

The topics below provide information for troubleshooting connection and file transfer errors. Also refer to the CuteFTP-related Knowledgebase articles at http://kb.globalscape.com/KnowledgebaseCategory7.aspx.

**Antivirus Problems**

Outgoing connections can be affected by the presence of firewall or anti-virus software on the local computer or network connection. Either one can block the ports needed to make a successful FTP connection to a remote server.

Configure your antivirus software so that ports 20 and 21 are open (not blocked). It may also be necessary to grant specific permission for CuteFTP to access those ports. If you need help configuring your software, consult the documentation or the support section of their website.

Symantec (Norton) support site:
http://www.symantec.com/techsupp/support_options.html

McAfee support site:
http://www.mcafeehelp.com

Microsoft Windows Firewall
Refer to Windows Firewall Blocking Connections.

**Cannot Close Data Transfer Gracefully**

If the error message "Cannot close data transfer gracefully" is generated after a download is complete, it indicates that CuteFTP has received all the data it needs, but the server is still sending information. Since that data is still transmitting, CuteFTP forces the connection to close.

**Cannot Connect to Server**

Making one or more minor configuration changes usually solves connection problems quite easily.

In the Log pane, a complete list of all communications and commands between CuteFTP and the FTP server to which you are trying to connect appear. If you cannot connect, at least one ERROR message appears in the Log pane in red text, which you probably need to scroll up to see. That error message should tell you the specific reason why you cannot connect.

The most common connection problem is that the Host Address, the User Name or the Password has been entered incorrectly. Make sure all three pieces of information exactly match what the administrator of the Server you are connecting with provided.

Globalscape does not provide you with an FTP server, username, or password for uploading files. The Internet Service Provider/Web Hosting Provider to which you want to upload files provides you with the username, password, and FTP account information required to connect to their server. Most Internet Service Providers/Web Hosting Providers have this information available on their Web pages.

If you cannot connect to your server:

1. Verify that the destination server name and IP address is correct
2. Verify that the connection port number is correct (on the Type tab of Site Properties). For example, for FTP connections, it is usually port 21.
3. The remote server may be temporarily or permanently inaccessible (try again later).
4. Verify that you have chosen the right protocol (SSH2, SSL, FTP, etc.) and have setup all required options for that protocol.

5. The remote server may be refusing multiple connections from the same client. Try using only one connection thread when connecting to this particular server (on the Options tab of Site Properties).

6. Try pinging the address (see Troubleshooting Tips for details).

7. If you are using a router, verify the router is up and running (check by pinging it and then ping an address outside of the router).

8. Do a traceroute to the destination to verify all routers along the connection path are operational (see Troubleshooting Tips for details).

9. Verify that your Windows network connection is setup properly. (Can you connect to the Internet?)

10. Verify that your local software or hardware firewall is not blocking outbound connections originating from CuteFTP.

11. Verify that your anti-virus software is not at fault (disable it temporarily while you attempt to reconnect).

**Cannot Create Multiple Connections to the Same Server**

If CuteFTP does not open new connections when you try to start new sessions, or if it does not let you browse while transferring files, you can force CuteFTP to open new connections.

**To open multiple concurrent connections**

1. Select the Site in the Site Manager then do one of the following:
   - On the main menu, click File > Connect > Connect.
   - Click Connect.
   - Press CTRL+T.

2. Repeat to create more connections to the same Site.

**To configure CuteFTP to open new connections for multiple transfers**

1. On the main menu, click Tools > Global Options (or press ALT+F7).

2. Expand the Transfer node. The Transfer options appear.

3. Clear the Allow transfers to occur over the existing (browse) session check box.

4. Click the Connection node.

5. In the Per Site max connections/transfers box, ensure the value is greater than 1 (2-200).

6. Click OK, then attempt to make multiple connections to the same server.

---

*i* If the procedures above do not work, it is possible that your server is refusing multiple connections.*
Cannot Download Executable Files
If you use remote filters while connecting with some Unix or Linux servers, CuteFTP cannot download some of the files. You must turn off the filters to download the files.

To turn off remote filters
1. In the Site Manager, click the Site you want to change.
2. Do one of the following:
   • Right-click the Site, then click Properties.
   • On the main menu, click File, then click Properties.
3. Click the Actions tab.
4. Click Filter. The Filter dialog box appears.
5. Delete any filters listed in Remote filter, except for the -L filter.
6. Click OK to close the Filter dialog box.
7. Click Connect and download your files.

Cannot Download Files from a VMS Server
If your downloads from a VMS server repeatedly restart and try to complete but never do, try turning off the SIZE and MDTM commands.

To turn off the SIZE and MDTM commands
1. On the main menu, click Tools, then click Global Options (or press ALT+F7).
2. Expand the Transfer node, then click Smart Overwrite. The Smart Overwrite options appear.
3. In the Advanced Options area, clear the Use SIZE and MDTM commands to gather precise details check box.
4. Click OK.

Cannot Initiate Data Transfer
If you receive this error from a server, it could indicate one of the following problems:

- The server you are trying to log into requires a special user name and or password in order to transfer files.
  - Contact the server administrator, and find out if you need to use a special user name or password, and whether you have permission to access that server.
- The permissions on the server are incorrect, so even though your user name and password are correct, you are unable to upload or download.
  - Contact the server administrator, and make sure that your user name and password have read and write permissions set correctly.
- You cannot upload because the server you are sending to is full and will not allow more files to be uploaded.
  - Delete files that are no longer used or ask the administrator for more space on the system.
- The file name you are using has a space or a character that the server will not allow.
Double-check with the server administrator regarding which characters are accepted on the server, and rename the files to an acceptable name. For example, some Web hosting providers only allow lower-case characters, no spaces, and the files must be named HTM instead of HTML. Many hosting providers list this information on their websites.

- A communication error is occurring between the FTP host and your computer, making data transfer impossible.
  - If CuteFTP has worked in the past, change nothing and wait a little while to see if the problem is caused by Internet traffic. If this is the first time you are trying to connect, try using host types other than Auto-detect.

**Cannot Resolve Host Name**

The **Cannot Resolve Host Name** message is displayed when CuteFTP cannot make a connection to the FTP host address that you specified when you set up the connection. It could be a website that is not up at the moment or does not exist. There are several ways to approach this situation:

- Make sure you are connected to the Internet. If you are not connected to the Internet, you will need to connect before you can connect to any FTP sites.

- Make sure you typed in the **FTP Host Address** correctly. This would be just the host address of the server. For example, if you were given an FTP host address in the format: ftp://ftp.yourhost.com, you would only type ftp.yourhost.com. Also, be sure there is nothing after the host address, especially slashes ("/") indicating subdirectories. If the server does not automatically put you in your default directory when you log in to it, then you can add the directory into the "Default Remote Directory" box when configuring this Site.

- If you do not know the **FTP Host Address** for your site, you will need to contact your server administrator for more information. Globalscape support staff does **not** know or keep track of FTP host addresses of every ISP/Web server.

- If you have a firewall or proxy server, make sure CuteFTP is properly configured to work with the proxy server. You can edit the firewall or proxy settings by clicking **Tools > Global Options** and expanding **Connection** and selecting **Proxy Server**. If you are not sure what the **settings for the proxy** should be, you will need to contact your network or system administrator for that information.

If all of these options fail with the same results, contact the administrator of the server to which you are attempting to connect to in order to resolve the problem.

**Cannot See Remote Files or Folders**

If you cannot see your directory listing or files, you can try these solutions then attempt to connect again.

**Your connection log shows a LIST-L command instead of the normal LIST**

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Navigation** node, then click **Links**. The **Links options** appear.
3. Clear the **Attempt link resolution using LIST -L command** check box, then click **OK**.

**Use the -L filter on the server**

1. **Display the Site Manager**, right-click the Site, then click **Properties**.
2. Click the **Actions** tab, then click **Filter**. The **Filter Properties** dialog box appears.
3. Select the **Enable filtering** check box.
4. Select the **Enable server side filtering** check box, then type -L in the **Remote filter** box.
5. Click **OK** to close the **Filter Properties** dialog box and accept the changes.
6. Click **Connect** or **OK**.

### Change connection type
1. Display the Site Manager, right-click the Site, then click **Properties**.
2. Click the **Type** tab.
3. In the **Data connection type** box, click **Use PASV**.
4. Click **Connect** or **OK**.
   
   If you still cannot connect, follow the same steps, but click **Use PORT**.

### Turn off all filters
1. Display the Site Manager, right-click the Site, then click **Properties**.
2. Click the **Actions** tab, then click **Filter**. The **Filter Properties** dialog box appears.
3. Clear the **Enable filtering** check box, then click **OK**.
4. Click **Connect** or **OK**.

### Change server Host type
1. Display the Site Manager, right-click the Site, then click **Properties**.
2. Click the **Type** tab.
3. In the **Server type** box, click the first server type in the list (Unix).
4. Click **Connect** or **OK**.
   
   If that does not work, try the next server type on the list.

### Turn off ModeZ compression
1. Click **Tools > Global Options**.
2. Expand the Transfer node, click **MODE Z**, and then clear the **Apply Mode Z compression to the following extensions when possible** check box.
3. Click **OK**.

### Send an extended log to Technical Support
If none of the solutions above resolve the problem, obtain a raw directory listing and submit it, along with details of the problem, to [Globalscape Technical Support](https://www.globalscape.com/support/)

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **General** node, then click **Logs**. The **Log** options appear.
3. Select the **Record/display raw directory listing in logs** check box.
4. Reconnect to the problem Site.
5. Once connected, right-click in the **Log** pane, then click **Copy Entire Log to Clipboard**.
6. Paste the selection (CTRL+V) into an email message.
7. Describe the problem, what you have already tried and include information about the computer you are using (operating system, Internet connection, etc.).
8. Submit your support request using our [support submission form](https://www.globalscape.com/support/).
Child Transfer Failed

If you attempt to transfer a folder or directory and see this error, it simply means that an item or items within the folder failed to transfer. You can check your connection log to find a more detailed error describing why the item failed to transfer.

Connecting after a 425 Error

If you receive an 425 error, or an error that says "Cannot open data connection" or "Cannot build data connection," try connecting in PASV mode. If you still cannot connect, you can try connecting via HTTP and port 80. Enter all your information as you would for an FTP Site.

To connect via HTTP and port 80

1. On the main menu, click File > New > HTTP Site. The Site Properties dialog appears showing the General tab.
2. In the Label box, provide a name for the Site.
3. In the Host Address box, provide the regular FTP address for the Site.
4. In the Username box, provide your user name for the Site.
5. In the Password box, provide your password for the Site.
6. Click Connect.

Copy and Paste Functions Remove File from the Remote Folder

FTP Servers do not support the Copy command. If you copy a file from a folder in the Remote pane and then try to paste it in any folder in the Remote pane itself, you are moving the file from the original folder to that folder or to a new location on the server. FTP protocol does not allow you to retain the original file and create a copy in other folder in the remote location. You can use the Cut and Paste commands to restore the original file. This is a limitation of the FTP protocol, not CuteFTP.

- The copy command is available, because you can copy files from the Remote to the Local pane, to the queue, etc.

To copy a file or folder from one remote folder to another remote folder

1. Download the file.
2. Upload the file to the new location.

Another option is to perform a Site-to-Site transfer; however, many servers do not support Site-to Site transfers.

Error 421 Messages

Common 421 errors include:

- Error 421 Service not available, closing control connection.
- Error 421 User limit reached
- Error 421 You are not authorized to make the connection
- Error 421 Max connections reached
- Error 421 Max connections exceeded
You can receive a 421 error if the FTP server you are connected to limits the total number of connections available or limits the connections available to one user. To clear the error, change the number of per Site max concurrent transfers, remove items from the Queue Window, and make sure only one instance of CuteFTP is running.

**To change per Site max concurrent transfers**
1. On the main menu, click **Tools > Global Options**.
2. Click the **Connection** node.
3. Set **Per Site max concurrent transfers** to 1. (By default it is set to 2. This setting limits the number of connections to any one FTP Site.

**To remove items from the Queue Window**
- Sometimes the **Queue Window** can become cluttered with unfinished transfers. To clear the queue, right-click inside the **Queue Window**, then click **Remove All**.

**To verify only one instance of CuteFTP is running on your system.**
1. Right-click on the Windows Task bar, then click **Task Manager**.
2. On the **Applications** tab, view the list of running tasks to determine if CuteFTP is listed more than once.
3. If more than one instance is listed, click one of them, then click **End Task**.

**Failed to Establish Data Socket**
This error usually occurs when trying to connect in PASV mode to a Site that only accepts PORT mode connections. Change the connection type from PASV mode to PORT mode to connect to the Site.

**To switch from PASV to PORT mode**
1. In the **Site Manager**, click the problem Site.
2. On the main menu, click **File > Properties**.
3. Click the **Type** tab.
4. In the **Data connection type** list, select the **Use PORT** check box.
5. Click **OK**.

**FTP Status and Error Codes**
CuteFTP displays FTP status codes in the log window. The codes are numbered according to their category. Some codes represent errors, while most codes simply communicate the status of the connection.

Refer to the Globalscape Knowledgebase article #10142 for a list of codes and descriptions.

**High Memory Usage**
If the **Transfer Engine (SDK)** of the CuteFTP works for extended periods of time, it begins to consume large amount of system resources, such as memory and hard drive space, due to log and queue requirements.
You can set CuteFTP to remove successful items from the queue to help alleviate this problem.

Successful items are removed even if tasks were run without the user interface open.

Each finished queue item takes up about 500 bytes of memory until the Transfer Engine is closed.

Disable the logging function to improve resource management.

To remove successful items from the queue

1. On the main menu, click Tools > Global Options (or press ALT+F7).
2. Expand the Transfer node, then click Events. The Events options appear.
3. Select the Remove successful transfers from the queue automatically check box, then click OK.

To disable logging

1. On the main menu, click Tools > Global Options (or press ALT+F7).
2. Expand the General node, then click Logs. The Log options appear.
3. Clear the check boxes for logs you do not need.

HTTP Status and Error Codes

During your HTTP sessions, you will receive various numbered codes from Web servers. When connected via HTTP, CuteFTP displays these codes in the Log window. Some codes represent errors; most others simply communicate the status of the connection.

Refer to the Globalscape Knowledgebase article #10141 for a list of codes and descriptions.

Installshield Error 1628: Failed to Complete Script-Based Installation

The following error message can occur at run time when you are trying to uninstall, repair, or update an installation.

Error 1628: Failed to complete script based install.

This error message is caused by the Windows Installer Service and is often caused by the installation itself.

Possible Cause 1

This error message is often caused when the uninstallation log file becomes corrupt. This can happen if the installation is somehow corrupt.

Fix: In the Windows Task Manager, end the process that is running IDriver.exe:

1. Right-click the Windows Task bar, then click Task Manager.
2. On the Processes tab, click the Image Name column to sort it alphabetically.
3. Review the running processes to see if idriver.exe is running.
4. If idriver.exe is running, click it or right-click it, then click End Process.

Run the installation again to see if the error still occurs.

Possible Cause 2

This error can also occur if the Windows Installer Service is not properly configured on your computer or if the installation is created with a newer version of the Windows Installer Service than the one on your computer.
Fix: To fix this issue, install the latest Windows Installer Service on your computer. Instructions and download links for the Windows Installer are listed below, sorted by operating system.

- **Windows 95/ 98/ Me:**

- **Windows NT 4.0 or 2000:**

- **Windows XP:**
  Windows XP contains Windows Installer version 2.0. You should not have to install the Windows Installer Service (MSI engine) on Windows XP.

Restart your computer and run the installation again to see if the error continues to occur.

**Possible Cause 3**

This error message may also occur if a file in the Temp directory is conflicting with the files used by the installation while it is running.

Fix: Delete the entire contents of the Temp directory:

1. Double-click the My Computer icon on your desktop, or right-click Start, then click Explore.
2. Navigate to the Temp directory, for example, C:\Windows\Temp.
3. Click in the directory, then right-click and click Select All (or CTRL+A).
4. On the toolbar, click Delete or right-click the selection, then click Delete (or CTRL+X). A confirmation message appears.
5. Click Yes.

Run the installation again to see if the issue is resolved.

**Not Enough Credits to Download**

You may not be able to download from some FTP Sites until you have uploaded something to them. In other words, you have to give them a file before they give you one; a type of file trading. Most of these "ratio Sites" have a text file that explains how to upload files to them to get credits. If you have any problems, contact the server administrator. (Globalscape does not have this information.)

**Shell cannot get Data from TE**

If you see this error, there is not enough space in your Temp folder to run CuteFTP.

**To correct the error**

- Make sure the path to the Temporary Files folder (Temp) is valid.
- Make sure there is enough space to run the program on the drive where the Temporary Files (Temp) folder exists.

**Configuration Notes**

- A valid path for a temp folder on a Windows 2000 or XP computer would be similar to C:\Documents and Settings\USER\Local Settings\Temp
- A valid path for a temp folder on a Windows NT computer would be similar to C:\Temp
- This issue is more likely on computers with several different users with different accounts; each user's account needs a valid Temp folder on a hard drive with enough room to run CuteFTP.
Site-to-Site Transfer Limitations

You can connect to two servers and transfer files between them using FXP (File Exchange Protocol). FXP lets you copy files from one FTP server to another. CuteFTP supports this mechanism for transferring files between Sites.

When you transfer files between two remote hosts using an FXP client, the maximum transfer speed does not depend on your connection, but on the connection between the two hosts, which is much faster than your own connection. You cannot see the progress or the transfer speed of the files, because it is a direct connection.

Although transferring files using FXP is very easy, there are a few restrictions in transferring the files. Keep the following points in mind before using FXP:

- Both hosts must to support PASV mode and must allow PORT commands to foreign hosts. The FXP client communicates with the destination FTP server by sending a PASV command.
- The source FTP server connects to the data port reported by the destination server after a successful PASV command. All the data then goes directly from the source to the destination server, and both servers only report fail or success messages to the FTP client.

Socket Errors

Refer to the Globalscape Knowledgebase for information about the following socket errors:

- Socket error 0: [http://kb.globalscape.com/KnowledgebaseArticle10472.aspx](http://kb.globalscape.com/KnowledgebaseArticle10472.aspx)
- Socket error 10054: [http://kb.globalscape.com/KnowledgebaseArticle10235.aspx](http://kb.globalscape.com/KnowledgebaseArticle10235.aspx)
- Socket error 10055: [http://kb.globalscape.com/KnowledgebaseArticle10234.aspx](http://kb.globalscape.com/KnowledgebaseArticle10234.aspx)
- Socket error 10060: [http://kb.globalscape.com/KnowledgebaseArticle10384.aspx](http://kb.globalscape.com/KnowledgebaseArticle10384.aspx)

For information about Winsock error codes, refer to Knowledge Base article 10140.

Overwrite Repeatedly Prompts Me

If you are getting numerous overwrite prompts and want to avoid receiving them in the future, configure a default rule for the overwrite configuration panel.

To add a rule

1. On the main menu, click **Tools > Global Options** (or press ALT+F7).
2. Expand the **Transfer** node, then click **Smart Overwrite**. The **Smart Overwrite** options appear.
3. In the **For matching files** list, click **Use Rules**.
4. Select the **Ignore zero byte files** check box.
5. In the **For matching folders** list, click **Use Rules**.
6. Click **Configure Rules**. The **Overwrite Rules** dialog box appears.
7. In the **If the destination file date is** list, click **older**.
8. In the **and size is** list, click **smaller**.
9. In the **during** list, click **any transfer**.
10. In the **then** list, click **overwrite**.
11. Click **Add**. The new rule appears in the list. Add more rules as needed. Below are some recommendations:
Troubleshooting Connection and Transfer Errors

- If destination file date is **the same** and size is **the same** during any transfer then **skip**.
- If destination file date is **older** and size is **different** during any transfer then **overwrite**.
- If destination file date is **no matter** and size is **smaller** during any transfer then **resume**.
- If destination file date is **newer** and size is **larger** during any transfer then **skip**.

12. Click **OK** to save the rule and close the **Overwrite Rules** dialog box.

13. In the Prompt timeout action list, click **Skip**.

14. Select the **Timeout in** check box, and leave the time at **30 seconds**.

15. Select the **Resend LIST command as necessary** check box.

16. Select the **Use SIZE and MDTM commands to gather precise details** check box.

17. Click **OK**.

**Permission Denied**

Every time an FTP account (for uploading your Web pages) is opened, your server determines all the things that you are allowed to do, like upload, download, write to a file, delete a file, make new directories, etc. If permissions have not been set up correctly, you will not be able to upload your files to the server. If you receive this message, your server administrator has not established your permissions correctly. Contact the server administrator to reset the permissions.

If none of the transactions you try with CuteFTP seem to be completed, refer to the log pane for any entries that are colored red or any messages indicating a potential problem. You can **copy the contents** of the log into an email or text file to send to your administrator or Web hosting provider.

Refer to Globalscape Knowledgebase article #10142 and Globalscape Knowledgebase article #10141 for information about error codes.

**Port Already in Use Error with Dial-up VPN**

If you are connecting to a Virtual Private Network through a modem and receive the **Port already in use** error when trying to connect, you might need to correct your connection settings.

**To review/correct connections settings**

1. On the main menu, click **Tools > Global Options**.

2. In the left pane, expand **Connection**, then click **DUN/LAN**.

3. In the right pane, click **Connect to the Internet using a LAN**. CuteFTP uses an existing connection defined on your computer.

4. Click **OK**.

If **Connect to the Internet using a LAN** is already selected, verify your computer's VPN settings.

**To verify your computer's connection settings**

1. Do one of the following:
   - In the Windows Control Panel, click **Internet Options**.
   - In Internet Explorer, click **Tools > Internet Options**.

2. Click the **Connections** tab. The connection settings for one or more internet connections appear on this tab.

3. The **Dial-up and Virtual Private Network settings** box displays dial-up and VPN connections that are defined on your computer.
4. Click **LAN Settings** to view the local area network and proxy server settings.

---

**Transferring to Case-Sensitive Servers**

Some case-sensitive servers treat two files with same name but different case as two different files. CuteFTP is not case-sensitive and, when uploading or downloading files, it treats two files with same name and different case as the same file. For example, if you want to upload TEXT.txt file and a text.txt file already exists on the server, then it will see the files as the same and prompt you to overwrite the text.txt file.

**To set a site as case sensitive**

1. Display the Site Manager, right-click the Site, then click **Properties**.
2. Click the **Type** tab.
3. In the **Server type** list, click **Unix-compatible**.
4. Click **Connect** or **OK**.

---

**Troubleshooting Connections**

A common file transfer error is the inability to connect to the server. To test your connection, you can use the **ping** and **tracert** utilities.

Ping and tracert are DOS command-line utilities that you can use to troubleshoot connection problems. Third-party applications are also available that do basically the same thing, but provide a graphical interface for those who are not comfortable entering commands at a command prompt.

- **Ping** - When you ping a remote host, your computer sends "echo request" packets to the target host and listens for "echo response" replies. Ping also estimates the round-trip time, generally in milliseconds, records any packet loss, and prints the ping statistics when finished.

- **Tracert** - Tracert is used to determine the route taken by packets across an IP network. This is useful to determine where the connection problem exists, whether with your CuteFTP configuration, at the server, or somewhere in between, such as blocking by a firewall.

**TCPView is a Windows utility, available for free on Microsoft TechNet at**


**To use ping or tracert**

1. On the Windows task bar, click **Start > Run**. The **Run** dialog box appears.
2. In the **Run** box, type **cmd**, then click **OK**. The Windows Command Prompt appears.
3. At the prompt, type the command and then the IP address or domain name of the server to which you are trying to connect.

   For example, to test that you are using ping correctly, try pinging the Globalscape web site and do a tracert to the Gmail server, as shown in the illustrations below:

   ```
   ping www.globalscape.com
   -or-
   tracert www.globalscape.com
   ```
tracert www.gmail.com

Windows XP SP1 will not respond to an echo request on the public Internet, but you should have updated to SP2 to get the latest security fixes.

The ping command function has several switches available, as described in the Windows XP documentation available at http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/ping.mspx?mfr=true. At that same address, click in the table of contents for more Windows XP troubleshooting tips.

Truncated Listings

If you connect to a server and the log displays the message 266-Options: -1 or 226 Output truncated to 2000 matches, the server cannot display more than 2000 items in file listings. This is a limitation of the server to which you are connecting, not CuteFTP.

Using CuteFTP behind a Router

In most cases, CuteFTP does not have any problems working behind a router. If you are having problems, try transferring in PASV mode.

To transfer in PORT mode or for secure transfers, refer to your router's documentation for information on how to configure the router for such transfers.

If you are behind a NAT firewall and the FTP server is on a different network, you can only make data transfers in PORT mode using a Clear Command Channel SSL connection.
If connections or transfers fail, try one or more of the following possible solutions:

1. Ask the FTP server's administrator if the server and its network are configured to allow FTP in PASV mode.
2. Review the router documentation for information on how to set it up for FTP or how to open the appropriate ports. FTP generally uses port 21.
3. Define a port range for CuteFTP.
4. Use UPnP (if your NAT or router supports it) to establish a connection properly.
5. Turn on port mapping.

Using CuteFTP with Norton Internet Security

If you have Norton Internet Security installed on the same computer as CuteFTP, you will need to adjust a setting in the Norton program to allow CuteFTP to make connections and transfers.

Refer to Knowledge Base article #10132 for details.

Using Error Messages and Logs to Troubleshoot

You can help resolve errors by recording information from error messages and log files.

- The Log pane appears at the top of the interface under the Remote pane.
- A standard error dialog box includes a short error message and two buttons, Cancel and Details. Click Cancel to dismiss the error dialog box. Click Details to expand the error dialog to show more information.

Review the information in the logs and error messages. The problem could be as simple as a typo in the connection information, or the remote server might be refusing connection for some reason.

To use error messages and logs to troubleshoot

1. Do one or both of the following:
   - In the error message, click the Details button, right-click in the log text area, then click Copy All Text. The entire contents of the window is copied to the clipboard, then paste it into an email or text file.
   - In the Log pane, right-click, then click Copy Entire Log to Clipboard (or press CTRL+SHIFT+C), then paste it into an email or text file.
2. If you suspect CuteFTP configuration is at fault, paste it directly into the Description field at the Globalscape Technical Support Contact page to ask for help from Globalscape Technical Support.
3. Send the information to your technical support department, ISP, or Web hosting provider for troubleshooting assistance.
Troubleshooting Connection and Transfer Errors

Windows Firewall is Blocking Connections

Outgoing connections can be affected by the presence of firewall or antivirus software on the local computer or network connection. Windows comes with a built-in Internet Firewall that is active by default and blocks all FTP traffic. You can turn off this firewall (not recommended by Microsoft) or configure it to allow connections via CuteFTP. Configure your firewall so that ports 20 and 21 are open (not blocked). It may also be necessary to grant specific permission for CuteFTP to access those ports.

Follow the steps below to add CuteFTP to the Windows Firewall exceptions list.

To add CuteFTP to the Windows Firewall exceptions list

1. In the Windows Control Panel, double-click Security Center, then click Windows Firewall.
2. On the General tab, ensure Windows Firewall is On and then clear the Don’t allow exceptions check box.
3. On the Exceptions tab, review the Programs and Services list to determine if CuteFTP is listed. Look for:
   - CuteFTP (the interface)
   - ftpte.exe (the Transfer Engine)

   Both programs must be shown in the list of exceptions. If they are not, then follow the steps below to add either one or both programs to the list.
4. Click Add Program. The Add a Program dialog box appears.
5. In the Programs list, click CuteFTP, then click OK. The Add a Program dialog box closes.
6. Click Add Program. The Add a Program dialog box appears.
7. Click Browse to navigate to the CuteFTP installation folder (by default in C:\Program Files\Globalscape), click ftpte.exe, then click Open.
8. Click OK to close the Add a Program dialog box and save your changes.
9. Verify both programs appear in the Programs and Services list, then click OK to exit Windows Firewall. The firewall will now ignore the transfer engine and the interface.

For more information about the Windows Firewall, see the article on Microsoft’s website at http://www.microsoft.com/windowsxp/using/security/internet/sp2_wfintro.mspx, or search the Internet for "Windows Firewall."
This page left blank for 2-sided “book” printing.
Chapter 13. Getting Help

For the most up-to-date information regarding this version of CuteFTP; to view version history and updates; to download a PDF of this user guide; and for other self-help resources, visit the [Globalscape Support Center](http://support.globalscape.com).

After release of the product, the online help is updated as errors and omissions are identified; therefore, you should visit the Support center when the help in the application or this PDF cannot answer your questions.

**Globalscape Support Center**

If you are having a transfer or connection problem, contact your Internet Service Provider. Before contacting them, [enable consolidated transfer logs](http://kb.globalscape.com/rsshread.aspx), reproduce the problem, then copy and paste the entire log in to our online support request form or email. (Globalscape cannot tell you which server to log in to, what your login credentials are (username/password), and which folders on the server you have permissions to. Only your ISP has that information.)

If you are having a problem with CuteFTP, visit the [CuteFTP support pages](http://support.globalscape.com) for downloads, documentation, activation instructions, and the latest news regarding CuteFTP. Our Customer Service team can answer your questions about software activation and registration or help with order problems. If you need technical assistance with your software, submit your question to the [Technical Support](http://support.globalscape.com) team. However, before you contact Technical Support, please access our online help resources:

- The [Globalscape User Forum](http://support.globalscape.com) is a great place to find information or seek help from the global community of Globalscape customers and product experts.
- The [Globalscape Knowledgebase](http://kb.globalscape.com) (KB) is a database of information on our products.
- [Subscribe to the RSS feed](http://kb.globalscape.com/rssfeed.aspx) to keep abreast of the latest KB articles. Copy and paste this URL http://kb.globalscape.com/rssfeed.aspx into your RSS feed reader. (See [below](#) for examples.)
- [Subscribe to Globalscape Email Announcements](http://www.globalscape.com/newsletter) Sign up for the Globalscape Newsletter, press releases, product announcements, and other Globalscape news.
- [Recover a Lost Serial Number](http://support.globalscape.com) - If you know the email address you used when you activated the software, we can send it to you at your new address.

**To add the Globalscape Knowledge Base RSS feed to your Google home page**

The procedures below are provided as an example; see your feed reader's online help for specific instructions.

1. Sign in to your Google home page, then, in the upper right area of the page, click **Add Stuff**.
2. At the top center of the page, to the right of **Search Homepage Content**, click **Add by URL**. The **Add by URL** form appears.
3. In the text box, provide the URL of the RSS feed, http://kb.globalscape.com/rssfeed.aspx, then click **Add**.
4. In the upper left corner, click **Back to Homepage**. The Globalscape RSS feed appears on your home page.
To add the RSS feed to Microsoft Outlook 2007

1. On the main menu, click **Tools > Account Settings**.
2. On the **RSS Feeds** tab, click **New**.
3. In the **New RSS Feed** dialog box, type or paste the URL of the RSS Feed. For example, http://kb.globalscape.com/rssfeed.aspx.
4. Click **Add**.
5. Click **OK**.

Microsoft Office Online provides a tutorial on RSS feeds.

Finding Information in the Help

You can find information in the online or application help in several ways:

- **Hyperlinks** - Clickable text that opens another topic or a Web page.
- **Related Topics** - Listed at the bottom of many topics, lists other topics relevant to the current topic.
- Using the **Contents**, **Index**, **Search**, or **Favorites**, tabs, do the following:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents</td>
<td>Contains the table of contents. Click a main heading (represented by a book icon) to display pages that link to topics, and click each subheading (represented by a page icon) to display the corresponding topic in the right pane.</td>
</tr>
<tr>
<td>Index</td>
<td>Lists each of the topics in the help file in alphabetic order.</td>
</tr>
<tr>
<td>Search</td>
<td>Use the search pane to locate words or phrases within the content of the topics. Type the word or phrase in the text box, press ENTER, then click in the list of topics, click the topic you want to view.</td>
</tr>
<tr>
<td>Favorites</td>
<td>(This option is not available in the Web help.) You can add a frequently viewed topic to the Favorites tab in the application’s help. Click Add to add the topic you are viewing to the Favorites tab. To remove a topic, click the topic then click Remove. To display a topic, double-click it or click the topic, then click Display.</td>
</tr>
</tbody>
</table>

Searching the User Guide or globalscape.com

When searching, try several different searches using different words for the same concept. For example, if you want help with creating a script, search for **script**, **vb**, **batch**, and so on. Also, we have attempted to provide intuitive names for the topic titles, and the Index and Table of Contents contains the topic titles of every topic in the help file. So, in this example, if you are looking for a procedure on how to create a script, click the **Index** tab or **Contents** tab and scroll to the topic **Creating Scripts**.

When you search globalscape.com, you are searching across all of Globalscape products, not just CuteFTP. For targeted searches, try the application’s help file first, then the online help file, then the **Knowledge Base**, then the **user forum**. (You can also search this PDF.) If you still cannot find the answer to your question, contact **Globalscape Technical Support**. Be sure to let us know that you had problems finding your answer in any of our self-help resources so that we can provide better information in the future.
Printing a Help Topic

To print a Help topic:

1. Do one of the following:
   - Click the Print icon in the toolbar.
   - Right-click in the topic (in the right pane), then click Print. The Print dialog box for your operating system appears.

2. Click Print. The topic is printed to the specified printer.

Sharing Topic Links from the Online Help

In the online (HTML) help, the address bar displays the IP address (URL) of the help file, not the URL of the specific topic. If you right-click in the topic, then click Properties, you can copy the URL of the topic; however, the URL displays only the topic, without the Table of Contents. The procedure below describes how to send a topic URL that also displays the Table of Contents.

To copy a topic URL that includes the table of contents

1. Open the topic in your Web browser.
2. Right-click within the topic (the right frame), then click Properties.
3. Highlight the URL for the topic, right-click the selection, click Copy, and then close the Properties dialog box.

4. Right-click in the address bar of your browser, click Paste, and then press ENTER. The topic displays, but not the table of contents (TOC).
5. If you want to see the topic AND the TOC, click Show. The URL will update in the address bar and the TOC will appear to the left of the topic.
6. Copy the URL in the address bar (e.g., http://help.globalscape.com/help/cuteftp8/index.htm#toc_getting_help.htm) and paste it into an e-mail.
Using the Knowledge Base

Globalscape’s Knowledge Base, http://kb.globalscape.com, provides information in HOW TOs, FAQs, and other types of articles. Many of the articles are created as a result of assisting customers with configuration and troubleshooting.

Search Tips:

- For the most comprehensive search for articles specific to CuteFTP type cuteFTP, then click Go.
- To narrow your search, in the Within drop-down menu, click CuteFTP.
- To only find certain types of articles (FAQ, HOWTO, INFO, etc.), in the Type drop-down menu, click an article type.
- In the Search area, the options apply to where it searches, not the display of results. That is, if you search for cuteftp and then click Article ID, no results are returned, since Article IDs are numbers. For example, if you wanted to search for an article ID 10070, in the For solutions containing box type 10070, click Article ID, then click Go.
- To search for your keyword only in article titles, click Article Title Only.
- To search only for articles going back a certain length of time (e.g., 3 days ago, last year), click the Maximum Age drop-down menu, then click the interval.
- After your search results display, at the bottom left of the page, you can click a drop-down menu to choose to display from 10 to 100 results per page, then click Update.

Serial Number

When you contact Globalscape Customer Support for assistance, you might be asked to provide your serial number, which is available in the About dialog box:

- On the main menu, click Help > About. The About dialog box appears.
Chapter 14. License Agreements

CuteFTP® Version 9 End-User License Agreement

The CuteFTP EULA is saved in the CuteFTP installation directory during installation and is copied below for your convenience.

GlobalSCAPE, Inc. CuteFTP® Version 9 License

THIS SOFTWARE IS LICENSED, NOT SOLD. YOU MAY USE THIS SOFTWARE ONLY AS DESCRIBED IN THIS AGREEMENT.

IF YOU DO NOT AGREE TO THE TERMS OF THIS AGREEMENT, DO NOT INSTALL THE SOFTWARE OR USE ANY REGISTRATION NUMBER THAT WAS PROVIDED WITH THE SOFTWARE. YOU MAY CONTACT THE WEB SITE OR STORE WHERE YOU PURCHASED THE LICENSE FOR A REFUND IF APPLICABLE.

1. SOFTWARE. The capitalized term "Software" refers to the object code for the computer program known as CuteFTP 9, any updates, supplemental code or programs provided to you by GlobalSCAPE with or in connection with CuteFTP 9, the user's manual and Help file, any components, any related media and printed materials, and any related "online" or electronic documentation.

2. GRANT OF LICENSE. Evaluation License. If you acquired the license for the Software on an evaluation or trial basis, you may use the Software without charge for the evaluation period. Your evaluation period begins on the day you install the Software. You must pay the license fee and register your copy to continue to use the Software after the evaluation period. To pay the license fee and register your copy, you should visit www.globalscape.com or an authorized sales agent. For so long as the Software is the most current version of CuteFTP distributed by GlobalSCAPE, you may give exact copies of the evaluation Software to anyone. You may not charge any fee for the copy or use of the evaluation Software itself, but you may charge a distribution fee that is reasonably related to any cost you incur distributing the evaluation Software (e.g. packaging). You must not represent in any way that you are selling the Software itself. Your distribution of the evaluation Software will not entitle you to any compensation from GlobalSCAPE. You must distribute a copy of this license with any copy of the Software and anyone to whom you distribute the Software is subject to this license. You may not remove any copyright, trademark or reservation of rights language displayed on, in or with the Software.

Registered License. When you purchase a license, you will be provided with a registration number. You must enable the registered license for the Software by entering the registration number as prompted by the Software. The term of the license is perpetual unless you purchased a limited term license. You may install and use one copy of the registered Software on the number of computers for which you have purchased a separate license as indicated on the invoice or sales receipt. If the Software is installed on a network server or other storage device, you must purchase a license for each separate computer on which the Software is used or accessed. A license for the Software may not be shared by alternating use of the Software between different computers. If you acquired the Software for a reduced price as an upgrade from a previous version of the Software, you may no longer use the previous version. The primary user of a computer for which a license has been purchased may access the Software via a remote technology, and may make and use one copy of the Software on his or her portable computer. You may also make one copy of the Software for back-up or archival purposes. Otherwise, you may not copy the Software in whole or in part. You may permanently transfer all of your rights under this license if the recipient agrees to the terms of this license, you destroy any copy of the Software not transferred to the recipient, and, if the Software was licensed to you at a reduced price as an upgrade from a previous version, you destroy any copy of any previous version that is not transferred to the recipient. If you purchased the Software on a multi-user basis, you may permanently transfer your rights to one person only, but that person may use the Software on that number of computers for which you purchased a license.
3. Restrictions. You may not reduce the Software to human readable form, reverse engineer, de-compile, disassemble, merge, adapt, or modify the Software, except and only to the extent that such activity is expressly permitted by applicable law notwithstanding this limitation. You may not rent, lease, or lend the Software. You may not use the Software to perform any unauthorized transfer of information, such as copying or transferring a file in violation of a copyright, or for any illegal purpose.

4. Support Services. Globalscape may provide you with support services related to the Software. Use of support services is governed by the user's manual, online documentation, and other Globalscape materials, as they may be modified from time to time. Globalscape may use any information you provide as part of obtaining support services for its business purposes, including product support and development.

5. Information Collection. The Software includes a feature that assigns a unique number to your computer based on system information. The Software reports this number to us either when you install the Software or enter your registration number, or both. The Software may also identify and report to us your Windows language identifier setting, IP address, and the date and time of installation and/or registration. We use this information to count the number of installations, detect piracy of the Software, and develop rough statistical data regarding the geographic location of our users. If you register our Software, we tie this information to the personally identifiable information that we have about you.

6. Termination. This license terminates if you fail to comply with its terms and conditions. If your license terminates, you must destroy all copies of the Software. The termination of this license does not limit Globalscape's other rights it may have by law.

7. Intellectual Property. You acknowledge that you have only the limited, non-exclusive right to use and copy the Software as expressly stated in this license and that Globalscape retains title to the Software and all other rights not expressly granted. You agree not to remove or modify any copyright, trademark, patent or other proprietary notices that appear, on, in or with the Software. The Software and all derivatives thereof are protected by United States copyright, patent and trademark law and rights granted by international treaties related to intellectual property rights. The Software is copyright (c) 1996-2012 GlobalSCAPE, Inc. All rights reserved. Globalscape® and CuteFTP® are registered trademarks of GlobalSCAPE, Inc.

8. Export Restrictions. You may not export or re-export the Software in violation of the export laws of the United States, or the applicable laws of any other jurisdiction. Among other things, U.S. laws provide that the Software may not be exported or re-exported to certain countries that are embargoed or restricted or to certain restricted persons. Embargoed and restricted countries currently include Cuba, Iran, Iraq, Libya and Sudan.

9. No Warranties: To the extent permitted by applicable law, the Software and any support services are provided "as is" without warranty of any kind, either express or implied, including, without limitation, the implied warranties of merchantability, fitness for a particular purpose, or noninfringement. If applicable law requires a warranty, the required warranty is limited to ninety (90) days from your receipt of a copy of the Software. Computer programs are inherently complex, and the software may not be free of errors. The software is provided with all faults and the entire risk as to satisfactory quality, performance, accuracy and effort is with you.

10. Limitation of Liability. Globalscape is not liable to you for any consequential, special, incidental, or indirect damages of any kind arising out of the delivery, performance, or use of the Software, even if Globalscape has been advised of the possibility of such damages. Unless applicable law provides otherwise, Globalscape's liability for any claim related to your purchase of a license for or use of the Software, whether in contract, tort, or any other theory of liability will not exceed the greater of U.S. $5.00 or the license fee paid by you.
11. U.S. GOVERNMENT. The Software is commercial computer software developed solely at private expense. The rights of civilian and non-civilian agencies of the U.S. Government to use, disclose and reproduce the Software are governed by the terms of this License. Publisher is GlobalSCAPE, Inc., 4500 Lockhill-Selma Road, Suite 150, San Antonio, Texas, 78249, USA.

12. SECURITY. You agree that Globalscape is not liable to you for security breaches resulting from your use of the Software. The security of the Software depends primarily on you selecting a secure password and keeping it confidential. You should not select a password that may be easily discovered by others. For example, you should not use a word or sequential series of numbers. We recommend a random choice of at least 6 mixed alpha and numeric characters, with variations between upper and lower case.

13. AUDIT. You agree that on Globalscape's request you will certify in writing your compliance with the terms of this license, including your use of the Software only on the number of computers/servers licensed.

14. MISCELLANEOUS. This license is governed by the laws of the State of Texas, U.S.A. This license is not governed by the United Nations Convention of Contracts for the International Sale of Goods. You agree to submit to the jurisdiction of courts sitting in the State of Texas for all purposes. Sole and exclusive venue for any dispute arising under or relating to this agreement shall be in a court sitting in Bexar County, San Antonio, Texas. This license constitutes the complete and exclusive agreement between us, notwithstanding any provision in any purchase order or other written document, except for the definition of any evaluation period or limited term license appearing on the Web or other documentation accompanying the license and the statement of the number of separate user license fees for which you have paid as described in Section 2, above. This license may only be modified by a written document signed by Globalscape. No Globalscape dealer or distributor is authorized to change the terms of this license. If any provision of this license is held to be unenforceable, the remainder of the license shall not be affected, and the unenforceable provision shall be reformed to the extent necessary to make the provision enforceable.

If you are located outside the United States, then the following provision applies:

Les parties aux présentés conferment leur volonté que cette convention de même que tous les documents y compris tout avis qui SHY rattaché, soient redigés en langue anglaise. (Translation: "The parties confirm that this Agreement and all related documentation is and will be in the English language.")

Should you have any questions concerning this license, or if you desire to contact Globalscape for any reason, please contact Globalscape by mail at: 4500 Lockhill-Selma Road, Suite 150, San Antonio, Texas, 78249, USA, by telephone at: (210) 308-8267, or by electronic mail from: http://support.Globalscape.com.

Registration and Trademarks

Copyright © 1996-2012 GlobalSCAPE, Inc. All rights reserved. CuteFTP and Globalscape are registered trademarks of Globalscape, Inc. The CuteFTP and Globalscape logos are trademarks of Globalscape, Inc.

This program includes software libraries licensed from 3rd parties. Refer to 3rd-Party License Agreements for details.
3rd-Party License Agreements

CuteFTP uses various 3rd-party libraries under the following license agreements:

- [OpenSSL](https://www.openssl.org) license
- [7zip](https://7zip.org) license
- [Zlib](https://zlib.net) license
- [log4cpp](http://log4cpp.org) license
- [pugixml](https://pugixml.org) license
- [Veridis](https://veridis.com) license
### Index

#### 3
- 3rd-Party License Agreements..............................268

#### A
- About the Transfer Engine........................................185
- Accepting Server SSL Certificates.............................103
- add to queue ..................................................127
- Adding a Site to the Site Manager..............................62
- Adding counters and other utilities..........................183
- Adding Custom Commands.......................................146
- Adding CuteFTP to the Windows Explorer Right-Click Menu........................53
- advanced search..............................................153
- ASCII Transfer options.........................................141
- Authenticating in SSH2.........................................109

#### B
- Backing up Local Files to Remote Host......................159
- Backing Up Remote Folders.....................................165
- Backing Up Site Configurations...............................19
- Basic HTML Tags..................................................176

#### C
- Cannot Close Data Transfer Gracefully.....................245
- Cannot Connect from Windows................................259
- Cannot Connect to Server......................................245
- Cannot Create Multiple Connections to the Same Server........................................246
- Cannot Download Executable Files..........................247
- Cannot Download Files from a VMS Server ................247
- Cannot Initiate Data Transfer..................................247
- Cannot Resolve Host Name.....................................248
- Cannot See Remote Files or Folders........................248
- Cascading Style Sheets (CSS)..................................248
- Certificate.........................................................99
- Changing a Site’s Connection Settings or Login Information..................................................86
- Changing File and Folder Permissions.........................155
- Changing the Data Connection Type..........................87
- Changing the FTP Port ............................................65
- Child Transfer Failed..........................................250
- Choosing a Certificate for SSL Sessions.....................103
- Closing an HTML Document.....................................182
- Comparing Folders by Case, Size and Date..................156
- Compressing and Decompressing............................144
- Configuring Options for Completed Transfers................131
- Configuring Prompts.............................................53
- Confirm Passphrase..............................................99
- Connecting after a 425 Error..................................250
- Connecting to a Site.............................................59
- Connecting to an HTTP Site......................................66
- Connecting to Secure Shell (SSH2) Sites......................71
- Connecting to Secure Sites.....................................68
- Connecting to Secure Socket Layer (SSL) Sites...............69
- Connecting to Sites..............................................59
- Connection Options.............................................63
- Copy and Paste removes files from the remote folder................................................250
- Correcting Times for Sites in Different Time Zones..............................250
- Create Certificate...............................................99
- Creating a New HTML Document...............................174
- Creating and Using Bookmarks...............................91
- Creating Scripts..................................................194
- Creating SSH2 Key Pairs.......................................111
- Creating SSL Certificates......................................100
- CuteFTP Toolbar..................................................30
- F
- Failed to Establish Data Socket...............................251
- File and Folder Properties.....................................47
- Filtering Transfers.............................................49
- Finding a Site in the Site Manager............................91
- Finding and Replacing Text in HTML Documents..............174
- Finding Files and Folders.....................................153
- Finding Information in the Help..............................262
- Firewall and Anti-Virus (AV) Problems.......................245
- FTP error numbers............................................251
- FTP error numbers............................................251
- FTP error numbers............................................251

---

269
Restoring Local Files Backed Up to Remote Host .................................................................163
Resuming Transfers ..............................................132
Right-click shell Integration ........................................126
Running Scripts ..................................................193
Running the Transfer Engine from a SQL Job .................................................................241
Running the Transfer Engine without a User Present ..................................................240
Saving an HTML Document .................................................180
Saving and Reusing a List of Transfer Tasks .................................147
Scheduling Scripts from the Windows Scheduled Tasks Folder ........................................239
Scheduling Scripts with the Windows NT4 AT Scheduler ..............................................240
Scheduling Transfers ................................................136
search .....................................................................153
Secure Connections ......................................................107
Secure Site-to-Site Transfers using SSCN ..............................................105
Selecting a Group of Items ..................................................154
SFTP .....................................................................110
SFTP error ..................................................................115
SFTP Errors ..............................................................115
Shell cannot get Data from TE ................................................253
Site Properties - Actions Tab ..............................................44
Site Properties - General Tab ..............................................43
Site Properties - Options Tab ..............................................46
Site Properties - Type Tab ..................................................45
Site-to-Site Transfer Limitations .............................................254
Site-to-Site Transfers ....................................................137, 222
Smart Keep Alive Options ..................................................75
Smart Overwrite Settings ...................................................120
smart sorting .................................................................51
socket error ..................................................................254
Socket Errors ..............................................................254
Socks 4 and 5 Connection Settings ..............................................76
sorting ........................................................................51
Sound options ................................................................54
Specifying a Default Download Folder ..............................................123
Specifying HTML Tags to Use for a Specific Browser ....................................................172
Specifying the Folder for Storing HTML Code Snippets and Java Scripts ..................................................173
Specifying Time CuteFTP Waits after a Transfer Completes .............................................132
Specifying Whether to Save a Site’s Information
   - Caching ..........................................................89
   SSH ......................................................................110
   SSH2 (SFTP2) Security Settings ..............................................110
   SSL Security Settings ..................................................99
Starting the Transfer Engine on Windows Startup ......................................................119
Startup Options ..............................................................119
Staying Connected to Sites ..................................................75
Stopping Transfers ....................................................129
Storing and Modifying Sites ..............................................85
suspend ........................................................................127
Symbolic Link Options ...................................................124
Synchronizing Folders Using the Folder Synchronization Wizard ........................................157
System requirements ........................................................17
T
TappIn Integration ......................................................79
TappIn™ Site Creation ..................................................79
Thumbnail Views ..........................................................50
time stamp .....................................................................54
timestamp ........................................................................54
TOC File Settings .....................................................130
Tolerance Options .......................................................128
Transfer Engine .........................................................185
Transfer Engine (TE) Initial Setup ........................................187
Transfer Settings ..........................................................117
Transferring Files and Folders ................................................117
Transferring Files in Binary or ASCII Mode .............................................141
Transferring Files in Order ..................................................127
Transferring Files or Sites with the Transfer Engine ......................................................193
Transferring Manually ......................................................149
Transferring to Case-Sensitive Servers .............................................256
Troubleshooting ..............................................................245
Troubleshooting SFTP Connections .............................................114
Troubleshooting SSL Connections .............................................105
Troubleshooting TE Problems ................................................243
Troubleshooting Tips .......................................................256
Truncated Listings .........................................................257
Trusted Certificates .........................................................99
Trusted List .................................................................99
U
Unable to Connect to Titan FTP Server when
   Using SSL ..........................................................106
Unicode Support in CuteFTP .............................................150
Updating or Refreshing Folder Listings .............................................152
Upgrading CuteFTP .......................................................20
Upload Filtered ............................................................149
Upload/Download Filtered Files ...............................................149
Uploading and Downloading Files Using
   OpenPGP Keys ..........................................................96
Uploading Files from Anywhere in Windows .............................................126
Using a Clear Command Channel with SSL .............................................105
Using a Clear Data Channel with SSL .............................................104
Using a Script to Connect with a Remote Site .............................................238
Using a Script to Download a file ..................................................238
Using Colors ..........................................................179
Using CuteFTP behind a Router ..................................................257
Using CuteFTP with Norton Internet Security
   2004 ..................................................................258
Using Error Messages to Troubleshoot .......258
Using Quick Connect .................................134
Using Scripts to Transfer Files....................145
Using SSH2 Key Pairs ...............................113
Using the ACCT Command ..........................73
Using the Clipboard to Transfer ..................135
Using the Connection Wizard ......................60
Using the Knowledge Base ..........................264

V
Verifying Integrity of Transferred Files .......142
Viewing Document Information ..................175
Viewing Transfer Status ............................134

W
webdav ..................................................83
What's New? .............................................16
Wildcard masks .......................................155
  Socket Errors .......................................254