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Using PureCMS 

Working with Pages 

Opening a Web page 

To open a Web page from the Start Page 

1. Open PureCMS. 

2. In the Start Page, click Edit pages directly from your web site. 

3. Click links to open the page you want. 

4. Scroll down to the bottom of the page and click the Direct Edit link. The default Direct Edit 
link is GS. 

5. The page opens in the Edit Region View. 

6. Click on an Edit button, or from the menu, choose Page > Edit Page. 

7. The area or page you are modifying opens in the Editor.  
 

To open a Web page from the Site Manager 

1. From the Start Page menu bar, click View > Go to > Site Manager. 
2. In the right panel, click on a page. 
3. In the menu bar click File > Open Page. 

4. The page opens in the Edit Region View. 

5. Click on an Edit button, or from the menu, choose Page > Edit Page. 

6. The area or page you are modifying opens in the Editor.  
 

To open a Web page with Direct Edit 

1. In your Web browser, navigate to the page on the Staging Server. 

2. Scroll down to the bottom of the page and click the Direct Edit link. The default Direct Edit 
link is GS. 

3. Enter your Username and Password. 

4. Click Log In. 

5. The page opens in the Edit Region View. 

6. Click on an Edit button, or from the menu, choose Page > Edit Page. 

7. The area or page you are modifying opens in the Editor.  
 

 

Related topics 

Creating a new Web page 

Editing a Web page 

Saving a Web page 
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Creating a new Web page 

To create a new Web page based on an existing page 

1. Login to PureCMS. 

2. On the menu bar, choose View > Go to > Site Manager. The Site Manager window 
opens. 

3. In the left pane, select the folder where you want the new page. 
4. On the menu bar, click File > New Page. The New Page window appears. 

5. In the right panel, choose Make a copy of an existing page.   

6. In the left panel, highlight the page you want to use as a guide. You can click folders to 
display the pages within them. 

7. Type in a New page name. You do not need to type an extension (i.e. "html"). 

8. Click Ok. A message appears telling you the new page has been created. 

9. Click Ok again. The new page opens in the Edit Region View. 

 

To create a new Web page based on a template 

1. Login to PureCMS. 

2. On the menu bar, choose View > Go to > Site Manager. The Site Manager window 
opens. 

3. In the left pane, select the folder where you want the new page. 
4. In the right panel, choose Use a pre-made Template. 

5. Highlight a template in the Select a template from your site list. 

6. Type in a New page name. You do not need to type an extension (i.e. "html"). 

7. Click Ok. A message appears telling you the new page has been created. 

8. Click Ok again. The new page opens in the Edit Region View. 

 

Note 

To create a page in a subfolder, you must go to the Site Manager and click the destination folder 
before clicking File > New Page. 

 

Related topics 

Editing a Web page 

Saving changes 

Getting approval for a page 

Publishing a page 

Opening a Web page 

To open a Web page from the Start Page 

1. Open PureCMS. 
2. In the Start Page, click Edit pages directly from your web site. 

3. Click links to open the page you want. 
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4. Scroll down to the bottom of the page and click the Direct Edit link. The default Direct Edit 
link is GS. 

5. The page opens in the Edit Region View. 

6. Click on an Edit button, or from the menu, choose Page > Edit Page. 

7. The area or page you are modifying opens in the Editor.  
 

To open a Web page from the Site Manager 

1. From the Start Page menu bar, click View > Go to > Site Manager. 
2. In the right panel, click on a page. 

3. In the menu bar click File > Open Page. 

4. The page opens in the Edit Region View. 

5. Click on an Edit button, or from the menu, choose Page > Edit Page. 

6. The area or page you are modifying opens in the Editor.  
 

To open a Web page with Direct Edit 

1. In your Web browser, navigate to the page on the Staging Server. 

2. Scroll down to the bottom of the page and click the Direct Edit link. The default Direct Edit 
link is GS. 

3. Enter your Username and Password. 

4. Click Log In. 

5. The page opens in the Edit Region View. 

6. Click on an Edit button, or from the menu, choose Page > Edit Page. 

7. The area or page you are modifying opens in the Editor.  
 

 

Related topics 

Creating a new Web page 

Editing a Web page 

Saving a Web page 

Editing a Web page 

To edit a Web page 

1. Open PureCMS. 

2. On the Start Page, click Edit pages directly from your web site.  

3. Browse to the page you want to edit. 

4. Scroll to the bottom of the page and click the Direct Edit link. On the sample site, the 
Direct Edit links are GS. The page opens in the Edit Region View. 

5. Click on an Edit button to edit a specific region of the page. 

OR 

 On the menu bar click Page > Edit Page, to edit the entire page. 

6. Make desired changes. 
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7. Click Save to keep changes, click Cancel to discard changes. 

8. If you click Save or Request Approval, the Enter Notes window opens. 

9. You can type up to 256 characters to explain your changes in the Explain the changes... 
field. 

10. Click Ok. 

11. Changes will not appear on the Web until they are approved and the site is published. 

 

To edit the HTML of a Web page 

1. On the start page, click Edit pages directly from your web site.  

2. Browse to the page you want to edit. 

3. Scroll to the bottom of the page and click the Direct Edit link. On the sample site, the 
Direct Edit links are GS. 

4. Click on an Edit button to edit a specific region of the page. 

OR 

 On the menu bar click Page > Edit Page, to edit the entire page. 

5. On the menu bar click View > HTML. 

6. Make desired changes. 

7. Click Save or Request Approval and the Enter Notes window opens. 

8. You can type up to 256 characters to explain your changes in the Explain the changes... 
field. 

9. Click Ok. 

10. Changes will not appear on the Web until they are approved and the site is published. 

 

Notes 

 Depending on your permissions, you may not see the Edit Page option listed on the Page 
menu, and you may not have an HTML option on the View menu. 

 The HTML code you view through the Editor is not an exact copy of the HTML for the page 
you are editing.  PureCMS takes out extra white space like tabs, leading spaces, and trailing 
spaces so you can see more code.  PureCMS also shows full URL paths 
("http://www.myserver.com/images/nice.jpg") to links and other objects, even if they are 
entered as relative links ("images/nice.jpg"). 

 

Related topics 

Creating a new Web page 

Opening a Web page 

Adding text 

Adding images 

Adding hyperlinks 

 

Previewing a Web page 

To preview a Web page from the Site Manager 

1. From the Start Page menu bar, click View > Go to > Site Manager. 



Using PureCMS 

5 

2. Click on the page you want to preview. 

3. On the menu bar, choose File > Open. The page opens in the Edit Region View. 

4. On the menu bar, choose Page > Preview This Page. 

5. Click the X button in the upper right corner to close the preview window. 

 

To preview a Web page from the Editor 

1. If you do not have changes to save, on the menu bar, click File > Cancel and skip to step 
six. 

2. If you have changes to save, on the menu bar, click File > Save.  

3. If your changes must be approved, the Enter Notes screen appears, continue with step 
four.  

OR 

  If you do not need approval, skip to step six. 

4. In Explain the changes to..., type any information you want to keep about your changes. 

5. Click Ok. The page will be displayed in the Edit Region View.  

6. On the menu bar, click Page > Preview this page. 

7. Click the X button in the upper right corner to close the preview window. 

 

Note 

You will not be able to see pending changes other users have made unless you are a group 
leader or Webmaster. 

Viewing HTML code 

To view pages as HTML 

1. Open a page in the Editor.  
2. On the menu bar, click View > HTML. 

 

To switch back to the WYSIWIG view 

 On the menu bar, click View > Normal. 
 

 

Related topics 

Editing a Web page 

Saving changes 

Saving changes to a Web page 

1. With a page or region open in the Editor, go to the menu bar and click File > Save. 

2. If your changes require approval, the Enter Notes page appears. Type any notes about 
your changes in Explain the changes made to.... You can type up to 256 characters.  

3. Click OK. 
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Notes 

 If you have Restricted group rights (your work must be approved before publishing), other 
users will not see your changes on the Staging Server until they have been approved. 

 If your changes do not require approval, you will be returned to the Edit Region View 
immediately after clicking Save. You can still request approval while in the Editor by 
clicking File > Request Approval and following steps two and three. 

 If you have Full group rights (your work does not have to be approved before publishing), 
your changes will be available on the Staging Server immediately. 

 

Related topics 

Editing a Web page 

Changing page notes 

 

 

Sending notifications about a page 

Every time you make changes or modifications, PureCMS will automatically send notification of 
the changes to the appropriate group leader and administrators. If you need to send extra notes 
or questions about a page or other file, you can use the Send Notification tool. 

 

To send extra notifications 

1. Login to PureCMS. 

2. On the menu bar, choose View > Go to > Site Manager. 
3. Select a page or other file you want to discuss via email. 

4. On the menu bar, choose File > Send Notification. The Send Notification window 
appears. 

5. In Choose Recipient, select a user to receive the note. 

6. Click To or CC. The user appears in the To or CC box.  

7. If you want to send the note to several users, repeat steps five and six for each user. 
8. In Message, type your note concerning the page or file. 

9. Select Send a copy to myself if you want the message sent to your email box. 

10. Select Include Hyperlink in message and your message will have a link to the page or 
file discussed in the note. 

11. Click Send. The note will be sent to all the recipients you chose. The note will include 
details about the page or file, and will be marked from the email address designated for 
the account you used to log in to PureCMS.  

 

Note 

You must have access to the Site Manager to use Send Notification. Your Webmaster can give 
you access to the Site Manager. 

Changing page notes 

When you submit page changes for approval you are required to include notes before your 
changes are saved.  You can alter the notes after the changes are saved. 
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To change page notes 

1. Log in to PureCMS. 

2. On the menu bar, choose Tools > Set Page Notes. The Set Page Notes window opens 
listing notes for all changes you have submitted that are pending. 

3. Click in the Notes field for any page listed, and make any modifications. In the Notes 
field you can edit, delete, cut, copy, and paste text. 

4. Click Update. A message appears saying your notes were successfully updated. 

5. Click Ok. 

 

Related topics 

Saving changes 

Submitting changes for approval 

Adding hyperlinks 

To add a hyperlink to a page 

1. Open a page or region in the Editor. 
2. Click where you want the link. 
3. On the menu bar, click Insert > Create or Modify link. The Link window appears. 

4. In Web Address, type the address of the destination page. To link to another page on 
your site, select the page in the left pane. You can double-click folders to list their pages. 

5. In Text to Link, type the text you want as the hyperlink. 

6. If you know the name of a style you want for the link, type the name in CSS Stylesheet 
Class. You can leave Class blank. 

7. If the page has anchors, you can choose a specific anchor as the destination in the 
Anchor list. 

8. Choose where you want the destination page to appear from the Load in Window 
(target attribute) list. 

 Same Frame/Window - the destination page will appear in the same frame or 
browser window replacing the current page. 

 New Window - another browser window will open and display the destination 
page, while the current page stays open in the original window. 

 Parent Frame - the destination page will appear in the frame that referenced the 
original linking frame. 

 Whole Page - The destination page will appear in the same browser window, but 
it will fill the whole window and get rid of any previous frames. 

9. Click Update.  

 

To turn existing text into a hyperlink 

1. Open a page or edit region in the Editor. 
2. Select the text you want as a link. 

3. On the menu bar, click Insert > Create or Modify link. The Link window appears. 
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4. Type the address of the destination page in Web Address. To link to another page on 
your site, select the page in the left pane. You can double-click folders to list their pages. 

5. The text you selected will already appear in Text to Link. 

6. If you know the name of a style you want for the link, type the name in CSS Stylesheet 
Class. You can leave Class blank. 

7. If the destination page has anchors, you can choose a specific anchor as the destination 
in the Anchor list. 

8. Choose where you want the destination page to appear from the Load in Window list. 

 Same Frame/Window - the destination page will appear in the same frame or 
browser window replacing the current page. 

 New Window - another browser window will open and display the destination 
page, while the current page stays open in the original window. 

 Parent Frame - the destination page will appear in the frame that referenced the 
original linking frame. 

 Whole Page - The destination page will appear in the same browser window, but 
it will fill the whole window and get rid of any previous frames. 

9. Click Update.  

 

Submitting changes for approval 

If you have Full group rights, you can save changes without submitting them. You can also 
submit changes for approval.  If you have Restricted group rights, all your changes will be 
automatically submitted for approval.  

To have changes approved 

1. Open a page in the Editor. 
2. Make any changes. 

3. Click the Request Approval button in the lower right. The Enter Notes page opens. 

4. Type any information the group leader needs in Explain the changes made to.... You 
can enter up to 256 characters. 

5. Click Ok.  Your notes and changes are submitted to the group leader or Webmaster, who 
will receive an email announcing your changes. 

 

Notes 

 You will be able to see your changes in the Edit Region View even if the changes have 
not been approved. Other users will not see the changes until they are approved. 

 Group leaders and webmasters decide which users have Restricted group rights and 
which have Full group rights. 

 

To approve changes 

1. Log in to PureCMS as a Webmaster or another administrator.  

2. On the menu bar, click View > Pending Changes. 

3. In Pending Changes, click Approve next to the file name of the changed page. 
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Note 

To approve changes, you must be the webmaster or leader for the group that owns the changed 
page. 

 

Related topics 

Editing a Web page 

Publishing changes 

Publishing a Web page 

Viewing and approving changes 

Changing page notes 

Finding files and text 

To find a file or folder by name 

1. Click Edit > Search in the Site Manager menu or the Start Page menu. 

2. In Search for files and folders named, type the text you want to find. 

3. Click the folder where you want to search. 

4. Click the Search Now button. All files and folders with the name will be listed in the right 
pane. 

 

To find specific text 

1. In the Site Manager menu or the Start Page menu, click Edit > Search. 

2. In Search for this text in all files, type the text you want to find. 

3. Click the folder where you want to search. 
4. Click the Search Now button. All files with the text will be listed in the right pane. 

 

Notes 

 Search results will include all word forms, and words that include your search text.  For 
example if you search for "bar", the search will return files with "Bar", "bartender", "bars", 
and "rebar". 

 We suggest you use the two search methods independently. If you enter text in both 
Search for files and folders named and Search for this text in all files at the same 
time, the Search will look for files with both the name AND the text you designated.  

 

Related topics 

Finding and replacing text 

Working with Text 

Check spelling 

To check spelling in a Web page 

1. Open a page or edit region in the Editor. 
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2. On the menu bar, click Edit > Check Spelling. The Check Spelling box opens and the 
spelling check begins automatically. Misspelled words appear in the Not in Dictionary 
box. Possible correct spellings appear in the Suggestions list. 

3. Highlight a suggested replacement or type the correct spelling in Replace with. 

4. Click Replace. 

5. Click Ignore to pass over a word. 

6. Click Done or Cancel to close the Check Spelling box. 

 

 

 

Finding and replacing text 

To search for text and then replace it 

1. Click Edit > Replace in the Site Manager menu or the Start Page menu. The Search 
and Replace window opens. 

2. In the left pane, select the page or pages you want to search.  Click folders to see the 
pages they contain. 

3. Type the text you want to find in Search For. 
4. Type the new text in Replace With. 

5. Clear the Match Case text box to search for all occurrences of the text. Select the Match 
Case box to search only for occurrences that have the same letters in upper or lower 
case. 

6. Choose Entire File to look for your target text in the page's regular text and the page's 
HTML tags. Choose Text Only and the search will ignore the HTML tags. 

7. Choose For the selected page(s) only..., and the search will only look in the files you 
highlighted. Choose For entire site and the search will look through every file for the 
target text. 

8. Click Ok, and your replacement text will be substituted for the target text in every file 
selected. 

 

Warning: You will not have the option to approve or deny individual changes. Every instance of 
the text will be replaced, even if the text occurs within a larger word.  For example, if you Search 
for 'bar' and replace it with 'pipe', every instance of 'bar' would become 'pipe', 'bartender' would 
also become 'pipetender', and 'rebar' would be changed to 'repipe'. 

 

Related topics 

Finding files and text 

Finding and replacing text in a single page 

To find and replace text 

1. Open a page or edit region in the Editor. 
2. On the menu bar, choose Edit > Find/Replace. The Find/Replace window appears. 

3. In Find what, type the text you want to find. 

4. In Replace with, type the text you want in its place. 

5. Click Find Next. The Editor selects the first occurrence of the word. 
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6. Click Replace to change the word that was found. Click Replace All to change every 
occurrence of the word in the page. 

7. When you have finished your search, click the close button in the upper right corner of 
the Find/Replace window. 

 

Notes 

 Select Match case, to search only for occurrences of the word that have the same 
capitalization as the word you typed in Find what. 

 Select Match whole word only to search for stand-alone occurrences of the word. For 
example, if you want to find the word 'bar', but do not want to find 'bartender', 'rebar', or 
'hyperbaric'  select this check box. 

Adding text 

To add Web page text  

1. Open a page or edit region in the Editor. 
2. Click where you want to add text.  

3. Begin typing.  

4. Click Save to keep changes, click Cancel to discard changes. 

 

To edit Web page text 

1. Open a page or edit region in the Editor. 
2. Select the text you want to change.  

3. Type the new text.  

4. Click Save to keep changes, click Cancel to discard changes. 

 

Notes 

 You can reject small changes before cancelling or saving by clicking Edit > Undo on the 
menu bar.  You can reverse Undo's by clicking Edit > Redo. 

 Unless you have Webmaster, or publishing privileges, when you click Save your changes 
will be submitted for approval. The changes will only be visible to you and the approving 
administrator until they are approved. 

Working with Tables 

Working with tables 

To change an existing table 

1. Open a page or region in the Editor. 
2. Click in the table. 

3. On the tool bar, click the Table button. 

 Choose Insert Table to embed a new table. 

 Choose Modify Table Properties to modify the current table. 
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 Choose Modify Cell Properties to modify the current cell. 

 Choose to insert rows or columns. 

 Choose to delete rows or columns. 

 Choose to increase or decrease column span. 

 

To delete a table 

1. Open a page or region in the Editor. 
2. Click on the edge of the table you want to delete. 

3. Press the Delete key on your keyboard. 

 

To insert a table 

1. Open a page or region in the Editor. 
2. Click where you want the table. 

3. On the tool bar, click the Table button. 
4. Choose Insert Table. The Insert Table window appears. 

5. Choose from the following settings. 

 Rows - Enter any number of rows for your table. The more rows you add, the longer your 
table will be. Rows will also become taller if you hit the Enter key while the mouse cursor 
is in a row.  

 Columns - Enter any number of columns for your table.  The more columns you add the 
wider your table will be.  The columns will also widen as you type in text or add graphics. 

 Cell Padding - Enter a number that will set a margin inside the cells. For example, if you 
enter 5, then any text within cells will stay at least five pixels from all cell borders. 

 Cell Spacing - Enter a number that will set the space between cells. For example, if you 
put cell spacing at 5, then you would see a five pixel gap between cells.  

 Width - Enter a number to set a width that applies to the whole table. 

o Enter just a number and the table width will stay the same, regardless of the 
width of a viewer's browser window. 

o Enter a number followed by a percent sign and the table width will adjust to 
remain a set percentage of the entire browser window width. 

 Height - Enter a number to set a height that applies to the whole table. 

o Enter just a number and the table height will stay the same, regardless of the 
height of a viewer's browser window. 

o Enter a number followed by a percent sign and the table height will adjust to 
remain a set percentage of the entire browser window height. 

 Background Color - If you want the table to have a background color different from the 
page background, choose a color from this list. 

 Border  - Enter a number for how wide you want the table's borders.  The size is in 
pixels.   

6. Click Insert Table. 

 

To modify a table 
1. Open a page or region in the Editor. 
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2. Click in the table. 

3. On the tool bar, click the Table button. 

4. Choose Modify Table Properties. The Modify Table Properties window appears.  

5. Choose from the following settings. 

 Background Color - If you want the table to have a background color different from the 
page background, select a color from this list. 

 Border - Enter a number for how wide you want the tables borders.  The size is in pixels. 
  

 Cell Padding - Enter a number that will set a margin inside the cells. If you enter 5, then 
any text within cells will stay at least five pixels from all cell borders. 

 Cell Spacing - Enter a number that will set the space between cells. If you have a 
colored border and cell spacing is 5, then you would see a five pixel gap between cells.  

 Width - Enter a number to set a width that applies to the whole table. 

o Enter just a number and the table width will stay the same, regardless of the 
width of a viewer's browser window. 

o Enter a number followed by a percent sign and the table width will adjust to 
remain a set percentage of the entire browser window width. 

 Height - Enter a number to set a height that applies to the whole table. 

o Enter a just number and the table height will stay the same, regardless of the 
height of a viewer's browser window. 

o Enter a number followed by a percent sign and the table height will adjust to 
remain a set percentage of the entire browser window height. 

6. Click Modify Table Properties. 

 

To edit cell properties 

1. Open a page or region in the Editor. 
2. Click in the cell. 

3. On the tool bar, click the Table button. 

4. Choose Modify Cell Properties. The Modify Cell Properties window appears. 

5. Choose from the following settings. 

 Cell Background Color - If you want the cell to have its own background color, choose a 
color from this list. 

 Cell Width - Enter a number to set the cell's width. Every cell in the same column will be 
that width. 

 Cell Height - Enter a number to set the cells's height. Every cell in the same row will be 
the same height. 

 Horizontal Align - Choose to display text on the Left side, in the Center, or on the Right 
side of the cell.   

 Vertical Align - Choose to display text at the Top, in the Middle, or on the Bottom of the 
cell.   

 Insert Row 
o Above - Create one new row above the current row.  

o Below - Create one new row below the current row.  

 Insert Column 
o to the Left - Create one new column to the left of the current column. 
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o to the Right - Create one new column to the right of the current column. 

 Delete 
o Delete Row - Remove the current row and all its text and graphics. 

o Delete Column - Remove the current column and all its text and graphics.  

o Delete Cell - Erase the current cell and all its text and graphics. 

 Span 
o Columns Span - Merge the current cell with the cell to its right. So you have one 

cell spanning two columns.  

o Rows Span - Merge the current cell with the cell beneath it. So you have one cell 
spanning two rows. 

Tips - If creating a span adds an extra cell to your table, simply click in the extra 
cell, choose Table > Edit Cell, and click the Delete Cell button. If you want to span 
more than two cells, you will have to edit the table in HTML view, and you will have 
to delete more cells. 

6. Click Modify Cell Properties. 

 

 

 

Editing a table 

To edit a table 
1. Open a page or region in the Editor. 
2. Click anywhere inside the table. 

3. On the tool bar, click the Table Functions button.  

4. Choose Modify Table Properties. The Modify Table Properties window appears. 

5. Make any desired changes. For more information see Working with tables. 

6. Click Ok. 

 

Related topics 

Changing table background color 

Changing table borders 

Hiding table borders 

Changing table size 

Changing margins in cells 

Changing border size between cells 

Editing a table cell 

To edit a cell 

1. Open a page or region in the Editor. 
2. Click inside the cell you want to edit. 

3. On the tool bar, click the Table Functions button.  

4. Choose Modify Cell Properties.  The Modify Cell Properties window appears. 

5. Make any desired changes. For more information see Working with tables. 

6. Click Ok. 
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Related topics 

Changing a cell's background color 

Changing the position of cell contents 

Controlling column width 

Controlling row height 

Combining table cells 

Splitting table cells 

Deleting a table 

To delete a table from a page 

1. Open a page or region in the Editor. 
2. Move the mouse cursor over the edge of the table until it becomes a black, four-headed 

arrow. 

3. Click the edge of the table. White squares will appear at each corner and on each side of 
the table. 

4. Press the Delete key on your keyboard. 

Changing a table background color 

To change a table's background color 

1. Open a page or region in the Editor. 
2. Click in a table. 

3. On the tool bar, click the Table Functions button  .   

4. Choose Modify Table Properties, The Modify Table Properties window appears. 

5. In the Background Color list, choose the color you want. 

6. Click Modify Table Properties. 

 

Changing a table border 

To change a table's border 

1. Open a page or region in the Editor. 
2. Click in a table. 

3. On the tool bar, click the Table Functions button  .   

4. Choose Modify Table Properties, The Modify Table Properties window appears. 

5. In the Border box, enter the border width you want. The number represents the width in 
pixels. You can enter any whole number between 0 and 99. If you enter 0, the outside 
border and all cell borders will be invisible when the page is published or previewed. 

6. Click Modify Table Properties. 

 

Hiding table borders 
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To hide table borders 

1. Open a page or region in the Editor. 
2. Click in a table. 

3. On the tool bar, click the Table Functions button  .   

4. Choose Modify Table Properties, The Modify Table Properties window appears. 

5. In the Border box, type 0.  

6. Click Modify Table Properties. The outside border and all cell borders will be invisible 
when the page is published or previewed. 

Changing table size 

To change a table's size 

1. Open a page or region in the Editor. 
2. Click in a table. 

3. On the tool bar, click the Table Functions button  .   

4. Choose Modify Table Properties, The Modify Table Properties window appears. 

5. In the Width box, type a number. If you leave the percent sign, the width will be a 
percentage of the page width (relative width). If you delete the percent sign, the width will 
be measured in pixels (absolute width). 

6. In the Height box, type a number. If you leave the percent sign, the height will be a 
percentage of the page height (relative height). If you delete the percent sign, the height 
will be measured in pixels (absolute height). The height will automatically adjust to make 
room for additional text. 

7. Click Modify Table Properties. 

Changing margins in table cells 

To change margins in table cells 

1. Open a page or region in the Editor. 
2. Click in a table. 

3. On the tool bar, click the Table Functions button  .   

4. Choose Modify Table Properties, The Modify Table Properties window appears. 

5. In the Cell Padding box, enter a number. The number represents the space, in pixels 
between the cell edges and anything inside the cell. You can enter any whole number 
between 0 and 99.  

6. Click Modify Table Properties. 

Changing border size between table cells 

To change margins in table cells 

1. Open a page or region in the Editor. 
2. Click in a table. 

3. On the tool bar, click the Table Functions button  .   

4. Choose Modify Table Properties, The Modify Table Properties window appears. 

5. In the Cell Spacing box, enter a number. The number represents the width, in pixels, 
between cells. You can enter any whole number between 0 and 99.  
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6. Click Modify Table Properties. 

Changing a table cell's background color 

To change a table cell's background color 

1. Open a page or region in the Editor. 
2. Click in a table cell. 

3. On the tool bar, click the Table Functions button  .   

4. Choose Modify Cell Properties, The Modify Cell Properties window appears. 

5. In the Background Color list, choose the color you want.  

6. Click Modify Cell Properties.  

Changing the position of cell contents 

To change the position of cell contents 

1. Open a page or region in the Editor. 
2. Click in a cell. 

3. On the tool bar, click the Table Functions button  .   

4. Choose Modify Cell Properties, The Modify Cell Properties window appears. 

5. In the Horizontal Align list, choose None, Left, Center or Right. Choosing None or Left 
will both align the cell contents to the Left cell border. 

6. In the Vertical Align list, choose None, Top, Middle or Bottom. Choosing None or 
Middle will both align the cell contents halfway between the top and the bottom. 

7. Click Modify Cell Properties.  

Controlling table column width 

To set column width 

1. Open a page or region in the Editor. 
2. Click in a cell. 

3. On the tool bar, click the Table Functions button  .   

4. Choose Modify Cell Properties, The Modify Cell Properties window appears. 

5. In Cell Width, enter a number, the number signifies the width in pixels.  

6. Click Modify Cell Properties. All cells in the same column will adjust to the width you 
chose. 

Controlling table row height 

To set row height 

1. Open a page or region in the Editor. 
2. Click in a cell. 

3. On the tool bar, click the Table Functions button  .   

4. Choose Modify Cell Properties, The Modify Cell Properties window appears. 

5. In Cell Height, enter a number, the number signifies the height in pixels.  

6. Click Modify Cell Properties. All cells in the same row will adjust to the same height. 
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Note 

If you add content that requires more room in the cell, the row will automatically grow taller to fit 
the content, even beyond the height you chose.  

Adding table columns and rows 

To add a column to a table 

1. Open a page or region in the Editor. 
2. Click in a cell. 

3. On the tool bar, click the Table button  .   

4. Choose Insert Column to the Right, or choose Insert Column to the Left. A new 
column appears in your table to the left or right of the cell where you clicked. 

 

To add a row to a table 
1. Open a page or region in the Editor. 
2. Click in a cell. 

3. On the tool bar, click the Table button  .   

4. Choose Insert Row Above, or choose Insert Row Below. A new row appears in your 
table above or below the cell where you clicked. 

 

Removing table columns and rows 

To remove a column from a table 
1. Open a page or region in the Editor. 
2. Click in a cell. 

3. On the tool bar, click the Table Functions button  .   

4. Choose Delete Column. The column where you clicked is removed. 

 

To remove a row from a table 

1. Open a page or region in the Editor. 
2. Click in a cell. 

3. On the tool bar, click the Table Functions button  .   

4. Choose Delete Row. The row where you clicked is removed. 

Combining table cells 

To merge two cells 

1. Open a page or region in the Editor. 
2. Click in a table cell. 

3. On the tool bar, click the Table Functions button  .   

4. Choose Increase Column Span. The cell you clicked and the cell to its right are joined 
together. 

Splitting table cells 
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To split one cell into two 

1. Open a page or region in the Editor. 
2. Click in a table cell that spans more than one column. 

3. On the tool bar, click the Table Functions button  .   

4. Choose Decrease Column Span. The cell you clicked will be split into two separate 
cells. 

 

Note 

You can only split a cell if it is wider than a single column.  

Adding a table 

To add a table to a page 

1. Open a page or region in the Editor. 
2. Click where you want your table to start. 

3. On the tool bar, click the Table button  .   

4. Choose Insert Table. 

5. The Insert Table window appears. 

6. Type in the number of Rows. 

7. Enter a number for Cell Padding. This is the size, in pixels, of the internal margins of all 
cells in the table. 

8. Type in the number of Columns. 

9. Enter a number for Cell Spacing. This is the amount of space, in pixels, between table 
cells. 

10. Type in a Width. If you leave the percent sign, the width will be a percentage of the page 
width (relative width). If you delete the percent sign, the width will be measured in pixels 
(absolute width). 

11. Leave Height blank, and the table will adjust it's height to as you add contents. You can 
enter defined values for Height in the same way as you would for Width. 

12. In the Background Color list, choose a color for the table background. If you leave this 
at None, the page background will "show through" the table. 

13. In Border, type a number for the width, in pixels, of the table's outside border. 

14. Click OK.  

 

To delete a table from a page 

1. Open a page or region in the Editor. 
2. Move the mouse cursor over the edge of the table until it becomes a black, four-headed 

arrow. 

3. Click the edge of the table. White squares will appear at each corner and on each side of 
the table. 

4. Press the Delete key on your keyboard. 

 

To edit a table 

1. Open a page or region in the Editor. 
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2. Click anywhere inside the table. 

3. On the tool bar, click the Table button.  

4. Choose Modify Table Properties. The Modify Table Properties window appears. 

5. Make any desired changes. For more information see Working with tables. 

6. Click Ok. 

 

To edit a cell 

1. Open a page or region in the Editor. 
2. Click inside the cell you want to edit. 
3. On the tool bar, click the Table button.  

4. Choose Modify Cell Properties.  The Modify Cell Properties window appears. 

5. Make any desired changes. For more information see Working with tables. 

6. Click Ok. 

 

Related topics 

Working with tables 

Working with Forms 

Working with forms 

To add a form to a page 

1. Open a page in the Editor. 

2. On the tool bar, click the Form button.  

3. Choose Insert Form. The Insert Form window appears. 

4. Enter a Name for your form. 

5. In the Action box, enter the command or script that will process the information in the 
form when a page visitor submits the form. 

6. In the Method list, choose a Post or a Get method. 

7. Click Insert Form. A red broken-line box appears in your page where you can add form 
boxes, buttons, and fields. 

 

To edit a form 

1. Open a page in the Editor. 
2. Click in the form 
3. On the tool bar, click the Form button. 

4. Choose Modify Form Properties. The Modify Form Properties window appears. 

5. Make your desired changes. 

6. Click Modify Form Properties. 

 

To remove a form 

1. Open a page in the Editor. 
2. Select the form and all of its contents. 
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3. Press Delete on your keyboard. 

Adding an input field to a form 

To place an input field on a Web page 

1. Open a page or region in the Editor. 
2. Insert a Form. 

3. Click in the form. 

4. On the menu bar, click the Form button.  

5. Choose Insert/Modify Text field. The Insert Text Field window opens. 

6. In Name, type a name for the field, this name will not be visible to page visitors. 

7. In Initial Value, type any text you want in the field when the visitor first opens the page. 

8. In Character Width, enter a number. This represents how many characters will fit in the 
visible part of the field.  If page visitors type more characters, this number may limit what 
they see in the field. 

9. In Maximum Characters, enter the largest number of characters a visitor will be able to 
type into the field. If this number is larger than Character Width, page visitors may not be 
able to see everything that they typed. This number will truncate any entries that exceed 
the maximum. 

10. In Type, choose Text or Password. If you choose Password, when a visitor enters 
information, all the information will display as asterisks. 

11. Click Insert Text Field. 

Changing an input field 

To change a text input box 

1. Open a page or region in the Editor. 
2. Click the field you want to modify. Eight small white squares should surround the field. 

3. On the menu bar, click the Form button.  

4. Choose Insert/Modify Text field. The Modify Text Field window opens. 

5. Make any of the following changes; 

 Name: The name for the field. This name will not be visible to page visitors. 

 Initial Value: the text you want the visitor to see in the field when the page first 
opens. 

 Character Width:  This number represents how long the field will be on the page, 
and the maximum number of characters that can be seen in the field. 

 Maximum Characters: The largest number of characters a visitor will be able to type 
into the field.  

 Type: Choose Text or Password. If you choose Password, when a visitor enters 
information, all the information will display as asterisks. If you choose Text, all 
characters will appear normally. 

6. Click Modify Text Field. 

 

To remove text input box from a form 

1. Open a page or region in the Editor. 
2. Click the input box you want to remove. Eight small white squares should surround it. 
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3. On your keyboard, press Delete. 

Adding a large input field 

To place a large text input field on a Web page 

1. Open a page or region in the Editor. 
2. Insert a Form. 

3. Click in the form. 

4. On the menu bar, click the Form button.  

5. Choose Insert/Modify Text Area. The Insert Text Area window opens. 

6. In Name, type a name for the field, this name will not be visible to page visitors. 

7. In Initial Value, type any text you want in the field when the visitor first opens the page. 

8. In Character Width, enter a number. This number represents how many characters you 
can fit across the input box. 

9. In Lines, enter a number. This represents the number of lines you can fit from top to 
bottom in the input box.  

10. Click Insert Text Area. 

Changing a large input field 

To change a large text input box 
1. Open a page or region in the Editor. 
2. Click the input box. Eight small white squares should surround the box. 

3. On the menu bar, click the Form button.  

4. Choose Insert/Modify Text Area. The Modify Text Area window opens. 

5. Make any of the following changes 

 Name: The name for the field, this name will not be visible to page visitors. 

 Initial Value: Text you want in the field when the visitor first opens the page. 

 Character Width: This number represents how wide the field will be on the Web 
page. 

 Lines: The height of the input box in text lines.  

6. Click Modify Text Area. 

 

To remove a large text input box from a form 

1. Open a page or region in the Editor. 
2. Click the input box you want to remove. Eight small white squares should surround it. 
3. On your keyboard, press Delete. 

Placing a hidden field on a Web page 

To place a hidden field on a Web page 

1. Open a page or region in the Editor. 
2. Insert a Form. 

3. Click in the form. 
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4. On the menu bar, click the Form button.  

5. Choose Insert/Modify Hidden Field. The Insert Hidden Field window opens. 

6. In Name, type a name for the field. 

7. In Initial Value, type any characters you want in the field. 

8. Click Insert Hidden Field. 

Changing a hidden field 

To edit a hidden field 

1. Open a page or region in the Editor. 
2. Click the hidden field you want to modify. Eight small white squares should surround the 

hidden field. 

3. On the menu bar, click the Form button.  

4. Choose Insert/Modify Hidden Field. The Modify Hidden Field window opens. 

5. In Name, make any change to the field name. 

6. In Initial Value, make any changes you want. 

7. Click Modify Hidden Field. 

 

To remove a hidden field from a form 

1. Open a page or region in the Editor. 
2. Click the field you want to remove. Eight small white squares should surround the field. 

3. On your keyboard, press Delete. 

Adding a button 

To place a button on a form 

1. Open a page or region in the Editor. 
2. Insert a Form. 

3. Click in the form. 

4. On the menu bar, click the Form button.  

5. Choose Insert/Modify Button. The Insert Button window opens. 

6. In Name, type a name for the button. This name will not be visible to visitors. 

7. In Initial Value, type the text you want on the button. 

8. In the Type list, choose Submit, Reset, or Button. 

 Submit starts the action you chose for the form. 

 Reset clears the form. 

 Button puts a button in the form whose on-click action can be defined. 

9. Click Insert Button. 

Changing a button 

To modify a form button 

1. Open a page or region in the Editor. 
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2. Click the button you want to change. Eight small white squares should surround the 
button. 

3. On the menu bar, click the Form button.  

4. Choose Insert/Modify Button. The Modify Button window opens. 

5. In Name, change the name for the button. This name will not be visible to visitors. 

6. In Initial Value, change the text you want to appear on the button. 

7. In the Type list, choose Submit, Reset, or Button. 

 Submit starts the action you chose for the form. 

 Reset clears the form. 

 Button puts a button in the form whose on-click action can be defined. 

8. Click Modify Button. 

 

To remove a button from a form 

1. Open a page or region in the Editor. 
2. Click the button you want to remove. Eight small white squares should surround the 

button. 

3. On your keyboard, press Delete. 

Adding checkboxes 

To place a check box on a Web page 

1. Open a page or region in the Editor. 
2. Insert a Form. 

3. Click in the form. 

4. On the menu bar, click the Form button.  

5. Choose Insert/Modify Checkbox. The Insert Checkbox window opens. 

6. In Name, type a name for the field, this name will not be visible to page visitors. 

7. In Initial Value, type any information you want. 

8. In Initial State, choose Unchecked or Checked. This determines if the box is checked 
when the visitor first opens the page. 

9. Click Insert Checkbox. 

Modifying checkbox properties 

To modify a check box 

1. Open a page or region in the Editor. 
2. Click the checkbox. 

3. On the menu bar, click the Form button.  
4. Choose Insert/Modify Checkbox. The Modify Checkbox window opens. 

5. Make any changes to the following: 

 Name: The name for the field, this name will not be visible to page visitors. 

 Initial Value: Type any information you want. 
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 Initial State: Choose Unchecked and the box will be clear when a visitor opens the 
page. Choose Checked and the box will already be checked when the visitor first 
opens the page. 

6. Click Modify Checkbox. 

 

To remove a checkbox from a form 

1. Open a page or region in the Editor. 
2. Click the checkbox you want to remove. Eight small white squares should surround it. 

3. On your keyboard, press Delete. 

 

 

Adding radio buttons 

To place a radio button on a Web page 

1. Open a page or region in the Editor. 
2. Insert a Form. 

3. Click in the form. 

4. On the menu bar, click the Form button.  

5. Choose Insert/Modify Radio Button. The Insert Radio Button window opens. 

6. In Name, type a name for the button, this name will not be visible to page visitors. 

7. In Initial Value, type any information you want. 

8. In Initial State, choose Unchecked or Checked. This determines if the radio button is 
checked when the visitor first opens the page. 

9. Click Insert Radio Button. 

 

Note 

If you want a series of radio buttons to be mutually exclusive, each radio button in the series must 
have the same name, but they can all have different initial values. 

Changing a radio button 

To modify a radio button 

1. Open a page or region in the Editor. 
2. Click the radio button you want to modify. Eight small white squares should surround the 

radio button. 

3. On the menu bar, click the Form button.  

4. Choose Insert/Modify Radio Button. The Modify Radio Button window opens. 

5. Make changes to any of the following: 

 Name: The name for the button, this name will not be visible to page visitors. 

 Initial Value: type any information you want. 

 Initial State: Choose Unchecked and the radio button will be empty when the visitor 
first opens the page. Choose Checked and the radio button will already be checked 
when the visitor first opens the page. 

6. Click Modify Radio Button. 



PureCMS 3 User's Guide 

26 

 

Note 

If you want a series of radio buttons to be mutually exclusive, each radio button in the series must 
have the same name, but they can all have different initial values. 

 

To remove a checkbox from a form 

1. Open a page or region in the Editor. 
2. Click the radio button you want to remove. Eight small white squares should surround it. 

3. On your keyboard, press Delete. 

 

Adding a form 

To add a form to a page 

1. Open a page in the Editor. 

2. On the tool bar, click the Form button.  

3. Choose Insert Form. The Insert Form window appears. 

4. Enter a Name for your form. 

5. In the Action box, enter the command or script that will process the information in the 
form when a page visitor submits the form. 

6. In the Method list, choose a Post or a Get method. 

7. Click Insert Form. A red broken-line box appears in your page where you can add form 
boxes, buttons, and fields. 

 

To edit a form 

1. Open a page in the Editor. 
2. Click in the form 
3. On the tool bar, click the Form button. 

4. Choose Modify Form Properties. The Modify Form Properties window appears. 

5. Make your desired changes. 

6. Click Modify Form Properties. 

 

To remove a form 

1. Open a page in the Editor. 
2. Select the form and all of its contents. 

3. Press Delete on your keyboard. 

Working with Images 

Adding images 

To add an image to a Web page 

1. Open a page or region in the Editor. 
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2. Click where you want to add a graphic.   

3. On the menu bar click Insert > Image. The Image window appears. 

4. In the left pane, click on file name of the image you want. You can click a folder to see 
images within a folder. A preview of the image will appear in the top of the right pane. 

5. In Alt, type a text name for the image. 

6. In the Align list, choose how you want to align text with the image. 

7. If you want to change the size of the image, choose a new width and height for the 
graphic (measured in pixels). 

8. Choose a border width from the Border list. 

9. Enter the number of pixels of space you want on the sides of the image in Horizontal 
Spacing. 

10. Enter the number of pixels of space you want above and below the image in Vertical 
Spacing.  

11. Click Insert to add the image to the page. 

 

To add an image from your computer 

1. Open a page or region in the Editor. 
2. Click where you want to add a graphic.   

3. On the menu bar click Insert > Image. The Image window appears. 

4. In the left pane click On My Computer. The Image Upload window appears. 

5. In the left pane, click the directory where you want to save the image. 
6. In the right pane click Browse. The Choose File window opens. 

7. Navigate to the folder of the image you want. 

8. Click on the image and click Open. The Image Upload window reappears. With a 
preview of your image. 

9. Click Upload to move the image to your Web folders. The Image window reappears with 
your new image listed in the left pane. 

10. Select the image from the list in the left pane. 

11. In Alt, type a text name for the image. 

12. In the Align list, choose how you want to align text with the image. 

13. If you want to change the size of the image, choose a new width and height in pixels for 
the graphic.  You will have to find the values that keep the image in proper proportion. 

14. Choose a border width from the Border list. 

15. Enter the number of pixels of space you want on the sides of the image in Horizontal 
Spacing. 

16. Enter the number of pixels of space you want above and below the image in Vertical 
Spacing.  

17. Click Insert to add the image to your page. 

 

Related topics 

Removing an image 

Removing an image 

To remove a graphic or image 
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1. Open a page or region in the Editor. 
2. Click on the graphic or image. Six little white squares will appear around the graphic.  

3. Hit the Delete key on your keyboard.  

 

Related topics 

Adding images 

Changing Page Properties 

Changing page titles 

1. Open a page in the Edit Region View. 

2. On the menu bar, click Page > Page Properties. The Page Properties window opens. 

3. Type a new title in Page Title. 

4. Click Update. 

 

Note 

This will change the HTML title, which may or may not be visible on the Web page itself. 

Changing page backgrounds 

To use or change an image as a page background 

1. Open a page in the Edit Region View. 

2. On the menu bar, click Page > Page Properties. The Page Properties window opens. 

3. Click in the Background Image field. The Image window opens. 

4. In the left pane click a file, or click a folder, then a file in the folder.  The image is 
previewed in the right pane. 

5. Click Insert in the Image window. 

6. Click Update in the Page Properties window. 

 

To change the color of a page background 

1. Open a page in the Edit Region View. 

2. On the menu bar, click Page > Page Properties. The Page Properties window opens. 

3. Click the Color button  in the Background Color row. A color palette opens. 

4. Click the color you want. 

5. Click Update in the Page Properties window. 

 

To remove an image from a page background 

1. Open a page in the Edit Region View. 

2. On the menu bar, click Page > Page Properties. The Page Properties window opens. 

3. Click in the Background Image field. The Image window opens. 
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4. In the Source box, delete all the text. 

5. Click Insert in the Image window. 

6. Click Update in the Page Properties window. 

Changing text colors 

1. Open a page in the Edit Region View. 

2. On the menu bar, click Page > Properties. The Page Properties window opens. 

3. Click the Color button  in the Text Color row. A color palette opens. 

4. Click the color you want. 

5. Click Update in the Page Properties window. 

 

Related topics 

Changing link colors 

Changing link colors 

To change link colors 

1. Open a page in the Edit Region View. 

2. On the menu bar, click Page > Page Properties. The Page Properties window opens. 

3. Click the Color button  in the Link Color row. A color palette opens. 

4. Click the color you want. 
5. Click Update in the Page Properties window. 

 

To change active link colors 

1. Open a page in the Edit Region View. 

2. On the menu bar, click Page > Page Properties. The Page Properties window opens. 

3. Click the Color button  in the Active Links row. A color palette opens. 

4. Click the color you want. 

5. Click Update in the Page Properties window. 

 

To change visited link colors 

1. Open a page in the Edit Region View. 

2. On the menu bar, click Page > Page Properties. The Page Properties window opens. 

3. Click the Color button  in the Visited Links row. A color palette opens. 

4. Click the color you want. 

5. Click Update in the Page Properties window. 

 

Related topics 
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Changing text colors 

Changing margins 

You can set the distance between the left and top borders of the browser and your pages' 
elements. 

To change a page's left margin 

1. Open a page in the Edit Region View. 

2. On the menu bar, click Page > Page Properties. The Page Properties window opens. 

3. In Left Margin enter the margin size you want in pixels. 

4. Enter the same value in Margin Width. 

5. Click Update. 

 

To change a page's top margin 

1. Open a page in the Edit Region View. 

2. On the menu bar, click Page > Page Properties. The Page Properties window opens. 

3. In Top Margin enter the margin size you want in pixels. 

4. Enter the same value in Margin Height. 
5. Click Update. 

 

Note 

The Left Margin property and the Margin Width property create the same effect on your Web 
pages. Left Margin inserts the proper HTML tag for some browsers, and Margin Width inserts 
the proper HTML tag for other browsers. No browser will add the two values together. The Top 
Margin and Margin Height properties work the same way. 

Adding meta tags 

If your Webmaster has given you permission to change page properties, you can add and edit 
meta tags for any page on your site. PureCMS provides an interface where you can add data to 
Author, Description, Keyword, and Robots meta tags. You can also create your own meta tags. 

 

To add data to standard meta tags 

1. Log in to PureCMS. 

2. Open a page in the Edit Region view. 

3. On the menu bar, choose Page > Page Properties. The Page Properties window 
appears. 

4. Click Meta Tags. The Meta Tags window appears. Enter the data you want in the 
appropriate box.  

5. Click Ok when you have finished adding data. The Meta Tags window disappears. 

6. In the Page Properties window, click Update. The Page Properties window disappears.  

7. Close the page in the Edit Region view, or log out. The meta tag data will be published 
the next time the page is published. 
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To add custom meta tags 

1. Log in to PureCMS. 

2. Open a page in the Edit Region view. 
3. On the menu bar, choose Page > Page Properties. The Page Properties window 

appears. 

4. Click Meta Tags. The Meta Tags window appears.  

5. In the Name box type a name for the meta tag. 

6. In Value type any data you want as the meta tag's content. 

7. Click Add. Your tag appears in the Custom box. 

8. Repeat steps five through seven to create more custom meta tags. 

9. Click Ok when you have finished adding data. The Meta Tags window disappears. 

10. In the Page Properties window, click Update. The Page Properties window disappears.  

11. Close the page in the Edit Region view, or log out. The meta tag data will be published 
the next time the page is published. 

 

Related topic 

Editing meta tags 

Editing meta tags 

You can edit meta tags for any page on your site.  

 

To edit data in standard meta tags 

1. Log in to PureCMS. 

2. Open a page in the Edit Region view. 

3. On the menu bar, choose Page > Page Properties. The Page Properties window 
appears. 

4. Click Meta Tags. The Meta Tags window appears. Change or delete any data in the 
Author, Description, Keywords, or Robots box.  

5. Click Ok when you have finished changing data. The Meta Tags window disappears. 

6. In the Page Properties window, click Update. The Page Properties window disappears.  

7. Close the page in the Edit Region view, or log out. The meta tag data will be changed on 
your Web site the next time the page is published. 

 

To edit custom meta tags 

1. Log in to PureCMS. 

2. Open a page in the Edit Region view. 

3. On the menu bar, choose Page > Page Properties. The Page Properties window 
appears. 

4. Click Meta Tags. The Meta Tags window appears.  

5. In the Custom box, select the meta tag you want to change. 

6. In the Name box type any changes to the meta tag name. 

7. In Value type any changes to the data you want as the meta tag's content. 

8. Click Edit. Your changes appear in the Custom box. 

9. Repeat steps five through seven to change more custom meta tags. 

10. Click Ok when you have finished changing data. The Meta Tags window disappears. 
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11. In the Page Properties window, click Update. The Page Properties window disappears.  

12. Close the page in the Edit Region view, or log out. The meta tag data will be published 
the next time the page is published. 

 

To delete data in standard meta tags 

1. Log in to PureCMS. 

2. Open a page in the Edit Region view. 

3. On the menu bar, choose Page > Page Properties. The Page Properties window 
appears. 

4. Click Meta Tags. The Meta Tags window appears. Delete any data in the Author, 
Description, Keywords, or Robots box.  

5. Click Ok when you have finished changing data. The Meta Tags window disappears. 

6. In the Page Properties window, click Update. The Page Properties window disappears.  

7. Close the page in the Edit Region view, or log out. The meta tag data will be changed on 
your Web site the next time the page is published. 

 

To delete custom meta tags 

1. Log in to PureCMS. 

2. Open a page in the Edit Region view. 

3. On the menu bar, choose Page > Page Properties. The Page Properties window 
appears. 

4. Click Meta Tags. The Meta Tags window appears.  

5. In the Custom box, select the meta tag you want to delete. 

6. Click Delete. A message appears asking if you are sure you want to delete the meta tag. 

7. Click Yes. The meta tag disappears from the Custom box. 

8. Repeat steps five through seven to delete more custom meta tags. 
9. Click Ok when you have finished deleting tags. The Meta Tags window disappears. 

10. In the Page Properties window, click Update. The Page Properties window disappears.  

11. Close the page in the Edit Region view, or log out. The meta tags will be removed from 
the Web page the next time the page is published. 

 

Related topic 

Adding meta tags 



 

33 

Administering PureCMS 

Opening PureCMS 

To open PureCMS on the Staging Server 
1. Click the Windows Start menu. 

2. Click Programs > GlobalSCAPE > PureCMS > PureCMS Login. 

3. Enter your Username and Password. 

4. Click Log in. 

 

To open PureCMS from a Web browser 
1. Open your Web browser. 

2. Type the address for your PureCMS Staging Server in the Web browser Address field. 

3. Enter your Username, and Password. 

4. Click Log In. 

 

Managing Groups 

Creating a group 

Use groups to control who has access to specific Web pages in PureCMS 

 

To create a group 

1. Log in to PureCMS with your Webmaster or another administrator account. 

2. On the menu bar, click Tools > Admin Options > Create a New Group. The New 
Group window opens. 

3. In Group Name, type any name you want for the group. 

4. In Group Leader, choose your user name, or choose another administrator if you want 
someone else to be in charge of the group. 

5. Choose a Default access level for group users. 

 Full Access - Users in the group can create new pages, edit pages, and publish 
pages without approval. 

 Restricted Access - Users must submit pages and modifications for approval before 
publishing.  This setting is recommended. 

6. Select Group Members by clicking users in the list.  You can select several users at 
once by holding down the Ctrl key on your keyboard while you click. 

7. Click OK. The group is created and the Modify Group File Ownership page opens. 

8. Choose Give the group ownership of selected files, to assign only some of the site 
pages and folders to the group. Continue with step two. 

Or 

 Choose Give the group ownership of all files on the site (CAREFUL), to assign all 
files and folders to the group. Skip to step four. 
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9. Click folders to see the files within them.  All files already assigned to the group will be 
highlighted. 

10. Click once on files you want to add. Click again to de-select a file. 
11. Click Finished to assign all selected files to the group.  A message appears giving the 

number of files with changed ownership. 

12. Click OK. 

 

Related topics 

Deleting a group 

Modifying a group 

To modify a group 

1. Log in to PureCMS using your Webmaster or another administrator account. 

2. On the menu bar, click Tools > Admin Options > Manage Groups. 

3. Choose the group you want to modify from Select Group. 

4. Make changes to your group. 

5. Click Ok to complete your changes, or click Cancel to erase your changes. 

 

Notes 

From the manage groups view you can: 

 Rename the group  

 Change the administrator of the group 

 Assign files and folders to the group 

 Remove users from the group 

 Change permissions for users 

 Require users to submit all changes for approval 

 Allow users to make changes without approval 

 View users recent activity 

Renaming a group 

To rename a group 

1. Log in to PureCMS using your Webmaster or another administrator account. 

2. On the menu bar, click Tools > Admin Options > Manage Groups. 

3. Choose the group you want to rename from the Select Group list. 

4. Type the new name in the Rename Current Group to box. 

5. Click OK to apply the new name, or click Cancel to revert to the old name. 

 

Related topics 

Creating a group 

Removing a group 
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Changing a group's leader 

To change the leader for a group 

1. Log in to PureCMS using your Webmaster or another administrator account. 

2. On the menu bar click Tools > Admin Options > Manage Groups. 

3. Choose the group you want to modify from the Select Group list. 

4. Choose a user or administrator from the Change Group Leader to box. 

5. Click Ok to complete the change, or click Cancel to revert to the old leader. 

 

Note 

 Every group leader can see all pending changes for your Web site. 

 Group leaders can only approve pending changes for their respective groups.  For 
example, the leader of Group1 can only approve changes to files owned by Group1.  

Assigning files and folders to a group 

To assign files and folders to a group 

1. Log in to PureCMS using your Webmaster or another administrator account. 

2. On the menu bar click Tools > Admin Options > Manage Groups. 

3. Choose the group you want to modify from the Select Group list. 

4. Under Group File Ownerships, click the Modify link. The Modify Group File 
Ownership window opens. 

5. Choose Give the group ownership of selected files, to assign only some of the site 
pages and folders to the group. Continue with step six. 

Or 

 Choose Give the group ownership of all files on the site (CAREFUL), to assign all 
files and folders to the group. Skip to step eight. 

6. Click folders to see the files within them.  Names of files already assigned to the group 
will appear in bold text. 

7. Click once on files you want to add. Click again to deselect a file. 

8. Click Finished to assign all selected files to the group.   

9. Click OK. 

 

To remove a file or folder from a group 

1. Log in to PureCMS using an administrator or Webmaster account. 

2. On the menu bar click Tools > Admin Options > Manage Groups. 

3. Follow steps 3 through 9 above to assign the files to a different group. 

 

Note 

If you give a group ownership of all files on a site, any users who are not members of that group 
will no longer have access to any files on the site. 

 

Related topics 
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Receiving notification of changes 

 

Receiving notification of changes 

PureCMS automatically sends an email to a group leader whenever a file owned by the group is 
changed.  Most changes will result in one email per file changed.  

 

Changes where one change is made to several files at once, like Search and Replace, enabling 
Direct Edit, and changes to a template or library item, will result in only one email being sent to 
the group leader.  The single email will list all the files owned by the group that were changed. 

 

To receive notification of changes to a page  

1. Make yourself a group leader of a group.  

2. Assign the page to any group where you are the group leader. 

 

Related topics 

Changing a group's leader 

Assigning files and folders to a group 

Creating a group 

 

Adding an existing user to a group 

To add an existing user to a group 

1. Log in to PureCMS using your Webmaster or another administrator account. 

2. On the menu bar, click Tools > Admin Options > Manage Groups. The Manage 
Groups window appears. 

3. In the Select Group list, select the group where you want to add the user. 

4. In the Add Member list, select the user. 

5. Click Add. The user appears in the groups member list. PureCMS gives the user the 
access level you chose as the default access level when you created the group. 

6. Click Ok to close the Manage Groups window. 

 

Related topics 

Creating a user 

Removing a user from a group 

Creating a group 

Removing a user from a group 

To remove a user from a group 

1. Log in to PureCMS using your Webmaster or another administrator account. 

2. On the menu bar, click Tools > Admin Options > Manage Groups. The Manage 
Groups window opens. 
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3. Choose the group you want to change in the Select Group list. 

4. Select the Remove box next to the user you want to delete. 

5. Click OK.  Click Cancel to keep the user in the group. 

 

Note 

Removing the user from a group will not remove the user from the system. 

 

Related topics 

Adding an existing user to a group 

Removing a user from the system 

Requiring a user to submit all changes for approval 

To require a user to submit all changes for approval 

1. Log in to PureCMS using your Webmaster or another administrator account. 

2. On the menu bar, click Tools > Admin Options > Manage Groups. 

3. Choose the group with the user you want to modify in the Select Group list. 

4. In the user's row, go to the Access Level column and click the Modify link. 

5. Click Restricted next to the user's name.   

6. Click Update. A message appears saying the access levels have been successfully 
updated. 

7. Click Ok. 

 

Related topics 

Allowing a user to make changes without approval 

Allowing a user to make changes without approval 

If users have Restricted access to group files, when they make changes to one of the groups 
owned files they have to submit the changes for approval. Giving users Full access means they 
can make changes without submitting them for approval. 

To allow a user to make changes without approval 

1. Log in to PureCMS using an account with Webmaster permissions. 

2. On the menu bar, click Tools > Admin Options > Manage Groups. The Manage 
Groups window appears. 

3. In the Select Group list,  choose the group with the user you want to modify.  

4. In the user's row, go to the Access Level column and click the Modify link. A list of 
group users and their access levels appears. 

5. Click Full next to the user's name.   

6. Click Update. A message pops up telling you access has been updated. 

7. Click Ok. You are returned to the group's administration page. 

 

Related topics 

Requiring a user to submit changes for approval 
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Allowing a user to publish a group's pages 

Publishing a group's pages 

To publish all the pages assigned to a group 

1. Login to PureCMS. 

2. On the menu bar, choose Tools > Publish > Group Publishing. The Group Publish 
window appears. 

3. Select the group with the pages you want to publish. 
4. Click Ok. A message appears saying the publication task is in progress. 

5. Click Ok again. The pages assigned to the group are published. 

 

Note 

If you see a message that says No Rights after step two, the Webmaster has not given you 
group publishing permissions. 

 

Related topic 

Allowing a user to publish group pages 

Changing a group's leader 

To change the leader for a group 

1. Log in to PureCMS using your Webmaster or another administrator account. 

2. On the menu bar click Tools > Admin Options > Manage Groups. 

3. In the Select Group list, choose the group you want to modify. 

4. In the Change Group Leader to list, select a user or administrator. 

5. Click Ok to complete the change, or click Cancel to revert to the old leader. 

 

Note 

 Every group leader can see all pending changes for your Web site. 

 Group leaders can only approve pending changes for their respective groups.  For 
example, the leader of Group1 can only approve changes to files owned by Group1.  

 

Related topics 

Receiving notification of changes 

Deleting a group 

To delete a group 

1. Log in to PureCMS using your Webmaster or another administrator account. 

2. On the menu bar, click Tools > Admin Options > Manage Groups. 

3. Choose the group you want to delete from the Select Group list. 

4. Click Delete Group. 

5. Click Yes to delete the group, or click No to keep the group. 
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Note 

Deleting a group will not delete any users. 

 

Related topics 

Creating a group 

Deleting a user from the system 

Managing Users 

Creating a user 

To add a user 

1. Log in to PureCMS using your Webmaster or another administrator account. 

2. On the menu bar, click Tools > Admin Options > Create a New User. 
3. In New Username, enter a name for the user. 

4. In User E-mail, enter the email address where the user should receive updates and 
information from PureCMS. 

5. Enter the same password in Password and Confirm Password. 

6. Choose a Preferred Language. 

7. Clear the Descriptive Message Popups checkbox only if you do not want the user to 
receive them. 

8. Choose the user's main group in Default Member of Group. 

9. Select other groups for this user in Select Groups or make the user a member of the 
same groups as an existing user by choosing Inherit same memberships as following 
user and choosing the existing user from the list.  

10. Select permissions for the user.  

11. Click OK. By default, new users have Restricted rights to all of their group's files.  

 

Notes 

 Descriptive Message Popups appear in the Edit Region view when the mouse pointer is 
placed over Edit buttons or disabled links.  

 Restricted rights to a file means if users change the file they must submit all changes for 
approval. 

  A user must have webmaster privileges to modify or create user accounts, or enable 
Direct Edit on Web pages.  

Removing a user from a site 

To remove a user 

1. Log in to PureCMS using your Webmaster or another administrator account. 

2. On the menu bar, click Tools > Admin Options > Manage Users. 

3. Choose the user you want to remove from the Select User list. 

4. Click the Delete User button located below all the permissions. 
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5. Click Yes to permanently remove the user, or click No to keep the user. 

 

Note 

 Removing a user from the site will remove the user from all groups.  

 Only the server administrator can remove a user from all sites. 

 

Related topics 

Creating a user 

Removing a user from a group 

Changing user permissions 

To change a user's permissions 

1. Log in to PureCMS with your Webmaster or another administrator account. 

2. On the menu bar click Tools > Admin Options > Manage Users. 

3. In Select User, choose the user account you wish to modify. 

4. Scroll down to view the Permissions check boxes. 

 Allow image uploading 
o Select this box and the user will be able to add images to the Staging Server.  

o Clear this box and the user will not be able to add images to the Staging Server. 

 Allow creation of new pages using the new page creator 
o Select this box and the user will be able to create new pages in PureCMS. 

o Clear this box and the user will not be able to create new pages in PureCMS. 

 Allow access to change properties (title, background color, etc.) 
o Select this box and the user will be able to access Page Properties in the Edit 

Region View, allowing changes to page properties like link colors, text colors, 
background images and background colors. 

o Clear this box and the user will not be able to change page properties from the 
Edit Region View. 

 Allow access to the Site Manager  
o Select this box to allow the user access to the Site Manager and allow the user 

to open pages from a list of files. 

o Clear this box to hide the Site Manager from the user and only allow access to 
pages through Direct Edit. 

 Allow file deleting 
o Select this box to allow the user to delete files from the Site Manager. 
o Clear this box to prohibit the user from deleting files from the Site Manager. 

 Allow cut, copy, paste and rename for files 
o Select this box to allow the user to cut, copy, paste, and rename files in the Site 

Manager. 
o Clear this box to prohibit the user from cutting, copying, pasting, and renaming 

files in the Site Manager. 

 Allow new directories 
o Select this box to allow the user to create new folders in the Site Manager. 
o Clear this box to prohibit the user from creating new folders in the Site Manager. 
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 Allow plain HTML editing 
o Select this box and the user will be able to view and modify the HTML code of an 

edit region or page from the Editor. 
o Clear this box and the user will not be able to view and modify the HTML code of 

an edit region or page from the Editor. 

 Allow file uploading 
o Select this box and the user will be able to upload files to the Staging Server. 

o Clear this box and the user will not be able to upload files to the Staging Server. 

 Allow searching files or text 
o Select this box and the user will have access to the Edit > Find feature for 

finding text or files. 

o Clear this box and the user will not have access to the Edit > Find feature for 
finding text or files. 

 Allow file modifications (Direct Edit, Statistics, Replace) 
o Select this box and the user can enable Direct Edit, statistics, and can use the 

search and replace function. 

o Clear this box and the user cannot enable Direct Edit, statistics, and cannot use 
the search and replace function. 

 Change font colors in editor 
o Select this box and the user will be able to change text colors for a page or 

region in the Editor. 
o Clear this box and the user will not be able to change text colors for a page or 

region in the Editor. 

 Allow text formatting in editor 
o Select this box and the user will be able to change font style and size for a page 

or region in the Editor. The user will have menu items and toolbar buttons for 
Font Name, Font Size, Alignment, Indent, Outdent and other formatting tools. 

o Clear this box and the user will not be able to change font style and size for a 
page or region in the Editor. The user will not have Menu items and toolbar 
buttons for Font Name, Size, Alignment, Indent, Outdent, and other formatting 
tools available when he's logged in to PureCMS. 

 Allow inserting of images in editor 
o Select this box and the user will be able to add images for a page or region in the 

Editor. 
o Clear this box and the user will not be able to add images for a page or region in 

the Editor. 

 Allow inserting tables in editor 
o Select this box and the user will be able add and modify tables in a page or 

region in the Editor. 
o Clear this box and the user will not be able add and modify tables in a page or 

region in the Editor. 

 Allow webmaster privileges  
o Select this box and the user can create, modify, and delete other user accounts. 

The user will also be able to publish the entire site, publish any group of files, 
schedule publications, access Web statistics, and enable Direct Editing on 
pages. 

o Clear this box and the user will not be able to change, create, or delete any user 
accounts. The user will NOT be able to access Web statistics, or enable Direct 
Editing on pages. 
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 Allow Web site publishing 
o Select this box and the user will be able to publish the whole Web site or run a 

task to publish all updated pages on the site. 

o Clear this box and the user will not be able to publish the whole Web site or run a 
'publish changed pages' task (unless the user has webmaster privileges). 

 

5. Click Ok to complete your changes, or click Cancel to erase any changes you have 
made. 

 

Note 

These permissions are completely independent of each other.  For example, if you give a user 
permission to edit in HTML, but take away permission to insert tables, the user will not be able to 
add a table from the Editor, but will be able to add a table while in the HTML view. 

Allowing users to publish 

You can allow users to publish pages to the Production server at three different levels: 

 Webmaster - All users with Webmaster permissions can publish the entire site, updated 
files, group files, selected files, and can schedule any publication task. 

 Site publishing - All users with site publishing permissions can publish the entire site, or 
updated files. 

 Group publishing - All users with group publishing permissions can publish every file 
owned by the group, selected files owned by the group, and can schedule publication 
tasks for any and all group files.  

You can combine these levels for any user. Note that Site Publishing permission does not 
automatically allow group publishing privileges. 

 

To allow a user to publish a group's pages 

1. Login to PureCMS as a Webmaster. 
2. On the menu bar, choose Tools > Admin Options > Manage Groups. The Manage 

Groups window appears. 

3. In the Select Group list, select the group where you will allow the user to publish. 

4. In the list of users, find the user that will get publishing permission. 

5. Under Access Level, click Modify in the appropriate user's row. An Access Level 
window appears. 

6. In the appropriate user's row, select the Allow Group Publishing check box. 

7. Click Update. A message appears saying the update was successful. 

8. Click Ok. The user will now be able to publish all the pages in the group. The user will be 
able to publish group pages separately, or all together. 

 

Note 

User's with group publishing permission will not be able to publish the entire site unless you give 
the user that permission separately in the Manage Users window. 

 

Related topic 

Publishing group pages 

Changing user permissions 
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Viewing a users recent activity 

To view a users recent activity 

1. Log in to PureCMS using your Webmaster or another administrator account. 

2. On the menu bar, click Tools > Admin Options > View User Activity. 

3. In the Select User list, choose the user whose activity you want to view. 

4. In Time Range, choose which recent actions to list based on how long ago the actions 
took place. 

5. Use the Sort By box to list actions by date Modified, File name, Status of the changes 
or description of the change Action. 

6. Click Update, to apply the listing options you chose in steps three, four, and five. 

 

Related topics 

View recent Site activity 

View a page's history 

Setting how long an account can be idle 

By default, PureCMS will automatically log out users who are inactive for 30 minutes. You can 
change the amount of time PureCMS waits before logging out idle users. 

To set the time a logged in account can be idle 

1. On the Staging Server, open Windows Explorer. 
2. Navigate to C:/ Program Files/GlobalSCAPE/PureCMS. If you installed to a location 

other than the default, open the PureCMS/main folder in the location where you chose to 
install. 

3. Open the Main folder for PureCMS.  

4. Open the file named PHP.ini in Notepad or another text editor. 

5. On the menu bar, click Edit > Find. 

6. In Find What, type session.cookie_lifetime. 

7. Click Find Next. Session.cookie_lifetime will be highlighted.   

8. Replace the number after the equal sign (default is 1800) with the number of seconds 
you want PureCMS to wait before logging out an idle user. 

9. On the Notepad menu bar, click File > Save, and then File > Close. 

10. The time you have chosen will apply to all users and administrators the next time they log 
in to PureCMS. 

 

Notes 

 You can open Windows Explorer by right-clicking on My Computer and choosing 
Explore. 

 If the client computer and the Staging Server are not on the same time, either the timeout 
feature will not work, or the user will not be able to log in. 

 If users or administrators are logged in while you make the change, the change will not 
apply to their current session. 
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Controlling access to files and folders 

As an administrator, you can control access to files and folders by hiding them from users.  You 
hide files from users by assigning the files to groups where the users are not members. If you 
want to hide a group of files from one user, simply remove the user from the group or groups that 
have ownership of the files. You hide folders through Site Options.  

  

To hide a file from users 

1. Log in to PureCMS as Webmaster or another administrator. 

2. On the menu bar, choose Tools > Admin Options > Manage Groups. The Manage 
Groups window opens. 

3. In the Select Group list, select Master. Only administrators (the Webmaster and users 
granted webmaster privileges) can see files assigned to this group. If you want to hide 
files from some users but not others, create a group for the users who should see the file, 
and select that group from the Select Group list. 

4. Under Group File Ownerships, click Modify. The Modify Group File Ownership 
window opens. 

5. Under Select the pages to be configured, choose Give the group ownership of 
selected files. 

6. In the pane on the left, select the files you want to hide from users. Click folders to see 
and select the files within them. Files listed in Bold Italics already belong to the group. 

7. When you have selected all the files you want to hide, click Ok. A Permissions box opens 
telling you how many files have changed ownership. 

8. Click Ok again. 

  

To hide a folder from users 

1. Log in to PureCMS as Webmaster or another administrator. 

2. On the menu bar, choose Tools > Admin Options > Site Options. The Site Options 
window opens. 

3. In the Directories to exclude from the Site Manager, type the names of any folders you 
do not want displayed.  You only need to type the name, do not type any slashes. Type a 
semicolon to separate folder names. Match the case of the names as they appear in the 
Site Manager. 

4. Click Update. A Preferences box appears telling you your preferences have been 
updated. 

5. Click OK. The folder will no longer appear in the Site Manager, even for those who log on 
as administrators. 

Note 

You cannot leave a folder showing and hide folders within it. 

 

To reveal a hidden folder 

1. Log in to PureCMS as Webmaster or another administrator. 
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2. On the menu bar, choose Tools > Admin Options > Site Options. The Site Options 
window opens. 

3. In the Directories to exclude from the Site Manager, delete the names of any folders 
you want to display. 

4. Click Update. A Preferences box appears telling you your preferences have been 
updated. 

5. Click OK. The folder will appear in the Site Manager for all users and administrators. 

 

Managing Pages 

Creating templates 

To create a template 

1. From the Start Page menu bar, click View > Go to > Site Manager. 
2. Click on the page you want as a template. 

3. On the menu bar, click Edit > Copy. 

4. Click the Templates folder. 

5. On the menu bar, click Edit > Paste. 

6. Click on the file you pasted. 

7. On the menu bar, click Edit > Rename. The Rename File window appears. 

8. In the Enter the new name for the file box, type a name for the template file, making 
sure it ends with a .dwt extension.  

9. Click Ok. A message appears telling you the file has been renamed successfully. 

10. Click Ok again. 

 

Note 

When you want to use a template to make a new page in a specific folder, the template must 
reside in a subfolder named "templates".  For example, if you wanted to create a new page in a 
folder called "Products", and the template was called "example.dwt", the template file would have 
to reside in the following path ../Products/templates/example.dwt. 

 

Related topics 

Creating a new Web page from template 

Uploading pages to the Staging Server 

To upload a page to the PureCMS Staging Server 

1. Log in to PureCMS. 

2. On the menu bar, click File > Upload Files. 

3. In the left pane, click the destination folder for the file.  
4. Click the Browse button. The Choose file window appears. 

5. Browse to the file you want to upload and select it. 

6. Click Open. 

7. The file will be listed under Files to be uploaded. 
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8. To upload more files to the same directory, repeat steps five through seven. 

9. Click Upload. Click Clear to remove files from the upload list. Click Cancel to abort the 
upload operation. 

 

Notes 

 If you do not see the Upload Files option on the File menu, an administrator or 
Webmaster will need to assign the upload permission to your PureCMS user account.  

 If you do not see the files you have uploaded, the Webmaster needs to approve the files 
and assign them to your group. 

 The PureCMS System supports uploading files up to 8 Megabytes in size.  Your 
configuration of Microsoft IIS may further limit the size of uploaded files.  

 You can select options to change all file names to lower case, change .htm extensions, 
and overwrite existing files. 

 If you upload a large number of files, or upload to a slow server, your upload connection 
may timeout.  It is recommended that you only upload a few files at a time. 

Approving uploaded files 

When users upload files to the Staging Server they will not be able to see or edit the files until the 
files are approved and assigned to a group. 

To approve uploaded files 

1. Log in to PureCMS as Webmaster or another administrator. 

2. On the menu bar, choose View > Pending Changes. 
3. Find the newly uploaded file. 

4. Click Approve. A message appears asking if you are sure you want to approve. 

5. Click Yes. Another message appears telling you your changes have been successfully 
completed. 

6. Click Ok. Now you must assign the file to a group. 

7. On the menu bar, choose Tools > Admin Options > Manage Groups. 

8. Choose the group that will own the file in the Select Group list. 

9. Under Group File Ownerships, click Modify. The Modify Group File Ownership 
window opens. 

10. Under Select the pages to be configured, choose Give the group ownership of 
selected files. 

11. Select the new file. If the file is in a subfolder, click the subfolder to see the file. 

12. Click Ok. A Permissions box opens telling you the file or files have been modified. 

13. Click Ok again. 

Note 

When administrators upload files, approval is not required, but the files still need to be assigned 
to a group. 

Create a new folder on the Staging Server 

1. Log in to PureCMS. 
2. On the menu bar, choose File > New Folder. The New Folder box opens. 

3. Type a name for the folder and click Ok. 

4. The folder is created in the main folder. 
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To create a new folder in a subfolder 

1. Log in to PureCMS 
2. On the menu bar, choose View > Go to > Site Manager. The Site Manager window 

opens. 

3. In the left pane, select the folder where you want the new folder. 

4. On the menu bar, choose File > New Folder. The New Folder box opens. 

5. Type a name for the folder and click Ok. 

6. The folder is created in the subfolder. 

Defining editable areas 

To define an editable area by region 

This is the recommended method for defining regions. 

1. Log in to PureCMS as Webmaster or another administrator. 

2. On the menu bar, click View > Go to > Site Manager. 
3. Click on a Web page. 

4. On the menu bar, click Edit > Define Regions. The Define Regions window opens. 

5. Choose By Region to see the page in Web format. If a region is already defined, a gray 
highlight will appear around it when you move your mouse over it.  If a region is not 
defined, a blue highlight will appear around it when you move your mouse over it. 

6. Click an area of the page you want to define as editable for users. A Content Name 
window appears.  

7. In the Enter a name for the Region Content box, type a name for the region. 

8. Click Ok. 

9. To choose more regions repeat steps six through eight. 

10. When you have finished choosing regions, click Done. 

 

To define an editable region by selection 

This method can be difficult and may result in overlapping regions or other problems that could 
result in serious errors. 

1. Log in to PureCMS as Webmaster or another administrator. 

2. On the menu bar, click View > Go to > Site Manager. 
3. Click on a Web page. 

4. On the menu bar, click Edit > Define Regions. The Define Regions window opens. 

5. Choose By Selection to see the page in HTML. 

6. Click and drag the mouse cursor over the area you want to define as editable for users. 

7. Click the Select button. 

8. Type a name for the region. 

9. Click OK. 

10. To choose more regions repeat steps five through eight. 

11. When you have finished choosing regions, click Done. 

 

Notes 
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 It is highly recommended that you do not create editable regions within editable regions 
(nested regions). 

 If you do not select any regions as editable within a page, the whole page will be editable. 

 

Related topics 

Deleting editable areas 

Enabling Direct Edit 

Deleting editable areas 

To un-define a page region as editable 

1. Log in to PureCMS as Webmaster or another administrator. 

2. On the menu bar, click View > Go to > Site Manager. 
3. Click the page you want to change.  

4. On the menu bar, click File > Open Page. 

5. On the menu bar, click Page > Edit Page.  

6. Click the Source tab at the bottom left of the window. 

7. Look for comment tags like this; <!-- #BeginEditable  --> and this <!-- #EndEditable -->. 

4. Remove the BeginEditable and EndEditable tags that surround the region you want to 
delete or un-define as editable. 

Warning: You must delete both the BeginEditable and EndEditable tags when un-defining 
an edit region. 

5. Click Save. 

 

Notes 

 The BeginEditable and EndEditable tags are only comment tags and will not in any way 
affect the display of pages when they are published to the Web.   

 Leaving a BeginEditable tag without an EndEditable tag, or an EndEditable tag without 
a BeginEditable tag will adversely affect your ability to edit any regions on a page in 
PureCMS. 

 

Related topics 

Defining and changing editable areas 

Enabling Direct Edit 

With Direct Edit, users can browse your Web site on the Staging Server, and immediately open a 
page for editing by clicking a link on the page. 

 

To enable Direct Edit 

1. Log in to PureCMS as Webmaster or another administrator. 

2. On the menu bar, click Tools > Direct Edit Options. All Web pages and folders will 
appear in the left pane. Files that already have Direct Edit enabled will appear in bold. 
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3. Click any file or folder in the left pane. You may need to double-click a folder to see files 
you want. 

4. Choose Enable Direct Edit. 
5. Choose Direct Edit Link Text, and in the box, type the text that users will click to edit the 

page or pages. You can also use an image as your Direct Edit link. 

6. in the Direct Edit Link Prefix list, choose the means of separating the Direct edit link 
from the web content. 

7. Choose For the selected pages only, or 

 Choose For Entire Site. 

8. Click Ok. A message appears saying your changes are in progress. 

9. Click Ok again. 

 

To disable Direct Edit 

1. Log on to PureCMS as Webmaster or another administrator. 
2. On the menu bar, click Tools > Direct Edit Options. All Web pages and folders will 

appear in the left pane. If a page has Direct Edit enabled it will appear in bold. 

3. Click any file or folder in the left pane. You may need to double-click a folder to see files 
you want. 

4. Choose Disable Direct Edit. 
5. Choose For the selected pages only, or 

 Choose For Entire Site. 

8. Click Ok. A message appears saying your changes are in progress. 

9. Click Ok again. 

 

To use an image as the Direct Edit link 

1. Log in to PureCMS as Webmaster or another administrator. 

2. On the menu bar, click Tools > Direct Edit Options. All Web pages and folders will 
appear in the left pane. Files that already have Direct Edit enabled will appear in bold. 

3. Click any file or folder in the left pane. You may need to double-click a folder to see files 
you want. 

4. Choose Enable Direct Edit. 
5. Choose Direct Edit Link Image. You can also use text as your Direct Edit Link. 

6. Click Select to choose the image users will click to edit a page. The Image window 
appears. 

7. In the left pane select the image file that you want as the link, a preview of the image will 
appear in the right pane. 

8. Click Insert. The Image window disappears. 

9. in the Direct Edit Link Prefix list, choose the means of separating the Direct edit link 
from the web content. 

10. Choose For the selected pages only, or 

 Choose For Entire Site. 

8. Click Ok. A message appears saying your changes are in progress. 

9. Click Ok again. 
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Updating several pages at once 

If you create pages based on a template, and then change your template, you can update all the 
pages based on the template without opening and editing each page.  If you have pages with a 
library item and change the library item, you can update each page with the library item without 
have to open and edit each page. 

 

To update all pages based on a template 

1. Log in to PureCMS with a webmaster account. 

2. On the menu bar, choose Tools > Update Pages > Template Changed. 

3. In the Select a Template list, highlight the template.  

4. Click Ok. A message appears telling you the update process has started. 

5. Click Ok again.. 

  

To update a library item on all pages 

1. Log in to PureCMS with a webmaster account. 

2. On the menu bar, choose Tools > Update Pages > Library Item Changed. 

3. In the Select a Library Item list, highlight the library item.  

4. Click Ok. A message appears telling you the update process has started. 

5. Click Ok again. 

 

Note 

In order for updating of templates to work, PureCMS must index those pages that are derived 
from a template.  To do so, select Tools > Update Pages > Template Changed  from the menu, 
select the template in question, and check build an index of the selected.  This puts information 
into the PureCMS database tables that cross references templates and the pages that use them, 
so that future updates of templates happens much more quickly. 

 

 

Related topics 

Building an index for library items or templates 

Publish a single file 

1. On the menu bar, choose View > Go to > Site Manager. 
2. If the file is not in the main folder, click the folder that contains the file. 

3. Select the page you want to publish. 

4. On the menu bar, choose Tools > Publish > Publish Selected File. A message appears 
telling you the selected file will be published. 

5. Click Ok.  

 

Note 

The publication task may take up to five minutes to start after you click Ok. 
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Backing up individual pages 

By default, PureCMS will keep the 5 previous versions of every page on your site. You can 
change how many previous versions PureCMS will keep. 

 

To set the number of previous page versions PureCMS will save 

1. Log in to PureCMS with a Webmaster account. 

2. On the menu bar, click Tools > Admin Options > Site Options. The Site Options 
window appears. 

3. In Backup the previous 5 changes to each file on this website, replace the 5 with the 
number of backups you want for each page. 

4. Click Update. If you decreased the number of backups, a message appears warning you 
that your change may take a long time. If you increase the number of backups, a 
message appears confirming that your preferences have been updated. 

5. Click Ok. 

 

Note 

The number of versions you keep determines which past versions you can compare.  For 
example, if you keep 7 versions of a page, when you go to the Page Change History, you will 
not be able to compare your current version with the page as it looked before the last eight 
changes. 

 

Related topics 

Viewing a single page's history 

 

Publishing a group's pages 

To publish all the pages assigned to a group 

1. Login to PureCMS. 

2. On the menu bar, choose Tools > Publish > Group Publishing. The Group Publish 
window appears. 

3. Select the group with the pages you want to publish. 

4. Click Ok. A message appears saying the publication task is in progress. 

5. Click Ok again. The pages assigned to the group are published. 

 

Note 
If you see a message that says No Rights after step two, the Webmaster has not given you 
group publishing permissions. 

 

Related topic 

Allowing a user to publish group pages 
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Receiving notification of changes 

PureCMS automatically sends an email to a group leader whenever a file owned by the group is 
changed.  Most changes will result in one email per file changed.  

 

Changes where one change is made to several files at once, like Search and Replace, enabling 
Direct Edit, and changes to a template or library item, will result in only one email being sent to 
the group leader.  The single email will list all the files owned by the group that were changed. 

 

To receive notification of changes to a page  

1. Make yourself a group leader of a group.  

2. Assign the page to any group where you are the group leader. 

 

Related topics 

Changing a group's leader 

Assigning files and folders to a group 

Creating a group 

 

Viewing proposed changes to a page 

To view changes 

1. Log in to PureCMS as Webmaster or a group leader. 

2. On the menu bar, click View > Pending Changes. 

3. In Pending Changes, find the file name for the changed page. 

4. To view the page: 

 click Current to see currently published page in a browser window. 

 click Proposed to see the new, unpublished version in a browser window.   

 click Compare to see the new page and the published page side-by-side in the 
Compare Versions window. 

5. Close the Web browser to return to PureCMS. 

6. Click Close to return to the Site Manager. 
 

Comparing pages 
In the Compare Versions window: 

 To see the changes highlighted, select the Show Changes check box. 

 Inserted text shows green. 

 Replaced text shows blue with a strikethrough. 

 Replacement text shows blue. 

 Deleted text shows red with a strikethrough. 

 Moved text shows brown. 

 To see the current page above the new page, clear the Show Changes check box and 
choose Horizontal Layout. 

 To see the current page to the left of the new page, clear the Show Changes check box 
and choose Vertical Layout. 
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 Select Scroll Lock and the new page will move with the current page when you move 
the scroll bars for the current page.   

 Clear Scroll Lock and only the current page will move when you move its scroll bars. 

 

Note 

All group leaders can see all pending changes, but only the group leader who has responsibility 
for a file will be able to approve changes to the file. 

 

Related topics 

Accepting or denying proposed changes to a page 

Approving or denying proposed changes to a page 

To approve changes 

1. Log in to PureCMS with your Webmaster or group leader account. 

2. On the menu bar, click View > Pending Changes. 

3. In Pending Changes, find the file name for the changed page. 

4. To view the changes, click Proposed or Compare. 

5. Close either the browser with the proposed changes or the Compare Versions window. 

6. Click Approve.  A message appears asking if you are sure you want to approve the 
changes. 

7. Click Yes. Another message appears telling you the changes have been completed. 

8. Click Ok. 

 

To deny changes 

1. Log in to PureCMS with your Webmaster or group leader account. 
2. On the menu bar, click View > Pending Changes. 

3. In Pending Changes, find the file name for the changed page. 

4. To view the changes, click Proposed or Compare. 

5. Close either the browser with the proposed changes or the Compare Versions window. 

6. Click Deny. A message appears asking if you are sure you want to deny the changes. 

7. Click Yes. Another message appears telling you the changes have been cancelled. 

8. Click Ok. 

 

To approve or deny changes with conditions 

1. Log in to PureCMS with your Webmaster or group leader account. 

2. On the menu bar, click View > Pending Changes. The Pending Changes window 
opens. 

3. In Pending Changes, find the file name for the changed page. 

4. Click More. The Approve Changes window opens. 

5. Click Current Version, Proposed Version, or Compare to see the page and changes. 

6. Close either the browser with the proposed changes or the Compare Versions window. 
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7. Choose: 

 Approve: Update the web page to the proposed version. This accepts all 
changes with no conditions. Click Ok, and click Ok again to finish.  

 Approve: Update the web page to the proposed version and schedule for 
publishing. This accepts all changes and takes you to the screen where you can set 
a publishing time and date. Click Ok, and the Scheduled Publishing dialog opens. 

 Deny: Retain the current version and delete the proposed changes. This rejects 
all changes with no conditions. Click Ok, and click Ok again to finish. 

 Approve and edit. The page will be updated after additional editing.   Select this, 
click Ok and the page will be opened in the Editor. Make your edits and click Save. 
This allows you to make additional changes to the page before it is approved. 

 Request additional changes: The page will remain locked by the current user. 
This allows you to send directions to the user who made the changes. Type 
instructions in the box. Click Ok, and click Ok again. An email will be sent to the user 
with the instructions you typed, and the user will have to resubmit for approval. 

 

Notes 

 If you log in with a group leader account, though you will be able to see a list of all pending 
changes, you will only be able approve or deny changes to files that belong to your group. 

 If you click Request additional changes, the page will be locked by the user who 
submitted the changes, until the user submits changes for approval again. 

 

Related topics 

Viewing proposed changes to a page 

Staging and Publishing sites 

Publishing changes to a page 

To publish one page to your Production Server 

1. Log in to PureCMS as an administrator. 

2. On the menu bar, choose View > Go to > Site Manager. 
3. Select a page. 

4. On the menu bar, choose Tools > Publish > Publish Selected File. A message appears 
saying the file will be published to the Production Server.  

5. Click Ok. 

Note 

After you click Ok, it may take up to five minutes for the page to publish.  If you need to re-publish 
a page, wait at least five minutes before repeating the Publish Selected File process.  

  

To publish just pages that have been changed 

1. Log in to PureCMS using your Webmaster account. 

2. On the menu bar, choose Tools > Publish > Publish Web Site. The Publish Web Site 
window opens. PureCMS will first backup your current site. 

3. Enter a name for the site backup in Archive Label. The name can be up to 50 characters 
long. 
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4. Enter any Comments you choose. Comments can be up to 255 characters long. 
5. Select the Publish only changed files check box, and PureCMS will not publish the 

whole site, just those pages that have changed since the last time you published. 
6. Click Publish. A box titled Publishing site is in progress appears. 
7. Click Ok. 

   

To schedule a page to be published later 

1. With a page open in the Editor, make any changes to the page. 

2. In the lower right, click Save & Schedule. The Scheduled Publishing window opens. 

3. Choose the Hour, Minutes, Month, Day and Year for the publication. You must pick a 
time at least fifteen minutes after the current time. 

4. Select Does not expire to keep the page on the Web indefinitely. 

5. Click Ok. A message appears to confirm the scheduling was successful. 

6. Click Ok again. 

 

To schedule a page to expire 

1. With the page open in the Editor, make any changes to the page. 

2. In the lower right, click Save & Schedule. The Scheduled Publishing window opens. 

3. Choose the Hour, Minutes, Month, Day and Year for the publication. You must pick a 
time at least one hour in the future. 

4. Select the Expires at the following time check box. 

5. Choose the Hour, Minute, Month, Day and Year for expiration. The expiration must be 
at least 15 minutes after the scheduled publish time. 

6. Choose Remove to delete the page when it expires, or choose Replace with original 
file, to publish the old page in its place when the scheduled page expires. 

7. Click Ok. A message appears to confirm the scheduling was successful. 

8. Click Ok again. 

 

Notes 

 Only Webmasters and others with publishing privileges can schedule publication of a page. 

 You can also schedule publication from the Pending Changes window. Click on More and 
then Approve and Schedule Publishing. 

 When scheduling publication times you can only choose times at quarter hour intervals. 

 If you schedule publication for a time in the past or less than fifteen minutes in the future, 
PureCMS will return an error that says The start time is before the current time, and 
ignore the scheduled time. 

 If you schedule an expiration that is not at least 15 minutes after publication, PureCMS 
displays a message that says The end time is before the start time, and it will reset the 
schedule. 

 If you change a Production Server Web page outside PureCMS, the change will not appear 
in PureCMS or be recognized by PureCMS. 

 If you set a page to expire, it will be deleted or replaced on both the production and staging 
server. 
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Related topics 

Scheduling page publication 

Undoing published changes 

If you have accepted changes on your staging server, and decide you do not want them, you can 
rollback the changes. Even if you have published your site, and want to return to an earlier 
version of the site, you can easily revert to a previous version of the site. 

 

To undo accepted changes to a page 

1. Log in to PureCMS with an account that has access to the Site Manager. 

2. On the menu bar, choose View > Go to > Site Manager. 
3. Select the page with the changes you want to undo. 

4. On the menu bar, choose Tools > Version Control. The page opens in the Version 
Control window. 

5. Click Back or Next until you find the version of the page you want. 

6. Click Revert to change the page.  The version you choose will open in the Edit Region 
view. It becomes the active version on your Staging Server, and you can publish it to your 
Production Server. 

 

To undo a site publication 

1. Log in to PureCMS as Webmaster or another administrator. 
2. On the menu bar, choose Tools > Publish > View Backup History. 

3. Choose the publication task dated just before the publication you want to undo. 

4. Click Restore. A message appears asking if you are sure you want to restore the Staging 
Server to the selected version. 

5. Click Yes. Another message appears to tell the restore is in process. 

6. Click Ok.  The version you chose will be posted to your Staging Server, and you can 
publish it to your Production Server. 

7. Wait at least ten minutes before continuing. 

8. On the menu bar, choose Tools > Publish > Publish Web Site. 

9. In Archive Label type a name for the backup that will be saved during the publish 
process. 

10. In Comments, type any remarks or notes you want to save with the backup. 

11. Click Publish. A message appears telling you the publication will begin soon. 

12. Click Ok. The older version of your site will be published to your Production Server. 

Scheduling page publication 

If you want to schedule publication tasks, you must have the Windows Task Scheduler installed 
on the Staging Server, and it must be accessible to the PureCMS program. 

To publish a changed page 

1. Log on to PureCMS as a Webmaster or another account with publication privileges. 

2. On the menu bar click, Tools > Publish > Select Files to Schedule. 
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3. Select the file or folder you want to publish in the left pane. Click folders to see the files 
they contain. Files listed in Bold are currently scheduled for publication. 

4. Choose the Hour, Minutes, Month, Day and Year for the publication. You must pick a 
time at least 15 minutes after the current time. 

5. Select Does not expire to keep the page on the Web indefinitely. 

6. Click Ok. A message pops up announcing the scheduling task was successful. 

7. Click Ok again. 

 

To publish a change with an expiration 

1. Log on to PureCMS as a Webmaster. 
2. On the menu bar click, Tools > Publish > Scheduled Publishing. 

3. Click the file or folder you want to publish in the left pane. Click folders to see the files 
they contain. 

4. Choose the Hour, Minutes, Month, Day and Year for the publication. You must pick a 
time at least 15 minutes after the current time. 

5. Select Expires at the following time. 

6. Choose the Hour, Minute, Month, Day and Year for expiration. The expiration must be 
at least 15 minutes after the scheduled publish time. 

7. Choose Remove to delete the page when it expires, or choose Replace with original 
file, to publish the old page in its place when the scheduled page expires. 

8. Click Ok. A message pops up announcing the scheduling task was successful. 

9. Click Ok again. 

 

Notes 

 Only Webmasters and others with publication rights can schedule publication tasks. 

 If you publish a page with graphics or other files that are not currently on the Production 
Server, those files must be published or uploaded to the Production Server as well. 

 When scheduling publication times, you can only choose times at quarter hour intervals. 

 If you schedule publication for a time in the past or less than 15 minutes in the future, 
PureCMS will return an error that says The start time is before the current time, and 
ignore the scheduled time. 

 If you schedule an expiration that is not at least 15 minutes after publication, PureCMS 
displays a message saying The end time is before the start time, and it will reset the 
schedule window. 

 You can also schedule by opening a page in the Editor, and then clicking the Save & 
Schedule button. 

 If you schedule a page to expire, it will be removed or deleted from both the Staging Server 
and the Production Server. 

 

Related topics 

Publishing changes to a page 

 

 

Deleting a folder 
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To delete a folder 

1. Log in to PureCMS 

2. On the menu bar, choose View > Go to > Site Manager. The Site Manager window 
opens. 

3. In the left pane, select the folder you want to delete. 

4. On the menu bar, choose Edit > Delete. A message appears asking if you are sure you 
want to delete the folder. 

5. Click Yes. 

6. The folder is removed. 

 

WARNING: Deleting a folder will also delete all of its contents without warning or prompt. 

Cancelling a scheduled publication 

To cancel a scheduled publication 

1. Log in to PureCMS with your Webmaster or another account with publication privileges. 

2. On menu bar, click Tools > Publish > Currently Scheduled Files. 

3. Find the publication task you want to cancel. 

4. In the Username column for the task, click the circle. 

5. Click Delete. PureCMS asks if you are sure you want to cancel the scheduled 
publication. 

6. Click Yes. A notification appears telling you the cancellation was successful. 

7. Click Ok. 

 

Related topics 

Scheduling automatic publication 

Viewing a single page's history 

To see the history of changes to a page 

1. From the Start Page menu bar, click View > Go to > Site Manager. 
2. Click on a page. 

3. On the menu bar, click View > Page Change History.  

4. Select any two versions' check boxes and click Compare to see the two pages side-by-
side. 

 

Note 

You can only compare versions of the page that have been backed up.  By default PureCMS 
keeps the 5 previous versions of all pages.  You can change how many versions PureCMS keeps 
in the Site Options page. 

 

Related topics 

Viewing a user's recent activity 

View recent activity for the site 

Backing up individual pages 
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Controlling access to files and folders 

As an administrator, you can control access to files and folders by hiding them from users.  You 
hide files from users by assigning the files to groups where the users are not members. If you 
want to hide a group of files from one user, simply remove the user from the group or groups that 
have ownership of the files. You hide folders through Site Options.  

  

To hide a file from users 

1. Log in to PureCMS as Webmaster or another administrator. 

2. On the menu bar, choose Tools > Admin Options > Manage Groups. The Manage 
Groups window opens. 

3. In the Select Group list, select Master. Only administrators (the Webmaster and users 
granted webmaster privileges) can see files assigned to this group. If you want to hide 
files from some users but not others, create a group for the users who should see the file, 
and select that group from the Select Group list. 

4. Under Group File Ownerships, click Modify. The Modify Group File Ownership 
window opens. 

5. Under Select the pages to be configured, choose Give the group ownership of 
selected files. 

6. In the pane on the left, select the files you want to hide from users. Click folders to see 
and select the files within them. Files listed in Bold Italics already belong to the group. 

7. When you have selected all the files you want to hide, click Ok. A Permissions box opens 
telling you how many files have changed ownership. 

8. Click Ok again. 

  

To hide a folder from users 

1. Log in to PureCMS as Webmaster or another administrator. 

2. On the menu bar, choose Tools > Admin Options > Site Options. The Site Options 
window opens. 

3. In the Directories to exclude from the Site Manager, type the names of any folders you 
do not want displayed.  You only need to type the name, do not type any slashes. Type a 
semicolon to separate folder names. Match the case of the names as they appear in the 
Site Manager. 

4. Click Update. A Preferences box appears telling you your preferences have been 
updated. 

5. Click OK. The folder will no longer appear in the Site Manager, even for those who log on 
as administrators. 

Note 

You cannot leave a folder showing and hide folders within it. 

 

To reveal a hidden folder 

1. Log in to PureCMS as Webmaster or another administrator. 
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2. On the menu bar, choose Tools > Admin Options > Site Options. The Site Options 
window opens. 

3. In the Directories to exclude from the Site Manager, delete the names of any folders 
you want to display. 

4. Click Update. A Preferences box appears telling you your preferences have been 
updated. 

5. Click OK. The folder will appear in the Site Manager for all users and administrators. 

 

Validating links 

Type topic text here. 

 

 

Managing a Single Site 

Staging and Publishing sites 

Any changes you make to pages or sites will not be available on the Web until you publish the 
Web site.  It is recommended that you give very few users the authority to publish. 

Publishing a site simply moves all changes from the Staging Server to a Web (Production) server. 
 When you publish, PureCMS reviews all the pages on the Web and moves all approved changes 
from the Staging Server to the Web server. 

 

 

 
 

Without permission to publish, users cannot make any changes to the Web site that the public will 
see. When a user makes changes, those changes take place on the Staging Server. Only the 
user can see the changes when he opens the page. The user's group leader can see the 
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changes from the Pending Changes view. If the group leader approves the changes, then all 
users can see the changes. 

 

Once the changes are approved, they will show up for all users, but will not exist on the Web 
Server until the Webmaster or someone with publishing permission publishes the changes. 

 

Related topics 

Publishing a Web site 

Publishing changes 

Designating the Staging site folder as the Web site root folder 

When importing your site, it will be placed in a virtual directory inside the Web site root folder, this 
will create problems if you use absolute paths in your HTML code.  Set the Staging site folder as 
the IIS Web site root folder so that absolute paths will work properly. 

 

To designate the staging site folder as the Web site root 

1. On your Staging computer, open Microsoft IIS. 

2. Select the Staging Web site. 

3. On the menu bar, choose Action > Properties. 

4. Click the Home Directory tab. 

5. In Local Path, type the path to the Staging site's folder. Including the hard drive and all 
parent folders. For example: c:\program files\globalscape\puresmssample. 

6. Click OK. 

Note 

When using absolute paths, only type the path to the root directory, do not type a path to a URL. 
For example, the correct path for a graphic in an "images" folder called menu.gif would be: <img 
src = "/images/menu.gif">.  If you were to use a path like this <img src = 
"www.example.com/images/menu.gif"> then the image wouldn't show up on your Staging site. If 
you were to reference the URL for the Staging site, then the image wouldn't show up on your 
Production site. 

To view a record of recent activity 

To see a record of recent changes to your Web site 

1. Log in to PureCMS. 

2. Click History so that the arrow button is pointing down . 

3. In Time Range, choose how far back you want the history to display. 

4. In Sort By, choose to list changes in order by the date of the change (Modified), the 
User who made the changes, or the type of change (Action). 

5. Click Update, and the history items will be re-sorted.  

 

To see a record of recent changes to an individual page 

1. Log in to PureCMS as a Webmaster or group leader 

2. On the menu bar, click View > Go to > Site Manager. 
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3. Select a page and then choose File > Open Page from the menu bar. 

4. On the menu bar, click Versions >  Page Change History.  From here you can compare 
non-contiguous versions of the page.   

 

Note 

You cannot compare versions that are older than your oldest backup of the page. To set how 
many backups you keep, see Backing up individual pages. 

 

 

Related topics 

Viewing a user's recent activity 

Backing up individual pages 

Preparing a Web site for publication 

Before publishing your site, you must provide PureCMS with the information necessary to transfer 
files from your Staging Server to your Production Server. 

To configure a site for publishing on a local network 

1. Log in to PureCMS with your Webmaster account. 

2. On the menu bar, click Tools > Admin Options > Publishing Options. 

3. Choose Local from the Server Type list. 

4. Type the Path to the Web site directory on the Production Server. 

5. Click Ok. 

6. A message appears telling you the configuration has been saved. Click Ok again. 

 

To configure a site for publishing at a remote location 

1. Log in to PureCMS with your Webmaster account. 

2. On the menu bar, click Tools > Admin Options > Publishing Options. 

3. Choose FTP from the Server Type list. 

4. Type the Path to the Web site directory on the Production Server. If you connect directly 
to the Web site directory, type /. 

5. In FTP Host Address, type the domain or IP address for the Production Server. Do NOT 
include ftp:// in the domain name. 

6. If the Production Server uses a port other than 21 for FTP transfers, type the correct port 
number in FTP Port. 

7. Enter your FTP Username and FTP User Password for the Production Server account. 

8. Click OK. 

9. A message appears telling you the configuration has been saved. Click Ok again. 

 

Notes 

Publication requires a stable connection between the Staging Server and the Production Server, 
especially if you are publishing a large site, or a site with many large files. 
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Publishing on a network using UNC path names 

If you want to publish to a network or other local drive using UNC path names, there are several 
tasks you will need to do before publishing. 

1. Temporarily change the anonymous user account for the PureCMS virtual directory to an 
account that has access to the UNC path of your Production Server. 

2. Set your publishing options in PureCMS. 

3. Change the anonymous user account back to the default (for security reasons).  

4. Change the account under which the Cron service runs,  

5. You will need to publish to a folder on any shared drive (you cannot publish to the root of 
a shared drive if you are using UNC path names).  

 

To temporarily change the anonymous user account 

1. Log on to the Staging Server. 

2. Right-click the My Computer icon and choose Manage.  The Computer Management 
window opens. 

3. In the left pane expand Services and Applications.  

4. Expand Internet Information Services. 

5. Expand Default Web Site (or if you chose a different site during installation expand the 
site you chose). 

6. Select PureCMS (or if during install, you gave the virtual folder a different name, select 
the folder with that name). 

7. On the menu bar, choose Action > Properties.  The PureCMS (or other virtual folder 
name) Properties window opens. 

8. Click the Directory Security tab. 

9. Under Anonymous access and authentication control, click Edit. The Authentication 
Methods window opens. 

10. Make sure the Anonymous Access box is checked and click Edit again.  The 
Anonymous User Account window opens. 

11. Make sure you know the User name and password for the account that is currently 
entered. 

12. In Username, type the name for an account that has access to the UNC path you will use 
for publication. 

13. Clear the Allow IIS to control password check box. 

14. Enter the password for the user you entered in step twelve.  A message appears asking 
you to re-enter the password. 

15. Re-enter the password and click OK. 

16. Click OK to close the Anonymous User Account window. 

17. Click OK again to close the Authentication Methods window. 

18. Click OK again to close the PureCMS Properties window. 

19. On the Windows task bar, click Start and choose Run. The Run window opens. 
20. In the Open box, type "cmd", and then click OK. The command prompt window opens. 
21. Type "IISRESET" and press the Enter key on your keyboard, this will stop and restart IIS 

so that it recognizes the new anonymous user. 
22. When the C:// or command prompt reappears type "Exit" and press the Enter key on 

your keyboard. 
23. Open PureCMS and set your publishing options. 
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To set publishing options with a UNC path in PureCMS 

1. Log in to PureCMS with your Webmaster account. 

2. On the menu bar, click Tools > Admin Options > Publishing Options. 

3. Choose Local from the Server Type list. 

4. Using FORWARD SLASHES, type the UNC Path to the Web site directory on the 
Production Server.  

5. Click Ok. 

6. A message appears telling you the configuration has been saved. Click Ok again. 

7. Log out and close PureCMS. 

 

To change the Virtual Directory back to standard anonymous user for security 

1. Right-click the My Computer icon and choose Manage.  The Computer Management 
window opens. 

2. In the left pane expand Services and Applications.  

3. Expand Internet Information Services. 

4. Expand Default Web Site (or if you chose a different site during installation expand the 
site you chose). 

5. Select PureCMS (or if during install, you gave the virtual folder a different name, select 
the folder with that name). 

6. On the menu bar, choose Action > Properties.  The PureCMS (or other virtual folder 
name) Properties window opens. 

7. Click the Directory Security tab. 

8. Under Anonymous access and authentication control, click Edit. The Authentication 
Methods window opens. 

9. Make sure the Anonymous Access box is checked and click Edit again.  The 
Anonymous User Account window opens. 

10. Click Browse. The Select User window opens.  

11. Select the default anonymous user and click OK. The default anonymous user is usually 
IUSR_COMPUTERNAME.  For example, if the Staging Server computer name was 
OurStageServ, the default anonymous user would be IUSR_OURSTAGESERV. 

12. Select the Allow IIS to control password check box. 

13. Click OK.  A message appears warning about password synchronization with non-local 
user accounts, since the default anonymous user is a local account you can disregard 
this message and simply click Yes. 

14. Click OK again to close the Authentication Methods window. 

15. Click OK again to close the PureCMS Properties window. 

16. Close the Computer Management window. 

17. On the Windows task bar, click Start and choose Run. The Run window opens. 
18. In the Open box, type "cmd", and then click OK. The command prompt window opens. 
19. Type "IISRESET" and press the Enter key on your keyboard, this will stop and restart IIS 

so that it recognizes the new anonymous user. 
20. When the C:// or command prompt reappears type "Exit" and press the Enter key on 

your keyboard. 
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To set the account under which the Cron service runs 

1. Right-click the My Computer icon and choose Manage.  The Computer Management 
window opens. 

2. In the left pane expand Services and Applications, and select Services. 

3. In the right pane select Cron service. 

4. On the menu bar, choose Actions > Properties. The Cron service Properties window 
opens. 

5. Click the Log On tab. 

6. Under Log on as, select This Account and type in the user name for the account with 
access to the UNC path for the Production Server. 

7. Type in the account password in Password and Confirm Password. 

8. Click OK. A message will appear telling you the new name will not take effect until you 
stop and restart the service. 

9. Click OK again. 

10. On the Computer Management menu bar, choose Action > Stop. The Service Control 
window appears while the service stops. Wait for the Service Control window to 
disappear. 

11. On the menu bar choose Action > Start. The Service Control window appears while the 
service starts. When the Service Control window disappears, the Cron service runs 
under the new account that has access to the Production Server. 

 

 

Note 

When you  use UNC path names, the publishing process will not create new folders on your 
Production Server.  You will need to create any Production Server sub-folders outside PureCMS 
before publishing. 

Publishing a Web site 

To publish a Web site 

1. Log in to PureCMS using your Webmaster account. 

2. On the menu bar, click Tools > Publish > Publish Web Site. The Publish Web Site 
window opens. PureCMS will first backup your current site. 

3. Enter a name for the site backup in Archive Label. The name can be up to 50 characters 
long. 

4. Enter any Comments you choose. Comments can be up to 255 characters long. 
5. (Optional) Select the Publish only changed files check box, and PureCMS will not 

publish the whole site, just those pages that have changed since the last time you 
published. Leave the box clear, and the whole site will be published. 

6. Click Publish. A message appears telling you the publication task will begin shortly. 
7. Click Ok. 

 

Notes 

 The computer will start the publication task within five minutes of step seven. 

 Unless you select Publish only changed files, the whole site is published and archived. 

 The archive files are compressed in .CAB format and stored on the Staging Server in the 
Data folder of the PureCMS program directory. 
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 You can view the publication task while it is running from Tools > Publish > View 
Publishing History. 

 

Related topics 

Preparing a Web site for publication 

Publishing changes to a page 

 

Using the publishing hook 

When you start any publication task, PureCMS processes the files targeted for publication in a 
temporary folder for backup, then transfers the files to the Production server. You can 
automatically run a batch file just before the transfer, to perform specific actions related to your 
site files. You can generate a simple log, or send a confirmation email, or you can save all the 
Web-ready files to a second location for alternate backups and other purposes. 

 

To run a batch file at publication 

1. Log on to your Staging server. 

2. Navigate to the PureCMS program folder. The default location is C:\Program 
Files\GlobalSCAPE\PureCMS. 

3. In the App folder, create a new folder and name it Localscripts. 

4. In the Localscripts folder, create a batch file and name it publish.bat. Localscripts 
becomes the default working directory for the batch file. 

5. Every time you publish your web site or any part of the web site, the publish.bat file will 
run just before files are transferred to the Production server. 

 

Notes 

 In the batch file, you can use the parameter %1% to reference the temporary directory 
where PureCMS places the Web-ready files. You can use the parameter %2% to 
reference the directory where the Web-ready files are published. If you publish to a 
network drive, %2% will reference the complete directory path. If you publish to an FTP 
site, %2% will only reference the directories in the path within your ftp root folder. 

 If your publication task fails due to connection problems or network errors, your 
publish.bat file will still run successfully. 

 

Backing up a Web site 

PureCMS backs up your site every time you publish. The backup files are compressed in .CAB 
format and stored on the Staging Server in the Data folder of the PureCMS program directory. 

 

To backup a Web site 

1. Log in to PureCMS using your Webmaster account. 

2. On the menu bar, click Tools > Publish > Publish Web Site. The Publish Web Site 
window opens.  
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3. Enter a name for the site backup in Archive Label. The name can be up to 50 characters 
long. 

4. Enter any Comments you choose. Comments can be up to 255 characters long. 
5. Click Publish. A box appears saying the site is queued to be published. 
6. Click Ok. Your site is published and backed up. 

   
 

Related topics 

Restoring a Web site from a backup 

Restoring a Web site from a backup 

To restore a Web site from a backup 

1. Log in to PureCMS using your Webmaster account. 

2. On the menu bar, click Tools > Publish > View Backup History. 

3. Select the radio button at the left end of the backup listing you want. 

4. Click Restore. A prompt appears asking if you are sure you want to restore the site. 

5. Click Yes. Another message appears stating the restore is in process. 

6. Click Ok. 

 

Note 

Restoring a backup restores the site on the Staging Server and automatically publishes the 
restored site to your Production Server. 

 

Related topics 

Backing up a Web site 

Publishing a Web site 

 

Publishing a single page 

To publish one page to your Production Server 

1. Log in to PureCMS as an administrator. 

2. On the menu bar, choose View > Go to > Site Manager. 
3. Select a page. 

4. On the menu bar, choose Tools > Publish > Publish Selected File. A message appears 
saying the file will be published to the Production Server.  

5. Click Ok. 

 

Note 

After you click Ok, it may take up to five minutes for the page to publish.  If you need to re-publish 
a page, wait at least five minutes before repeating the Publish Selected File process.  

Undoing published changes 
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If you have accepted changes on your staging server, and decide you do not want them, you can 
rollback the changes. Even if you have published your site, and want to return to an earlier 
version of the site, you can easily revert to a previous version of the site. 

 

To undo accepted changes to a page 

1. Log in to PureCMS with an account that has access to the Site Manager. 

2. On the menu bar, choose View > Go to > Site Manager. 
3. Select the page with the changes you want to undo. 

4. On the menu bar, choose Tools > Version Control. The page opens in the Version 
Control window. 

5. Click Back or Next until you find the version of the page you want. 

6. Click Revert to change the page.  The version you choose will open in the Edit Region 
view. It becomes the active version on your Staging Server, and you can publish it to your 
Production Server. 

 

To undo a site publication 

1. Log in to PureCMS as Webmaster or another administrator. 

2. On the menu bar, choose Tools > Publish > View Backup History. 

3. Choose the publication task dated just before the publication you want to undo. 

4. Click Restore. A message appears asking if you are sure you want to restore the Staging 
Server to the selected version. 

5. Click Yes. Another message appears to tell the restore is in process. 

6. Click Ok.  The version you chose will be posted to your Staging Server, and you can 
publish it to your Production Server. 

7. Wait at least ten minutes before continuing. 

8. On the menu bar, choose Tools > Publish > Publish Web Site. 

9. In Archive Label type a name for the backup that will be saved during the publish 
process. 

10. In Comments, type any remarks or notes you want to save with the backup. 

11. Click Publish. A message appears telling you the publication will begin soon. 

12. Click Ok. The older version of your site will be published to your Production Server. 

Generating site statistics 

To generate visitor and hit statistics for your Web site with PureCMS, your Production Server 
must be using Microsoft Internet Information Server 5.x.    

You must first configure your Production Server to log site activity and generate the information in 
W3C Extended Log File Format with specific settings.  This topic discusses how to configure a 
Production Server with Microsoft Internet Information Server to generate the log.   

After configuring the Production Server, you need to configure PureCMS to save statistics for 
your Web site. 

Finally you can generate reports for the site and reports for specific Web pages. 

 

To configure Web logs on MS IIS 5.x 
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1. Log on to the Production Server. 

2. Right click the My Computer icon. 

3. Click Manage. 

4. Expand Service & Applications. 

5. Expand Internet Information Server. 
6. Right-click your production Web site. 

7. Click Properties. 

8. Click the Web Site tab. 

9. Choose Enable Logging. 

10. From the Active log format list, choose W3C Extended Log file Format. 
11. Click Properties. 

12. Click the General Properties tab. 

13. From the log rotation options you can choose only one of the following Hourly, Daily, 
Weekly, or Monthly.  

14. Clear the Use local time for file naming & rollover check box. 

15. Browse or type a path to the location where you want to save your logs in the Log file 
directory field. If you connect to the production server via FTP.  This directory must be 
available to your FTP user account.  

16. Click the Extended Properties tab. 

17. Select all of the following options, but no others: Date, Time, Client IP Address, URI 
stem, User Agent, and Referrer. 

18. Click OK. 

19. Click OK again. 

20. Close the Computer Management window. 

  

Now configure PureCMS to record site statistics. 

To save site statistics with PureCMS 

1. Log in to PureCMS as a Webmaster. 
2. On the menu bar, click Tools > Statistics > Statistics Options. 

3. Select the Enable Statistics check box. If you have not set up your publishing options, 
you will be prompted to set them up now. 

4. In Site Base URL, type in the full URL to the Production server, including the virtual 
directory. 

5. Type the path where you will save the logs in Log File's Directory. This will be the same 
location as the Log file directory you chose in step 15 if configuring IIS. 

6. In Time Zone, choose the correct time zone for your Production Server. 

7. In Log Format, choose W3C Extended Log file Format. 
8. In Log Time Period, choose Hourly, Daily, Weekly, or Monthly, making sure it is the 

same as the log rotation option you chose for the Production Server (step 13 for IIS). 

9. Click Ok. A message appears telling you the configuration has been saved. 

10. Click Ok again. 

 

To generate site activity reports 
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1. Log in to PureCMS as a Webmaster. 

2. On the menu bar, click Tools > Statistics > Enable Statistics. 

3. Under Select the operation to be performed, choose Enable Statistics. 

4. Under Select the pages to be configured, choose For entire site. 

5. Click Ok. A message appears stating that enabling or disabling statistics is in progress. 

6. Click Ok again. 

 

To generate page activity reports 

1. Log in to PureCMS as a Webmaster. 

2. On the menu bar, click Tools > Statistics > Enable Statistics. 

3. Under Select the operation to be performed, choose Enable Statistics. 

4. Select a page or pages from the left pane. Pages with statistics already enabled will 
appear in bold text. Click folders to see the pages within them.  

5. Under Select the pages to be configured, choose For the selected pages only.  

6. Click Ok. A message appears explaining the statistics for only the pages selected will 
show in PureCMS, but the log file will still collect statistics for the entire site. 

7. Click Ok again. 

 

Notes 

 Your statistics will be saved in the Log File directory you chose while configuring IIS.  

 The W3C format logs all times in GMT (Greenwich Mean Time) 

 Pages marked in bold text already have statistics enabled. 

 If you publish to your Production Server via FTP, that FTP User account must have access 
to the log folder. 

 

Viewing hit and other statistics for your site 

To see site statistics for the current day 

1. Log in to PureCMS. 

2. On the Start Page, click History so that the double arrow button points down . 

3. Scroll down past the recent changes list. 

4. Click the Web Site Traffic link or the Most Visited Pages link. 

5. On the menu bar, click View > Go to > Start Page to return to the Start Page.  

 

To see site statistics for a different day 

1. Log in to PureCMS. 

2. On the Start Page, click History so that the double arrow button points down . 

3. Scroll down past the recent changes list. 

4. Click the Web Site Traffic link or the Most Visited Pages link. 

5. Move the mouse cursor over Reports Selection Calendar. 
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6. Click a date on the calendar to see statistics for that day. 

7. On the menu bar, click View > Go to > Start Page to return to the Start Page.  

 

Related topics 

Generating site statistics 

Modifying or uploading files outside PureCMS 

Once you have installed PureCMS, it is strongly recommended that all your work on the Web site 
take place from within the PureCMS system to maintain valid backups and a valid change history 
for all your pages. 

 

If you do make changes outside PureCMS, keep the following issues in mind. 

1. You can copy files into the Staging Server's local path using an FTP client or Windows 
Explorer.  For example, if you installed PureCMS with the default site, then the staging server's 
local path may be: C:\ProgramFiles\GlobalSCAPE\PureCMS\SampleSite\ 

 

2. If you copy files into the Staging Server's local path from outside PureCMS, the files will have 
no version/compare history, they will not have statistics enabled, they will not have Direct Edit 
enabled, and they will be part of Everybody group by default.  Once you edit an added file for the 
first time, that will begin its version/compare history. 

 

3. When a file is uploaded through PureCMS, that creates the first history entry, which will show 
 Edited content. You can then open and save the file in the PureCMS Editor to register the 
uploaded page as the original version of the page. 

 

4. If you delete or rename a file outside of PureCMS, then the file loses all ties to its group 
ownership, statistics are no longer enabled or counted, Direct Edit is disabled for the file, and you 
won't be able to access the version history.  If a folder is renamed or deleted outside PureCMS, 
then all of the files within that folder will be affected in the same way. 

 

5. If a file (or folder) is deleted or renamed outside of PureCMS, and a new file with the same 
name as the old file is uploaded through PureCMS or copied to the same path outside of 
PureCMS, the new file (though its contents differ) will inherit the attributes of the 
removed/renamed file. 

 

Though you can change or move your Web files from outside PureCMS, it s most advisable to 
make changes to the files from within PureCMS whenever possible. 

Building an index for library items or templates 

You can speed up the process of updating template-based pages and pages with library items by 
creating indexes of those pages. 

To build an index for a library item 

1. Log in to PureCMS with a webmaster account. 
2. On the menu bar, choose Tools > Update Pages > Library Item Changed. 

3. Highlight the library item in the Select a Library Item list.  



PureCMS 3 User's Guide 

72 

4. Select the Index All Web Pages check box. 

5. Click Ok. A message appears saying Updating library items in web page is in 
progress. 

6. Click Ok again. 

 

To build an index for a template 

1. Log in to PureCMS with a webmaster account. 

2. On the menu bar, choose Tools > Update Pages > Template Changed. 

3. Highlight the template in the Select a Template list.  

4. Select the Index All Web Pages check box. 

5. Click Ok. A message appears saying Updating templates in web page is in progress. 

6. Click Ok again. 

 

Note 

Every time you create a new page based on a template or create a new page with a library 
item, you should rebuild your indexes. 

 

Related topics 

Updating several pages at once 

Viewing the status of background processes 

Several PureCMS tasks will run in the background after you start them, including publishing, 
indexing templates, indexing library items, updating templates, updating library items, and 
gathering statistics from the Web server. You can see the processes that are running in the 
background. 

 

To see which process is currently running in the background 

1. Log in to PureCMS as a Webmaster or other administrator. 

2. On the menu bar, choose Tools > Admin Options > Status of Background 
Processes. A small window appears with details about the current background process. 

 

Note 

 You will not see a background process immediately, there is a delay of a few minutes 
before processes display or change in the Background Process window. 

 If you have started several background processes, they will run one at a time. If you 
choose to open the Background Process window, when one process ends, the next will 
appear in the window. 

Adding commands to the menu 

You can add commands to the menu that will run scripts or services on the Staging server. 

 

To add a command to the menu 

1. Login to PureCMS as a Webmaster or other administrator. 
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2. On the menu bar, choose Tools > Admin Options > Manage Custom Commands. The 
Custom Commands Manager window opens. 

3. Click Add.  

4. Type a name for the command. This will be the name that appears on the menu.  

5. In Command, type the actual command, just as you would enter in the Windows Run 
box. 

6. In Parameters, type any parameters for the command. This would be anything you would 
type after  the command and a space in the Windows Run box.  

7. Click Save. The new command appears in the Commands box. 

8. If you want to add more commands, repeat steps three through seven. 

9. When you have entered all your commands, click Ok. A message appears telling you the 
custom commands have been updated. 

10. Click Ok again. 

 

Notes 

 In the Name box you can type up to 50 characters, but the menu has space for only twenty 
or thirty characters. 

 The combined text you type into the Command and Parameters boxes can be no more 
than 255 characters long. 

 You cannot create commands that open any GUI interface. 

 Every user on your site will have access to every custom command you add.  

 The custom commands appear in PureCMS  on the menu bar at Tools > Custom 
Commands.  

 

Related topic 

Changing custom commands 

Changing custom commands 

To edit a custom command 

1. Login to PureCMS as a Webmaster or other administrator. 

2. On the menu bar, choose Tools > Admin Options > Manage Custom Commands. The 
Custom Commands Manager opens. 

3. In the Commands box, select the command you want to change. 

4. Click Edit.  
5. Make any changes in Name, Command or Parameters.  

6. Click Save. 

7. If you want to change more commands, repeat steps three through six. 
8. When you have made all your changes, click Ok. A message appears telling you the 

custom commands have been updated. 

9. Click Ok again. 

 

Notes 

 In the Name box you can type up to 50 characters, but the menu has space for only twenty 
or thirty characters. 

 The combined text you type into the Command and Parameters boxes can be no more 
than 255 characters long. 
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 You cannot create commands that open any GUI interface. 

 

To remove a custom command 

1. Login to PureCMS as a Webmaster or other administrator. 

2. On the menu bar, choose Tools > Admin Options > Manage Custom Commands. The 
Custom Commands Manager opens. 

3. In the Commands box, select the command you want to remove. 

4. Click Delete. A message appears asking if you are sure you want to delete the 
command. 

5. Click Yes. 

6. Click Ok to close the Custom Commands Manager. A message appears telling you the 
custom commands have been updated. 

7. Click Ok again. 

 

 

Related topic 

Adding custom commands 

Managing Multiple Sites 

Log in as Server Administrator 

To log in for the first time as Server Administrator 

1. Open PureCMS. 

2. In Username, type PureAdmin. 

3. In Password, type the administrator password you chose during installation. 

4. Click Log in. PureCMS opens to the Server Administration/Web Sites window, where 
you can change the user name and password for the Server Administrator. 

Adding a new site 

To add a new site 

1. Obtain a license for the additional site. 

2. Login as the Server Administrator. 

3. If you cannot see Add a Site, click Server Administration. 

4. In the Add a New Site to Staging Server box, click Add. A Windows Enter Network 
Password window appears. 

5. In User Name, type in the user name for an account that has administrator rights on the 
Staging Server. 

6. In Password, type the password for the same account that has administrator rights on 
the Staging Server. 

7. In Domain, type the Staging Server's domain only if it is on a different domain from the 
one where you are working. 

8. Click OK. The Add a Web Site window opens. 

9. In Web Site URL, type the complete Web address of the new site, using the IP address, 
rather than a domain name. For example type http://127.0.0.1/MySite. 
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10. In Web Site Home Folder, type the site's physical path on the server.  

Warning: If your site already exists in IIS make sure you type in the correct existing physical path 
for the site. 

11. In Serial No, type the number you obtained from GlobalSCAPE. 

12. Clear the Create New Site Webmaster check box. A Select Site Webmaster list 
appears. 

13. In the Select Site Webmaster list, select the user you want as the site's Webmaster. 

14. Click Ok. After a few moments a message appears telling you a web site has been 
created. 

15. Click Ok again. 

 

To add a new site with a new Webmaster 

1. Obtain a license for the additional site. 

2. Login as the Server Administrator. 

3. If you cannot see Add a Site, click Server Administration. 

4. In the Add a Site box, click Add.  A Windows Enter Network Password window 
appears. 

5. In User Name, type in the user name for an account that has administrator rights on the 
Staging Server. 

6. In Password, type the password for the same account that has administrator rights on 
the Staging Server. 

7. In Domain, type the Staging Server's domain, only if it is on a different domain from the 
one where you are working. 

8. Click OK. The Add a Web Site window opens. 

9. In Web Site URL, type the complete Web address of the new site, using the IP address, 
rather than a domain name. For example type http://127.0.0.1/MySite. 

10. In Web Site Home Folder, type the new site's physical path on the server. 

Warning: If your site already exists in IIS make sure you type in the correct existing physical path 
for the site. 

11. In Serial No, type the number you obtained from GlobalSCAPE. 

12. Leave the Create New Site Webmaster check box selected. 

13. In the Web Master User Name, type a name for the new site's administration account. 

14. In User E-mail, type the email address where the new Webmaster should receive 
notifications. 

15. Type the same password in Password and Confirm Password. This will be the new 
Webmaster's password for logging in to the new site. 

16. Click Ok. After a few moments a message appears telling you a web site has been 
created. 

17. Click Ok again. 

 

Notes 

If you login to a remote machine with a Windows account that has Administrator permissions for 
the Staging Server, you can leave all the fields blank and click OK when the Windows Enter 
Network Password window appears. 

Changing the Server Administrator user name 
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To change the Server Administrator's user name 

1. Login as the Server Administrator. 

2. If you cannot see Modify the Server Administrator Account, click Server 
Administration. 

3. Under Modify the Server Administrator Account, click Modify. The Modify the Server 
Administrator Account window opens. 

4. In Username, type a new user name. 

5. Click Ok. A message appears telling you the change to the account was successful. 

6. Click Ok again. 

 

Note 

PureCMS user names are not case sensitive. 

Changing the Server Administrator's email address 

To change the Server Administrator's email address 

1. Login as the Server Administrator. 

2. If you cannot see Modify the Server Administrator Account, click Server 
Administration. 

3. Under Modify the Server Administrator Account, click Modify. The Modify Server 
Administrator Account window opens. 

4. In User E-mail, type the new address. 

5. Click Ok. A message appears telling you the change to the account was successful. 

6. Click Ok again. 

Changing the Server Administrator's password 

To change the Server Administrator's password 

1. Login as the Server Administrator. 
2. If you cannot see Modify the Server Administrator Account, click Server 

Administration. 

3. Under Modify the Server Administrator Account, click Modify. The Modify Server 
Administrator Account window opens. 

4. In Password, type the new password. 

5. In Confirm Password, type the new password again exactly the same as before. 

6. Click Ok. A message appears telling you the change to the account was successful. 

7. Click Ok again. 

 

Note 

All passwords in PureCMS are case sensitive. 

Changing the PureCMS IP address 
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There are two suggested methods for changing the IP address for a PureCMS staging server. 
The first requires that you change the IP address in PureCMS, before it changes on your server, 
but you may see a "Page Not Found" error in the process.   

With the second method, you can avoid seeing the error, but you will need to make some 
changes in IIS, before and after changing the IP address in PureCMS. 

To change the IP address in PureCMS first 

1. Login as the Server Administrator. 

2. If you do not see Modify PureCMS IP Address, click Server Administration. 

3. Under Modify PureCMS IP Address, click Modify. The Modify PureCMS IP Address 
window opens. 

4. In New IP Address for PureCMS, type the address you want for the site. 

5. Click Ok. A message appears telling you the change was successful and will begin 
shortly. 

6. Click Ok again. 

7. Click Log Out. If you try to log in before changing the IP address on the server you may 
see a  page not found error. 

8. Change the IP address on the server. 

 

To change the IP address on the server first 

1. Log on to the Staging server. 

2. On the My Computer icon, right-click and choose Manage. The Computer Management 
window appears.  

3. Expand Services and Applications. 

4. Expand Internet Information Services. 

5. Select the PureCMS Web site. 

6. On the menu bar, choose Action > Properties. The web site's Properties window 
appears. 

7. Click the Web Site tab. 

8. In IP address list, select (All Unassigned). 
9. Click OK. 

10. Open PureCMS.  

11. Login as the Server Administrator. 

12. If you cannot see Update PureCMS IP Address, click Server Administrator. 
13. Under Modify PureCMS IP Address, click Modify. The Modify PureCMS IP Address 

window opens. 

14. In New IP Address for PureCMS, type the address you want for the site. 

15. Click Ok. A message appears telling you the change was successful and will begin 
shortly. 

16. Click Ok again. Check to make sure the process is complete, it may take a long time. 

17. Close PureCMS. 

18. In the Computer Management window, open the PureCMS Web site Properties window 
again. 

19. Click the Web Site tab. 

20. In IP address list, select the IP address you chose in PureCMS. 

21. Click OK. 
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22. Close the Computer Management window. 

 

 

 

Choosing file types displayed in the Site Manager 

As Site Administrator, you can define what file types appear in the Site Manager, and you can 
define if the Site Manager recognizes them as text, Web pages, scripts, images, default pages, or 
link target files. 

 

To include or exclude specific files from showing in the Site Manager 

1. Login as the Server Administrator. 

2. If you cannot see Modify the Supported File Types, click Server Administration. 

3. In the Modify the Supported File Types box, click Modify. A file type list opens in the 
PureCMS Editor.  

4. Add any extensions for file types you need, making sure to follow the format from the 
existing entries. 

5. Delete any extensions for files that you do not want to appear in the Site Manager. 

6. On the menu bar, choose File > Save. A message appears telling you the changes were 
successful. 

7. Click Ok. 

 

Note 

If you have more than one site, any changes you make to the file type list will affect every site. 

Changing PureCMS email messages 

To edit the text of PureCMS email messages 

1. Login as the Server Administrator. 

2. If you cannot see Edit System Notification Messages, click Server Administration. 

3. Under Edit System Notification Messages, click Edit. The Edit Email window opens. 

4. In the Select Email Template list, select the message type you want to change. 

5. Click Ok. The PureCMS Editor opens with the standard message. 

6. Make changes to any text in blue. 
7. On the menu bar, choose File > Save. A message appears telling you the change to the 

message was successful. 

8. Click Ok. 

 

Notes 

 You cannot change the text in gray. Gray text represents information that PureCMS will 
add to the message automatically.  

 If you have more than one site, the changes you make to email notifications will affect 
every site. 

Changing the PureCMS mail server 



Administering PureCMS 

79 

To change the server PureCMS uses to send email messages 

1. Login as the Server Administrator. 

2. If you cannot see Modify the SMTP Server, click Server Administration. 

3. Under Modify the SMTP Server, click Modify. The Modify the SMTP Server window 
opens. 

4. In SMTP Server, type the IP address or the host name of the new mail server. 

5. Click Ok. A message appears telling you the change was successful. 

6. Click Ok again. 

 

Note 

If you have several sites, the server you choose will be the mail server for every site. 

Log in to a site as server administrator 

To login to a specific site with the server administrator account 

1. Login to PureCMS as the server administrator. 

2. If you cannot see Site URL, click Web Sites. 

3. Under Site URL, choose the site where you want to log in. 

4. Under Log In to Selected Site, click Log In. The Start Page of the selected site will 
open. 

Allowing users to log in to more than one site 

If you have multiple sites and multiple URL's you can restrict users to one site, or allow them to 
login to several sites. 

 

To allow a user to log in to a second site 

1. Login to PureCMS as the Server Administrator. 

2. If you do not see Site URL, click Web Sites. 

3. Under Site URL, choose the site you want as an additional site where an existing user 
can log in. 

4. In the Add Existing Users to Selected Site box, click the Add button. The Add 
Existing User window appears. 

5. In the Select User list, choose the user you want to allow to log in to the site. 

6. Choose the default and other groups for the user, and choose the appropriate 
permissions. 

7. Click Ok. The Add Existing User window disappears and the number of users listed for 
the site increases by one. 

8. Repeat steps three through seven to allow more users to access another site.  

Deleting a site 

To remove a site from PureCMS 

1. Login to PureCMS as the server administrator. 

2. If you cannot see Site URL, click Web Sites. 

3. Under Site URL, choose the site you want to delete. 
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4. Under Delete Selected Site from Staging Server, click Delete. A message appears 
asking if you are sure you want to delete the site. 

5. Click Yes. Another message appears telling you the site has been deleted. 
6. Click Ok.  

 

Note 

 When you delete a site, any users exclusive to that site will be deleted as well. 

 Deleting the site only deletes the site from PureCMS, all the html, image and other files for 
the site will still exist in their physical location. 

Registering PureCMS 

Registration takes place when you install PureCMS, whether you have a trial serial number or a 
purchased serial number.  If you install with a trial serial number, you will have to change the 
license for your site when you purchase the software. 

 

To change from a trial license to a purchased license 

1. Make sure your Internet connection is active. 

2. Login as the Server Administrator. 

3. If you cannot see Site URL, click Web Sites. 

4. Under Site URL, choose the site you want to change. 

5. Under Modify the Serial Number of Selected Site, click Modify. The Modify Serial 
Number window opens. 

6. In Serial No, type the serial number you received when you purchased a full license. 

7. Click Ok. A message appears telling you registration was successful. 

8. Click Ok again. 

Changing a site's webmaster 

To choose a new webmaster from existing users 

1. Login as the Server Administrator. 

2. If you cannot see Site URL, click Web Sites. 

3. Under Site URL, choose the site you want to change. 

4. In Modify Webmaster of Selected Site, click Modify. The Modify Webmaster window 
appears. 

5. Clear the Create New Site Webmaster check box. The Select Site Webmaster list 
appears. 

6. In the Select Site Webmaster list, select the user you want as the new site's 
administrator. 

7. Click Ok. A message appears telling you the change has been successful. If the old 
Webmaster account is not listed as a user or Webmaster of another site the message will 
also warn you that the old Webmaster account will be completely deleted. 

8. Click Ok again. 

 

To create a new webmaster for a site 
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1. Login as the Server Administrator. 

2. If you cannot see Site URL, click Web Sites. 

3. Under Site URL, choose the site you want to change. 

4. In Modify Webmaster of Selected Site, click Update. The Modify Webmaster window 
appears. 

5. Select the Create New Site Webmaster check box. 

6. In the Webmaster User Name, type a name for the new site's administration account. 

7. In User E-mail, type the email address where the new Webmaster should receive 
notifications. 

8. Type the same password in Password and Confirm Password. This will be the new 
Webmaster's password for logging in to the new site. 

9. Click Ok. A message appears saying the change has been successful. If the old 
Webmaster account is not listed as a user or Webmaster of another site the message will 
also warn you that the old Webmaster account will be completely deleted. 

10. Click Ok again. 

 

To avoid deleting an old Webmaster account 

Before you change from an old Webmaster to a new one, use the Add Existing Users to 
Selected Site tool to assign the old Webmaster to another site, then change Webmasters, and 
then you can add back the old Webmaster as a user without having to recreate the entire 
account. 

Changing a site's IP address 

1. Login as the Server Administrator. Make sure all other users are logged out before 
making the change. 

2. If you cannot see Site URL, click Web Sites. 

3. Under Site URL, choose the site you want to change. 

4. In Modify the IP Address of Selected Site, click Modify. The Modify the IP Address 
of Selected Site window appears. 

5. In New IP Address check box. Type the new IP address for the site.  

6. Click Ok. A message appears telling you that the IP address is being updated. This may 
take several minutes.  

 

Note 

Do not let users log in to the site until PureCMS finishes updating the IP address. 

 

Viewing the status of background processes 

Several PureCMS tasks will run in the background after you start them, including publishing, 
indexing templates, indexing library items, updating templates, updating library items, and 
gathering statistics from the Web server. You can see the processes that are running in the 
background. 

 

To see which process is currently running in the background 

1. Log in to PureCMS as a Webmaster or other administrator. 
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2. On the menu bar, choose Tools > Admin Options > Status of Background 
Processes. A small window appears with details about the current background process. 

 

Note 

 You will not see a background process immediately, there is a delay of a few minutes 
before processes display or change in the Background Process window. 

 If you have started several background processes, they will run one at a time. If you 
choose to open the Background Process window, when one process ends, the next will 
appear in the window. 

Managing Workflows 

Add workflow levels to a group 

1. Log in to PureCMS with your administrator account. 

2. On the menu bar, click Tools > Admin Options > Manage Groups. The Manage 
Groups window opens.  At the bottom of this window is the Workflow Manager. 

3. In Select Group, choose the group you want to add a workflow hierarchy 

4. Click the Add Workflow button.  This will open the Create Activity Window. 

5. In Activity Name, type a name for the activity.  For example: Mrktg Director 

The length of the Activity Name field is 16 characters.  The Descriptions field 
allows you to add notes describing the activity name in greater detail. 

6. Select the approvers from the Approvers list.  Hold down the Ctrl key to select more 
than one approver from this list. 

7. Click OK. 

8. The newly created workflow level will now be added to the Workflow list appearing under 
Workflow along with the list of approvers in that level. 

Delete a workflow level 

1. Log in to PureCMS with your Webmaster or another administrator account. 
2. On the menu bar, click Tools > Admin Options > Manage Groups. The Manage 

Groups window opens.  At the bottom of this window is the Workflow Manager. 

3. In Select Group, choose the group you want to add a workflow hierarchy 

4. Select the Workflow level from the list under Workflow.   Click the Delete button.   

5. A Workflow Activity Dialog box will pop up.  Clicking Yes will remove the selected level 
from the Workflow list.  Clicking No will cancel any changes. 

Create a multi-level workflow for a group 

You may want to have more than one individual approve or reviews changes made to a web page 
content.  PureCMS allows you to create multi-level approval “workflow pipelines”.  Designated 
members in the workflow have the ability to review changes, make corrections or comments, and 
then pass the files to the next level in the workflow pipeline.  

Each approval level can have one or more users in that group who are able to approve or deny 
the changes made by a lower level. 
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Groups members have either FULL or PARTIAL access.   FULL access will mean that the user 
can self-approve, which means that the user can bypass the entire workflow for that group.  
Partial access means that any content changes will enter the workflow pipeline.   

Higher-ranking levels may always approve changes made by any lower level.  However, any 
given level can send approved files up the pipeline only to the next higher level.  Files do not 
move to the staging server for publication until they are approved by the workflow’s highest level. 

To Create a Multi-Level Workflow for a Group: 

1. Log in to PureCMS with your Webmaster or another administrator account. 

2. On the menu bar, click Tools > Admin Options > Manage Groups. The Manage 
Groups window opens.  At the bottom of this window is the Workflow Manager. 

3. In Select Group, choose the group you want to add a workflow hierarchy 

4. Click the Add Workflow button.  This will open the Create Activity Window. 

5. In Activity Name, type a name for the activity.  For example: Mrktg Director 

The length of the Activity Name field is 16 characters.  The Descriptions field 
allows you to add notes describing the activity name in greater detail. 

6. Select the approvers from the Approvers list.  Hold down the Ctrl key to select more 
than one approver from this list. 

7. Click OK.  The newly created workflow level will now appear under Workflow along with 
the list of approvers in that level. 

Modify a workflow level 

1. Log in to PureCMS with your Webmaster or another administrator account. 

2. On the menu bar, click Tools > Admin Options > Manage Groups. The Manage 
Groups window opens.  At the bottom of this window is the Workflow Manager. 

3. In Select Group, choose the group you want to add a workflow hierarchy 

4. Select the Workflow level from the list under Workflow.   Click the Modify button.  This 
will open the Modify Activity window.  You may modify the name, description or 
members of the workflow level. 

 To add approvers from the Approvers list.  Hold down the Ctrl key to select 
more than one approver from this list.  

 To remove approvers from the Approvers list,  Hold down the Ctrl key and 
deselect the approvers by clicking on their name 

5. Click OK.  The modifications to the workflow level will now be displayed on the Workflow 
list appearing under Workflow. 

Change the approval order of a workflow 

1. Log in to PureCMS with your Webmaster or another administrator account. 
2. On the menu bar, click Tools > Admin Options > Manage Groups.  The Manage 

Groups window opens.  At the bottom of this window is the Workflow Manager. 
3. In the Select Group drop down, choose the group you want to change the order of the 

workflow hierarchy. 

4. Select the workflow level from the list under Workflow.  Click either the Up or Down 
button change approval order buttons.  This will move the selected group of approvers 

either up or down in your workflow structure.  Important: The highest approver in 
workflow hierarchy is located at the bottom of the workflow list. 
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Working with Breadcrumbs 

About breadcrumbs 

Breadcrumbs on Websites are form of navigation where the current location within the Website is 
indicated by a list of pages above this page up to the main page.  The term "breadcrumbs" is a 
reference to the Hansel and Gretel tale where they leave breadcrumbs as they wander the forest 
so they can find their way home. The metaphor is imperfect because the breadcrumbs do not 
represent the actual path the user took, but instead the optimal path from the home page to the 
current page.  If you were browsing the products at a department store Website, you might see 
the following hierarchy when you're on the Shoes page: 

 

Home > Products > Clothes > Shoes 

 

There are four tasks that must be performed before your site will display breadcrumbs generated 
by PureCMS: 

 

1. Create your navigation using the breadcrumb navigation tool. 

2. Associate your pages to the breadcrumb navigation. 

3. Define the location of the breadcrumbs on your pages. 

4. Turn breadcrumbs on. 

Create your navigation using the breadcrumb navigation tool 

Open the breadcrumb navigation tool 

 
1. Log in to PureCMS with your administrator account. 

2. Access the breadcrumb navigation tool by opening any page in the Site Manager and 
then selecting Page > Page Properties > Add Category button. 

 
 
Add your first category 

1. Enter the name of your first category in the Breadcrumb Category box. This is typically 
a top level navigation page such as "Products" or "Company". 

2. Enter a text you want to display in the breadcrumbs on your Web pages in the 
Breadcrumb Description box. 

 

 
Add additional breadcrumb categories 
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1. Once you enter your first breadcrumb category subsequent categories will have a 
checkbox next to them.  

2. Select the breadcrumb category that you want your new breadcrumb category to be a 
subcategory or don't select any breadcrumb categories if you want the new breadcrumb 
category to be a top level category. 

3. When finished, click Add and then Ok. 

 

 

Notes 

 You can return and add categories at any time. 

 The breadcrumbs generated by the example above are: 

 

Home > Company 

and 

Home > Products > Furniture > Bedroom 

Associate your pages to the breadcrumb navigation. 
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1. Log in to PureCMS with your administrator account and open the Site Manager. 

2. Open the page you want to add breadcrumbs to. 

3. Select Page > Page Properties. 
4. Select the breadcrumb category from the Breadcrumb Category drop down box that you 

want to associate the page to. If you are working with a page that needs a new category 
you can click Add Category to create a new breadcrumb category. 

Place a Javascript on your pages to define the location of the 
breadcrumbs 

You need to tell PureCMS where to place the breadcrumbs on the page by placing a Javascript in 
the desired location. 

 

Add breadcrumbs to your HTML 
Place the following Javascript in your HTML where you want the breadcrumbs to appear: 

 

<!-- PureCMS_Breadcrumb --> 

<script language='javascript'> 

document.write('<'+'scr' + 'ipt 
src='+purecms_breadcrumb_src_path+'><'+purecms_tmp+'script'+'>'); 

</script> 

<!-- /PureCMS_Breadcrumb --> 

 

 

Use breadcrumbs to generate top level navigation 
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The example above creates two sets of navigation, Breadcrumbs and Site Navigation. 
Breadcrumbs are a hierarchy of pages. In this example they are: 

 

Home > Products > Furniture > Bedroom 

and 

Home > Company 

 

Site Navigation is the top level of the breadcrumbs: 

 

Home 

Products 

Company 

 

You can use Site Navigation in your Web site by placing the following Javascript in your HTML: 

 

<!-- PureCMS_Navigation -->  
<script language='javascript'> 
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document.write('<'+'scr' + 'ipt 
src='+purecms_navigation_src_path+'><'+purecms_tmp+'script'+'>'); 

</script> 

<!-- /PureCMS_Navigation --> 

 

Turn breadcrumbs on 

To Enable / Disable Breadcrumbs 

1. Log in to PureCMS with your Webmaster or another administrator account. 

2. On the menu bar, click Tools > Admin Options > Site Options.  The Site Options 
window opens.  At the bottom of this window is the Generate Breadcrumbs check box.   

3. Breadcrumbs are enabled or disabled on the basis of the Generate Breadcrumbs check 
box being checked or empty. 

4. Click the Update to update your choices. 

Change the appearance of breadcrumbs 

 

Modify the breadcrumb stylesheet 
The breadcrumb stylesheet is named purecms_style.css and located in the root directory of the 
PureCMS staging server. 

 

Change the top level site navigation to a horizontal or vertical layout 
1. Log in to PureCMS with your administrator account. 

2. On the menu bar, click Tools > Admin Options > Site Options.  The Site Options 
window opens.  At the bottom of this window is the Breadcrumb Separator box. 

3. Type the desired breadcrumb separator in the Breadcrumb Separator box.  For 
example: >, ::, / or |.   You may choose any character(s), symbol(s) or number(s) 
available on your keyboard to become your breadcrumb separator. 

4. Click the Update to update your choices 

 

Choose the breadcrumb separator 
1. Log in to PureCMS with your administrator account. 

2. On the menu bar, click Tools > Admin Options > Site Options.  The Site Options 
window opens.  At the bottom of this window is the Breadcrumb Separator box. 

3. Type the desired breadcrumb separator in the Breadcrumb Separator box.  For 
example: >, ::, / or |.   You may choose any character(s), symbol(s) or number(s) 
available on your keyboard to become your breadcrumb separator. 

4. Click the Update to update your choices 
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