Copying, Importing and Reusing Task Steps

There are several different ways to copy or reuse steps from existing tasks. In Task Builder, use Copy and Paste to copy task steps within a task or from one task to another. The Copy function copies the.AML code associated to the step(s), which can then be pasted into any task or into documents outside of AWE such as Notepad. To reuse all steps of a task, use the Save As to save a copy of the task under a new name, or you can import all of the steps of one task into another.

To copy and paste task steps:

  1. In the Steps pane, click the tab for the task that has the steps to be copied.

  2. Select the steps you want to copy. To select a group of steps, hold down the SHIFT key and click the first and the last step in the group. To select multiple separate steps, hold down CTRL while you click the desired steps. To select all steps, press CTRL+A or click Select All from the Edit menu.

  3. Click Copy .

  4. In the Steps pane, click the tab for the task in which you want to place the steps.

  5. Select the step where you want to place the copied steps, and click Paste .

    The selected step is moved down and the copied steps are pasted above it.

Note: You can also paste copied steps or step descriptions in other documents such as e-mail messages or text files.

To copy and paste step descriptions:

  1. In the Steps pane, select the step(s) in which to copy the description from. To select more than one step, press CTRL during selection.

  2. On the Edit menu, click Copy Description.

  3. Go to the location where you want to place the copied descriptions, and press CTRL+V or select Paste from the right-click menu.

To save a copy of a task:

  1. Open the task you would like to save a copy of.

  2. On the File menu, click Save As.

  3. Navigate to the desired location, enter a name for the new task, and click Save.

To import all steps of a task:

  1. Open the desired task.

  2. On the Edit menu, click Import Steps.

  3. Navigate to the task (.aml file) that has the steps you want to import, and click Open. (By default tasks are stored under Documents and Settings\All Users\Shared Documents\My AWE tasks; On Windows 2008, Application Data files for all users are in a hidden folder named %systemroot%\ProgramData instead of under Documents and Settings\All Users\Application Data.)

    All the steps of the task are imported into the end of your open task.

NOTE: You can change the placement of any step by selecting it and clicking Move Up or Move Down on the toolbar.

See Also

About Actions

Adding Task Steps

Editing Task Steps